Version change summaries

 

 

 

VERSION Equinox 1.10a (May 24, 2007)

 

VERSION Equinox 1.10 (May 18, 2007)

 

VERSION Equinox 1.05 (January 17, 2007)

VERSION Equinox 1.04 (January 7, 2007)

VERSION Equinox 1.03 (January 6, 2007)

VERSION Equinox 1.02 (January 2, 2007)

 

VERSION Equinox 1.01 (January 2, 2007)

VERSION Equinox 1.00 (January 1, 2007)

 

 Fusion (beta)

Fusion 0.6h 11-Nov-06



Fusion 0.6e3 05-Jul-06



Fusion 0.6e2 04-Jul-06

Fusion 0.6e1 03-Jul-06

 

 Workstation

VERSION V1.0b (March 24 2004)

Adds support for RVRT, AVRT, DVRG script commands. Fixed internal handling of fields to provide more uniform use of u,v,z format and prevent any surprise problems.

Fixed gust problem in METAR import routine.

Fixed Recompile Tables to remove something that was commented out, preventing digatmos.stn from being imported.

Updated this help file accordingly.

 

VERSION WORKSTATION (Dec 2003 - March 2004)

***** Hundreds of changes were made which are too numerous to list. *****

 

VERSION WORKSTATION 0.32alpha (15 Nov 2003)

Algorithm added to read the server directory when a front bulletin is being imported. If a server directory structure is accessed on the same path as the file desired, the time tokens are discarded and the last file in the directory list is queued for download. [This is a significant development in the Digital Atmosphere line that allows DA to consistently obtain the latest frontal bulletin from a standard server that allows directory listings. It has been a much-needed capability. Digital Atmosphere depends on a consistent appearance of a directory listing, and this algorithm may not work if a server begins listing four-digit years in the directory listing, goes to a strange directory format, or the last file on the page is not the latest frontal bulletin. If this occurs please contact me with details.]

The weather symbol fonts have been thoroughly reworked. Fonts have been scaled down in relative size and left/right bounds have been repaired on a few symbols. Fonts now include pressure tendency and cloud code symbols. This allows integration of full station plot data. In summary, ASCII slots 040-049 contain augmented sky cover symbols; 050-059 contain automated sky cover symbols; 060-068 contain pressure tendency; 069 the symbol for automated observation with no sky cover report; 071-079 contain low clouds; 081-089 contain middle clouds; and 091-099 contain high clouds; and 100-199 contain standard WMO weather symbols. IF YOU INSTALL THE PATCH AND ARE STILL MISSING CLOUD AND PRESSURE TENDENCY SYMBOLS, PLEASE DELETE THE "WeatherSymbols" FONT FROM YOUR CONTROL PANEL > FONTS AND REINSTALL THE PATCH -- AND NOTIFY ME OF THE PROBLEM. [The new fonts allows further improvements to plotting functionality in the Alpha version.]

Digital Atmosphere plotting module has been revised to handle the new fonts and to add pressure tendency, pressure trend, and cloud symbols back into the plots. [This further enhances functionality in the Alpha version.]

A checkbox for Suspend Highs/Lows has been added to the "Fronts" Toolbar Control Panel as well as to Preferences > Analysis (which cannot be saved as a preference since it is for temporary use only. [Allows user to defeat plotting of High/Low labels on the map on demand, for example, when plotting the NCEP Fronts bulletin together with a METAR isobar analysis -- this prevents a duplicate field of H and L symbols from appearing on the map]

A bug has been removed where a sky cover = 10 (automated with no sky cover result) created no station marking (in the classic DA a crosshair was plotted). This uses the new font symbol of a small circle with crosshair (ASCII 69). [Fixes station plots in the Alpha version where a station is not marked by any station circle or square.]

Created a separate, independent download algorithm (not tied to the main download system) to allow internal downloads to a site (such as of a directory listing) without creating a programming mess. [May fix problems with erratic download behavior (including missing datasets) when trying to download NEXRAD radar data.]

Hourglass has been added during Map > Generate operations. [Helps give user feedback as to when the system is busy.]

Spacing of elements in a station plot has been expanded by 10%. [Allows station plot to be slightly less cluttered and maximizes ability to display weather symbols.]

Bug was removed where a weather condition of 1 to 4 resulted in no weather symbol but left a blank area in the WX symbol area (pressing out the visibility value when set to "smart" and causing a value to be shown). 1 to 4 are now treated as no weather value. [Invisible "hijacking" of the weather symbol slot is now prevented.]

Adds the missing USMAP.BMP file required for the Radar > Internet Radar Settings to show its information. [Fixes a bug in the Alpha release where going to Radar > Internet Radar Settings shows sites but no background map.]

A correction was made to the front import module to fix an infinite loop during processing of frontal data. Also adds code to prevent writing of spurious frontal data. [Fixes lockups during data import. Fixes range check errors during data import. Fixes stray segments on frontal depictions.]

VERSION WORKSTATION 0.31alpha (15 Oct 2003)

This version entails a vast retooling of the GRIB module. It allows much faster, convenient access to GRIB datasets. As usual, GRIB data is imported through the File > Import GRIB module. From there, the changes are significant. First, a GRIB field must be chosen on the Grib Control panel (on the toolbox) -- see below for more info. All of the packaged fields are stripped out into individual field files (GRID.001...GRID.999 in the /grids subdirectory), with an index provided in /grids/grid.idx and /grids/grid.dat. From there they may be accessed and viewed at any time. Since they are plaintext, users may adapt these field files for other purposes. To summarize, here are the latest changes in this update:

The GRIB module has been thoroughly reworked to spool gridded data directly out to files in \grids subdirectory. This allows the data to be instantly selected and plotted, without the need for re-import. Importing more GRIB data replaces the gridded data selections with new data.

GRIB data is stripped out into

Wind direction fields are now automatically separated into their own special fields, providing that the correct U/V components can be located.

Scheme of DIGATMOS.GRD modified so that >PARAM parameters can be resolved to Digital Atmosphere contour Styles.

Added control panel for GRIB on Toolbox > Control. Allows selection of gridded data that has been previously converted through File > Import GRIB. By checking either "Plot" or "Contour", the field will be displayed immediately when selected. Otherwise it can be viewed after being selected using Plot > Custom data or Contour > Custom Data.

SPECIAL NOTE -- CONTOUR INTERVALS FOR ANALYSIS FIELDS, especially with GRIB data, need to be checked and are not complete!!! I have to resolve all of the measurement units between the GRIB data, the internal formats, and the Styles.

SPECIAL NOTE -- Custom Data Plots and Contours no longer work except when GRIB data is selected. This will be fixed.

VERSION WORKSTATION 0.3alpha (12 Oct 2003)

Numerous improvements were made to the GRIB module (File > Import GRIB). It appears to be working now with the NCEP AWIPS Eta grid and globalmarinenet GRIB files. A bug was fixed in which bitmap data (particularly for marine grids) was ignored, resulting in bad plots. Fixed a corruption of wind output in which components rather than polar vectors were written to the custom data file, resulting in bad GRIB wind plots. Help documentation has been updated. The author would like inputs on how the GRIB module is working.

Fixed Contour > Custom Data so that it works with GRIB and other data. This will be worked on so that it uses parameter intervals defined in user settings.

Removed crowding algorithm from Data > Custom Data. GRIB wind plots now contain the entire grid (and may be illegible if the grid is dense enough). This will be replaced with a more flexible user-defined method.

Got some rudimentary isopleth labels working in the Contour module. This will need more work to tie in better with the Style settings.

A Styles panel was developed and implemented to manage the Styles settings. Changes are reflected in the help documentation.

The parameter lat/long was added to the default styles. A master default style (styles\master.stx) was added.

 

VERSION WORKSTATION 0.2alpha (07 Oct 2003)

Adds Shapefile import capability. Documentation for this added to manual.

Corrected Help > About window.

Fixes front page tab so that Data/Control is on front rather than diagnostics.

VERSION WORKSTATION 0.1alpha (Sep 2003)

ERRONEOUS SYNOPTIC WEATHER VALUES, PARTICULARLY IN BUOYS, WAS ELIMATED. The T/Td extraction routines, as well as pressure, pressure tendency, rainfall, and so forth were looking at the whole report rather than just Section 1 and as a result if a 10xxx, 11xxx, 20xxx, or 21xxx group was omitted in Section 1, it would be pulled out of other sections if a similar group existed, and thus a false T or Td was encoded. The routine was changed to only look at Section 1 and ignore other sections.

NEXRAD RADAR SUPPORT has been added. Stations are selected in a selection panel, and are retained within the program permanently whenever a radar source is selected in Internet > Retrieve. Users can also manually select a radar file for import.

OCEAN FILL PROBLEMS are now largely eliminated. This is because the mapping routines use polygons instead of vectors now.

A MULTIPLE DOCUMENT INTERFACE HAS BEEN REINSTATED to allow multiple maps to be worked with simultaneously.

NEW WEATHER TYPE FACES HAVE BEEN ADDED. This is reflected in your Windows Fonts folder.

THE LAST DATA DIRECTORY USED DURING A FILE>IMPORT FILE ROUTINE IS REMEMBERED. This is handy for users who constantly access the same data directory all the time.

SOME CHANGES TO MASTER STATION LIST (created Edition 51 and afterward).

DOCUMENTATION CORRECTED to delete obsolete information such as time zone settings, etc.

METAR IMPORT ADDS ABILITY TO HANDLE "RECENT" PRECIPITATION/OBSCURATION TYPES. Now the module looks for REDZ, RERA, RESN, RERASN, REFZ, RESH, RESHRA, RESHSN, REGR, REFG, and RETS.

METAR IMPORT HANDLED Q9 BUT NOT Q0 QNH PRESSURES, E.G. Q0984, Q0993, ETC. This support has been added.

METAR IMPORT GUSTS ABOVE 100 ARE NOW HANDLED.

METAR IMPORT OF P0000 PRECIPITATION WAS PLOTTED AS TRACE. Fixed to represent a zero amount.

STILL ON THE DRAWING BOARD....

TRY TO ADD A WAY OF HANDLING WINDS WITH NO DIRECTION... A REMARK NEAR THE STATION PLOT?

.......... Mapping ....................................................

ADD SUPPORT FOR ALBERS, LAMBERT, AND GRID (CARTESIAN) PROJECTIONS.

IF A NULL STATION IDENTIFIER IS ADDED INTO THE GENERATE MAP BY STATION DIALOG, AN ERROR IS REPORTED.

LABEL LATITUDE AND LONGITUDE ON GRID.

.......... Mathematics ................................................

INVESTIGATE THAT THETA-E FORMULATION IS INDEED ((AS^0.190263)-0.000013126*Hp)^(1/0.190263) INSTEAD OF (AS-0.000013126*Hp)^(1/0.190263) AS SUGGESTED BY MIKE UMSCHEID AND JONATHAN FINCH (4/8/03). ENSURE FEET INSTEAD OF METERS ARE GOING INTO THE FORMULA.

.......... Importing ..................................................

DIFFERENTIATE OBSERVED WEATHER AT AUTO AND MANNED STATIONS (SEE WMO CODE TABLES 4680 AND 4677). CODE 23 IS AN EXAMPLE.

INVESTIGATE SUPPORT FOR BBXX AND ZZYY BUOYS. ASSIGNMENT OF IDENTIFIERS APPEARS TO BE A PROBLEM. SEE SMVX90 KWBC, ET AL.

BUG: METRIC VISIBILITY FROM METAR REPORTS (STANDALONE VALUES OF PREVAILING VISIBILITY) - IF THE VISIBILITY DATA ARE MORE THAN 10000M NOTHING IS SHOWN; IF LESS THAN 10000M IT SHOWS -9999.

SUPPORT MAX/MIN TEMPERATURES FROM METAR REPORTS AND FROM SYNOP IN 333 GROUP.

INVESTIGATE CURRENT STATUS OF AUSTRALIAN AXF SUPPORT.

ADD SUPPORT FOR PACIFIC BUOYS ON PSU. SEE http://www.ems.psu.edu/wx/buoydata/t-04/pac-west.html

FIND WAY OF DEALING WITH SPECIAL OBSERVATIONS... DA HAS TENDENCY TO PLOT ALL OBS WITHIN THE 60-MINUTE WINDOW, ALONG WITH ALL WEATHER TYPES OBSERVED.

METAR VRB WIND IS INGESTED AS NORTH... MIGHT BE BETTER TO SELECT A PROTOCOL TO GO WITH IN SUCH AN INSTANCE. SUGGESTION: SET VRB05KT OR LESS TO CALM, AND VRB06KT+ TO MISSING (GEORGE PHILLIPS, WSFO TOP).

USER REPORTS PROBLEMS IMPORTING BOTH METAR AND BUOY DATA... CAN IMPORT-PLOT ONE OR THE OTHER BUT NOT BOTH SIMULTANEOUSLY.

USER REPORTS PROBLEM IMPORTING SOUNDING DATA FROM U OF WYO.

REQUEST: HAVE DIGATM PICK UP ON "MAINTENANCE NEEDED" FLAG (THE DOLLAR SIGN) ON US METAR REPORTS. FLAG THESE ON THE PLOTS SOMEHOW.

BUG: SYNOP DECODE FOR 6****/ PRECIP GROUP SHOULD DECODE / AS 24 HR, APPARENTLY DOES NOT.

FULL PARSING OF SKY CONDITION DATA (NOW THAT CLOUD FORMS ARE PLOTTABLE).

.......... Plotting ...................................................

INVESTIGATE ALLEGED NON-PLOT OF 03005 LERWICK AND 03026 STORNOWAY. ANOTHER USER REPORTS NON-PLOT OF 03204. COULD BE A LINEFEED PROBLEM.

METRIC WAVE HEIGHT PROBLEM: CODE 10807 "7" IS HALF-METER WAVE HEIGHT (3.5 M) -- PLOTS AS 17 METERS. MAY BE RELATED TO METRIC PREFERENCES. SEE SFVF01 EGRR.

REQUEST: PLOT LEVEL OF THE TROPOPAUSE.

REQUEST: OPTION TO PLOT METRIC VISIBILITY AS KM OR IN CODED FORM.

REQUEST: PLOT W1 AND W2 PREVIOUS WEATHER FROM SYNOP.

ADD ABILITY TO SCALE WIND BARBS.

ICAO INDICATORS ARE NOT PLOTTED FOR SYNOP DATA. NEED TO LINK THIS SOMEHOW TO THE TABLES.

COLOR CODING FOR ACTUAL STATION PLOT ELEMENTS.

BETTER HANDLING OF PRECIP TOTALS (SEE LAURIER WILLIAMS MESSAGE).

.......... Contouring/Analysis ........................................

HIGH PRESSURE AREAS IN INCHES PLOT AS 30 (MISSING TENTHS AND UNITS) WHILE LOWS IN 29XX WORK OK.

BUG: PROBLEM WITH 250 MB ANALYSIS REPORTED.

REQUEST: ADD STREAMLINE COLOR PARAMETERS.

CHECK Q-VECTOR SIGNS.

BUG: MAKE SURE USER CAN SHUT OFF PLOTTING OF HIGHS AND LOWS DURING CONTOURING OF SLP/ALSTG. USER SAID HE HAD TROUBLE WITH THIS.

MAKE SURE SST'S/OTHER SEA CONTOURS CAN BE PLOTTED WITHOUT OVERPAINTING LAND MASSES.

MAKE SURE CONTOURING MODULE OBSERVES THE RULE FILE.

KICK OUT FROM EXPANDING GRID MODULE IF TOO MANY ITERATIONS GO ON.

.......... Fronts .....................................................

INVESTIGATE POSSIBLE FRONTAL IMPORT PROBLEMS CREATED BY LACK OF NNNN CLOSURE GROUP.

FIX CODE THAT DOWNLOADS FRONT BULLETINS (THESE COME IN AT UNUSUAL HOURS).

.......... Data Sources ...............................................

* SYSTEMATICALLY TEST ALL URL'S, OF COURSE.

* DELETE SUPPORT FOR FSU IF DATA IS STILL DOWN.

* CHANGE BULLETIN URL'S TO REMOVE OR UPDATE FD WINDS ALOFT SOURCES. This data type has become increasingly hard to find, but is being superseded by GRIB data, which Digital Atmosphere is moving toward.

NEW FRONT BULLETIN SOURCE TO BE ADDED THANKS TO PATRICK FRANCIS: http://www.theweathercenter.com/weather/asus01/@Y@M@D@F_frt.wmo

CHECK THAT DA IS USING THE CORRECT NOAA METAR CYCLE SOURCE: http://weather.noaa.gov/pub/data/observations/metar/cycles/@HZ.TXT

* AUSTRALIAN BULLETINS FROM LAURIER WILLIAMS. Surface METAR (from BoM via Laurier Williams) (Australia Only) http://www.australianweathernews.com/digatm/met/@Y@M@D@H.MET Surface SYNOP (from BoM via Laurier Williams) (Australia Only) http://www.australianweathernews.com/digatm/syn/@Y@M@D@H.SYN

.......... Special ...................................................

EXPAND GRIB SUPPORT Avail use of resources such as http://weather.cod.edu/grib/ kindly supplied by Eric Nelson at COD.

SUPPORT FLEETCODE FORMAT. A test version from the Feb 2002 release will be used and upgraded. Sources to be used include http://ftp.hb-yacht.ch/ASXX21.270000 . Other sources are needed. Also make sure this is tied correctly to frontal functions.

ADD SUPPORT FOR ARCHIVES DISKS. FIX ERRATIC CD ACCESS PROBLEM.

CONVECTIVE OUTLOOK - IF BOTH DAY1 AND DAY2 ARE RETRIEVED, THEY BOTH PLOT. ALSO SUPPORT DAY3. SEE QUEUE.SWO.

SUPPORT FOR LAYERING OF GRAPHICS. NOT SURE IF THIS CAN BE DONE JUST YET, BUT WILL INVESTIGATE.

SUPPORT FOR UK LIGHTNING STRIKE DATA (SFUK30 EGRR) (SEE IAN DAVY'S MESSAGE).

OVERHAUL ENTIRE SCHEDULER AND SCRIPTING SYSTEM. ENSURE DIALOGS CAN BE BYPASSED (SUCH AS NOT ENOUGH DATA, 426 ERROR, ETC).

INVESTIGATE IF WE ARE REACHING LIMITS ON STATION TABLE ENTRIES. One user in Australia (near bottom of list) has reported some trouble after extensive customization in the 94100-95999 range.

FIND WAY TO FLAG US D.O.T. AND OTHER AUXILIARY WEATHER STATIONS IN STATION TABLES, AND USE FLAG TO ALLOW/DENY PLOTS AND ALLOW/DENY CONTOURS AS SPECIFIED BY THE USER.

EXPANSION OF SKEW-T FUNCTIONS.

EXPANSION OF INSTABILITY COMPUTATIONS (REQUIRES CONTOUR MODULES TO BE COMPLETED). INCLUDE CAPE, LCL, ETC.

SUPPORT LAYER COMPUTATIONS SUCH AS TURBULENCE, ICING, PRECIPITABLE WATER, PARTIAL THICKNESS, AND SEEING CONDITIONS.

FRONTOGENESIS FUNCTION AND LAPLACIANS.

ADD CODE TO CHECK FOR AUTO-UPDATE OF RESOURCE DIGATMOS.SLZ FILE AND OPTION TO TURN OFF AUTO-UPDATE. ALSO POSSIBLY CODE TO CHECK FOR NEW UPDATE.

FORMALIZATION OF "PRIORITY" FOR STATION PLOTS. CURRENTLY USE THE DIGATMOS.PRI FILE; MAY NEED TO BRING THESE INTO THE STATION LIST ITSELF SOMEHOW.

FORMALIZATION OF "RULES" FILE (DIGATMOS.RUL). NEED ABILITY TO CHANGE DWPT, WIND, ETC VALUES. ALSO NEED TO MAKE SURE CONTOUR MODULE OBSERVES THE RULES FILE.

WEATHER STATION TABLE SEARCH DIALOG, OR POSSIBLY EDITOR.

MAKE SURE SCHEDULER COMES BACK ON IF IT WAS ENABLED WHEN APPLICATION WAS CLOSED.

WHEN USER SELECTS DATA > TABLE AND CANCELS, PROGRAM GOES FORTH WITH PLOTTING DATA AND SHOWS "NGM FCST WIND PLOT".

FIX DROPDOWN LIST OF QUICK COUNTRY PLOTS FOR HAITI, SUDAN, ETHIOPIA, AND SOMALIA. [[ Fixed ]]

REQUEST: ALLOW OTHER SHAPES IN THE "PLOT POINTS" FEATURE.

SCRIPTING NEEDS TO SUPPORT THICKNESS AND STREAMLINES.

MEMO: ADD ERROR TEXT FOR 426 TRANSFER ERROR.

ADD HURRICANE/TYPHOON TRACKING. FIND RELIABLE SOURCES. SOME ARE: http://www.npmoc.navy.mil/jtwc.html and http://www.drdisk.com.hk/cyclones.htm

ALLOW SEA DATA AND AUTO FLAG OF SURFACE DATA TO BE EDITED IN QC PANEL.

REMOVE THE "SFC" AND "ANALYSIS" FROM BEING PLOTTED IN THE LEGEND FOR A CUSTOM DATA FIELD.

ISENTROPIC AND X-SECT ANALYSES -- OVERHAUL AND FINE-TUNE.

RIGHT-CLICK ON A TOOLBAR TO HIDE IT.

E-MAIL BUTTON TO ALLOW A MAP TO BE E-MAILED TO A FRIEND. Set aside as a long-term idea. Not enough time to work on this.

EXPANSION OF DRAWING TOOLS. One user requested a number of paint functions. This is a possibility but will have to await the more important work above.

DUAL MONITOR CAPABILITY.

BUFR SUPPORT.

METEOGRAMS.

NETCDF FORMAT.

VERSION 2K2 0.5beta (Feb 2002)

Uses significantly enhanced topography/terrain engine.

Parses Australian AXF surface data, indicated by [synopData] or [metar2Data] and ended by [$] and defined by formats in DIGATMOS.FMT.

Changed program icon.

Moved many user controls from toolbar to side panel.

Parses Australian weather collective bulletin produced by Australian Bureau of Meteorology.

Parses FM45-IV (analysis) and FM46-IV (forecast) fleet code (see http://www.fleetcode.com/fleetcodedefinition.html for more info).

Import routines drastically improved and streamlined, allowing full content of all METAR reports to be ingested (which in turn improves reliability of high/low/rainfall data from METARs).

Plots earth shadows, depicting sunset/sunrise terminator line and twilight terminator.

Adds GRIB import routines

User can right-click on the map and choose "Recenter Map" to move the view.

Deletes Daytime Saving item in General Preferences; all time conversions are now totally transparent to the user; the user only needs to make sure their computer is set to the right time and time zone in the Windows Control Panel.

Added wet bulb temperature

Numerous other changes and tweaks (not yet documented)

VERSION 2000 - V1.0a maintenance (4/16/01)

Added "mixed" grid option in Preferences > Maps.

Adds revised station tables.

VERSION 2000 - V1.0a (1/20/01)

Eliminates problem reported in V1.0 with left third of screen occasionally being blotted out at random.

Analysis > Export Last Analysis has been removed and in its place the text output is always written to GRID.TXT.

Added SLEEP command to Scripting (see Appendix / Scripting section).

Corrected program so that a timer script will only execute ONCE per scheduled time interval. The previous version would keep re-executing the script as long as the current time was the scheduled execution time.

Added rule file (DIGATMOS.RUL) with rules for importing observations.

Minor enhancements to tracking of metric vs. English units for purposes of product labelling

Added COM4 to COM8 in EMWIN Ingest

Allows up to 1000 stations in DIGATMOS.PRI priority table

Adds Map > Import command to allow satellite photos, etc, to be "underlaid"

Map > Generate By Lat/Lon now allows latitude, longitude, and zoom to be numerically tweaked and advanced settings to be "reset" with one button click.

Enhanced fills for Australia

Script timer has been renamed to "Scheduler".

Scheduler now allows multiple script names along with the usual multiple execution times; documentation has been added in this manual under Appendix / Scripting.

Digital Atmosphere now caches a map as soon as it is created so that it will be available on reloading Digital Atmosphere (this applies both in Generate by Lat/Long and Generate dropdown menu).

Vorticity and divergence now color appropriately as in earlier versions (with inverted shades for negative divergence). A solid zero-line has also been added.

Divergence and vorticity have now been added to the Analysis > Wind menu for more convenient access.

Divergence has been recalibrated and plots in 10**-6 m-2

A bug in the scripting which prevented wind analysis (grids and streamlines) from plotting is now fixed.

BETA 1/21/01 FIXES

Problem with Map > Save in 1/20/01 release fixed

Conflict with Alt- shortcut keys for main menu fixed

Added script command SFCPLOTMODEL for loading surface plot models (see Appendix / Scripting)

Script commands for convective outlooks and MVFR/IFR depiction (dy1, dy2, cig) added to documentation.

Printing capabilities have been fully restored and diagnostic gridboxes on printouts are eliminated. Print button has been fixed.

 

VERSION 2000 - V1.0 (12/3/00):

Option added to File > Preferences > Analysis to allow transparent fonts

Slight changes made to remove plotting of extra pixel line at bottom of NMC fonts

Errors under Win 98 with File > Get Archived Data and EMWIN ZIS extraction fixed

EMWIN ingest capabilities improved with regards to extraction of ZIS files (previous versions were error-prone)

Map > Generate by Station fixed

Option for 1000-500 mb thickness added in File > Preferences > Contours

MVFR/IFR contour labels were invisible with certain contour font combinations; this is fixed

 

VERSION 2000 beta 3 (12/2/00):

NEW FEATURES . . . . .

Added EMWIN ingest engine (in EMWIN > Ingest)

EMWIN upper air (upr*.*) added to File > Import EMWIN data

Added command to clear out data directory (File > Clear data directory)

Frontal workchart toolbox added (in Data > Frontal bulletins and right-click menu)

1000-500 mb thickness added (in Analysis > Temperature > Thickness); upper air data is required

Calculator now allows station pressure, wind chill, and heat index calculations entirely in metric

Replaced .CXN, .CXP county name label file with editable .CXT file

Moved county name label for Ventura County (California) westward slightly

Added aspect ratio to Map > Generate Map

Color palettes in Preferences > Colors are now saved and loaded with maps (with .ATP file)

Added more information in help file

Added Dutch weather station corrections in DIGATMOS.STN

Drop a file from Windows explorer onto a running copy of Digital Atmosphere to import that file

When a convective outlook indicates "NO TSTMS" this is plotted on the map

Print capability re-enabled (was disabled during beta tests)

ERROR FIXES

Error: File not found error in File > Get Archive Data / FIXED

Error: Old links for UNCA in DIGATMOS.SLZ Internet retrieval table / FIXED

Error: Altimeter setting H/L values round to nearest inch / FIXED

Error: Map > Generate Map "offset settings may produce bad results / FIXED

Error: If edge of Earth is seen in a generated map, ocean fills do not work correctly / FIXED

Error: DRSN (drifting snow) in METAR not properly recognized by Dig Atm / FIXED

Error: Help does not work for Map > Information button / FIXED

Error: Map > Information produces some bad results / FIXED

Error: QC rubberband keeps appearing erratically / FIXED; NOW DISAPPEARS ON RELEASE OF MOUSECLICK

Error: When cancelling in Map > Generate map, corrupt results occur / FIXED

COULD NOT DUPLICATE . . .

Fronts are inconsistently erased / COULD NOT DUPLICATE

Climatology contour of Europe January mean high temperature erratic / COULD NOT DUPLICATE

Problem: Pressure tendency shows labels only for positive numbers / COULD NOT DUPLICATE

COULD NOT FIX YET . . . WILL ADDRESS IN UPCOMING VERSIONS . . .

Problem: Timer does not work when a screensaver gets focus / NO SOLUTION

Problem: Europe army weather server causes DA to hang / NO SOLUTION YET

Problems with importing radar when it appears after surface data in raw data file / NO SOLUTION YET

Problems with 333 group SYNOP rainfall when a 111 6xxxx group is present / NO SOLUTION YET

Some problems that have been reported with plotting of warnings / NO SOLUTION YET

 

VERSION 2000 beta 2 (11/25/00):

Sea data now nullified in METAR reports so garbage doesn't appear in station plots with sea elements

Beta bug with Analysis > Wind > Wind Speed not working is fixed

Celsius/English beta problems fixed (in plotting and climatology extract)

Beta testers need to check their station plot elements and change TEMP/DWPT/VIS to match valid choices

Elevation can now be plotted in meters or feet according to English/metric preferences

Climatology > Extract Data now gives option of plotting the data or analyzing it

Additional options in File > Preferences > Analysis to let users specify isopleth fonts as "small" and/or "negative"

Added remaining font files as well as font preferences

Fixed problem with streamline thicknesses changing "randomly"

Added option in File > Preferences > Meteorological > "Geopotential height in full meters only"

Geostrophic height contouring algorithms improved to eliminate irregularities along margins

Added upper highs/lows

Added tutorial directory with tutorial files

Re-instated and improved serial/key routines

 

VERSION 2000 beta 1 (11/11/00):

Added photorealistic topography

Fixed zoom bar on map settings panel not working

Added file drag and drop capability from Windows Explorer

Fixed outer space fill

Fixed "Quit Searching" in Climatology graph

Added NCEP legacy fonts to isoplething routines for labelling of lines

Added "Thick Contours" option in File > Preferences > Analysis (makes isopleths twice as wide)

Added easter egg (Shift-Ctrl-F7)

Changed FTP timeout from 1000 to 15 seconds, so a quicker response occurs if a connection is hung

Vastly improved isentropic analysis (in "Level" dropdown on toolbar)

Added freeform horizontal analysis (in "Level" dropdown on toolbar)

Corrected and improved 3-D atmosphere build (in Analysis menu)

Reinstated and improved roaming sounding

Satellite wind observation import provided

Slight bug in contouring fixed (prevented random charts from drawing any contour lines)

Changed "Wind Speed" analysis so that it uses a gridded x/y wind field for better accuracy

Documentation provided in dual formats: context-sensitive Windows Help and PDF format.

Numerous additions, edits, and improvements to help documentation.

Added capability for user to modify Gradient Fills in analysis (in File > Preferences > Misc).

Added capability to import and plot SATOB observations (NOAA/NESDIS format).

Added scripting commands for ISOPLETH and GRADIENT

Added extra surface station plot element which is available to user (in extreme lower left of plot)

Added import of sea surface data from SYNOP reports

Changes have been made to allow saving and loading of upper plot models

Added capability to plot h and Nh code forms from SYNOP; corresponding additions in Preferences

Changed temperature and precipitation units to a single "English or metric" choice

Added streamlines

Added capability to plot fronts, highs, and lows from ASUS1 KWBC bulletin

 

VERSION 2.3.3 (MAINTENANCE RELEASE) BUILD #1015 (10/1/99):

Quality control was improved to change point/point clicking to mouse dragging. A distance meter enhanced this capability.

 

VERSION 2.3.2 (MAINTENANCE RELEASE) BUILD #989 (9/23/99):

The main purpose of this release was to get rid of a memory violation reported by six users (which consisted of various forms of "Invalid pointer" and "Access violation" errors when Digital Atmosphere was started). This was finally traced to coding errors in the creation of new maps. In addition to a fix for the problem, this release has some additional enhancements.

* "Invalid pointer" and "access violation" errors eliminated.

* Status bar can be made visible or non-visible (View > Status Bar).

* The data directory is now *always* the "data" subdirectory under Digital Atmosphere. Any data should always be placed in here unless it is being received by EMWIN or is a single file to be chosen manually by the user.

* In the synoptic decoder, dewpoints are now omitted if they exceed the temperature.

* File > Retrieve Data used to not process warning data, while File > Import EMWIN Directory, File > Import File, and the schedulers did. This has been fixed.

* The number of importable files during one pass has been increased from 100 to 150 files.

* METAR reports without times but times in FOS headers are now parsed properly.

* Font face/sizes in EMWIN Bulletins and View Raw Data can now be specified in Preferences > Fonts.

* A new feature, Map > Information, provides detailed information about the map projection currently shown.

* Another new feature, "Show distance", allows users to determine the distance between two points on the map. Identify each of the two points by right-clicking and choosing "Set point", then choose "Show distance". The distance will be shown in nm, sm, and km.

* Under the View menu, the selections for Speed Buttons, Time Toolbar, Wind Toolbar, and Status Bar are saved when the user exits the program, then restored when the program is started again.

 

VERSION 2.3.1 (MAINTENANCE RELEASE) BUILD #930 (8/29/99):

* Fixed problem where 24-hr precipitation data in METAR reports wasn't recognized.

* Readme file updated with new information.

* Error message during Emwin Scheduler when no warning files are found has been eliminated.

* Map tiles have been consolidated from 365 down to 25 files, saving 10 MB of disk space when installed (fewer wasted blocks in the file allocation tables). Some users may see a slight slowdown when generating new maps. The new tiles are binary and cannot be edited. Users who need to add map information should use the more convenient Custom Overlay files (see the Data chapter under Overlay Custom Overlay).

 

VERSION 2.3 FINAL BUILD #918 (8/20/99):

* Added two binary files required for program operation (DIGATMOS.GCI and OUTPUT.WRQ).

* Adjusted effects of "smart visibility plot" to only take effect when left-center slot contains visibility data, weather symbols, or a blank entry. This way other data (dewpoints, etc) residing in this slot does not get blanked out when no weather is present. The user may still have to adjust the contents of the far left slot for optimum appearance.

* File > Quality Control now allows editing of pressure tendency, pressure trend, precipitation amount and period, cloud codes, and mb and ft levels.

* Inability of File > Preferences > Contours settings to save has been rectified; settings will always be saved whenever "Ok" is clicked.

* Fixed a problem with inability to do station plots of FD data; and inability to plot 24 hour FD contours/grids.

* Added code that prevents "stack overflow error" and execution of warning import when OUTPUT.WRQ is missing.

* Precipitation contours are now indicated in the legend, along with the units of measure (inches or mm).

* In Internet > Retrieve Data, an "Uncheck All" button has been added.

 

BUILD #907 (8/18/99):

* AIREP reports have been enabled. These are usually found in upper air files and can help fill in wind patterns across oceanic regions.

* "Round AIREP reports within xxx mb of a standard level" has been added. When checked, and the user produces a constant pressure map, Digital Atmosphere will include all AIREP reports that are within the specified number of millibars of the constant pressure level being used (i.e. an AIREP at 278 mb will be included in a 300 mb plot/contour if the box is checked and the value is 22 mb or greater). If unchecked, then all reports have to be exactly equal to the constant pressure level being used (i.e. an AIREP at 492 mb would not be included in a 500 mb chart). This will help users control the quality and variety of data being included in upper air charts.

* "Data > View Sounding" and map popup menu item "Show Sounding" have been re-enabled.

* About 25 new EMWIN text products added to the DIGATMOS.EMP EMWIN product lookup list. This will add many new product descriptions to "EMWIN > Get EMWIN Bulletin".

* Digital Atmosphere now recognizes "SN" intermediate synoptic header in addition to "SA" and "SM" when determining times for synoptic reports. (Thanks to Hans-Stefan Lichius)

* Preferences > Meteorological option for "Round synoptic reports to nearest 6 hours when importing" has been corrected to "round to nearest 3 hours". Rounding operations have always been to nearest 3 hours.

* Data > Warnings has been adjusted to import warning datasets correctly. EMWIN users who keep seeing outdated warnings on their maps should change the purge intervals in their EMWIN reception software.

* The option "Default data time selection" in File > Preferences > General is now functional again.

 

BUILD #885 (8/16/99):

* If main window is maximized, the window is no longer resized when a new chart is loaded.

* Emwin Scheduler -- on receipt of new EMWIN data, the map did not erase; this has been fixed.

* MVFR/IFR contour analysis has been fixed.

* An "Access Violation" that popped up during import of some RCM (NEXRAD) datasets was fixed by adding code to quality-check incoming data. (Thanks in part to Wayne Cotterly

* Some problems with precipitation contouring in synoptic reports was fixed; additional code was written so that Digital Atmosphere could differentiate missing reports from zero and zero from nonzero amounts. (Thanks to Hans-Stefan Lichius)

* In an effort to consolidate internal data processing, upper air split files (OUTPUT.H00, H85, F18, etc) are no longer used. This will solve QC problems where RAOB reports can't be deleted. Users with slow computers will notice delays when plotting rawinsonde reports (due to the large size of the upper air output file). Since the code has been rewritten slightly there is a slight chance this fix could introduce errors, so testers should note any plots or contours that "don't seem to do anything". (Thanks to Phil Rider)

* Rawinsonde data elements with solidii encoded anywhere in the element (rather than just the first position) are thrown out. For example, Katmandu was encoding heights like "5085/", corrupting upper air contours.

* Scalars (temperature, wind speed, etc) could not be contoured with FD data due to an unwanted line of test code. This has been removed. (Thanks to Phil Rider)

* Various buoys, such as those in the Arctic ocean, omit the wind (0ddff) group, confusing Digital Atmosphere and making it plot erroneous winds and sky condition. This has been fixed.

* EMWIN imagewrites were saving to the DA directory, not the directory specified in Preferences. Fixed. (Thanks to Jesse Ferrell)

* Scheduled internet retrieval was not making its panel appear during retrieval; this has been fixed. (Thanks to Wayne Cotterly)

* Derived fields (vorticity and convergence) are now functional.

* Radar status annotations now work with RCM data. (Thanks to Jesse Ferrell)

* TVS signature will always be plotted in red. (Thanks to Jesse Ferrell)

* A "Preferences" speed button has been added. (Thanks to George Sobala)

* On the wind toolbar, wind vectors (as opposed to just barbs) now work again. (Thanks to George Sobala)

* When any map is loaded, all settings (not just lat/long/zoom) are transferred to the Generate Map panel in case the user wants to tweak the map. Also fixed the inverted transferred latitude. (Thanks to George Phillips)

* Menu item "View > Remove last product" has been added so that you can delete the last contour or plot.

* I could not duplicate the "Invalid filename" on "save station plot" in Preferences. For users that continue to have problems, please go to the Preferences > Misc tab and check "Diagnostic -- Show filename when loading/saving station plots". Then when you save or load the station plot, report the message that it shows.

* SPECIAL NOTES: Users may mistake station plot minus signs as decimal points, particularly with pressure tendency.

 

BUILD # 864 (8/08/99):

* Added a "Generate Map" dropdown box on the Speed Button toolbar. Clicking on any of these entries causes a map for the area to be generated, using the default map width/height specified in File/Preferences/Map. The entries for the "Generate Map" dropdown box come from a new file called DIGATMOS.MSE. Users may freely modify this file. Column 1-3 is for the latitude (south hemisphere negative). Column 5-8 is for the longitude (west hemisphere negative). Column 10-14 is for the zoom width in miles. Column 15-65 is for the descriptive name. Users may add saved maps to this list by simply leaving the first 3 columns blank, then for a descriptive name use an asterisk followed by the filename (without any dot or extensions), for example, *mymap .

* Added a Preferences entry under the Map tab for Default Width and Default Height. This specifies default image size settings for new maps that will be generated.

* Reworked the Preferences/Station Plot/"Save" segment, as some users have reported that the plot model is incorrectly saved. Could not duplicate this problem but made adjustments to code.

* Eliminated problems with importing FD and Model data (this was a consequence of improvements made to the data import algorithms in Build #849.

* Build number now shown on splash screen.

* PROBLEMS REMAINING: Internet links except for Retrieve Data are dead; locks up using data retrieval window with FSU SAO ticked.

* SUMMARY: New files required to run this build: DIGATMOS.MSE

 

BUILD # 849 (8/6/99):

* Synoptic and buoy recognition module reworked. You should see a greater number of synoptic observations, and especially buoy (ZZYY) observations that now work. Please let me know if you see any problems.

* Eliminated "Access Violation" during View Raw Data/Find. Corrected code to link in a missing component. (Thanks to John Glaveskas, Trevor Cousens, Geert Vandebrande)

* Legend was not cleared when generating a new chart; this has been fixed. (Thanks to Geert Vandebrande)

* Eliminated problems with Digital Atmosphere resolving FD data times. Corrected code to properly evaluate FD forecast hours. (Thanks to John Souza)

* Quality control has been fixed. Some stations would not get QC'd, and this was due to a problem in the mouse coordinate variables and has been fixed. (Thanks to Michael Welch and Trevor Cousens)

* Relative humidity in station plots produced an invalid floating point operation; this was fixed. (Thanks to Michael Welch)

* Television plot city font size was not set correctly; this has been fixed but not verified. (Thanks to Jesse Ferrell)

* The location to set Television font colors was not obvious. A note has been placed in "Preferences" under "Fonts" and in the User Manual to indicate where this is done. (Thanks to Robert Dale)

* Television plots are now centered horizontally. Also a bug where observation times were being ignored in television plots, leading to blank maps, has been fixed. (Thanks to Robert Dale)

* Removed "Status window on top" menu item, which is obsolete. (Thanks to Robert Dale).

* An error was found in the synoptic cloud code import; this was fixed. (Thanks to Michael Welch)

* Stations without sky condition report plotted without a center symbol; a plus is now plotted at the observation location. The newest (8/05/99 or later) version of DIGATMOS.SYI is required.

* Topography now works. (Thanks to Hendricus Lulofs and Trevor Cousens)

* At the end of a File/RecompileTables operation it seems that Windows locks up. This is because Digital Atmosphere is sorting the Warnings table. A progress message has been added, and the status window no longer truncates long progress messages. The ICAO/WMO sorting algorithm has also been speeded up. (Thanks to John Glaveskas)

* Large maps were not framed correctly when loading such as at startup. This has been fixed by forcing the image object width to equal the bitmap width. (Thanks to Hendricus Lulofs and Geert Vandebrande)

* Internet retrieval list (DIGATMOS.SLZ) enhancements: Added UCAR upper air (thanks to Robert Schmidt), added Albany buoy.

* Digital Atmosphere now parses the RCM file when the EMWIN Scheduler is running. (Thanks to Robert Dale)

* User must specify the EMWIN directory for warnings; this allows compatibility with software such as RealEMWIN. This option is in File/Preferences/General. (Thanks to Robert Dale)

* Speed button toolbar can now be hidden or unhidden (see View menu item). (Thanks to Robert Schmidt).

* All fonts used in contouring operations are now set in Preferences, Fonts under "Annotations". Only the font type is used; the size is ignored. (Thanks to Robert Schmidt)

* Internet sites which don't report the filesize in some headers (such as IWIN and FSU) no longer produce unusual progress results during download; program now reports "unknown". (Thanks to Verna Young and Mark Hayes)

* Digital Atmosphere no longer tries to resize itself after generating a new map when maximized. (Thanks to Robert Dale)

* VARIOUS ISSUES STILL TO BE RESOLVED: "Bitmap image not valid" will still appear when viewing EMWIN products -- this is because the functionality has been temporarily disabled; geostrophic wind field feathers not available; SKEW-T, CAPE and other extended analysis stuff has not been restored yet; will not import a V2.2 map; Data/Warning causes "Illegal function" error; hidden toolbars reappear at startup (this is not a bug but an item suggested and will be evaluated); unusually high heights (above 580 dam) such as with what we are seeing this summer are inverted to 480+ dam.

* OTHER NOTES. I am on the lookout for errors where a data directory, data product, or error message shows a path with two solidii, for example, c:\program_files\digatm\data\\ or c:\digatm\data\\infile.txt. This has cropped up a couple of times but I haven't found the source of it. It will cause non-found datafile errors and so forth.

 

CHANGES FOR V2.2 to V2.3 BETA INITIAL (JUNE 1999)

* Multiple chart forms eliminated. This was performed to simplify numerous algorithms within Digital Atmosphere, reduce the complexity of our source code, and enable further development of other key areas of the program. The vast majority of users indicated that they preferred one map at a time.

* Status panel deleted and toolbars added. It was decided that the status panel, which has always been a part of Digital Atmosphere, was too awkward, cluttered, and frequently got in the way. It has been replaced by two toolbars: a time toolbar and a wind toolbar. They can be hidden or displayed in the "View" dropdown menu.

* Tab ordering improved. The tabbing order of controls in the map customization screens were improved so that navigation without the mouse would be much easier.

* Automated version numbering. This is mostly an internal change that isn't of interest to most users. Version and build numbers listed on the Splash Screen and About Screen are now extracted directly from the application file. This is the same data seen when you choose "Properties" and "Version" from Windows Explorer.

* A new registration authentication scheme has been enabled. To register your copy, you will need to go to Help, Register to find out their individual serial number, then contact us for a key number. Note that this keying scheme is subject to change.

* RCM NEXRAD radar parsing has been vastly improved. The algorithms were edited, tested, and tweaked to give a high level of competency in parsing NEXRAD RCM data. Furthermore the algorithms extract cell, mesocyclone, TVS, hail, and wind data from the datasets. RCM data is not available at most weather data servers, but it can be found in the SAORCMUS.TXT file regularly transmitted by EMWIN (this is also available at http://emwin.cira.colostate.edu/rxfiles/SAORCMUS.TXT, which has been placed in the new Internet data retrieval panel).

* New NEXRAD site codes added to the station tables. About 40 new RCM station codes have been added. This fills in many radar gaps that existed in earlier Digital Atmosphere versions.

* NEXRAD VAD/VWP wind parsing has been added. Simply import an RCM file and plot using "Analysis" for time and a valid FL for level. These reports can then be plotted or analyzed. Although this is an incredible tool for filling in gaps between rawinsonde stations and rawinsonde times, NEXRAD winds are usually missing where there are no droplets, dust, insects, or birds to yield a velocity measurement (such as high aloft or in dry regions).

* The level selector can contain FD winds, RCM winds, or both. This is chosen with the "R", "F", and "All" buttons next to the level selector. Use it when, for example, you want to look at NEXRAD VAD/VWP winds aloft and don't want to accidentally click on an FD wind level. You would simply hit the "R" button to pare down the list.

* Major improvements in the Internet data retrieval panel. The panel now uses true HTTP binary transfer to connect with weather data sites, delivering much swifter, more reliable data downloads than in previous Digital Atmosphere versions. It also allows FTP sites to be accessed. For those few users who need to specify a port number and/or user ID & password, you must append the User ID, Password, and Port to the end, all separated with "$$". Example: ftp://ftp.mysite.com/pub/data.txt$$myusername$$mypassword$$port ). If you decide to specify a port number, you must specify a username and ID.

* New formats added to "Export map". In earlier versions you could save your map as a BMP or a JPG. In addition to those, you can now save PCX, PNG, and TIF (uncompressed and packbits) formats. The packbits TIF format generally offers the best format for desktop publishing purposes. The GIF and LZW TIF formats were not included because they are proprietary technologies and require licensing from Unisys.

* Map can be copied to the clipboard. This can be found in the menu under "Map" and "Copy to Clipboard". When the map is in the clipboard it can be pasted into other Windows applications.

* Fonts in Preferences improved. The interface has been changed slightly, and we have added the ability to let you set "annotations" fonts, which are seen when you plot custom map points and city overlays, and county name fonts.

* County name overlays added. You can now add county names on your map. The county name text will be truncated automatically according to the map scale (to see more of each county name, make a more-zoomed in map). The font color is controlled by the "county overlay" setting in Preferences/Map and the font name/size is controlled by the "county name" setting in Preferences/Fonts.

* Custom geography added. This is done in the WeatherGraphix style, with custom geography residing in DIGATMOS.PLR. Edit this file to make changes. Note that longitude in the west hemisphere is negative; files imported from WeatherGraphix will need to have the longitude signs inverted. The color of the line is controlled by the "roads and custom lines" setting in Preferences/Map.

* Contour labelling algorithm improved. Previous versions of Digital Atmosphere plotted isopleth labels only at the chart edges, making closed contours difficult to interpret. Digital Atmosphere will now plot labels in many closed contour patterns.

* Data tables now produced. These are stored in OUTPUT.SFC (surface) and OUTPUT.UPR (upper) every time you import data. These tables can be parsed using your own applications or can be brought into spreadsheets and databases.

* Precipitation data now available. Data from the synoptic 6xxxx group is now imported into Digital Atmosphere and can be plotted or contoured. Note that most U.S. and Canada stations report 6-hour precipitation.

* Precipitation inches/millimeters choice added in Preferences/Meteorological. This applies to precipitation plots and contours.

* Pressure tendency, and low, middle, and high cloud symbols have been added. These can be plotted if they are part of the surface plot in Preferences/Station Plots. The pressure tendency can be analyzed and contoured.

* Maps can be automatically exported when the program is in automatic mode. You simply specify the target file in Preferences/General under Autosave (a complete directory and filename is required), and check the Autosave box. The graphics type is determined by the extension of your filename (BMP, JPG, PNG, PCX, or TIF). Every time the map is refreshed automatically, the completed map will be exported to your target file.

* Previous versions of Digital Atmosphere had trouble identifying some warnings. This occurred when warning bulletins did not end with the "NNNN" termination sequence (this recently began appearing on EMWIN); therefore warnings piled up in the first warning text slot. This has been fixed; a new header now can substitute for an "NNNN" termination sequence.

 

CHANGES FOR V2.1C BETA to V2.2 (FEBRUARY 1999)

* Preferences buttons for the FOUS level have been added. This is located in Preferences, Meteorological. This allows a level aloft (such as the T3 and T5, and R2 and R3 levels) to be plotted or analyzed. Note that since the T3/R2 and T5/R3 levels aren't exactly the same, you should avoid calculations which cause the temperature and relative humidity to be combined (for example, dewpoint analyses).

* Preferences buttons for the default time select have been added. It is located in Preferences, General. Using these buttons you can pick something else besides "Automatic" time select to appear on the status panel when Digital Atmosphere is started.

* Cursor lat/long can be determined by right-clicking the map. Using the pop-up menu simply choose "Cursor location" and an information box will appear.

* Nondiscrimination between ETA and NGM data during contour operations has been fixed. Earlier versions did not discriminate between ETA and NGM data (according to the status panel) during contour operations.

* Appropriate labelling is now applied to charts when a contour of model data is done.

* The registration information box contained within the program for new users has been updated to reflect a new E-mail address and minor changes in sales policies.

* Default color preferences have been fine-tuned to get rid of contour line colors that match the background.

 

CHANGES FOR V2.1A BETA to V2.1B BETA (FEBRUARY 1999)

* The lat/long grid interval can now be controlled. This is done in "Preferences", "Maps".

* A range check error that occurs during analysis of rawinsonde data has been fixed.

* The File, Print option has been fixed. The diagnostics window in the beta version has been disabled. The "inverse print" option had to be deleted due to an inability to make it work successfully without considerable programming. Many PostScript drivers allow you to force the printer to make negative printouts.

* Wind feathers are reversed in the South Hemisphere to meet standard convention. One note, however -- in the Analyze, Wind Grid section, the routines have to make the feathers a uniform style, so the center position of the background map is what determines the style rather than each gridpoint location.

* The status panel now uses "Automatic" for default time selection. It's assumed that most people will only want to use "Show Contents First" in special cases.

* A Data Check interval has been added in Preferences in the General tab. In earlier versions, Digital Atmosphere checked for new data every 20 seconds. This is now user-specifiable.

* During find operations in "View Raw Data", the cursor is now an hourglass.

* New station tables are now packaged with the upgrade. This consists of DIGATMOS.RIX, DIGATMOS.STI, DIGATMOS.STW, DIGATMOS.SXI, and DIGATMOS.SXW. This fixes some persistent "range check" errors with surface data that were present in the beta version.

* The Internet alphanumeric product retrival list (DIGATMOS.SLZ) has been updated slightly.

* Soundings have been reinstated. The sounding window contains a box where you can enter the desired station and easily view consecutive stations.

* Background maps now plot after a gradient analysis.

* You can now overlay the base map without erasing the graphics, thanks to the new Map command "Add basemap".

* The status bar at the bottom of the screen has been restructured. It now holds a progress bar detailing all ongoing operations, the task progress, and the ingest mode currently in use. Additional status notifications have been added throughout the analysis module and other processes.

 

CHANGES FOR V2.1B BETA to V2.1C BETA (FEBRUARY 1999)

* Isentropic analysis has been reinstated. The isentropic level can be selected from the Status Panel under "active level". You will be prompted for a level in whole Kelvin degrees. While this level is active, all analysis operations will pertain to parameters on that particular isentropic surface. The two most useful parameters under Analysis are "isentropic height" and "wind grid".

* Isentropic height has been added as an Analysis option. This analyzes the height of datapoints in mb at the Active Level. Therefore its only suggested use is when an isentropic level has been entered into the Status Panel. Its color scheme currently follows the 500 mb contour scheme.

* A Composed CAPE option has been added in Analysis. This "builds" a 3-dimensional representation of the atmosphere based on existing observations and calculates CAPE at each gridpoint, rather than calculating CAPE at each station.

* CAPE, LCL, and 0-6 km mean wind are now functional and can be accessed under the Analysis menu.

* A bug has been fixed where the toolbar Print button had no effect.

* A bug has been fixed where analysis gradient fills with no isopleths produced no background map.

 

CHANGES FOR V2.1 to V2.1A BETA (JANUARY 1999)

* Documentation is now contained entirely in an Adobe Acrobat document. The manual was extensively rewritten and updated.

* Lat/long grid usage is now controlled by the Preferences, Color checkbox. The "none" radio button under lat/long grid has been removed.

* New time tokens for Internet data products have been introduced. They allow you to specify the latest synoptic or intermediate synoptic time. You can also specify the previous hour as a base token.

* You can easily override the time settings used in Internet time tokens to gain access to data files for different hours. The variables that will be used are now shown in the Internet Data Retrieval window.

* Contour color and attribute settings are now in Preferences "Contour", for easy access. Advanced users only if you delete DIGATMOS.CGZ, Digital Atmosphere will automatically make a new one when you open the Preferences window by importing your older DIGATMOS.CCL settings file. This is how you can preserve your color schemes when you upgrade.

* You can pick a range of hours to analyze or plot, rather than just a specific one, when manually selecting an observation time. This is great for data-sparse areas.

* View EMWIN bulletins using a nested tree structure similar to File Explorer, rather than the older series of dropdown menus. These bulletins also show the plain-English description of each region, as well as a more complete description of each product, so you can easily see what product you'll be getting.

* Extensive changes have been made in the station tables, DIGATMOS.STN. Three-letter ISO-3166 country code identifiers are now being used, and the time zone entries have been reformatted and filled to support upcoming capabilities. Absolutely no attempt should be made to import station tables using the old format without converting them to the new format. Various stations have also been added worldwide.

* There are no longer overflow problems with the View Raw Data window. Imported data greater than 64K in size used to generate a "text exceeds memo capacity" error when the user viewed it through File, View Raw Data. The viewer has been replaced with a new 32-bit component which does away with the error.

* Sporadic range check errors during data imports have been eliminated. The error was caused when erratic WMO numbers in synoptic data were looked up in a station table.

* An import is automatically done after retrieving Internet data. This eliminates an extra step that the user had to do in the past.

* It is now impossible for a station plot to appear at the intersection of the equator and the prime meridian. Occasionally when a report can't be processed correctly, Digital Atmosphere is forced to assume it has a latitude and longitude of zero.

* You can now adjust the lowest possible METAR pressure, under the Preferences, Meteorological tab, to change how the hundreds place of a coded METAR sea level pressure is determined. This is useful when contouring very low or very high pressure.

* Model output thicknesses between 4800 m and 4999 m are now handled correctly. Since they are coded as hundreds and tens, earlier Digital Atmosphere versions simply assumed the thousands place was "5".

* You can now specify to create a map centered on a particular station. This is similar to how maps are created in WeatherGraphix. Maps can still be generated using lat and long.