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HIGHLIGHTS OF DIGITAL ATMOSPHERE

*  Self-contained realtime weather data plotting system
*  Immediate access to surface charts, upper air plots, and soudings before they’re available on Internet sites
*  Is always ready to create maps when your favorite Internet site fails to update the charts
*  Contains a worldwide geography dataset with 2-mile resolution
*  Automatic retrieval of datasets and graphical weather products through the Internet
*  Global terrain data with 30-mile resolution
*  Detailed county/parish geography, highway, and road data for the United States
*  A master listing of nearly 15,000 weather stations across the globe, which can be modified by the user
*  Lightning-fast ability to import surface airways (SAO), METAR, synoptic, ship synoptic, and AIREP code
*  Easily-customized surface and upper-air plots
*  A powerful array of analysis and contouring tools; complete with vorticity, divergence, and advection derivatives
*  The ability to plot most National Weather Service watches and warnings
*  Quick plotting of national radar composites and NEXRAD RCM (radar coded message) images
*  Graphing, plotting, and contouring of climatology for over 2,000 stations worldwide
*  Instantly delete or modify erroneous reports with an easy-to-use quality control panel



	 Digital Atmosphere’s history dates to 1992 
with its predecessor program RadarScan, which 
was used to look at MDR code, the first genera-
tion of national digital radar.  This grew into the 
popular WeatherGraphix program in 1993.  The 
idea was to provide powerful capabilities for the 
desktop similar to the National Weather Ser-
vice’s AFOS system.  In 1995 the code base was 
ported to Windows 95 and released as Digital 
Atmosphere on January 7, 1996.  A succession of 
updates and expansions have followed over the 
years.  The program is written in Object Pascal, 
and supports Windows 7,  8, and 10 as well as 
older Windows versions.
	 For the past two decades, Digital Atmosphere 
has served as the leading operational weather 
analysis tool for Windows, allowing users to “roll 
their own” weather maps without being tied down 
to proprietary servers or websites that provide only 
a limited set of products.  It also helps solve the 
problem of surface and upper weather charts “per-
ishing” from web servers in mere hours.  Digital 
Atmosphere is used by certain National Weather 
Service, Air Force, and Navy offices, dozens of 
television stations and consulting firms, and hun-
dreds of amateurs and hobbyists.  Its powerful and 
rapidly expanding capabilities will let you monitor 
developing weather anywhere on Earth — around 
the globe, or right in your own local area.
	 The maps and other products you create with 
Digital Atmosphere are fully customizable.  You 
can define the geographic area you wish to map 
and specify the map’s resolution.  You decide how 
much detail you want shown in your maps, from 
country borders only to rendered topography with 
county lines and roads overlaid.  You choose what 
weather data you want displayed, how the data is 
displayed, and in many cases what algorithms are 

1 / About this software

used to analyze the data.  Whatever your meteo-
rological graphics needs, Digital Atmosphere can 
create exactly the map you desire, using only the 
parameters you desire.

1.1. Supported datasets
	 Digital Atmosphere supports the follow-
ing data, all of which is readily available on the 
Internet and is the worldwide standard of data 
exchange:
n Land synoptic (WMO FM-12 SYNOP)
n Ship synoptic (WMO FM-13 SHIP)
n METAR (WMO FM-15 METAR)
n Buoy (WMO FM-18 BUOY)
n Upper air (WMO FM-35 TEMP)
n Aircraft data report (ACARS) (WMO FM-42 
AMDAR)
n NMC frontal depiction interchange format 
(ASUS1 KWBC)
n Gridded binary (GRIB) (WMO FM-92-IX).  
Note that this functionality is experimental at this 
time and GRIB2 is not yet supported.
n NEXRAD Level III WSR-88D NEXRAD 
format
n Australian AXF comma-delimited observational 
data and similar formats
n NHC Hurricane Warning bulletins
 

1.2. System requirements
	 Digital Atmosphere runs under Windows 7, 
8, and 10; and Windows Vista, XP, and 2000.  It 
is still written as a 32-bit (x86) application as the 
algorithms are not particularly processor-intensive.  
However, it run under all current 64-bit versions 
of Windows, including Windows 10.  There is no 
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minimum hardware requirement.  It is strongly 
recommended to have an Internet connec-
tion when running the software, but this is not 
necessary if users are supplying their own data 
sources or are using data archives.

1.3. Registering the software
	 Your Digital Atmosphere copy is a fully-
functional version. There are no separate 
“registered” and “demo” versions, and there’s 
nothing else to download or install! However, 
you must register Digital Atmosphere 
Workstation within 30 days of installing it. 
If you don’t do this, at the 30-day point the 
software will disable certain features such as 
quality control, scripting, climatology, and 
loading/saving of maps.
	 The software is written and maintained 
by Tim Vasquez.  Your registration is vital for 
helping Tim continue to invest countless hours 
into this program.  The project consists of 
150,000 lines of computer source code, so it is 
no small undertaking.  A coding session may 
take a full 17 hour day for Tim.  You are a very 

important user, even more so 
than with multi-million dollar 
software companies which just 
bank the money and pay their 
executives lucrative salaries.  
Your registration literally 
helps pay the bills and keep 
the lights on!  Thank you for 
being a part of this project.  If 
you want to send a little extra 
to keep it going, visit www.
weathergraphics.com/pay and 
you might receive some extra 
VIP perks and privileges.
	 Anytime you register 

Digital Atmosphere, you will receive a key 
number that you enter into Digital Atmosphere. 
This prevents it from expiring and restores 
expired copies. All of this can be handled 
conveniently via the Web, and we can get you 
up and running in many cases in less than 24 
hours.
	 We also hope that our low price and our 
commitment to continued development work 
is an incentive to register. We’ve served weather 
enthusiasts for almost 20 years with affordable 
prices and personalized service directly from the 
author, rather than inflated markups and non-
existent tech support, which is the norm in the 
software industry.
	 Your registration is greatly appreciated!

1.4. Your rights
	 You own all maps you create in Digital 
Atmosphere.  There are no restrictions, no 
licensing requirements, and no royalties, on the 
use of maps produced by Digital Atmosphere.  
They can freely be used for commercial 
applications, published in books, and uploaded 
to your website.

FIGURE 1-1: Surface analysis for 
Canada, June 2015.
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	 You cannot make multiple installations of 
Digital Atmosphere or install it to other peoples’ 
computers.  You are, however, permitted to install 
Digital Atmosphere on up to three personal 
computers that you own and which are used 
strictly for personal purposes.

1.5. Pricing and ordering
	 If you haven’t already purchased the software, 
here’s what you need to know.  The sole source 
for Digital Atmosphere is the Weather Graphics 
website at:
     www.weathergraphics.com
	 Pricing and registration is available on 
the website.  If you have questions, contact 
servicedesk@weathergraphics.com.
	 European Union and German users are 
encouraged to register through our official 
partner, MeteoSoft, and receive German-language 
assistance, at:
	 www.meteosoft.de

1.6. Standard vs. Professional 
versions
	 For quite some time we have needed to 
raise prices to cover the costs of continued 
development. Digital Atmosphere has been kept at 
under $100 since its release in 1996. However we 
also recognize the need to provide an economical 
version of Digital Atmosphere. Therefore we 
provide twoversions: a Standard and a Professional 
version.
	 Here are the differences between the two 
versions.  Note that a program can be upgraded 
from Standard to Professional simply for the 
difference in price.

Standard version
* Maps: Limited to vector-mapped workcharts 
(same as in previous versions of Digital 
Atmosphere). New York City aeronautical 
coverage only.

* Menu scripts: Limited to a maximum of 30 
dynamic scripts in your menu.
* Registration: We send you a key for the program 
to continue working beyond 30 days.  Without a 
key, various functions of Digital Atmosphere will 
cease working, even after reinstallation.

Professional version
* Menu scripts: Unlimited scripts in your menu.
* Maps: Includes CD packed with 4 scales 
aeronautical charts for the United States at 
1:500K, 1:1M, 1:2M, and 1:5M.  These highly 
detailed charts fill a CD-ROM and are an 
outstanding complement to our radar modules.  
In the Standard version you can view a sample of 
them by generating a chart for the New York City 
area and changing the Projection. to one of the 
Raster maps.
* Registration: No key is required. This gears it 
toward corporate, government, and university 
environments, as well as military applications, 
where serial/key validation procedures are 
unacceptable and a pre-unlocked solution is 
required.

1.7. A quick walkthrough
	 Now we present a quick tutorial to help you 
get up and running. We suggest printing out 
these pages or viewing them on a tablet or second 
monitor and following along.

Loading a little data
	 Digital Atmosphere comes with a set of 
prepackaged data for April 15, 2015, the date 
of a major tornado outbreak in Illinois. To load 
this data, go to the top menu and choose “File > 
Import Specific File”.  Select “sample.txt” from 
the “tutorial” folder in your Digital Atmosphere 
application data folder.  If you’re not sure where 
this folder is, see “Help > About” and noting the 
application data path.
	 After you select “sample.txt”, Digital Atmo-
sphere will import all the weather data in that file 
(it contains METAR surface observations). On a 
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Pentium III it takes about 15 seconds. That’s all 
there is to it! Now you can plot the data, analyze 
it, or perform other operations.

Make sure we’re at the surface
	 For our first activity, we want to make sure 
we’re looking at data at the surface, so check the 
toolbar and make sure Level Selection shows 
“Primary - Surface”. Digital Atmosphere usually 
starts with this by default.

Looking at the big picture
	 Meteorologists usually like to get their first 
look at a weather chart using isobars (lines of 
equal pressure). To display these, choose “Analy-
sis > Pressure > Sea level pressure (mb)”. Con-
gratulations -- you’ve made your first weather 
map, and it was incredibly easy.
	 You’ll notice a deep low over Iowa and 
northern Missouri, with a Pacific high dominat-
ing the Rockies.

Generating a new base map
	 We don’t always want to look at the same 
location all the time. Let’s zoom in for a better 
view of the Midwest.  First choose “Map > Gen-
erate Base Map”. Make sure “Projection” is set 
to “Orthographic” (this is always the best one to 
use; others may not work as well).
	 Set “Latitude” to “39” and “Longitude” to 
“-92” (note the minus sign; a negative longi-
tude is always in the western hemisphere).  You 
can type these in or use the slider bars.  Set the 
“Scale” to “1000” miles.  You can change the 
image size if you want to; if you feel like it, go 
right ahead.  We suggest a width of 1200 and 
height of 900 for most monitors.  Note that you 
can set it much, much higher if you have fancy 
displays or want a publication-quality graphic.
	 Now, press “OK” at the bottom to gener-
ate the map.  Wait about 5 to 15 seconds for 
the map to render. During this time you will 
see the map drawn. Watch for a “Map drawing 
completed” in the status window to the left, and 

for the cursor to change from an hourglass to a 
pointer. Is it done? Good.
	 Let’s save this map for future use. Pick “Map 
> Save Base Map” and in the File window type 
“midwest”.  Take careful note of the folder 
you’re saving it in; if you want, you can pick 
your own location to save this file in. Now press 
“OK”.  You can retrieve this same map instantly 
at any time in the future!
	 PRO TIP: Never save any files to the “Pro-
gram Files” or “Windows” folder hierarchies.  
These are protected locations and Windows will 
prevent the file from being saved here.  Most 
other folders on your hard drive are accept-
able, including any folders you create under 
c:\ (the top level) or from your desktop (which 
is equivalent to c:\Users\(username)\Desktop.  
If you choose to use your desktop for Digital 
Atmosphere maps and data, we recommend 
creating a dedicated folder for that purpose.

Recentering the map
	 Centering the map on a new location is easy. 
Right-click on the most southerly tip of Illinois 
and in the popup menu choose “Recenter Map”. 
If you wait briefly  you’ll see a new map drawn, 
centered on the Ohio River region! When it’s 
finished, however, let’s load the original map 
again.
	 Now let’s go to “Map > Load Base Map” and 
reload the “midwest” file.  Press “OK”.

Easy map operations
	 Did you know you can measure distances 
with Digital Atmosphere? Simply put the cur-
sor over a certain spot on the map, and hold 
down the left mouse button as you move the 
mouse around. Notice that you see a “marching 
ants” box and a line that moves with you. The 
line helps show you the path between your two 
points, while the box defines an area, which is 
often used to lasso a group of observations and 
quality check them.
	 At the bottom of the window, note that the 
status bar is displaying the latitude and longi-
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tude of each point, and the bearing and distance 
between the two! The line drawn on the map is ac-
tually a great circle line, and on global map views 
you will notice that it forms an arc rather than a 
line. This arc is always the shortest distance be-
tween the two points (i.e., as the crow flies), even 
if it looks slightly curved.  Now you know how 
to measure distances and get latitude-longitude 
information.

Looking at station plots
	 Station plots are little meteorological “packets” 
of data that appear on the map at various loca-
tions, showing the actual observed conditions 
at that location. Plotting them in Digital Atmo-
sphere is a snap.
	 To do this, just click on Data > Data plots. 
Instantly the map is filled with a smorgasbord of 
information.  Each plot contains a temperature 

value at the top left and a dewpoint value at the 
bottom left.  We can’t predict what exactly you’ll 
see since this depends on the image size of your 
map and what the clutter filter is set to, but you 
can decode any plot by using any station plot 
reference found on the Internet.  The format 
is universal.  Just go to images.google.com and 
in the search box put in “weather station plot”.  
You’ll notice there are simple versions, with just 
temperature, dewpoint, and pressure, and much 
more detailed formats with cloud type, pressure 
tendency, and other values.

FIGURE 1-2: Surface chart for the sample dataset, with al-
timeter setting (barometric pressure) overlaid.  This can be 
accessed via Analysis > Altimeter Setting.  The altimeter 
setting differs from sea level pressure in that it is reported 
in inches of mercury (in Hg) and it is a raw reading with no 
temperature or climatological-based corrections.
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	 The long shaft sticking out from each plot 
is the wind direction.  It always sticks INTO 
the wind.  The feathers on the shaft indicate the 
wind speed.  Each long barb represents 10 mph; 
each short one represents 5 mph.  On rare occa-
sion you may see a thick flag, which represents 
50 mph.
	 In the center circle, the amount of shading 
indicates the amount of cloud cover.  A com-
pletely shaded circle means it’s overcast.  You’ll 
also note that some stations have a square; this 
means the observation was made by an auto-
mated  station.
	 Some stations (not in this particular ex-
ample) have a red color; this means bad (IFR) 
weather, while some are blue which means 
marginal (MVFR) weather. This coloring is 
determined strictly by visibility and cloud height 
and is more for the use of pilots and experienced 
meteorologists, though they can clue you in on 
where significant weather is happening.

Cutting down on crowding
	 Soem users may want their plots more clut-
tered but yielding more information, while oth-
ers may want fewer plots and a much “cleaner” 
chart.  Let’s adjust the plot crowding.  On the 
left side tool bar, change the “Data Plot Crowd-
ing” to 50%.  To enable the change, go to “Map 
> Erase” map, and choose “Data > Data Plots”. 
You’ll notice a lot of stations have disappeared, 
but it makes the chart easier to read.
	 Now change the “Data Plot Crowding” to 
100%.  Replot by going to “Map > Erase” map, 
and choosing “Data > Data Plots”.  Every single 
available station will now plot.  That’s a lot of 
data!  More data is good, but you’ll want to play 
around with this slider in your day-to-day chart 
use to get it just the way you want it.

The NMC font
	 Let’s check out one cool feature the software 
offers.  First, use the “Data Plot Crowding” 
slider and set it to 80%.  Now go to the main 
menu and click “File > Font Mode > NMC/

NCEP Raster”.  Replot by going to “Map > 
Erase” map, and choosing “Data > Data Plots”.
	 What you’re seeing is station plots drawn in 
a special font which was developed by the Na-
tional Meteorogical Center in the late 1960s for 
use on their CDC 6600 mainframe computers.  
It’s one of the oldest computer fonts still in ex-
istence!  We extracted the font from the original 
FORTRAN source code and it is available for 
use it in Digital Atmosphere.
	 Why is it good to know about this font?  
It is is an exceptionally high-contrast, and is 
suitable for applications where readability is 
important.  It is also widely   Also as a raster 
rather than a vector font, it does not suffer from 
scaling artifacts that may affect precipitation 
symbols used in station plots.

Overlaying more contours
	 Now choose Analysis > Pressure/Height > 
Sea level pressure. Nice! You just added the same 
isobar field seen earlier in this tutorial on top of 
the map. This illustrates how you can view dif-
ferent meteorological fields at the same time.

Seeing the wind flow
	 It is possible to visualize the wind field in 
a couple of different ways. Go ahead and click 
on Map > Erase map. Now choose Analysis > 
Wind > Wind speed (barbs). You’ll see a pretty 
cool gridded array of wind patterns! It’s the ideal 
thing to depict how the air is moving.
	 Next, try Map > Erase map.  Then select 
Analysis > Wind > Streamlines.  This shows the 
wind like rivers of air.  The low pressure center 
in Iowa is instantly identifable, and fronts can 
be found where the streamlines tend to bunch 
up, as in western Missouri and western Pennsyl-
vania.

Looking at isotherms
	 Remember how you overlaid isobars on the 
map? It’s easy to overlay other fields, such as 
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isotherms (lines of equal temperature). Just go to Analysis > Tempera-
ture > Temperature (deg F).

Get new weather data
	 Now it’s time to get real data! Make sure you’re connected to the 
Internet. Now go to Internet > Retrieve Data. Press Uncheck All to 
make sure we start with a blank “shopping list”. Now check METAR 
from COD. This makes sure we retrieve surface (METAR) data from 
College of DuPage’s server. Now press Retrieve. The data will be 
loaded in just a matter of seconds and is ready to view (if you have 
any error messages please see our FAQ elsewhere in this guide, or on 
the website). Now go to Map > Erase Map and choose Data > Data 
plots. You’re looking at current weather!

					     * * *

	 That completes the quick tour of Digital Atmosphere. This tour 
was only intended to give you a feel for how Digital Atmosphere 

FIGURE 1-3.  Sample heights 
and vorticity chart for 500 hPa 
(500 mb) for Europe, showing 
a channel jet over Switzerland, 
upper lift associated with the 
left front quadrant of the jet over 
the Czech Republic, and a series 
of short wave troughs west of 
St Petersburg, Russia; over the 
British Midlands, over northeast 
Poland, and over the western 
English Channel.
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works. You’ve covered all of the basic functions, 
and now you can build on your knowledge by 
playing around with the software and reading 
through this help guide. There’s no way you can 
“break” Digital Atmosphere just by experiment-
ing. Have fun!
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	 Before we continue, let’s look at the major 
components of the Digital Atmosphere screen in 
the illustration below.  It’s important to be famil-
iar with each of these parts, since we will refer 
to them occasionally through the manual.  This 
chapter discusses each component in detail.
	 The main menu is where you issue most 
commands for Digital Atmosphere.  This drop-
down menu structure works just like most other 
Windows programs.  Each main menu command 
will be described in the following chapters in this 
manual, so we won’t discuss them in detail at this 
time.

2.1. Speed buttons
	 The speed buttons in the top horizontal 
toolbar provide you with a convenient way of ac-
cessing some of the most common Digital At-
mosphere commands, such as downloading data 
from the Internet.  You can find the meaning of 
each one by simply resting the cursor on a button 
(a popup hint will appear).  Each button corre-
sponds to a main menu command, summarized as 
follows (going left to right).  To get more informa-
tion, go to the following chapters to see what the 
main menu command does.

2 / The main window

FIGURE 2-1. Components of the main window interface.
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2.2. Control toolbar
	 At the left side of the screen is a vertical 
toolbar with various options and settings that 
help you select and view Digital Atmosphere 
products.  It is divided by a tabs into three main 
sections, “Workchart”, “Fronts”, and “Script-
ing”.  Below we will go through each of these 
tabs in order, starting with the Workchart tab.

Level Selection [Workchart tab]
	 The great majority of Digital Atmosphere 
products are horizontal charts for a specific 
level.  This is set in the PRIMARY dropdown 
box, where you can select the surface, a constant 
pressure level such as 500 mb, or isentropic 
analysis.
	 If isentropic analysis has been selected in the 
primary box, choose the desired isentropic level 
in the ISENTROP dropdown box.  These val-
ues are in Kelvin.  Keep in mind the lowest Kel-
vin values are found closest to the ground and in 
cold air masses.  If you’re uncertain which level 
to use, it’s best to start with the warmest expect-
ed surface temperature you see on the map (e.g. 
90°F = 32°C = 305 K) and adjust it as needed.  
A value too high will be too far aloft for data to 
be available, and a value too low will be entirely 
underground and not produce any results.
	 NOTE: When the charts show no plots or 
analyzed fields, the culprit is often forgetting to 
select a millibar level here when upper air data 
has been imported, or forgetting to set surface 
data here when METAR and SYNOP data has 
been loaded!

Time Selection [Workchart tab]
	 Digital Atmosphere products are also for 
specific instances in time.  To define which 
times you want to see, make your selections 
here.
* Surface time.  This controls how the valid time 
for surface data is chosen.  You should leave 
it on “auto” to allow Digital Atmosphere to 
choose the most popular time from the avail-

able data.  If you wish to override it, you can 
choose “manual” to be prompted for a time each 
time you generate a surface product, or you can 
choose a specific numerical time.
* Upper time.  This controls how the valid time 
for upper-air data is chosen.  You should leave it 
on “auto” to allow Digital Atmosphere to choose 

FIGURE 2-2. The 
workchart tab of 
the control toolbar.

Pro tip
Keep in mind that freezing, 0°C, equals 273.15 K.  
It’s also very helpful to memorize a few key refer-
ence temperatures.  Here are a few:
-10°C / 263 K / 14°F	 20°C / 293 K / 68°F
0°C / 273 K / 32°F	 30°C / 303 K / 86°F
10°C / 283 K / 50°F	 40°C / 313 K / 104°F
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the most popular time from the available data.  If 
you wish to override it, you can choose “manual” 
to be prompted for a time each time you generate 
an upper-air product, or you can choose a specific 
numerical time.
* Forecast time.  Controls whether forecast data is 
used.  You should always leave it at “analysis” un-
less you are plotting FD winds aloft data.  Model 
output data valid times are chosen separately.  
Special note: This option will not generate fore-
cast data.  It is only for use with specific fore-
cast products, such as MOS data and FD winds 
aloft.  The forecast time should normally be left 
at its default position, “Analysis”.

Data plot crowding [Workchart tab]
	 This controls the density of station plots plot-
ted on the charts.  Set it to as high of a value as 
possible, but not so high that the charts become 
illegible.  Setting it all the way to the right or 
clicking “all” will set the crowding at 100% and 
plot every available station, which may be useful 
for evaluating how much data is available.

Clock [Workchart tab]
	 The clock panel shows the local and UTC 
time, as obtained from your computer’s time and 
time zone settings.  It is necessary that this infor-
mation is correct for the Data Retrieval functions 
to work correctly.  If the information appears er-
roneous, check our time and time zone settings in 
Windows and set them accordingly. 

GRIB [Workchart tab]
	 This panel is used for importing and display-
ing GRIB data.  GRIB is an interchange format 
for basic meteorological fields, and is currently 
the best way to get forecast data into the program.  
Third party sources provide GRIB data; Weather 
Graphics does not.
	 Use the import button to specify the file 
containing GRIB data.  Check either plot or 
contour, depending on whether you want to see 

gridded values or isoplethed fields.  Use the select 
field button to plot the desired data.
	 Special note: Currently this function only 
works with simple GRIB fields and does not yet 
handle the GRIB2 format.  The GRIB function-
ality is strictly experimental / use at your own 
risk, and is currently being worked on.

Front tab
	 Digital Atmosphere allows for fronts to be 
drawn as an overlay on the charts.  This data may 
either be programmed manually (using this tab) or 
may be imported using the Data > Fronts section.  
Note that Digital Atmosphere has no capability 
to automatically estimate frontal positions.  There 
is currently no method for doing this, and even 

FIGURE 2-3. The fronts tab of the 
control toolbar.
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frontal data imported from NOAA is manually 
generated by human forecasters.
	 Use the view fronts button if frontal data 
has already been generated during this Digital 
Atmosphere session using manual entry or the 
Data > Fronts option.
	 To program fronts manually, click the Start 
New Overlay.  This erases any frontal data 
already in memory and lets you start a new 
session.  The left-mouse-button drag options to 
measure distances and lasso stations for QC will 
interfere with drawing fronts, so you must turn 
them off by using the Drawing Mode Enabled 
checkbox to turn those functions off.  When it 
is checked, then any left-mouse-button clicks on 
a map will signify a frontal position.
	 With drawing mode enabled, click any of 
the buttons Isopleth, Cold Front, Warm Front, 
Stationary Front, Occluded Front, Trough, 

Low, High, and Text to place those features on 
the map.  Never drag on the map to place those 
items!
	 When drawing linear features (isopleth, cold 
front, warm front, stationary front, occluded 
front, and trough), you will click that button 
first to start a new line and then set a series of 
points on the map, preferably between 3 and 6 
points that best define the front or trough.  By 
drawing the points away from the low pressure 
centers, this will automatically point the front’s 
barbs or pips in the proper direction (i.e. draw-
ing a cold front southward will place the barbs 
facing east).
	 When drawing point features (low, high, 
and text), simply click the button of the feature 
you wantand click once on the map.  It will 
then appear and or you will be prompted for the 
text you want to be shown.
	 Currently there is no “undo” function, so if 
you make an error drawing on the map, you will 
need to click the Start New Overlay button and 
start over.
	 The Suspend Highs/Lows checkbox will 
prevent front plot highs and lows from ap-
pearing on the map.  This is useful when you 
are plotting front data from a central source 
(NOAA) and prefer Digital Atmosphere’s analy-
sis to plot the highs, lows, and isobars.

Scripting tab
	 Digital Atmosphere has powerful scripting 
capabilities that allows automation of weather 
charts.  A set of instructions is referred to as a 
“script”, and scripts are executed either manually 
or using a clock-based “scheduler”.
	 The Run... button is used to open a previ-
ously saved script file (*.dsf ) and execute it im-
mediately.  
	 You can also stat a new script file from 
scratch using the Create... button.  You may 
also do this in Windows Notepad, as long as 
script files are saved with the extension “.dsf ”.
	 The Scheduler Is Off/On button indicates 
the status of the scheduler and allows it to be 

FIGURE 2-4. The scripting tab of the 
control toolbar.
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turned on and off.  If it is on, it will trigger the 
execution of script files at the times you select.  To 
turn it on and off, simply click on the button and 
make the change in Enable Scheduler.  You can 
also edit the scheduler in this window.  See the 
appendix for more information.
	 The Schedule list displays which scripts will 
be executed at which time.  The first four digits 
are the UTC time at which the script will be ex-
ecuted.  Following this is the script file that will be 
executed at that time.  Script files are named *.dsf.
	 The Script Command text box allows you 
to directly input one script command to evaluate 
what happens when it is executed.  See the appen-
dix for a listing of valid script commands.
	 The Analysis Command textbox, likewise, 
allows you to directly input an analysis command 
to observe what happens.  This is the same thing 
as typing ANALYSIS,[command] in the Scheduler 
Command window above.  See the appendix for a 
listing of valid analysis commands.

2.3. Status panel
	 Just below the Product Control Toolbar is the 
status panel.  Diagnostic information detailing 
what is going on within the software will appear 
here.  The status panel automatically clears itself 
when the amount of data in it becomes excessive.  
To copy the data to the clipboard, click To Clip-
board.
	 The option Show Memory Use simply ap-
pends memory statistics to each line of status 
output, and is intended to be only for test use.

2.4. Workchart
	 The workchart is the large graphical space 
used to display maps, plots, and contours.

Clicking on the workchart
	 Clicking on the workchart will normally 
have no effect unless Drawing Mode for fronts is 
enabled.  For more information, see above under 
Product Control Toolbar > Front Tab.

Hovering on the workchart
	 As you move the cursor around the workchart, 
the latitude and longitude for the cursor location 
will be continuously displayed on the status bar at 
the bottom of the Digital Atmosphere form.  This 
is shown in both decimal degrees and in degree-
minute-second format.

Dragging on the workchart
	 A drag operation on the workchart will pro-
duce a “marching ants” geographical selection box 
that has a twofold effect:
* Showing distance and azimuth.  You can eas-
ily measure distances and bearings between two 
points.  As you drag on the workchart, the status 
bar at the bottom of the screen will show the cur-
sor latitude/longitude where you started the drag 
operation and where the cursor is now, and will 
also show the bearing relative to true north, along 
with the distance in statute miles, nautical miles, 
and kilometers.
* Defining a quality control location.  Before using 
the Quality Control function (see File Menu) you 
will need to drag a box around a station of inter-
est.  The Quality Control function will display all 
available data within the geographical selection 
box.

FIGURE 2-5. Right mouse button popup  
for the workchart images.
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Workchart popups
	 Right-clicking on workcharts will allow you 
to issue specific commands relating to that posi-
tion on the map.  When you do this, a popup 
menu will appear and you will have the follow-
ing options that apply to the defined location:
* Cursor slaving.  If you have multiple work-
charts open, cursor slaving causes the geographi-
cal location of your cursor to be shown on all 
workcharts at their correct location.  This can be 
useful for resolving a radar feature and com-
paring it with other products.  Normally this 
should be set to “off”.
* Recenter map.  Generates a new map that is 
centered on the geographical location that has 
been clicked.
* Marks.  Marks are small “specks” that can be 
added to the map and referred back to later.  
You can use Set Mark to save the current loca-
tion to the list of marks, and Draw Marks to 
show all marks.  Use Clear Memory to erase all 
stored marks and start again.
* Add Symbol (experimental).  This draws a 
symbol directly onto the map.  Currently only a 
cloud shape can be added.
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3.1. IMPORTANT: About data!
	 Digital Atmosphere is a tool that lets you cre-
ate weather charts using current raw data.  There-
fore, the first thing you need is a tool to get raw 
data into Digital Atmosphere.  We refer to this 
process as raw data import.  Once you import 
data into Digital Atmosphere (via any of the pos-
sible methods explained below), the program will 
continue to retain that data until you perform 
another import operation.  Any new raw data 
import will replace the existing data.
	 There are three primary ways to import raw 
data.  Most of the time you will be using Data > 
Internet Retrieve.  This is easiest.  When you use 
this method, the import operation is done auto-
matically and there is no need to run any of the 
File Import commands.  If you are supplying the 
source data on your hard drive, then you should 
use the Import Specific File or Import Directory 
options.
	 In any case, all raw import source files are 
treated as read-only and are not modified in any 
way.  Even when you perform a new data import, 
only the internally converted data is changed out; 
not the original data file it came from.
 

3.2. Import specific file
	 SPECIAL NOTE: See “IMPORTANT: About 
data!” above.
	 This option prompts the user for a specific 
file containing raw data to manually import.  The 
file will then be decoded and imported.  The data 
file should consist of text bulletins containing 
METAR, synoptic, SAO, FD winds aloft, buoy 

reports, or rawinsonde data.    After the data is 
imported, it can then be plotted or analyzed.
	 Instead of selecting one file, you may select 
multiple files (up to 20) by using Ctrl+click to se-
lect each file, or clicking on one file to set the start 
file and Shift+click to set the end file.  This is use-
ful for importing multiple data types at a specific 
time (such as when you have separate METAR, 
UPPER, and SYNOP data).

3.3. Import directory
	 SPECIAL NOTE: See “IMPORTANT: About 
data!” above.
	 This option will manually import all files in 
the Digital Atmosphere data directory at once.
	 Regardless of the mode that Digital Atmosphere is 
in (scheduled or manual), this command imports 
all files contained in the directory listed on the 
File, Preferences General tab under “Data directo-
ry”.  The data files should consist of text bulletins 
containing METAR, synoptic, SAO, FD winds 
aloft, buoy reports, or rawinsonde data.  After 

3 / File menu
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the data is imported, it can then be plotted or 
analyzed.  This is the command you should use 
if you want to look view data from several files 
at the same time.
	 If you need more detailed information, con-
sult the Appendix for technical information on 
data import.

WARNING
Avoid importing any directories that contain 

binary files, programs, or other unrelated data.  
This may cause Digital Atmosphere to crash.

3.4. Clear data directory
	 This is a utility command that deletes all 
files in the data folder.  Normally it should never 
be used unless you are seeing corrupted plots 
after multiple raw data imports.
	 Clearing the data directory ensures that 
File > Import Directory does not inadvertantly 
retrieve stray files that were placed there by the 
user.  It can also prepare the data directory in 
case the user wishes to place numerous files into 
the directory to be imported.

3.6. Font mode	
	 Text plots (especially station plots) can be 
plotted in one of two modes: as Windows Fonts 
or as NMC/NCEP Raster Fonts.
	 For most routine program use, users should 
use the Windows Font choice.  In that case, the 
exact font name and size will be controlled from 
File > Preferences settings for the workchart 
style.
	 The NMC/NCEP Raster Fonts option 
is highly unique in that it uses character sets 
implemented in the late 1960s by the National 
Meteorological Center on their supercomput-
ers.  These fonts have been extracted from the 
FORTRAN code listings and can be used as 
fonts in Digital Atmosphere.  This not only pro-

vides “official” looking charts but also provides 
high-visibility plots that are especially suitable 
for faxes and photocopies.

3.7. Get archived data
	 (Experimental) This function is designed to 
directly access optional Total Archives histori-
cal datasets in the computer’s DVD drive.  This 
capability was developed in 2006 and is now 
outdated.  Furthermore it needs to be updated 
for use with the new Global Archives dataset.

3.10. Print
	 This option will print your currently active 
map.  It’s that easy!  If you want to make chang-
es in the way that the map is printed, you’ll need 
to use Print Setup, listed below.  Print sends an 
exact copy of the screen image to the printer, 
so if the printouts are too dark, you will need 
to change your map settings in Preferences and 
regenerate new maps (preferably with white 
backgrounds), then print those.  Also keep in 
mind that many PostScript printer drivers will 
allow you to set the printer to produce negative 
printouts.
	 If the maps are too dark, you should avoid 
using solid colors.  Regenerate your maps with-
out topography or ocean fills.  Topography is de-
signed mainly for screen viewing.  If you abso-
lutely must have dark maps on-screen and can’t 
force your printer to produce acceptable output 
(either through File, Print Setup or through the 
printer’s own setup menus), you will need to ex-
port the map and then use a photo-editing type 
graphics program (such as Photo Shop or Paint 
Shop Pro) to make a negative image or enhance-
ments that allow for better printouts.
	 If the printer shows memory errors, this 
means that the graphic you are sending to the 
printer is too large to fit into the printer’s mem-
ory.  The easiest way to remedy this is to go to 
File, Print Setup and choose a portrait printout 
rather than a landscape printout.  Another solu-
tion is to regenerate your charts without using 
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any color fills or topography (i.e. totally composed 
of line graphics).  The third method of solving a 
memory problem is to use a lower resolution (i.e. 
choose 600 dpi rather than 1200 dpi, or 300 dpi 
rather than 600 dpi in your printer setup).  The 
final and best solution is to increase the amount 
of RAM in your printer by installing a SIMM 
memory module.  Your printer will require a total 
minimum amount of 2 MB of RAM, but will 
work best with 4 MB or more.
	 Around 2003-2005 some users reported 
problems printing to HP LaserJet and a couple of 
other printers (such as getting blank pages).  This 
is usually a problem with the Windows PCL 5 
print driver and is beyond the control of Digital 
Atmosphere.  Solutions for this that have been 
documented are changing the resolution from 600 
to 300 dpi or change the print mode from “vec-
tor” to “raster”.  If your printer is equipped with a 
PostScript option, always use the PostScript mode 
for 600-dpi printing.  Overall, this printing prob-
lem is not specific to Digital Atmosphere and may 
occur with other applications that make extensive 
use of the PCL driver.  Also note that for some 
HP printers, PCL6 fixes the problems.

3.11. Print Setup
	 This function is used for specifying how you 
want your printer to print maps.  These panels 
will vary based on what type of printer you are 
using.  One option that is useful for some printers 
is the “Graphics Resolution”.  When you lower 
this value, it will help you send extremely detailed 
charts to printers that keep producing “out of 
memory” errors or blank pages.

3.12. Station tables
	 When you import weather observations, Digi-
tal Atmosphere refers to a special, internal listing 
of all of the weather stations.  Starting in 2010 
the storage format for this table was extensively 
revised and updated, and organized into a struc-
tured format called the Master Location Identifier 

Database (MLID).  It uses the latest identifier 
updates from the FAA, ICAO, and WMO.
	 After several years of development, the MLID 
was was finally added to Digital Atmosphere in 
December 2014 with Version 2.12.  The old for-
mat (where ICAO appears in Columns 1-4) is no 
longer supported.
	 Some users may prefer to delete stations or 
add unofficial observing stations from their own 
network which report in METAR or SYNOP.  
Users may directly edit the Master Location 
Identifier Database, but this is not recommended 
because it is designed to be overwritten when 
Digital Atmosphere or the MLID version is up-
dated.  To keep your changes from being lost, we 
are implmenting an “overlay file” solution.   This 
is a file that Digital Atmosphere uses to modify 
the MLID listings after it has been loaded.  Your 
overlay files can be kept permanently without 
fear of loss, allowing you to use any version of the 
MLID with a permanent set of changes.

Editing the overlay file
	 (Under development -- this has not yet been 
added but is a high priority item)
	 Load the overlay file into any text editor.  If 
you don’t have one, follow the format in the 
digatmos.lid file as a guide.  Column 15 is used 
for signaling whether a row in the overlay deletes 
something in the master station list or adds/re-
places a station.
* Delete a station: in column 15, enter DEL or 
DELETE and signify the identifier that is to be 
removed.  It will be searched for in MLID column 
16 (ICAO), 19 (FAA), or 22 (WMO).  No other 
data needs to be entered.
* Add a station: in column 15, enter ADD.  
Make the appropriate entries throughout the row.  
Note that column 16, 19, or 22 will be used by 
Digital Atmosphere to obtain the identifer, not 
columns 10-14.
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3.13. Preferences
	 Here’s where you set your preferences for 
how the program will operate.  Any changes you 
make are used only for the duration of the pro-
gram’s execution, unless you place a check mark 
at the bottom of the dialog, in the box named 
“Save as default settings”.  If you check this box, 
the entire set of preferences is saved to your 
registry (HKEY_CURRENT_USER\Software\
DigAtm2015) and will be used each time you 
run the program.  Advanced users can manually 
delete the HKEY_CURRENT_USER\Soft-
ware\DigAtm2015 with Windows REGEDIT if 
there is a need to “factory reset” all preferences.
	 The preferences menus are divided up into 
several sections, each of which may be accessed 
by clicking once on the tabs at the top of the 
dialog box.  Just click on the tab correspond-
ing to the settings you want to change to switch 
between preference pages.
	 For more information on each Preferences 
item, please consult the chapter at the end of 
this manual, titled “Preferences Settings”.

3.14. Exit
	 Exits Digital Atmosphere.  The background 
map will be saved and it will automatically ap-
pear the next time you run the program.  For 
many dialog boxes that were open, the directory 
they used will be memorized.  The last data set 
you imported will continue to be available.
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About the Master Location Identifier Database

	 The new station table is maintained in master-location-identifier-database.
csv in your Digital Atmosphere data directory (to see where this is, check Help 
> About).  This table is in csv (comma-delimited) format.  The format is called 
MLID (Master Location Identifier Database) format.  Further information and 
new data can be found at: http://www.weathergraphics.com/identifiers/.
	 Although you can make direct modifications to the internal MLID station 
list to add new stations or your own custom station sets and recompile them, it is 
strongly recommended that you do not do this since Digital Atmosphere is pro-
grammed to use two forms of location identifier files: a master file and an overlay 
file.  The overlay file is a separate file in the same MLID format that modifies the 
master file using add and delete commands. This means you can maintain your 
own overlay data, and Digital Atmosphere will automatically apply your overlay 
after any MLID updates are processed.
	 It is important to mention that the MLID format was developed by Weather 
Graphics to allow both forward and reverse lookups of stations so that it can be 
used accurately with old datasets.  For example Denver Stapleton Airport (KDEN) 
closed in 1995 and its identifier was reassigned to Denver International Airport 
about 15 miles away.  To accurately locate the station on a map, Digital Atmo-
sphere looks up KDEN, consults the Start/End columns, and uses the date to 
determine which row (and thus which coordinate) applies for KDEN.
	 The identifiers for all new stations are notated in the primary columns (16 
through 29).  If the station is current, also add it in the crossreference columns 
(10 through 14), and enter “m” in the Status column (15).  If it is old (histori-
cal) then the crossreference columns should indicate the location’s current identi-
fier information, if available.  If none exist, for example all observing activity has 
ceased, then no identifier goes in the crossreference columns.  If the crossreference 
identifier differs from the primary identifier, then use the Start and End columns 
(42 through 45) to specify exact or approximate dates for this row using the format 
yyyy, yyyymm, or yyyymmdd (do not vary from this method) such as 19961225 
for Christmas 1996.  It is also recommended you enter x in the status column (15) 
to indicate the row contains obsolete data and that this is a historical entry.
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4.1. Erase Map
	 Before you make annotations, plots, or con-
tours on your map, Digital Atmosphere retains a 
copy of the original map image in case you want 
to start with a blank slate.  Use this command 
whenever you want to erase weather data from the 
map.

4.2. Load Map
	 Loads a workchart from your disk drive.  You 
will need a previously-saved workchart (which can 
be saved using the Save Map command).  Load 
Map loads images that are Windows bitmaps (file-
name *.BMP), and it also expects to load a map 
attribute file with the same name (*.ATR), which 
contains data about the image’s latitude, longi-
tude, and zoom setting.
	 If this map attribute file is not present, you 
will get an error.  This is why you cannot substi-
tute a BMP satellite photo as a map, unless you’ve 
already created an corresponding binary ATR file 
that contains the proper attribute settings valid for 
that photo (not a job for the fainthearted).

4.3. Save Map
	 Saves the workchart for future access within 
Digital Atmosphere.  This also saves any markings, 
annotations, weather data, and contours that are on 
the map already as a permanent part of the map, so 
if you intend to load this map later without any 
weather data, you’ll need to use the Erase Map 
command to get rid of the data  before you save 
it.  Save Map produces one image file (a Windows 
bitmap, *.BMP) and a very small map attribute 
file (*.ATR).  The ATR file is necessary to load the 

map into Digital Atmosphere and should stay in 
the same directory as the BMP file.
	 An important consideration is that only 
Windows bitmap (BMP) files can be saved, and 
they are rather large.  File sizes can range any-
where from 300 to 700K in 8-bit color mode to 
2.5 megs in 24-bit color mode.  So avoid saving 
too many unless you have plenty of disk space.  If 
you’re using on-the-fly disk compression (such as 
Stacker, DoubleSpace, DriveSpace, etc), these im-
ages will take up about 80% less disk space than 
they do when uncompressed.
	 Once the *.BMP file is saved, you are free to 
use any graphics editor to tweak or annotate the 
image.  Note that you must re-save it as the same 
type of graphics format it was in (a BMP with a 
color depth of 24 bits), or Digital Atmosphere 
may produce an error when it attempts to load the 
image.

4.4. Generate Map
	 There are three ways to generate a map.  The 
easiest method is to use the “Generate map” drop-

4 / Map menu
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down box on the speed button toolbar and pick a 
country or continent.  For those that want more 
accuracy, these two selections will provide greater 
control of map generation.

Enter station
	 If you know the station that you want to cen-
ter you map on, you can simply enter it here.
* Station.  Enter an ICAO code, WMO code, 
IATA code, or partial station name.
* Map width.  Sets the width of the map in miles.
* Map size.  Allows you to specify how many 
screen pixels wide and tall you want the map 
image to be.  You may also wish to choose one 
of the map size quick-pick buttons.  If you want 
an exceptionally detailed image, you may want 
to choose one of the higher settings.  The 1550 x 
1150 size yields excellent printed maps that are 
suitable for publishing.  If this image size is larger 
than the screen, you will be provided with scroll 
bars to roam around the image.  However, note 
that large maps place a burden on your computer’s 
resources, and too many large maps open at the 
same time may cause warnings or errors.  Avoid 
setting sizes larger than 2000 pixels.

Enter lat/long
	 This is a powerful tool that replaces the map 
contained within the selected workchart with 
another map.  Once you choose this command, 
you’ll see a settings panel appear.  This is where 
you choose how your map should look.  All maps 
are generated using an orthographic (“satellite 
view”) projection.
* Latitude.  Sets the latitude for the center of the 
screen in degrees.
* Longitude.  Sets the longitude for the center of 
the screen in degrees.
* Scale.  Sets the width of the map in either miles 
or kilometers.
* Map size.  Allows you to specify how many 
screen pixels wide and tall you want the map 
image to be.  You may also wish to choose one 
of the map size quick-pick buttons.  If you want 

an exceptionally detailed image, you may want 
to choose one of the higher settings.  The 1550 x 
1150 size yields excellent printed maps that are 
suitable for publishing.  If this image size is larger 
than the screen, you will be provided with scroll 
bars to roam around the image.  However, note 
that large maps place a burden on your computer’s 
resources, and too many large maps open at the 
same time may cause warnings or errors.  Avoid 
setting sizes larger than 4000 pixels unless testing 
shows there are no problems.
* Location quick-pick.  Click on any of these but-
tons to automatically set an appropriate latitude, 
longitude, and scale for a commonly-used region.
* Zoom quick-pick.  Click on any of these buttons 
to automatically set a map scale based on a me-
teorological scale type.  Global scale sets a width 
of 8300 nm, synoptic scale 4000 nm, subsynoptic 
scale 3000 nm, meso alpha scale 1500 nm, meso 
beta scale 700 nm, and meso gamma scale 200 
nm.

4.5. Blank Map
Creates a workchart with no background map.  
Projection data from the last workchart is used.

4.6. Import map from file
	 This option imports a graphic from an image 
file, replacing the existing map graphic.
	 IMPORTANT: Map positioning will remain 
unchanged, because there is no practical way to 
read the map and estimate lat/long and projection 
information.  This option is designed to be used 
for very special cases, such as when you have care-
fully matched up a Digital Atmosphere base map 
with a pre-existing satellite image and wish to load 
the satellite data in.

4.7. Import map from URL
	 This imports a map from an Internet URL, 
similar to “Import map from file” above.  The 
same caveats apply.
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4.8. Import shapefile
	 Imports map data from a shapefile, which is  
a geospatial vector data format.  Using Internet 
searches you can find all kinds of useful geograph-
ic shapefiles for your area that may be applicable 
to your forecasting work (power grids, FAA center 
boundaries, and so forth).  It is important to 
remember that shapefiles (.shp) are always paired 
with a database file (.dbf ) and index file (.shx) 
of the same name, and they need to reside in the 
same directory as the shapefile.
	 Also the shapefile must use latitude/longitude 
coordinates.  WGS84 is not acceptable.
	 When you import the shapefile, you will 
be shown an attribute selection dialog, which is 
necessary to tell Digital Atmosphere which fields 
contain the latitude and longitude information.  
Here you can also set the color of the line to be 
trawn.  In most cases you can leave all the drop-
down boxes to their default positions “(none)”, 
but with some files you may need to override this 
to indicate which fields contain the data.
	 You may also fine-tune your display by choos-
ing to display only shapes that have specific at-
tributes, such as in the case of a shapefile of NWS 
warning areas, you may only want to display a 
shape where WFO equals OUN, so that only the 

Oklahoma City warning area shows on the map.  
Or you may want to use this in a shapefile of road 
data to make different kinds of roads appear dif-
ferently.  This is done in the Attribute Selection 
Dialog under the “Plot Specific Features Only” 
panel.  Choose the attribute, the operator (equals 
or does not equal), and the desired value.  If you’re 
unsure what to pick, open the shapefile DBF file 
in an editor that handles .dbf format (Microsoft 
Excel is good for this) and examine the rows.
	 Since the shapefile drawing process is some-
what slow with larger files, we encourage you 
to use “Map > Copy Markings Onto Basemap” 
after you’re done, so that they remain part of your 
workchart even after you erase the data.
	 Shapefiles can be obtained from many sources, 
including the US Census Bureau, state geological 
and natural resource agencies, and other govern-
ment agencies.  If they are zipped, always be sure 
to unzip them into a directory first before at-
tempting to import them; the ZIP packages will 
not be recognized.

FIGURE 4-1. Road overlays (dark 
lines) from 2010 US Census 
Bureau TIGER/Line shapefiles, 
combined with radar imagery.  
These shapefile datasets can 
downloaded from the following 
link (be sure to unzip all files be-
fore rying to import them): http://
catalog.data.gov/dataset?res_
format=shapefile
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4.9. Copy markings onto base-
map
	 If you choose this option, absolutely all 
markings, plots, and data becomes part of 
your basemap permanently, even if you choose 
Erase Map.  The markings will persist until you 
replace it with a different map through a Load 
Map or Generate Map operation.

4.10. Copy chart to clipboard
	 This is the easiest way of transferring a 
workchart to another software program.  When 
you choose this, the workchart is placed in the 
Windows clipboard.  From there, you can paste 
it into any of your favorite graphics programs.

4.11. Export chart
	 This command is exactly identical to Save 
Map, except that no map attribute file (ATR) 
is saved.  Therefore it is designed for your own 
projects, presentations, or reports.  The output 
format can be selected under “Save as type”.  
Default JPEG compression settings can be 
altered in preferences, under File > Preferences > 
Map.
	 Here are the different supported filetypes.  
Since Digital Atmosphere produces graph-
ics that are similar to monochromatic line art,  
non-lossy formats will always give the best 
results.
* GIF (Graphics Interchange Format).  Non-lossy 
format that produces the smallest file.  This is 
often the best choice for saving charts.
* PNG (Portable Network Graphics).  Non-lossy 
format similar to GIF; good compression.
* JPG (JPEG).  Lossy format that yields excel-
lent compression, but is not as crisp.  The most 
widely used format.
* BMP (Windows bitmap).  Non-lossy format 
native to Windows.  It does not work well in 
browsers and produces bloated filesizes; creates 
24-bit files (may not be suitable with Windows 
95 era programs which expect 8-bit files).

4.12. Cursor city distance
	 If this is enabled, the nearest city, direction, 
and distance will be shown corresponding to the 
geographical coordinates at the cursor location.  
This only works in the United States.  CPU load 
may increase slightly while this is enabled.
	 To disable Cursor City Distance, click this 
option again so the menu checkmark disappears.

4.13. Map information
	 Displays detailed information about the 
map currently shown.  Included is the map 
width and height (in both pixels and nautical 
miles), the center latitude/longitude of the map, 
and the corner latitude/longitude points.  All 
negative latitudes indicate the southern hemi-
sphere, and all negative longitudes indicate the 
western hemisphere.

4.14. Set comment
(Under development)

4.15. Make topography
Renders a topographic representation (terrain 
features) of the Earth on your map projection.  
After the topography is drawn, Digital Atmo-
sphere then re-overlays the basic geography data.  
The topography draw operation may take a few 
minutes on slower computers.

4.16. Add Overlay
	 The overlay options allow you to add addi-
tional geographic datasets as follows:
* Basemap: Redraws the workchart basemap 
without erasing the contents of the workchart.
* Point: Overlays a specified point on your map.  
You can also load or save a point plot list. 
* City: Overlays predefined city marks and labels 
onto your map as a reference (see table in mar-
gin for formatting and location).
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* County outlines:  Overlays United States coun-
ties, parishes, and certain city border information. 
* County names: Overlays the names of the coun-
ties.  The names are truncated according to the 
zoom factor so that they fit within the county.
* Highways: Overlays United States interstate 
highways onto the map.
* Secondary highways: Overlays United States 
U.S. and state highways onto your map.  This is 
a detailed process and may take a few minutes 
depending upon your computer. 

4.17. Annotations
* Change credits: (Under development)
* Change title: (Under development)

City overlay format

For city overlays, you will need to define the cities you 
want drawn by editing the file DIGATMOS.CIT with any 
text editor.  The columns used are as follows:

1-2	 Latitude of city in degrees
3-4	 Latitude of city in minutes
5	 N or S latitude sign
7-9	 Longitude of city in degrees.
10-11 	 Longitude of city in minutes.
12	 E or W longitude sign
14-33	 Name of city as you want
	  it to appear

	 The DIGATMOS.CIT file contains some default 
cities that are formatted per the above specifications, 
which you may find useful to refer to as a template 
when adding new cities.
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	 Before you use any of these commands, you 
will need to make sure there is an active Internet 
connection.  Note that Digital Atmosphere has 
only very limited support of proxy servers, so 
if you encounter problems, you’ll have to use a 
regular browser to obtain the data, then save it 
and import it manually into Digital Atmosphere, 
or script it with a specialized web download utility 
such as wget.
	 If you are new to using the Internet and need 
some basic information, see the section on getting 
data at the end of this manual.

5.1. Retrieve data
	 This module retrieves alphanumeric data 
through the Internet and saves it to your hard 
drive.  When the data download is completely 
finished, Digital Atmosphere will import the data 
for you.  This means you can immediately begin 
plotting and analyzing.
	 To use Retrieve Data, you must have a con-
nection to the Internet.  If you can’t get any of the 
download links to work, firewalls and antivirus 
programs might be blocking Digital Atmosphere.  
Make sure Digital Atmosphere is running and 
check Windows under Control Panel > Windows 
Firewall > Allow A Program > Allow Another 
Program and find Digital Atmosphere in the list 
and Add it.  If you have a proxy server, enter any 
necessary proxy host information in Preferences 
> Misc.  Also check your system time and time 
zone, since some of the product URLs are date-
time dependent.
	 When you select Retrieve data, you will be 
presented with a dialog box containing a list of 
weather data products where you can check off 
the items you want to download (see illustra-

tion) from a product list.  Normally you will only 
choose one or two products.  A common favorite 
is METAR data from Albany.
	 Once you press Retrieve, the chosen products 
will be downloaded and stored in your data direc-
tory.  Then you can use File, Import Directory to 
see the results.
	 Since Internet sites often change, you can fully 
edit the list of products and data directly from this 
dialog box by highlighting the item you wish to 
change and clicking the Edit Site button or the 
Delete Site button.  You can also add a new site 
by clicking the Add Site button.  You will then be 
prompted to enter the site name and URL for the 
data.
	 Many sites, especially for surface and upper 
air data, have a filename that is dependent on the 
Greenwich Mean time of the observation.  To 
support this, Digital Atmosphere lets you insert 

5 / Data menu
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time tokens into a filename.  For example, if 
you entered a product that had a URL address 
of http://www.weatherdata.com/@Hdata.txt, 
Digital Atmosphere would automatically substi-
tute the current UTC (GMT) hour in place of 
the @H.  So if it was 9 pm EST (02Z), Digital 
Atmosphere would retrieve http://www.weather-
data.com/02data.txt.
Here is a complete list of all the UTC time 
token combinations you can use:

Character 1 - mode
@	 This hour
$	 Last hour

Character 2 - time
M	 Month
D	 Day
H	 Hour
X	 Radiosonde hour
	 (rounds to 00 or 12 UTC)
S	 Main synoptic hour
	 (rounds to 00, 06, 12, or 18 UTC)
I	 Intermediate synop hour
	 (rounds to 00/03/06/09/12/15/18/21 UTC)

	 Although Digital Atmosphere automati-
cally figures the current time tokens before you 
retrieve data, you may want to override them.  
This is handy if you want to see data for an 
earlier hour.  All you have to do is change the 
numbers that are displayed in the time token 
panel.
* Solving incorrect time problems.  If the time 
tokens always show a slightly incorrect hour, 
check your Preferences menu under the Gen-
eral tab and make sure the “Daylight Saving” 
checkbox is marked in accordance with whether 
daylight savings time is in effect.  If the hours 
are significantly off, go to your Windows control 
panel, look under Date/Time, and make sure 
your computer is set to the correct time zone.  
Then make sure your system clock is set to a 
current time which is valid for that time zone.  
For example, if you live in New York and typi-
cally have your computer clock set to Greenwich 

Mean Time, you will have to set the Windows 
time zone to “GMT” rather than Eastern Time.
* Solving access problems.  Digital Atmosphere 
must have access to a regular Internet network 
(Winsock)  in order to retrieve data.  If for some 
reason you can’t retrieve data through Digital 
Atmosphere, all is not lost.  You can still use 
your Internet browser to get products, then save 
them to your Digital Atmosphere data directory.  
More adept users can use retrieval utilities like 
wget (http://gnuwin32.sourceforge.net/ under 
Packages and WGet) to script the download of 
data and call Digital Atmosphere to import it on 
startup using a script.
* Technical tip.  Do you want to swap data 
product lists with other users?  No problem; 
we’ve made it easy.  Simply give them a copy of 
your DIGATMOS.SLZ file (it’s in your Digital 
Atmosphere directory).  If they replace their 
DIGATMOS.SLZ file with yours, they’ll get 
your list of data products.  We sometimes offer 
updated DIGATMOS.SLZ files on our web site 
to give you the latest set of data products.

5.2. Quality Control
	 If you’re a newcomer to meteorology, you’ll 
quickly discover that not all weather data is 
100% accurate.  Errors can get into raw weather 
data either through transmission problems, 
communications interference, human error, 
or simply the observer hitting the wrong key 
when typing up the report.  These can either be 
unnoticable or may corrupt an analysis.  For-
tunately, Digital Atmosphere provides a tool to 
help fix the problem.
	 When you are looking at a chart and see 
a station reporting bad data, you will need to 
right-click once just to the top left of the sta-
tion, then choose “Set QC corner” on the 
popup menu.  Move the mouse to the bottom 
right of the station and repeat the procedure.  
Next, click on File, then on Quality Control.  
You’ll see a panel showing all of the meteoro-
logical data at that station.  Change the values 
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to whatever is appropriate.  Always use a value of 
-9999 to indicate missing, unusable data.
* Accept Entry — Saves the report as shown, in-
cluding any modifications you might have made.  
Once you hit Accept Entry, all changes become 
permanent.
* Ignore Changes — Ignores any changes that 
you’ve made to the report and moves to the next 
one.
* Delete Report — If the individual report is so 
corrupted that you know you won’t want to use 
it, you’ll probably want to delete it.  This is the 
button to use.
* Stop Search — Stops sifting through the file, 
saving any values that you’ve already entered.
	 Note that QC displays all data within the 
bounding box (even if it.s filtered out on the 
map), so you may need to press .Accept entry. nu-
merous times until you find the station you want.  
One way of avoiding this problem is to make the 
initial QC box as small as possible so that you get 
only the station you want.
	 Since QC changes the internal cached data in 
Digital Atmosphere, you will lose your changes if 
you reimport the original source data.

	 Digital Atmosphere maintains a database of 
numerous monthly weather parameters for over 
2,000 weather stations across the world.  Most 
of this archive spans a 30-year time period.  This 
data can be viewed on a graph or plotted on your  
maps.
	 Keep in mind that, as with most other meteo-
rological data, the results may be affected by the 
observing station’s elevation or proximity to the 
ocean.  This is why you may see significant varia-
tions in temperature along a coastal region, among 
other effects.

5.3. View Raw Data
	 Sometimes you will want to go back and look 
at the original data.  Program users may wish to 
review observations for vital clues (such as observ-

er remarks), as well as look through any other data 
embedded in the data files.
	 The file that is viewed is the internally-saved 
clean data file produced by the most recent File Im-
port or Data Retrieve command.  The original raw 
source file is not referenced and does not have to 
be present.  If you don’t like this interface, you can 
view the same data file (DATA.USR in the Digital 
Atmosphere directory) using any text editor.
	 The View Raw Data panel also has a .Find. 
function that lets you search for stations and key-
words in the file.

5.4. Troubleshoot data
	 This interface shows at a glance which datasets 
are available from the most recent import opera-
tion. If a dataset is shown as empty, it cannot be 
plotted. Note that some data may be shown which 
does not really exist, due to wide variations in 
coding formats. You should consult this to check 
on any problems before reporting a problem 
about data not plotting. If no data is shown, check 
your source, the URL it came from (if any), and 
make sure the system clock settings are correct 
on your computer since some products are time-
dependent.
	 Protip (US users): if you are still not getting 
data and have tried everything, check the National 
Weather Service Telecommunications Gateway 
outages page at: http://weather.noaa.gov/tgstatus/ 
for messages.  On rare occasion there may be data 
outages.

5.5. Data Plots
	 This option is provided near the top of the 
menu, since it’s one of the functions you’ll be 
using most.  What it does is draw station plots, 
which are symbolic representations of the weather 
data at each station.  You can check on how they 
are currently laid out and modify their appearance 
in the File > Preferences section.
	 If the station center represents sky condition 
(the default preference), a red station plot indi-
cates instrument flight rules (IFR), which means 
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the ceilings are below 1000 feet and/or the 
visibility is below 3 miles.  A blue station plot 
indicates marginal visual flight rules (MVFR), 
meaning the ceiling is below 3000 feet and/or 
the visibility is below 5 miles.  These colors are 
good for helping you visualize areas of low ceil-
ings and visibility at a glance.

5.6. Custom Data Plots
	 You can use this to plot custom datasets on 
your screen.  These can originate from Digital 
Atmosphere’s Climatology module or from your 
own sets of data!  The density of these graphical 
plots is determined by the settings in Prefer-
ences, Station Plots.
	 The source file for custom data plots is 
always CUSTOM.DAT, located in your Digital 
Atmosphere directory (even if the source of data 
is climatology).  Here is an example of what the 
format looks like:
APR LOWEST PRESSURE 
US AL:Bir 722280    33.567    -86.750   2951 
US AL:Hun 723230    34.650    -86.767   2946 
US AL:Mob 722230    30.683    -88.250   2956 
US AL:Mon 722260    32.300    -86.400   2957

	 The first line is used as a map legend title, 
and the lines following that are actual data 
groups.  The columns must be organized as 
follows, and data must be left-justified into its 
respective column or it will not plot (i.e. putting 
a latitude in columns 23-25 will not work, but 
it will if it is shifted to column 21-23).
* Column 1-10: City name (not used at this 
time; you may omit it)
* Column 11-20: WMO block (not used at this 
time; you may omit it)
* Column 21-30: Latitude in decimal degrees 
(not minutes or seconds; negative is south hemi-
sphere)
* Column 31-40: Longitude in decimal degrees 
(not minutes or seconds; negative is west hemi-
sphere)
* Column 41-50: Data value at this location

5.7. Television plots
	 “Television plots” are large, simple displays 
- similar to what you might see on television - 
of the temperature at predefined cities.  Each 
plot is made up of a temperature value and a 
city name.  The use of Celsius or Fahrenheit is 
controlled in File, Preferences under the Meteo-
rological tab.  The font is controlled in File/Pref-
erences under “Fonts”, and the color is specified 
by the setting on the “Maps” tab under “Plots, 
text, and contours”.
	 The television plots are controlled by the file 
DIGATMOS.PLL.  It contains an ICAO and 
WMO that correspond to the city (either may 
be left blank).  There can be up to 500 entries.  
The format is as follows:
Column 1-4		  ICAO of the station
Column 6-10		  WMO of the station
Column 12-61		  City name 

5.8. Warnings
	 (Under development)
	 Overlays National Weather Service flash 
flood warnings, winter storm warnings, severe 
thunderstorm warnings, tornado warnings, se-
vere thunderstorm watches, and tornado watch-
es.  You must have original National Weather 
Service warning bulletins on your system and 
stored in your data directory.  The directory and 
import mode specified in Preferences, Ingest 
method is critical to finding the warning files.
— If Normal Import Mode is on, Digital 
Atmosphere will look in all files in the Manual 
Import Mode Data Directory to locate warnings 
(make sure it is set correctly).
— If Automatic Import Mode is on, Digi-
tal Atmosphere will look only in files meeting 
the filename convention used by EMWIN 
(e.g. WSW*.*, FLW*.*, FFW*.*, SVR*.*, and 
TOR*.*).  If you are not using EMWIN but are 
in automatic mode, simply name your data file 
TORN.TXT.
	 Once you see the warnings on the screen, 
you can view the text for any of the warnings by 
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right-clicking on or near the county and choos-
ing “Identify Warning”.  Do not display multiple 
screens with warning data if you intend to use 
Identify Warning.
	 There may be some warnings that Digital 
Atmosphere is unable to process, most likely due 
to unusual text formats.  It’s always best to use the 
overlay as a first-guess, and if you have a critical 
need to study the current warnings, refer back to 
the original data files that you captured.  If you 
find a warning that doesn’t plot correctly, please 
pass it on to me (preferably via E-mail) and I’ll 
adjust the program to plot it (and others like it) 
correctly.

5.9. AMDAR Plot
(Under Development)

5.10. Fronts
	 This option allows plotting of georeferenced 
fronts, highs, and lows. The features are georef-
erenced, therefore you can always plot them later 
even if you zoom in or quit the program. You will 
lose your frontal depictions if you again create a 
depiction or if you import original ASUS1 data.
	 Using original sources of data. Raw sources of 
data consist only of the ASUS1 KWBC numerical 
text bulletin produced by the National Weather 
Service. This bulletin must have been imported 
and found with its headers intact before it can be 
plotted. The bulletin is usually found on Uni-
data servers under data/surface/front or a similar 
directory, or by the bulletin header name itself. 
A couple of links are provided in Digital Atmo-
sphere’s Internet > Retrieve Data window, which 
should be used if possible. 
	 If you prefer to create your own frontal analy-
sis, use the “Fronts” tab on the control toolbar on 
the left side of the screen (see Chapter 2, Control 
Toolbar).

5.11. Fleetcode
	 Imports FLEETCODE format data. It pro-
duces graphics like those shown below. All fronts 
and isobars are plotted as spline curves, and due 
to the limited resolution of the data they may not 
display optimally. There is no way to alter how 
a spline plots except to change the scale of the 
workchart.
	 To the author’s knowledge, FLEETCODE 
data is produced only for Europe. It comes in 
under the ASXX21 Family of Services header. 
One source ready for use is provided in the default 
Internet tables.

5.12. Sferics
	 Europe’s primary lightning network consists 
of five stations in the UK, one in Cyprus, and 
one in Gibraltar. The stations listen for static and 
use triangulation of the time delay to pinpoint 
the location. This is encoded to the nearest half-
degree, yielding a resolution of about 40 km. The 
commonly-available British bulletin (SFUK) has 
a domain of 40W to 40E and 30N to 70N. The 
time period for each bulletin is 30 minutes, and a 
new bulletin is generated every 30 minutes. The 
SFUK is based on the WMO FM 32-I SFLOC 
code form but is adapted under a national varia-
tion. The British Met Office does have a new 
system online that can pinpoint lightning within 
100 meters, however this data is not publically 
distributed. Contact the Met Office if you need 
access to this data.
	 Using this information, Digital Atmosphere 
will plot lightning strikes to the nearest half-de-
gree (about 40 km resolution).
	 Special note: Europe imposes restrictions on 
the commercial use of lightning data and recovers 
its cost through end-user charges. Though SFLOC 
data is publically available, you must contact the 
data supplier to inquire about your status if you 
are using the information on a commercial basis. 
The responsibility rests with the user to ensure 
that they are not violating any rules or national 
regulations. The SFUK bulletin’s point of contact 
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is the British Met Office (http://www.meto.gov.
uk / tel. +44 (0)1392 885680).

5.13. Convective Outlooks
	 This option plots convective outlooks 
(thunderstorm forecasts) issued by the National 
Weather Service’s Storm Prediction Cen-
ter (SPC) in Norman, Oklahoma. These are 
centralized human-produced forecasts issued 
several times a day, and are used to help provide 
guidance to National Weather Service forecast 
offices. They are also used frequently by storm 
chasers, pilots, and hobbyists.
	 To use this option, you must have imported 
a convective outlook as part of your raw data set 
or from one of the choices in Internet > .
	 Advanced users can modify the color scheme 
by changing the contents of the file DIGAT-
MOS.CCC in the Digital Atmosphere directory 
using a standard text editor such as Notepad 
(never use a word processor such as Microsoft 
Word or you will corrupt the file). This file con-
tains self-explanatory instructions for modifying 
the hexadecimal numbers used to determine 
colors of the various threat boundaries.
	 If there are any problems ingesting a bul-
letin, the problem is most likely an error in the 
composition of the bulletin. It is not necessary 
for the header to be intact, but the “STORM 
PREDICTION CENTER” title must appear in 
the bulletin along with the convective outlook 
type, valid times, and standard bounding loca-
tions of each threat area.

5.14. Hurricane tracks
	 Plots hurricane tracks from the National 
Hurricane Center (NHC) or Joint Typhoon 
Warning Center (JTWC) forecast/advisory bul-
letin (WTNT, WTPZ, WTPN, WTIO, and 
WTXS). This shows the current and forecast 
location of hurricanes, typhoons, and tropical 
storms. A track connecting each forecast point is 
created using a mathematical spline.

	 The source bulletin needs to be the NHC 
forecast/advisory or JTWC warning with co-
ordinates and forecast positions. They can be 
automatically downloaded via the Internet > 
Retrieve panel. If there is any problem with a 
bulletin not plotting, it may be due to an error 
in the way the bulletin is written. Decoding 
these bulletins into machine-readable format is 
not always error-free.
	 Currently there is no support for bulletins 
from other global hurricane centers.
	 Technical information: The import module 
locates hurricane bulletins based on the Na-
tional Hurricane Center header (KNHC) or 
the Joint Typhoon Warning Center header, and 
saves them to the queue.hur holding file. When 
Data > Hurricane Tracks is requested, the hur-
ricane module reads queue.hur and displays any 
available bulletins.

5.15. Sounding
	 This function allows you to display a sound-
ing (a SKEW-T diagram, or graph of the vertical 
structure of the atmosphere above a point) for a 
chosen station.  You must have already imported 
upper air (rawinsonde or FD) data.  You will be 
prompted to enter the WMO or ICAO for the 
station that you want to view.  The “Rescale” 
button resizes the SKEW-T window to its nor-
mal size (unstretches it).
	 If you do not know the WMO or ICAO 
you want to use, you can simply right-click on 
any horizontal map window and choose “Dis-
play SKEW-T”.  Digital Atmosphere will locate 
the closest rawinsonde observation and plot the 
sounding for you.

5.16. Cross section
(Under Development)
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5.17. Extract model data
	 This command extracts various elements from 
NGM and ETA output bulletins which have been 
imported.
	 Prior to using this command, you must use 
the status panel to (1) choose the desired Forecast 
Hour, and (2) to select the model you want (un-
der Active Level). The extracted data is saved into 
a custom data file. Then you may use Overlay, 
Custom Data or Analyze, Custom Data to plot 
or contour that data element. For more details on 
custom data files, see Overlay, Custom Data in the 
“Overlay Commands” chapter.
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	 Digital Atmosphere hosts a powerful suite of 
tools for analyzing various atmospheric proper-
ties.  It is quite simple to use.  You simply click 
on a primary field that you want to view (such 
as temperature, wind speed, pressure, etc) in the 
Analysis menu.  However, if you first click on 
a derivative field (i.e. vorticity, divergence, or 
advection) in the status panel, Digital Atmosphere 
places a checkmark next to that field.  Deriva-
tive fields are not analyzed until you click on a 
primary field from the Analysis menu.  Only then 
are the derivative choices looked at.  All analysis 
methods are computed based on whatever level is 
selected under the “Active Level” pop up menu on 
the status panel, so if the analysis does not appear, 
it means no data is available for the active level.
	 Font types used during analysis (contouring 
and labelling) operations are controlled in “File/
Preferences/Fonts” under “Annotations”.  Only 
the font name is used; the size is ignored.

6.1. Analysis basics
	 To fully understand how the analysis routines 
work, you have to know a little bit about the 
theory behind them.  All meteorological fields can 
be described as a series of waves.  For example, 
assume that at a certain time the coldest spot in 
the country is International Falls, MN at 12°F and 
the hottest spot is Death Valley, CA at 96°F.  Then 
draw a long line on your map that passes through 
both of those points.  If you graph the tempera-
tures along this line and gather data from cities 
along the line, your temperature graph will show 
unique undulations, rises, and falls.  These are 
mathematical waves in the temperature field.
	 Assume that you find that the temperature 
200 miles on each side of Death Valley (along the 
line) is 94 deg F.  You could then assume most 

of the southwest United States is hot.  The tem-
perature graph would show a gradual rise towards 
Death Valley and a gradual fall as you move away.  
But what if the temperature 200 miles on each 
side is instead 52 deg F?  With Death Valley being 
at 96, this would appear on your graph as a short 
upward “spike” at the location corresponding to 
Death Valley.  These are two unique mathemati-
cal waves — the first one (with gradual rises and 
falls) means that the temperature field is com-
posed of large or long wavelength features.  The 
latter situation (with sharp spikes and dips) means 
that the temperature field is composed of short or 
small wavelength features.  As you can see, gradual 
changes mean that the meteorological field has 
long wavelength characteristics, and sharp local-
ized changes imply small wavelength features.
	 Digital Atmosphere uses a 30 x 30 mesh (ad-
justable in Preferences > Analysis) to sample these 
conditions.  The mesh is like lines that are drawn 
across the map, 30 across and 30 down, to sample 
the wave structure that is present in the type of 
analysis you pick.  Using equally-spaced grid 
points is the easiest way to perform computerized 
analysis calculations.  Digital Atmosphere must 
find where reporting stations are within the grid, 

6 / Analysis menu
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and try to map the values to that grid, taking 
into consideration how far the reporting station 
is from a gridpoint and figuring out what to do 
with gridpoints that aren’t assigned any data.  
This is what takes up the majority of processing 
time.
	 So why not just map values to the grids 
and interpolate between all the points?  Digital 
Atmosphere’s nearest neighbor technique does 
something like this.  It maps data to gridpoints 
and fills in unassigned gridpoints using the near-
est data value, a process known as expansion.  
However, if the temperature in San Francisco 
is 52 and in Los Angeles is 85 (and assuming 
we have NO other data), the analyzed field 
anywhere in California will show either 52 or 
85 degrees!  This is clearly not correct, so after 
expansion, Digital Atmosphere runs a smooth-
ing algorithm.  Smoothers “smooth” out the 
mesh by changing the value at each gridpoint to 
an average of itself and its neighbors.  Unfortu-
nately, this can dampen out features in the field.  
Too much smoothing will remove all of the 
short wavelength features.
	 A better way to do this is to use the Weight-
ed, Barnes, or Cressman techniques.  See the 
Preferences > Analysis section for more infor-
mation.  Proper selection of analysis type gives 
much better control over smoothing, which is 
not available from Internet web charts, and al-
lows the software to accurately resolve a mix of 
large waves as well as small, localized waves.
	 Let’s now take a closer look at each type of 
analysis.

6.2. Analysis fields

Temperature
	 Analyzes the free air temperature in either 
degrees Fahrenheit or degrees Celsius.

Potential temperature
	 Potential temperature is what the tempera-
ture of the air would be if it was forced to the 

1000 mb level.  In other words, it eliminates the 
effects of elevation, allowing you to effectively 
compare temperatures in mountainous areas us-
ing a common temperature measurement.

Equivalent potential temperature (theta-e)
	 Equivalent temperature indicates the poten-
tial temperature of a parcel of air whose latent 
heat had been completely released.  Physically, 
it’s what the parcel’s temperature would be if 
it were forced upwards to about 200 mb then 
forced downwards to 1000 mb.  In any given 
atmosphere, higher values of surface or low-level 
theta-e will always yield higher instability values 
(it’s a better indicator than dewpoint or tem-
perature), so theta-e is useful for seeing where an 
inversion or cap is about to break.

Dewpoint temperature
	 The dewpoint is the temperature that the air 
must be cooled to before saturation begins.  It is 
proportional to the actual quantity of moisture 
present in the air, so it is often used as a univer-
sal indicator of the “moisture” in the air.

Mixing ratio
	 This measure tells you exactly how much 
moisture is in the air.  It is calibrated in grams 
of water vapor per kilogram of air.  Mixing 
ratio is basically the same type of measurement 
as dewpoint, however, mixing ratio is an abso-
lute, measurable quantity, and with increasing 
amounts of moisture, changes in mixing ratio 
become more significant than changes in dew-
point.  This makes it ideal for finding features 
in moist air masses, especially in severe weather 
situations.
	 At the surface, by checking the divergence 
derivative and clicking mixing ratio, you can 
produce a “moisture convergence” chart useful 
for forecasting severe thunderstorms.  By click-
ing that and the advection derivative, you can 
produce “moisture flux convergence” (SMC).  
In an unstable atmosphere, it takes a few hours 
for SMC to produce convection, so persistant 
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SMC areas must be watched.  SMC patterns are 
more important than the actual values.

Relative humidity
	 This is a measure of how close the air is to 
being saturated.  An analogy is having a shot glass 
half full of water, and a large jar half full of water.  
Relative humidity is like saying that each of the 
containers is 50% saturated with water, regardless 
of the true amount in the container.

Wind chill
	 The wind chill is an empirical equation 
describing what the temperature feels like to a 
person based on the free air temperature and the 
wind speed.  The wind chill always equals the free 
air temperature when the winds are 4 knots or 
less.

Heat index
	 The heat index is an empirical equation 
describing what the temperature feels like to a per-
son based on both the free air temperature and the 
relative humidity.

Humidex
	 This is similar to the heat index but is often 
used in Canada.  It equals H = T + (0.5555 * (e - 
10)), where T is the temperature in Celsius and e 
is the vapor pressure in mb.  Further information 
is available in Humidex, A method of quantifying 
human discomfort due to excessive heat and humid-
ity, by J.M. Masterton and F.A. Richardson, CLI 
1-79, Environment Canada, Atmospheric Envi-
ronment Service, Downsview, Ontario, 1979.

Sea level pressure   
	 (Surface data only)  The sea level pressure is the 
atmospheric pressure at the surface in millibars 
reduced to sea level, taking into account tempera-
ture patterns over the previous 12 hours.  It is 
similar to altimeter setting, but not the same.  It’s 
biggest use is for comparing patterns over a broad 
area, as in synoptic analysis.

Altimeter setting   
	 (Surface data only) The altimeter setting, mea-
sured in inches, is what the surface pressure would 
be if it were reduced to sea level, however it takes 
into account no temperature corrections.  Unlike 
the sea-level pressure, if the temperature outside 
varies drastically, the altimeter setting will fluctu-
ate.  Altimeter setting is typically what is used by 
the National Weather Service to report pressure 
readings to the public.  It is somewhat more com-
monly available than sea level pressure, so it finds 
use in day-to-day mesoscale analysis.

Geopotential height   
	 (Radiosonde data only) Geopotential height 
(usually called simply “height”) is the height of a 
given pressure surface (such as 300 mb) in meters.  
It is widely used in upper-air analysis

Wind speed
	 This is the speed of the air movement, usually 
measured in knots (nautical miles per second, or 
1.15 mph).

Observed wind  
	 (Vector field) Computes an observed wind 
grid, as reported in the weather data.  The “arrow” 
of the feather or vector points towards where the 
wind is going.

Custom data file
	 Analyzes a custom data set from your CUS-
TOM.DAT file (see the appendix on Custom 
Data for full details).  The contour base and inter-
val are automatically determined.

Geostrophic wind  
	 (Vector field) Computes a wind grid based on 
the pressure or geopotential height field.  Geo-
strophic wind is based on the pressure gradient 
and the Coriolis effect, and due to the effects of 
friction, it is always higher than the observed wind 
speed.  Geostrophic winds are useful for getting 
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an idea of how strong the winds will be later in 
the morning when air flow is being suppressed 
by radiational inversions.

Ageostrophic wind  
	 (Vector field) This is the vector difference be-
tween the actual wind vector and the geostroph-
ic wind vector.  Ageostrophic wind is stronger 
when the pressure and wind fields are out of 
balance.  Much of the vertical motion in the 
atmosphere can be attributed to ageostrophic 
flow.

Q-vectors   
	 (Vector field) The omega equation is a diag-
nostic for the total time derivative of pressure.  
It allows synoptic-scale vertical motion to be 
accurately estimated by analyzing temperature 
and wind fields above the boundary layer.  The 
omega equation is defined as shown here, where 
the term on the left side of the equation indi-
cates vertical motion.  On the right side, the 
left term is proportional to differential vorticity 
advection, while the right term solves for thick-
ness advection.  So positive differential vorticity 
advection plus warm thickness advection equals 
upward vertical motion.  A Q-vector roughly 
depicts the ageostrophic horizontal wind that 
develops in order to maintain the thermal wind 
balance in a developing synoptic system.
	 Q-vector convergence implies synoptic-scale 
upward vertical motion, and Q-vector diver-
gence implies downward vertical motion.  This 
can be interpreted either by looking at the Q-
vectors or running a derivative convergence field 
together with Q-vectors.  Also, where 850 mb 
Q-vectors cross the 850 mb isotherms, moving 
towards warmer air, frontogenesis is indicated.  
Q-vectors crossing into colder temperatures 
indicate frontolysis.  This quality is known as 
the “geostrophic frontogenesis function” (use 
700 mb levels in mountainous areas).  Avoid us-
ing the advection derivative to forecast Q-vector 
movement, since the field is constantly changing 
and may not be representative after a few hours.

Divergence
	 Divergence is a measure of the amount of 
stretching of a parcel of air, or the relative rate 
of increase of a material surface.  Divergence is 
defined by the following, where u and v are the 
x and y components of wind, respectively.

Relative vorticity
	 Relative vorticity is a measure of curl of the 
air.  Geometrically, vorticity is twice the angular 
speed of rotation of a parcel that moves with the 
flow.  It is a relatively simple expression of the 
flow of air, and is most often used to examine 
the wind field within the boundary layer.  Rela-
tive vorticity is defined by the following, where 
u and v are the x and y components of wind, 
respectively.

Absolute vorticity
	 Absolute vorticity is the same as relative 
vorticity, however, the Coriolis effect is added 
into the equation (absolute vorticity equals rela-
tive vorticity at the Equator).  Absolute vorticity 
of the wind is used most frequently in upper-air 
analysis.
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About analysis

 	 To fully understand how the analysis 
routines work, you have to know a little bit 
about the theory behind them. All meteorologi-
cal fields can be described as a series of waves. 
For example, assume that at a certain time the 
coldest spot in the country is International 
Falls, MN at 12°F and the hottest spot is Death 
Valley, CA at 96°F.  Draw a long line on your 
map that passes through both of those points. If 
you graph the temperatures along this line and 
gather data from cities along the line, your tem-
perature graph will show unique undulations, 
rises, and falls. These are mathematical waves in 
the temperature field.
	 Assume that you find that the temperature 
200 miles on each side of Death Valley (along 
the line) is 94 deg F. You could then assume 
most of the southwest United States is hot. The 
temperature graph would show a gradual rise 
towards Death Valley and a gradual fall as you 
move away. But what if the temperature 200 
miles on each side is instead 52 deg F? With 
Death Valley being at 96, this would appear 
on your graph as a short upward “spike” at the 
location corresponding to Death Valley. These 
are two unique mathematical waves — the first 
one (with gradual rises and falls) means that the 
temperature field is composed of large or long 
wavelength features. The latter situation (with 
sharp spikes and dips) means that the tempera-
ture field is composed of short or small wave-
length features. As you can see, gradual changes 
mean that the meteorological field has long 
wavelength characteristics, and sharp localized 
changes imply small wavelength features.
	 Digital Atmosphere uses a 30 x 30 mesh 
(grid) to sample these conditions. The mesh 
is like lines that are drawn across the map, 
30 across and 30 down, to sample the wave 
structure that is present in the type of analysis 
you pick. Using equally-spaced grid points is 

the easiest way to perform computerized analysis 
calculations. Digital Atmosphere must find where 
reporting stations are within the grid, and try to 
map the values to that grid, taking into consider-
ation how far the reporting station is from a grid-
point and figuring out what to do with gridpoints 
that aren’t assigned any data. This is what takes up 
the majority of processing time.
	 So why not just map values to the grids and 
interpolate between all the points? Digital Atmo-
sphere’s nearest neighbor technique does some-
thing like this. It maps data to gridpoints and fills 
in unassigned gridpoints using the nearest data 
value, a process known as expansion. However, if 
the temperature in San Francisco is 52 and in Los 
Angeles is 85 (and assuming we have NO other 
data), the analyzed field anywhere in California 
will show either 52 or 85 degrees! This is clearly 
not correct, so after expansion, Digital Atmo-
sphere runs a smoothing algorithm. Smoothers 
“smooth” out the mesh by changing the value at 
each gridpoint to an average of itself and its neigh-
bors. Unfortunately, this can dampen out features 
in the field. Too much smoothing will remove all 
of the short wavelength features.
	 A better way to do this is to use the Weighted, 
Barnes, or Cressman techniques. These techniques 
look at each gridpoint, find where it corresponds 
to on the earth, and from that location it looks at 
the values of the stations around it and figures out 
a carefully averaged value best representing what 
the value at that gridpoint probably is. The Barnes 
algorithm goes a step further by going back and 
seeing how incorrect its mesh turned out to be, 
then adjusting that to produce a final analysis. The 
Cressman algorithm does the same thing, but it 
also begins its analysis using values at stations over 
a wide area, then gradually tightens up its analysis, 
running corrections and using values at stations 
over a progressively more narrow area. This allows 
Cressman to accurately resolve large waves as well 
as small, localized waves.
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	 The radar menu is for native support of the 
United States WSR-88D radar systems.  Cur-
rently, the United States is the only country in the 
world that openly shares its raw radar data in real 
time.  Although Europe and other countries have 
similar radar networks, the data is proprietary and 
consequently Digital Atmosphere is unable to 
support this data except through low-resolution 
imports of publicly available images (the user can 
configure these if they are available; see the Import 
Radar Images section).
	 Digital Atmosphere’s radar module processes  
Level III high-resolution data directly from sites 
that carry the data feed. Because there are over 
100 radar sites and 31 products at each site that 
can be used operationally, Digital Atmosphere 
has implemented a completely separate, unique 
system for retrieving data. The Data > Retrieve in-
terface used for “normal” weather data is not used. 
Rather, all choices for obtaining data are built 
into the radar menu and controlled by options in 
Preferences.
	 To use the radar menu, you simply (1) 
make sure the station you want is set (with 
Set NEXRAD Station or Quick Pick); and (2) 
click on the product you want. The image will 
be downloaded (taking anywhere from 1 to 30 
seconds) and will be displayed immediately on the 
current workchart.
	 Special note about choosing multiple stations: 
Digital Atmosphere can only access a handful of 
stations at a time. It cannot access all stations in 
the U.S., because currently no server provides 
current data combined in one file, and accessing 
each file individually would take several minutes 
of time and potentially “hammer” the server with 
requests. Digital Atmosphere is also intended to 
be a tool to view local storms and phenomena 
rather than to build national mosaics, which are 

7 / Radar

readily available on the Internet from countless 
sources. If you select two or more stations, Digital 
Atmosphere will mosaic the radar based on high-
est reflectivity at a given bin.

7.1. View last radar product
	 This function will display any radar data that 
has been recently imported. You can use it to 
redisplay existing data without causing the system 
to download new radar data.

7.2. View radar free text mes-
sages
	 This will view freeform text messages (if pres-
ent) contained in the downloaded data files.  This 
generally has information on things like outages.

7.3. Load radar data from file
	 Rather than accessing new radar data through 
the Internet, you may load the data from an exist-
ing file. Any NEXRAD data in this file will be 
imported and automatically displayed. You may 
save data to be loaded and viewed again at any 
time in the future by using the “Save radar data to 
file” command.
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7.4. Save radar data to file
	 Saves any imported radar data to a file of 
your choice. You may then view it again later by 
using the “Load radar data from file” option.
	 Advanced users: This basically copies the 
queue.nid holding pen to your desired location.

7.5. Import radar images
	 This is a sophisticated interface that allows 
any graphical radar image to be georeferenced 
and mapped into Digital Atmosphere.  This 
provides a “poor man’s” solution that can be 
used with international radar sites that just have 
a static graphical image.
	 Please see the appendix for complete infor-
mation on how these are constructed and built.

7.6. Set NEXRAD station
	 Before Digital Atmosphere can access 
NEXRAD data from the Internet, it must know 
which stations you want to look at. A map will 
be displayed and you will be able to select the 
sites for which data should be accessed.

7.7. Quick pick
 Allows you to quickly set a new station by 
typing its identifier into an entry box. This is 
designed for advanced users. Always enter the 
three-letter identifier, such as FWS, MHX, or 
CCX.  If there are multiple stations, separate 
them with a space.
	 If you do not know what to enter or how 
to use this box, use the Set NEXRAD Station 
interface instead.
	 Special note: Please see “Special Note About 
Choosing Multiple Stations” in the radar intro-
duction.

7.8. Set date-time
	 Beginning 2015 this functionality has 
been removed because the university server 

that hosted the data went offline.  It is going 
to be replaced shortly with access to cloud-
based data holdings.
	 The Radar Time Select module allows fast, 
efficient display of historical WSR-88D (Ameri-
can) radar information, often going back to 2 or 
3 weeks.
	 If “Use current (real-time) radar data” is 
enabled, Digital Atmosphere will function nor-
mally.
	 If it is disabled, then Digital Atmosphere 
will use the date and time shown to find ar-
chived radar information online whenever a 
product is chosen in the Radar menu.  The 
Preferences > General > Radar Source dropdown 
must be set to a designated radar archive source, 
and that source must be configured properly in 
the digatmos.rad file.

7.9. Tilt 1 reflectivity
	 Shows the most common radar product: 
radar reflectivity at the lowest (0.5 deg) scan. 
Radar echoes are shown as color-coded poly-
gons that may be one of 15 colors. If you need 
to see a scan over a wider area or at different 
elevations, use the expanded Reflectivity menu 
instead to select a more specialized reflectivity 
product.

7.10. Reflectivity
	 Shows radar echoes in any of several for-
mats. Reflectivity is simply a measure of power 
returned to the radar in decibels (dBZ).
* 0.5 deg. Shows reflectivity from scan elevation 
1, tilted 0.5 deg from the ground. This is exactly 
the same as “Tilt 1 Reflectivity” selection shown 
in the radar main menu, so you should not nor-
mally have to select this item.
* 1.5 deg. Shows reflectivity from scan elevation 
2, tilted 1.5 deg from the ground.
* 2.4 deg. Shows reflectivity from scan elevation 
3, tilted 2.4 deg from the ground.
* 3.4 deg. Shows reflectivity from scan elevation 
4, tilted 3.4 deg from the ground.
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 	 Remote data is selected with the digatmos.
rad file. Data is imported into queue.nid, then 
is plotted. The digatmos.nxc file is used to 
define how fields are plotted, and digatmos.
nex defines the colors. Since the station identi-
fier is not contained within the data blocks, 
the NEXRAD station table (digatmos.nxa) is 
consulted (this table is built from digatmos.stn 
whenever doing a Recompile Tables command).
	 For advanced users who are custom-
izing access URLs, a list of valid product 
codes for Internet retrieval can be found at: 
http://www.nws.noaa.gov/tg/radfiles.php . 
To get historical NEXRAD data, visit http://
has.ncdc.noaa.gov/plclimprod/plsql/HAS.
FileAppSelect?datasetname=7000 . Level II data 
is at http://has.ncdc.noaa.gov/plclimprod/plsql/
HAS.FileAppSelect?datasetname=6500 but is 
not compatible with Digital Atmosphere at this 
time.

* Setting and overriding radar access URLs . Us-
ers are able to change URLs corresponding to 
the desired products. This is done by editing 
the digatmos.rad file. Within this file you con-
struct a template for retrieving the NIDS Level 
III radar file. Only the URLs in the “Default” 
section are used under normal circumstances. 
However you can override them by creating 
new sections (which contain a title that starts 
with an equal sign). To implement any radar 
access source, set the “Preferred source” in 
Set NEXRAD Station to something besides 
Default. If the product you request cannot be 
found in the override, the one in the default 
section will be used.

* Setting and overriding color schemes . Likewise, 
users are able to set and override color schemes. 
To do this, simply edit the digatmos.nex file. 
To implement any color scheme, go to Set 

NEXRAD Station and choose something besides 
the default color scheme. Color schemes for an-
notations, storm tracks, hail, mesocyclones, and 
so forth, are handled in the map’s color table (you 
may either edit this in File > Preferences > Colors 
or by directly editing any file in the /styles direc-
tory).

* Translucency: Radar echoes are drawn using 
translucent polygons. Due to the limited capabil-
ity of the graphics library currently being used, 
there is only limited support for translucency at 
this time.  For best results, make sure your base-
map is as bright or as dark as possible. Before 
plotting radar echoes, Digital Atmosphere will 
examine your style file for the background color 
(bas, in Preferences > Styles) and use the appropri-
ate translucency algorithm based on whether it is 
closer to white or black. If you get unusual results, 
change your background color or regenerate the 
map, preferably towards the white or dark end of 
the spectrum.

* Mosaicing.  When plotting radar imagery for 
multiple sites, an important problem arises when 
Digital Atmosphere has to decide which radar’s 
data to use for a particular location.  The rule is 
that Digital Atmosphere plots the pixel for the 
nearest radar site.  The exception is when raster 
images (such as echo tops, composite reflectivity, 
etc) are displayed; in this case the pixel with the 
highest detected level is used (this raster rule took 
effect with Equinox v1.05, 1/16/07, and later ver-
sions).

RADAR: Technical information & overriding the defaults
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* Extended (248 nm) 0.5 deg.  This is similar to 
the 0.5 deg reflectivity scan, but shows it over 
a wider area (248 nm). This comes at the cost 
of degraded resolution (1.1 nm instead of 0.54 
nm).
* Composite. Composite reflectivity blends all 
available elevations, showing the highest re-
flectivity in all elevations above a given point 
on Earth. This is useful for showing all echoes 
returned by the radar, regardless of scan eleva-
tion. However this masks important features 
useful for severe weather forecasting, such as 
hook echoes and reflectivity gradients which are 
seen only on base slices. Composite reflectiv-
ity can give false impressions of precipitation at 
the surface from suspended precipitation, as in 
storm anvils.
* Extended (248 nm) composite.  This is similar 
to the composite product but reaches over a 
wider area: 248 nm instead of 124 nm.

7.11. Velocity
	 Shows radial velocity (to and from the radar 
site) in any of several formats. It is expressed in 
knots. Positive velocity is always motion away 
from the radar, while negative velocity is always 
motion toward the radar. As a mnemonic it is 
useful to link positive (“typical”) values to that 
of energy being transmitted from the radar 
(“typical” radar energy), and negative values as 
being associated with energy coming back the 
other way.
* 0.5 deg. Shows velocity from scan elevation 1, 
tilted 0.5 deg from the ground.
* 1.5 deg. Shows velocity from scan elevation 2, 
tilted 1.5 deg from the ground.
* 2.4 deg. Shows velocity from scan elevation 3, 
tilted 2.4 deg from the ground.
* 3.4 deg. Shows velocity from scan elevation 4, 
tilted 3.4 deg from the ground.
* Short 32 nm (0.5 deg). Surprisingly, the radar 
generates a close-range velocity product with a 
gate resolution of only 790 feet! You can view 
this product here for looking at storms up close.

* SRM 0.5 deg. Shows storm-relative mean ra-
dial velocity from scan elevation 1, tilted 0.5 deg 
from the ground. The storm-relative mean radial 
velocity (SRM) product is essentially the same 
as base velocity, but removes the component of 
the storm’s motion, allowing velocity signatures 
to be more accurately analyzed. This product is 
preferable to the standard velocity products for 
storm forecasting. The source for the storm mo-
tion component is usually the average motion 
of all storms detected by the radar’s SCIT storm 
tracking algorithm.
* SRM 1.5 deg. Shows storm-relative mean ra-
dial velocity from scan elevation 2, tilted 1.5 deg 
from the ground.
* SRM 2.4 deg. Shows storm-relative mean ra-
dial velocity from scan elevation 3, tilted 2.4 deg 
from the ground.
* SRM 3.4 deg. Shows storm-relative mean ra-
dial velocity from scan elevation 4, tilted 3.4 deg 
from the ground.

7.12. Spectrum width
	 Spectrum width is a measure of the variance 
in velocity within each bin. It is actually gener-
ated from a pulse pair algorithm, rather than 
being computed directly from velocity data. The 
product is generated using 7 levels, with a maxi-
mum possible width of 20 kt. Anything beyond 
20 kt is truncated by the radar unit.
	 The spectrum width product it is the basis 
for the WSR-88D turbulence products. The ap-
plication of the product to severe thunderstorm 
forecasting is not known, but it may be a sec-
ondary indicator of small tornadoes, landspouts, 
and gustnadoes.
* 32 nm. Uses the close-range radius of 32 nm 
at 0.13 nm resolution.
* 124 nm. Uses the standard radius of 124 nm 
at 0.54 nm resolution.

7.13. Differential reflectivity
	 Dual-polarization radars have the ability to 
measure the signal as received in the horizon-
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tal plane as well as the vertical plane.  The ratio 
between these two for a given bin is known as 
differential reflectivity (DR).  This tends to mea-
sure the oblateness of scatterers: particles that are 
stretched horizontally (pancaked) tend to be large 
raindrops.  On the other hand, particles stretched 
vertically usually include ice particles and espe-
cially hail.
	 Values of high differential reflectivity (+2 to 
+5 and up) indicate stretching in the horizontal, 
and suggest pancaked particles.  Values that are 
near zero suggest a spherical ratio of width to 
height.  Values that are negative (e.g. -1 to -2) 
indicate the particles are stretched in the vertical, 
and are likely to be ice.

7.14. Correlation coefficient
	 Correlation coefficient (DCC) provides a mea-
sure of the similarity of scatterers in the horizontal 
plane to scatterers in the vertical plane.
	 Very low correlation coefficients are in the 
range of 0 to 0.8 (0-80%) and normally indicate 
non-meteorological targets such as birds, insects, 
bats (especially in Texas), chaff, tornado debris, 
and ground clutter. Giant hail may dip into the 
upper range of these values (about 70-80%), as 
can large, clumped snow.
	 Moderate correlation coefficients are in the 
range of 0.8 to 0.97 (80-97%) and normally con-
sist of transitional forms of precipitation like hail 
and wet melting snow.
	 High correlation coefficients are in the range 
of 0.97 to 1 (97-100%) and are made up of un-
form snow, rain, and drizzle.  The highest values 
are made up of very small droplets.

7.15. Specific differential phase
	 Specific differential phase (DKD) measures 
the change in phase of the radar signal caused 
by precipitation and other scatterers.  It is highly 
similar to base reflectivity (DR), except that by 
nature it tends to be impervious to attenuation.  
This makes it of excellent use for finding the 
“true” reflectivity of cells when the beam is hav-

ing to cross lengthwise through a squall line or 
through numerous cells to a distant storm.

7.16. Other
	 A number of derived products are generated 
from the base products of reflectivity, velocity, and 
spectrum width.
* Echo tops (ET). This displays the highest altitude 
at which a radar echo exceeds 18.5 dBZ. It is 
computed to the nearest 5,000 ft up to a maxi-
mum height of 70,000 ft. The standard coverage 
radius is 124 nm with a resolution of 2.2 nm.
* Vertically integrated liquid (VIL). Sums the reflec-
tivities above a bin location to provide a measure 
of the total water load above a given location in 
kilograms per square meter. It has a direct correla-
tion to severe weather, hail, and flood potential, 
and is most useful in assessing in an extremely 
short time which storm cells have the greatest 
significance. Generally values above 40 kg/m^2 
are associated with severe weather. The maximum 
possible displayable value is 80 kg/m^2. The prod-
uct has a coverage radius of 124 nm with a resolu-
tion of 2.2 nm.
* Severe weather probability (SWP). Displays the 
probability of severe weather, based solely on the 
VIL algorithm. This product is of extremely lim-
ited use for severe weather forecasting and must be 
used with caution. Values are expressed as a per-
centage from 0 to 100. The product has a coverage 
radius of 124 nm with a resolution of 2.2 nm.
* Mesocyclone. Shear couplets are resolved verti-
cally and with time to determine the existence 
of a storm mesocyclone. If one is present, it is 
displayed as a red circle. The radius of the circle 
equals the reported radius of the mesocyclone. 
Mesocyclones are resolved only within 124 nm of 
the radar.
* Hail index. The radar system contains a severe 
hail index (SHI) algorithm that relates the 45 dBZ 
level to the -20C height. When the computed 
probability for hail for each storm cell exceeds a 
predetermined criteria, it will be displayed as a 
green isosceles triangle. If the triangle is small, 
there is a 30% probability of hail (50% if it is 
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filled). If it is large, there is a 30% probability 
of severe hail (50% if it is filled). The maximum 
expected hail size (MESH) is displayed in the 
middle of the symbol, rounded to the near-
est whole inch; if less than one inch an asterisk 
shows. The hail index has a radius of coverage of 
124 nm from the radar.
* Tornado (TVS). This product uses the Tornado 
Detection Algorithm (TDA) to resolve velocity 
signatures that suggest a tornado. The tornado 
signature is shown as a red filled inverted isos-
celes triangle. An ETVS may also be displayed, 
but the NIDS code does not provide for dif-
ferenting TVS from ETVS signatures, therefore 
they will appear the same. The radius of cover-
age is 124 nm, but is rarely detected outside of 
60 nm since the algorithm is unable to sample 
the lower portions of the storm at long ranges.
* 1-hour precipitation (OHP). Radar reflectiv-
ity is summed with time to estimate the rainfall 
accumulation in the coverage area. This product 
provides an estimate of how much rain fell dur-
ing the past hour. The highest reportable total is 
8 inches. The radius of coverage is 124 nm with 
a resolution of 1.1 nm.
* 3-hour precipitation (THP). Radar reflectiv-
ity is summed with time to estimate the rainfall 
accumulation in the coverage area. This product 
provides an estimate of how much rain fell dur-
ing the past three hours. The highest reportable 
total is 8 inches. The radius of coverage is 124 
nm with a resolution of 1.1 nm.
* Storm total precipitation (STP). Radar reflectiv-
ity is summed with time to estimate the rainfall 
accumulation in the coverage area. This product 
provides an estimate of how much rain fell dur-
ing the past hour. The highest reportable total 
is 15 inches. The radius of coverage is 124 nm 
with a resolution of 1.1 nm.
* Storm tracking information (STI). This prod-
uct shows information provided by the radar’s 
Storm Cell Interpretation and Tracking (SCIT) 
algorithm. It shows past, current, and future 
location of identified storm cells. Past loca-
tions are shown for each volume scan (this is an 

interval of 5 minutes in VCP11 and 6 minutes 
in VCP21). Future locations are identified at 15, 
30, 45, and 60 minutes in the future; though 
these intervals are customizable by the radar 
site operator. Each storm has a unique ID of 
two characters ranging from A0 to Z9 and is 
recycled when past A0; when no storms have oc-
curred in a certain number of volume scans the 
ID is reset to A0. The storm data has a radius of 
coverage of 248 nm.
* Clutter control filter (CFC). Shows the clutter 
filter notch and bypass maps as a radial im-
age. The levels are coded as follows: 0=disable 
filter; 1=no clutter filter; 2,5=low clutter filter; 
3,6=medium clutter filter; 4,7=high clutter fil-
ter. Codes 1 to 4 specify the map is bypassed by 
CTRL, while 5-7 force the filter to operate. The 
product has a radius of coverage of 124 nm with 
a resolution of 1 km and 1.4 deg azimuth.
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8.1. Live chart retriever
	 (Professional version only)
	 This module retrieves weather from over the 
Internet and sends them automatically to your 
printer.  Please note that supported filetypes are 
limited to GIF, JPEG, PNG, and TIF.  There is no 
support for animated files or dynamically gener-
ated URLs.
	 To use this module, open the Chart Selection 
Menu and set a checkmark next to each chart you 
are interested in.  Then close the menu and click 
Activate Retriever.  The red square around the dog 
icon will turn green, indicating the retriever is ac-
tive.
	 Charts will be sent to the printer shown in 
the Printer section.  You can also control the 
startup behavior here to indicate whether you 
want the initial set of charts printed.  The status of 
the retrieval jobs will be shown in the next three 
windows, “products queued for polling”, “retriever 
engine status”, and “preview of last downloaded 
product”.
	 To add or edit products in the Chart Selection 
Menu, use the INSERT and DEL key to add and 
delete rows, respectively.  Expert users may direct-
ly edit the digatmos.dfz file in the Digital Atmo-
sphere working directory to make any complex 
changes.

8.2. Calculator
	 Do you need to find a wind chill value?  A 
mixing ratio?  A theta-E?  No problem.  Digital 
Atmosphere’s meteorological calculator lets you 
plug in values and find a result.
	 A very important note about pressure — when 
you are asked for “Actual Pressure”, this indicates 
the actual pressure of the parcel.  This is station 

pressure as a mercury barometer would observe it, 
not sea-level pressure or altimeter setting (which 
are corrected to sea level).  If you’re computing a 
surface-based parameter at a high elevation, you 
can find “actual pressure” by simply calculating 
“Station Pressure (mb)”.
	 An example: In Denver, Colorado, your eleva-
tion is 5300 ft and the pressure is 29.96 inches.  
This yields a station pressure or actual pressure of 
834.8 mb.  You can then use this value in calcula-
tions which ask for this information.

8.3. Warning status
	 (Under development)

8.4. Import GRIB data from file
	 (Experimental) This will open a GRIB data 
file for processing.  Note that complex GRIB and 
GRIB2 data are not yet supported; we are working 
on this.  See the Appendix: GRIB Data section for 
further information.

8 / Tools
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8.5. Extract climatology data
	 This option will let you extract climatology 
data for any of 2,000 stations around the world.  
Simply enter a partial word or country digraph 
to search for a station, or choose from the drop-
down list.
	 Extract Data will allow you to select a 
category and timeframe of climatological data.  
Digital Atmosphere will then create a custom 
data field, saving it into CUSTOM.DAT in 
your Digital Atmosphere directory.  This can 
then be immediately plotted (with Graphics, 
Plot, Custom Data) or analyzed (with Analyze, 
Custom Data Field).  You can even import the 
data into a spreadsheet or database program.

8.6. Graph climatology data
	 This option will let you graph climatology 
data for any of 2,000 stations around the world.  
Simply enter a partial word or country digraph 
to search for a station, or choose from the drop-
down list.
	 What you’ll see is a graph of average high 
and low temperatures for each month, as well 
as extreme high and low temperatures for each 
month.  They will be indicated in either degrees 
Fahrenheit or Celsius, depending on your choice 
of units in File, Preferences.  At the bottom, 
you’ll see average monthly precipitation totals 
(United States) or precipitation days (elsewhere).  
The total height of a precipitation day bar is the 
total precipitation days during a given month.  
The part in gray is how many of those days are 
composed of snow days, and the part in red is 
how many are composed of thunderstorm days.

8.7. Hurricane tracks
	 Digital Atmosphere offers a database of 
historical hurricane tracks, taken every six hours, 
for storms that occurred in the East Pacific and 
Atlantic basins from 1850 to 2002. The tracks 
will be displayed on the active workchart.

* Year. Use the range boxes to display data for a 
certain time period. To display data for only one 
year, enter the same year in both boxes.
* Line width. Enter a number here to control 
the width of the lines that will be plotted. The 
recommended value of 4 should be used.
* Plot storm name at origin. Plots a label contain-
ing the storm’s name at the beginning of the 
track.
* Plot date labels along track. Plots dates and 
times along the length of each storm track.
* Color code for wind speed. Changes the line 
color of the previous segment based on the 
sustained wind speed at that time. The values 
are: Gray 0-34 kt (tropical depression); Black 
35-63 kt (tropical storm); Green 64-83 kt (hur-
ricane, Saffir Simpson 1); Yellow 84-95 kt (Saffir 
Simpson 2); Red 96-113 kt (Saffir Simpson 
3); Purple 114-134 kt (Saffir Simpson 4); Blue 
135+ kt (Saffir Simpson 5).
* The source of the data is the NHC HURDAT 
tables at http://www.nhc.noaa.gov/pastall.shtml 
. The tables are provided in Digital Atmosphere 
verbatim, so users are free to swap out the exist-
ing tables with fresh ones. The files are located 
in the /hurr directory.

8.8. Tornado tracks
	 Digital Atmosphere is equipped with a da-
tabase of United States tornadoes that occurred 
between 1950 and 2002. These may be plotted 
on any weather chart for reference purposes. It 
is important to note that due to limitations in 
available data, the database carries only the start 
and end location of a tornado track, and not 
the intermediate points. This means that tracks 
will tend to be more accurate for short, slow-
moving tornadoes, and much less accurate for 
long-tracked, fast-moving tornadoes. This is a 
limitation in the way that tornado climatology is 
compiled by the National Weather Service, and 
neither Digital Atmosphere nor its authors have 
any control over this.
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* Year. Choose a range of years to display only 
data during these periods. To display data for 
only one year, set both blanks to the same value. 
Choose “all” if you want all years in the database 
to be displayed.
* Month. Choose a range of months to display 
only data during these periods. To display data 
for only one month, set both blanks to the same 
value. Choose “all” if you want all months in the 
database to be displayed.
* Day. Choose a range of days to display only data 
during these periods. To display data for only one 
day, set both blanks to the same value. Choose 
“all” if you want all days in the database to be 
displayed.
* Plot date labels at each track. Digital Atmosphere 
will plot a MM/DD/YY label to the lower right 
of the beginning of each tornado track to show 
which date the track occurred.
* Color code. If checked, Digital Atmosphere will 
code a track black if there were no reported inju-
ries or fatalities, green if there were fatalities but 
no recorded deaths, and red if deaths occurred.
	 The source of data is the Storm Prediction 
Center historical tornado archive, located at 
http://www.spc.noaa.gov/archive/tornadoes/ . To 
save disk space, the data has been converted into a 
series of binary records stored in digatmos.tor that 
have this structure: Year (signed 32-bit integer); 
month (unsigned 8-bit integer); day (unsigned 
8-bit integer); hour (unsigned 8-bit integer); 
minute (unsigned 8-bit integer); fujita rating, of 
which very little data is available (unsigned 8-bit 
integer); fatalities (signed 32-bit integer); injuries 
(signed 32-bit integer); latitude of beginning (4-
byte float); longitude of beginning (4-byte float); 
latitude of end (4-byte float); and longitude of 
end (4-byte float). Weather Graphics does not ob-
ject to users providing their own updated tornado 
statistics to replace this one.
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9.1. New workchart
	 Opens another workchart window.

9.2. Update all windows
	 Updates all open workcharts with newly 
imported data. (Has not been tested with latest 
programming efforts as of 2015).

9.3. Cascade
	 Arranges all open workcharts in a stacked 
fashion in which they overlap one another. The 
title bar remains visible so that you can always see 
which windows are open.

9.4. Tile
	 Arranges all open workcharts so that they do 
not overlap one another, appearing in a gridlike 
fashion.

9.5. Arrange icons
	 Minimized workcharts are arranged so that 
they are evenly spaced and do not overlap

9.6. Remove last product
	 The last product that was drawn on the active 
workchart is erased. (Has not been tested with lat-
est programming efforts as of 2015).

9.7. Replot last product
	 The last product that was drawn to the active 
workchart is drawn again. (Has not been tested 
with latest programming efforts as of 2015).

9 / Window

9.8. Allow Digital Atmosphere to 
run in background
	 Currently this option is not used.

9.9. Left side toolbox panel
	 This controls whether the left side panel 
containing the control toolbox is visible.  This 
may be unchecked temporarily to help make 
more of the workchart visible.  It will be reset to 
“checked”when Digital Atmosphere is started.

9.10. Speed buttons
	 If unchecked, the speed button bar at the top 
will be temporarily removed.  It will be restored 
when this open is checked again or the program is 
restarted.
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10.1. Help / Contents
	 This menu option is a remnant of the old 
Windows Help system.  It will remind you that a 
PDF version of the help manual (this document) 
is available on your computer and on the website.
	 The context-sensitive “F1 key” help was 
removed because of Microsoft’s decision to stop 
supporting  the simple, elegant WinHelp format 
in Windows Vista.  This significantly complicated 
our own efforts to provide a simple help system 
embedded in the program.  Therefore we migrated 
to a PDF help manual.

10.2. Help / Register
	 (Only appears if program is the Standard Version 
and is unregistered)
	 If the program is still in 30-day evaluation 
mode, the Register menu option will be visible.  
Clicking it will present a dialog that helps you 

10 / Help

to  panel will let you “unlock” the program and 
convert it to a fully registered version.
	 To use it, you must first obtain the key num-
ber shown in this panel.  This is uniquely gen-
erated for your computer.  E-mail this to us at 
servicedesk@weathergraphics.com.  If our records 
show you as a registered user, we will provide you 
with a key number to enter in this panel that will 
complete the unlock process.
	 Programs that are still in evaluation mode 
after 30 days will lose some functionality such 
as loading and generating of maps.  However, 
completing the registration process at any time wil 
unlock it.
	 Please note that if you reinstall Windows or 
use a new computer, you will see a different serial 

number in this panel and will 
need to contact us for a new key.

10.3. Help / About
	 Displays the version of 
Digital Atmosphere being ex-
ecuted, and also provides helpful 
information on the location of 
your Program Path (where this 
executable resides) and the Ap-
plication Data Path (where all of 
the Digital Atmosphere data files 
are located).  You should never 
save maps and other data to the 

FIGURE 10-1. The About panel.
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Program Path if it exists under “c:\Program 
Files” because this location is write-protected by 
Windows.
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11.1. General tab

Send errors to status window
	 If this option is checked, certain errors will 
be sent to the status panel at the bottom left.  In 
particular this pertains to Internet retrieval errors.

Automatically check for updates
	 If checked, Digital Atmosphere will notify you 
when a new version is on the weathergraphics.com 
website.  If an update is available, it will offer to 
download the update.  If you accept, the Digital 
Atmosphere download page will appear in your 
default browser. Otherwise it will offer to remind 
you, and you can accept or decline.
	 If this is unchecked, Digital Atmosphere will 
not check for updates.

NEXRAD settings
* Preferred radar source override: This directs Digi-
tal Atmosphere to which set of URLs it should 
be using to retrieve its NEXRAD (WSR-88D) 
data.  Expert users can load the file digatmos.rad, 
found in your Application Data folder (see Help > 
About) to view and edit the sets.
* Preferred radar color override: This sets the radar 
color table scheme.  Expert users can load the file 
digatmos.nxc, found in your Application Data 
folder (see Help > About) to view and edit the 
sets.  Note that we are changing the color set for-
mats as of 2015 to support newer NEXRAD data 
formats, so this item may temporarily not work.

Print settings
* Color assignment: This can be used to experi-
ment with how Digital Atmosphere maps colors 
to the printer, in case printouts do not look as 
expected.  Simply try changing the value here and 

make a printout, and if it still does not look satis-
factory then change it back.
	 Expert users: Setting this to Palette causes 
the Windows API function StretchDIBits to use 
DIB_PAL_COLORS in the iUsage field (which 
indicates the color structure of the source image).  
If the setting is RGB, then DIB_RGB_COLORS 
is used.

11.2. Meteorological tab

CAPE mixed layer depth
	 This sets the depth of the layer that will be 
used for mixed layer parcel calculations (including 
CAPE and parcel trace) in the Data > Soundings 
panel.

FOUS data level
	 Whenever you plot model (ETA/NGM) data, 
the temperature and moisture variables are deter-
mined according to this setting.  Normally the 
first button (T1/R1) is selected to give you surface 
data, but by choosing another button you can plot 
or analyze temperature or moisture aloft (calcu-
lating derived values such as dewpoint should be 
done with caution, though, since T3 is not the 
same level as R2).  Here are the meanings of the 
different levels.

	 Level    Equivalent

11 / Preferences
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	 T1	Surface 
	 T3	About 100 mb above the surface (1 km) 
	 T5	About 215 mb above the surface (2 km) 
	 R1	Surface to about 35 mb above the 
			   surface (lowest 1000 ft) 
	 R2	About 35 mb above the surface to 
			   500 mb 
	 R3	500 mb to the tropopause

Geopotential heights in full meters only
	 The geopotential height on upper-level 
charts are commonly plotted in decameters 
(dam). When this box is checked, contour 
labels and upper plot models will appear in full 
meters.  When it is unchecked, the labels and 
plot models will switch to conventional shorten-
ing typically used by meteorologists (see table 
below).  The default setting is unchecked.
	 Normal shortening values are as follows:
* 100-500 mb: Hundreds, tens, and units, dam.
* 501-1000 mb  Hundreds, tens, and units, m.

Round synoptic reports to nearest 3 hours 
when importing
	 You have two options when importing 
synoptic (SYNOP) data — you can either 
round the reports to the nearest 3 hours (mak-
ing maximum use of off-hour data) or use no 
rounding (ensuring sampling of the atmosphere 
at an exact moment).  It is generally best to use 
no rounding when possible.

View NEXRAD RCM rather than RAREP 
radar data
	 This prevents two different radar formats 
from being mixed when you use Data > Radar 
> Echoes.  Check this box whenever you use 
NEXRAD RCM data (such as that transmitted 
over EMWIN).  If you use the old SD RAREP 
code, uncheck this box.

Round AIREP reports within __ mb of a 
standard level
	 Forecasters like to see AIREP reports on 
upper-air charts, but AIREPs are rarely at an 
exact standard constant-pressure level.  When 
this box is checked, it allows AIREPs within a 
certain range of the active pressure level to be 
included on the map.  Usually 25 mb is a good 
value.  When it is unchecked, no AIREPs will 
be used unless they are at the exact pressure level 
that’s active.

Display highs and lows when plotting frontal 
bulletins
	 This should usually be left checked.  When 
you display a frontal bulletin using Data > 
Fronts, Digital Atmosphere will automatically 
plot highs and lows contained in that bulle-
tin.  However if you intend to plot an analyzed 
pressure analysis, you may want to have Digi-
tal Atmosphere determine the high and low 
locations.  Thus you can switch off the frontal 
bulletin highs and lows with this option so they 
don.t clash.
	 If you wish to suppress drawing of highs and 
lows in Digital Atmosphere analysis, you will 
need to remove the HILO command from the 
appropriate analysis script entry in digatmos.
mnu (see Analysis Scripting in the appendix).

Display pressure values when plotting frontal 
bulletins
	 This should usually be left checked.  When 
you display a frontal bulletin using Data > 
Fronts, Digital Atmosphere will automatically 
plot any pressure values found in that bulletin 
for highs and lows.  You may suppress these la-
bels by unchecking this selection.  This does not 
have any effect on highs and lows created with 
an Analysis command; it is solely for imported 
frontal bulletin message data.
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Winter depiction: extend contours over non-
precipitating areas
	 (Not implemented yet)

Convert ALSTG to SLP for analysis (advanced 
users only)
	 If you are plotting maps with sea-level pres-
sure, then source data that does not offer a sea-
level pressure value but does have altimeter setting 
data will be converted through a simple standard-
atmosphere pressure reduction.  This should not 
be used in mountainous areas or with unusually 
hot or cold temperatures.

Lowest possible METAR pressure
	 The METAR surface observation code format 
only allows the tens, units, and tenths place to be 
encoded, which means that Digital Atmosphere 
has to determine whether the final millibar value 
is 9xx.x or 10xx.x.  The default value for lowest 
METAR pressure is 960 mb, which means that if 
a value such as 584 is found, Digital Atmosphere 
will assume it is 1058.4 mb, not 958.4 mb.
	 Normally there is no need to change this, but if 
you’re looking at exceptionally low pressure areas 
and the sea level pressure contours aren’t plot-
ting correctly, you’ll want to decrease this value.  
Likewise, if you’re looking at very high pressure 
and the sea level pressure contours aren’t plotting 
correctly, you’ll want to increase this value.  Some 
adjustment may be needed during the cold season 
in temperate and polar latitudes.

Earth’s rotation constant
	 Specifies the earth’s rotation in radians per 
second, which is normally set at 0.000007292.  
Naturally, there is no need to change this unless 
you want to tinker and see the results.  The earth’s 
rotation constant is used in the Coriolis parameter 
equations, which are used for geostrophic wind 
calculations and calculation of absolute vorticity.  
Hitting reset replaces any entered value with the 
Earth’s rotation constant.

Gravity constant
	 Specifies the gravity on the Earth’s surface, 
which is normally set at 9.806 m/s-2.  There’s no 
need to change this unless you want to tinker and 
see the results.  Gravity is only used in the calcula-
tion of geostrophic wind based solely on height 
contours.  Hitting the reset button replaces any 
entered value with the Earth’s gravity constant.

11.3. Maps tab

Topography: use avg elev rather than max
	 This controls what source of data is used when 
you select Map > Make Topography.  When it is 
checked, average elevation data is used.  When 
it is unchecked, the maximum elevation data is 
used.

Fill outer space
	 When the map is zoomed out to where you 
can see the disc of the Earth, the area outside the 
disc (the outer space area) will be filled with the 
general plot color if this option is selected.

Label graticule
	 When checked, and the  are checked and ac-
tive, latitude/longitude labels will be placed at the 
left and bottom of the map consistent with the  
setting.

Draw graticule behind landmasses
	 If checked, the latitude/longitude graticule 
will not appear on top of landmasses and will only 
be shown over oceanic areas.

Plot legend on right hand side of the map
	 The product legend will appear on the right 
side of the map if this is checked, otherwise it will 
appear on the left side.
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Copy viewed point files from PLS to PLT 
format
	 Data point files that were used before 2008 
used the older PLS format.  If checked, Digital 
Atmosphere will offer to convert them for you 
to the new PLT format if they are encountered.

Graticule type
	 Digital Atmosphere can overlay a latitude/
longitude grid, and here you can control how it 
will be displayed.  You will see the lat/long grids 
only if the .lat/long grids. setting in the .map 
element table. is checked and only when you re-
generate a new map.  Note that the grid interval 
is controlled by the .grid interval. setting and 
the color is controlled by the grid color listed in 
the .map element settings. color table.
* Line.  Plots latitude/longitude as a series of 
lines.
* Mixed.  Same as “line” above, but also adds 
dots for every integer degree of latitude and lon-
gitude.  The size and interval of the dots is fixed 
and cannot be controlled.
* Cross.  Plots a cross at each latitude/longitude 
intersection.
* Dash.  Plots latitude/longitude as a series of 
dashed lines.
* Dotted.  Plots latitude/longitude as a series of 
dotted lines

Graticule interval
	 If a latitude/longitude map is plotted, this 
value controls what interval will be used (in 
degrees) to plot the grid.  A value of 10 or 15 
should normally be used.  So that the grid wraps 
uniformly around the globe, the value you select 
should divide evenly into 360.

Default map size
	 When you use quick mapmaking commands 
such as Generate Map on the speed button tool-
bar, this determines what the map size will be in 
pixels.

Map features to be drawn
	 Use this table to set which geographical 
features you want displayed.  Remember that 
these will not take effect until the next time you 
generate a map.  Colors are set in Styles.
	 NOTE: To set translucency on states, set the 
Styles / Misc field for states to 1.  This will pre-
vent international borders from being redrawn 
with state/province line settings.

Professional map file tile root location
	 You can use this to adjust where the Profes-
sional maps can be located, such as if you copy 
them to a hard drive.

JPEG image compression
	 If you choose Map, Export and choose 
JPEG as an image type, the image will be com-
pressed according to the settings you specify 
here.  JPEG is a lossy compression scheme, 
which means that higher compression values 
result in degradation of the image.  As the user, 
you select the tradeoff that you think is most 
acceptable.  For a typical 640 x 480 image, a 
setting of 0% (loose) will result in a high-quality 
image with a filesize of 225K.  A setting of 
100% (tight) will result in a very coarse image 
with a filesize of 11K.

11.4. Station Plots tab

Plot radar status labels
	 Whenever Overlay > Radar is chosen, this 
determines whether symbols are plotted at each 
radar location together with the radar echoes.  
By unchecking this box, only radar echoes will 
be plotted.

Station plot units
	 This controls the units (English or metric) 
used for plots of temperature, dewpoint, vis-
ibility, sea temperature, wave height, wind wave 
height, swell height, minimum and maximum 
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temperature, elevation, precipitation, and .televi-
sion. plots.  This also controls the units used for 
Data > Television temperature plots.

Surface plot model settings
	 These settings only apply when the active level 
is the surface level and Overlay, Data is selected.
* Plot wind barb.  If checked, Digital Atmosphere 
will plot a wind barb at each station plot when 
it is reporting valid wind data.  If unchecked, no 
wind barb is plotted on any report.
* Smart visibility plot.  If checked, Digital Atmo-
sphere will omit plotting surface visibility when 
no significant weather is occurring.  If unchecked, 
surface visibility is always plotted.
* Plot missing as “M”. If checked, missing values 
for key elements will be plotted as “M” instead of 
left blank.
* Color code IFR/MVFR plots.  If checked, when 
stations are reporting IFR conditions (visibility 
less than 3 miles and/or ceiling less than 1000 
ft), the OKTAS (sky cover) plot symbol is col-
ored red; when MVFR conditions (visibility less 
than 5 miles and/or ceiling less than 3000 ft), the 
OKTAS (sky cover) plot symbol is colored blue.  
If unchecked, the standard draw color is used to 
paint the sky cover plot symbol.
* Use km when above 5000 m. If a visibility is 
reported as greater than 5000 m (5 km) it will be 
reported in whole kilometers.
* Plot model configuration.  A “grid” of combo box-
es are set up in a way that represents the various 
data positions around a given station plot.  You 
can use these combo boxes to adjust the kinds of 
data that are plotted in the different positions.  A 
“Save Plot Model” and a “Load Plot Model” op-
tion are provided so that you can make quick, on-
the-fly changes to the desired plot model.  For a 
listing of the different types of data and the mean-
ing of encoded values, please see the Appendix.
* Load plot model.  Loads a predefined plot model 
configuration from disk.
* Save plot model.  Saves the current plot model 
configuration to disk.

 
Upper plot model settings
	 These settings only apply when the active level 
is an upper level and Overlay, Data is selected.
* Plot wind barb.  If checked, Digital Atmosphere 
will plot a wind barb at each station plot when 
it is reporting valid wind data.  If unchecked, no 
wind barb is plotted on any report.
* Fill dewpoint depression circle.  If checked, Digital 
Atmosphere will “shade in” the station plot of 
each upper level station whenever the dewpoint 
depression is 5 deg C or less.  If unchecked, all 
station plots are left unfilled.
* Plot model configuration.  A “grid” of combo 
boxes are set up in a way that represents the vari-
ous data positions around a given station plot.  
You can use these combo boxes to adjust the kinds 
of data that are plotted in the different positions.  
A “Save Plot Model” and a “Load Plot Model” 
option are not provided for upper air plot models 
since most users will stick to a single configura-
tion.
* Load plot model.  Loads a predefined plot model 
configuration from disk.
* Save plot model.  Saves the current plot model 
configuration to disk.

11.5. Analysis tab

Analysis type
	 Specifies which algorithm is to be used to 
construct the analysis.
* Nearest neighbor (proximal interpolation) — 
This is by far the quickest, and most users will 
use this setting.  This is a simple multivariate 
interpolation scheme. Values are mapped to the 
closest gridpoint, then are mathematically ex-
panded to neighboring unfilled gridpoints in 
an outward manner from the data field.  After-
wards, a smoothing operator removes noise, with 
the smoothing proportional to how soon in the 
iteration cycle the gridpoint was filled with data.  
STRENGTHS: It’s fast and always works since 
a gridpoint will always be matched with a data 
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point.  WEAKNESSES: In data void areas, the 
transition between gridpoints using different 
sources takes on a  linear or pie-shaped appear-
ance.
* Weighted — Digital Atmosphere looks at the 
neighboring stations around a gridpoint, giv-
ing it an average of those values around it with 
more weight allotted to values from closer 
stations and less weight from distant stations. 
STRENGTHS: This method is more sophisti-
cated than Nearest Neighbor as it uses multiple 
sources of data, considering distance.
* Barnes — The Barnes method, the cornerstone 
of the MCIDAS and GEMPAK weather work-
stations, has a number of advantages: versatil-
ity, simplicity, and speed.  Each gridpoint is 
assigned a meteorological value which is the 
result of a distance-dependent Gaussian weight-
ing function.  A difference field is calculated, 
which determines how far off from reality the 
analysis field appears to be, then a difference 
correction is applied to the analysis field.  This 
takes a relatively long time to compute, but is 
one of the more accurate analysis algorithms.  
STRENGTHS:  Only two passes are necessary.  
WEAKNESSES: It can fail with extreme data 
distribution.  SOURCE: Koch, SE, des Jardins, 
M, Kocin, PJ 1983, “An interactive Barnes ob-
jective map analysis scheme for use with satellite 
and conventional data”. J Climate Appl. Meteor. 
22, 1487-1503.
* Cressman — The Cressman analysis method 
is similar to the Barnes technique, however 
it is a successive corrections method (SCM) 
technique.  In this technique, it uses multiple 
iterations with a smaller and smaller radius of 
influence to eliminate all errors.  It takes more 
time, but the results can be superb if configured 
correctly.  In data-sparse areas like over oceans, 
it is common for there to be erroneous contours 
with Nearest Neighbor and Weighted methods.  
The Cressman method is one of the best meth-
ods for use in these data sparse areas without 
smoothing fine-scale data near dense data areas.  
STRENGTHS: It is sophisticated and flex-
ible, and retains more mesoscale structure while 

smoothing data-sparse areas properly.  WEAK-
NESSES: It can’t resolve short-wavelength com-
ponents very well, it can require a large amount 
of time, and it can fail with extreme data distri-
bution.  It does not account for the distribution 
of observations relative to one another.  Also the 
optimum distance values might only be obvi-
ous after trial and error.  SOURCE: Cressman, 
G.P. (1959): “An Operational Objective Analysis 
System”. Mon. Weather Rev, 87, 367-374.

For the following items, the letter after 
the title indicates the parameter applies 
to: N=Nearest Neighbor, W=Weighted, 
B=Barnes, or C=Cressman.

Automatic smoothing
	 If checked, Digital Atmosphere will auto-
matically determine the surface and upper air 
surface radius based on existing data for the 
Weighted, Cressman, and Barnes analyses.

Smoothing coefficient
	 (ALL) Sets the mathematical value of “s” for 
the smoothing equation.  This affects what kind 
of wavelengths will be filtered in the analysis 
grid.

Smoothing passes
	 (ALL) Determines how many times a 
smoothing operator will operate whenever it is 
called.  With this, you can set how “smoothed” 
the maps will look when the analysis is com-
plete.  This should be set to “1” or to a low non-
zero value.

Surface radius
	 (W, B, C, in nm) Determines a radius of 
influence used in the Weighted, Cressman, and 
Barnes analysis method for surface data.  All 
data outside the radius of influence is ignored.  
This value should approximate the average spac-
ing between surface stations.
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Upper radius
	 (W, B, C, in nm) Determines a radius of 
influence used in the Weighted, Cressman, and 
Barnes analysis method for upper air data.  All 
data outside the radius of influence is ignored.  
This value should approximate the average spacing 
between upper air stations.

Gamma
	 (B) This is known as the “convergence pa-
rameter”.  It determines the gamma used in the 
Barnes analysis method for upper air data.  It may 
range between 0..1, but a value of 0.2 to 0.3 is 
recommended.

Reduction
	 (C) Determines a reduction value used in the 
Cressman analysis method for upper air data.

Analysis domain size
	 This controls the number of gridpoints in the 
analysis domain.  The default is 30 x 30, but you 
can set it to 60 x 60 for fine-scale analysis.  The 
maximum this should be set to is 100 x 100, and 
larger sizes may cause memory errors.

Isopleth - small fonts
	 This option simply controls what size and type 
of fonts are used to label contour lines on analysis 
charts.

Isopleth - negative fonts
	 Plots an inverted color font.

11.6. Styles tab
	 With Digital Atmosphere you are not stuck 
having to use one set of map colors, line styles, 
and fonts for everything.  Obviously when you 
want to use a different color set, this might mean 
spending a lot of time making tedious changes.  
Digital Atmosphere allows you to manage sets 
of colors, fonts, and line settings.  These sets are 
known as styles.  A style is identified by a plaintext 

name and a filename (all styles are stored in the \
styles directory under Digital Atmosphere, with-
out exception).  To change the color settings, use 
the Preferences > Styles panel.  Advanced users 
may edit the files directly.

Editing the parameters
	 Listed here are the various codes that appear 
in the edit window.  Above all, be sure you pick 
Save when you are done, or your changes will be 
discarded!

Code
	 This is a predefined code that marks the pa-
rameter type for internal use.  It cannot be modi-
fied.

Parameter
	 This is a predefined code that is used to pro-
vide a plain language explanation of the parameter 
for that row.  It cannot be modified.

R, G, B
	 These are color codes, which must be a whole 
number between 0 and 255.  The R column is 
for red, G is for green, and B is for blue.  To pick 
orange, for example, you would set R to 255, G 
to 128, and B to 0.  You do not need to use these 
columns.  A vastly simpler input is available sim-
ply by clicking on the color swatch to the right of 
the R, G, and B columns.  If you do wish to enter 
R, G, and B values, the following resource may 
help:
    http://www.colorpicker.com/
Do not enter hex (hexadecimal) values; they will 
not be recognized.

Color swatch
	 Click on the color swatch to select a different 
color.  In the popup window, a crosshair will show 
the current color value.  Move it around or change 
the values to pick a new color.  The value of R, G, 
and B will be filled in automatically for.
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Contour type
	 Indicates the purpose of this contour.  It 
cannot be modified.

Unit
	 Proper entries are as follows.  Do not mix-
match units or the program will ignore the set-
ting and use a default unit.  Units marked with 
* cannot be changed.
   Temperature . . . . . . . deg f, deg c, deg k
   Moisture . . . . . . . .  g/kg
   Relative Humidity . . . . percent
   Horizontal Velocity . . . knots, mph, m/s
   Vertical Velocity . . . . ub/s (microbars 
					     per second)
   Height . . . . . . . . .  meters
   Pressure . . . . . . . .  mb, hpa, kpa, inches
   Precipitation Totals . .  inches, mm

Base
	 Determines the base value that the intervals 
are based off of.  For example, if you use an 
interval of 5 degrees, a base of zero will give 0, 
5, 10, 15, 20, 25.. degrees.  If you use a base of 
2 degrees, you.ll get 2, 7, 12, 27, etc.  Always 
reduce the base to the lowest common denomi-
nator (as close to zero as possible).

Interval
	 Represents the contour step interval (the 
numerical difference between each contour).

AI
	 Automated interval.  If y is entered, Digital 
Atmosphere will override the base and interval 
settings and choose the ones that will give the 
clearest view of the data field.

Style
	 Indicates the linestyle that will be used to 
draw the contour.  Acceptable values are solid, 

dash, or dot.  Radar echoes must be either solid, 
clear, bdiag, fdiag, cross, crdiag, horiz, or vert.

Making a new style
	 At some point you may not be happy with 
just editing the default styles.  When you want 
to create a new style, click the New... button.  
You will see a panel like this.
	 Enter a plaintext name.  Choose any phrase 
that will readily identify the map to you.  A 
brief phrase without any brackets should be 
used.
	 Filename for this map style.  The file shown 
here is what the filename will be on your hard 
drive.  This will be filled in automatically when 
you choose a plaintext name.  However the edit 
box gives you the opportunity to override the 
filename.  Only alphanumeric characters and 
dashes are allowed.
	 Style template filename (optional).  Normal-
ly the new color settings will be extracted from 
the \styles\master.stx file.  If you.d like to clone 
a different file, choose it here.

Creating style files manually
	 Advanced users can can create their own 
style files manually in a text editor, as long as 
the filename ends with *.sty, resides in the \styles 
directory, and conforms to the style formats 
shipped with Digital Atmosphere in this direc-
tory.  Incorrect configurations may produce an 
error in Digital Atmosphere and prevent fields 
from being generated.

NOTE: To set translucency on states, set the 
Styles > Misc. field for states to 1.  This will pre-
vent international borders from being redrawn 
with state/province line settings.

11.7. Misc1 tab
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Advanced internet settings
If you use a proxy host, enter the name and port 
here.  If you do not know the proxy settings, you 
will need to contact your ISP.  Our tech support 
personnel cannot guess thes settings or look them 
up for you.  For example, users of Alphalink in 
Melbourne, Australia will notice on their Al-
phalink support pages that they would need to 
enter proxy.alphalink.com.au in “Proxy host” and 
8080 in “Proxy port”.

Color gradient fills
	 This section lets you define how gradient fills 
will look.  It is designed mostly for experienced 
users and will require some basic mathemati-
cal knowledge.  The colors are defined according 
to the plotted Value for the particular point on 
the map, which will always be in the range 0..1, 
where 0 is the lowest possible reading and 1 is the 
highest possible reading.  This Value is fitted to a 
sine wave according to user defined parameters to 
determine the Red, Green, and Blue component 
of its color.
	 See the appendix for full information.

Planetary maps
	 This preference setting is used for Map > Plan-
etary Map generation.
* Smooth final image.  Applies a smoothing func-
tion to the finished planetary map.
* Reoverlay geography.  Plots the basemap on top of 
the planetary map.

Cities
	 Digital Atmosphere has certain functions 
related to cities (namely, Map > Cities and Map 
> Cursor City Distance).  It is impractical for all 
40,000 towns and cities in the United States to 
be displayed and used all the time.  Therefore this 
panel gives the user control over how many towns 
and cities are considered. 
	 Set the number high (in the thousands or tens 
of thousands) to use as few cities as possible.  Set 
the number low (in the tens or hundreds) to use 

as many cities as possible.  To determine whether a 
city will display at a given threshold, open digat-
mos.cty, look up the city, and look at its PROGDI 
value (cols 40-44).
	 You will have to enter a number lower than 
this value for it to be used.  There is some varia-
tion in the sensitivity between different states and 
you may need to increase or decrease the factor for 
your region.
* Cursor sensitivity threshold. This controls which 
cities and towns will be referred to when Map > 
Cursor City Distance is active.
* Plotting threshold.  Controls how many cities 
and towns will be plotted when Map > Cities is 
chosen.

Special diagnostics
	 This obtains diagnostic information for spe-
cialized user debugging purposes.  As of 2015 its 
only function was to obtain system time data.

11.8. Misc2 tab

Copy imported data to local file
	 If enabled, data will be saved to a local file 
with a fixed filename.  If you know how to write 
command line batch files, you can have a script 
which monitors this file for changes, and then 
when a change is detected it performs other opera-
tions on this file.

Debug GRIB data
	 (For internal use only)

Icons have black backgrounds
	 Icons plotted on the map will have black 
backgrounds.

11.9. Annotations tab
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Text annotations / Highs and lows
	 Highs and lows will be plotted with the 
characters shown here.  This is useful for inter-
national users who may have other abbreviations 
for high and low pressure areas.

Text annotations / Title
	 If this is enabled, a large title will be dis-
played at the top or bottom of the chart indicat-
ing the product name, such as “Station Plots”.  
You can use the other options here to further 
fine-tune the appearance of the title and disable 
the small, detailed legend that normally appears 
in the bottom left or bottom right corner.

Text annotations / Credits
	 This will display a permanent credit at one 
corner of the screen, such as a copyright, website 
name, or source.  Using the options here you 
can fine-tune it the way you want it to look.

Logo
	 Here you can specify a logo, such as a 
company image, to be displayed on the chart.  
Acceptable image types are GIF and JPEG.
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If you are having trouble with Digital Atmo-
sphere, first check and see if the problem you are 
having and its solution are listed here.  If not, you 
can obtain technical support via the Internet.  We 
always appreciate feedback and notification when 
users find bugs, since we are committed to pro-
ducing the best possible product.

A station plot I want to look at isn’t on the map
Digital Atmosphere operates with a default selec-
tion of using a clutter suppression algorithm, 
which avoids plotting a station if there is a chance 
it will overwrite an neighboring one that’s already 
plotted.  You can turn this off by going to File > 
Preferences > Station Plots and checking “Plot All 
Stations”.  This may make your map VERY clut-
tered.  To have a legible, uncluttered map and see 
a particular station, your only options are zoom-
ing in further so that more stations in the region 
of interest are displayed, or eliminating a neigh-
boring station you don’t want to see by deleting it 
from the DIGATMOS.STN listing and selecting 
File, Recompile Tables.  Plans are in the works 
for a station priority function that forces Digital 
Atmosphere to always plot a desired station before 
it uses the clutter supression algorithms.

The analysis isopleths don’t seem to match well 
with the data.
All objective analysis routines are smoothed so 
that the isopleths don’t look extremely coarse.  
You can reduce the smoothing operators in the 
File, Preferences, Analysis menus.  Also, take into 
account that if a station sends out a bad meteoro-
logical value, the analysis may yield a more rep-
resentative value than the station plot itself.  You 
can clean up bad data using the Quality Control 
command as discussed in previous chapters.  If 

you need extremely accurate isoplething, hand 
analysis (on top of a printed map) is always the 
best solution.

Why are some station plots red or blue?
A red station plot indicates instrument flight rules 
(IFR), which means bad weather with the ceil-
ings below 1000 feet and/or the visibility below 3 
miles.  A blue station plot indicates marginal vi-
sual flight rules (MVFR), meaning marginally bad 
weather, with the ceiling below 3000 feet and/or 
the visibility below 5 miles.  These colors are use-
ful for helping you visualize areas of poor weather 
at a glance.  Areas poleward of a warm front are 
often characterized by extensive IFR (red) areas.

How can I make a map with the colorful topog-
raphy?
Whenever you use the Map, Generate Map com-
mand, the map is always in monochrome outline 
format.  Topography is something you have to add 
in manually if you want it.  If you want to elimi-
nate ocean fills, there’s an option in File, Prefer-
ences in Graphics that will turn it off.

Every now and then when generating a map, I 
see an area that’s been flooded by an ocean fill.
There is probably a defect in the geography file 
that allows a gap in the coastline to be plotted.  
Let me know all the settings on the “Generate 
Map” panel so I can reproduce it.  You may be 
able to fix this yourself by zooming in on the sus-
pect area and making changes to the data in the 
geography files to isolate and close off the coast-
line gap (see the File Commands, Generate Map 
section).  If you succeed, let me know what you 
did so I can fix the distribution copies. 

12 / FAQ
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I just generated a map and noticed a certain 
inlet or water body did not fill with an ocean 
color.
If you modify the [digitalatmosphere]\GEO\
FILL.GEO file, you can add in a new “point” 
where an ocean color fill can be forced.  Simply 
right-click on the unfilled area and choose “Get 
lat/long”.  Using this lat/long, enter it in the 
FILL.GEO file. Future map generating opera-
tions will fill this area starting at this point.

Digital Atmosphere never fills ocean colors. 
This may happen if the map background color is 
set to a custom (non-basic) color. It is a limita-
tion of the graphics components we are using. 
To remedy the problem, go to File > Preferences 
> Maps > “Background Color” and choose a 
color under Basic Colors (not a custom one) 
and make sure that Water Body Fill is checked. 
Then re-generate your map. 

The printer responds with “overflow error” or 
erratic “out of paper” errors
The maps that Digital Atmosphere sends to 
your printer are huge and for best results will 
require 4MB or more of RAM on your printer.  
This usually isn’t a problem with inkjet printers 
(where the printfile can be spooled off the hard 
drive), but laser jet printers require a complete 
image in their memory before they print to the 
drum.  If this is the case, go to File > Printer 
Setup and change the resolution settings so the 
map is printed at a lower resolution.  Another 
remedy is to avoid solid color fills, such as 
topography, blue oceans, etc, since they take up 
considerable printer memory.

The Digital Atmosphere status bar shows a 
countdown message down to zero, then I get 
the error message “Automatic/EMWIN sur-
face file not found.” 
How it happens: When Digital Atmosphere is 
in EMWIN Scheduler mode, every 60 seconds 
it checks the “EMWIN Data Directory” for the 
presence of the “EMWIN Surface Datafile”. If 

there is no such file, an error message is returned 
and Digital Atmosphere turns off the EMWIN 
Scheduler.
How to fix it: First, find out what file the surface 
observations are being stored in. For example, 
the satellite EMWIN feed usually puts them in:
    Directory:
	 C:\WEATHER\WXDATA\RXFILES\
    File:
	 SAHOURLY.TXT
Check this in Digital Atmosphere by going to 
File > Preferences > General.  Compare “EM-
WIN Data Directory” to the correct directory 
and “EMWIN Surface Datafile” to the correct 
data file. 

FD observations will not plot. 
This is usually due to one of several things: 
* The file containing weather observations either 
does not contain FD observations or was not 
imported by Digital Atmosphere. 
* Before plotting the data, the current level is 
not set to a level in feet.
* The FD observations have been reformatted 
or are in a nonstandard format, and they have 
failed the pattern recognition algorithms in 
Digital Atmosphere. If this happens, please send 
a sample of the file (no larger than 50K) to sup-
port@weathergraphics.com and we will try to 
provide added support for the format in future 
releases of the program. Be sure to clearly mark 
what is wrong with the sample or we will not be 
able to do anything with it. 

Upper level height contours don’t work. The 
computer freezes up. 
Check File > Preferences > Analysis > “Figure 
geostrophic heights”.  When it is checked, 
height contours can take a long time on slow 
computers -- for example if you have a 486 it 
can take several minutes.  The results are im-
pressive but the time may be too much for 486 
users.
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Do you need the Internet to use Digital Atmo-
sphere? 
No, you don’t. Digital Atmosphere will work with  
saved (canned) data, as long as it is given a file 
containing raw weather data. 

How can I change isopleth colors, linestyles, 
and intervals? 
Just go to File > Preferences > Contours and make 
the changes.

I get a “Range Check” or “Floating Point Over-
flow” error when importing data.  However 
everything else seems to work fine. 
This is caused by a corrupt data element in your 
file that is causing Digital Atmosphere to abort 
one of the import modules. It will continue 
importing data, but one of the data types (such as 
synoptic, SD, or rawinsonde) will be unavailable. 
Range check errors are for the most part harmless 
though annoying. If this happens, please send a 
sample of the file (no larger than 50K) to sup-
port@weathergraphics.com and we will try to fix 
it in the next version of the program. Be sure to 
clearly indicate the problem with the sample or we 
will not be able to do anything with it. 

How can I download data to a file and then 
load it into Digital Atmoshere so that it can 
process the data? 
You must save the incoming weather data into a 
disk file. Under your favorite browser, bring up 
the raw data on your screen, then choose “File, 
Save As...” and save it as a text file (not HTML).  
Remember the location you saved it to.  Then go 
into Digital Atmosphere, choose “File, Import a 
file...” and choose that file. After it imports, you 
can then plot and analyze it.  Note that if you’re 
on the Internet, you can skip this whole process 
by choosing Internet > Retrieve Data and let Digi-
tal Atmosphere do all the work.

I’m having problems printing to my HP Laser-
Jet printer.
Some users report problems printing to HP Laser-
Jet printers (such as getting blank pages).  To fix 
this, go to print setup (below), and either change 
the resolution from 600 to 300 dpi or change 
“vector” to “raster”.  If your printer is equipped 
with a PostScript option, use the PostScript mode 
for 600-dpi printing. This 600-dpi PCL5 print-
ing problem is not specific to Digital Atmosphere.  
Documents with various graphic images may not 
print correctly to the LaserJet 4 in PCL mode at 
600 dpi unless the Graphics option in the Win-
dows printer driver setup is set to Raster mode.

Digital Atmosphere is missing the mouse 
tracker and roaming SKEW-T. 
The mouse tracker has been replaced by right-
clicking on the map and choosing “Get lat/long”.  
The roaming SKEW-T will be enabled soon. 

When using the Internet Data Retrieval func-
tion, Digital Atmosphere always retrieves the 
wrong file, a missing file, or the file for an 
incorrect time. 
This will happen if your computer clock is set to 
the wrong time or Windows is set to the wrong 
timezone.  Also if you’ve recently gone off or came 
onto daylight saving time, check File > Preferences 
> General > “Adjust for daylight time”.  To set 
the timezone, head to your Windows status bar 
and right-click on the time clock.  Choose Adjust 
Time/Date. Then look at the Time Zone tab. 
Make sure these settings are all correct.  Digital 
Atmosphere tries to determine UTC (Greenwich 
Mean Time) based on the system time and the 
time zone setting, and using this data tries to 
retrieve the appropriate file. 

Digital Atmosphere will let me perform one 
Barnes analysis, but if I try to perform a second 
Barnes analysis I receive the Range Check error. 
A couple of bugs in the functions used by the 
Cressman and Barnes analysis are known to exist. 
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How can I customize the Television Plot cit-
ies? 
All you need to do is look in your Digital At-
mosphere program directory (using any ASCII 
editor such as Windows Notepad) and edit the 
file named DIGATMOS.PLL . Columns 1-4 
should contain the ICAO (for METAR obser-
vations) and columns 6-10 should contain the 
synoptic station number (for synoptic observa-
tions). Either the ICAO or synoptic identifier, 
or both, can be used. Columns 12-50 should 
contain the text for the station that you want 
plotted on the map (leave it blank if you want 
nothing). We hope to do away with this crude 
interface in an upcoming version of Digital 
Atmosphere and add a city list interface. 

I performed a contour analysis but no lines 
appear. 
In most cases, the contour lines have been set to 
the background color.  Go to File > Preferences 
and check the colors under the Map tab and the 
Contours tab.
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APPENDIX
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APPENDIX A — Terminology

Please refer to these key terms when 
asking for technical support or 
talking with other users.  It will 
help streamline some of the confusing 
“lingo” used for the functions in this 
program.

ACTIVE LEVEL — At any given moment, 
Digital Atmosphere will only perform 
analysis or plotting operations for a 
certain type of data or height/level 
(such as surface, 300 mb, NGM model 
output, etc).  Active level describes 
which one is the current one.  You 
change it by going to the Level menu.  
The active level is indicated by a 
checkmark in the Level menu, as well 
as in the title of the status panel.
ANALYSIS — See objective analysis.
DERIVATIVE FIELD — The vorticity, 
divergence, or advection of a selected 
primary field.
DIALOG BOX — Any box (window) that 
pops up on the screen temporarily 
asking you to enter or click 
something.
FORMATTED BINARY DATA FILE — The 
end results of File, Import, where 
tables of raw data are stored on disk 
and made available to the plotting 
or analysis routines.  These files 
consist of compressed data and can 
only be modified using the File, 
Quality Control function.
IMPORTING — The process of “crunching” 
raw data.  This is how you feed new 
data into Digital Atmosphere.  The 
data is stored in formatted data 
files.
ISOPLETHING — The process of Digital 
Atmosphere drawing contours, or lines, 
on the screen, as the result of an 
objective analysis.  Isopleths are not 
“plotted”; they are “drawn”.
MAP ATTRIBUTE FILE — A small file 
(36 bytes) that is paired with a 
geographical bitmap file to provide 
mathematical mapping information about 
that image.  A map attribute file has 
the file extension “ATR”.
MAP GENERATION — Forcing Digital 
Atmosphere to draw a customized map 
based on latitude, longitude, and zoom 

settings that the user selects.
OBJECTIVE ANALYSIS — The process that 
Digital Atmosphere undergoes before 
it can show a contour or isopleth.  
It consists of looking at data at 
randomly-spaced points, mapping it to 
a grid, and running smoothers on the 
grid.  In the context of this user’s 
guide, I will refer to objective 
analysis as simply “analysis”, and 
refer to human analysis as “hand 
analysis”, etc.
OCEAN FILL — The blue color that 
Digital Atmosphere usually draws in 
oceans and lakes.
PLOT — See station plot.
PRIMARY FIELD — An atmospheric property 
that the user chooses to analyze.  The 
user may also force Digital Atmosphere 
to calculate a derivative field of the 
primary field.
RAW DATA FILE — The original weather 
data from online services, the 
Internet, etc, that is fed into 
Digital Atmosphere when the user 
selects File, Import.  First, the file 
is copied and filtered to produce a 
clean data file (C:\DIGATM\DATA.USR), 
and then data is imported, producing a 
formatted data file.
STATION PLOT — A small grouping of 
numbers and symbols that depicts the 
observed weather at a given location.  
Plots are not “drawn”; they are 
“plotted”.
STATUS PANEL — The window that shows 
the clock, the active level, data 
display options, and import filters.
STERILIZED DATA FILE — A temporary 
file containing original raw data 
that is produced whenever the user 
imports data.  It contains no control 
codes or extraneous characters.  The 
sole purpose of a clean data file is 
for the File, View Raw Data command 
and for Digital Atmosphere functions 
where English-language bulletins are 
drawn on the screen (such as tornado 
watches, convective outlooks, etc).  
Weather data plots and analyses do 
not come from this file, but from the 
formatted data file.
TOPOGRAPHY — The multicolor shades 
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that can be manually drawn on 
landmasses to represent terrain.
UPPER AIR — Involving any level 
besides the surface.
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A custom data field comprises a package of data that can be readily imported 
into Digital Atmosphere.  You can create this data by any means (using third-
party programs).

The custom data field must always be placed in the file CUSTOM.DAT in your 
Digital Atmosphere directory.  It should be structured according to the 
following example:

   THUNDERSTORM DAYS (ALL MONTHS)
   US AL:Bir 722280    33.567    -86.750   57        *                 
   US AL:Oza 722269    31.283    -85.717   73        *        
   US AL:Hun 723230    34.650    -86.767   54        *        
   US AL:Mon 722265    32.383    -86.367   56        *        

Here is a breakdown of each row and column:

Row 1   A header that will be used by Digital Atmosphere to title the field
Row 2+  Custom data

Column 1-19    Not used.  The user may wish to put location names here.     
Column 21-29   Latitude (degrees and thousandths; negative is southern 
hemisphere)
Column 31-39   Longitude (degrees and thousandths; negative is western 
hemisphere)
Column 41-49   Primary data value
Column 51-59   Secondary data value

Ingesting a scalar field.  When a simple scalar field (such as temperature, 
pressure, wind speed, etc) is imported, the value must be placed in the primary 
data value field, and the secondary data value field must contain an asterisk 
character: *.

Ingesting a vector field.  If a numerical value is detected in the secondary 
data value field, Digital Atmosphere will assume a vector field (such as 
wind u/v component) is being ingested.  The primary data value must assume a 
direction relative to true north (such as wind direction), and the secondary 
data value must assume a magnitude (such as wind speed).  When vector data mode 
is being used, analysis calculations will use wind barb symbology to represent 
data elements.

APPENDIX B — Custom data fields
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APPENDIX C — Map attribute file format

For technically inclined users only!

This file, ending with the file extension *.ATR, is associated with each map 
which is saved to disk.  The attribute file consists of 6 48-bit real numbers.  
They can be modified as follows:

Number	 Purpose
1		  Central latitude (degrees)
2		  Central longitude (degrees)
3		  Zoom setting
4		  Horizontal offset (in pixels)
5		  Vertical offset (pixels)
6		  Projection, where
		    0 or 2 = orthographic
		    1 = polar stereographic (not implemented)
		    3 = space oblique (not implemented)
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APPENDIX D — Field and product codes

Product codes
Representing a set of data (a product).

pla ACARS plots
plf Standard data plots
plc Custom data plot
tdy Television-style data plots
rad Radar plots
sf0 Europe sferics (0 hr)
sf6 Europe sferics (6 hr)
wgr Wind grid

Field codes
Representing a single quantity; usually a scalar value.

tmf Temperature (deg F)
tmc Temperature (deg C)
pot Potential temperature (deg K)
wcx Wind chill factor
hix Heat index
dwf Dewpoint (deg F)
dwc Dewpoint (deg C)
rhu Relative humidity
mxr Mixing ratio
eqp Equivalent potential temperature (theta-e)
slp Sea level pressure
alt Altimeter setting (QNH)
wsp Wind speed
cig Ceiling
hgt Geopotential height
thk Thickness (1000-500 mb)
wrx Warning overlays
p01 1-hour precipitation
p06 6-hour precipitation
p12 12-hour precipitation
p18 18-hour precipitation
p24 24-hour precipitation
rst RCM radar storm centroids
rhl RCM radar hail signatures
rms RCM centroid movement and speed
rtv RCM tornado TVS signature
reh RCM echo height signatures
rem RCM echo movement
wxp ASUS1 KWBC frontal depiction bulletin
ste Sea surface temperature
pdw Wave period
htw Wave height
hti Wave instrument-measured height
pdd Wind wave period
htd Wind wave height
di1 Primary swell direction
di2 Secondary swell direction
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pd1 Primary swell period
ht1 Primary swell height
pd2 Secondary swell period
ht2 Secondary swell height
cig MVFR/IFR weather
dy1 SPC Convective Outlook Day 1
dy2 SPC Convective Outlook Day 2
06k Surface-6000 ft shear [not completed]
lcl Lifted condensation level [not completed]
be+ CAPE [not completed]
be- CIN [not completed]
cxx [not used]
hux [not used]
iht [not used]
zb+ [not used]
prt [not used]

Radar product codes
All ranges 128 nm unless otherwise noted

Base reflectivity
BREF1  Base reflectivity 0.5 deg
BREF2  Base reflectivity 1.5 deg
BREF3  Base reflectivity 2.4 deg
BREF4  Base reflectivity 3.4 deg
BR248  Base reflectivity 0.5 deg (248 nm)

Base velocity
BV32   Base velocity 0.5 deg (32 nm)
BVEL1  Base velocity 0.5 deg
BVEL2  Base velocity 1.5 deg
BVEL3  Base velocity 2.4 deg
BVEL4  Base velocity 3.4 deg

Base spectrum width
SW     Spectrum width
SW32   Spectrum width (32 nm)

Derived products
CR     Composite reflectivity
CR248  Composite reflectivity (248 nm)
ET     Echo tops
SWP    Severe weather probability
VIL    Vertically integrated liquid
STI    Storm tracking
H      Hail detection
TVS    Tornado vortex signature
M      Mesocyclone
OHP    One-hour precipitation
THP    Three-hour precipitation
STP    Storm total precipitation
SRMV1  Storm relative velocity 0.5 deg
SRMV2  Storm relative velocity 1.5 deg
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SRMV3  Storm relative velocity 2.4 deg
SRMV4  Storm relative velocity 3.4 deg
CFC    Clutter filter



82  |  DIGITAL ATMOSPHERE MANUAL / September 2017



DIGITAL ATMOSPHERE MANUAL / September 2017 |  83

APPENDIX E — GRIB data

Because of the complexity of GRIB data and the fact that it is not fully 
supported by Digital Atmosphere yet, Weather Graphics Technologies will not 
provide assistance in locating, retrieving, or using GRIB data.  It is provided 
as-is.  Comments are welcomed but we may not be able to respond to questions. If 
you need help, please access our public discussion group on our website at www.
weathergraphics.com

Sources
The majority of GRIB output data is available from supercomputer models, such 
as the ETA model output provided by the National Center for Environmental 
Prediction near Washington DC. Sources of data include:

    ftp://140.90.88.142
    http://weather.noaa.gov/pub/SL.us008001/ST.opnl/      - Choose the .grl 
directories. Within these, try to choose the smallest datasets, as even the 
smallest ones will contain a vast amount of data. The larger ones may crash 
Digital Atmosphere. A good dataset usually ends in awp211. These are GRIB sets 
but will not have a *.grb extension. To get them to show up you will need to 
change the filetype to “AWIPS” or “all” when choosing a GRIB file to import.
    http://nomad3.ncep.noaa.gov/   (new as of 2006)
    http://www.globalmarinenet.net/grib.htm
    http://www.ecmwf.int/products/realtime/d/gts/essential/

Documentation

Documentation for the GRIB format includes:

    http://www.nws.noaa.gov/dataprod.html

    http://205.156.54.206/oso/ftpgenl.shtml

    http://zephyr.unl.edu/grids/

    http://www.ncep.noaa.gov/NCO/PMB/docs/on388/tablea.html (MMM model codes)

    http://www.ncep.noaa.gov/NCO/PMB/docs/on388/tableb.html (grids with pole 
point listings)

    http://www.comet.ucar.edu/strc/data/model_data_summaries/ (lists grids w/ 
images and model codes in current use)

    http://www.comet.ucar.edu/strc/data/model_data_summaries/osoname.html (GRIB 
naming conventions)

    http://dss.ucar.edu/docs/formats/grib/gribdoc.pdf (Complete documentation)

    http://weather.unisys.com/wxp/Appendices/Formats/GRIB.html (more 
documentation)

    http://weather.unisys.com/wxp/File/Model_Name.html

    http://www.cgd.ucar.edu/cms/eaton/cf-metadata/ECMWF.html
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New NWS GRIB filename convention

Since 2002, the NWS has used a hierarchichal naming convention that forms a 
URL. An example is:
  http://weather.noaa.gov/pub/SL.us008001/ST.opnl/MT.eta_CY.00/RD.20031009/
PT.grid_DF.gr1/fh.0000_tl.press_gr.awp211

This shows that at the central server location (SL.us008001), one can find 
operational status data (ST.opnl) consisting of the Eta 00Z cycle model (MT.
eta_CY.00) produced on 09 Oct 2003 (RD.20031009). Within this one can find 
GRIB data (PT.grid_DF.gr1) consisting of data for the 00h forecast hour 
mapped onto the AWIPS 211 grid (fh.0000_tl.press_gr.awp211).

For more information on this naming convention see
   http://www.nws.noaa.gov/datamgmt/filstnd.html (Directory and File Naming 
Standards)
and
   http://www.nws.noaa.gov/datamgmt/tgftp_file_reference.html (TGFTP File 
Reference).
Information on grids is at
   http://wwwt.emc.ncep.noaa.gov/mmb/etagrids/

 

Old NWS GRIB filename convention

The legacy filename format for NWS GRIB data is as follows. Some datasets can 
still be found in the top-level directory at http://weather.noaa.gov/pub/ 
which use this filename convention.

Sample: us008_gf000_02020300_HxXAx

Portions: us008_gfMMM_YYMMDDHH_ADGT

Here is what each field means:

MMM - Model code. Underlined codes are in current use as of February 
2002; others are obsolete and are listed only for historical purposes. 
000=Experimental, 010=GlobalWindWave, 039=NGM, 044=SeaSfcTemp, 
076=MRFbiascorrected, 077=AVNfcst, 078=MRF, 080=MRF, 081=AVNinit, 
082=MRFinit, 083=ETA80km, 084=ETA22km, 085=ETA29km, 086=RUC60km, 089=ETA48km, 
094=MRF-T170/L42, 096=AVNfcst-T170/L42, 121=WesternNorthAtlanticwavemodel, 
122=AlaskaWatersRegWaveModel, 130=MergeOfRucEtaSpectral.

YYMMDDHH - Year, month, date, and hour - of model start time.

A - GRIB designator - H=WAFS (Family Of Services), Y=AWIPS, Z=AWIPS.

D - Data type. X=mixture.

G - Grid. A=201 (Nhem/PS), H=213 (US/PS), I=202 (US/PS), J=203 (Alaska/
PS), K=204 (Hawaii/MER), L=205 (PuertoRico/PS), M=206 (CentralUS/LAM), N=207 
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(Alaska/PS), O=208 (Hawaii/MER), P=210 (PuertoRico/MER), Q=211 (US/LAM), R=212 
(US/LAM), T=214 (Alaska/PS), U=215 (US/LAM), V=216 (Alaska/PS), X=experimental. 
Code following the geographical area means PS=Polar Stereographic, LAM=Lambert 
Conformal, MER=Mercator.

T - Timestamp. A=00, B=06 C=12, D=18, E=24, F=30, G=36, H=42, I=48, J=60, K=72, 
L=84, M=96, N=108, O=120, P=132, Q=144, R=156, S=168, T=180, U=192, V=204, 
W=216, X=228, Y=240. However if “A” (GRIB designator) is Z (AWIPS), this will 
instead be A=02, B=03, C=04, D=08, etc.

Note that Digital Atmosphere will only process grids mapped in lat/long, polar 
stereographic, and lambert conformal projections
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APPENDIX F — Scheduler scripting

Scripting is a powerful function that allows Digital Atmosphere to do various 
tasks while unattended. You can have it download data every half hour and always 
have the latest map displayed, or send charts to the printer automatically. The 
possibilities are up to you.

 

Scripting basics

To run a single script command
Simply type in the script command in the “command” line on the scripts toolbar. 
Hit return or click “Enter” and it will be processed. Note that this does not 
run a script; it just runs a script command. A list of commands is below.

To write a script
Use any text editor or click on Create Script on the scripts toolbar and you can 
begin typing your script. Note that scripts should use the file extension .dsf 
in order to be properly recognized in Digital Atmosphere. To “comment out” a 
line of code simply place a # (octothorpe), : (colon), or ; (semicolon) at the 
beginning of the line. Commands are generally not case-sensitive.

To run a script in run-time
Go to the scripts toolbar and select the Run Script button.

To run a script at startup
Advanced users can run scripts on Digital Atmosphere startup by using standard 
command-line parameters. A space and the full name of the script file is simply 
appended after the filename at the command prompt or in the shortcut property 
for Digital Atmosphere.

To use the scheduler
Go to the scripts toolbar and select the Scheduler button (it will say 
“Scheduler on...” or “Scheduler off...”). This will bring up a configuration 
window (see below) where the scheduler will coordinate which script files run at 
which time.

* You must set “Enable scheduler” for the scheduler to take effect.
* When the scheduler is no longer wanted, bring up this window again and unset 
“Enable scheduler”.
* To specify the execution time for each script, write the execution time in 
4-digit UTC time in hhmm format (i.e. 7:45 am is 0745 and 2:15 pm is 1415), 
followed by a space, and the name of the file (including its .dsf extension).
* Be sure to specify the full pathname of the file, otherwise Digital Atmosphere 
will assume it is located in your Digital Atmosphere directory.
* There can be an unlimited number of scripts and execution times in this list.
* Advanced users: You can edit or swap out this schedule list if you wish; it’s 
located in the Digital Atmosphere directory under digatmos.sft . 
 
Valid script commands

DATA DISPLAY COMMANDS
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PRODUCT,type,level,title
Overlays a meteorological product on the map. The appropriate data must have 
already been imported. Valid type parameters are documented at the end of 
this section. Levels are specified as follows: for surface data, the level is 
0 (zero); for millibar levels the level equals the millibar level (500, etc); 
and for FT height levels the level equals the ten-thousands and thousands 
digits multiplied by -1 (so 34,000 ft equals -34). The title parameter is 
optional and contains a text title that will be placed in the legend. Derived 
fields are not supported at this time.

ANALYZE,scriptstring
Performs an analysis using an analysis script command. For information on 
building an analysis script command please see the Analysis section.

FONTTRUETYPE
Forces workchart fonts to TrueType mode.  Takes effect when new products or 
contours are displayed.

FONTNCEP
Forces workchart fonts to NCEP raster font mode.  Takes effect when new 
products or contours are displayed.

SFCPLOTMODEL,filename
Loads a particular surface plot model. Filename must be the fully qualified 
filename with path and extension (*.sps).

DATA MANAGEMENT COMMANDS

DOWNLOAD,url,filename
Downloads a product from an Internet source. The url is the fully qualified, 
RFC 1738 standard URL (including filename), and filename is the full local 
name where the file will be stored.
Example: download,ftp://userid:password@ftp.mydomain.com/anonftp/pub/out.
jpg,c:\da20\bin\map\in.jpg

UPLOAD,url,filename
Uploads a product to an Internet source. The url is the fully qualified, RFC 
1738 standard URL (including filename), and filename is the full local name 
of the file to be uploaded.
Example: upload,ftp://userid:password@ftp.mydomain.com/anonftp/pub/out.
jpg,c:\da20\bin\map\out.jpg

Note that you can set a password privately by using the DIGATMOS.PWD file (if 
there isn’t one, you may create it).  This will make your scripts secure and 
prevent passwords from showing up in the status windows. This file must be 
located in the Digital Atmosphere directory.  Make entries as follows:
token=value
So if you have a login for your blog site, you might have something like this 
in your DIGATMOS.PWD file:
myusername=joeblow
mypassword=12341234
When Digital Atmosphere encounters %%something%% in your URL, it will replace 
it with the values you defined in DIGATMOS.PWD.  Thus, in the example above 
%%myusername%% would get replaced with joeblow, and %%mypassword%% would get 
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replaced with 12341234.

INGEST,filename
Imports the specified data file (filename is a fully qualified file name).

RADAR COMMANDS

RADAR,product,station
Retrieves the desired radar product from the given station.  Station is a 
3-letter station identifier (e.g. FWS, EWX, etc).  Multiple stations are 
separated by one space character.  Product is the Radar Product Code from the 
table below.

RADARPLOT
Plots the latest retrieved radar data.

RADARSAVE,filename
Saves the latest retrieved radar data to a given filename.

IMPORTRADAR
Imports an imagemap radar, using parameters selected in Radar > Import Radar 
Images.

DERIVED PRODUCT COMMANDS

HURRICANE
Imports hurricane bulletins.

HURRMODEL,type
Plots hurricane models.  The type is as follows: 0, splines only; 1, splines and 
datapoints; 2, splines, datapoints, and labels.

FLEET
Plots all fleetcode information.

FLEETHL
Plots fleetcode bulletins with only highs and lows.

FLEETF
Plots fleetcode bulletins with only fronts.

FLEETI
Plots fleetcode bulletins with only isobars.

 
GRAPHICS COMMANDS

LOAD,filename
Loads a map. IMPORTANT: You must specify the .dmf file in your filename, e.g. 
c:\da20\bin\mymap.dmf . The associated map will also be loaded.

SAVE,filename
Saves a map. The filename parameter is the fully qualified filename without the 
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extension (i.e. without .bmp).

EXPORT,filename
Exports a map (i.e. saves it to a variety of formats and without the 
accompanying .atr file). The filename parameter is the fully qualified 
filename with a valid extension (may be bmp, gif, jpg, png, pcx, or tif). 
Compressed TIFF saving is not available.

IMPORT,filename
Imports a map.

SOUNDING,station
Plots a sounding for the given station.

ERASE
Erases all of the overlays on the map.

BLANK
Erases the overlays as well as the basemap.

STAMP
Imprints a timestamp at the top of the map that says “GENERATED (date) 
(time)”.

CLIP
Copies the map to the clipboard.

GRADIENTCOLOR,red|blue|green,ph1|ph2|scale|offset,value
Sets one of the File > Preferences > Misc > settings to a particular value. 
This allows the script to change a contour gradient scheme on the fly.

PROGRAMMING COMMANDS

SET,keywordnumber,keyword
Sets a specified keyword (1 through 9) to a certain value. You can then 
use this keyword later on in the same script simply by placing the token 
$$x anywhere in the code, where x is the keywordnumber. This is useful for 
managing large scripts.

    Example:
    SET 1 500 Sets keyword 1 to “500”
    PRODUCT $$1 HGT $$1 indicates “500”, so here 500 mb heights are plotted
    PRODUCT $$1 TMP $$1 indicates “500”, so here 500 mb temperatures are 
plotted

TIMERON
Enables the script timer. It will adhere to the current timer script 
schedule.

TIMEROFF
Turns off the script timer.

PRINT
Prints the map to the default printer using default settings.
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SLEEP,seconds
Causes Digital Atmosphere to pause for the specified number of seconds. An 
hourglass cursor will be displayed during this time.

SPAWN,filename
Executes an executable file or MS-DOS batch file specified by filename (must 
be a fully qualified filename with correct path; e.g. “c:\utilities\myprogram.
exe”).

MINIMIZE
The Digital Atmosphere application window is minimized.

MAXIMIZE
The Digital Atmosphere application window is maximized.

NORMAL
The Digital Atmosphere application window is neither minimized nor maximized.

QUIT
Quits the program

MAPMAKING COMMANDS

MAKE,lat,long,zoom,width,height
Makes a map using the given coordinates. Lat is negative in the southern 
hemisphere. Long is negative in the western hemisphere. Zoom is a value equal to 
3964/x, where x is the width of the map in statute miles. Width and height are 
the map sizes in pixels.

TOPO
Makes a topographic underlay on the map (takes some time).

POINT
Plots points.

BASEMAP
Plots the basemap.

CITY
Plots cities.

COOUT
Plots county outlines.

CONAME
Plots county names

HIGHWAY
Plots Interstate highways (U.S. only).

ROAD
Plots major roads (U.S. only).
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CUSTOM
Plots custom overlays.

REMOVE
Removes the last product from the display.

 
DEPRECATED COMMANDS

THESE COMMANDS ARE NOT SUPPORTED AS OF THIS BUILD

CENTER,station,zoom,width,height
Makes a map with the chosen station in the center of the screen. Zoom is a 
value equal to 3964/x, where x is the width of the map in statute miles. 
Width and height are the map sizes in pixels.

ARCHIVE,cddriveletter,yymm,yymmddhh
Accesses data from the Weather Graphics Technologies Surface Archives or 
Upper Archives CD-ROM. The cddriveletter parameter is the drive letter, 
while yymm is the year and month (full four digits) and yymmddhh is the year, 
month, date, and hour (full eight digits). Caution: This command has not been 
fully tested and may not work.

GRADIENT,on|off
Turns on or turns off the File > Preferences > Contours > option.

ISOPLETH,on|off
Turns on or turns off the File > Preferences > Contours > option.
 

LIST OF VALID PRODUCT TYPES
 
For a list of valid codes, see the appendix showing Valid Product Types.
 
 
Sample scripts

This script downloads synoptic data from Albany, imports it, displays plots 
and sea level pressure, and outputs it to a file. Note that this will 
probably not work on your computer without changes, and is only intended to 
demonstrate the appearance of script commands.

    download,http://www.atmos.albany.edu/weather/data1/surface/syn/@Y@M@D@S_
syn.wmo,c:\digatm\data\test.dat
    import,c:\digatm\data\*.*
    product,plf,0,Test plot
    product,slp,0,Test plot
    export,d:\da20\bin\map\out.jpg

This script plots a series of upper air charts for 1200 UTC August 27, 1990 
from our Upper Archives CD-ROM and saves the completed charts for 250 mb, 500 
mb, 700 mb, and 850 mb to individual files (1990082712250.gif, etc). Again 
this may not work on your computer without some changes.

    set,1,9008
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    set,2,90082712
    archive,f,$$1,$$2
    product,plf,250,PLOT
    export,d:\da20\bin\shannon\19$$2250.gif
    erase
    product,plf,500,PLOT
    export,d:\da20\bin\shannon\19$$2500.gif
    erase
    product,plf,700,PLOT
    export,d:\da20\bin\shannon\19$$2700.gif
    erase
    product,plf,850,PLOT
    export,d:\da20\bin\shannon\19$$2850.gif
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APPENDIX G — Analysis scripting

Analysis scripting is slightly different from scheduler scripting. While 
scheduler scripts are designed to accomplish tasks in Digital Atmosphere 
such as accessing data, displaying fronts, and so forth, the analysis script 
language is based solidly on logic and mathematics, and is meant to build 
display products in a very flexible manner. (Note that you can run any analysis 
script command in a schedule script by using the ANALYZE command.)

A script is made up of a group of commands on one line. There are two ways of 
executing a script:

(1) On the command line (in the Toolbox under the Scripting tab).

(2) In the DIGATMOS.MNU file, which is used to build the Analysis dropdown 
menu. This may be edited by hand. The pipe, |, symbol is used to separate the 
title from the script form and may be placed anywhere between the two providing 
it is padded with spaces only. The Standard version is limited to 50 defined 
script commands; the Professional version is unlimited.
 

Command sentences

A sentence of analysis script code follows the strict order:

[output] [transform] [base] [setup]

(1) Digital Atmosphere processes the script from RIGHT TO LEFT , so that any 
optional setup is done (such as setting the level), then defining the base field 
to be worked on (such as temperature), then transforming (such as converting 
m/s to kts), then producing output (such as setting a contour interval and then 
displaying contours. Deviation from this form may cause unpredictable results.

(2) Users must be vigilant as to whether a scalar or vector field is being 
processed. For example, CONT WIND will result in a nonsensical output, because 
wind is a vector field and cannot be contoured (you can streamline it, but 
that command hasn’t been provided yet). To view wind speed, you will need to 
extract a magnitude by using CONT WSPD (contour windspeed) or using a vector-
to-magnitude function (which has not been provided yet).

(3) The active level is always taken from the Active Level setting on the 
toolbar. It can be overridden using a Setup command. The same is true for data 
Time settings.

(4) Multiple fields are handled by using the output form to write a field to 
a slot, such as STOR=5 to store the result in slot 5. Various transformations 
which depend on a field number, such as SDIF (scalar difference), are supplied 
with two field slots with which to read.

(5) Commands can be strung together to produce multiple fields. Currently there 
is a limit of 255 characters to a script command.

(6) Suggestions for transformation commands, output commands, operators, and 
so forth are greatly welcomed at this time. Much more is planned; this is only 
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a start! For an idea of what is possible see the PCGRIDDS documentation at 
http://www.lib.noaa.gov/pcgridds/appendix.html#C

(7) Scripts are not case-sensitive.

 
Examples

CONT CINT=4 SLPR
Explanation: Take the sea level pressure field. Set the contour interval to 
4. Now contour it. Note that the color is not set, so the result color is 
unpredictable. Also the level is not set, so if the current height setting is 
500 mb, an invalid fieldwill result.

DATA VKNT WSPD
Explanation: Take the wind speed field (which will be in m/s). Convert it to 
knots. Now view it as a numerical grid.

CONT CINT=60 DASH COLOR=200,0,0 SDIF=1,2 STOR=2 HGHT H000 STOR=1 HGHT H500
Explanation: Take the 500 mb height field. Store it in slot 1. Take the 1000 
mb height field. Store it in slot 2. Compute a difference between field 1 
and2.Nowsetthepencolorto200,0,0(lightred,i.e.red=200,green=0,blue=0. Set 
lines to dashed, and set a contour interval of60. Nowcontour theresult. This 
produces the1000-500 mb thickness.

For other examples please open the DIGATMOS.MNU file and study the examples 
provided. They drive the Analysis dropdown menu.
 

Summary of commands

SETUP

HSFC Set level to surface
H000 Set level to 1000 mb
H925 Set level to 925 mb
H850 Set level to 850 mb
H700 Set level to 700 mb
H500 Set level to 500 mb
H400 Set level to 400 mb
H300 Set level to 300 mb
H250 Set level to 250 mb
H200 Set level to 200 mb
H150 Set level to 150 mb
H100 Set level to 100 mb

Analysis method: if not specified, setting in Preferences > Analysis will be 
used
ANLN Sets analysis method to Nearest Neighbor
ANLW Sets analysis method to Weighted
ANLC Sets analysis method to Cressman
ANLB Sets analysis method to Barnes

BASE FIELDS
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TEMP Temperature (deg C)
THTA Theta, or potential temperature (deg K)
DWPT Dewpoint (deg C)
RELH Relative humidity (%)
BULB Wet bulb temperature (deg C)
MIXR Mixing ratio (g/kg)
HIDX Heat index (deg F)
HGHT Geopotential height (m)
GHGT Geostrophically balanced height field (m)
THTE Theta-e, or equivalent potential temperature (deg K)
PTEN Reported pressure tendency
WCHL Wind chill (deg F)
HIDX Heat index (deg F)
HUMX Humidex (deg C)
WSPD Wind, speed (m/s)
WIND Wind, vector (m/s) (referenced to true north)
WDRC Wind, direction (deg)
UGRD Wind, west-to-east component (m/s) (referenced to true north)
VGRD Wind, south-to-north component (m/s) (referenced to true north)
HGHT Geopotential height (m)
SLPR Sea level pressure (QFF) (mb)
ALST Altimeter setting (QNH) (in Hg)
PRES Pressure (mb) (used for upper-level heights)
LATT Latitude (deg)
LONG Longitude (deg)
ELEV Elevation (m)
TSEA Temperature, sea-surface (deg C)
PC01 Precipitation (1 hr)
PC02 Precipitation (2 hr)
PC03 Precipitation (3 hr)
PC06 Precipitation (6 hr)
PC09 Precipitation (9 hr)
PC12 Precipitation (12 hr)
PC15 Precipitation (15 hr)
PC18 Precipitation (18 hr)
PC24 Precipitation (24 hr)
PCXX Precipitation (unknown time period; used in Australian AXF data)
WSWP Wave period (sec)
WSWH Wave height (m)
WWWP Wind wave period (sec)
WWWH Wind wave height (m)
WLP1 Sea swell period 1 (sec)
WLP2 Sea swell period 2 (sec)
WLH1 Sea swell height 1 (m)
WLH2 Sea swell height 2 (m)
WLD1 Sea swell direction 1 (screen relative)
WLD2 Sea swell direction 2 (screen relative)

TRANSFORMATIONS

VKNT m/s to kt
VMPH m/s to mph
VKMH m/s to km/h
DEGF deg C to deg F
MAGN Magnitude of a vector field (produces speed for a wind field)
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DVRG Divergence of a vector field
RVRT Relative vorticity of a vector field (pure; used mainly at surface)
AVRT Absolute vorticity of a vector field (adds Earth’s rotation; used for 
upper air)
SMTH Apply Haltiner smoother
SMTP=[number] Allow this number of smoothing passes (default 1)
SMTC=[number] Set smoothing coefficient (0 to 1 only) (default 0.5)
SSUM=[f1,f2] Calculates sum of fields f1 and f2
SDIF=[f1,f2] Calculates difference of fields f1 and f2
SAVG=[f1,f2] Calculates average of fields f1 and f2
SMLT=[f1,f2] Calculates product of fields f1 and f2
SDVD=[f1,f2] Calculates quotient of fields f1 and f2
SADC=[f1,#] Calculates sum of field f1 and any number #
SSBC=[f1,#] Calculates difference of field f1 and any number #
SMLC=[f1,#] Calculates product of field f1 and any number #
SDVC=[f1,#] Calculates quotient of field f1 and any number #

OUTPUT

* UNIVERSAL OUTPUT COMMANDS

COLOR=r,g,bSetdrawcolortocolorr=red,g=green,b=blue (each is 0-255)
STOR= nStorefieldin slot n (1-9)

* SCALAR OUTPUT COMMANDS

DATA Data grid values
CONT Contour (defaults to contour interval of 1)
VAON Allow plotting of numeric values below minimum/maximum (default)
VAOF Prohibit plotting of numeric values below minimum/maximum
NMCY Plot highs and lows in special NMC font (default is according to 
Preferences > Analysis)
NMCN Plot highs and lows in standard font (default is according to 
Preferences > Analysis)
HILO Plots H or L above data at gridpoint maximum/minimum
HIID Plots H above data at gridpoint maximum
LOWD Plots L above data at gridpoint minimum
MXMN Plots H or L above data at gridpoint maximum/minimum
MAXD Plots H above data at gridpoint maximum
MIND Plots L above data at gridpoint minimum
DVCV Plots H or L above data at gridpoint maximum/minimum
DVVD Plots H above data at gridpoint maximum
CVVD Plots L above data at gridpoint minimum
PLMN Plots H or L above data at gridpoint maximum/minimum
PLLD Plots H above data at gridpoint maximum
MNND Plots L above data at gridpoint minimum
OVER Overlay basemap translucently (good for fills)
CINT=[number] Contour interval (must be an nonzero positive number)
GRTN=[number] Contours or fills greater than this number
LSTN=[number] Contours or fills less than this number
EQUA=[number] Plot a contour equal to this number
LINE=[number] Set line width (must be nonzero positive integer)
FILL Fill using fill color
SOLD Plot contours as solid line
DASH Plot contours as dashes
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DOTS Plot contours as dots
DADO Plot contours as dash-dot
DADD Plot contours as dash-dot-dot
FILL Perform a floodfill
FILS=[number] Set fillstyle to one of the following (must appear to right of 
FILL command):  0, Solid (default); 1, Cross; 2, Diagonal cross; 3, Diagonal 1; 
4, Diagonal 2; 5, Horizontal stripes; 6, Vertical stripes

* VECTOR OUTPUT COMMANDS

BARB Wind barbs (m/s)
BKNT Wind barbs (m/s shown as kt)
BMPH Wind barbs (m/s shown as mph)
BKMH Wind barbs (m/s shown as km/h)
VECT Vector grid
STRM Streamline
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APPENDIX H — Radar importing

The list of radar resources is kept in the file digatmos.rdy.

Example of making a radar image

Here is a quick tutorial on how to add a radar site.  We Googled “south 
africa radar” and found a radar image page at http://metsys.weathersa.co.za 
.  We go to the page for Durban and see that there is an image.  Right-
clicking on the image we see that the radar image is stored in http://metsys.
weathersa.co.za/radar_image/DN.gif (which is good, as loopers and non-fixed 
filenames can be considerably more complicated to deal with).  Now we need to 
get the latitude and longitude of this site.  It’s not anywhere on the page, 
however the website has a handy radar information page at http://metsys.
weathersa.co.za/nwrn.htm.  This shows Durban at 30.01S 30.93E.  Make a note 
of that.

Now we need to import the radar image into a graphics program; we use 
PaintShop Pro.  In your browser, right-click on the image and choose Copy 
Image.  Then paste it in your software.

In another window, open Notepad and then open your digatmos.rdy file in the 
Digital Atmosphere directory.  Start a new line at the top of the data block 
(anywhere in the list is fine, but entering new items at the top we can see 
the column headers more conveniently).

In your graphics program, position the cursor on the very center of the radar 
site and read the X/Y coordinates, wherever your graphics program displays 
it.  This shows a center position of304,367(X=304,Y=367).  Enter this into 
digatmos.rdy under XXX YYY.  So far it should look like this:

Now we need to find the top left and bottom right of the part of the image 
containing valid radar information.  This image has a border box enclosing 
the radar product; the legends are outside of it and the radar image is 
inside of it. We can use the border box.  The top left is (0,54) and bottom 
right is (612,665).  Enter this under LEFX,TOPY and RGTX,BOTY.

Now we determine the maximum range of the radar scan.  This can be seen 
easily with the 200 km ring.  So the range will be 200 km.  Enter that under 
RNG.  Now we need to determine a scale in pixels per km.  This is an easy 
task since the range rings and site center are obvious.  Since the leftmost 
extent of the 200 km ring is at X=0 and the radar center is X=304, this means 
that we have 304 pixels per 200 km of distance.  Do the division and we get 
304/200 = 1.52.  Fit this figure under SCALE.

Now put the latitude and longitude under LATITU LONGITU.  Note that if your 
figures came in degrees-minutes-seconds you need to convert them to decimal 
values before entering them here.  Fortunately the South Africa radar 
information page gave us decimal degrees.  Always use negative for westerly 
longitudes and southerly latitudes.  So we will be entering -30.01 30.93.

Now let’s get the URL of the image.  Simply right-click on the radar image 
in your browser and choose Copy Image Location.  Paste this under URL in 
digatmos.rdy.  In this case the image is at http://metsys.weathersa.co.za/
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radar_image/DN.gif .

Under FMT we need to enter the image format type.  Typically you just use 
the extension on the URL, which in this case is gif.  Other types seen may 
be jpg and png.  Some sources use the wrong image type on the filename, in 
which case the image will not display in Digital Atmosphere and you will have 
to see if the site is posting, say, a JPG using a PNG filename (this kind of 
thing is happening with Canadian radar images).

Now we need to develop a color table to tell Digital Atmosphere which radar 
colors contain information.  Scroll to the bottom of the digatmos.rdy file 
and start a new TABLE= line using a value that is not in use.  If you’re 
using the default Digital Atmosphere digatmos.rdy file, you’ll probably be 
starting a TABLE=05 line.  So enter TABLE=05 followed by two forward-slashes 
and a note telling you what this table is for.  We recommend:

TABLE=05 // South African radars

Now we need to enter the color information for each intensity level.  The 
South African radar source has a handy scale on the right side.  View this 
in your graphics program.  Now you need to use whatever tool will let you 
hover over pixels and show you the color value using RGB numbers (i.e. three 
numbers, each ranging from 0, dark, to 255, bright, indicating the numerical 
level of red, green, and blue).  In PaintShop Pro it is the eyedropper icon 
(pick up color).  If you hover over the “0 dBz” level, which is gray, you 
should see it has R=90 G=89 B=90.  We enter a line using this format:

LEVEL=dbz,red,green,blue,threshold

The red, green, and blue are self-explanatory.  The dbz is the dBz level from 
the scale; it’s only used for color mapping.  If no scale is provided you can 
use 0 for weak echoes ranging up to 60 for heavy levels.  Finally threshold 
is a value used to “accept” pixels that are close to the required R,G,B 
values... we will use 10.  However it may be important to set this for JPG 
files where color drift may occur.  Threshold should usually be 10, but you 
can increase it to 50 or 100 if lossy JPGs are used and “holes” are appearing 
in the generated radar images.  Basically Digital Atmosphere looks at the 
numerical difference in red, blue, and green and adds up these differences 
(using the absolute value) to gauge the pixel against the threshold.  So if 
you define RGB=10,10,10 and the program sees a pixel with RGB=30,30,30, this 
adds up to a difference of 60.  The pixel will be treated as part of your 
level definition as long as the threshold value doesn’t exceed 60.

When we are done defining all levels it will look like this:

TABLE=05 // South African radar
  LEVEL=00,090,089,090,10
  LEVEL=05,074,060,140,10
  LEVEL=10,000,089,000,10
  LEVEL=20,000,113,000,10
  LEVEL=30,008,125,222,10
  LEVEL=35,024,069,231,10
  LEVEL=36,107,012,198,10
  LEVEL=39,198,016,132,10
  LEVEL=42,189,101,132,10
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  LEVEL=45,206,134,057,10
  LEVEL=48,247,195,049,10
  LEVEL=51,255,251,000,10
  LEVEL=54,255,154,090,10
  LEVEL=57,255,093,008,10
  LEVEL=60,255,052,024,10
  LEVEL=65,189,190,189,10
  LEVEL=70,214,211,214,10

Note that extraneous zeroes have been prefixed to make numbers two or three 
digits.  This is optional, and has been done here to make the file look neater.  
We will also skip South Africa’s 80 dBz since it matches the basemap color 
(white) and may give undesirable results.

Finally we need to hook up this table number (05) with the Durban radar entry 
above.  Put this number under CO to point it at the table.

We’re done!  Now generate a map in Digital Atmosphere for Durban (the ICAO is 
FADN) and use a tight zoom level of about 300 or 400 nm.  Now use Radar > Import 
Images and Clear All and then check Durban.

Note that there are traces of radar range rings.  This cannot be avoided since 
it is an artifact on the original image.  The outer red radar range ring is 
provided by Digital Atmosphere to mark the maximum extent of radar information 
and can be shut off by putting RANGERING=0 instead of RANGERING=1 before the 
TABLE= entries in digatmos.rdy.  The palette can also be changed in this section 
to something more desirable.



106  |  DIGITAL ATMOSPHERE MANUAL / September 2017



DIGITAL ATMOSPHERE MANUAL / September 2017 |  107

APPENDIX I — Importing satellite images

Digital Atmosphere is not able to automatically read satellite images and 
georeference them.  This must be done by the user.  We cannot provide support 
for this, but we will present some suggestions on how to get started.  Also 
see our user forums at www.weathergraphics.com/forum as many users have 
worked with this sort of task.  The Map > Import command is central to 
working with satellite images as it allows the basemap to be replaced with 
any graphical image.  However the image must correspond with the basemap that 
was replaced.

Help from Ton Lindemann
Users who wish to use satellite imagery as basemaps in DAWS from David 
Taylor’ GeoSatSignal output may ask for a free set of .dmf setup files. The 
set comes with a sample map for each continent and ocean, except the polar 
regions. Just replace the sample map by GSS output and open the .dmf-file to 
have the image on the desktop in Digital Atmosphere.  The winzipped file is 
around 720 kB and comes with a setuplist for GSS. It can be ordered free by 
sending an e-mail to: info@meteo-maarssen.com.

Help from Fred van den Bosch
In the RIG-journal 73 (June 2003) is an article by Thomas Scheelen ( www.
rig.org.uk ). He uses some modules of David Taylor like HRPT-reader and 
Groundmap. My experiences are based on that article.
Setup.  Download from http://www.satsignal.net/ the programs HRPT-reader and 
GroundMap and install them.

Download.  Download files from http://www.saa.noaa.gov/. How to do this is 
described on http://www.satsignal.net/. On the page about HRPT-reader is 
a link to basic notes on using the SAA. The final results are one or more 
downloaded files.

HRPT-reader.  Open a downloaded file. The main result is a false colour 
image. Save this image. On the background a location file is saved too.
GroundMap.  Open the location file from the previous step. Choose 
.Ortographic. as projection and use a suitable output size. The image is 
showed. Save the image.  If Groundmap is not registered you have a few 
possibilities in output size. This means that you get a rather small image in 
DAWS. But you can see what is possible.

Initial Digital Atmosphere.  Generate a map. Use for latitude and longitude 
the same values as in the download. Use for scale a size that generates more 
or less the same map as GroundMap. It is not so important at this moment. 
Give width en height the values from the download. Generate the map and if 
it.s ok, save it with <Map/Save map> as BMP.
Fine-tuning.  Repeat the next steps until both maps fits exactly.
1.Choose icon .load map. and read the GroundMap image.
2.Choose <map/add base map>. This option will project the DA-map over the 
image and will surely not fit. Now we must try to make the DA-map fit. This 
is done by making changes in <Map/Generate map/Enter lat/lon.> :
3.Latitude. This will move the map in vertical direction
4.Longitude. This will move the map in horizontal direction.
5.Scale for resizing the map.
6.Make small changes in the steps 3, 4 and 5. After <OK> DA will generate a 
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new map.
7.Continue with step 1.

Finishing.  Save the DA-map for the last time. This must be done because 
every lay-out has its own base map and parameter-files. Always open this 
corresponding map before loading a picture with a different layout from 
GroundMap.
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APPENDIX J — Color fills

This is a breakdown of the color fill method used in File > Preferences under 
the Misc 1 tab.

The colors are defined according to the plotted Value for the particular point 
on the map, which will always be in the range 0..1, where 0 is the lowest 
possible reading and 1 is the highest possible reading.  This Value is fitted to 
a sine wave according to user defined parameters to determine the Red, Green, 
and Blue component of its color.

First the value (0 for minimum possible and 1 for maximum possible) is fitted to 
the sine wave to determine what the amplitude will be.  Amplitude will always 
be in the range -1 to 1.  Amplitude is determined by ph1 and ph2, which are in 
degrees.  A greater difference between ph1 and ph2 will result in a more curved 
function, while a smaller difference will produce a flatter function.  For basic 
users, the sine responses are as follows: 

	 Amplitude = sin( [(ph2-ph1) * Value] + ph1 )

	 where
	    ph1 = a user defined value in degrees,
	    ph2 = a user defined value in degrees,
	    sin(0)=0, sin(90)=1, sin(180)=0, sin(270)=-1 .

Finally the amplitude is modified according to the user-defined scale and offset 
values to determine ColorValue, which must always be in the range 0..1 (0 is 
dark, 1 is bright).  This means if an Amplitude value is negative, it must be 
offset so that it falls into the range 0..1.  An out of bounds ColorValue is 
always rounded up or down so that it equals 0 or 1.

	 ColorValue = (Amplitude * Scale) + Offset

Example: For a basic scale where cold temperatures are black and hot 
temperatures are bright red, set Red Ph1=0, Ph2=90, Scale=1, and Offset=0.  Set 
the Green and Blue Scale to 0 and Offset to 0, which will always provide a value 
of 0 for these components.
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APPENDIX K — Tabular weather data

 Digital Atmosphere is capable of importing observations from a comma-delimited 
database listing. This is excellent for weather observations exported out of a 
database or a spreadsheet.  It is also suitable for Australian AXF weather data.

If recognized as shown below, the data will be imported and available for 
viewing as long as it is imported as usual from the data directory or from a 
specified file.

The rules for this data are:

    Comma-delimited data only!
    Each line must correspond to one observation
    No extraneous commas are permitted (even within quote marks)
    The observation must contain the station’s latitude and longitude.

To take advantage of this capability, you need to open the DIGATMOS.FMT file 
with a text editor and define the start sequence and the parameters that apply 
to that type of data.

Start sequence

You define the start sequence by placing a “start sequence” between brackets in 
the DIGATMOS.FMT file; for example if your database starts out with “Joe’s Data” 
you should start out with this:

[Joe’s Data]

No database entries are read in until the start sequence is found.

 
Parameter list

To actually read the data, you will need to create a parameter list, such as 
this:

TMP=4
DWP=6

Each entry must be on its own line, and the list ends when the end of the file 
is reached or another start sequence is found. The example above indicates that 
the temperature can be found in column 4 and the dewpoint can be found in column 
6.

Sample listing

Here is a sample of an entry in DIGATMOS.FMT which is used for Australian Bureau 
of Meteorology AXF data.

[synopData]
ICA=3
WMO=1
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LAT=6
LON=7
ELE=9
TIM=5
DAT=4
TMP=22
DWP=23
WND=11
WNM=12
SKY=10
CIG=26
WXX=14
VIS=13

Valid parameters

ICA=xxx ICAO of the station (for display purposes only)
WMO=xxx WMO number of the station (for display purposes only)
LAT=xxx Latitude, in hundreds of degrees (negative is southern hemisphere)
LON=xxx Longitude, in hundreds of degrees (negative is western hemisphere)
LAX=xxx Latitude, in regular format (negative is southern hemisphere)
LOX=xxx Longitude, in regular format (negative is western hemisphere)
ELE=xxx Elevation in meters (used only for potential temperature 
calculations)
TIM=xxx Time in UTC (expressed as 450 for 4h50m and 1629 for 16h29m)
DAT=xxx Day of month (expressed as “16” for September 16)
TMP=xxx Temperature in degrees Celsius
DWP=xxx Dewpoint in degrees Celsius
WND=xxx Wind direction in degrees true
WNS=xxx Wind speed in knots
WNM=xxx Wind speed in meters/second
SKY=xxx Total sky cover in oktas (9=obscured, 10=not available)
SLP= xxx Sea-level pressure in millibars< FONT face= Courier>
CIG=xxx Ceiling in hundreds of feet
WXX=xxx Weather code; first and second digit equals ww weather code (e.g. 61 
is light rain)
VIS=xxx Visibility in meters
P01=xxx Precipitation total in millimeters (past 1 hr)
P06=xxx Precipitation total in millimeters (past 6 hr)
P12=xxx Precipitation total in millimeters (past 12 hr)
P24=xxx Precipitation total in millimeters (past 24 hr)
PXX=xxx Precipitation total in millimeters (source-defined period; unknown to 
Digital Atmosphere)
PCP=xxx Precipitation total in millimeters
PCT=xxx Precipitation time period in hours
PTR=x   Pressure trend (equals a in app group)
PTN=xxx Pressure tendency (in tens of millibars)
SNO=xxx Snow depth in centimeters
CLL=x   Low cloud code
CLM=x   Middle cloud code
CLH=x   High cloud code
MAX=xxx Maximum temperature, in degrees Celsius
MIN=xxx Minimum temperature, in degrees Celsius
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 More on Australian AXF data

Information on Australian AXF data can be found here:
http://www.bom.gov.au/nmoc/Obs/IDY03000.doc
http://www.bom.gov.au/nmoc/Obs/IDY03090.doc
http://www.bom.gov.au/nmoc/Obs/IDY03100.doc

Note that there may be restrictions on the use of Australian data, so look into 
this before creating commercial products.

Template file entries
#DEF starts the definition of a table.  Give the table a name in T1; this name 
is used for
display purposes.
#LEG defines a line that can be used as a legend for the table (such as a line 
that contains a date or valid time).  Specify a keyword that is to be located on 
the line.  When encountered, it will be used in legends
#FLG is a scrap of text which, when encountered during importing, tells Digital 
Atmosphere that it is about to encounter a table.  This flag must be encountered 
before any data can be imported.  Specify the scrap of text in T1.
#BEG is a scrap of text which, when encountered during importing, tells Digital 
Atmosphere that a data table is starting right now.  Put the scrap in T1, and 
define the column where it must be seen in V1 and the length of the scrap in V2.  
Data import always ends on an empty line.
#DAT is specified for each data element that appears on a line.  Give the field 
a name in T1 (this is used only for display purposes). Define the beginning 
column of the data in V1 and the length of the data in V2.
#MIS specifies characters that are used to denote missing data.
#LAT specifies where the latitude (decimal only) is found.  Put the column start 
position in V1 and the field length in V2.
#LON is similar to #LAT but for longitude.

Example
#DEF -   -   Australian rainfall data
#LEG -   -   Observations
#FLG -   -   IDCLRD00001
#BEG 66  2   :-
#MIS -   -   +
#LAT 67  6
#LON 60  6
129
#DAT 1   10  Date
#DAT 12  6   Stn_num
#DAT 23  40  Name
#DAT 81  5   Precipitation_mm
#DAT 87  1   PP
#DAT 89  1   DC
#DAT 91  1   OF

 



114  |  DIGITAL ATMOSPHERE MANUAL / September 2017



DIGITAL ATMOSPHERE MANUAL / September 2017 |  115

APPENDIX L — Exported analysis grids

Whenever an Analysis is performed on any data (scalar, isoplethed fields only), 
Digital Atmosphere always exports its output to GRID.TXT. The output can then be 
imported into spreadsheets or analyzed further by other methods.

The output consists of 900 points (30 by 30) representing the value at each 
point of X and Y in the geographic area shown in the workchart window. The 
X-axis is left-right in the window, pointing right, while the Y-axis is up-down 
in the window, pointing down. This means that the highest values of X and Y are 
found east and south, respectively. The latitude/longitude of each X and Y point 
in decimal format is shown, followed by the analyzed value at that point.

Here is a sample of output from GRID.TXT.

    X  Y  LATITUDE LONGITUDE VALUE
    0  0  42.435   -107.721  1012.79998779
    0  1  42.471   -107.141  1012.84558105
    0  2  42.505   -106.560  1012.92547607
    0  3  42.537   -105.979  1013.08880615 
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APPENDIX M — Station plot fields

(blank) Nothing will be plotted in this space
TEMP Air temperature in whole degrees (C or F)
TEMP(10) Air temperature in tenths (C or F)
DWPT Dewpoint in whole degrees (C or F)
DWPT(10) Dewpoint in tenths (C or F)
GUST Wind gust (kt)
RH Relative humidity (%)
MXR Mixing ratio (g/kg)
THETA Potential temperature (deg K)
THETAE Equivalent potential temperature (theta-e) (deg K)
WINDCHILL Wind chill
HEATINDEX Heat index
SLP Sea level pressure (mb) (plots tens, units, and tenths)
ALSTG Altimeter setting (in Hg) (plots units, tenths, and hundredths)
WX Pictogram of current weather type
VIS Prevailing visibility (sm or m)
ELEV Elevation (ft or m)
CIG Ceiling (lowest layer more than half of sky) (hundreds of feet)
OKTAS Cloud cover in oktas (eighths)
ID(ICAO) Station identifier (4-letter ICAO)
ID(WMO) Station identifier (5-digit WMO)
PCP01 Precipitation during past 1 hour
PCP06 Precipitation during past 6 hours
PCP12 Precipitation during past 12 hours
PCP18 Precipitation during past 18 hours
PCP24 Precipitation during past 24 hours
PTEND Pictogram of pressure tendency during past 3 hours
CLD/L Pictogram of low cloud type
CLD/M Pictogram of middle cloud type
CLD/H Pictogram of high cloud type
CLDHGT Cloud height code (synoptic only) (see chart below)
CLDAMT Cloud amount code (synoptic only) (see chart below)
SHIPDIR Pictogram of direction of ship movement
SHIPSPD Speed of ship movement (kt)
SEATEMP Sea-surface temperature (C or F)
TEMPTYPE Type of temperature measurement device
WAVEPD Period of ocean waves (sec)
WAVEHGT Height of ocean waves (ft or m)
SEAINSTHGT Instrument-measured height of ocean waves (ft or m)
WINDPD Ocean wind wave period (sec)
WINDHGT Ocean wind wave height (ft or m)
SWELL1DIR Direction of primary ocean swells (deg)
SWELL2DIR Direction of secondary ocean swells (deg)
SWELL1PD Primary ocean swell period (sec)
SWELL1HGT Primary ocean swell height (ft or m)
SWELL2PD Secondary ocean swell period (sec)
SWELL2HGT Secondary ocean swell height (ft or m)
MINTEMP Minimum temperature (C or F)
MAXTEMP Maximum temperature (C or F)
GRNDSTATE Ground state code (see below)

Ground state codes
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0 Surface of ground dry (without cracks and no appreciable amount of dust or 
loose sand)
1 Surface of ground moist
2 Surface of ground wet
3 Flooded
4 Surface of ground frozen
5 Glaze on ground
6 Loose dry dust or sand not covering ground completely
7 Thin cover of loose dry dust or sand covering ground completely
8 Moderate or thick cover of loose dry dust or sand covering ground 
completely
9 Extremely dry with cracks
10 Ground predominantly covered by ice
11 Compact or wet snow (with or without ice) covering less than half of 
ground
12 Compact or wet snow (with or without ice) covering half to less than 
entire ground
13 Even layer of compact or wet snow covering ground completely
14 Uneven layer of compact or wet snow covering ground completely
15 Loose dry snow covering less than half of ground
16 Loose dry snow covering at least half of ground but ground not completely 
covered
17 Even layer of loose dry snow covering ground completely
18 Uneven layer of loose dry snow covering ground completely
19 Snow covering ground completely; deep drifts

Synoptic cloud amount codes (CLDAMT) (Nh)
This category is defined as Nh; the amount of all the low cloud present, or, 
if no low cloud is present, the amount of all the middle clouds present.  
The figure is always in oktas (eighths).  9 is reserved for sky obscured 
by fog and/or other meteorological phenomena, and / is reserved for cloud 
cover being indiscernable for reasons other than fog or other meteorological 
phenomena, or observation is not made

Synoptic cloud height codes (CLDHGT) (h)
.h. is reserved for the height of the surface of the base of the lowest cloud 
seen.  They are as follows (below).  If the total sky cover is greater than 
4/8ths, this figure is also transposed into the CIG slot, where they are 
plotted as .L. (.low cloud.) followed by a loose translation of the table 
below in hundreds of feet.  This .L. differentiates it from true ceilings 
where .C., .E., or .M. is prefixed.
0 0 to 50 m
1 50 to 100 m
2 100 to 200 m
3 200 to 300 m
4 300 to 600 m
5 600 to 1000 m
6 1000 to 1500 m
7 1500 to 2000 m
8 2000 to 2500 m
9 2500 m or more, or no clouds
/ Height of base of cloud not known, or base of clouds at a level lower and 
tops at a level higher than that of the station
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APPENDIX N — Multilanguage support

Support for output of the chart legends in another language can be obtained 
by editing the language.txt file in the Digital Atmosphere directory.  Simply 
create a new section header at the end of the file like:

[DANSK]

Then set the language by editing the Language= line at the top:

Language=DANSK

This tells Digital Atmosphere to only read sections following a [DANSK] block 
and ignore the rest of the file.  You can have as many different sections and 
section headers as you like in the file.

To add the foreign language entries, copy all of the information in the English 
section and paste it below the new language header, then in the “Display as” 
column write the items as you wish them to be displayed.  It is not necessary to 
edit items under “Name (not used in Dig Atm)” but you may edit the entries to 
make the file more readable for you.

If you do not intend to use Digital Atmosphere in English you may simply 
overwrite the English section with your own entries.

Note that there is no support for Unicode at this time (thus Cyrillic and other 
fonts cannot be plotted).

To change the language of the analysis options under “Analysis” you may edit the 
digatmos.mnu file directly.  There is currently no support for displaying the 
main menu in other languages.
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APPENDIX O — Raw data samples

Listed here are some examples of what kinds of data will be imported by Digital 
Atmosphere, depending on your checkmarks on the status panel. You can refer 
to these examples if you have any trouble getting Digital Atmosphere to read 
something or are unsure of what a particular product or bulletin should look 
like.

 
Airways (SAO) data

This is the backbone of weather observation code in the United States and 
Canada. It is issued hourly from thousands of weather stations. A sample report 
will look like this:

JFK SA 1150 250 SCT 7 113/44/21/2513/989=

 
SD RAREP radar reports

Also called hourly radar reports, RAREPS, and SD reports. Early versions of 
Digital Atmosphere do not import this type of data. Radar reports come from 
about 100 stations around the country. A few years ago, they were typed up by 
humans, but most of them are now centrally generated by computer based on images 
from NEXRAD radar sites around the country. This is what a radar report looks 
like:

MCI 0225 CELLS TRW/NEW 250/195 D10 C2330 MT 300
^OI22

 
FD winds aloft data

This is not an analysis of real conditions; rather it is numerical output from 
the National Centers for Environmental Prediction (formerly NMC) in Washington, 
DC. It is used primarily for aviation forecasting purposes, consisting of 
a coded wind and temperature forecast at 12 and 24 hours into the future. 
Nevertheless, it makes excellent forecasting charts in Digital Atmosphere.

For Hours
ID Use Z From Now 3000 6000 9000 12000 18000 24000
2XG 09-18 00-09 3613 2911+06 2520+02 2430-03 2342-15 2462-26

Rawinsonde data

Also called TEMP or TTAA data. This is the backbone of upper-air observation 
reports, sent twice daily from hundreds of stations worldwide (several dozen 
in the United States alone). It is a highly numerical, coded set of data that 
is used extensively in meteorological operations and is used as input into the 
numerical forecast models. Here’s an example of what it looks like:

72558 TTAA 69121 72558 99973 00821 30002 00130 ///// /////
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92762 01611 03014 85444 01850 00521 70993 04159 30025 50559 etc..
 

Weather watches

Also called SELS watches, watch boxes, or even WWUS9 KMKC. This is an English 
bulletin produced by forecasters at the Storm Prediction Center (formerly 
NSSFC, the National Severe Storms Forecast Center).

WWUS9 KMKC 141239
SEL7
MKC WW 141239
KSZ000-142000-

BULLETIN - IMMEDIATE BROADCAST REQUESTED
SEVERE THUNDERSTORM WATCH NUMBER 77
NATIONAL WEATHER SERVICE KANSAS CITY MO
639 AM CST THU MAR 14 1996

.A..THE STORM PREDICTION CENTER HAS ISSUED A SEVERE THUNDERSTORM WATCH FOR
PARTS OF EAST-CENTRAL AND SOUTHEASTERN KANSAS
EFFECTIVE THIS THURSDAY MORNING AND AFTERNOON UNTIL 200 PM CST.
LARGE HAIL...DANGEROUS LIGHTNING AND DAMAGING THUNDERSTORM WINDS
ARE POSSIBLE IN THESE AREAS.
THE SEVERE THUNDERSTORM WATCH AREA IS ALONG AND 45 STATUTE MILES
NORTH AND SOUTH OF A LINE FROM 45 MILES WEST OF EMPORIA KANSAS TO
45 MILES EAST OF CHANUTE KANSAS.

Convective outlook

The convective outlook is a bulletin produced by forecasters at the 
Storm Prediction Center (formerly NSSFC, the National Severe Storms 
Forecast Center), and intended for use by other National Weather Service 
meteorologists. Two are produced; one for the “today” time frame (Day 1), and 
another for the “tomorrow” time frame (Day 2). It is one of the best sources 
of forecast information on the potential for severe thunderstorms.

ACUS1 KMKC 141441
SWODY1
MKC AC 141441

CONVECTIVE OUTLOOK...REF AFOS NMCGPH94O.
VALID 141500Z - 151200Z

REF WW NUMBER 0077...VALID TIL 2000Z

THERE IS A SLGT RISK OF SVR TSTMS TO THE RIGHT OF A LINE FROM PGO
OKC 30 NNE P28 35 ESE SLN OJC JEF MVN EVV BWG BNA MEM PBF PGO.
GEN TSTMS ARE FCST TO THE RIGHT OF A LINE FROM OXR FAT TPH ELY
15 NW PUC CAG LIC HLC FNB PIA FWA YNG DUJ DCA 25 W RIC RDU AND CBM
TXK FSI 60 NNE AMA RTN 10 SE ABQ 30 SSW DMN.
 

Model output data
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These are numerical output bulletins from the National Center for Environmental 
Prediction (NCEP, formerly known as NMC), which describe forecast parameters at 
different locations around the country. These bulletins are available on most 
weather databases. For those who want the “real thing” from the supercomputers, 
full-fledged model output is in a binary format known as GRIB; these files are 
huge, hard to obtain, and are not importable into Digital Atmosphere at this 
time.

652
FOUS72 KWBC 201200
OUTPUT FROM ETA 12Z JAN 20 96
TTPTTR1R2R3 VVVLI PSDDFF HHT1T3T5 TTPTTR1R2R3 VVVLI PSDDFF HHT1T3T5
SEA//928157 03005 131714 30989795 GEG//894554 03407 152312 25969490
06021947750 05304 021921 34009996 06000877354 02207 101416 29979693
12010957438 -1802 992315 30019995 12014928044 03104 021809 32999795
18006957340 01501 992612 30019995 18000957342 02502 012208 30999895
24005977941 02601 012517 28019995 24011957646 02502 022516 29999794
30010967941 01201 042819 27019894 30000957544 01001 042513 27009894
36005856037 -0202 102814 26019894 36004938141 01501 072607 27009794
42000794430 -0906 152811 25019793 42003837138 00703 123009 26009693
48000783339 -0510 182710 27009792 48000614637 00007 173109 24999491

ASUS frontal bulletin

Produced by the National Centers for Environmental Prediction.
515

ASUS1 KWBC 111919
CODSUS
VALID 111118Z
HIGHS 1030 41165 1030 38154 1027 45135 1025 31138 1035 6143 1022 3730
1033
5589 1030 6286
LOWS 979 46169 1017 38139 997 4257 997 3865 980 63172 987 66144 998
75113
1005 36102 1013 35112 998 7168
OCFNT WK 46169 46170 45171
COLD WK 45171 44170 42169 40169 40169 39168
WARM WK 45171 46172 47174 46178
COLD WK 38139 36140 33144 31149 31153
STNRY WK 4418 4525 4531 4741 4748 4653 4457 4160
TROF 4257 4151 3647 3145 2845
COLD WK 3865 3763 3463 3164 2869 2673 2478 2384
COLD WK 66144 64142 62142 59142 53145 48149 45153 42156 40162
STNRY WK 55116 59117 62121 65129 67138 69144 69155 68167 68176
STNRY WK 6291 6395 64101 64110 63117
OCFNT WK 76114 77111 78104 7895 7786 7680
COLD WK 36102 34103 32104 31106
TROF 36101 35101 32100 30101 28102 26102
COLD WK 7680 7574 7168 6866 6565 6365 5969 5672
STNRY WK 37103 38104 40106 40109 41111 43114 44117
WARM WK 38101 3999 3897 3795 3791
TROF 48112 51112 55112
TROF 5294 5095 4896 4498 4199
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TROF 5571 5270 4968 4767
NNNN

Hurricane bulletin

Produced by the National Hurricane Center.

WTNT22 KNHC 060837
TCMAT2
TROPICAL DEPRESSION LARRY FORECAST/ADVISORY NUMBER  19
NWS TPC/NATIONAL HURRICANE CENTER MIAMI FL   AL172003
0900Z MON OCT 06 2003
TROPICAL DEPRESSION CENTER LOCATED NEAR 17.3N  94.0W AT 06/0900Z
POSITION ACCURATE WITHIN  50 NM
PRESENT MOVEMENT TOWARD THE SOUTH-SOUTHWEST OR 200 DEGREES AT   3 KT
ESTIMATED MINIMUM CENTRAL PRESSURE 1005 MB
MAX SUSTAINED WINDS  20 KT WITH GUSTS TO  25 KT...DISSIPATING
12 FT SEAS..  0NE   0SE   0SW 100NW.
WINDS AND SEAS VARY GREATLY IN EACH QUADRANT.  RADII IN NAUTICAL
MILES ARE THE LARGEST RADII EXPECTED ANYWHERE IN THAT QUADRANT.
REPEAT...CENTER LOCATED NEAR 17.3N  94.0W AT 06/0900Z
AT 06/0600Z CENTER WAS LOCATED NEAR 17.5N  93.9W
FORECAST VALID 06/1800Z 16.9N  94.1W...INLAND...DISSIPATING
MAX WIND  20 KT...GUSTS  25 KT.
FORECAST VALID 07/0600Z...DISSIPATED
REQUEST FOR 3 HOURLY SHIP REPORTS WITHIN 300 MILES OF 17.3N  94.0W
THIS IS THE LAST FORECAST/ADVISORY ISSUED BY THE
NATIONAL HURRICANE CENTER ON LARRY UNLESS REGENERATION OCCURS.
FORECASTER PASCH
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APPENDIX P — Version change summaries

- Interim release to fix the accidental registered version on the website 
and a lack of a Pro version for 2.12/2.13
- GPS component and menu have been removed as those use obsolete 
COM ports
- Color tables in DIGATMOS.NEX have been changed to the GRLevelX 
format to allow more standardization.  All types of radar products are 
contained in this single file.
- Printer configuration is temporarily not working

VERSION 3.00
This is the parallel Delphi 7 version (see Delphi 7 Fork below, 2013) 
which has not been released since there are dependencies in the 
radar module that have not been addressed.

VERSION 2.13
began 23-Feb-15
 - Fixed problem with elevation data not being extracted from location 
identifier tables (so no wet bulb / mixing ratio / theta E)
 - Added wet bulb to station plots.

VERSION 2.12
began 23-Dec-14 released 23-Dec-14 as public release of 2.11
- Includes the 2.11 snow depth plot option.
- Added support for new Master Location Identifer Database format
- Implemented 12/30/2014 release of MLID location database
MANIFEST CHANGES:
master-location-identifier-database.csv (add)

VERSION 2.11
began 23-Dec-14 released 23-Dec-14
- Begun as a continuattion of V2.09.  The Delphi 7 fork was dropped 
and the Delphi 5 code base was retained to avoid having to rewrite 
dependencies for Delphi 7 and prolonging the release date.
- Adds snow depth plot display option in Preferences station plot 
model).

DELPHI 7 FORK - 2012-2013
Between August 2012 and June 2013 a parallel version (V3.00-V3.01) 
was developed under Delphi 7.  In 2014 it was decided to set this 
aside due to problems with dependencies (zlib, etc) and so the more 
important issues could be addressed.

VERSION 2.10
began 04-Dec-09
- Enhanced scripting; added DELETE script command for file delete; 
allowed use of absolute filename in script execution commands

VERSION 2.09
Began 12-Oct-09
Began work on DIFAX graphic engine (Weatherpipe type utility) for Pro 
version and completed most of it.

VERSION 2017 2.30
(Coding start date 6/1/2015 - Release date 9/20/2017)
Continued update/revision work of revisions that started with V2.11.  It 
was decided with this update to get rid of the TMS menu framework, 
but after seeing it did not detract from menu appearance in Windows 8 
it was decided to leave it alone.
  - The Level III radar module with dual-polarization products has been 
completed and updated through Build 17 (added 8-Sep-17)
- Extensive work on documentation
 - Added colon to next NMC character position (font.012)
- Extensive GUI control panel work to slim it and improve appearance.
- Added hovering hints to speed bar.
- BELOW are changes before December 2016.
- Updated data sources, removed old ones (Albany, FSU), changed 
URLs (NWS, Texas Tech).  These changes are also reflected in the 
DIGATMOS.URX file so older versions can use this.
- Data > Data Retrieval dialog delete function fixed (was inoperative)
- Data > Data Retrieval window optimized so that cursor returns to 
active row upon a deletion or edit.
- Extensive development of the PDF manual.
- Geography rendering (Map > Generate) is much faster.
- Radar module has been revised to provide fixes for new coding 
changes.
- Format of DIGATMOS.NXC has been changed.  DIGATMOS.RAD has 
been updated.
- Color theme has been adjusted to a gray/silver contemporary look.
- Changed color scheme from blue to a more subdued dark gray / gray.
- Made a change to allow Analysis menu options to inherit the menu 
style.
- Paired this release with a drastic update in the program 
documentation to bring it up to date.  Focus will be on a PDF manual, 
and it will be created as a shortcut in tandem with the program.
- Added support for Shapefile attribute matching; also removed an 
Application.ProcessMessages block in the Shapefile module that was 
slowing down the process somewhat.
- Removed support for GPS as it is based on old 9-pin COM port 
technology and most users have upgraded to USB devices, which are 
not yet supported by Digital Atmosphere.
- Changed Climatology menu to Tools.  Restructured menus to move 
certain data functions from the File menu to the Data menu, and tools 
from the File menu to the Tools menu.
- Internet data source table has been updated to change frontal 
bulletin source from hpc.ncep.noaa.gov to wpc.ncep.noaa.gov.
- Added status message for Map > Copy Markings To Basemap.
- Changed default font set to Calibri.
- Set legend font style to bold.

VERSION 2.14
compiled 05-Jul-17 (Not released)
- MAIN CHANGES: Contains brand new updated station tables, a new
      radar data package,
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MANIFEST CHANGES
DIGATMOS.DFY (add)
DIGATMOS.DFZ (add)

VERSION 2.08 
25-Jul-09
This updates affects the Professional Edition only.
- Cross Section > Copy To Clipboard function now works.
- Added Cross Section > Save To File (allows GIF, PNG, JPG, and 
BMP).

VERSION 2.07
18-Jul-09
- Adds cross-section capability under Data > Cross Section 
(requires radiosonde data and a line segment dragged on the map).
- Fixes problem with Workchart levels & times not being 
remembered fully when program is started; active levels and time 
selections were displayed but were not set internally, thus 500 mb 
plots would not appear, even with 500 mb showing in Active Level 
window, unless it was reselected
- Preferences > Analysis > Auto smoothing setting is now saved 
across sessions
- NEW FILES: Adds the file DIGATMOS.ELX to support the cross 
section module.

VERSION 2.06
22-May-09
- Fixed issue with soundings for WMO stations 00000-09999 
(Northern Europe) not plotting in V2.04-2.05.  This was caused by 
different handling of WMO identifier leading zeroes, which are often 
stripped out by spreadsheets such as Excel when preparing station 
identifier lists.  Any further issues with Northern Europe SYNOP 
or upper air may be attributable to this issue; this issue will be 
monitored.
- Hardened filtering of miscellaneous text in METAR import; this will 
produce fewer spurious results in the Station Data > Audit module.
- Further updates to station identifier list; provided updated list and 
station package.  The identifier list now contains almost all ICAOs 
currently being transmitted.  Work will now be done to finalize and 
document the location identifier format and fix other Dig Atm bugs 
reported. 

VERSION 2.05
20-May-09
- Adjusted Sounding window so that it is in the screen center.
- Fixed a problem with soundings not plotting in V2.04; this was due 
to the station table format changing and the sounding module being 
unable to validate the chosen WMO code.  This has been fixed.
- Removed faulty line of code that interfered with scripting (Unable 
to Create File error) whenever a URL was in the script line
- Fixed handling of custom data in Analysis module; Barnes/
Cressman/etc were using value stacks for grid 0 instead of 1/2/3
- Adds a new menu option (DIGATMOS.MNU) for custom data, data 
type CUSX, which is imported from the existing CUSTOM.DAT file 
rather than from the OUTPUT.*** imported/formatted data.  This 

can be used in addition to CUST in script files.
- Added more stations to location-identifier-list.csv and recompiled 
tables.
- Added a datafile edit capability (File > Station tables > Audit) 
to assist users with identifying stations that did not import due 
to missing data in the location identifier list.  This only evaluates 
the data against the current station table ingested into Digital 
Atmosphere.
- Added FAA identifier tables, added DIGATMOS.SXF and DIGATMOS.
STF to build.  This allows more accurate handling of airways and 
3-letter identifiers and separates them internally to prevent mixups.
  - Some new stations in location identifer list; will continue to add 
more in the days/weeks ahead.  Station indexes rebuilt.

VERSION 2.04
17-May-09
- Added the new LIL.CSV Location Identifier List and will begin 
phasing out the old DIGATMOS.STN file.  Made appropriate changes 
in File > Station Tables menu to give user the option of importing 
the new LIL.CSV or an older .STN table.  The LIL.CSV list is still in a 
draft form and is still in development.

VERSION 2.03
10-Apr-09  (Unreleased)
This version contains enhancements to scripting commands.
  - If you use scripts that use the LOOP command, you *MUST* be 
aware of the following scripting changes before using script files.
 - In scripting, support has been added for a LOOP...END block.  
Previously “LOOP” would run the entire file as a loop.  Now all 
content between the LOOP command and an END command are run.  
Multiple loops are supported, but nested loops are not supported.
- The LOOP command now requires 4-digit years.  It is as follows:
       LOOP,yyyy,mm,dd,hh,span,iterations
        where
          yyyy = loop start 4-digit year
          mm = loop start numerical month
          dd = loop start numerical day of month
          hh = loop start hour
          hours = span of loop from start to finish in hours (may 
exceed 24)
          interval = interval of timestep in hours (e.g. 1=hourly, 
24=daily)
- Added EXIT scripting command to exit the program.
- Scripting: User may now choose @YYX or @YYYYX token to 
choose between a 2-digit year or 4-digit year expression.
- Scripting lines which begin with //, #, :, or ; are treated as 
comments
- Scripting now allows comments to exist at the end of lines; these 
comments must begin with //
- Checked SOUNDING scripting command.  This is NOT an 
interactive display and only exports silently to a graphics file.  Users 
may use the SOUNDING command as follows:
     SOUNDING,station,filename,omitdate,omittrace
        where
          station = ICAO
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          filename = fully qualified output filename, GIF, JPG, or PNG
          omitdate = use false to display date, true to omit date
          omittrace = use false to display lifted trace, true to omit it
  - Add DIGATMOS.TSL temporary station table to manifest (used by 
sounding routine)
  - DIGATMOS.MNU is altered to remove numerous %2 and %3 entries 
that caused the “deg F” and “deg C” toolbar speed buttons to produce 
jumbled isotherm plots.
  - (Need to add checks to delete OUTPUT.FSL file)
  - Script file execution is adjusted so that if an exception (error) 
is thrown the script file will get closed properly, mitigating Error 32 
(sharing violation) afterward.
  - MADIS data throws “Read Beyond End Of File” error.  This was 
found to be due to a change in NOAA MADIS coding where an extra 
integer (purpose unknown) has been inserted after Precipitation and 
before Weather. Code has been fixed to handle this.

VERSION 2.02
2.02  16-Mar-09 -
  - Added code to prevent infinite loop during QC, Preferences Form, or 
Calculator form display
  - Removed bug in setting height of QC form
  - Added a test to see whether a DIGATMOS.STN file exists in both the 
Program Directory and Applications Data directory, which is checked 
on a File > Recompile Tables operation, and ask the user which one 
to import.

VERSION 2.01 
04-Mar-09
  - Added new setting in File > Preferences > Maps tab called 
“Professional map tile root location” to allow DA to find GNC/ONC/JNC/
TPC/JOG tiles.
  - Shifted default tile map root to the Program Files directory hierarchy 
instead of the Local Application Data directory to allow maps to 
be available when overwriting old Digital Atmosphere Professional 
installations.

VERSION 2.00
 27-Feb-09
  - NAMING: Dropped the Equinox name.  The file folder architecture of 
this Digital Atmosphere series is different than the Equinox line. Thus 
we are reverting to the basic Digital Atmosphere nomenclature for 
simplicity’s sake.
  - NEW FEATURE: Program detects if the Scheduler is on at shutdown.  
When the program is started again, the Scheduler resumes operation 
about five seconds after startup.
  - NEW FEATURE: Digital Atmosphere “remembers” across sessions 
the settings for the Workchart Panel for Active, Isentropic, Surface, 
Upper, and Forecast time and level dropdown boxes.
  - FIX: Data date/time detection changes have been made.  Date/
time is established ONLY during file import, internet retrieve, or script 
download, as follows. If none of the special conditions are met then the 
date/time is presumed to be the current clock UTC time.
      -- INTERNET RETRIEVE: Obtained from the time tokens.
      -- FILE IMPORT: Obtained from any file imported that contains an

           8-digit number at the start of the filename, which is presumed
           to signify a yymmddhh group.
      -- SCRIPT DOWNLOAD: Obtained from any 8-digit number in the 
URL, which      is presumed to signify a yymmddhh group.
  - FIX: Changed digatmos.mse so that Haiti is set to longitude -73, not 
+73
  - FIX: Fixed the QC and Calculator form so that scroll bars (which may 
occur in certain Windows skins) will not appear.  Could not test this 
inhouse.
  - Only a full release is provided; no patch from previous versions is 
available due to the change in file folder architecture.

EQUINOX V1.52 BETA
26-Feb-09
  - NEW FEATURE: User-defined analysis domain size.  All Digital 
Atmosphere versions prior to this one used a fixed 30 x 30 domain.  
The user can choose a finer analysis resolution in File > Preferences 
> Analysis > Analysis Domain Size.  About 50 x 50 is sufficient for 
most purposes; resolutions exceeding 100 x 100 will appear “noisy” 
and may require excessive filtering.  It is not advisable to set the 
resolution finer than the resolution of the observation network, as this 
will cause mathematical noise.
  - FIX: Fixed problem with blank okta station symbol being plotted 
if sky condition was unknown (oktas=10) in TrueType mode... this 
problem goes back through all Equinox versions.
  - FIX: Fixed the Preferences form so that scroll bars (which may occur 
in certain Windows skins) will not appear.  Could not test this inhouse.
  - FIX: Established proper display of version number (V1.51 showed 
as V1.50)

EQUINOX V1.51 BETA 
21-Feb-09
  - Preferences will be reset.  Preferences are now being established 
in the registry HKCU\DigAtmEquinox key instead of HKCU\DAFusion.  
This will allow Digital Atmosphere to co-exist independently of older 
versions.  Older preferences will NOT be imported.
  - Changed setup program to require admin privileges, since correct 
font installation under XP/2000/Vista requires power user or admin 
privileges.
  - Fixed extra solidus in ImportData module that may cause a \\data.
usr not found error.
  - Fixed Mercator isoplething issues caused by unnecessary checks 
against drawing isopleths in part of the canvas that’s in outer space.
  - Changed the set of default data (OUTPUT. files) to conform to the 
new internal surface data class definition (older OUTPUT files cause 
a read beyond end of file error if not refreshed by downloading new 
data).

EQUINOX V1.50 BETA 
01-Feb-09
  - The scheme for folders for Digital Atmosphere has been changed, 
making it fully compatible with the User Account Control restrictions of 
Windows Vista. No longer is all working content placed in a single Digi-
tal Atmosphere directory. Instead it is placed in CSIDL_LOCAL_APP-
DATA, which under Vista is C:\[User]\UserName\AppData\Local and in 
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XP is C:\Documents and Settings\[User]\Local Settings\Application 
Data. Users wishing to tinker with Digital Atmosphere files will need 
to look in this directory to make modifications. (12/18/08,2/1/09)
  - When a required file is not found (testfile unit), Digital Atmo-
sphere suggests an e-mail address to report the problem to.  This 
has been updated. (2/1/09)
  - Infiletype variable in import module changed from 100 to 255 
length to handle much larger filenames. (2/1/09)
  - The setting for File > Font Mode is now remembered across 
sessions (default is TrueType fonts). (2/1/09)
  - Repaired Mercator projection to allow correct display across the 
180 degree meridian.  This has not been fully tested. (2/1/09)
  - Cosmetic: changed Digital Atmosphere window title to use a pipe 
(|) instead of two dashes (--) between the version number and 
software type. (2/1/09)

VERSION Equinox 1.10a
(May 24, 2007)
    Micropatch to fix corrupted handling of downloaded radar data 
(data was downloaded into obs.001, obs.002 etc and program 
needed to find these in nids.001, nids.002, etc.
    Added description element into version change message, so 
users can decide whether a download is needed when a notification 
is received.

VERSION Equinox 1.10 
(May 18, 2007)
    Numerous fixes and repairs, including fixes for handling of clima-
tological daily data from SYNOP reports.

VERSION Equinox 1.05
(January 17, 2007)
    A few new Mexican radars in the northwest provinces have been 
added to DIGATMOS.RDY.  Not all radars are active, as Mexico’s 
radar network is not reliable.
    Internet > Retrieve shows how many items are selected.
    Map > Overlay > Points now uses a more capable file format.  
See the help under Map > Add Point.  It allows the use of lines, 
attributes that can be changed, and shortcuts.
    Map > Overlay > Points now prompts for a filename.  Editing is 
no longer done in the program as editing flow was unclear.
    Contour labels are now plotted at the top of closed contours.
    Removed digatmos.ptt from project; it is superfluous.
    Adjusted digatmos.nex to put clear air mode on the same palette 
as precipitation mode to allow for a standardized mosaic.
    Entering “------” for a color in digatmos.nex keeps that color level 
from plotting.  This can be used to allow for a unified mosaic color 
scheme.
    Added code to prevent Digital Atmosphere from generating zero-
value serial numbers.
    Added handling for METAR unknown precipitation (UP).  This will 
plot as two solidii (//) and will carry weather code 100.  I saw lots of 
UP reports from Texas during the January 15 2007 sleet event; UP is 
most likely sleet.
    Changes made to WSR-88D plotting module to allow various ras-

ter data (most notably Composite Reflectivity) to plot correctly.  The 
module now determines polygon positioning based on the number of 
rows in the raster table as well as the resolution for the product as 
defined in digatmos.nxc. Also added progress bar updating on raster 
data.
    In Radar > (product) logic is added to detect and discard old 
radar scans so as not to mess up mosaics.  An RPG product that is 
more than 15 minutes older than the preceding RPG products being 
plotted will be discarded and a message will appear in the status 
window showing it was discarded.  The weakness is if the plotted 
site is the very first to be plotted, it will be used since no other 
comparisions are available.
    A tutorial has been added for the Radar > Import Image menu 
option on how to add radars , using the example of Durban, South 
Africa.  This will be of considerable interest to international users.
    Started preliminary work on importing GRIB2 data .  This module 
does not work and will not plot, however the file will be handled with 
probably no errors.
    Muted menu colors slightly to reduce blue and red saturation.

VERSION Equinox 1.04
(January 7, 2007)
    Preferences > Annotations > “H” and “L” characters now plot 
correctly.  The software was defaulting to “H” and “L” rather than 
using the characters shown here.
    Removed possible error in installer related to “tutorial” directory.  
This was returning a harmless error.
    Incorrectly plotted coordinates when using older Digital Atmo-
sphere charts (from early Fusion and before) has been fixed by 
adding sanity checks to the load function for *.dmf map data.  If 
the rotation value is out of bounds (<-360 or >360 deg), which 
may be the case in earlier versions where the rotation value was not 
specified, it will set it to zero and correct the source file, perma-
nently fixing the problem for that map.
    Diagnosed slight positioning errors in contour labels and highs/
lows and fixed them.

VERSION Equinox 1.03
((January 6, 2007)
    METAR visibility values are now correctly ingested.
    Fixed script LOAD command which was only loading in the image 
and not loading the background map and resizing the window.
    Eliminated redundant labels in the chart title stack to prevent 
multiple display of the exact same chart title.
    Fixed problem with GRN or TEMPO in METAR being interpreted as 
GR and PO weather types.
    Improper time token entries in Internet Retrieve (using one 
instead of two digits) will be automatically detected and corrected.
    View Last Radar Product fixed, so as to plot the last -radar- prod-
uct.  A Window > Replot Last Product command has been added to 
replot any last product.
    Added “Window > Allow Digital Atmosphere to run in back-
ground” command which prevents Digital Atmosphere from popping 
up (such as during scripting operations) and regaining focus.  Right 
now this only suppresses the “plotting radar” message... if you 



DIGITAL ATMOSPHERE MANUAL / September 2017 |  129

see Digital Atmosphere pop up at other times, please send detailed 
information.
    Tutorial directory and sample.txt file added to build.

VERSION Equinox 1.02
(January 2, 2007)
    Emergency patch as Internet > Retrieve was nonfunctional due to 
problem in URL preprocessor.

VERSION Equinox 1.01
(January 2, 2007)
    When all workcharts are closed and then new ones are created, 
there is now proper handling of the workchart and its background map.  
The user no longer gets an empty frame.
    Added ability to auto-retrieve historical (past 1-2 weeks) radar im-
ages based on date-time selection from Radar > Set Date-Time and 
presence of an archival source in the digatmos.rad resource file.  If 
these are selected then choosing a radar product will cause historical 
data to be accessed via the Internet.   This is slightly slow because the 
data directory will have to be analyzed to find the closest matching file 
time.
    Password security has been introduced on scripting and internet 
resource URLs.  This allows you to devise your scripts so that they can 
be traded without compromising login information, and so that they 
execute onscreen without being insecure.  They can be used for not 
only passwords, but account names, server names, and so forth.  Your 
list of sensitive data must be maintained in DIGATMOS.PWD.  On each 
line, write token=value where token is a name created by you and 
value is the actual value to be substituted.  When %%token %% (your 
token word surrounded by double-percent signs) is found in a URL, it is 
replaced with the equivalent value that you defined.  Digital Atmo-
sphere will display the %%token %% marker, so don’t name tokens 
with sensitive information.

VERSION Equinox 1.00
(January 1, 2007)
    Help files converted from WinHelp to CHM to ensure compatibility 
with Vista.  This removes dependencies on Winhlp32.exe.  (12/22/06)
    Fixed analysis labels to provide correct centering of individual labels 
and correct coloring.  (12/27/06)
    Fixed problem with Canadian radar data import.  Canada made 
some changes sometime in November 2006.  This required some 
structural changes and a small change to the digatmos.rdy file.  Part 
of this was to allow users to explicitly define the image type, since 
Canada’s radar imagery was a GIF file but was actually a PNG object. 
(12/28/06)
    Support is added for NCEP high-res front bulletins.  These are 
provided at http://www.hpc.ncep.noaa.gov/discussions/codsus_hr and 
described at http://www.hpc.ncep.noaa.gov/html/read_coded_bull_
hr.shtml .  With these new bulletins, frontal positions are located to the 
nearest tenth of a degree (6 nm resolution) rather than nearest whole 
degree (60 nm).  There is no need to use the older format. (12/29/06)
    Fixed Error 103 problem with GRIB import caused when certain 
data is not found in a file.  This was caused by incorrect file handling. 
(12/29/06)

    Added support for public ECMWF data by making appropriate entries 
in digatmos.grd.  Also introduced support for scaling of units based on 
digatmos.grd entries.
    Enabled support for Preferences > Maps > Label Graticule. 
(12/29/06)
    Fixed incorrect symbol type used for thunderstorms in METAR 
reports.  Digital Atmosphere was mapping TSRA, TSSN, TSGR, etc to 
the ww code 91-94 sections rather than 95-99.  This has been fixed.  
(12/29/06)
    Added thread processing command to code just before FTP uploads 
to allow system to catch up.  This was resulting in null FTP uploads. 
(12/29/06)
    Enabled “check for updates” module to compare program version 
number with production version number on website and ask user once 
whether they want to update.  (12/29/06)
    Added import of MADIS data direct from FSL (NOAA).  This is 
included in a new Internet Retrieval resource list.
    Improved Internet Retrieval system to stream downloads into 
individual files, so binary files (like MADIS and future GRIB/BUFR) can 
be properly handled.  Files are captured under different names in /data 
and are processed out to the Digital Atmosphere home directory under 
obs.asc, obs.bin, and nids.bin.  The obs.*, nids.*, and madis.000 
files are deleted before each new download.  This also allows better 
management of content inside /data directory.  (12/30/06-12/31/06)
    Added pointer URL search function in Internet > Retrieve.  This was 
necessitated by the way SPC carries convective outlooks, and the fact 
that no static pages for this product exists.  In Internet > Retrieve, 
URLs with a space in the middle are handled as pointer URLs.  See the 
Internet > Retrieve help for more information.  (12/30/06)
    Fixed convective outlook plotting.  Changes in entire bulletin format 
prevented the plotting routine from working. (12/30/06)  

FUSION 0.6h
11-Nov-06
    Resets expiration date (60 days from first run). 

FUSION 0.6e3
05-Jul-06
    Added queue.iac and temp.iac to the build so that if no FLEET data 
has been imported, system will not cause an error when user displays 
FLEET data. 

FUSION 0.6e2
04-Jul-06
    Added PNG support (import/export)
    A METAR VRB wind (basically any wind direction that is assigned an 
internal wind direction value of -9999) is now omitted from plots and 
objective analyses.
    Additional code has been added to catch METAR lines which omit 
the wind block; up until now these have been discarded.

FUSION 0.6e1
03-Jul-06
*  This does the first and foremost important thing of resetting all 
30-day expirations for the evaluation. Obviously I cannot make the 
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release unlimited, as software pirates would have a field day with 
any unlimited version posted on our website. You can contact me if 
you’re a registered user and need a key.
* Also I have set up the compiler system under a new computer and 
a fresh Win 2000 OS. This release is rebuilt under that machine. If 
anything looks squirrely, let me know and I’ll see what happened. 
 
WORKSTATION V1.0b
(March 24 2004)
* Adds support for RVRT, AVRT, DVRG script commands. Fixed in-
ternal handling of fields to provide more uniform use of u,v,z format 
and prevent any surprise problems.
* Fixed gust problem in METAR import routine.
* Fixed Recompile Tables to remove something that was commented 
out, preventing digatmos.stn from being imported.
* Updated this help file accordingly.

WORKSTATION
(Dec 2003 - March 2004)
***** Hundreds of changes were made which are too numerous to 
list. *****

WORKSTATION 0.32alpha
(15 Nov 2003)
* Algorithm added to read the server directory when a front bulletin 
is being imported. If a server directory structure is accessed on the 
same path as the file desired, the time tokens are discarded and 
the last file in the directory list is queued for download. [This is a 
significant development in the Digital Atmosphere line that allows 
DA to consistently obtain the latest frontal bulletin from a standard 
server that allows directory listings. It has been a much-needed 
capability. Digital Atmosphere depends on a consistent appearance 
of a directory listing, and this algorithm may not work if a server be-
gins listing four-digit years in the directory listing, goes to a strange 
directory format, or the last file on the page is not the latest frontal 
bulletin. If this occurs please contact me with details.]
* The weather symbol fonts have been thoroughly reworked. Fonts 
have been scaled down in relative size and left/right bounds have 
been repaired on a few symbols. Fonts now include pressure 
tendency and cloud code symbols. This allows integration of full sta-
tion plot data. In summary, ASCII slots 040-049 contain augmented 
sky cover symbols; 050-059 contain automated sky cover symbols; 
060-068 contain pressure tendency; 069 the symbol for automated 
observation with no sky cover report; 071-079 contain low clouds; 
081-089 contain middle clouds; and 091-099 contain high clouds; 
and 100-199 contain standard WMO weather symbols. IF YOU IN-
STALL THE PATCH AND ARE STILL MISSING CLOUD AND PRESSURE 
TENDENCY SYMBOLS, PLEASE DELETE THE “WeatherSymbols” FONT 
FROM YOUR CONTROL PANEL > FONTS AND REINSTALL THE PATCH 
-- AND NOTIFY ME OF THE PROBLEM. [The new fonts allows further 
improvements to plotting functionality in the Alpha version.]
* Digital Atmosphere plotting module has been revised to handle the 
new fonts and to add pressure tendency, pressure trend, and cloud 
symbols back into the plots. [This further enhances functionality in 
the Alpha version.]

* A checkbox for Suspend Highs/Lows has been added to the 
“Fronts” Toolbar Control Panel as well as to Preferences > Analysis 
(which cannot be saved as a preference since it is for temporary use 
only. [Allows user to defeat plotting of High/Low labels on the map 
on demand, for example, when plotting the NCEP Fronts bulletin 
together with a METAR isobar analysis -- this prevents a duplicate 
field of H and L symbols from appearing on the map]
* A bug has been removed where a sky cover = 10 (automated 
with no sky cover result) created no station marking (in the classic 
DA a crosshair was plotted). This uses the new font symbol of a 
small circle with crosshair (ASCII 69). [Fixes station plots in the 
Alpha version where a station is not marked by any station circle or 
square.]
* Created a separate, independent download algorithm (not tied 
to the main download system) to allow internal downloads to a 
site (such as of a directory listing) without creating a programming 
mess. [May fix problems with erratic download behavior (including 
missing datasets) when trying to download NEXRAD radar data.]
* Hourglass has been added during Map > Generate operations. 
[Helps give user feedback as to when the system is busy.]
* Spacing of elements in a station plot has been expanded by 10%. 
[Allows station plot to be slightly less cluttered and maximizes abil-
ity to display weather symbols.]
* Bug was removed where a weather condition of 1 to 4 resulted 
in no weather symbol but left a blank area in the WX symbol area 
(pressing out the visibility value when set to “smart” and causing 
a value to be shown). 1 to 4 are now treated as no weather value. 
[Invisible “hijacking” of the weather symbol slot is now prevented.]
* Adds the missing USMAP.BMP file required for the Radar > Inter-
net Radar Settings to show its information. [Fixes a bug in the Alpha 
release where going to Radar > Internet Radar Settings shows sites 
but no background map.]
* A correction was made to the front import module to fix an infinite 
loop during processing of frontal data. Also adds code to prevent 
writing of spurious frontal data. [Fixes lockups during data import. 
Fixes range check errors during data import. Fixes stray segments 
on frontal depictions.]

WORKSTATION 0.31alpha
(15 Oct 2003)
* This version entails a vast retooling of the GRIB module. It allows 
much faster, convenient access to GRIB datasets. As usual, GRIB 
data is imported through the File > Import GRIB module. From 
there, the changes are significant. First, a GRIB field must be cho-
sen on the Grib Control panel (on the toolbox) -- see below for more 
info. All of the packaged fields are stripped out into individual field 
files (GRID.001...GRID.999 in the /grids subdirectory), with an index 
provided in /grids/grid.idx and /grids/grid.dat. From there they may 
be accessed and viewed at any time. Since they are plaintext, users 
may adapt these field files for other purposes. To summarize, here 
are the latest changes in this update:
* The GRIB module has been thoroughly reworked to spool gridded 
data directly out to files in \grids subdirectory. This allows the data 
to be instantly selected and plotted, without the need for re-import. 
Importing more GRIB data replaces the gridded data selections with 
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new data.
* Wind direction fields are now automatically separated into their 
own special fields, providing that the correct U/V components can be 
located.
* Scheme of DIGATMOS.GRD modified so that >PARAM parameters 
can be resolved to Digital Atmosphere contour Styles.
* Added control panel for GRIB on Toolbox > Control. Allows selection 
of gridded data that has been previously converted through File > 
Import GRIB. By checking either “Plot” or “Contour”, the field will be 
displayed immediately when selected. Otherwise it can be viewed after 
being selected using Plot > Custom data or Contour > Custom Data.
* SPECIAL NOTE -- CONTOUR INTERVALS FOR ANALYSIS FIELDS, 
especially with GRIB data, need to be checked and are not complete!!! 
I have to resolve all of the measurement units between the GRIB data, 
the internal formats, and the Styles.
* SPECIAL NOTE -- Custom Data Plots and Contours no longer work 
except when GRIB data is selected. This will be fixed.

VERSION WORKSTATION 0.3alpha
(12 Oct 2003)
* Numerous improvements were made to the GRIB module (File > 
Import GRIB). It appears to be working now with the NCEP AWIPS Eta 
grid and globalmarinenet GRIB files. A bug was fixed in which bitmap 
data (particularly for marine grids) was ignored, resulting in bad plots. 
Fixed a corruption of wind output in which components rather than 
polar vectors were written to the custom data file, resulting in bad 
GRIB wind plots. Help documentation has been updated. The author 
would like inputs on how the GRIB module is working.
* Fixed Contour > Custom Data so that it works with GRIB and other 
data. This will be worked on so that it uses parameter intervals defined 
in user settings.
* Removed crowding algorithm from Data > Custom Data. GRIB wind 
plots now contain the entire grid (and may be illegible if the grid is 
dense enough). This will be replaced with a more flexible user-defined 
method.
* Got some rudimentary isopleth labels working in the Contour module. 
This will need more work to tie in better with the Style settings.
* A Styles panel was developed and implemented to manage the 
Styles settings. Changes are reflected in the help documentation.
* The parameter lat/long was added to the default styles. A master 
default style (styles\master.stx) was added.

VERSION WORKSTATION
0.2alpha (07 Oct 2003)
* Adds Shapefile import capability. Documentation for this added to 
manual.
* Corrected Help > About window.
* Fixes front page tab so that Data/Control is on front rather than 
diagnostics.

VERSION WORKSTATION 0.1alpha
(Sep 2003)
* ERRONEOUS SYNOPTIC WEATHER VALUES, PARTICULARLY IN BUOYS, 
WAS ELIMATED. The T/Td extraction routines, as well as pressure, 

pressure tendency, rainfall, and so forth were looking at the whole 
report rather than just Section 1 and as a result if a 10xxx, 11xxx, 
20xxx, or 21xxx group was omitted in Section 1, it would be pulled out 
of other sections if a similar group existed, and thus a false T or Td 
was encoded. The routine was changed to only look at Section 1 and 
ignore other sections.
* NEXRAD RADAR SUPPORT has been added. Stations are selected in 
a selection panel, and are retained within the program permanently 
whenever a radar source is selected in Internet > Retrieve. Users can 
also manually select a radar file for import.
* OCEAN FILL PROBLEMS are now largely eliminated. This is because 
the mapping routines use polygons instead of vectors now.
* A MULTIPLE DOCUMENT INTERFACE HAS BEEN REINSTATED to allow 
multiple maps to be worked with simultaneously.
* NEW WEATHER TYPE FACES HAVE BEEN ADDED. This is reflected in 
your Windows Fonts folder.
* THE LAST DATA DIRECTORY USED DURING A FILE>IMPORT FILE 
ROUTINE IS REMEMBERED. This is handy for users who constantly 
access the same data directory all the time.
* SOME CHANGES TO MASTER STATION LIST (created Edition 51 and 
afterward).
* DOCUMENTATION CORRECTED to delete obsolete information such 
as time zone settings, etc.
* METAR IMPORT ADDS ABILITY TO HANDLE “RECENT” PRECIPITA-
TION/OBSCURATION TYPES. Now the module looks for REDZ, RERA, 
RESN, RERASN, REFZ, RESH, RESHRA, RESHSN, REGR, REFG, and 
RETS.
* METAR IMPORT HANDLED Q9 BUT NOT Q0 QNH PRESSURES, E.G. 
Q0984, Q0993, ETC. This support has been added.
* METAR IMPORT GUSTS ABOVE 100 ARE NOW HANDLED.
* METAR IMPORT OF P0000 PRECIPITATION WAS PLOTTED AS TRACE. 
Fixed to represent a zero amount.
* STILL ON THE DRAWING BOARD....
* · TRY TO ADD A WAY OF HANDLING WINDS WITH NO DIRECTION... A 
REMARK NEAR THE STATION PLOT?

TO DO LIST---

· .......... Mapping ....................................................
· ADD SUPPORT FOR ALBERS, LAMBERT, AND GRID (CARTESIAN) 
PROJECTIONS.
· IF A NULL STATION IDENTIFIER IS ADDED INTO THE GENERATE MAP 
BY STATION DIALOG, AN ERROR IS REPORTED.
· LABEL LATITUDE AND LONGITUDE ON GRID.

· .......... Mathematics ................................................
· INVESTIGATE THAT THETA-E FORMULATION IS INDEED 
((AS^0.190263)-0.000013126*Hp)^(1/0.190263) INSTEAD OF 
(AS-0.000013126*Hp)^(1/0.190263) AS SUGGESTED BY MIKE 
UMSCHEID AND JONATHAN FINCH (4/8/03). ENSURE FEET INSTEAD OF 
METERS ARE GOING INTO THE FORMULA.

· .......... Importing ..................................................
· DIFFERENTIATE OBSERVED WEATHER AT AUTO AND MANNED STA-
TIONS (SEE WMO CODE TABLES 4680 AND 4677). CODE 23 IS AN 
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EXAMPLE.
· INVESTIGATE SUPPORT FOR BBXX AND ZZYY BUOYS. ASSIGNMENT 
OF IDENTIFIERS APPEARS TO BE A PROBLEM. SEE SMVX90 KWBC, 
ET AL.
· BUG: METRIC VISIBILITY FROM METAR REPORTS (STANDALONE 
VALUES OF PREVAILING VISIBILITY) - IF THE VISIBILITY DATA ARE 
MORE THAN 10000M NOTHING IS SHOWN; IF LESS THAN 10000M 
IT SHOWS -9999.
· SUPPORT MAX/MIN TEMPERATURES FROM METAR REPORTS AND 
FROM SYNOP IN 333 GROUP.
· INVESTIGATE CURRENT STATUS OF AUSTRALIAN AXF SUPPORT.
· ADD SUPPORT FOR PACIFIC BUOYS ON PSU. SEE http://www.ems.
psu.edu/wx/buoydata/t-04/pac-west.html
· FIND WAY OF DEALING WITH SPECIAL OBSERVATIONS... DA HAS 
TENDENCY TO PLOT ALL OBS WITHIN THE 60-MINUTE WINDOW, 
ALONG WITH ALL WEATHER TYPES OBSERVED.
· METAR VRB WIND IS INGESTED AS NORTH... MIGHT BE BETTER 
TO SELECT A PROTOCOL TO GO WITH IN SUCH AN INSTANCE. SUG-
GESTION: SET VRB05KT OR LESS TO CALM, AND VRB06KT+ TO 
MISSING (GEORGE PHILLIPS, WSFO TOP).
· USER REPORTS PROBLEMS IMPORTING BOTH METAR AND BUOY 
DATA... CAN IMPORT-PLOT ONE OR THE OTHER BUT NOT BOTH 
SIMULTANEOUSLY.
· USER REPORTS PROBLEM IMPORTING SOUNDING DATA FROM U 
OF WYO.
· REQUEST: HAVE DIGATM PICK UP ON “MAINTENANCE NEEDED” 
FLAG (THE DOLLAR SIGN) ON US METAR REPORTS. FLAG THESE ON 
THE PLOTS SOMEHOW.
· BUG: SYNOP DECODE FOR 6****/ PRECIP GROUP SHOULD 
DECODE / AS 24 HR, APPARENTLY DOES NOT.
· FULL PARSING OF SKY CONDITION DATA (NOW THAT CLOUD 
FORMS ARE PLOTTABLE).

· .......... Plotting ...................................................
· INVESTIGATE ALLEGED NON-PLOT OF 03005 LERWICK AND 03026 
STORNOWAY. ANOTHER USER REPORTS NON-PLOT OF 03204. 
COULD BE A LINEFEED PROBLEM.
· METRIC WAVE HEIGHT PROBLEM: CODE 10807 “7” IS HALF-
METER WAVE HEIGHT (3.5 M) -- PLOTS AS 17 METERS. MAY BE 
RELATED TO METRIC PREFERENCES. SEE SFVF01 EGRR.
· REQUEST: PLOT LEVEL OF THE TROPOPAUSE.
· REQUEST: OPTION TO PLOT METRIC VISIBILITY AS KM OR IN 
CODED FORM.
· REQUEST: PLOT W1 AND W2 PREVIOUS WEATHER FROM SYNOP.
· ADD ABILITY TO SCALE WIND BARBS.
· ICAO INDICATORS ARE NOT PLOTTED FOR SYNOP DATA. NEED TO 
LINK THIS SOMEHOW TO THE TABLES.
· COLOR CODING FOR ACTUAL STATION PLOT ELEMENTS.
· BETTER HANDLING OF PRECIP TOTALS (SEE LAURIER WILLIAMS 
MESSAGE).

· .......... Contouring/Analysis ........................................
· HIGH PRESSURE AREAS IN INCHES PLOT AS 30 (MISSING TENTHS 
AND UNITS) WHILE LOWS IN 29XX WORK OK.
· BUG: PROBLEM WITH 250 MB ANALYSIS REPORTED.

· REQUEST: ADD STREAMLINE COLOR PARAMETERS.
· CHECK Q-VECTOR SIGNS.
· BUG: MAKE SURE USER CAN SHUT OFF PLOTTING OF HIGHS AND 
LOWS DURING CONTOURING OF SLP/ALSTG. USER SAID HE HAD 
TROUBLE WITH THIS.
· MAKE SURE SST’S/OTHER SEA CONTOURS CAN BE PLOTTED 
WITHOUT OVERPAINTING LAND MASSES.
· MAKE SURE CONTOURING MODULE OBSERVES THE RULE FILE.
· KICK OUT FROM EXPANDING GRID MODULE IF TOO MANY ITERA-
TIONS GO ON.

· .......... Fronts .....................................................
· INVESTIGATE POSSIBLE FRONTAL IMPORT PROBLEMS CREATED BY 
LACK OF NNNN CLOSURE GROUP.
· FIX CODE THAT DOWNLOADS FRONT BULLETINS (THESE COME IN 
AT UNUSUAL HOURS).

· .......... Data Sources ...............................................
· * SYSTEMATICALLY TEST ALL URL’S, OF COURSE.
· * DELETE SUPPORT FOR FSU IF DATA IS STILL DOWN.
· * CHANGE BULLETIN URL’S TO REMOVE OR UPDATE FD WINDS 
ALOFT SOURCES. This data type has become increasingly hard to 
find, but is being superseded by GRIB data, which Digital Atmo-
sphere is moving toward.
· NEW FRONT BULLETIN SOURCE TO BE ADDED THANKS TO 
PATRICK FRANCIS: http://www.theweathercenter.com/weather/
asus01/@Y@M@D@F_frt.wmo
· CHECK THAT DA IS USING THE CORRECT NOAA METAR CYCLE 
SOURCE: http://weather.noaa.gov/pub/data/observations/metar/
cycles/@HZ.TXT
· * AUSTRALIAN BULLETINS FROM LAURIER WILLIAMS. Surface 
METAR (from BoM via Laurier Williams) (Australia Only) http://
www.australianweathernews.com/digatm/met/@Y@M@D@H.
MET Surface SYNOP (from BoM via Laurier Williams) (Aus-
tralia Only) http://www.australianweathernews.com/digatm/
syn/@Y@M@D@H.SYN

· .......... Special ...................................................
· EXPAND GRIB SUPPORT Avail use of resources such as http://
weather.cod.edu/grib/ kindly supplied by Eric Nelson at COD.
· SUPPORT FLEETCODE FORMAT. A test version from the Feb 2002 
release will be used and upgraded. Sources to be used include 
http://ftp.hb-yacht.ch/ASXX21.270000 . Other sources are needed. 
Also make sure this is tied correctly to frontal functions.
· ADD SUPPORT FOR ARCHIVES DISKS. FIX ERRATIC CD ACCESS 
PROBLEM.
· CONVECTIVE OUTLOOK - IF BOTH DAY1 AND DAY2 ARE RETRIEVED, 
THEY BOTH PLOT. ALSO SUPPORT DAY3. SEE QUEUE.SWO.
· SUPPORT FOR LAYERING OF GRAPHICS. NOT SURE IF THIS CAN BE 
DONE JUST YET, BUT WILL INVESTIGATE.
· SUPPORT FOR UK LIGHTNING STRIKE DATA (SFUK30 EGRR) (SEE 
IAN DAVY’S MESSAGE).
· OVERHAUL ENTIRE SCHEDULER AND SCRIPTING SYSTEM. ENSURE 
DIALOGS CAN BE BYPASSED (SUCH AS NOT ENOUGH DATA, 426 
ERROR, ETC).
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· INVESTIGATE IF WE ARE REACHING LIMITS ON STATION TABLE 
ENTRIES. One user in Australia (near bottom of list) has reported some 
trouble after extensive customization in the 94100-95999 range.
· FIND WAY TO FLAG US D.O.T. AND OTHER AUXILIARY WEATHER STA-
TIONS IN STATION TABLES, AND USE FLAG TO ALLOW/DENY PLOTS 
AND ALLOW/DENY CONTOURS AS SPECIFIED BY THE USER.
· EXPANSION OF SKEW-T FUNCTIONS.
· EXPANSION OF INSTABILITY COMPUTATIONS (REQUIRES CONTOUR 
MODULES TO BE COMPLETED). INCLUDE CAPE, LCL, ETC.
· SUPPORT LAYER COMPUTATIONS SUCH AS TURBULENCE, ICING, 
PRECIPITABLE WATER, PARTIAL THICKNESS, AND SEEING CONDI-
TIONS.
· FRONTOGENESIS FUNCTION AND LAPLACIANS.
· ADD CODE TO CHECK FOR AUTO-UPDATE OF RESOURCE DIGATMOS.
SLZ FILE AND OPTION TO TURN OFF AUTO-UPDATE. ALSO POSSIBLY 
CODE TO CHECK FOR NEW UPDATE.
· FORMALIZATION OF “PRIORITY” FOR STATION PLOTS. CURRENTLY 
USE THE DIGATMOS.PRI FILE; MAY NEED TO BRING THESE INTO THE 
STATION LIST ITSELF SOMEHOW.
· FORMALIZATION OF “RULES” FILE (DIGATMOS.RUL). NEED ABILITY 
TO CHANGE DWPT, WIND, ETC VALUES. ALSO NEED TO MAKE SURE 
CONTOUR MODULE OBSERVES THE RULES FILE.
· WEATHER STATION TABLE SEARCH DIALOG, OR POSSIBLY EDITOR.
· MAKE SURE SCHEDULER COMES BACK ON IF IT WAS ENABLED WHEN 
APPLICATION WAS CLOSED.
· WHEN USER SELECTS DATA > TABLE AND CANCELS, PROGRAM 
GOES FORTH WITH PLOTTING DATA AND SHOWS “NGM FCST WIND 
PLOT”.
· FIX DROPDOWN LIST OF QUICK COUNTRY PLOTS FOR HAITI, SUDAN, 
ETHIOPIA, AND SOMALIA. [[ Fixed ]]
· REQUEST: ALLOW OTHER SHAPES IN THE “PLOT POINTS” FEATURE.
· SCRIPTING NEEDS TO SUPPORT THICKNESS AND STREAMLINES.
· MEMO: ADD ERROR TEXT FOR 426 TRANSFER ERROR.
· ADD HURRICANE/TYPHOON TRACKING. FIND RELIABLE SOURCES. 
SOME ARE: http://www.npmoc.navy.mil/jtwc.html and http://www.
drdisk.com.hk/cyclones.htm
· ALLOW SEA DATA AND AUTO FLAG OF SURFACE DATA TO BE EDITED 
IN QC PANEL.
· REMOVE THE “SFC” AND “ANALYSIS” FROM BEING PLOTTED IN THE 
LEGEND FOR A CUSTOM DATA FIELD.
· ISENTROPIC AND X-SECT ANALYSES -- OVERHAUL AND FINE-TUNE.
· RIGHT-CLICK ON A TOOLBAR TO HIDE IT.
· E-MAIL BUTTON TO ALLOW A MAP TO BE E-MAILED TO A FRIEND. Set 
aside as a long-term idea. Not enough time to work on this.
· EXPANSION OF DRAWING TOOLS. One user requested a number of 
paint functions. This is a possibility but will have to await the more 
important work above.
· DUAL MONITOR CAPABILITY.
· BUFR SUPPORT.
· METEOGRAMS.
· NETCDF FORMAT.

VERSION 2K2 0.5beta
(Feb 2002)
* Uses significantly enhanced topography/terrain engine.

* Parses Australian AXF surface data, indicated by [synopData] or 
[metar2Data] and ended by [$] and defined by formats in DIGATMOS.
FMT.
* Changed program icon.
* Moved many user controls from toolbar to side panel.
* Parses Australian weather collective bulletin produced by Australian 
Bureau of Meteorology.
* Parses FM45-IV (analysis) and FM46-IV (forecast) fleet code (see 
http://www.fleetcode.com/fleetcodedefinition.html for more info).
* Import routines drastically improved and streamlined, allowing full 
content of all METAR reports to be ingested (which in turn improves 
reliability of high/low/rainfall data from METARs).
* Plots earth shadows, depicting sunset/sunrise terminator line and 
twilight terminator.
* Adds GRIB import routines
* User can right-click on the map and choose “Recenter Map” to move 
the view.
* Deletes Daytime Saving item in General Preferences; all time conver-
sions are now totally transparent to the user; the user only needs to 
make sure their computer is set to the right time and time zone in the 
Windows Control Panel.
* Added wet bulb temperature
* Numerous other changes and tweaks (not yet documented)

VERSION 2000 - V1.0a maintenance
(4/16/01)
* Added “mixed” grid option in Preferences > Maps.
* Adds revised station tables.

VERSION 2000 - V1.0a
(1/20/01)
* Eliminates problem reported in V1.0 with left third of screen oc-
casionally being blotted out at random.
* Analysis > Export Last Analysis has been removed and in its place 
the text output is always written to GRID.TXT.
* Added SLEEP command to Scripting (see Appendix / Scripting sec-
tion).
* Corrected program so that a timer script will only execute ONCE per 
scheduled time interval. The previous version would keep re-executing 
the script as long as the current time was the scheduled execution 
time.
* Added rule file (DIGATMOS.RUL) with rules for importing observa-
tions.
* Minor enhancements to tracking of metric vs. English units for 
purposes of product labelling
* Added COM4 to COM8 in EMWIN Ingest
* Allows up to 1000 stations in DIGATMOS.PRI priority table
* Adds Map > Import command to allow satellite photos, etc, to be 
“underlaid”
* Map > Generate By Lat/Lon now allows latitude, longitude, and 
zoom to be numerically tweaked and advanced settings to be “reset” 
with one button click.
* Enhanced fills for Australia
* Script timer has been renamed to “Scheduler”.
* Scheduler now allows multiple script names along with the usual 
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multiple execution times; documentation has been added in this 
manual under Appendix / Scripting.
* Digital Atmosphere now caches a map as soon as it is created so 
that it will be available on reloading Digital Atmosphere (this applies 
both in Generate by Lat/Long and Generate dropdown menu).
* Vorticity and divergence now color appropriately as in earlier 
versions (with inverted shades for negative divergence). A solid 
zero-line has also been added.
* Divergence and vorticity have now been added to the Analysis > 
Wind menu for more convenient access.
* Divergence has been recalibrated and plots in 10**-6 m-2
* A bug in the scripting which prevented wind analysis (grids and 
streamlines) from plotting is now fixed.

BETA 1/21/01 FIXES
* Problem with Map > Save in 1/20/01 release fixed
* Conflict with Alt- shortcut keys for main menu fixed
* Added script command SFCPLOTMODEL for loading surface plot 
models (see Appendix / Scripting)
* Script commands for convective outlooks and MVFR/IFR depiction 
(dy1, dy2, cig) added to documentation.
* Printing capabilities have been fully restored and diagnostic 
gridboxes on printouts are eliminated. Print button has been fixed.

VERSION 2000 - V1.0
(12/3/00):
* Option added to File > Preferences > Analysis to allow transpar-
ent fonts
* Slight changes made to remove plotting of extra pixel line at bot-
tom of NMC fonts
* Errors under Win 98 with File > Get Archived Data and EMWIN 
ZIS extraction fixed
* EMWIN ingest capabilities improved with regards to extraction of 
ZIS files (previous versions were error-prone)
* Map > Generate by Station fixed
* Option for 1000-500 mb thickness added in File > Preferences 
> Contours
* MVFR/IFR contour labels were invisible with certain contour font 
combinations; this is fixed

VERSION 2000 beta 3
(12/2/00):

NEW FEATURES . . . . .
* Added EMWIN ingest engine (in EMWIN > Ingest)
* EMWIN upper air (upr*.*) added to File > Import EMWIN data
* Added command to clear out data directory (File > Clear data 
directory)
* Frontal workchart toolbox added (in Data > Frontal bulletins and 
right-click menu)
* 1000-500 mb thickness added (in Analysis > Temperature > 
Thickness); upper air data is required
* Calculator now allows station pressure, wind chill, and heat index 
calculations entirely in metric
* Replaced .CXN, .CXP county name label file with editable .CXT file

* Moved county name label for Ventura County (California) west-
ward slightly
* Added aspect ratio to Map > Generate Map
* Color palettes in Preferences > Colors are now saved and loaded 
with maps (with .ATP file)
* Added more information in help file
* Added Dutch weather station corrections in DIGATMOS.STN
* Drop a file from Windows explorer onto a running copy of Digital 
Atmosphere to import that file
* When a convective outlook indicates “NO TSTMS” this is plotted 
on the map
* Print capability re-enabled (was disabled during beta tests)

ERROR FIXES
* Error: File not found error in File > Get Archive Data / FIXED
* Error: Old links for UNCA in DIGATMOS.SLZ Internet retrieval table 
/ FIXED
* Error: Altimeter setting H/L values round to nearest inch / FIXED
* Error: Map > Generate Map “offset settings may produce bad 
results / FIXED
* Error: If edge of Earth is seen in a generated map, ocean fills do 
not work correctly / FIXED
* Error: DRSN (drifting snow) in METAR not properly recognized by 
Dig Atm / FIXED
* Error: Help does not work for Map > Information button / FIXED
* Error: Map > Information produces some bad results / FIXED
* Error: QC rubberband keeps appearing erratically / FIXED; NOW 
DISAPPEARS ON RELEASE OF MOUSECLICK
* Error: When cancelling in Map > Generate map, corrupt results 
occur / FIXED

COULD NOT DUPLICATE . . .
* Fronts are inconsistently erased / COULD NOT DUPLICATE
* Climatology contour of Europe January mean high temperature 
erratic / COULD NOT DUPLICATE
* Problem: Pressure tendency shows labels only for positive num-
bers / COULD NOT DUPLICATE

COULD NOT FIX YET . . . WILL ADDRESS IN UPCOMING VERSIONS . 
. .
* Problem: Timer does not work when a screensaver gets focus / 
NO SOLUTION
* Problem: Europe army weather server causes DA to hang / NO 
SOLUTION YET
* Problems with importing radar when it appears after surface data 
in raw data file / NO SOLUTION YET
* Problems with 333 group SYNOP rainfall when a 111 6xxxx group 
is present / NO SOLUTION YET
* Some problems that have been reported with plotting of warnings 
/ NO SOLUTION YET

VERSION 2000 beta 2
(11/25/00):
* Sea data now nullified in METAR reports so garbage doesn’t ap-
pear in station plots with sea elements
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* Beta bug with Analysis > Wind > Wind Speed not working is fixed
* Celsius/English beta problems fixed (in plotting and climatology 
extract)
* Beta testers need to check their station plot elements and change 
TEMP/DWPT/VIS to match valid choices
* Elevation can now be plotted in meters or feet according to English/
metric preferences
* Climatology > Extract Data now gives option of plotting the data or 
analyzing it
* Additional options in File > Preferences > Analysis to let users 
specify isopleth fonts as “small” and/or “negative”
* Added remaining font files as well as font preferences
* Fixed problem with streamline thicknesses changing “randomly”
* Added option in File > Preferences > Meteorological > “Geopoten-
tial height in full meters only”
* Geostrophic height contouring algorithms improved to eliminate 
irregularities along margins
* Added upper highs/lows
* Added tutorial directory with tutorial files
* Re-instated and improved serial/key routines

VERSION 2000 beta 1
(11/11/00):
* Added photorealistic topography
* Fixed zoom bar on map settings panel not working
* Added file drag and drop capability from Windows Explorer
* Fixed outer space fill
* Fixed “Quit Searching” in Climatology graph
* Added NCEP legacy fonts to isoplething routines for labelling of lines
* Added “Thick Contours” option in File > Preferences > Analysis 
(makes isopleths twice as wide)
* Added easter egg (Shift-Ctrl-F7)
* Changed FTP timeout from 1000 to 15 seconds, so a quicker 
response occurs if a connection is hung
* Vastly improved isentropic analysis (in “Level” dropdown on toolbar)
* Added freeform horizontal analysis (in “Level” dropdown on toolbar)
* Corrected and improved 3-D atmosphere build (in Analysis menu)
* Reinstated and improved roaming sounding
* Satellite wind observation import provided
* Slight bug in contouring fixed (prevented random charts from draw-
ing any contour lines)
* Changed “Wind Speed” analysis so that it uses a gridded x/y wind 
field for better accuracy
* Documentation provided in dual formats: context-sensitive Windows 
Help and PDF format.
* Numerous additions, edits, and improvements to help documenta-
tion.
* Added capability for user to modify Gradient Fills in analysis (in File 
> Preferences > Misc).
* Added capability to import and plot SATOB observations (NOAA/
NESDIS format).
* Added scripting commands for ISOPLETH and GRADIENT
* Added extra surface station plot element which is available to user 
(in extreme lower left of plot)
* Added import of sea surface data from SYNOP reports

* Changes have been made to allow saving and loading of upper plot 
models
* Added capability to plot h and Nh code forms from SYNOP; cor-
responding additions in Preferences
* Changed temperature and precipitation units to a single “English or 
metric” choice
* Added streamlines
* Added capability to plot fronts, highs, and lows from ASUS1 KWBC 
bulletin

VERSION 2.3.3 (MAINTENANCE RELEASE) — BUILD #1015 
(10/1/99):
* Quality control was improved to change point/point clicking to mouse 
dragging. A distance meter enhanced this capability.

VERSION 2.3.2 (MAINTENANCE RELEASE) — BUILD #989
(9/23/99):
     The main purpose of this release was to get rid of a memory viola-
tion reported by six users (which consisted of various forms of “Invalid 
pointer” and “Access violation” errors when Digital Atmosphere was 
started). This was finally traced to coding errors in the creation of 
new maps. In addition to a fix for the problem, this release has some 
additional enhancements.
* “Invalid pointer” and “access violation” errors eliminated.
* Status bar can be made visible or non-visible (View > Status Bar).
* The data directory is now *always* the “data” subdirectory under 
Digital Atmosphere. Any data should always be placed in here unless 
it is being received by EMWIN or is a single file to be chosen manually 
by the user.
* In the synoptic decoder, dewpoints are now omitted if they exceed 
the temperature.
* File > Retrieve Data used to not process warning data, while File > 
Import EMWIN Directory, File > Import File, and the schedulers did. 
This has been fixed.
* The number of importable files during one pass has been increased 
from 100 to 150 files.
* METAR reports without times but times in FOS headers are now 
parsed properly.
* Font face/sizes in EMWIN Bulletins and View Raw Data can now be 
specified in Preferences > Fonts.
* A new feature, Map > Information, provides detailed information 
about the map projection currently shown.
* Another new feature, “Show distance”, allows users to determine 
the distance between two points on the map. Identify each of the two 
points by right-clicking and choosing “Set point”, then choose “Show 
distance”. The distance will be shown in nm, sm, and km.
* Under the View menu, the selections for Speed Buttons, Time Tool-
bar, Wind Toolbar, and Status Bar are saved when the user exits the 
program, then restored when the program is started again.

VERSION 2.3.1 (MAINTENANCE RELEASE) — BUILD #930
(8/29/99):
* Fixed problem where 24-hr precipitation data in METAR reports 
wasn’t recognized.
* Readme file updated with new information.
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* Error message during Emwin Scheduler when no warning files are 
found has been eliminated.
* Map tiles have been consolidated from 365 down to 25 files, 
saving 10 MB of disk space when installed (fewer wasted blocks in 
the file allocation tables). Some users may see a slight slowdown 
when generating new maps. The new tiles are binary and cannot 
be edited. Users who need to add map information should use the 
more convenient Custom Overlay files (see the Data chapter under 
Overlay Custom Overlay).

VERSION 2.3 FINAL — BUILD #918
(8/20/99):
* Added two binary files required for program operation (DIGATMOS.
GCI and OUTPUT.WRQ).
* Adjusted effects of “smart visibility plot” to only take effect when 
left-center slot contains visibility data, weather symbols, or a blank 
entry. This way other data (dewpoints, etc) residing in this slot does 
not get blanked out when no weather is present. The user may still 
have to adjust the contents of the far left slot for optimum appear-
ance.
* File > Quality Control now allows editing of pressure tendency, 
pressure trend, precipitation amount and period, cloud codes, and 
mb and ft levels.
* Inability of File > Preferences > Contours settings to save has 
been rectified; settings will always be saved whenever “Ok” is 
clicked.
* Fixed a problem with inability to do station plots of FD data; and 
inability to plot 24 hour FD contours/grids.
* Added code that prevents “stack overflow error” and execution of 
warning import when OUTPUT.WRQ is missing.
* Precipitation contours are now indicated in the legend, along with 
the units of measure (inches or mm).
* In Internet > Retrieve Data, an “Uncheck All” button has been 
added.

BUILD #907
(8/18/99):
* AIREP reports have been enabled. These are usually found in 
upper air files and can help fill in wind patterns across oceanic 
regions.
* “Round AIREP reports within xxx mb of a standard level” has been 
added. When checked, and the user produces a constant pressure 
map, Digital Atmosphere will include all AIREP reports that are 
within the specified number of millibars of the constant pressure 
level being used (i.e. an AIREP at 278 mb will be included in a 
300 mb plot/contour if the box is checked and the value is 22 mb 
or greater). If unchecked, then all reports have to be exactly equal 
to the constant pressure level being used (i.e. an AIREP at 492 
mb would not be included in a 500 mb chart). This will help users 
control the quality and variety of data being included in upper air 
charts.
* “Data > View Sounding” and map popup menu item “Show 
Sounding” have been re-enabled.
* About 25 new EMWIN text products added to the DIGATMOS.EMP 
EMWIN product lookup list. This will add many new product descrip-

tions to “EMWIN > Get EMWIN Bulletin”.
* Digital Atmosphere now recognizes “SN” intermediate synoptic 
header in addition to “SA” and “SM” when determining times for 
synoptic reports. (Thanks to Hans-Stefan Lichius)
* Preferences > Meteorological option for “Round synoptic reports 
to nearest 6 hours when importing” has been corrected to “round to 
nearest 3 hours”. Rounding operations have always been to nearest 
3 hours.
* Data > Warnings has been adjusted to import warning datasets 
correctly. EMWIN users who keep seeing outdated warnings on their 
maps should change the purge intervals in their EMWIN reception 
software.
* The option “Default data time selection” in File > Preferences > 
General is now functional again.

BUILD #885
(8/16/99):
* If main window is maximized, the window is no longer resized 
when a new chart is loaded.
* Emwin Scheduler -- on receipt of new EMWIN data, the map did 
not erase; this has been fixed.
* MVFR/IFR contour analysis has been fixed.
* An “Access Violation” that popped up during import of some 
RCM (NEXRAD) datasets was fixed by adding code to quality-check 
incoming data. (Thanks in part to Wayne Cotterly
* Some problems with precipitation contouring in synoptic reports 
was fixed; additional code was written so that Digital Atmosphere 
could differentiate missing reports from zero and zero from nonzero 
amounts. (Thanks to Hans-Stefan Lichius)
* In an effort to consolidate internal data processing, upper air 
split files (OUTPUT.H00, H85, F18, etc) are no longer used. This will 
solve QC problems where RAOB reports can’t be deleted. Users with 
slow computers will notice delays when plotting rawinsonde reports 
(due to the large size of the upper air output file). Since the code 
has been rewritten slightly there is a slight chance this fix could 
introduce errors, so testers should note any plots or contours that 
“don’t seem to do anything”. (Thanks to Phil Rider)
* Rawinsonde data elements with solidii encoded anywhere in the 
element (rather than just the first position) are thrown out. For 
example, Katmandu was encoding heights like “5085/”, corrupting 
upper air contours.
* Scalars (temperature, wind speed, etc) could not be contoured 
with FD data due to an unwanted line of test code. This has been 
removed. (Thanks to Phil Rider)
* Various buoys, such as those in the Arctic ocean, omit the wind 
(0ddff) group, confusing Digital Atmosphere and making it plot er-
roneous winds and sky condition. This has been fixed.
* EMWIN imagewrites were saving to the DA directory, not the direc-
tory specified in Preferences. Fixed. (Thanks to Jesse Ferrell)
* Scheduled internet retrieval was not making its panel appear dur-
ing retrieval; this has been fixed. (Thanks to Wayne Cotterly)
* Derived fields (vorticity and convergence) are now functional.
* Radar status annotations now work with RCM data. (Thanks to 
Jesse Ferrell)
* TVS signature will always be plotted in red. (Thanks to Jesse 
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Ferrell)
* A “Preferences” speed button has been added. (Thanks to George 
Sobala)
* On the wind toolbar, wind vectors (as opposed to just barbs) now 
work again. (Thanks to George Sobala)
* When any map is loaded, all settings (not just lat/long/zoom) are 
transferred to the Generate Map panel in case the user wants to tweak 
the map. Also fixed the inverted transferred latitude. (Thanks to George 
Phillips)
* Menu item “View > Remove last product” has been added so that 
you can delete the last contour or plot.
* I could not duplicate the “Invalid filename” on “save station plot” 
in Preferences. For users that continue to have problems, please go to 
the Preferences > Misc tab and check “Diagnostic -- Show filename 
when loading/saving station plots”. Then when you save or load the 
station plot, report the message that it shows.
* SPECIAL NOTES: Users may mistake station plot minus signs as 
decimal points, particularly with pressure tendency.

 
BUILD # 864
(8/08/99):
* Added a “Generate Map” dropdown box on the Speed Button toolbar. 
Clicking on any of these entries causes a map for the area to be gener-
ated, using the default map width/height specified in File/Preferences/
Map. The entries for the “Generate Map” dropdown box come from 
a new file called DIGATMOS.MSE. Users may freely modify this file. 
Column 1-3 is for the latitude (south hemisphere negative). Column 
5-8 is for the longitude (west hemisphere negative). Column 10-14 is 
for the zoom width in miles. Column 15-65 is for the descriptive name. 
Users may add saved maps to this list by simply leaving the first 3 
columns blank, then for a descriptive name use an asterisk followed by 
the filename (without any dot or extensions), for example, *mymap .
* Added a Preferences entry under the Map tab for Default Width and 
Default Height. This specifies default image size settings for new maps 
that will be generated.
* Reworked the Preferences/Station Plot/”Save” segment, as some 
users have reported that the plot model is incorrectly saved. Could not 
duplicate this problem but made adjustments to code.
* Eliminated problems with importing FD and Model data (this was a 
consequence of improvements made to the data import algorithms in 
Build #849.
* Build number now shown on splash screen.
* PROBLEMS REMAINING: Internet links except for Retrieve Data are 
dead; locks up using data retrieval window with FSU SAO ticked.
* SUMMARY: New files required to run this build: DIGATMOS.MSE

BUILD # 849
(8/6/99):
* Synoptic and buoy recognition module reworked. You should see a 
greater number of synoptic observations, and especially buoy (ZZYY) 
observations that now work. Please let me know if you see any 
problems.
* Eliminated “Access Violation” during View Raw Data/Find. Corrected 
code to link in a missing component. (Thanks to John Glaveskas, Trevor 

Cousens, Geert Vandebrande)
* Legend was not cleared when generating a new chart; this has been 
fixed. (Thanks to Geert Vandebrande)
* Eliminated problems with Digital Atmosphere resolving FD data 
times. Corrected code to properly evaluate FD forecast hours. (Thanks 
to John Souza)
* Quality control has been fixed. Some stations would not get QC’d, 
and this was due to a problem in the mouse coordinate variables and 
has been fixed. (Thanks to Michael Welch and Trevor Cousens)
* Relative humidity in station plots produced an invalid floating point 
operation; this was fixed. (Thanks to Michael Welch)
* Television plot city font size was not set correctly; this has been fixed 
but not verified. (Thanks to Jesse Ferrell)
* The location to set Television font colors was not obvious. A note has 
been placed in “Preferences” under “Fonts” and in the User Manual to 
indicate where this is done. (Thanks to Robert Dale)
* Television plots are now centered horizontally. Also a bug where 
observation times were being ignored in television plots, leading to 
blank maps, has been fixed. (Thanks to Robert Dale)
* Removed “Status window on top” menu item, which is obsolete. 
(Thanks to Robert Dale).
* An error was found in the synoptic cloud code import; this was fixed. 
(Thanks to Michael Welch)
* Stations without sky condition report plotted without a center 
symbol; a plus is now plotted at the observation location. The newest 
(8/05/99 or later) version of DIGATMOS.SYI is required.
* Topography now works. (Thanks to Hendricus Lulofs and Trevor 
Cousens)
* At the end of a File/RecompileTables operation it seems that 
Windows locks up. This is because Digital Atmosphere is sorting the 
Warnings table. A progress message has been added, and the status 
window no longer truncates long progress messages. The ICAO/
WMO sorting algorithm has also been speeded up. (Thanks to John 
Glaveskas)
* Large maps were not framed correctly when loading such as at 
startup. This has been fixed by forcing the image object width to equal 
the bitmap width. (Thanks to Hendricus Lulofs and Geert Vandebrande)
* Internet retrieval list (DIGATMOS.SLZ) enhancements: Added UCAR 
upper air (thanks to Robert Schmidt), added Albany buoy.
* Digital Atmosphere now parses the RCM file when the EMWIN 
Scheduler is running. (Thanks to Robert Dale)
* User must specify the EMWIN directory for warnings; this allows 
compatibility with software such as RealEMWIN. This option is in File/
Preferences/General. (Thanks to Robert Dale)
* Speed button toolbar can now be hidden or unhidden (see View 
menu item). (Thanks to Robert Schmidt).
* All fonts used in contouring operations are now set in Preferences, 
Fonts under “Annotations”. Only the font type is used; the size is 
ignored. (Thanks to Robert Schmidt)
* Internet sites which don’t report the filesize in some headers (such 
as IWIN and FSU) no longer produce unusual progress results during 
download; program now reports “unknown”. (Thanks to Verna Young 
and Mark Hayes)
* Digital Atmosphere no longer tries to resize itself after generating a 
new map when maximized. (Thanks to Robert Dale)
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* VARIOUS ISSUES STILL TO BE RESOLVED: “Bitmap image not 
valid” will still appear when viewing EMWIN products -- this is be-
cause the functionality has been temporarily disabled; geostrophic 
wind field feathers not available; SKEW-T, CAPE and other extended 
analysis stuff has not been restored yet; will not import a V2.2 map; 
Data/Warning causes “Illegal function” error; hidden toolbars reap-
pear at startup (this is not a bug but an item suggested and will be 
evaluated); unusually high heights (above 580 dam) such as with 
what we are seeing this summer are inverted to 480+ dam.

* OTHER NOTES. I am on the lookout for errors where a data direc-
tory, data product, or error message shows a path with two solidii, 
for example, c:\program_files\digatm\data\\ or c:\digatm\data\\
infile.txt. This has cropped up a couple of times but I haven’t found 
the source of it. It will cause non-found datafile errors and so forth.

 

CHANGES FOR V2.2 to V2.3 BETA INITIAL
(JUNE 1999)
* Multiple chart forms eliminated. This was performed to simplify 
numerous algorithms within Digital Atmosphere, reduce the com-
plexity of our source code, and enable further development of other 
key areas of the program. The vast majority of users indicated that 
they preferred one map at a time.
* Status panel deleted and toolbars added. It was decided that the 
status panel, which has always been a part of Digital Atmosphere, 
was too awkward, cluttered, and frequently got in the way. It has 
been replaced by two toolbars: a time toolbar and a wind toolbar. 
They can be hidden or displayed in the “View” dropdown menu.
* Tab ordering improved. The tabbing order of controls in the map 
customization screens were improved so that navigation without the 
mouse would be much easier.
* Automated version numbering. This is mostly an internal change 
that isn’t of interest to most users. Version and build numbers listed 
on the Splash Screen and About Screen are now extracted directly 
from the application file. This is the same data seen when you 
choose “Properties” and “Version” from Windows Explorer.
* A new registration authentication scheme has been enabled. To 
register your copy, you will need to go to Help, Register to find out 
their individual serial number, then contact us for a key number. 
Note that this keying scheme is subject to change.
* RCM NEXRAD radar parsing has been vastly improved. The 
algorithms were edited, tested, and tweaked to give a high level of 
competency in parsing NEXRAD RCM data. Furthermore the algo-
rithms extract cell, mesocyclone, TVS, hail, and wind data from the 
datasets. RCM data is not available at most weather data servers, 
but it can be found in the SAORCMUS.TXT file regularly transmitted 
by EMWIN (this is also available at http://emwin.cira.colostate.edu/
rxfiles/SAORCMUS.TXT, which has been placed in the new Internet 
data retrieval panel).
* New NEXRAD site codes added to the station tables. About 40 
new RCM station codes have been added. This fills in many radar 
gaps that existed in earlier Digital Atmosphere versions.

* NEXRAD VAD/VWP wind parsing has been added. Simply import 
an RCM file and plot using “Analysis” for time and a valid FL for 
level. These reports can then be plotted or analyzed. Although this 
is an incredible tool for filling in gaps between rawinsonde stations 
and rawinsonde times, NEXRAD winds are usually missing where 
there are no droplets, dust, insects, or birds to yield a velocity 
measurement (such as high aloft or in dry regions).
* The level selector can contain FD winds, RCM winds, or both. 
This is chosen with the “R”, “F”, and “All” buttons next to the level 
selector. Use it when, for example, you want to look at NEXRAD VAD/
VWP winds aloft and don’t want to accidentally click on an FD wind 
level. You would simply hit the “R” button to pare down the list.
* Major improvements in the Internet data retrieval panel. The 
panel now uses true HTTP binary transfer to connect with weather 
data sites, delivering much swifter, more reliable data downloads 
than in previous Digital Atmosphere versions. It also allows FTP 
sites to be accessed. For those few users who need to specify a port 
number and/or user ID & password, you must append the User ID, 
Password, and Port to the end, all separated with “$$”. Example: 
ftp://ftp.mysite.com/pub/data.txt$$myusername$$mypassword$
$port ). If you decide to specify a port number, you must specify a 
username and ID.
* New formats added to “Export map”. In earlier versions you could 
save your map as a BMP or a JPG. In addition to those, you can 
now save PCX, PNG, and TIF (uncompressed and packbits) formats. 
The packbits TIF format generally offers the best format for desktop 
publishing purposes. The GIF and LZW TIF formats were not included 
because they are proprietary technologies and require licensing from 
Unisys.
* Map can be copied to the clipboard. This can be found in the 
menu under “Map” and “Copy to Clipboard”. When the map is in the 
clipboard it can be pasted into other Windows applications.
* Fonts in Preferences improved. The interface has been changed 
slightly, and we have added the ability to let you set “annotations” 
fonts, which are seen when you plot custom map points and city 
overlays, and county name fonts.
* County name overlays added. You can now add county names 
on your map. The county name text will be truncated automatically 
according to the map scale (to see more of each county name, make 
a more-zoomed in map). The font color is controlled by the “county 
overlay” setting in Preferences/Map and the font name/size is 
controlled by the “county name” setting in Preferences/Fonts.
* Custom geography added. This is done in the WeatherGraphix 
style, with custom geography residing in DIGATMOS.PLR. Edit this 
file to make changes. Note that longitude in the west hemisphere is 
negative; files imported from WeatherGraphix will need to have the 
longitude signs inverted. The color of the line is controlled by the 
“roads and custom lines” setting in Preferences/Map.
* Contour labelling algorithm improved. Previous versions of Digital 
Atmosphere plotted isopleth labels only at the chart edges, making 
closed contours difficult to interpret. Digital Atmosphere will now 
plot labels in many closed contour patterns.
* Data tables now produced. These are stored in OUTPUT.SFC (sur-
face) and OUTPUT.UPR (upper) every time you import data. These 
tables can be parsed using your own applications or can be brought 
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into spreadsheets and databases.
* Precipitation data now available. Data from the synoptic 6xxxx 
group is now imported into Digital Atmosphere and can be plotted or 
contoured. Note that most U.S. and Canada stations report 6-hour 
precipitation.
* Precipitation inches/millimeters choice added in Preferences/Meteo-
rological. This applies to precipitation plots and contours.
* Pressure tendency, and low, middle, and high cloud symbols have 
been added. These can be plotted if they are part of the surface plot in 
Preferences/Station Plots. The pressure tendency can be analyzed and 
contoured.
* Maps can be automatically exported when the program is in auto-
matic mode. You simply specify the target file in Preferences/General 
under Autosave (a complete directory and filename is required), and 
check the Autosave box. The graphics type is determined by the exten-
sion of your filename (BMP, JPG, PNG, PCX, or TIF). Every time the map 
is refreshed automatically, the completed map will be exported to your 
target file.
* Previous versions of Digital Atmosphere had trouble identifying 
some warnings. This occurred when warning bulletins did not end 
with the “NNNN” termination sequence (this recently began appearing 
on EMWIN); therefore warnings piled up in the first warning text slot. 
This has been fixed; a new header now can substitute for an “NNNN” 
termination sequence.

CHANGES FOR V2.1C BETA to V2.2
(FEBRUARY 1999)
* Preferences buttons for the FOUS level have been added. This is 
located in Preferences, Meteorological. This allows a level aloft (such 
as the T3 and T5, and R2 and R3 levels) to be plotted or analyzed. Note 
that since the T3/R2 and T5/R3 levels aren’t exactly the same, you 
should avoid calculations which cause the temperature and relative 
humidity to be combined (for example, dewpoint analyses).
* Preferences buttons for the default time select have been added. 
It is located in Preferences, General. Using these buttons you can 
pick something else besides “Automatic” time select to appear on the 
status panel when Digital Atmosphere is started.
* Cursor lat/long can be determined by right-clicking the map. Using 
the pop-up menu simply choose “Cursor location” and an information 
box will appear.
* Nondiscrimination between ETA and NGM data during contour opera-
tions has been fixed. Earlier versions did not discriminate between 
ETA and NGM data (according to the status panel) during contour 
operations.
* Appropriate labelling is now applied to charts when a contour of 
model data is done.
* The registration information box contained within the program for 
new users has been updated to reflect a new E-mail address and 
minor changes in sales policies.
* Default color preferences have been fine-tuned to get rid of contour 
line colors that match the background.

CHANGES FOR V2.1A BETA to V2.1B BETA
(FEBRUARY 1999)
* The lat/long grid interval can now be controlled. This is done in 

“Preferences”, “Maps”.
* A range check error that occurs during analysis of rawinsonde data 
has been fixed.
* The File, Print option has been fixed. The diagnostics window in 
the beta version has been disabled. The “inverse print” option had 
to be deleted due to an inability to make it work successfully without 
considerable programming. Many PostScript drivers allow you to force 
the printer to make negative printouts.
* Wind feathers are reversed in the South Hemisphere to meet 
standard convention. One note, however -- in the Analyze, Wind Grid 
section, the routines have to make the feathers a uniform style, so the 
center position of the background map is what determines the style 
rather than each gridpoint location.
* The status panel now uses “Automatic” for default time selection. 
It’s assumed that most people will only want to use “Show Contents 
First” in special cases.
* A Data Check interval has been added in Preferences in the General 
tab. In earlier versions, Digital Atmosphere checked for new data every 
20 seconds. This is now user-specifiable.
* During find operations in “View Raw Data”, the cursor is now an 
hourglass.
* New station tables are now packaged with the upgrade. This con-
sists of DIGATMOS.RIX, DIGATMOS.STI, DIGATMOS.STW, DIGATMOS.SXI, 
and DIGATMOS.SXW. This fixes some persistent “range check” errors 
with surface data that were present in the beta version.
* The Internet alphanumeric product retrival list (DIGATMOS.SLZ) has 
been updated slightly.
* Soundings have been reinstated. The sounding window contains a 
box where you can enter the desired station and easily view consecu-
tive stations.
* Background maps now plot after a gradient analysis.
* You can now overlay the base map without erasing the graphics, 
thanks to the new Map command “Add basemap”.
* The status bar at the bottom of the screen has been restructured. 
It now holds a progress bar detailing all ongoing operations, the task 
progress, and the ingest mode currently in use. Additional status 
notifications have been added throughout the analysis module and 
other processes.

CHANGES FOR V2.1B BETA to V2.1C BETA
(FEBRUARY 1999)
* Isentropic analysis has been reinstated. The isentropic level can 
be selected from the Status Panel under “active level”. You will be 
prompted for a level in whole Kelvin degrees. While this level is active, 
all analysis operations will pertain to parameters on that particular 
isentropic surface. The two most useful parameters under Analysis are 
“isentropic height” and “wind grid”.
* Isentropic height has been added as an Analysis option. This 
analyzes the height of datapoints in mb at the Active Level. Therefore 
its only suggested use is when an isentropic level has been entered 
into the Status Panel. Its color scheme currently follows the 500 mb 
contour scheme.
* A Composed CAPE option has been added in Analysis. This “builds” 
a 3-dimensional representation of the atmosphere based on exist-
ing observations and calculates CAPE at each gridpoint, rather than 
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calculating CAPE at each station.
* CAPE, LCL, and 0-6 km mean wind are now functional and can be 
accessed under the Analysis menu.
* A bug has been fixed where the toolbar Print button had no effect.
* A bug has been fixed where analysis gradient fills with no iso-
pleths produced no background map.

CHANGES FOR V2.1 to V2.1A BETA
(JANUARY 1999)
* Documentation is now contained entirely in an Adobe Acrobat 
document. The manual was extensively rewritten and updated.
* Lat/long grid usage is now controlled by the Preferences, Color 
checkbox. The “none” radio button under lat/long grid has been 
removed.
* New time tokens for Internet data products have been introduced. 
They allow you to specify the latest synoptic or intermediate synop-
tic time. You can also specify the previous hour as a base token.
* You can easily override the time settings used in Internet time 
tokens to gain access to data files for different hours. The variables 
that will be used are now shown in the Internet Data Retrieval 
window.
* Contour color and attribute settings are now in Preferences — 
“Contour”, for easy access. Advanced users only — if you delete 
DIGATMOS.CGZ, Digital Atmosphere will automatically make a new 
one when you open the Preferences window by importing your older 
DIGATMOS.CCL settings file. This is how you can preserve your color 
schemes when you upgrade.
* You can pick a range of hours to analyze or plot, rather than just a 
specific one, when manually selecting an observation time. This is 
great for data-sparse areas.
* View EMWIN bulletins using a nested tree structure similar to File 
Explorer, rather than the older series of dropdown menus. These 
bulletins also show the plain-English description of each region, as 
well as a more complete description of each product, so you can 
easily see what product you’ll be getting.
* Extensive changes have been made in the station tables, DIGAT-
MOS.STN. Three-letter ISO-3166 country code identifiers are now 
being used, and the time zone entries have been reformatted and 
filled to support upcoming capabilities. Absolutely no attempt should 
be made to import station tables using the old format without 
converting them to the new format. Various stations have also been 
added worldwide.
* There are no longer overflow problems with the View Raw Data 
window. Imported data greater than 64K in size used to generate a 
“text exceeds memo capacity” error when the user viewed it through 
File, View Raw Data. The viewer has been replaced with a new 32-
bit component which does away with the error.
* Sporadic range check errors during data imports have been elimi-
nated. The error was caused when erratic WMO numbers in synoptic 
data were looked up in a station table.
* An import is automatically done after retrieving Internet data. This 
eliminates an extra step that the user had to do in the past.
* It is now impossible for a station plot to appear at the intersection 
of the equator and the prime meridian. Occasionally when a report 
can’t be processed correctly, Digital Atmosphere is forced to assume 

it has a latitude and longitude of zero.
* You can now adjust the lowest possible METAR pressure, under 
the Preferences, Meteorological tab, to change how the hundreds 
place of a coded METAR sea level pressure is determined. This is 
useful when contouring very low or very high pressure.
* Model output thicknesses between 4800 m and 4999 m are now 
handled correctly. Since they are coded as hundreds and tens, 
earlier Digital Atmosphere versions simply assumed the thousands 
place was “5”.
* You can now specify to create a map centered on a particular 
station. This is similar to how maps are created in WeatherGraphix. 
Maps can still be generated using lat and long.
 
Documentation on older versions not available in this version 
history.



DIGITAL ATMOSPHERE MANUAL / September 2017 |  141



142  |  DIGITAL ATMOSPHERE MANUAL / September 2017


