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2. Introduction and legal notice

by Tim Vasquez, software author
Norman, Oklahoma

Thanks for trying out Digital Atmosphere. This software, initially developed in 1992 and rewritten under
Windows in 1996, encompasses thousands of hours of programming by one person (me) and is the unique
result of over fifteen years of forecasting experience, working with various meteorological workstations and
mainframes, and many years of amateur observation activities and storm chasing.  This manual is designed to
help you get up and running with this advanced but easy-to-use weather analysis program. It will start out by
taking you on a short overview of Digital Atmosphere. Following that, each menu command is explained in
detail.  Finally there is an extensive appendix with possibly all the miscellaneous information you could ever
want.

If you acquired a "lite" version of Digital Atmosphere, certain features will not work and you will need to
register in order to get these capabilities.  The philosophy is to give users basic plotting capabilities in the "lite"
version, and bundle all the extras and freebies in the full version.  Information on how to register are in the next
section.

WHAT IS DIGITAL ATMOSPHERE?

It's a powerful weather prediction tool.  It's hands-down the leading weather software program for Windows,
and is used by the National Weather Service, the Air Force and Navy, dozens of television stations and
consulting firms, and hundreds of amateurs and hobbyists. Its powerful and rapidly expanding capabilities will
let you monitor developing weather anywhere on Earth — around the globe, or right in your own local area.

Digital Atmosphere is essentially a geographical display program that ingests raw weather bulletins
disseminated by the National Weather Service to Internet sites, satellite feeds, and weather databases. Using
this data, it produces stunning plots and analyses that are equivalent to those found on multi-million dollar
workstations.

The maps and other products you create with Digital Atmosphere are fully customizable. You can define the
geographic area you wish to map and specify the map's resolution. You decide how much detail you want
shown in your maps, from country borders only to rendered topography with county lines and roads overlaid.
You choose what weather data you want displayed, how the data is displayed, and in many cases what
algorithms are used to analyze the data. Whatever your meteorological graphics needs, Digital Atmosphere can
create exactly the map you desire, using only the parameters you desire.

DIGITAL ATMOSPHERE IMPORT SPECIFICATIONS

• Land synoptic (WMO FM 12 SYNOP)
• Ship synoptic (WMO FM 13 SHIP)
• METAR (WMO FM 15 METAR)
• Buoy (WMO FM 18 BUOY)
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• Upper air (WMO FM 35 TEMP)
• Aircraft data report (ACARS) (WMO FM 42 AMDAR)
• WSR-88D RCM radar coded message (FMH 8 RCM)
• NMC frontal depiction transmission format (ASUS1 KWBC)

DIGITAL ATMOSPHERE REQUIREMENTS

• Operating system:  Windows 95, Windows 98, Windows 2000, or Windows NT 4.0.
• Processor:  Pentium or better recommended; 486 minimum.
• RAM :  16 MB or better recommended; 8 MB minimum.
• Disk space:  Minimum 35 MB.
• Source of data:  Internet access recommended, which allows access to any of numerous free data sites.
• Special notes:  Windows 3.1, Win32s, and earlier versions of Windows are not supported.

NO-NONSENSE LEGAL NOTICE

The Digital Atmosphere software program and this user's guide are copyrighted.  All rights are reserved.
Unauthorized reproduction or distribution of this software is strictly prohibited and may constitute a criminal
offense.

The user agrees to evaluate Digital Atmosphere during the 30-day trial period and determine whether the
software performs acceptably.  By registering Digital Atmosphere with the author (Tim Vasquez and Weather
Graphics Technologies), the user expresses that the software is acceptable.

The author makes no warranty or representation, expressed or implied, with regard to the accuracy of Digital
Atmosphere, its quality, quality, performance, merchantability, or fitness for a particular purpose, and may not
be held responsible for any damages whatsoever arising from the use, misuse, or attempted use of this product,
including injury, death, and/or loss of earnings.  Users who require a significant degree of forecasting accuracy
shall use other tools in conjunction with Digital Atmosphere and shall seek the assistance of qualified
meteorological consultants.

The author reserves the right to make changes and improvements to Digital Atmosphere, to the User's Guide,
and to sales and pricing policies at any time, and without obligation to notify any person or organization of the
revision or change.

All brand and product names are the trademarks of their respective owners.  Microsoft and Windows are either
trademarks or registered trademarks of Microsoft Corporation.  Digital Atmosphere is a trademark of Weather
Graphics Technologies.
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3. Why register?  Where?  How much?

WHY REGISTER?

Your Digital Atmosphere 2000 copy is a fully-functional version.  There are no separate "registered" and
"demo" versions, and there's nothing else to download or install!  However, you must register Digital
Atmosphere 2000 within 30 days.  If you don't do this, at the 30-day point the software will disable certain
features such as quality control, photorealistic maps, scripting, climatology, and loading/saving of maps.  When
you register, you will receive a key number that you enter into Digital Atmosphere.  This prevents it from
expiring and restores expired copies.  What other extras are there?  If you order the CD-ROM version (an extra
$10 plus $5 shipping) you get a copy of NSSFC-5 "Operational Mesoanalysis", a 42 meg PDF document on
small-scale forecasting.  We also hope that our low price and our commitment to continued development work
is an incentive to register.  We prefer to offer affordable prices and great service rather than inflated markups
and shoddy support, which is common in the software industry.  Your registration is greatly appreciated!

UPGRADE INFORMATION (registered users only)

Old key numbers from previous versions will not work in Digital Atmosphere 2000.  Digital Atmosphere 2000
is the first major upgrade since 1997, and a $45 fee will apply to all registered users who want to upgrade their
copy of Digital Atmosphere.  Of course our upgrade policy has always been quite generous and we have
released dozens of free upgrades to Digital Atmosphere during the past few years.  However the weather
software market is not very large and we have to periodically recover costs to continue further development
work.  If you choose not to upgrade, you can always reinstall your old version and continue to use it.

REGISTRATION PRICING

• First-time users.  Welcome!  The cost of Digital Atmosphere is $68.  You'll be added to our books as a
registered user.

• Registered Digital Atmosphere users (V1.x, V2.x).  The upgrade cost is $45.  You will need to specify in
your order that you are upgrading, and you will need to provide your mailing address info that we have on
file so that we can verify your status.  If we cannot find this, you will need to submit clear proof of purchase
(credit card statement, receipt, etc).

• Individuals who purchased Digital Atmosphere after April 1, 2000.  You are grandfathered to this edition
for free.  You will need to specify in your order that you registered after April 1, 2000 (we will check this
with our records), and you will need to provide your mailing address info that we have on file so that we can
verify your status.  If you want the CD-ROM a $10 charge will still apply.

• Texas residents.  We're Texas-based and the 8.25% tax rate applies to all individuals in Texas.

WHAT YOU GET WHEN YOU REGISTER

All users will receive a key number that will allow the program to be "unlocked".  There's nothing else to install
or download!  This key number will keep your copy fully-functional without the headache of it expiring.
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DO I NEED THE CD-ROM VERSION?

For many users, the answer is "no", you don't need the CD-ROM version.  You should only order the CD-ROM
version if you want the "Operational Mesoanalysis" PDF document, if you don't want to download the program,
or if you want to have a readily-available backup copy of Digital Atmosphere.  The downloadable version and
the CD-ROM version are exactly identical; in other words, ordering the CD-ROM doesn't give you a different
version of Digital Atmosphere.  It's strictly provided for convenience.  The cost of the CD-ROM version is an
extra $10 plus $5 shipping, and it will usually arrive within a week.

PROFESSIONAL VERSION

Digital Atmosphere 2000 Professional Version is available for $199 (no discounts or special upgrade prices
permitted).  It provides the single added benefit of eliminating all serial/key validation.  This makes it especially
geared for industrial, government, and university environments where serial/key validation procedures are
unacceptable and a pre-unlocked solution is needed.  This version is provided only on CD-ROM, and it does
include the "Operational Mesoanalysis" PDF book listed above.  Additional site licenses can be purchased
anytime at a significant discount ($45 per license).

HOW TO REGISTER

To register, follow any one of the methods below.  Note that we accept credit card (Visa/Mastercard), check,
cashier's check, money order, international money order, and Government IMPAC cards. Purchase orders from
government agencies and A-rated corporations/institutions are accepted subject to verification and must be
faxed or mailed in writing.

• Telephone. Use your VISA or MasterCard and call us at toll-free (888) 388-0070 or (405) 573-0700.
• Web site. Use your VISA or Mastercard and fill out the secure order form located on the World Wide Web

at http://www.weathergraphics.com/buy.htm and it will be automatically transmitted to us.  Orders are
usually processed within 24 hours.

• E-mail. Use your VISA or MasterCard and E-mail us at support@weathergraphics.com . Include the
expiration date and cardholder name, your address, and phone number.  Orders are usually processed within
24 hours.

• Fax. Fax your order to (405) 329-5275.  For your convenience, there's a file in your Digital Atmosphere
directory called ORDER.TXT, which you can print out and send to us.  Orders will usually be processed
within 24 hours.

• Postal mail. Orders may be sent to Weather Graphics Technologies, P.O. Box 450211, Garland, Texas
75045-0211 USA. Orders will be processed upon receipt.

• Weatherdish users.  Do you use Weatherdish?  If so, you can register by contacting the friendly folks at
ItWorks, 3490 Silverbell Rd, Chico CA 95973, (530) 899-8434, E-mail info@weatherdish.com or
www.weatherdish.com .

• Weather conference. We often attend severe weather conventions, where you can register your copy.
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4. Tutorial

4.1. Tutorial on Digital Atmosphere

Now we present a quick tutorial to help you get up and running.

You may want to print out this help page and follow along (if you're in Windows Help, just go to File > Print
Topic... to print this page).

Loading a little data
Digital Atmosphere comes with a set of prepackaged data for November 18, 2000.  To load this data, just
choose File > Import a File and select the folder "tutorial".  Select the file "incoming.txt".  Digital Atmosphere
will import all the data in this file.  On a Pentium III it takes about 15 seconds.  That's all there is to it!  Now
you can plot the data, analyze it, or perform other operations.

Make sure we're at the surface
We want to make sure we're looking at data at the surface, so check the time toolbar and make sure Level
shows "Surface".  The time toolbar is on the bar below all the shortcut buttons.

Looking at the big picture
Meteorologists usually like to get their first look at a weather chart using isobars (lines of equal pressure).  To
display these, choose Analysis >  Pressure/Height > Sea level pressure.  Congratulations!  You've made your
first weather map.  You'll notice a deep low over the northern Plains, with a Pacific high dominating the
western U.S. and an old polar air mass over the southeastern United States.

Checking out those fronts
It's easy to overlay fronts -- assuming we saved a certain kind of bulletin produced by the National Weather
Service.  Thankfully this bulletin is packaged right into the tutorial file.  To see the fronts, select Data > Frontal
depiction.  Even better!  We can see an old stationary front in the Gulf of Mexico, and that the cold front
associated with the northern U.S. low is still north of the border.

Erasing the map
The map is looking a little cluttered, huh?  No problem.  Just click on Map > Erase map.  Ouila!  All the
overlays and markings are gone.

Looking at station plots
Station plots are little "packets" of data that appear on the map at various locations, showing the actual
observed conditions at that location.  Plotting them in Digital Atmosphere is a snap.  Just click on Data > Data
plots.  Instantly the map is filled with a smorgasbord of information.  Take a look at the plot in eastern Iowa.  It
shows a temperature of 19 degrees, a dewpoint of 15 degrees, and a sea level pressure of 1018.7 mb (prefix it
with "10" if it's below 500, "9" if it's above 500, and add a decimal point between the second and third digit).
The squiggly line at the right is the pressure trend over the past 3 hours; it was rising then steady, and the
change was 0.4 mb (divide the number by ten).  The long shaft sticking southwestward is the wind direction; it
always sticks INTO the wind, so the wind is blowing from the southwest.  There is one tiny barb on the shaft,
indicating a wind speed of 5 mph (every long barb is 10 mph; every short one is 5 mph).  And in the center
circle, there is no shading, indicating clear skies.  The amount of shading is proportional to the amount of
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clouds.  You'll also note that some stations have a square; this means the observation was made by a
computerized station.  Some stations have a red color; this means bad (IFR) weather, while some are blue
which means mediocre (MVFR) weather.  The coloring is determined strictly by visibility and cloud height and
is more for the use of pilots and experienced meteorologists, though they can clue you in on where significant
weather is happening.  If you look in the southeast U.S., you'll see that some stations have two fat dots.  This is
the international symbol for rain.

Overlaying more contours
Now choose Analysis > Pressure/Height > Sea level pressure.  Nice!  You just added the same field seen earlier
on top of the map.  This illustrates how you can view different meteorological fields at the same time.

Seeing the wind flow
It is possible to visualize the wind field.  Go ahead and click on Map > Erase map.  Now choose Analysis >
Wind > Wind field.  You'll see a pretty cool gridded array of wind patterns! It's the ideal thing to depict how the
air is moving.

Another way to see the winds
A second way of seeing winds is to choose streamlines.  Go ahead and choose Map > Erase map again.  Now
choose Analysis > Wind > Streamlines.  These lines are always oriented parallel with the wind.  You can see
that if you released a balloon in Kansas and it stayed near the ground, it would probably drift towards
Michigan.  Forecasters in the tropics love to use streamlines, as it's one of the best tools for finding
disturbances in that region of the world.

Looking at isotherms
Remember how you overlaid isobars on the map?  It's easy to overlay other fields, such as isotherms (lines of
equal temperature).  Just go to Analyze > Temperature > Temperature (F) or (C).

Moving around
Want to look at a different part of the world?  Look at the speed button toolbar, and at the far right you will see
an option called "Generate Map".  Simply click on this dropdown menu and pick "Illinois".  The workchart will
be redrawn with Illinois in focus.

Fine tuning the map
There's another way you can generate maps for exact areas you want to see.  Click on Map > Generate > Enter
lat/long.  A d

That completes the quick tour of Digital Atmosphere. This tour was only intended to give you a feel for how
Digital Atmosphere works.  There's lots more to see that is better covered elsewhere in the help files than in this
tutorial! As soon as you feel ready, jump on the Internet or your favorite online service and download new
weather data.  Then poke around and get comfortable with the software.  There's almost no way you can
"break" it.  Have fun!
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5. Display Components

5.1. Introduction

Before we continue, let's look at eight major components of the Digital Atmosphere screen in the illustration
below. It's important to be familiar with each of these parts, since we will refer to them occasionally through the
manual. This chapter discusses each component in detail.
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5.2. Main menu

The main menu is where you issue most commands for Digital Atmosphere. This dropdown menu structure
works just like most other Windows programs. Each main menu command will be described in the following
chapters in this manual, so we won't discuss them in detail at this time.

5.3. Speed buttons toolbar

Speed buttons. The speed buttons are provided as a convenient way of accessing frequently-used main menu
commands. You can find the meaning of each one by simply resting the cursor on a button (a popup hint will
appear). Each button corresponds to a main menu command, summarized as follows (going left to right). To get
more information, go to the following chapters to see what the main menu command does.

  Import a file  -- Accomplishes the same thing as File > Import file

  Import a directory  -- File > Import directory

  Load a map -- Map > Load Map...

  Erase workchart -- Map > Erase Map

  Data plot -- Data > Data Plots

  Internet retrieval  -- Internet > Retrieve Data

  Print -- File > Print

  Quality control -- File > Quality Control

  Calculator -- File > Calculator...

  Warnings -- Data > Warnings

  Preferences -- File > Preferences

Generate map. This presents a list of geographical locations that can be generated. The workchart will then be
redrawn with the specified location. You can use this instead of the "Map > Generate map" options for creating
charts.  The size of the workchart is dictated by the settings in File > Preferences > Maps > Default Size.  Note
that the entries and their lats/longs/zooms are loaded from the DIGATMOS.MSE file in your Digital
Atmosphere directory, which you can edit with any text editor.

5.4. Time toolbar

Surface time. This controls how the valid time for surface data is chosen. You should leave it on "auto" to
allow Digital Atmosphere to choose the most popular time from the available data. If you wish to override it,
you can choose "manual" to be prompted for a time each time you generate a surface product, or you can
choose a specific numerical time.
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Upper time. This controls how the valid time for upper-air data is chosen. You should leave it on "auto" to
allow Digital Atmosphere to choose the most popular time from the available data. If you wish to override it,
you can choose "manual" to be prompted for a time each time you generate an upper-air product, or you can
choose a specific numerical time.

Valid time. Controls whether forecast data is used. You should always leave it at "analysis" unless you are
plotting FD winds aloft data. Model output data valid times are chosen separately.

Level. This controls the current level. Set it to "surface" when viewing surface data. Set it to a "mb" level when
viewing rawinsonde data. Set it to a "ft" level when viewing FD winds aloft or RCM wind data.
R. Press this to delete all of the "ft" entries from the "level" list except those used for RCM wind data.
F. Press this to delete all of the "ft" entries from the "level" list except those used for FD winds aloft data.
All . Press this to restore all "ft" levels, including FD and RCM wind data.

5.5. Analysis toolbar

Wind . Controls what type of wind information is used during any "Analysis" operation. Leave this on
"observed" for most typical uses. Otherwise, choose geostrophic, ageostrophic, or Q-vector to view these
respective wind fields.

Wind plot. Controls what symbology is used to display wind fields during any "Analysis" operation. You can
choose from "barbs" or choose "vectors".

Derived field. Controls what kind of derivative field is used when producing any kind of "Analysis". You
should leave this on "No" except when producing vorticity or convergence maps. For more information on
derived fields, see the chapter on Analysis.

Advection box. If checked, an advected derivative field will be used during any kind of "Analysis". You should
normally leave this unchecked.

5.6. Script toolbar

The script toolbar is a powerful interface that lets you give Digital Atmosphere a certain degree of
automation.  You can initiate tasks at various hours.

For more information on working with scripts, please see the Appendix under Scripting.

Command .  Type any command in this box and hit return or press Enter.  It will then be executed.

Run script .  Runs a predefined script.

Create script .  Creates a script.  You can use any text editor instead of this button.

Timer off/on .  Indicates whether the timer is off or on.  Press it to call up the timer configuration window.
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5.7. Workchart

The workchart is the large graphical space that is used to display maps, plots, and contours. There can only be
one workchart open at any one time.

5.8. Status bar

Messages about what Digital Atmosphere is doing are displayed on the status bar at the bottom of the Digital
Atmosphere screen.

5.9. Pop-up menu

Digital Atmosphere allows you to issue specific commands by right-clicking on the map. This action defines a
location. When you do this, a popup menu will appear and you will have the following options that apply to the
defined location:

Identify Warning . If you have imported valid warning data, this option will locate a warning at the defined
location and display its text. If there is no valid warning data, no warnings will be found.

Set point. This is used to define one of two points to be used in either the Quality Control function or the Show
Distance function. For more information, see "Show distance" (about five lines down) or "Quality Control" (in
the File chapter).

Get lat/long. This will display the latitude and longitude of the defined location.

Show sounding. If you have imported valid rawinsonde (upper air) data, Digital Atmosphere will find the
closest rawinsonde station to the defined location and display the SKEW-T (sounding) for that station.

Show distance. Shows the distance between two points previously chosen. To set each point, right-click on the
map and choose "Set point". This must be done twice to define the start and end. Then right-click anywhere and
pick "Show distance". The lat/long of the start and end points, along with the distance in nm, sm, and km, will
be shown.

Frontal depiction tools.  Please refer to the chapter Data > Frontal Depiction for further information on using
these selections.
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6. File Menu Commands

6.1. Introduction

These menu commands are reserved for functions that operate on data files or are significant to Digital
Atmosphere's operation.

6.2. Import EMWIN directory

This should only be used by users who are running EMWIN. This imports all data from the EMWIN directory
on the computer. It uses the settings in Preferences, General to figure which files to use. The EMWIN warnings
are also imported at this time.

6.3. Import Weatherdish directory

This imports all data from the Weatherdish directory on the computer. It uses the settings in Preferences,
General to figure which files to use. The Weatherdish warnings are also imported at this time.

6.4. Import file

Regardless of the mode that Digital Atmosphere is in (manual or automatic), this prompts the user for a
specific file to import.  The file will then be decoded and imported.  No other files will be imported.  The data
file should consist of text bulletins containing METAR, synoptic, SAO, FD winds aloft, buoy reports, or
rawinsonde data.    After the data is imported, it can then be plotted or analyzed.

6.5. Import directory

Digital Atmosphere is a tool that lets you create weather charts using current raw data. Therefore, the first
thing you need is a tool to get raw data into Digital Atmosphere. We refer to this process as raw data import.
Once you import data into Digital Atmosphere (via any of the possible methods explained below), the program
will continue to work off that data until you perform another import. In other words, the data will still be in
Digital Atmosphere if you exit out of the program and then run it again later, but once you perform a second
import all the data from the first import will no longer be available.

Regardless of the mode that Digital Atmosphere is in (scheduled or manual), this command imports all files
contained in the directory listed on the File, Preferences General tab under "Data directory". The data files
should consist of text bulletins containing METAR, synoptic, SAO, FD winds aloft, buoy reports, or
rawinsonde
data. After the data is imported, it can then be plotted or analyzed. This is the command you should use if you
want to look view data from several files at the same time.
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If you use the Internet, you can avoid all use of "Import" by using "Internet", "Retrieve Data". Digital
Atmosphere will get data from the Internet and import it automatically when it's finished.

If you need more detailed information, consult the Appendix for technical information on data import.

WARNING : Never import a directory containing binary files, programs, or over 100 files. The results may be
unpredictable.

6.6. Clear data directory

This is a utility command that clears out the data subdirectory /data  under Digital Atmosphere.  Normally it
does not need to be used unless suspicious plots or contours occur and the user wishes to flush out all data.

This ensures that File > Import directory does not inadvertantly retrieve files that were placed there by the
user.  It can also prepare the data directory in case the user wishes to place numerous files into the directory
to be imported.

Data that has already been imported and stored in native binary format will remain unaffected, but "Import
directory" will not work at all until new data is placed in the data directory (via a file copy or via the Internet >
Retrieve command).

6.7. Get archived data

If you have the Surface Archives or Upper Archives disc sets from Weather Graphics Technologies, you can
use this option to retrieve data on the disc instantly.  Digital Atmosphere will decompress and ingest the
desired datasets, enabling you to plot maps of any date and time between 1961 and 1990 (and earlier and
later in some cases).
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In the above example, we've specified that we want data for September 4, 1972 at 1700 UTC (Greenwich
Mean Time).  It is assumed that the Surface Archives 1961-73 disc is in the drive (if the wrong disc is in the
drive, you will get an error).  Once the "Import" item is selected, the data will be imported.  You can then use
commands such as Data > Plots and Analysis > Sea Level Pressure to view the data.

6.8. Quality control

If you're a newcomer to meteorology, you'll quickly discover that not all weather data is 100% accurate.  Errors
can get into raw weather data either through transmission problems, communications interference, human error,
or simply the observer hitting the wrong key when typing up the report.  These can either be unnoticable or may
corrupt an analysis.  Fortunately, Digital Atmosphere provides a tool to help fix the problem.

To perform quality control, simply drag the mouse over the location where erroneous data is suspected.  A box
will appear, as shown below:

When you select File > Quality Control or press the QC speed button, the quality control panel will appear, as
seen below:
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You may then edit the values shown and correct any entries that look suspicious.  Always use a value of -9999
to indicate missing data.

Note that the data shown is dependent on what the active level is (as is shown on the Time Toolbar).  If the
active level is a non-surface level, Quality Control will only display upper-air data.  If the active level is a
surface level, Quality Control will display only surface data.

The options you have are:

• Accept Entry — Saves the report as shown, including any modifications you might have made.  Once you
hit Accept Entry, all changes become permanent.

• Ignore Changes — Ignores any changes that you've made to the report and moves to the next one.
• Delete Report — If the individual report is so corrupted that you know you won't want to use it, you'll

probably want to delete it.  This is the button to use.
• Stop Search — Stops sifting through the file, saving any values that you've already entered.

Note that QC displays all data within the bounding box (even if it's filtered out on the map), so you may need to
press "Accept entry" numerous times until you find the station you want.  One way of avoiding this problem is
to make the initial QC box as small as possible so that you get only the station you want.

Since QC changes the formatted binary data files, you will lose your changes if you re-import the original data.
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6.9. View raw data

Very often, you will want to go back and look at the original data.  Not only is this handy; it is recommended so
that you can review observations for vital clues (such as observer remarks), as well as look through any
forecast data you might have captured.

The file that is shown is the internally-saved clean data file produced by the most recent File, Import command.
The original raw data file is not referenced and does not have to be present.  If you don't like this interface, you
can view the same data file using any text editor and setting it to examine DATA.USR in your Digital
Atmosphere directory.

The View Raw Data panel also has a "Find" function that lets you search for stations and keywords in the file.

6.10. Print

This option will print your currently active map.  It's that easy!  If you want to make changes in the way that
the map is printed, you'll need to use Print Setup, listed below.  Print sends an exact copy of the screen image to
the printer, so if the printouts are too dark, you will need to change your map settings in Preferences and
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regenerate new maps (preferably with white backgrounds), then print those.  Also keep in mind that many
PostScript printer drivers will allow you to set the printer to produce negative printouts.

If the maps are too dark, you should avoid using solid colors.  Regenerate your maps without topography or
ocean fills.  Topography is designed mainly for screen viewing.  If you absolutely must have dark maps on-
screen and can't force your printer to produce acceptable output (either through File, Print Setup or through the
printer's own setup menus), you will need to export the map and then use a photo-editing type graphics program
(such as Photo Shop or Paint Shop Pro) to make a negative image or enhancements that allow for better
printouts.

If the printer shows memory errors, this means that the graphic you are sending to the printer is too large to fit
into the printer's memory.  The easiest way to remedy this is to go to File, Print Setup and choose a portrait
printout rather than a landscape printout.  Another solution is to regenerate your charts without using any color
fills or topography (i.e. totally composed of line graphics).  The third method of solving a memory problem is to
use a lower resolution (i.e. choose 600 dpi rather than 1200 dpi, or 300 dpi rather than 600 dpi in your printer
setup).  The final and best solution is to increase the amount of RAM in your printer by installing a SIMM
memory module.  Your printer will require a total minimum amount of 2 MB of RAM, but will work best with
4 MB or more.

Some users report problems printing to HP LaserJet and a couple of other printers (such as getting blank
pages).  This is usually a problem with the Windows PCL 5 print driver and is beyond the control of Digital
Atmosphere.  Solutions for this that have been documented are changing the resolution from 600 to 300 dpi or
change the print mode from "vector" to "raster".  If your printer is equipped with a PostScript option, always
use the PostScript mode for 600-dpi printing.  Overall, this printing problem is not specific to Digital
Atmosphere and may occur with other applications that make extensive use of the PCL driver.

HP Laserjet 4si / HP Laserjet 4000 / HP Laserjet 4+.
Windows 95.  Landscape mode tends to generate blank pages, and portrait tends to print garbled maps when
using PCL5.  PCL 6 tends to fix the problem.
Windows 98.  No problems.

Canon BJC-240.
Windows 95.  Problems with Canon BJC-240, with latest driver, with maps coming out extremely garbled in
both landscape  and portrait modes.
Windows 98.  No problems.

Canon  LBP-660.
Windows 98.  Prints blank pages.

6.11. Print setup

This function is used for specifying how you want your printer to print maps.  These panels will vary based on
what type of printer you are using.  One option that is useful for some printers is the "Graphics Resolution".
When you lower this value, it will help you send extremely detailed charts to printers that keep producing "out
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of memory" errors or blank pages.

6.12. Calculator

Do you need to find a wind chill value?  A mixing ratio?  A theta-E?  No problem.  Digital Atmosphere's
meteorological calculator lets you plug in values and find a result.

Simply choose the conversion you want at the top, enter the values in the center panel, then press Calculate.

Note about actual pressure.  A very important note — when you are asked for "Actual Pressure", this
indicates the actual pressure of the parcel, not the sea-level pressure, unless you're really at sea level!  You can
find your "actual pressure" by simply calculating "Station Pressure (mb)" and entering your altimeter setting
(pressure in inches as provided in public weather reports) and your elevation in feet.  An example: In Denver,
Colorado, your elevation is 5300 ft and the pressure is 29.96 inches.  This yields a "station pressure" or "actual
pressure" of 834.8 mb.  You can then use this value in calculations which ask for "actual pressure".

6.13. Recompile tables

This option is used to recompile station tables from scratch.  Most users don't need to use this command since
compiled tables are already provided with Digital Atmosphere.  It is used only when you change the station
listings in DIGATMOS.STN and you want these changes to be enabled.

To modify DIGATMOS.STN, you'll need a standard text editor (such as MS-DOS EDIT).  Always be
absolutely sure that you save it as a ASCII (text) file or you will corrupt your installed copy.  When you have
finished your changes, you can use File > Recompile Tables at any time to regenerate the internal listings.  It
takes about 5 minutes (the sorting algorithm is a demanding operation).  Once the procedure is finished, Digital
Atmosphere will make use of the new changes.

You may Recompile Tables as many times as you wish.

SPECIAL NOTE:  Effective with Digital Atmosphere V2.2, a new station table format is being used, which
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contains changes in columns and data fields.  Never try to import older DIGATMOS.STN formats, as you
will corrupt your installed copy.

6.14. Preferences

This section has a chapter of its own.  Please consult the detailed chapter on Preferences Settings.

6.15. Exit

Exits Digital Atmosphere.  The background map will be saved and it will automatically appear the next time
you run the program.  The last data set you imported will continue to be available.
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7. Map Commands

7.1. Introduction

These commands are used to generate maps for Digital Atmosphere.

7.2. Erase map

Before you make annotations, plots, or contours on your map, Digital Atmosphere retains a copy of the original
map image in case you want to start with a blank slate.  Use this command whenever you want to erase weather
data from the map.

7.3. Generate map

There are three ways to generate a new map from scratch:

• Map > Generate Map > Enter lat/long
• Map > Generate Map > Enter station
• Generate Map list of countries and regions on the Speed Buttons toolbar

The easiest method is to use the "Generate map" dropdown box on the speed button toolbar and pick a country
or continent.  For those that want more accuracy, these two selections will provide greater control of map
generation.
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7.4. Generate map by lat/long

This is a powerful tool that replaces the map contained within the selected workchart with another map.  Once
you choose this command, you'll see a settings panel appear.  This is where you choose how your map should
look.  All maps are generated using an orthographic ("satellite view") projection.

• Latitude .  Sets the latitude for the center of the screen in degrees.
• Longitude.  Sets the longitude for the center of the screen in degrees.
• Scale.  Sets the width of the map in either miles or kilometers.
• Map size height/width.  Allows you to specify how many screen pixels wide and tall you want the map

image to be.  You may also wish to choose one of the map size speed buttons.  If you want an exceptionally
detailed image, you may want to choose one of the higher settings.  The 1550 x 1150 size yields excellent
printed maps that are suitable for publishing.  If this image size is larger than the screen, you will be provided
with scroll bars to roam around the image.  However, note that large maps place a burden on your computer's
resources, and too many large maps open at the same time may cause warnings or errors.  Avoid setting sizes
larger than 2000 pixels.

• Offset (advanced map setting).  Most users should leave these at a value of zero.  Advanced users may want
to change them to put the map off-center from the projection center (usually to align the image with satellite
photos, and so on).

Digital Atmosphere

Page 21



• Aspect (advanced map setting).  Most users should leave these at a value of one.  Advanced users may want
to change them to compress or expand the map geometrically by a certain value in the X or Y direction
(usually to align the image with satellite photos, and so on).

• Location quick-pick.  Click on any of these buttons to automatically set an appropriate latitude, longitude,
and scale for a commonly-used region.

• Zoom quick-pick.  Click on any of these buttons to automatically set a map scale based on a meteorological
scale type.  Global scale sets a width of 8300 nm, synoptic scale 4000 nm, subsynoptic scale 3000 nm, meso
alpha scale 1500 nm, meso beta scale 700 nm, and meso gamma scale 200 nm.

• Map size quick-pick.  These give quick predefined map size settings.

7.5. Generate map by station

If you know the station that you want to center you map on, you can simply enter it here.

• Station.  Enter an ICAO code, WMO code, IATA code, or partial station name.
• Map width .  Sets the width of the map in miles.
• Map size.  Allows you to specify how many screen pixels wide and tall you want the map image to be.  You

may also wish to choose one of the map size quick-pick buttons.  If you want an exceptionally detailed
image, you may want to choose one of the higher settings.  The 1550 x 1150 size yields excellent printed
maps that are suitable for publishing.  If this image size is larger than the screen, you will be provided with
scroll bars to roam around the image.  However, note that large maps place a burden on your computer's
resources, and too many large maps open at the same time may cause warnings or errors.  Avoid setting sizes
larger than 2000 pixels as there may not be enough memory.

7.6. Load map

Loads a workchart from your disk drive.  You will need a previously-saved workchart (which can be saved
using the Save Map command).

Technical tips
Load Map loads images that are Windows bitmaps (filename *.BMP), and it also expects to load a map
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attribute file with the same name (*.ATR), which contains data about the image's latitude, longitude, and zoom
setting.  If this map attribute file is not present, you will get an error.  This is why you cannot simply make a
BMP satellite photo and load it up as a map, unless you've already saved a map with similar settings in Digital
Atmosphere and replaced the map BMP with the satellite BMP.

7.7. Save map

Saves the workchart for future access within Digital Atmosphere.  This also saves any markings, annotations,
weather data, and contours that are on the map already as a permanent part of the map, so if you intend to
load this map later without any weather data, you'll need to use the Erase Map command to get rid of the data
before you save it.  If you want to save the map for your projects, presentations, and so forth in one of several
graphics formats, you should instead use Map > Export map.

An important consideration is that only Windows bitmap (BMP) files can be saved, and they are rather large.
File sizes can range anywhere from 300 to 700K in 8-bit color mode to 2.5 megs in 24-bit color mode.  So
avoid saving too many unless you have plenty of disk space.  If you're using on-the-fly disk compression (such
as Stacker, DoubleSpace, DriveSpace, etc), these images will take up about 80% less disk space than they do
when uncompressed.

Save Map produces one image file (a Windows bitmap, *.BMP) and a very small map attribute file (*.ATR).
The ATR file is necessary to load the map into Digital Atmosphere and should stay in the same directory as the
BMP file.  Advanced users can learn more about ATR files with Map Attribute File Structure in the Appendix.
Once the *.BMP file is saved, you are free to use any graphics editor to tweak or annotate the image.  Note that
you must re-save it as the same type of graphics format it was in (a BMP with a color depth of 24 bits), or
Digital Atmosphere will produce an error message when it attempts to load the image.

7.8. Export map

This command is exactly identical to Save Map, except that no map attribute file (ATR) is saved.  Therefore it
is designed to save maps for use in your projects, presentations, or reports.  The output format can be selected
under "Save as type".

Here are the different filetypes you can save.

• BMP (Windows bitmap).  This is a universal format but large filesize.  Note that it creates 24-bit files that
are not compatible with some older graphics viewers, particularly those written before 1996.

• JPG (JPEG).  Tightest compression, but details may be lost.  Compression settings are specified in File >
Preferences > Maps > JPEG image compression.

• PNG (Portable Network Graphics).  This is similar to GIF; good compression.  Only browsers written after
1998 or so will recognize them, though.

• PCX (ZSoft Paintbrush).  It's an older format that's a defacto standard among ancient DOS programs.  You
should always use BMP instead of this format when possible.

• TIF (TIFF Packbits).  This is best for important documents and desktop publishing.  Compresed TIF saving
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is not available since this requires separate licensing from Unisys.

The illustration above shows where you change the image type when using Export Map.  If you have chosen
Save Map, all you will see is BMP.

7.9. Blank map

Creates a workchart with no background map.  Projection data from the last workchart is used.

7.10. Information

Displays detailed information about the map currently shown.  Included is the map width and height (in both
pixels and nautical miles), the center latitude/longitude of the map, and the corner latitude/longitude points.  All
negative latitudes indicate the southern hemisphere, and all negative longitudes indicate the western hemisphere.
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7.11. Set comment

Sets an annotation that will be prefixed to the legend of a workchart when data or contours are drawn.  You
can enter any information you want.  A typical purpose is for specifying exact dates.

The above entry results in this when a map is plotted:

7.12. Copy to clipboard

This is the easiest way of transferring a workchart to another software program.  When you choose this, the
workchart is placed in the Windows clipboard.  From there, you can paste it into any of your favorite graphics
programs.
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7.13. Make topography

(Available only in registered version)

Renders a topographic representation (terrain features) of the Earth on your map projection.  After the
topography is drawn, Digital Atmosphere then re-overlays the basic geography data.  The topography draw
operation may take a few minutes on slower computers.

Example of topography in northern Siberia.

7.14. Photoreal topography

(Available only in registered version)

Renders a photoreal representation of topography.  If you plan to use this feature often, you may want to
head to File > Preferences > Maps and tweak the map elements to give you the most useful possible image.
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Example of pressure field over central Africa using photoreal topography.

7.15. Add basemap

Redraws the workchart basemap without erasing the contents of the workchart.

7.16. Add point

Overlays a specified point on your map.  You can also load or save a point plot list.

7.17. Add cities

Overlays predefined city marks and labels onto your map as a reference.

Very important!   Before you can use this successfully you will need to define the cities you want drawn by
editing the file DIGATMOS.CIT with any text editor (such as Windows Notepad).  The columns used are as
follows:

1-2  Latitude of city in degrees
3-4  Latitude of city in minutes
5  N or S latitude sign
7-9  Longitude of city in degrees.
10-11  Longitude of city in minutes.
12  E or W longitude sign
14-33  Name of city as you want it to appear

The DIGATMOS.CIT file contains some default cities that are formatted per the above specifications, which
you may find useful to refer to as a template when adding new cities.
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7.18. Add counties

Overlays United States counties, parishes, and certain city border information.  After this is done, the basic
geography is re-overlaid onto your map.  The source file is highly detailed, condensed from U.S. Geological
Survey data, and has an accuracy of 1 mile.  There are about 175,000 points in this file, so it may takea  few
minutes to plot on slower computers.

Outlines
Overlays the actual county lines onto the map.  This data is in binary format and is not editable.

Names
Overlays the names of the counties.  The names are truncated according to the zoom factor so that they fit
within the county.  Users can edit the locations of these county labels as well as their text content by editing the
plaintext file DIGATMOS.CXT with any text editor (such as Windows Notepad).

7.19. Add highways

Overlays United States interstate highways onto the map.

7.20. Add secondary highways

Overlays United States U.S. and state highways onto your map.  This is a detailed process and may take a few
minutes, depending upon your computer.

7.21. Add custom overlays

Overlays a custom overlay onto the map.  This is done in the WeatherGraphix style, with custom geography
residing in the file DIGATMOS.PLR.  Edit this file manually (using an ASCII text editor such as Windows
Notepad) to make changes.  Note that longitude in the west hemisphere is negative, so files imported from
WeatherGraphix will need to have the longitude signs inverted.  The color of the line is controlled by the "roads
and custom lines" setting in File > Preferences > Map.

7.22. Add date stamp

Adds a date/time stamp at the top of the map.
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8. Data Commands

8.1. Data plots

Overlays data plots on the workchart.

The level at which the data applies is dictated by the Level setting on the Speed Button Toolbar.

8.2. Custom data plots

Plots data on the workchart from a custom data file.  This is intended for use by advanced users.

A custom data file comprises a package of data that can be readily imported into Digital Atmosphere.  You can
create this data by any means (using third-party programs).

The custom data field must always be placed in the file CUSTOM.DAT in your Digital Atmosphere directory.
It should be structured according to the following example:

   THUNDERSTORM DAYS (ALL MONTHS)
   US AL:Bir 722280    33.567    -86.750   57        *
   US AL:Oza 722269    31.283    -85.717   73        *
   US AL:Hun 723230    34.650    -86.767   54        *
   US AL:Mon 722265    32.383    -86.367   56        *

Here is a breakdown of each row and column:

Row 1      A header that will be used by Digital Atmosphere to title the
field
Row 2+     Data, as explained below in "data row format"

Data row format:
Column 1-19    Not used.  The user may wish to put location names here.
Column 21-29   Latitude (degrees and thousandths; negative is southern
hemisphere)
Column 31-39   Longitude (degrees and thousandths; negative is western
hemisphere)
Column 41-49   Primary data value
Column 51-59   Secondary data value

Ingesting a scalar field.  When a simple scalar field (such as temperature, pressure, wind speed, etc) is
imported, the value must be placed in the primary data value field, and the secondary data value field must
contain an asterisk character: *.

Ingesting a vector field.  If a numerical value is detected in the secondary data value field, Digital Atmosphere
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will assume a vector field (such as wind u/v component) is being ingested.  The primary data value must
assume a direction relative to true north (such as wind direction), and the secondary data value must assume a
magnitude (such as wind speed).  When vector data mode is being used, analysis calculations will use wind
barb symbology to represent data elements.

8.3. Table plots

Plots weather data from tables generated by third-party sources.  Various weather agencies, such as the
Australian weather service, generate lists of rainfall and temperature data.  Digital Atmosphere has the
capability to import these based on the settings in the table template file (DIGATMOS.TPL in your Digital
Atmosphere directory).  A list of valid data types will be shown only if the most recent import operation has
found data defined in the template file .

In the data file itself, any table containing weather data should have each line of data corresponding to a
geographical point, and must have a latitude, longitude, and anywhere from 1 to 50 data values for that
point.

Template file entries

#DEF starts the definition of a table.  Give the table a name in T1; this name is used for display purposes.

#LEG defines a line that can be used as a legend for the table (such as a line that contains a date or valid
time).  Specify a keyword that is to be located on the line.  When encountered, it will be used in legends

#FLG is a scrap of text which, when encountered during importing, tells Digital Atmosphere that it is about to
encounter a table.  This flag must be encountered before any data can be imported.  Specify the scrap of text
in T1.

#BEG is a scrap of text which, when encountered during importing, tells Digital Atmosphere that a data table
is starting right now.  Put the scrap in T1, and define the column where it must be seen in V1 and the length
of the scrap in V2.  Data import always ends on an empty line.

#DAT is specified for each data element that appears on a line.  Give the field a name in T1 (this is used
only for display purposes). Define the beginning column of the data in V1 and the length of the data in V2.

#MIS specifies characters that are used to denote missing data.

#LAT specifies where the latitude (decimal only) is found.  Put the column start position in V1 and the field
length in V2.

#LON is similar to #LAT but for longitude.

Example

#DEF -   -   Australian rainfall data
#LEG -   -   Observations
#FLG -   -   IDCLRD00001
#BEG 66  2   :-
#MIS -   -   +
#LAT 67  6
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#LON 60  6
#DAT 1   10  Date
#DAT 12  6   Stn_num
#DAT 23  40  Name
#DAT 81  5   Precipitation_mm
#DAT 87  1   PP
#DAT 89  1   DC
#DAT 91  1   OF

8.4. Television plots

Plots large-font displays of temperatures.

Very important!   Before you can use this option successfully, you will need to configure the DIGATMOS.PLL
file correctly with any text editor (such as Windows Notepad).

DIGATMOS.PLL is in your Digital Atmosphere directory.  The structure is as follows, where the first column
is the ICAO identifier (for METAR data) and the second column is the WMO station identifier (for SYNOP
data).  The third column is the name of the station (city) as it should appear on your weather map.

KORD 72530 Chicago
KSEA 72793 Seattle
KSFO 72494 San Francisco
KLAX 72295 Los Angeles
KBOI 72681 Boise
KABQ 72365 Albuquerque

The font used by this plot type is specified in File > Preferences > Fonts.

8.5. Warnings

Plots warnings that were imported from the most recent data import.

8.6. Frontal depiction (ASUS1)

This option allows plotting of georeferenced fronts, highs, and lows.  The features are georeferenced,
therefore you can always plot them later even if you zoom in or quit the program.  You will lose your frontal
depictions if you again create a depiction or if you import original ASUS1 data.

Plot .  Displays whatever frontal bulletin currently resides in the QUEUE.FRT file.  This bulletin may be
imported from the Internet (see "using original sources of data" below) or may be created by the user (see
"create" and "making your own maps" below).

Create .  Allows the user to create fronts, highs, and lows from scratch using rudimentary drawing commands
(see below).

Append .  Allows the user to append fronts, highs, and lows to a frontal bulletin currently residing in the
QUEUE.FRT file.
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Using original sources of data .  Raw sources of data consist only of the ASUS1 KWBC numerical text
bulletin produced by the National Weather Service.  This bulletin must have been imported and found with its
headers intact before it can be plotted.  The bulletin is usually found on Unidata servers under
data/surface/front or a similar directory, or by the bulletin header name itself.  A couple of links are provided
in Digital Atmosphere's Internet Retrieval window.  Note that the presence of this bulletin does not imply that
computers can be used to automatically "create" frontal positions.  These bulletins are digitized from human
analysis at the National Center for Environmental Prediction and transmitted in numerical form.  The ability
for a computer to independently analyze for fronts does not exist except perhaps in experimental form, and it
is a poor method for analyzing the subtleties and complexities of the atmosphere.  One of the reasons Digital
Atmosphere was created is to help forecasters locate fronts.  Although this product is indeed created by
humans, it may be inaccurate at times due to varying experience levels among the analysts.  A good
cautionary essay on these centralized analysis charts can be found in "A Case for Detailed Surface Analysis",
by Doswell and Sanders, at http://www.nssl.noaa.gov/~doswell/sfcanal/surface_analysis.html .  Also the
resolution of the data format is no better than about 50 miles, so close-in zooms will not be very accurate.

Making your own maps .  By using the Create or Append options above, you can create your own frontal
depiction maps.  To pull up the drawing commands, simply right-click on the map and choose "frontal
depiction tools".  You will see a menu like the one below.

Drawing a front .  So that the barbs point the correct way, as you draw the line cold air must always be on
your right side (except when drawing warm fronts); the easiest way to remember this rule is to always start
from the center of a low pressure area and work your way to higher pressure.  Simply set the cursor on the
first point, choose "Set xxx front", then move along the front and right-click Frontal depiction tools > Add
front point at each point to define 3 or more points along the front.  The front will be drawn as you go along,
and will be smoothed automatically as a spline.

Drawing highs and lows .  Simply right-click on the map and choose Frontal Depiction Tools > Add high/low
to mark the position of a high or low pressure area.  You will be prompted for a central pressure in millibars.
You can leave this blank if you wish not to specify one.

Special notes .  Please note that due to inherent limitations in the ASUS1 KWBC format, which is what
Digital Atmosphere adheres to, precision of the toolbox commands is limited to 60 miles (100 km) or more.
Therefore you cannot draw microscale fronts and extremely small-scale outflow boundaries.

Format of the ASUS1 KWBC bulletin .  Finally, here is an example of an ASUS1 KWBC bulletin.  If your
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frontal depiction does not deliver the correct results, you can go in and hand edit this bulletin in QUEUE.FRT
using any text editor.

515
ASUS1 KWBC 111919
CODSUS
VALID 111118Z
HIGHS 1030 41165 1030 38154 1027 45135 1025 31138 1035 6143 1022 3730 1033
5589 1030 6286
LOWS 979 46169 1017 38139 997 4257 997 3865 980 63172 987 66144 998 75113
1005 36102 1013 35112 998 7168
OCFNT WK 46169 46170 45171
COLD WK 45171 44170 42169 40169 40169 39168
WARM WK 45171 46172 47174 46178
COLD WK 38139 36140 33144 31149 31153
STNRY WK 4418 4525 4531 4741 4748 4653 4457 4160
TROF 4257 4151 3647 3145 2845
COLD WK 3865 3763 3463 3164 2869 2673 2478 2384
COLD WK 66144 64142 62142 59142 53145 48149 45153 42156 40162
STNRY WK 55116 59117 62121 65129 67138 69144 69155 68167 68176
STNRY WK 6291 6395 64101 64110 63117
OCFNT WK 76114 77111 78104 7895 7786 7680
COLD WK 36102 34103 32104 31106
TROF 36101 35101 32100 30101 28102 26102
COLD WK 7680 7574 7168 6866 6565 6365 5969 5672
STNRY WK 37103 38104 40106 40109 41111 43114 44117
WARM WK 38101 3999 3897 3795 3791
TROF 48112 51112 55112
TROF 5294 5095 4896 4498 4199
TROF 5571 5270 4968 4767
NNNN

8.7. Convective Outlooks

This option plots convective outlooks (thunderstorm forecasts) issued by the National Weather Service's
Storm Prediction Center (SPC) in Norman, Oklahoma.  These are centralized human-produced forecasts
issued several times a day, and are used to help provide guidance to National Weather Service forecast
offices.  They are also used frequently by storm chasers, pilots, and hobbyists.

To use this option, you must have imported a convective outlook as part of your raw data set or from one of
the choices in Internet > Retrieve data.

Advanced users can modify the color scheme by changing the contents of the file DIGATMOS.CCC in the
Digital Atmosphere directory using a standard text editor such as Notepad (never use a word processor such
as Microsoft Word or you will corrupt the file).  This file contains self-explanatory instructions for modifying
the hexadecimal numbers used to determine colors of the various threat boundaries.

If there are any problems ingesting a bulletin, the problem is most likely an error in the composition of the
bulletin.  It is not necessary for the header to be intact, but the "STORM PREDICTION CENTER" title must
appear in the bulletin along with the convective outlook type, valid times, and standard bounding locations of
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each threat area.

Appearance of a convective outlook plot.

The raw data appears as follows:

492
ACUS2 KMKC 041803
SWODY2
MKC AC 041801

STORM PREDICTION CENTER...NWS/NCEP...NORMAN OK
DAY 2 CONVECTIVE OUTLOOK...REF AWIPS GRAPHIC PGWI47 KWBC.

VALID 051200Z - 061200Z

THERE IS A SLGT RISK OF SVR TSTMS TO THE RIGHT OF A LINE FROM
40 ESE P07 BGS CDS 55 NE AMA EHA LAA GLD HLC SLN CNU SGF JBR MKL
TUP LUL 35 SE HUM ...CONT... 30 S CRP 25 S LRD.

GEN TSTMS ARE FCST TO THE RIGHT OF A LINE FROM 30 ENE ELO 50 NW EAU
DBQ HUF LUK HTS TRI 65 S TYS ATL ABY AQQ ...CONT... 40 SW DMN
50 WNW ONM GUP 60 ESE PGA U17 VEL 45 NNE CAG CYS SNY ANW JMS
70 NNE DVL.

MODELS INDICATE UPPER CLOSED LOW OVER NORTHERN BAJA WILL EVOLVE
INTO A SHORT WAVE TROUGH AND ACCELERATE EASTWARD INTO THE SOUTHERN
PLAINS SUNDAY/SUNDAY NIGHT. THIS IS IN RESPONSE TO VIGOROUS
NORTHERN BRANCH SHORT WAVE TROUGH NOW OVER THE PACIFIC NORTHWEST...
AND PROGGED TO CONTINUE TO DIG INTO THE CENTRAL ROCKIES BEFORE
SHIFTING EASTWARD INTO THE CENTRAL PLAINS. AS THESE SYSTEMS
INTERACT...AND UPSTREAM SHORT WAVE DIGS ACROSS THE NORTHERN PACIFIC
COAST INTO THE GREAT BASIN...MODELS INDICATE EVOLUTION OF LONG WAVE
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8.8. Radar

Allows you to plot echoes and attribute data from radar messages.

Digital Atmosphere can import radar data from one of two sources

• Old-style MDR data from RAREP reports (has 30-mile resolution)
• NEXRAD-style RCM data from RCM text messages (has 6-mile resolution

Since a visual clash would occur if both were plotted, Digital Atmosphere requires you to pick which data you
want to see.  This is done in the File > Preferences > Meteorological tab under "View NEXRAD RCM rather
than RAREP radar data".

If you have chosen to view NEXRAD RCM data, you can also view other severe weather indicators, including
storm centroids, hail, tornado vortex signatures (TVS), mesocyclones, echo heights, and echo movement.

Note that neither of these will give you high-definition radar images as seen on special radar sites and on TV.
These require access to the NIDS datastream, which is currently encrypted according to a NOAA / NIDS
vendor agreement and will remain so probably until 2001.  After that time, Digital Atmosphere will likely be
programmed to use the NIDS data.

Also note that because NEXRAD RCM is a binary format transmitted on alphanumeric datastreams, some
weather servers may corrupt the data before it gets to Digital Atmosphere.  This can cause a loss of viewable
data.

8.9. Sounding

Allows you to see a sounding, which is a plot of temperature versus height for a given station.  You must
have imported data that contains upper air data.

8.10. Extract model data

Allows you to extract data gathered from FOUS-style model output.  This forces the data into a custom data
file, which you can then view using Data > Custom data plots.
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9. Analysis Commands

9.1. Introduction

Digital Atmosphere hosts a powerful suite of tools for analyzing various atmospheric properties.  It is quite
simple to use.  You simply click on a primary field  that you want to view (such as temperature, wind speed,
pressure, etc) in the Analysis menu.  However, if you first click on a derivative field (i.e. vorticity, divergence,
or advection) in the status panel, Digital Atmosphere places a checkmark next to that field.  Derivative fields
are not analyzed until you click on a primary field from the Analysis menu.  Only then are the derivative
choices looked at.  All analysis methods are computed based on whatever level is selected under the "Active
Level" pop up menu on the status panel, so if the analysis does not appear, it means no data is available for the
active level.

Font types used during analysis (contouring and labelling) operations are controlled in "File/Preferences/Fonts"
under "Annotations".  Only the font name is used; the size is ignored.

9.2. Analysis basics

To fully understand how the analysis routines work, you have to know a little bit about the theory behind them.
All meteorological fields can be described as a series of waves.  For example, assume that at a certain time the
coldest spot in the country is International Falls, MN at 12°F and the hottest spot is Death Valley, CA at 96°F.
Then draw a long line on your map that passes through both of those points.  If you graph the temperatures
along this line and gather data from cities along the line, your temperature graph will show unique undulations,
rises, and falls.  These are mathematical waves in the temperature field.

Assume that you find that the temperature 200 miles on each side of Death Valley (along the line) is 94 deg F.
You could then assume most of the southwest United States is hot.  The temperature graph would show a
gradual rise towards Death Valley and a gradual fall as you move away.  But what if the temperature 200 miles
on each side is instead 52 deg F?  With Death Valley being at 96, this would appear on your graph as a short
upward "spike" at the location corresponding to Death Valley.  These are two unique mathematical waves —
the first one (with gradual rises and falls) means that the temperature field is composed of large or long
wavelength features.  The latter situation (with sharp spikes and dips) means that the temperature field is
composed of short or small wavelength features.  As you can see, gradual changes mean that the meteorological
field has long wavelength characteristics, and sharp localized changes imply small wavelength features.

Digital Atmosphere uses a 30 x 30 mesh (grid) to sample these conditions.  The mesh is like lines that are
drawn across the map, 30 across and 30 down, to sample the wave structure that is present in the type of
analysis you pick.  Using equally-spaced grid points is the easiest way to perform computerized analysis
calculations.  Digital Atmosphere must find where reporting stations are within the grid, and try to map the
values to that grid, taking into consideration how far the reporting station is from a gridpoint and figuring out
what to do with gridpoints that aren't assigned any data.  This is what takes up the majority of processing time.

So why not just map values to the grids and interpolate between all the points?  Digital Atmosphere's nearest
neighbor technique does something like this.  It maps data to gridpoints and fills in unassigned gridpoints using
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the nearest data value, a process known as expansion.  However, if the temperature in San Francisco is 52 and
in Los Angeles is 85 (and assuming we have NO other data), the analyzed field anywhere in California will
show either 52 or 85 degrees!  This is clearly not correct, so after expansion, Digital Atmosphere runs a
smoothing algorithm.  Smoothers "smooth" out the mesh by changing the value at each gridpoint to an average
of itself and its neighbors.  Unfortunately, this can dampen out features in the field.  Too much smoothing will
remove all of the short wavelength features.

A better way to do this is to use the Weighted, Barnes, or Cressman techniques.  These techniques look at each
gridpoint, find where it corresponds to on the earth, and from that location it looks at the values of the stations
around it and figures out a carefully averaged value best representing what the value at that gridpoint probably
is.  The Barnes algorithm goes a step further by going back and seeing how incorrect its mesh turned out to be,
then adjusting that to produce a final analysis.  The Cressman algorithm does the same thing, but it also begins
its analysis using values at stations over a wide area, then gradually tightens up its analysis, running corrections
and using values at stations over a progressively more narrow area.  This allows Cressman to accurately
resolve large waves as well as small, localized waves.

Let's now take a closer look at each type of analysis.

9.3. Primary fields

Primary fields are your basic atmospheric properties.  When you click on any primary field, Digital
Atmosphere immediately examines which derivative fields are checkmarked (if any) and immediately begins
analyzing.  Most of these properties are scalar variables (having only magnitude), so Digital Atmosphere will
show them to you using isopleths ("contours").  You may instead display the gridded values themselves or a
gradient color field.  However, some of these properties, like observed wind and Q-vectors, are vector fields
(having both magnitude and direction), so they are displayed using wind feathers or drawn vectors.

Colors and settings are, for the most part, defined in File > Preferences > Contours.

9.4. Temperature menu

9.4.1. Wind chill

The wind chill is an empirical equation describing what the temperature feels like to a person based on the free
air temperature and the wind speed.  The wind chill always equals the free air temperature when the winds are 4
knots or less.

9.4.2. Temperature

Analyzes the free air temperature in either degrees Fahrenheit or degrees Celsius.
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9.4.3. Potential temperature

Potential temperature is what the temperature of the air would be if it was forced to the 1000 mb level.  In other
words, it eliminates the effects of elevation, allowing you to effectively compare temperatures in mountainous
areas using a common temperature measurement.

9.4.4. Thickness (1000-500 mb)

This option plots the difference in geopotential height between the 1000 and 500 mb levels (in meters).

Upper air (radiosonde) data must be imported in order to view this field.

9.5. Moisture menu

9.5.1. Humidex

This is similar to the heat index but is often used in Canada.  It equals H = T + (0.5555 * (e - 10)), where T is
the temperature in Celsius and e is the vapor pressure in mb.  Further information is available in Humidex, A
method of quantifying human discomfort due to excessive heat and humidity, by J.M. Masterton and F.A.
Richardson, CLI 1-79, Environment Canada, Atmospheric Environment Service, Downsview, Ontario, 1979.

9.5.2. Heat index

The heat index is an empirical equation describing what the temperature feels like to a person based on both the
free air temperature and the relative humidity.

9.5.3. Relative humidity

This is a measure of how close the air is to being saturated.  An analogy is having a shot glass half full of
water, and a large jar half full of water.  Relative humidity is like saying that each of the containers is 50%
saturated with water, regardless of the true amount in the container.

9.5.4. Mixing ratio

This measure tells you exactly how much moisture is in the air.  It is calibrated in grams of water vapor per
kilogram of air.  Mixing ratio is basically the same type of measurement as dewpoint, however, mixing ratio is
an absolute, measurable quantity, and with increasing amounts of moisture, changes in mixing ratio become
more significant than changes in dewpoint.  This makes it ideal for finding features in moist air masses,
especially in severe weather situations.

At the surface, by checking the divergence derivative and clicking mixing ratio, you can produce a "moisture
convergence" chart useful for forecasting severe thunderstorms.  By clicking that and the advection derivative,
you can produce "moisture flux convergence" (SMC).  In an unstable atmosphere, it takes a few hours for
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SMC to produce convection, so persistant SMC areas must be watched.  SMC patterns are more important
than the actual values.

9.5.5. Dewpoint temperature

The dewpoint is the temperature that the air must be cooled to before saturation begins.  It is proportional to the
actual quantity of moisture present in the air, so it is often used as a universal indicator of the "moisture" in the
air.

9.5.6. Equivalent potential temperature

Equivalent temperature indicates the potential temperature of a parcel of air whose latent heat had been
completely released.  Physically, it's what the parcel's temperature would be if it were forced upwards to about
200 mb then forced downwards to 1000 mb.  In any given atmosphere, higher values of surface or low-level
theta-e will always yield higher instability values (it's a better indicator than dewpoint or temperature), so theta-
e is useful for seeing where an inversion or cap is about to break.

9.6. Pressure/height menu

9.6.1. Height

Geopotential height (usually called simply "height") is the height of a given pressure surface (such as 300 mb)
in meters.  It is widely used in upper-air analysis

9.6.2. Pressure tendency

Plots the pressure tendency as obtained from the 5xxxx group in SYNOP reports and the 3-hourly pressure
groups on METAR reports.

9.6.3. Altimeter setting

The altimeter setting, measured in inches, is what the surface pressure would be if it were reduced to sea level,
however it takes into account no temperature corrections.  Unlike the sea-level pressure, if the temperature
outside varies drastically, the altimeter setting will fluctuate.  Altimeter setting is typically what is used by the
National Weather Service to report pressure readings to the public.  It is somewhat more commonly available
than sea level pressure, so it finds use in day-to-day mesoscale analysis.

9.6.4. Sea level pressure

The sea level pressure is the atmospheric pressure at the surface in millibars reduced to sea level, taking into
account temperature patterns over the previous 12 hours.  It is similar to altimeter setting, but not the same.  Its
biggest use is for comparing patterns over a broad area, as in synoptic analysis.
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9.6.5. Isentropic level (mb)

If a 3-D analysis has been created and the active level is "Isentropic (3-D", this option will allow the user to
map out the height of an isentropic surface in millibars.

9.7. Wind menu

9.7.1. Wind analysis choices

Wind field
Plots a staggered 31 x 31 grid of wind barbs or vectors, depending on the setting on the Analysis Toolbar.
Barbs are calibrated in knots, while vectors are an arbitrary length that is proportional to speed.

Streamlines
Plots streamlines for the wind field at the active level.  Streamlines are lines always drawn parallel with the
wind flow.  They are a function of wind direction and not velocity, however they are not drawn through regions
where the analyzed wind speeds are 1 kt or less.

Wind speed
This is the speed of the air movement, usually measured in knots (nautical miles per hour, or 1.15 mph).

9.8. Precipitation menu

9.8.1. Precipitation

Plots the precipitation total as obtained from the 6xxxx group of SYNOP reports and the precipitation group
of METAR reports.

9.9. Sea menu

9.9.1. Brief introduction

Sea data is provided by WMO FM 13 format ship synoptic observations.  These are usually carried in any
data source that provides synoptic observations.

Sea data is not provided in METAR, upper air, or other formats!

9.9.2. Sea surface temperature

Analyzes the sea surface temperature using units specified in File > Preferences > Meteorological > Units.
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9.9.3. Height

All units for heights are in units specified in File > Preferences > Meteorological > Units.

Wind wave
Height of wind waves.  This is usually the best choice for an overall look at oceanographic conditions.

Primary swell
Height of primary swell waves.

Secondary swell
Height of secondary swell waves.

Instrument
Height of waves obtained by instrumental methods.

9.9.4. Period

Wind wave
Period of wind waves.  This is usually the best choice for an overall look at oceanographic conditions.

Primary swell
Period of primary swell waves.

Secondary swell
Period of secondary swell waves.

Instrument
Period of waves obtained by instrumental methods.

9.9.5. Direction

Although swell direction vectors equal the direction from which the waves are originating, they are also given
an arbitrary magnitude that is equivalent to the wind wave height.  This helps give added emphasis to high
seas.

Primary swell
Direction from which primary swell waves are originating.

Secondary swell
Direction from which secondary swell waves are originating.
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9.10. 3-D fields

9.10.1. 3-D mode

Causes Digital Atmosphere to generate a three-dimensional analysis that correlates to the workchart being
displayed.  Upper air radiosonde data is needed for this module to work correctly.  The analysis is a gridpoint
model with a resolution of 31 x 31 x 31 (29791 data points).

How is it constructed?  A 3-D grid is defined which corresponds to the current workchart.  All upper air data is
looked at, including significant level data (TTBB) and AIREPs and assigned to the closest horizontal
gridpoint.  At each horizontal gridpoint, vertical gridpoints are individually checked to see if they fall between
two valid upper air data points.  If so, the data is interpolated and fitted to the gridpoint.  Once this is
completed at all horizontal gridpoints, they are smoothed horizontally at all levels to blend the data together.
The result is a 3-D analysis.

Once prepared, there are four ways that a 3-D analysis can be used.

Isentropic analysis .  The "Isentropic (3-D)" option is chosen under Level on the speed toolbar.  When an
analysis is chosen, you will be asked for an isentropic surface level in deg K.  Digital Atmosphere will
examine the 3-D grid, determine the lowest level that the isentropic surface exists at, and analyze the data at
this level.  Commonly chosen analysis options for isentropic analysis are Isentropic Height (mb), Wind Field,
and Relative Humidity.  The basic premise of isentropic analysis is that air moves three-dimensionally, and it
does NOT stay confined at constant pressure levels.  As expressed by isentropic advocate Dr. James Moore,
"Pressure coordinates bad!  Isentropic coordinates good!"  Constant pressure coordinates have been used
for decades because of their simplicity, but computational power now allows forecasters to become familiar
with isentropic coordinates.  Most airflow moves along isentropic surfaces (surfaces of constant potential
temperature), which are shaped according to large-scale thermal structures.  By using isentropic maps, we
can assume upward motion is occurring wherever wind is blowing air from higher to lower pressure levels
(lower to higher altitudes).  Since isentropic analysis is based on adiabatic assumptions, it will not work
reliably where air is saturated, in convective situations, or near the ground.  It will also not work well when a
weather system is moving rapidly.  For more information see
http://www.eas.slu.edu/People/JTMoore/isenbasics/index.htm .

Override level .  This is simply a way to "roll your own" heights to analyze, rather than being forced to use
standard levels like 500 mb, 300 mb, etc.  The "Override (3-D)" option is chosen under Level on the speed
toolbar.  When an analysis is chosen, you will be asked for a height in millibars.  Digital Atmosphere will
examine the 3-D grid and analyze the data at this height.  The power of an override is that it lets you
visualize the height at any millibar level (434, 570, 883 mb, etc), and it makes use of all available data,
including TTBB significant level data, to accurately represent data at those levels.

Roaming sounding .  To enable this option you simply choose Analysis > Roaming sounding.  A blank
sounding will appear.  As you move the mouse across the workchart, a sounding valid for that location will
appear on the sounding chart.  This is an impressive way to visualize soundings across a wide region without
having to call up individual soundings and figure their relationship to the weather patterns.  For more
information see Roaming Sounding.

Cross section .  Simply drag across the workchart to define a geographical line, and choose Analysis >
Cross Section.  A cross section window will pop up.  You can then choose to visualize various meteorological
parameters along this segment.  For more information see Cross Section.
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9.10.2. Roaming sounding

Causes a sounding to appear.  When you move the mouse over the horizontal area workchart, the sounding
plot will change accordingly to indicate the sounding appearance at that particular location.

When you are finished, click Close on the sounding window to stop roaming mode.

9.10.3. Cross section

If the mouse has been dragged across the horizontal workchart to define a geographical line and a 3-D
analysis has been generated, this will allow you to display atmospheric cross sections for the given line.

When you are finished, click Close on the window to close it.

9.11. MVFR/IFR weather

Plots areas of MVFR or IFR conditions.

9.12. Custom data field

Analyzes a custom data set from your CUSTOM.DAT file (see the appendix on Custom Data for full details).
The contour base and interval are automatically determined.

9.13. Export last analysis

[This item has been discontinued.  Digital Atmosphere always outputs its analysis to GRID.TXT in the Digital
Atmosphere directory.  For more information please see the Appendix under Using Exported Analysis Grids].

9.14. Wind field

Computes an observed wind grid, as reported in the weather data.  The "arrow" of the feather or vector points
towards where the wind is going.

9.15. Geostrophic wind

Computes a wind grid based on the pressure or geopotential height field.  Geostrophic wind is based on the
pressure gradient and the Coriolis effect, and due to the effects of friction, it is always higher than the observed
wind speed.  Geostrophic winds are useful for getting an idea of how strong the winds will be later in the
morning when air flow is being suppressed by radiational inversions.
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9.16. Ageostrophic wind

This is the vector difference between the actual wind vector and the geostrophic wind vector.  Ageostrophic
wind is stronger when the pressure and wind fields are out of balance.  Much of the vertical motion in the
atmosphere can be attributed to ageostrophic flow.

9.17. Q-vector

The omega equation is a diagnostic for the total time derivative of pressure.  It allows synoptic-scale vertical
motion to be accurately estimated by analyzing temperature and wind fields above the boundary layer.  The
omega equation is defined as shown here, where the term on the left side of the equation indicates vertical
motion.  On the right side, the left term is proportional to differential vorticity advection, while the right term
solves for thickness advection.  So positive differential vorticity advection plus warm thickness advection
equals upward vertical motion.  A Q-vector roughly depicts the ageostrophic horizontal wind that develops in
order to maintain the thermal wind balance in a developing synoptic system.

Q-vector convergence implies synoptic-scale upward vertical motion, and Q-vector divergence implies
downward vertical motion.  This can be interpreted either by looking at the Q-vectors or running a derivative
convergence field together with Q-vectors.  Also, where 850 mb Q-vectors cross the 850 mb isotherms, moving
towards warmer air, frontogenesis is indicated.  Q-vectors crossing into colder temperatures indicate
frontolysis.  This quality is known as the "geostrophic frontogenesis function" (use 700 mb levels in
mountainous areas).  Avoid using the advection derivative to forecast Q-vector movement, since the field is
constantly changing and may not be representative after a few hours.

9.18. Flow modifiers

If any of these items are checkmarked, it is a flag to Digital Atmosphere that it must compute divergence or
vorticity and show you these results instead.  If a flow derivative is flagged and you pick a primary field that is
a vector (observed wind, geostrophic wind, ageostrophic wind, or Q-vectors), the results will be valid for that
particular vector field.  If a flow derivative option is selected and you pick a scalar variable (temperature, etc)
as your primary field, only the observed winds are used in the equation, and the result is multiplied by the
scalar field that you select.  The end result is a scalar variable which can be displayed verbatim or analyzed
further with the advection modifier.

Some useful examples of using flow modifiers are:
Moisture convergence: Check "Divergence" and click on "Mixing Ratio".
500 mb vorticity: Check "Vorticity" and click on "Observed Wind" or "Geostrophic Wind".
Thermal advection: Check the "Advection" selection, then click on "Potential Temperature".
500 mb vorticity advection: Check "Advection" and "Absolute Vorticity", then click on "Wind Grid".
Moisture flux convergence: Check "Advection" and "Divergence", then click on "Mixing Ratio".

Divergence
Divergence is a measure of the amount of stretching of a parcel of air, or the relative rate of increase of a
material surface.  Divergence is defined by the following, where u and v are the x and y components of wind,
respectively.
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Relative Vorticity
Relative vorticity is a measure of curl of the air.  Geometrically, vorticity is twice the angular speed of rotation
of a parcel that moves with the flow.  It is a relatively simple expression of the flow of air, and is most often
used to examine the wind field within the boundary layer.  Relative vorticity is defined by the following, where
u and v are the x and y components of wind, respectively:

Absolute Vorticity
Absolute vorticity is the same as relative vorticity, however, the Coriolis effect is added into the equation
(absolute vorticity equals relative vorticity at the Equator).  Absolute vorticity of the wind is used most
frequently in upper-air analysis.

Advection
When this item is checked, Digital Atmosphere will use the results of the next analysis (together with  the flow
modifier) to calculate advection.  All computations of advection, including Q-vectors, are based off of the real
wind.  Advection measures the transport of an atmospheric property (such as temperature or precipitation) by
the wind.

9.19. Isentropic analysis

[This section has not been completed]
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10. Internet Menu Commands

10.1. Introduction

Before you use any of these commands, you will need to open a connection to the Internet (using your Dial Up
Networking or Remote Access Services to connect to your Internet service provider).  If you are new to using
the Internet and need some basic information, see the section on getting data at the end of this manual.  We've
provided some pointers for you.

10.2. Retrieve data

This module retrieves alphanumeric data through the Internet and saves it to your hard drive.  When the data
download is completely finished, Digital Atmosphere will import the data for you.  This means you can
immediately begin plotting and analyzing.

To use Retrieve Data, you must first open a connection to the Internet through your service provider before this
command will work.  Note that you must have a standard Winsock Internet connection.  Firewalls or unusual
configurations could cause problems.  If you have a proxy server, you may want to enter your proxy host
information in Preferences > Misc.

When you select Retrieve data, you will be presented with a dialog box containing a list where you can check
off the items you want to download (see illustration) from a product list.  Once you press Retrieve, the chosen
products will be downloaded and stored in your data directory.  Then you can use File, Import Directory to see
the results.

Since Internet sites often change, you can fully edit the list of products and data directly from this dialog box by
highlighting the item you wish to change and clicking the Edit Site button or the Delete Site button.  You can
also add a new site by clicking the Add Site button.  You will then be prompted to enter the site name and URL
for the data.

Many sites, especially for surface and upper air data, have a filename that is dependent on the Greenwich Mean
time of the observation.  To support this, Digital Atmosphere lets you insert time tokens into a filename.  For
example, if you entered a product that had a URL address of http://www.weatherdata.com/@Hdata.txt, Digital
Atmosphere would automatically substitute the current UTC (GMT) hour in place of the @H.  So if it was 9
pm EST (02Z), Digital Atmosphere would retrieve http://www.weatherdata.com/02data.txt.

Here is a complete list of all the UTC time token combinations you can use:

Character 1 - mode
@ This hour
$ Last hour

Character 2 - time
M Month
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D Day
H Hour
X Rawinsonde hour

(rounds down to 00 or 12)
S Main synoptic hour

(rounds down to 00, 06, 12, or 18)
I Intermed synop hour

(rounds to 00/03/06/09/12/15/18/21)
F Frontal hour (for ASUS1 KWBC frontal position bulletin)

(rounds to 01/04/07/10/13/16/19/22)
*** note that some servers do not produce a ASUS1 at 22Z ***

Although Digital Atmosphere automatically figures the current time tokens before you retrieve data, you may
want to override them.  This is handy if you want to see data for an earlier hour.  All you have to do is change
the numbers that are displayed in the time token panel.

Solving incorrect time problems.  If the time tokens always show a slightly incorrect hour, check your
Preferences menu under the General tab and make sure the "Daylight Saving" checkbox is marked in
accordance with whether daylight savings time is in effect.  If the hours are significantly off, go to your
Windows control panel, look under Date/Time, and make sure your computer is set to the correct time zone.
Then make sure your system clock is set to a current time which is valid for that time zone.  For example, if
you live in New York and typically have your computer clock set to Greenwich Mean Time, you will have to
set the Windows time zone to "GMT" rather than Eastern Time.

Solving access problems.  Digital Atmosphere must have access to a true Winsock Internet connection in order
to retrieve data.  It may not work with proprietary systems such as AOL and MSN.  If for some reason you
can't retrieve data through Digital Atmosphere, all is not lost.  You can still use your Internet browser to get
products, then save them to your Digital Atmosphere data directory, which is most users have had to do up
until 1997!

Technical tip.  Do you want to swap data product lists with other users?  No problem; we've made it easy.
Simply give them a copy of your DIGATMOS.SLZ file (it's in your Digital Atmosphere directory).  If they
replace their DIGATMOS.SLZ file with yours, they'll get your list of data products.  We sometimes offer
updated DIGATMOS.SLZ files on our web site to give you the latest set of data products.
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11. EMWIN Menu Commands

11.1. Introduction

This menu is provided for users who have access to the EMWIN system of data retrieval.  EMWIN is an
excellent, low cost solution for users who want 24 hour automatic access to current weather data.  If you do not
have EMWIN and are interested in obtaining it, please visit http://www.weathergraphics.com/ for more
information.  There is also a description of the EMWIN system near the end of this manual.

11.2. Get EMWIN bulletin

This option provides an easy method to access and display bulletins stored by the EMWIN datastream.  Each
one of the bulletins currently stored on your hard drive is presented in a tree format by region, then by product,
then by issuing office.  Simply double-click on any product to view it, and it will appear in the panel at the
right.  You can resize the window to read the bulletins better by dragging a corner of the window.  If you do not
see any entries, you are not using the EMWIN datastream or are saving data in a different directory (see your
Digital Atmosphere preferences panel).

You can also directly access a bulletin by typing its filename in the "expert access" box (such as NOWOUNOK
to retrieve NOWOUNOK.TXT, the nowcast from Norman, Oklahoma).  When you press Enter, the bulletin
will be displayed.

Technical tip.  If a region abbreviation in the tree shows an incorrect or blank full-length breakout, you can fix
it by editing the file DIGATMOS.EMR in your Digital Atmosphere directory.  Likewise, incorrect or missing
product breakouts can be edited in DIGATMOS.EMP.  Having missing or incorrect breakouts has no impact
on the functionality of Digital Atmosphere.

11.3. Display image

Displays any graphic image in the EMWIN data directory, as specified by File > Preferences > General >
EMWIN Data Directory.

Digital Atmosphere

Page 48



12. Climatology Menu Commands

12.1. Extract data

If you want to plot or analyze climatological data, this is where to start.  Extract Data will allow you to select a
category and timeframe of climatological data.  Digital Atmosphere will then create a custom data field, saving
it into CUSTOM.DAT in your Digital Atmosphere directory.  This can then be immediately plotted (with
Graphics, Plot, Custom Data) or analyzed (with Analyze, Custom Data Field).  You can even import the data
into a spreadsheet or database program.

12.2. Graph

This option will let you graph the climatology for any of 2,000 stations around the world.  Simply enter a
partial word or country digraph to search for a station, or choose from the drop-down list.

What you'll see is a graph of average high and low temperatures for each month, as well as extreme high and
low temperatures for each month.  They will be indicated in either degrees Fahrenheit or Celsius, depending on
your choice of units in File, Preferences.  At the bottom, you'll see average monthly precipitation totals (United
States) or precipitation days (elsewhere).  The total height of a precipitation day bar is the total precipitation
days during a given month.  The part in gray is how many of those days are composed of snow days, and the
part in red is how many are composed of thunderstorm days.

12.3. Introduction

Digital Atmosphere maintains a database of numerous monthly weather parameters for over 2,000 weather
stations across the world.  Most of this archive spans a 30-year time period.  This data can be viewed on a
graph or plotted on your  maps.

Keep in mind that, as with most other meteorological data, the results may be affected by the observing station's
elevation or proximity to the ocean.  This is why you may see significant variations in temperature along a
coastal region, among other effects.
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13. Window Commands

13.1. Add/remove toolbars

You can add or remove toolbars as needed to make more space on your workchart.

13.2. Remove last product

Removes the last data overlay from the screen.
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14. Help Commands

14.1. Register

The Help > Register dialog allows a user to "unlock" an unregistered version of Digital Atmosphere.  It
usually only needs to be done once.  The trial version will be converted to a fully registered version, even if it
has already expired.

A key number is only available from Weather Graphics Technologies, and can be given only in accordance
with our registration guidelines.  Furthermore, the key number can be computed only if the serial number is
provided.  The serial number is unique to each computer, and we can't predict what it will be.  If you don't
supply it, there will be a delay because we will have to ask you for it.

For most users, the unlocking procedure only needs to be done once.  However if your company or
organization specifically needs a pre-unlocked version of Digital Atmosphere (without the serial/key
procedure), we offer Digital Atmosphere 2000 Professional Version.  It is supplied on CD-ROM.  Click the
registration guidelines link above for more info.

If you have any questions, please E-mail support@weathergraphics.com or call us at toll-free (888) 388-
0070.  Thanks!
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15. Preferences

15.1. Preferences introduction

Here's where you set your preferences for how the program will operate.  Any changes you make are used only
for the duration of the program's execution, unless you place a check mark at the bottom of the page, in the
box named "Save as default settings".  If you check this box, the entire set of preferences is saved to your
system.

Technically inclined users will note that the registry that is affected is
HKEY_CURRENT_USER\Software\Digital Atmosphere .  This key can be deleted with Windows Regedit if a
"factory reset" of preferences is desired.

The preferences menus are divided up into several sections, each of which may be accessed by clicking once on
the tabs at the top of the dialog box.  Just click on the tab corresponding to the settings you want to change to
switch between preference pages.

Each tab will now be introduced individually.

General preferences
Meteorological preferences
Map preferences
Station plots preferences
Analysis preferences
Fonts preferences
Contours preferences
Miscellaneous preferences

15.2. General

15.2.1. General preferences settings

Also see the special topics on Default data time selection, Directories, Files, and the Scheduler.

Ignore system interrupts
This setting has been temporarily disabled in Digital Atmosphere.

Provide information messages
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You can use this to "turn off" informational dialog windows (dialogs that give you information but have no
bearing on how the program is executed).  One example where informational dialog boxes are used is when a
climatological dataset is generated and you are given a tip on how to plot the data.  By unchecking this setting,
you can choose not to see these messages.  This will also help prevent lost data when running Digital
Atmosphere unattended with its scheduler going.

Adjust for daylight time
Check this box if your time zone is currently observing daylight saving time.  This has an effect on what
filenames are downloaded through the Internet when retrieving raw data.

15.2.2. Default data time selection

Determines which data time selection mode will be enabled on the Time Toolbar each time Digital Atmosphere
starts up.  Normally you will want this at "Automatic".

15.2.3. Directories

Digital Atmosphere always expects its data to be found in the subdirectory called
[digitalatmospheredirectory]\data .  To keep Digital Atmosphere running smoothly, never place any binary or
unrelated files in this directory.

With that in mind, there are a couple of exceptions where Digital Atmosphere will interact with other
directories:

EMWIN data directory
This is the directory where all standard EMWIN bulletins on your system are stored.  Ignore it if you don't have
EMWIN reception.  Its default setting is the Weathernode default of c:\weather\wxdata\rxfiles\ and should not
be changed unless EMWIN data is stored elsewhere on your system.

EMWIN warning Directory
This is the directory where all EMWIN warnings on your system are stored.  Ignore it if you don't have
EMWIN reception.  Its default setting is the Weathernode default of c:\weather\wxdata\rxfiles\ and should not
be changed unless EMWIN data is stored elsewhere on your system.
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Archives and imagewrites
This is the directory where all output data (automatic archives and imagewrites) are stored.  Its default setting
is [digitalatmospheredirectory]\archive\ and may be freely changed as long as it corresponds to an existing
directory and filename.

15.2.4. Files

Files — EMWIN Surface Data
The EMWIN system stores all surface data in sahourly.txt but it is always possible at some point in the future
this may be changed.  This  option allows you to change the filename.  Ignore this if you do not have an
EMWIN system.

Files — EMWIN RCM Data
The EMWIN system stores all RCM radar data in sarcmus.txt but it is always possible at some point in the
future this may be changed.  This option allows you to change the filename. Ignore this if you do not have an
EMWIN system.

Files — Imagewrite file
The EMWIN system stores all imagewrites (automatically-saved images when in scheduler mode) to this
filename.  If you choose "autoname imagewrites" (under "Scheduler") this entry will only be used to determine
what type of graphic file to write.
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15.2.5. Scheduler

Scheduler — Off
This is the default setting.  Digital Atmosphere operates in manual mode and does not look for any incoming
weather data.

Scheduler — EMWIN
If selected, Digital Atmosphere will look in your EMWIN directory every 60 seconds and check for new data.
If a new file is detected, it will be imported immediately and all charts will be refreshed.  Digital Atmosphere
examines data in the EMWIN Data Directory with the EMWIN Surface Data filename and the EMWIN RCM
Data filename, and all warnings in the EMWIN Warning Directory (TOR*.*, SVR*.*, FFW*.*, etc).

Scheduler — Internet
If selected, Digital Atmosphere will be tasked to periodically retrieve data off the Internet and refresh its
workcharts.  The interval is determined by the value specified in "retrieve data every ___ minutes".  So that the
host servers don't get overloaded, we have designed this scheduler so that downloads cannot be made more than
once every 15 minutes.

Scheduler — Archive data
When the scheduler receives new data, it examines this setting.  If this field is checked, Digital Atmosphere will
archive the data automatically.  The file will be placed in the Archive/Export Directory and will have the
filename YYMMDD.HHZ  (i.e. Oct 7 1999 at 1600Z will be placed in 991016.06Z).  The filetime equals the
current system UTC time (Universal Coordinated Time), not the valid time of the data, and the conversion
from your system clock to UTC is based on whatever time zone settings are in effect in your Windows Control
Panel under Date/Time.

Scheduler — Enable imagewrites
When the scheduler receives new data, it automatically refreshes the workchart.  Would you like this workchart
to be saved to disk each time?  If unchecked, this will not occur.  If checked, the workchart will be
automatically exported (imagewritten) to disk using the settings provided in "Archive/Export Directory",
"Imagewrites File", and "Autoname imagewrites".

Scheduler — Autoname imagewrites
When the scheduler receives new data and Enable Imagewrites is checked, this determines what the imagewrite
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filename will be.  If unchecked, the graphic image will be automatically written to the "Archives and
Imagewrites Directory" using the name given in "Imagewrite File" (this is a fixed name; the old file is
overwritten each time).  If checked, Digital Atmosphere will automatically write the image to the "Archives and
Imagewrites Directory" using the name format YYMMDDHH.ext, where "ext" is the filetype obtained from the
"Imagewrite File" entry (jpg, pcx, tif, bmp, or png), and YYMMDDHH is the UTC year, month, date, and hour
(i.e. a new filename is generated every hour).

TECH TIP:  EMWIN Scheduler
Although the EMWIN Scheduler was designed for those receiving the EMWIN datastream, advanced users

can use these settings for automatically importing files gathered by their own applications.  Simply make sure
the files are automatically imported into the above directories and filenames.

TECH TIP:  Dialup Internet Connections
The Internet Scheduler is designed mainly for those who have dedicated Internet connections (office

networks, cable modems, and network servers).
If you use a dialup connection and you use the Internet Scheduler, it is possible that your provider may

"kick you offline" at some point, especially if there is a period of inactivity.  You can usually fix this by leaving
your E-mail program running and have it automatically check E-mail every few minutes.

If you are booted offline, Digital Atmosphere cannot renegotiate the connection.  However when it tries to
get more data, it will send a signal to your Dialup Networking (Remote Access Services in NT) asking to reach
the network.  What happens from there is determined by the settings in Dialup Networking or Remote Access
Services.  Once the connection is re-established, data transfer will resume.

Windows NT will usually renegotiate lost connections automatically.  However if you don't have this
capability or it's not enough, consider shareware programs such as "Connect Pal" from http://www.connect-
pal.com/ .  Please note that if you are connected continuously to an Internet dialup server, your provider may
find that you are spending too much time online and may ask that you purchase a dedicated connection at a
higher fee.

15.3. Meteorological

15.3.1. General Meteorological Preferences

Also see the special topics on Units, FOUS data level, Parcel lift calculations, and Physical constants.

Geopotential heights in full meters only
The geopotential height on upper-level charts are commonly plotted in decameters (dam).  When this box is
checked, contour labels and upper plot models will appear in full meters.  When it is unchecked, the labels and
plot models will switch to conventional shortening typically used by meteorologists (see table below).  The
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default setting is unchecked.

Level Three-digit conventional shortening
100 to 500 mb Hundreds, tens, and units of decameters
501 to 1000 mb Hundreds, tens, and units of meters

Round synoptic reports to nearest 3 hours when importing
You have two options when importing synoptic (SYNOP) data — you can either round the reports to the
nearest 3 hours (making maximum use of off-hour data) or use no rounding (ensuring sampling of the
atmosphere at an exact moment).  It is generally best to use no rounding when possible.

View NEXRAD RCM rather than RAREP radar data
This prevents two different radar formats from being mixed when you use Data > Radar > Echoes.  Check this
box whenever you use NEXRAD RCM data (such as that transmitted over EMWIN).  If you use the old SD
RAREP code, uncheck this box.

Round AIREP reports within __ mb of a standard level
Forecasters like to see AIREP reports on upper-air charts, but AIREPs are rarely at an exact standard constant-
pressure level.  When this box is checked, it allows AIREPs within a certain range of the active pressure level
to be included on the map.  Usually 25 mb is a good value.  When it is unchecked, no AIREPs will be used
unless they are at the exact pressure level that's active.

Omit highs and lows when plotting ASUS1 frontal bulletin
This should usually be left checked.  When you produce a pressure analysis, Digital Atmosphere will
automatically plot highs and lows.  When you use Data > Frontal depiction (ASUS1 KWBC), it will plot its
own sets of highs and lows, which clashes with Digital Atmosphere's depiction.  Since the ASUS1's fields are
coarser and may differ from the isopleth fields, you should generally leave this checked unless you have no
surface data and want to see the ASUS1 output of highs and lows.

15.3.2. Units

Picks whether temperatures displayed will be in Celsius or Fahrenheit.  When Celsius is selected, Digital
Atmosphere will use Celsius units where possible (please notify the author of any program segments where this
setting is ignored).  Modifying the units for station plots is done in the Station Plots panel, not here.
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Picks whether precipitation totals will be plotted/contoured in units of millimeters (mm) or inches (in).

15.3.3. FOUS data level

Whenever you plot model (ETA/NGM) data, the temperature and moisture variables are determined according
to this setting.  Normally the first button (T1/R1) is selected to give you surface data, but by choosing another
button you can plot or analyze temperature or moisture aloft (calculating derived values such as dewpoint
should be done with caution, though, since T3 is not the same level as R2).  Here are the meanings of the
different levels.

Level  Equivalent
T1  Surface
T3  About 100 mb above the surface (1 km)
T5  About 215 mb above the surface (2 km)
R1  Surface to about 35 mb above the surface (lowest 1000 ft)
R2  About 35 mb above the surface to 500 mb
R3  500 mb to the tropopause

15.3.4. Parcel lift calculations

Parcel lift calculations
This setting is consulted by the analysis module when CAPE and other instability parameters are calculated.
Valid settings are as follows.
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• Surface-based parcel.  A parcel is lifted from the surface.
• Lowest 100 mb.  A parcel takes on the average mixing ratio and potential temperature within the lowest 100

mb before being lifted (most representative of a convective atmosphere at the time of the sounding).
• Lowest 150 mb.  A parcel takes on the average mixing ratio and potential temperature within the lowest 150

mb before being lifted.
• Best layer.  A parcel takes on the highest theta-E (the level where mixing ratio and potential temperature are

the highest) within the lowest 150 mb of the atmosphere.

15.3.5. Physical constants

Lowest possible METAR pressure
The METAR surface observation code format only allows the tens, units, and tenths place to be encoded, which
means that Digital Atmosphere has to determine whether the final millibar value is 9xx.x or 10xx.x.  The
default value for lowest METAR pressure is 960 mb, which means that if a value such as 584 is found, Digital
Atmosphere will assume it is 1058.4 mb, not 958.4 mb.  Normally there is no need to change this, but if you're
looking at exceptionally low pressure areas and the sea level pressure contours aren't plotting correctly, you'll
want to decrease this value.  Likewise, if you're looking at very high pressure and the sea level pressure
contours aren't plotting correctly, you'll want to increase this value.

Earth's rotation constant
Specifies the earth's rotation in radians per second, which is normally set at 0.000007292.  Naturally, there is
no need to change this unless you want to tinker and see the results.  The earth's rotation constant is used in the
Coriolis parameter equations, which are used for geostrophic wind calculations and calculation of absolute
vorticity.  Hitting reset replaces any entered value with the Earth's rotation constant.

Gravity constant
Specifies the gravity on the Earth's surface, which is normally set at 9.806 m/s-2.  There's no need to change
this unless you want to tinker and see the results.  Gravity is only used in the calculation of geostrophic wind
based solely on height contours.  Hitting the reset button replaces any entered value with the Earth's gravity
constant.
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15.4. Maps

15.4.1. General Maps Preferences

Also see the special topics on JPEG image compression, Lat/Long grid, Grid interval, Default size, and Map
element settings.

Make coastlines double wide
By checking this box, any maps that you generate will look more professional due to thicker coastlines.
However you may have trouble reading data in coastal locations because of the thicker lines.  This setting will
not take effect until the next time you generate a map.

Plot ocean fill crosshairs
If checked, a small cross is plotted at each location where Digital Atmosphere tries to fill the ocean or space
with a solid color.  This is strictly a diagnostic tool which you can use if you want to add or delete points in the
ocean fill file (Digital Atmosphere\GEO\FILL.GEO).  It must be used in conjunction with an enabled ocean fill
color.  This setting will not take effect until the next time you generate a map.

Topography: use avg elev rather than max
This controls what source of data is used when you select Map > Make Topography.  When it is checked,
average elevation data is used.  When it is unchecked, the maximum elevation data is used.

Fill outer space
When the map is zoomed out to where you can see the disc of the Earth, the area outside the disc (the outer
space area) will be filled with the general plot color if this option is selected.

Label latitude/longitude lines
When checked, and the Lat/Long grids are checked and active, latitude/longitude labels will be placed at the left
and bottom of the map consistent with the Grid Interval setting.  The font color will be the same as the lat/long
grids and the attributes will be those specified in the Fonts preferences under "station plots".

Digital Atmosphere

Page 60



15.4.2. JPEG Image Compression

If you choose Map, Export and choose JPEG as an image type, the image will be compressed according to the
settings you specify here.  JPEG is a lossy compression scheme, which means that higher compression values
result in degradation of the image.  As the user, you select the tradeoff that you think is most acceptable.  For a
typical 640 x 480 image, a setting of 0% (loose) will result in a high-quality image with a filesize of 225K.  A
setting of 100% (tight) will result in a very coarse image with a filesize of 11K.

15.4.3. Lat/Long Grid

Digital Atmosphere can overlay a latitude/longitude grid, and here you can control how it will be displayed.
You will see the lat/long grids only if the "lat/long grids" setting in the "map element table" is checked and only
when you re-generate a new map.  Note that the grid interval is controlled by the "grid interval" setting and the
color is controlled by the grid color listed in the "map element settings" color table.

* Line.  Plots latitude/longitude as a series of lines.

* Mixed.  Same as "line" above, but also adds dots for every integer degree of latitude and longitude.  The size
and interval of the dots is fixed and cannot be controlled.

* Cross.  Plots a cross at each latitude/longitude intersection.

* Dash.  Plots latitude/longitude as a series of dashed lines.

* Dotted.  Plots latitude/longitude as a series of dotted lines.
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15.4.4. Grid Interval

If a latitude/longitude map is plotted, this value controls what interval will be used (in degrees) to plot the grid.
A value of 1, 5, 10, or 15 should normally be used.  So that the grid wraps uniformly around the globe, the
value you select should divide evenly into 360.

15.4.5. Default Size

When you use quick mapmaking commands such as Generate Map on the speed button toolbar, this determines
what the map size will be in pixels.

15.4.6. Map element settings

Use this table to set which geographical features you want displayed and in what color.  Remember that these
will not take effect until the next time you generate a map.
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15.5. Station plots

15.5.1. Station plots tab

Also see the special topics on Surface plot models, Upper air plot models, and Station filtering.

Plot radar status labels
Whenever Overlay, Radar is chosen, this determines whether symbols are plotted at each radar location
together with the radar echoes.  By unchecking this box, only radar echoes will be plotted.

15.5.2. Surface plot model

These settings only apply when the active level is the surface level and Overlay, Data is selected.

• Plot wind barb.  If checked, Digital Atmosphere will plot a wind barb at each station plot when it is
reporting valid wind data.  If unchecked, no wind barb is plotted on any report.

• Filter ASOS reports.  If checked, Digital Atmosphere will plot human observations first, with automated
(ASOS, AMOS, automated synoptic, etc) as last priority.  If unchecked, no priority is assigned to any
observation.

• Smart visibility plo t.  If checked, Digital Atmosphere will omit plotting surface visibility when no significant
weather is occurring.  If unchecked, surface visibility is always plotted.

• Color code IFR/MVFR plots.  If checked, when stations are reporting IFR conditions (visibility less than 3
miles and/or ceiling less than 1000 ft), the OKTAS (sky cover) plot symbol is colored red; when MVFR
conditions (visibility less than 5 miles and/or ceiling less than 3000 ft), the OKTAS (sky cover) plot symbol
is colored blue.  If unchecked, the standard draw color is used to paint the sky cover plot symbol.
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Plot model configuration
A "grid" of combo boxes are set up in a way that represents the various data positions around a given station
plot.  You can use these combo boxes to adjust the kinds of data that are plotted in the different positions.  A
"Save Plot Model" and a "Load Plot Model" option are provided so that you can make quick, on-the-fly
changes to the desired plot model.

Load plot model
Loads a predefined plot model configuration from disk.

Save plot model
Saves the current plot model configuration to disk.

Valid plot elements

Units marked "C or F" or "ft or m" or "sm or m" are in metric or English according to File > Preferences >
Meteorological > Units unless otherwise specified here.

(blank) Nothing will be plotted in this space
TEMP Air temperature in whole degrees (C or F)
TEMP(10) Air temperature in tenths (C or F)
DWPT Dewpoint in whole degrees (C or F)
DWPT(10) Dewpoint in tenths (C or F)
GUST Wind gust (kt)
RH Relative humidity (%)
MXR Mixing ratio (g/kg)
THETA Potential temperature (deg K)
THETAE Equivalent potential temperature (theta-e) (deg K)
WINDCHILL Wind chill
HEATINDEX Heat index
SLP Sea level pressure (mb) (plots tens, units, and tenths)
ALSTG Altimeter setting (in Hg) (plots units, tenths, and hundredths)
WX Pictogram of current weather type
VIS Prevailing visibility (sm or m)
ELEV Elevation (ft or m)
CIG Ceiling (lowest layer occupying more than half of sky) (hundreds of feet)
OKTAS Cloud cover in oktas (eighths)
ID(ICAO) Station identifier (4-letter ICAO)
ID(WMO) Station identifier (5-digit WMO)
PCP01 Precipitation during past 1 hour
PCP06 Precipitation during past 6 hours
PCP12 Precipitation during past 12 hours
PCP18 Precipitation during past 18 hours
PCP24 Precipitation during past 24 hours
PTEND Pictogram of pressure tendency during past 3 hours
CLD/L Pictogram of low cloud type
CLD/M Pictogram of middle cloud type
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CLD/H Pictogram of high cloud type
CLDHGT Cloud height code (synoptic only) (see chart below)
CLDAMT Cloud amount code (synoptic only) (see chart below)
SHIPDIR Pictogram of direction of ship movement
SHIPSPD Speed of ship movement (kt)
SEATEMP Sea-surface temperature (C or F)
TEMPTYPE Type of temperature measurement device
WAVEPD Period of ocean waves (sec)
WAVEHGT Height of ocean waves (ft or m)
SEAINSTHGT Instrument-measured height of ocean waves (ft or m)
WINDPD Ocean wind wave period (sec)
WINDHGT Ocean wind wave height (ft or m)
SWELL1DIR Direction of primary ocean swells (deg)
SWELL2DIR Direction of secondary ocean swells (deg)
SWELL1PD Primary ocean swell period (sec)
SWELL1HGT Primary ocean swell height (ft or m)
SWELL2PD Secondary ocean swell period (sec)
SWELL2HGT Secondary ocean swell height (ft or m)
MINTEMP Minimum temperature (C or F)
MAXTEMP Maximum temperature (C or F)
GRNDSTATE Ground state code (see below)

Ground state codes
0 Surface of ground dry (without cracks and no appreciable amount of dust or loose sand)
1 Surface of ground moist
2 Surface of ground wet
3 Flooded
4 Surface of ground frozen
5 Glaze on ground
6 Loose dry dust or sand not covering ground completely
7 Thin cover of loose dry dust or sand covering ground completely
8 Moderate or thick cover of loose dry dust or sand covering ground completely
9 Extremely dry with cracks
10 Ground predominantly covered by ice
11 Compact or wet snow (with or without ice) covering less than half of ground
12 Compact or wet snow (with or without ice) covering half to less than entire ground
13 Even layer of compact or wet snow covering ground completely
14 Uneven layer of compact or wet snow covering ground completely
15 Loose dry snow covering less than half of ground
16 Loose dry snow covering at least half of ground but ground not completely covered
17 Even layer of loose dry snow covering ground completely
18 Uneven layer of loose dry snow covering ground completely
19 Snow covering ground completely; deep drifts

Synoptic cloud amount codes (CLDAMT) (Nh)
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This category is defined as Nh; the amount of all the low cloud present, or, if no low cloud is present, the
amount of all the middle clouds present.  The figure is always in oktas (eighths).  9 is reserved for sky
obscured by fog and/or other meteorological phenomena, and / is reserved for cloud cover being
indiscernable for reasons other than fog or other meteorological phenomena, or observation is not made

Synoptic cloud height codes (CLDHGT) (h)
"h" is reserved for the height of the surface of the base of the lowest cloud seen.  They are as follows
(below).  If the total sky cover is greater than 4/8ths, this figure is also transposed into the CIG slot, where
they are plotted as "L" ("low cloud") followed by a loose translation of the table below in hundreds of feet.
This "L" differentiates it from true ceilings where "C", "E", or "M" is prefixed.

0 0 to 50 m
1 50 to 100 m
2 100 to 200 m
3 200 to 300 m
4 300 to 600 m
5 600 to 1000 m
6 1000 to 1500 m
7 1500 to 2000 m
8 2000 to 2500 m
9 2500 m or more, or no clouds
/ Height of base of cloud not known, or base of clouds at a level lower and tops at a level higher than
that of the station

15.5.3. Upper air plot model

These settings only apply when the active level is an upper level and Overlay, Data is selected.

• Plot wind barb.  If checked, Digital Atmosphere will plot a wind barb at each station plot when it is
reporting valid wind data.  If unchecked, no wind barb is plotted on any report.

• Fill dewpoint depression circle.  If checked, Digital Atmosphere will "shade in" the station plot of each
upper level station whenever the dewpoint depression is 5 deg C or less.  If unchecked, all station plots are
left unfilled.

Plot model configuration.
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A "grid" of combo boxes are set up in a way that represents the various data positions around a given station
plot.  You can use these combo boxes to adjust the kinds of data that are plotted in the different positions.  A
"Save Plot Model" and a "Load Plot Model" option are not provided for upper air plot models since most users
will stick to a single configuration.

Load
Loads a predefined upper air plot model configuration.

Save
Saves the upper air plot model configuration for later use.

15.5.4. Station filtering

The station filtering panel is a handy tool for increasing or decreasing the clutter (plot density) of station plots
on the map.  Users may want to increase the setting to show more useful weather data, or decrease it to make a
more presentable map.

Plot all stations
When checked, Digital Atmosphere will plot every single station that reported a valid meteorological report
within the desired timeframe when you choose Overlay, Data or Overlay, Custom Data.  This may result in a
very cluttered map, but can give you an idea of the extent of the data.  When unchecked, Digital Atmosphere
will consult the "Station Plot Density" slider bar to determine how many stations to plot and how many to
ignore.

Station plot density
This slider bar is only enabled when "Plot All Stations" is unchecked.  By adjusting the position of this slider
bar, you can change the density (clutter) of station plots whenever you choose Overlay, Data or Overlay,
Custom Data.

15.6. Analysis

15.6.1. Analysis tab

Also see the special topics on Analysis type and Analysis parameters.
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Thick contour lines
If checked, this gives all contour lines a width of 2 instead of 1.

Show gridpoint values
If checked, scalar field values are plotted at each analysis gridpoint.  This is used mainly for diagnostic
purposes.  This should normally be left in the unchecked position.

Perform isopleth
If checked, scalar fields are drawn using isopleths (lines connecting equal values).  This is the normal setting
and should normally be left checked.

Perform gradient fill
If checked and a scalar analysis is selected, the entire screen is painted in hot or cold shades depending on
whether the analysis value is high or low, respectively.  You cannot modify the colors that are painted, and
you should use plain maps without topography for best results.  It is advised to leave both "Perform Isopleth"
and "Show Gridpoint Values" unchecked if you select this option.  Note that gradient fills only work with scalar
fields, not vector fields.

Automatic smoothing
If checked, Digital Atmosphere will automatically determine the surface and upper air surface radius based on
existing data for the Weighted, Cressman, and Barnes analyses.

Figure geostrophic heights
When analyzing upper-level heights, Digital Atmosphere will calculate the height field by computing contour
gradients at each station (derived from the wind direction, speed, and existing height).  This takes longer but
yields much more accurate results.  You may uncheck this if you wish to perform only a very quick, rough
height analysis.
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500 mb heights WITHOUT geostrophic heights.  Note that the wind directions are largely ignored, and the
analysis looks coarser.

500 mb heights WITH geostrophic heights.  Wind directions are used to estimate the geostrophic height field,
yielding a better looking map.

15.6.2. Isopleths
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This option simply controls what size and type of fonts are used to label contour lines on analysis charts.
"Transparent" controls whether the map below bleeds through the font.

A sample analysis with "small fonts" checked and "negative fonts" checked:

The same thing, except with "small fonts" unchecked and "negative fonts" unchecked.

This is an example of the font above, except with "transparent" unchecked.  A background color is used to
backdrop the font.  If "transparent" is checked, then the map below would bleed through under the font.

15.6.3. Highs and lows

Use NMC font .  When checked this will allow Digital Atmosphere to use "NMC fonts", which are the fonts
used on various DIFAX products.  They are easily recognized by most experienced meteorologists.  Leaving
it unchecked will allow Digital Atmosphere to use the font specified by "Annotations" in File > Preferences >
Fonts.

Regular Digital Atmosphere font.
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NMC font.

15.6.4. Analysis type

Specifies which mathematical algorithm is to be used to analyze the data field.

• Nearest neighbor — This is by far the quickest, and most users will use this setting.  Values are mapped to
the closest gridpoint, then are mathematically expanded to neighboring unfilled gridpoints in a cyclical
manner.  Afterwards, a selective smoothing operator smooths gridpoints, performing more smoothing
iterations performed on gridpoints that are further from representative data areas and less or no smoothing
passes where data is close to a gridpoint.  Strengths: It's fast and always works.  Weaknesses: Data void
border areas look linear, and data void interior areas can look pie-shaped.

• Weighted — Digital Atmosphere looks at the neighboring stations around a gridpoint, giving it an average of
those values around it with more emphasis on the values at closer stations.

• Barnes — The Barnes method, the cornerstone of the MCIDAS and GEMPAK weather workstations, has a
number of advantages: versatility, simplicity, and speed.  Each gridpoint is assigned a meteorological value
which is the result of a Gaussian distance-dependent weighting function.  A difference field is calculated,
which determines how far off from reality the analysis field appears to be, then a difference correction is
applied to the analysis field.  This takes a relatively long time to compute, but is one of the more accurate
analysis algorithms.

• Cressman — Each gridpoint is assigned a meteorological value which is the result of a distance-dependent
weighting function.  The Cressman analysis method is similar to the Barnes technique, however it makes
successive corrections using a smaller and smaller radius of influence to eliminate all errors.  It takes more
time, but the results are good.  In data-sparse areas, it is common for there to be erroneous contours,
especially if Digital Atmosphere is tasked to determine the best station spacing.  Strengths: It's sophisticated
and flexible, and it may retain more mesoscale structure.  Weaknesses: It can't resolve short-wavelength
components, it can require a large amount of time, and it can fail with extreme data distribution.
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15.6.5. Analysis parameters

Smoothing coefficient
Sets the mathematical value of "s" for the smoothing equation.  This affects what kind of wavelengths will be
filtered in the analysis grid.

Smoothing passes
Determines how many times a smoothing operator will operate whenever it is called.  With this, you can set
how "smoothed" the maps will look when the analysis is complete.  This should be set to "1" or to a low non-
zero value.

Surface radius
Determines a radius of influence used in the Weighted, Cressman, and Barnes analysis method for surface data.
This value should approximate the average spacing between surface stations.

Upper radius
Determines a radius of influence used in the Weighted, Cressman, and Barnes analysis method for upper air
data.  This value should approximate the average spacing between upper air stations.

Gamma
Determines a gamma used in the Barnes analysis method for upper air data.

Reduction
Determines a reduction value used in the Cressman analysis method for upper air data.
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15.7. Fonts

15.7.1. Fonts tab

Press any of the buttons to make changes to the fonts that are used on Digital Atmosphere workcharts.
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15.8. Contours

15.8.1. Contours tab

This tab is where changes are made to contours that are produced under the "Analysis" dropdown menu.

Code
This is an internal code.  It cannot be modified.

Contour type
Indicates the purpose of this contour.  It cannot be modified.

Unit
Proper entries are as follows.  Do not mixmatch units or the program will ignore the setting and use a default
unit.  Units marked with * cannot be changed.

   Temperature . . . . . . . deg f, deg c, deg k
   Moisture . . . . . . . .  g/kg
   Relative Humidity . . . . percent
   Horizontal Velocity . . . knots, mph, m/s
   Vertical Velocity . . . . ub/s (microbars per second)
   Height . . . . . . . . .  meters
   Pressure . . . . . . . .  mb, hpa, kpa, inches
   Precipitation Totals . .  inches, mm

Base
Determines the base value that the intervals are based off of.  For example, if you use an interval of 5 degrees,
a base of zero will give 0, 5, 10, 15, 20, 25.. degrees.  If you use a base of 2 degrees, you'll get 2, 7, 12, 27, etc.
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Always reduce the base to the lowest common denominator (as close to zero as possible).

Interval
Represents the contour step interval (the numerical difference between each contour).

AI
Automated interval.  If y is entered, Digital Atmosphere will override the base and interval settings and choose
the ones that will give the clearest view of the data field.

Style
Indicates the linestyle that will be used to draw the contour.  Acceptable values are solid, dash, or dot.  Radar
echoes must be either solid, clear, bdiag, fdiag, cross, crdiag, horiz, or vert.

Color
Indicates the color of the contour.  Here are the acceptable color settings you can use.
    black         maroon           green           yellow
    olive         navy             purple          fuchsia
    teal          gray             silver          aqua
    red           lime             blue            white

15.9. Miscellaneous

15.9.1. Misc tab

Advanced internet settings.  If you use a proxy host, enter the name and port here.  If you do not know the
proxy settings, you will need to contact your ISP.  Our tech support personnel cannot guess these settings or
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look them up for you.  For example, users of Alphalink in Melbourne, Australia will notice on their Alphalink
support pages that they would need to enter proxy.alphalink.com.au in "Proxy host" and 8080 in "Proxy port".

Photorealistic topography.  This preference setting is only used in the full-blown version.
• Smooth final image.  Applies a smoothing function to the photoreal map.
• Reoverlay geography.  Plots the basemap on top of the photoreal map.  Checked by default.

Color gradient fills .  This section lets you define how gradient fills will look.  It is designed mostly for
experienced users and will require some basic mathematical knowledge.  The colors are defined according to the
plotted Value for the particular point on the map, which will always be in the range 0..1, where 0 is the lowest
possible reading and 1 is the highest possible reading.  This Value is fitted to a sine wave according to user
defined parameters to determine the Red, Green, and Blue component of its color.

First the value (0 for minimum possible and 1 for maximum possible) is fitted to the sine wave to determine
what the amplitude will be.  Amplitude will always be in the range -1 to 1.  Amplitude is determined by ph1 and
ph2, which are in degrees.  A greater difference between ph1 and ph2 will result in a more curved function,
while a smaller difference will produce a flatter function.  For basic users, the sine responses are as follows:
sin(0)=0, sin(90)=90, sin(180)=0, sin(270)=-1 .

Amplitude = sin( [(ph2-ph1) * Value] + ph1 )

Finally the amplitude is modified according to the user-defined scale and offset values to determine ColorValue,
which must always be in the range 0..1 (0 is dark, 1 is bright).  This means if an Amplitude value is negative, it
must be offset so that it falls into the range 0..1.  An out of bounds ColorValue is always rounded up or down
so that it equals 0 or 1.

ColorValue = (Amplitude * Scale) + Offset

Example: For a basic scale where cold temperatures are black and hot temperatures are bright red, set Red's
Ph1=0, Ph2=90, Scale=1, and Offset=0.  Set the Green and Blue Scale to 0 and Offset to 0, which will always
provide a value of 0 for these components.

Illustration of basic concepts of Ph1, Ph2, Scale, and Offset.
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16. Troubleshooting

16.1. How to solve a problem

If you are having trouble with Digital Atmosphere, the best thing to do is consult our online FAQ, located on
our web site at www.weathergraphics.com under "FAQ".  This troubleshooting list is kept up-to-date and has
numerous issues that tend to come up.

If this doesn't work, you can obtain support at the following locations.  E-mail is usually preferred since this
gives us time to research your problem.  We always appreciate feedback and notification when users find bugs,
since we are committed to producing the best possible product.

E-mail support@weathergraphics.com
Mailing lis t http://www.listhost.net:81/guest/RemoteListSummary/wx_software
Telephone (888) 388-0070
Fax (405) 329-5275
Mail Weather Graphics Technologies, P.O. Box 450211, Garland TX 75045
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17. Appendix

17.1. Terminology

If you want to be an expert with other Digital Atmosphere users and with tech support, here's the definitions of
some of the terms that we use.

Active level.  At any given moment, Digital Atmosphere will only perform analysis or plotting operations for a
certain type of data or height/level (such as surface, 300 mb, NGM model output, etc).  Active level describes
which one is the current one.  You change it using the Level setting on the Time Toolbar.

Analysis.  See objective analysis.

Derivative field.  The vorticity, divergence, or advection of a selected primary field.

Dialog box.  Any box (window) that pops up on the screen temporarily asking you to enter or click something.

Formatted binary data file.  The end results of File, Import, where tables of raw data are stored on disk and
made available to the plotting or analysis routines.  These files consist of compressed data and can only be
modified using the File, Quality Control function.

Importing.  The process of "crunching" raw data.  This is how you feed new data into Digital Atmosphere.
The data is stored in formatted data files.

Isoplething.  The process of Digital Atmosphere drawing contours, or lines, on the screen, as the result of an
objective analysis.  Isopleths are not "plotted"; they are "drawn".

Map attribute file.  A small file (36 bytes) that is paired with a geographical bitmap file to provide
mathematical mapping information about that image.  A map attribute file has the file extension "ATR".

Map generation.  Forcing Digital Atmosphere to draw a customized map based on latitude, longitude, and
zoom settings that the user selects.

Objective analysis.  The process that Digital Atmosphere undergoes before it can show a contour or isopleth.
It consists of looking at data at randomly-spaced points, mapping it to a grid, and running smoothers on the
grid.  In the context of this user's guide, I will refer to objective analysis as simply "analysis", and refer to
human analysis as "hand analysis", etc.

Ocean fill.  The blue color that Digital Atmosphere usually draws in oceans and lakes.

Plot.  See station plot.

Primary field.  An atmospheric property that the user chooses to analyze.  The user may also force Digital
Atmosphere to calculate a derivative field of the primary field.
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Raw data file.  The original weather data from online services, the Internet, etc, that is fed into Digital
Atmosphere when the user selects File, Import.  First, the file is copied and filtered to produce a clean data file
(C:\DIGATM\DATA.USR), and then data is imported, producing a formatted data file.

Station plot.  A small grouping of numbers and symbols that depicts the observed weather at a given location.
Plots are not "drawn"; they are "plotted".

Status panel.  The window that shows the clock, the active level, data display options, and import filters.

Sterilized data file.  A temporary file containing original raw data that is produced whenever the user imports
data.  It contains no control codes or extraneous characters.  The sole purpose of a clean data file is for the File,
View Raw Data command and for Digital Atmosphere functions where English-language bulletins are drawn on
the screen (such as tornado watches, convective outlooks, etc).  Weather data plots and analyses do not come
from this file, but from the formatted data file.

Topography.  The multicolor shades that can be manually drawn on landmasses to represent terrain.

Upper air.  Involving any level besides the surface.

17.2. Map attribute file structure

(For technically inclined users only)

This file, ending with the file extension *.ATR, is associated with each map which is saved to disk.  The
attribute file is structured as follows:

Number Purpose
real Central latitude (degrees)
real Central longitude (degrees)
real Zoom setting (3963/z where z=map width in miles)
integer    Not used
integer    Not used
integer    Not used
integer    Not used
integer    Map height (pixels)
integer    Map width (pixels)
integer    Offset x direction (pixels)
integer    Offset y direction (pixels

Real types have the range 2.9 x 10-39 .. 1.7 x 1038 with 11-12 significant bits and a length of 6 bytes.

Integer types have the range -2147483648..2147483647 and are signed 32-bit (4 byte) little endian.
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17.3. Scripting

Scripting is a powerful function that allows Digital Atmosphere to do various tasks while unattended.  You can
have it download data every half hour and always have the latest map displayed, or send charts to the printer
automatically.  The possibilities are up to you.

SCRIPTING BASICS

To run a single script command
Simply type in the script command in the "command" line on the scripts toolbar.  Hit return or click "Enter"
and it will be processed.  Note that this does not run a script; it just runs a script command.  A list of
commands is below.

To write a script
Use any text editor or click on Create Script on the scripts toolbar and you can begin typing your script.  Note
that scripts should use the file extension .dsf in order to be properly recognized in Digital Atmosphere.  To
"comment out" a line of code simply place a semicolon at the beginning of the line.  Commands are
generally not case-sensitive.

To run a script in run-time
Go to the scripts toolbar and select the Run Script button.

To run a script at startup
Advanced users can run scripts on Digital Atmosphere startup by using standard command-line parameters.
A space and the full name of the script file is simply appended after the filename at the command prompt or
in the shortcut property for Digital Atmosphere.

To use the scheduler
Go to the scripts toolbar and select the Scheduler button (it will say "Scheduler on..." or "Scheduler off...").
This will bring up a configuration window (see below) where the scheduler will coordinate which script files
run at which time.
• You must set "Enable scheduler" for the scheduler to take effect.
• When the scheduler is no longer wanted, bring up this window again and unset "Enable scheduler".
• To specify the execution time for each script, write the execution time in 4-digit UTC time in hhmm format

(i.e. 7:45 am is 0745 and 2:15 pm is 1415), followed by a space, and the name of the file (including its .dsf
extension).

• Be sure to specify the full pathname of the file, otherwise Digital Atmosphere will assume it is located in
your Digital Atmosphere directory.

• There can be an unlimited number of scripts and execution times in this list.
• Advanced users: You can edit or swap out this schedule list if you wish; it's located in the Digital

Atmosphere directory under digatmos.sft .
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VALID SCRIPT COMMANDS

SET,keywordnumber ,keywor d
Sets a specified keyword (1 through 9) to a certain value.  You can then use this keyword later on in the
same script simply by placing the token $$x anywhere in the code, where x is the keywordnumber.  This is
useful for managing large scripts.

Example:
SET 1 500 Sets keyword 1 to "500"
PRODUCT $$1 HGT $$1 indicates "500", so here 500 mb heights are plotted
PRODUCT $$1 TMP $$1 indicates "500", so here 500 mb temperatures are plotted

TIMERON
Enables the script timer.  It will adhere to the current timer script schedule.

TIMEROFF
Turns off the script timer.

SLEEP,seconds
Causes Digital Atmosphere to pause for the specified number of seconds.  An hourglass cursor will be
displayed during this time.

PRODUCT,typ e,level,titl e
Overlays a meteorological product on the map.  The appropriate data must have already been imported.
Valid type parameters are documented at the end of this section.  Levels are specified as follows: for surface
data, the level is 0 (zero); for millibar levels the level equals the millibar level (500, etc); and for FT height
levels the level equals the ten-thousands and thousands digits multiplied by -1 (so 34,000 ft equals -34).  The
title parameter is optional and contains a text title that will be placed in the legend.  Derived fields are not
supported at this time.

MAKE,lat,lon g,zoom,widt h,heigh t
Makes a map using the given coordinates.  Lat is negative in the southern hemisphere.  Long is negative in
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the western hemisphere.  Zoom is a value equal to 3964/x, where x is the width of the map in statute miles.
Width and height are the map sizes in pixels.

GENERATE,locatio n
Makes a map centered on a given location.  The location, which is not case-sensitive, must be a valid entry
in the Generate Map dropdown menu on the speed buttons toolbar.  This in turn gets its valid entries and
lat/long/zoom data from the DIGATMOS.MSE, which you can edit if a map does not appear right, and map
size settings are from File > Preferences > Maps > Default Size.

CENTER,statio n,zoom,widt h,heigh t
Makes a map with the chosen station in the center of the screen.  Zoom is a value equal to 3964/x, where x
is the width of the map in statute miles.  Width and height are the map sizes in pixels.

DOWNLOAD,ur l,filenam e
Downloads a product from an Internet source.  The url is the fully qualified, RFC 1738 standard URL
(including filename), and filename is the full local name where the file will be stored.  Example:
     download,ftp://userid:password@ftp.mydomain.com/anonftp/pub/out.jpg,c:\da20\bin\map\in.jpg

UPLOAD,ur l,filenam e
Uploads a product to an Internet source.  The url is the fully qualified, RFC 1738 standard URL (including
filename), and filename is the full local name of the file to be uploaded.  Example:
     upload,ftp://userid:password@ftp.mydomain.com/anonftp/pub/out.jpg,c:\da20\bin\map\out.jpg

ARCHIVE,cddrivelette r,yymm,yymmddh h
Accesses data from the Weather Graphics Technologies Surface Archives or Upper Archives CD-ROM.  The
cddriveletter parameter is the drive letter, while yymm is the year and month (full four digits) and yymmddhh
is the year, month, date, and hour (full eight digits).

LOAD,filenam e
Loads a map.  The filename parameter is the fully qualified filename without the extension (i.e. without
.bmp).

SAVE,filenam e
Saves a map.  The filename parameter is the fully qualified filename without the extension (i.e. without
.bmp).

EXPORT,filenam e
Exports a map (i.e. saves it to a variety of formats and without the accompanying .atr file).  The filename
parameter is the fully qualified filename with a valid extension (may be bmp, gif, jpg, png, pcx, or tif).
Compressed TIFF saving is not available.

GRADIENT,on|off
Turns on or turns off the File > Preferences > Contours > Gradient Fill option.

GRADIENTCOLOR,red|blue|green,ph1|ph2|scale|offset, valu e
Sets one of the File > Preferences > Misc > Gradient Color settings to a particular value.  This allows the
script to change a contour gradient scheme on the fly.

SFCPLOTMODEL,filename
Loads a particular surface plot model.  Filename must be the fully qualified filename with path and extension
(*.sps).

ISOPLETH,on|off
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Turns on or turns off the File > Preferences > Contours > Perform Isopleth option.

STAMP
Imprints a timestamp at the top of the map that says "GENERATED (date) (time)".

ERASE
Erases all of the overlays on the map.

MINIMIZE
The Digital Atmosphere application window is minimized.

MAXIMIZE
The Digital Atmosphere application window is maximized.

NORMAL
The Digital Atmosphere application window is neither minimized nor maximized.

QUIT
Quits the program

IMPORT,filenam e
Imports the specified data file (filename is a fully qualified file name).

PRINT
Prints the map to the default printer using default settings.

BLAN K
Erases the overlays as well as the basemap.

CLIP
Copies the map to the clipboard.

TOPO
Makes a topographic underlay on the map (takes some time).

BASEMAP
Plots the basemap.

CITY
Plots cities.

COOUT
Plots county outlines.

CONAME
Plots county names

HIGHWAY
Plots Interstate highways (U.S. only).

ROAD
Plots major roads (U.S. only).

Digital Atmosphere

Page 84



CUSTOM
Plots custom overlays.

REMOVE
Removes the last product from the display.

VALID PRODUCT TYPES

pla ACARS plots
plf Standard data plots
plc Custom data plot
tdy Television-style data plots
rad Radar plots
wgr Wind grid
tmf Temperature (deg F)
tmc Temperature (deg C)
pot Potential temperature (deg K)
wcx Wind chill factor
hix Heat index
dwf Dewpoint (deg F)
dwc Dewpoint (deg C)
rhu Relative humidity
mxr Mixing ratio
eqp Equivalent potential temperature (theta-e)
slp Sea level pressure
alt Altimeter setting (QNH)
wsp Wind speed
cig Ceiling
hgt Geopotential height
thk Thickness (1000-500 mb)
wrx Warning overlays
p01 1-hour precipitation
p06 6-hour precipitation
p12 12-hour precipitation
p18 18-hour precipitation
p24 24-hour precipitation
rst RCM radar storm centroids
rhl RCM radar hail signatures
rms RCM centroid movement and speed
rtv RCM tornado TVS signature
reh RCM echo height signatures
rem RCM echo movement
wxp ASUS1 KWBC frontal depiction bulletin
ste Sea surface temperature
pdw Wave period
htw Wave height
hti Wave instrument-measured height
pdd Wind wave period
htd Wind wave height
di1 Primary swell direction
di2 Secondary swell direction
pd1 Primary swell period
ht1 Primary swell height
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pd2 Secondary swell period
ht2 Secondary swell height
cig MVFR/IFR weather
dy1 SPC Convective Outlook Day 1
dy2 SPC Convective Outlook Day 2
06k Surface-6000 ft shear [not completed]
lcl Lifted condensation level [not completed]
be+ CAPE [not completed]
be- CIN [not completed]
cxx [not used]
hux [not used]
iht [not used]
zb+ [not used]
prt [not used]

SAMPLE SCRIPTS

This script downloads synoptic data from Albany, imports it, displays plots and sea level pressure, and
outputs it to a file.  Note that this will probably not work on your computer without changes, and is only
intended to demonstrate the appearance of script commands.

download,http://www.atmos.albany.edu/weather/data1/surface/syn/@Y@M@D@S_syn.wmo,c:\digatm\data\t
est.dat
import,c:\digatm\data\*.*
product,plf,0,Test plot
product,slp,0,Test plot
export,d:\da20\bin\map\out.jpg

This script plots a series of upper air charts for 1200 UTC August 27, 1990 from our Upper Archives CD-
ROM and saves the completed charts for 250 mb, 500 mb, 700 mb, and 850 mb to individual files
(1990082712250.gif, etc).  Again this may not work on your computer without some changes.

set,1,9008
set,2,90082712
archive,f,$$1,$$2
product,plf,250,PLOT
export,d:\da20\bin\shannon\19$$2250.gif
erase
product,plf,500,PLOT
export,d:\da20\bin\shannon\19$$2500.gif
erase
product,plf,700,PLOT
export,d:\da20\bin\shannon\19$$2700.gif
erase
product,plf,850,PLOT
export,d:\da20\bin\shannon\19$$2850.gif

17.4. Using tabular weather data

Digital Atmosphere is capable of importing observations from a comma-delimited database listing.  This is
excellent for weather observations exported out of a database or a spreadsheet.  If recognized as shown below,
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the data will be imported and available for viewing as long as it is imported as usual from the data directory or
from a specified file.

The rules for this data are:
• Comma-delimited data only!
• Each line must correspond to one observation
• No extraneous commas are permitted (even within quote marks)
• The observation must contain the station's latitude and longitude.

To take advantage of this capability, you need to open the DIGATMOS.FMT file with a text editor and define
the start sequence and the parameters that apply to that type of data.

Start sequence
You define the start sequence by placing a "start sequence" between brackets in the DIGATMOS.FMT file; for
example if your database starts out with "Joe's Data" you should start out with this:

[Joe's Data]

No database entries are read in until the start sequence is found.

Parameter list
To actually read the data, you will need to create a parameter list, such as this:
TMP=4
DWP=6
Each entry must be on its own line, and the list ends when the end of the file is reached or another start
sequence is found.  The example above indicates that the temperature can be found in column 4 and the
dewpoint can be found in column 6.

Sample listing
Here is a sample of an entry in DIGATMOS.FMT which is used for Australian Bureau of Meteorology AXF
data.

[synopData]
ICA=3
WMO=1
LAT=6
LON=7
ELE=9
TIM=5
DAT=4
TMP=22
DWP=23
WND=11
WNM=12
SKY=10
CIG=26
WXX=14
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VIS=13

Valid parameters
ICA=xxx     ICAO of the station (for display purposes only)
WMO=xxx     WMO number of the station (for display purposes only)
LAT=xxx     Latitude, in hundreds of degrees (negative is southern hemisphere)
LON=xxx     Longitude, in hundreds of degrees (negative is western hemisphere)
LAX=xxx     Latitude, in regular format (negative is southern hemisphere)
LOX=xxx     Longitude, in regular format (negative is western hemisphere)
ELE=xxx     Elevation in meters (used only for potential temperature calculations)
TIM=xxx     Time in UTC (expressed as 450 for 4h50m and 1629 for 16h29m)
DAT=xxx     Day of month (expressed as "16" for September 16)
TMP=xxx     Temperature in degrees Celsius
DWP=xxx     Dewpoint in degrees Celsius
WND=xxx     Wind direction in degrees true
WNS=xxx     Wind speed in knots
WNM=xxx     Wind speed in meters/second
SKY=xxx     Total sky cover in oktas (9=obscured, 10=not available)
CIG=xxx     Ceiling in hundreds of feet
WXX=xxx     Weather code; first and second digit equals ww weather code (e.g. 61 is light rain)
VIS=xxx     Visibility in meters
PCP=xxx     Precipitation total in millimeters
PCT=xxx     Precipitation time period in hours
PTR=x     Pressure trend (equals a in app group)
PTN=xxx     Pressure tendency (in tens of millibars)
SNO=xxx     Snow depth in centimeters
CLL=x     Low cloud code
CLM=x     Middle cloud code
CLH=x     High cloud code
MAX=xxx      Maximum temperature, in degrees Celsius
MIN=xxx      Minimum temperature, in degrees Celsius

17.5. Using exported analysis grids

Whenever an Analysis is performed on any data (scalar, isoplethed fields only), Digital Atmosphere always
exports its output to GRID.TXT.  The output can then be imported into spreadsheets or analyzed further by
other methods.

The output consists of 900 points (30 by 30) representing the value at each point of X and Y in the
geographic area shown in the workchart window.  The X-axis is left-right in the window, pointing right, while
the Y-axis is up-down in the window, pointing down.  This means that the highest values of X and Y are found
east and south, respectively.  The latitude/longitude of each X and Y point in decimal format is shown,
followed by the analyzed value at that point.
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Here is a sample of output from GRID.TXT.

X    Y    LATITUDE LONGITUDE  VALUE
0    0    42.435   -107.721   1012.79998779
0    1    42.471   -107.141   1012.84558105
0    2    42.505   -106.560   1012.92547607
0    3    42.537   -105.979   1013.08880615

17.6. EMWIN

EMWIN (Emergency Management Weather Information Network) was introduced in 1996 to give
economically-strapped government agencies and volunteer civil defense groups a smart way of receiving
weather data with no recurring costs.  The dividend for this effort is that anyone can receive the data, not just
government agencies.  EMWIN is an outstanding source of free data that is just now beginning to mature.
Using either a police scanner or a 3' or 5' satellite dish with cheap commercially-available hardware and
software, you can tap into a tremendous amount of basic weather data and bulletins, free of cost, without tying
up a phone line.  We recommend that all amateurs look into this method of receiving data!  For value-added
products (such as radar imagery, detailed upper-level data, and so forth), EMWIN will be of little help, and you
will need to set up a separate dial-up or Internet account with a commercial data provider.

What it offers

The EMWIN system contains many categories of weather data products, with over 6,500 unique products.
Altogether, your PC will have about 5 megs of weather data at any given time.  The current EMWIN
datastream contains all generally available public products from the NWS Telecommunications Gateway,
including the following product categories: Analyses (Environmental/Air Pollution, Hydrological/Marine,
Surface, etc), Climatic Products (Daily Surface, Monthly Surface, etc), Forecasts (Aerodrome, Aviation Area,
Extended, Flash Flood Guidance, Headwater Guidance, Hydrological, Iceberg, Local/Area, Public,
Recreation/Travelers, River, Shipping Area, etc), Graphics (AFOS charts and map overlays), Images (GOES
satellite), Misc (Civil Emergency Messages, Public Weather Statements), Reports (Radar, Seismic, Synoptic,
Hydrological River, Drifting Buoy, Ice
Severe Weather Warnings, Summaries, Statements, Advisories), Warnings (Tsunami/Tide, Tornado, River
Flood, Lakeshore/Marine, Typhoon/Hurricane, Marine/Coastal Flood, Severe Thunderstorm).  There are also
graphics which include stills of hurricanes and tornadoes, scanned charts of weather symbols and tutorials,
weather screen examples found on the Internet, and so forth.

Surface METAR data for the entire United States is transmitted hourly (for which Digital Atmosphere 2.0 is
already adapted), and there are plans to broadcast upper-level rawinsonde data shortly.  When this occurs, a
Digital Atmosphere patch will be released to help accommodate it.  Transmission of raw data for broad
international regions is being planned.

OPTION #1 OF 2 — Satellite based reception.  Satellite broadcast is the main method used for
disseminating the EMWIN datastream.  The data originates from the National Weather Service, is uplinked
from Wallops Island, Virginia, and you receive it with your satellite dish.  This allows hemispheric coverage
using the GOES 8 and GOES 9 weather satellites.  GOES 8 is geostationary at subpoint 75 deg W, and GOES
9 is at 135 deg W.
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THE SCOOP.  The 9600-baud signal transmits at 1690.725 MHz, converting to 137.225 MHz, while the
weaker 1200-baud signal transmits at 1690.6 MHz, converting to 137.1 MHz.  (The EMWIN data is also
currently uplinked to the Galaxy 4 satellite by Spacecom Systems of Tulsa, OK as a public service, at 99 deg
W: Ku-band, Transponder 4, FM-FM, DFSK, 0.5425 MHz subcarrier).  Due to the success of the 9600-baud
transmission, which is already being received successfully on small 3-foot dishes, the 1200 baud EMWIN
signal on GOES 8 and 9 will be cancelled on May 31, 1998 and the 9600-baud signal will go to an even higher
power level.
WHAT YOU NEED.   Geostationary satellite signals are weak, so you'll need at least a 3-foot dish, a low-
noise adapter, a downconverter, and a radio.  All of this is an investment of about $500 to $1000.  Zephyrus
Electronics of Tulsa sells a special EMWIN receiver that basically acts as a "black box" for all of the radio
elements; you just hook one end to the satellite dish, the other to your PC COM port, and plug it in.
WHAT'S IN IT FOR YOU .  You can receive the broadcast from almost anywhere in the western hemisphere,
whether you're in an igloo in Greenland or in the swamps of Louisiana.  You're directly linked to the EMWIN
datastream and are receiving it at the full 9600 baud, meaning you get all products.  And there is no fee for
receiving the data.
THE PITFALLS.  The cost of the equipment is the only pitfall.  Furthermore, the requirement for a satellite
dish may be a problem for apartment dwellers.

OPTION #2 OF 2 — Rebroadcast reception.  Some local government agencies, mostly in the south United
States, may have an EMWIN rebroadcast in your area.
THE SCOOP.  A rebroadcast station receives the EMWIN datastream via satellite and transmits selected text,
graphics, and imagery products as an audio signal on a dedicated VHF or UHF radio frequency.  Some stations
also insert products such as school closings, road conditions, and so forth.  Users need to be within 30-60 miles
of the station.  If you're within range, EMWIN software on your PC (usually Maryland Radio Center's
Weathernode), running under Windows, receives the signal from the demodulator, stores the received weather
products onto disk, and allows you to display this information.
WHAT YOU NEED.  All you need is a cheap police scanner (even a handheld one), a $100 DM-201B
demodulator plug, and a personal computer with a spare COM port.
WHAT'S IN IT FOR YOU.  Since this is a standard radio broadcast, hardware requirements are minimal and
will save you money.  A small antenna is all that is needed, meaning that many apartment dwellers won't need
any outdoor antenna.  As with the satellite broadcast, there are no fees to get the data.
THE PITFALLS.   Aside from private and local government efforts, the only federally-funded rebroadcasts are
in the Washington, DC and Norman, OK areas.  No plans are in effect to implement government-funded
EMWIN rebroadcasts nationwide.  All other rebroadcasts that exist are the result of cooperative efforts by
public and private agencies, downlinking from the various satellites and then rebroadcasting the datastream.
Another drawback is that the datastream is usually a slow 1200 baud, reducing the number of products you can
receive.  Some of these broadcasts are possibly experimental, and could be withdrawn or discontinued at any
time.

Where to get equipment and software

Maryland Radio Center, Inc., 3394 Laurel - Ft. Meade Road, Laurel, MD  20724, (301) 725-1212,
http://www.weathernode.com.  Offers the very popular WeatherNode software and demodulator, satellite
downlink equipment for GOES, and so on

Zephyrus Electronics, Ltd, 171 S. 122 E. Avenue, Tulsa, OK  74128-2405, (918) 437-3333, http://www.big-
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z.com.  Contact Ed Covington for radio and satellite downlink equipment and packages, including the WX-1
VHF radio receiver and WeatherNode software, WX-11 system and software for GOES 8/9, with antenna,
WX-21 system and software for Galaxy-4, with antenna, WX-31 SCA radio receiver and WeatherNode
software, and WX-41 Demodulator and WeatherNode software

SkyWalker Data Systems, Inc., 7303 West 35th Str., Tulsa, OK  74107, (918) 445-1488, www.skywin.com.
Sells software and demodulators, satellite downlink equipment for GOES, and EMWIN rebroadcast equipment.
They also have a nice web site dedicated to EMWIN efforts.

Swagur Enterprises, P.O. Box 620035, Middleton, WI  53562-0035, (608) 592-7409,
http://www.execpc.com/~swagur.  Offers satellite downlink equipment for GOES, along with Maryland Radio
Center merchandise

Wilmanco, 5350 Kazuko Court, Moorpark, CA  93021, (805) 523-2390.  Contact Deke Williams for EMWIN
product information, satellite downlink equipment for GOES, etc.

Handie-Base and More Inc., 27270 E 75th St S, Broken Arrow, OK 74104, (918) 357-2139.  Sells Zephyrus
"Weather Info Net Receivers" hardware and software and amateur radio gear

Digitronics Inc., P.O. Box 937, Round Rock, TX 78680-0937, (512) 255-0664.  Sells software, demodulators,
radios, Ku and GOES satellite equipment

Weather Affirmation, L.I.C., P.O. Box 13057, Oklahoma City, OK 73113-1057, (405) 478-3590.  Sells
software, demodulators, radios, GOES satellite equipment, alphanumeric paging service and equipment

W.A.T.C.H., Weather At The Current Hour, P.O. Box 16861, 10501 East 63rd Street, Raytown, MO 64133-
0961, (816) 356-5151, http://members.aol.com/kcwx/watch.html.  Offers Maryland Radio Center
WeatherNode software and demodulator, GOES Satellite Receiving System and WeatherNode Software, and
radio receivers

DuMond R/C Service Company, 2626 Valley View, Suite #4, Farmers Branch, TX 75234  (near Dallas), (972)
241-8492, http://www.weathernode.com/dumond/index.htm.  Carries software, demodulators, radios, R/C
service, and is the national distributor for WeatherNode resellers

OnFireVB Software, (714) 831-5324, http://www.weathernode.com/onfirevb/index.htm.  Offers software to
add faxing and paging capabilities to WeatherNode

WeatherTech Systems, 412 Wooded Trail, Longview, TX 75605, (903) 663-4939,
http://www.tornadowarning.com.  Weather Technologies, 2812 North 9th Str., Canon City, CO 81212, (719)
275-0485.  Sister companies that offer the Maryland Radio Center WeatherNode Software, demodulator,
GOES satellite downlink equipment, retransmission equipment, and weather station equipment (wireless)

Ft. Worth Weather Products (Electronic Service Solutions), 3821 Del Rio Drive, Ft. Worth, TX 76133, (817)
292-6579, (888) 837-2831, (817) 292-8836 (fax), http://www.ftwtexas.com/ftwp.  Sells Maryland Radio
Center WeatherNode packages, demodulators, computer equipment, rebuilt laptops for field use, VHF receiving
and transmitting equipment
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Weather Warning Systems, 1213 James St., Buffalo, MO 65622, (417) 345-2917, http://www.jtronics.com.
Offers software, demodulators, radio equipment, GOES satellite equipment, and retransmission transmitter and
equipment

Tigertronics, 400 Daily Lane, P.O. Box 5210, Grants Pass, Oregon 97527, (541) 474-6700, (541) 474-6703
(fax), http://www.tigertronics.com.  Sells EMWIN modulators and demodulators (1200, 2400, and 9600 baud)

Affinity Computer, 197 North 20th St, Battle Creek, MI 49015, (616) 962-3740, (616) 962-3711 (fax),
http://www.battle-creek.com/affinity.  Sells EMWIN equipment

More details

The National Weather Service coordinator for the EMWIN project is Kenneth Bashford, NWS EMWIN
Project Coordinator, National Weather Service, W/OSO13, 1325 East-West Highway, SSMC2, #16358, Silver
Spring, Maryland 20910, (301) 713-0386 x191, Kenneth.Bashford@noaa.gov.  Full details about EMWIN can
be found at this web site:

http://www.nws.noaa.gov/oso/oso1/oso12/document/emwin.htm

EMWIN Rebroadcast Frequency List
Individuals should only be called for site information, not for general technical assistance.

State City Freq (MHz) Point of contact
AL Mobile 148.375/142.375 Don Arnold/Michael Redd, (601) 762-1812
AR Fayetteville 148.050 Dan Puckett, (501) 575-2905
FL Orlando 156.105 Terry Schenk, (407) 323-2500
FL St. Petersburg 139.2125 Jack Belich, (727) 893-8652
IL Wheaton 148.6375 Rich Jirsa, (630) 682-7925
KS Wichita (1) John Crosby, (316) 383-7546
MD Laurel 142.925 Maryland Radio Center, (301) 725-1212
MD Silver Spring 400.175 Ken Bashford, (301) 713-0326 x 191
MI Battle Creek 150.500 Jim Zoss, (616) 966-3550
MI Coldwater 150.500 Jim Zoss, (616) 966-3550
MI Jackson 150.500 Jim Zoss, (616) 966-3550
MI Kalamazoo 150.500 Jim Zoss, (616) 966-3550
MI Sturgis 150.500 Jim Zoss, (616) 966-3550
MO Buffalo 139.2125 Terry James, (417) 345-7330
MO Kansas City 139.2125 Larry Gonnello, Sr., (816) 274-1806
MO St. Louis 460.425 Mike Redman, (314) 889-2362
ND Bismarck 143.150 Unknown
ND Fargo 143.150 Unknown
ND Grand Forks 143.150 Jim Belles, (701) 795-5659
NE Wilber 156.105 B.J. Fictum, (402) 826-2147
OK Atoka 153.950 Eddie Cooke, (405) 889-7321
OK Durant 150.750 Johnny Shepard, (405) 924-3661
OK Enid 142.950 Mike Honigsberg, (405) 249-5969
OK Guymon 150.750 Bill Wyatt
OK Kiamichi Mtn 142.950 Keith Butterfield, (918) 669-7388
OK McAlester 148.775 Ralph Suter, (918) 426-0141
OK Miami 150.750 Terry Durborow, (918) 542-7133
OK Norman 169.025 Ken Brown, (405) 366-6587
OK Oklahoma City 150.750 Ron Hill, (405) 521-2481
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OK Ponca City 150.750 Tom Montgomery, (405) 763-8019
OK Poteau 150.750 Jim Conley, (501) 788-1833
OK Stillwater 148.775 Mike Veldman, (405) 744-8392
OK Tulsa 165.015 Jack Long, (918) 445-1488
OK Woodward 150.750 Suzanne Ellenberger, (405) 254-6728
SC Moncks Corner 141.500 Wes Blanchard, (803) 719-4167
TN Memphis (2) Steve Terry, (901) 725-8833
TX Austin 150.435 Larry Jentry, (512) 424-2208/2422
TX College Station (3) Lance Parr, (409) 775-7014/779-5367
TX Corpus Christi 150.435 Henry Wood, South Texas Electric Coop.
TX Dallas 150.435 Fred Varian, (214) 464-6084
TX Houston 150.435 Jim Robinson, (713) 957-7498
TX LaFeria 150.435 Mike Partusch
TX Longvie w 150.435 Jim Cox, (903) 663-4939
TX Port Lavaca 150.435 Billy Zwerschke, EMC Calhoun County
TX Temple 150.435 Gerald Moore, (254) 773-1101
TX Victoria 150.435 South Texas Electric Coop.
TX Burkburnett 150.435 Dave Spitler, (940) 569-4179
WY Cheyenne 141.300 Ward Noakes, (307) 777-4445
_______________________________________________

(1) - Off-air due to interference.
(2) - Broadcasts on 67 kHz subcarrier on 89.3 MHz.  Requires subcarrier (SCA) receiver.
(3) - Broadcasts on 67 kHz subcarrier on 89.1 MHz.  Requires subcarrier (SCA) receiver.

17.7. About weather data

Every day, nearly ten thousand weather stations across the world disseminate weather observations.  These
observations are taken according to standards and formats laid out by the World Meteorological Organization
(WMO), a United Nations organization based in Geneva that facilitates international cooperation in
meteorology and hydrology.  In 1961 the WMO developed the concept of the World Weather Watch
(WWW), whose goal is to keep the entire atmosphere under continuous surveillance.  The nuts and bolts of
the WWW are laid out in its Global Observation System (GOS), and data is used, reprocessed, and shared
according to the WWW Global Data Processing System (GDPS).  However the technical breakthrough that
makes this all possible is the Global Telecommunications System (GTS).  This is a permanent
communications network that facilitates the flow of global weather information.

The GTS's main link is the Main Telecommunications Network (MTN), which links Melbourne, Moscow, and
Washington.  Connected to the MTN is a series of regional networks, known as Regional Meteorological
Telecommunications Networks (RMTNs), located at Algiers, Beijing, Bracknell, Brasilia, Buenos Aires, Cairo,
Dakar, Jeddah, Maracay (Venezuela), Nairobi, New Delhi, Norrkoping (Sweden), Offenbach, Prague, Rome,
Sofia, Tokyo, Toulouse (France), and Wellington.  Within each country is its own National Meteorological
Telecommunications Network (NMTN).  There are also specialized networks connected to the GTS, such as
the U.S. Air Force's Global Weather Intercept Program, which uses powerful receivers to collect and share
weather data from politically and economically isolated regions.

The weather data is shared among WMO member states, who in turn set policy and procedures for sharing
data with the private sector.  In the United States, the data is distributed to the public through the National
Weather Service's NOAAPORT and FOS data feeds.  Much of this data reaches the Internet and is available
free of charge.  This puts affordable forecasting in the hands of millions of American citizens and business
owners, boosting economic productivity and earnings on a national scale.  Unfortunately in Europe, Asia,
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South America, and even Canada, long-standing ultra-conservative government policies make the data
available only to pilots, mariners, and big spenders (i.e. large corporations).  The Internet is the ultimate
GTS, though, and its presence has done much to break down these economic barriers.

Surface weather data is transmitted in one of two main formats: METAR and SYNOP.  The METAR format is
used primarily at airports, and has an hourly observation cycle.  It gives us the best picture of weather
conditions in North America, Europe, and the Pacific Rim.  The METAR format is fairly readable and uses
station identifiers prescribed by the International Civil Aeronautical Organization (ICAO).  The SYNOP format
is more detailed and uses extensive numerical coding, using numerical station identifiers prescribed by the
WMO, and typically has a 6-hour cycle.  It gives us the best picture of weather in South America, Africa,
Asia, Australia, and Antarctica, where "meteorological observatories" tend to be bona fide weather offices
rather than control towers or flight service stations.

Upper air data from balloon launches is taken worldwide twice a day.  It is transmitted in TEMP format, also
known as "TTAA", "TTBB", "PPBB format", and "radiosonde format".  This format uses extensive numerical
coding.  Availability of upper air data is fairly good across much of the northern hemisphere, but is seriously
lacking in the southern hemisphere where satellite-based sensors are widely used to initialize computer
model forecasts.

Since much of this data is freely available from a variety of sources, Digital Atmosphere gives users a
flexible tool for graphically importing and displaying all of the different weather data formats provided by the
GTS.

17.8. Raw data samples

Listed here are some examples of what kinds of data will be imported by Digital Atmosphere, depending on
your checkmarks on the status panel.  You can refer to these examples if you have any trouble getting Digital
Atmosphere to read something or are unsure of what a particular product or bulletin should look like.

Airways (SAO) data

This is the backbone of weather observation code in the United States and Canada.
It is issued hourly from thousands of weather stations.  A sample report will
look like this:

JFK SA 1150 250 SCT 7 113/44/21/2513/989=

SD RAREP radar reports

Also called hourly radar reports, RAREPS, and SD reports.  Early versions of
Digital Atmosphere do not import this type of data.  Radar reports come from
about 100 stations around the country.  A few years ago, they were typed up by
humans, but most of them are now centrally generated by computer based on images
from NEXRAD radar sites around the country.  This is what a radar report looks
like:

MCI 0225 CELLS TRW/NEW 250/195 D10 C2330 MT 300
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FD winds aloft data

This is not an analysis of real conditions; rather it is numerical output from
the National Centers for Environmental Prediction (formerly NMC) in Washington,
DC.  It is used primarily for aviation forecasting purposes, consisting of a
coded wind and temperature forecast at 12 and 24 hours into the future.
Nevertheless, it makes excellent forecasting charts in Digital Atmosphere.

      For      Hours
ID   Use Z    From Now  3000    6000    9000   12000   18000   24000
2XG  09-18    00-09     3613 2911+06 2520+02 2430-03 2342-15 2462-26

Rawinsonde data

Also called TTAA data.  This is the backbone of upper-air observation reports,
sent twice daily from hundreds of stations worldwide (several dozen in the United
States alone).  It is a highly numerical, coded set of data that is used
extensively in meteorological operations and is used as input into the numerical
forecast models.  Here's an example of what it looks like:

72558 TTAA  69121 72558 99973 00821 30002 00130 ///// /////
92762 01611 03014 85444 01850 00521 70993 04159 30025 50559  etc..

Weather watches

Also called SELS watches, watch boxes, or even WWUS9 KMKC.  This is an English
bulletin produced by forecasters at the Storm Prediction Center (formerly NSSFC,
the National Severe Storms Forecast Center).

WWUS9 KMKC 141239
 SEL7
 MKC WW 141239
 KSZ000-142000-
 BULLETIN - IMMEDIATE BROADCAST REQUESTED
 SEVERE THUNDERSTORM WATCH NUMBER 77
 NATIONAL WEATHER SERVICE KANSAS CITY MO
 639  AM CST THU MAR 14 1996
 .A..THE STORM PREDICTION CENTER HAS ISSUED A SEVERE THUNDERSTORM WATCH FOR
      PARTS OF EAST-CENTRAL AND SOUTHEASTERN KANSAS
 EFFECTIVE THIS THURSDAY MORNING AND AFTERNOON UNTIL 200 PM CST.
 LARGE HAIL...DANGEROUS LIGHTNING AND DAMAGING THUNDERSTORM WINDS
 ARE POSSIBLE IN THESE AREAS.
 THE SEVERE THUNDERSTORM WATCH AREA IS ALONG AND 45 STATUTE MILES
 NORTH AND SOUTH OF A LINE FROM 45 MILES WEST OF EMPORIA KANSAS TO
 45 MILES EAST OF CHANUTE KANSAS.

Convective outlook

The convective outlook is a bulletin produced by forecasters at the Storm
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Prediction Center (formerly NSSFC, the National Severe Storms Forecast Center),
and intended for use by other National Weather Service meteorologists.  Two are
produced; one for the "today" time frame (Day 1), and another for the "tomorrow"
time frame (Day 2).  It is one of the best sources of forecast information on the
potential for severe thunderstorms.

ACUS1 KMKC 141441
 SWODY1
 MKC AC 141441
 CONVECTIVE OUTLOOK...REF AFOS NMCGPH94O.
 VALID 141500Z - 151200Z
 REF WW NUMBER 0077...VALID TIL 2000Z
 THERE IS A SLGT RISK OF SVR TSTMS TO THE RIGHT OF A LINE FROM PGO
 OKC 30 NNE P28 35 ESE SLN OJC JEF MVN EVV BWG BNA MEM PBF PGO.
 GEN TSTMS ARE FCST TO THE RIGHT OF A LINE FROM OXR FAT TPH ELY
 15 NW PUC CAG LIC HLC FNB PIA FWA YNG DUJ DCA 25 W RIC RDU AND CBM
 TXK FSI 60 NNE AMA RTN 10 SE ABQ 30 SSW DMN.

Model output data

These are numerical output bulletins from the National Center for Environmental
Prediction (NCEP, formerly known as NMC), which describe forecast parameters at
different locations around the country.  These bulletins are available on most
weather databases.  For those who want the "real thing" from the supercomputers,
full-fledged model output is in a binary format known as GRIB; these files are
huge, hard to obtain, and are not importable into Digital Atmosphere at this
time.

652
FOUS72 KWBC 201200
OUTPUT FROM ETA 12Z JAN 20 96
TTPTTR1R2R3 VVVLI PSDDFF HHT1T3T5   TTPTTR1R2R3 VVVLI PSDDFF HHT1T3T5
SEA//928157 03005 131714 30989795   GEG//894554 03407 152312 25969490
06021947750 05304 021921 34009996   06000877354 02207 101416 29979693
12010957438 -1802 992315 30019995   12014928044 03104 021809 32999795
18006957340 01501 992612 30019995   18000957342 02502 012208 30999895
24005977941 02601 012517 28019995   24011957646 02502 022516 29999794
30010967941 01201 042819 27019894   30000957544 01001 042513 27009894
36005856037 -0202 102814 26019894   36004938141 01501 072607 27009794
42000794430 -0906 152811 25019793   42003837138 00703 123009 26009693
48000783339 -0510 182710 27009792   48000614637 00007 173109 24999491

17.9. Version change summaries

VERSION 2000 - V1.0a maintenance (4/16/01)
• Added "mixed" grid option in Preferences > Maps.
• Adds revised station tables.

VERSION 2000 - V1.0a (1/20/01)
• Eliminates problem reported in V1.0 with left third of screen occasionally being blotted out at random.
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• Analysis > Export Last Analysis has been removed and in its place the text output is always written to
GRID.TXT.

• Added SLEEP command to Scripting (see Appendix / Scripting section).
• Corrected program so that a timer script will only execute ONCE per scheduled time interval.  The

previous version would keep re-executing the script as long as the current time was the scheduled
execution time.

• Added rule file (DIGATMOS.RUL) with rules for importing observations.
• Minor enhancements to tracking of metric vs. English units for purposes of product labelling
• Added COM4 to COM8 in EMWIN Ingest
• Allows up to 1000 stations in DIGATMOS.PRI priority table
• Adds Map > Import command to allow satellite photos, etc, to be "underlaid"
• Map > Generate By Lat/Lon now allows latitude, longitude, and zoom to be numerically tweaked and

advanced settings to be "reset" with one button click.
• Enhanced fills for Australia
• Script timer has been renamed to "Scheduler".
• Scheduler now allows multiple script names along with the usual multiple execution times; documentation

has been added in this manual under Appendix / Scripting.
• Digital Atmosphere now caches a map as soon as it is created so that it will be available on reloading

Digital Atmosphere (this applies both in Generate by Lat/Long and Generate dropdown menu).
• Vorticity and divergence now color appropriately as in earlier versions (with inverted shades for negative

divergence).  A solid zero-line has also been added.
• Divergence and vorticity have now been added to the Analysis > Wind menu for more convenient access.
• Divergence has been recalibrated and plots in 10**-6 m-2
• A bug in the scripting which prevented wind analysis (grids and streamlines) from plotting is now fixed.
• BETA 1/21/01 FIXES
• Problem with Map > Save in 1/20/01 release fixed
• Conflict with Alt- shortcut keys for main menu fixed
• Added script command SFCPLOTMODEL for loading surface plot models (see Appendix / Scripting)
• Script commands for convective outlooks and MVFR/IFR depiction (dy1, dy2, cig) added to

documentation.
• Printing capabilities have been fully restored and diagnostic gridboxes on printouts are eliminated.  Print

button has been fixed.

VERSION 2000 - V1.0 (12/3/00):
• Option added to File > Preferences > Analysis to allow transparent fonts
• Slight changes made to remove plotting of extra pixel line at bottom of NMC fonts
• Errors under Win 98 with File > Get Archived Data and EMWIN ZIS extraction fixed
• EMWIN ingest capabilities improved with regards to extraction of ZIS files (previous versions were error-

prone)
• Map > Generate by Station fixed
• Option for 1000-500 mb thickness added in File > Preferences > Contours
• MVFR/IFR contour labels were invisible with certain contour font combinations; this is fixed

VERSION 2000 beta 3 (12/2/00):
• NEW FEATURES . . . . .
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• Added EMWIN ingest engine (in EMWIN > Ingest)
• EMWIN upper air (upr*.*) added to File > Import EMWIN data
• Added command to clear out data directory (File > Clear data directory)
• Frontal workchart toolbox added (in Data > Frontal bulletins and right-click menu)
• 1000-500 mb thickness added (in Analysis > Temperature > Thickness); upper air data is required
• Calculator now allows station pressure, wind chill, and heat index calculations entirely in metric
• Replaced .CXN, .CXP county name label file with editable .CXT file
• Moved county name label for Ventura County (California) westward slightly
• Added aspect ratio to Map > Generate Map
• Color palettes in Preferences > Colors are now saved and loaded with maps (with .ATP file)
• Added more information in help file
• Added Dutch weather station corrections in DIGATMOS.STN
• Drop a file from Windows explorer onto a running copy of Digital Atmosphere to import that file
• When a convective outlook indicates "NO TSTMS" this is plotted on the map
• Print capability re-enabled (was disabled during beta tests)
• ERROR FIXES
• Error: File not found error in File > Get Archive Data / FIXED
• Error: Old links for UNCA in DIGATMOS.SLZ Internet retrieval table / FIXED
• Error: Altimeter setting H/L values round to nearest inch / FIXED
• Error: Map > Generate Map "offset settings may produce bad results / FIXED
• Error: If edge of Earth is seen in a generated map, ocean fills do not work correctly / FIXED
• Error: DRSN (drifting snow) in METAR not properly recognized by Dig Atm / FIXED
• Error: Help does not work for Map > Information button / FIXED
• Error: Map > Information produces some bad results / FIXED
• Error: QC rubberband keeps appearing erratically / FIXED; NOW DISAPPEARS ON RELEASE OF

MOUSECLICK
• Error: When cancelling in Map > Generate map, corrupt results occur / FIXED
• COULD NOT DUPLICATE . . .
• Fronts are inconsistently erased / COULD NOT DUPLICATE
• Climatology contour of Europe January mean high temperature erratic / COULD NOT DUPLICATE
• Problem: Pressure tendency shows labels only for positive numbers / COULD NOT DUPLICATE
• COULD NOT FIX YET . . . WILL ADDRESS IN UPCOMING VERSIONS . . .
• Problem: Timer does not work when a screensaver gets focus / NO SOLUTION
• Problem: Europe army weather server causes DA to hang / NO SOLUTION YET
• Problems with importing radar when it appears after surface data in raw data file / NO SOLUTION YET
• Problems with 333 group SYNOP rainfall when a 111 6xxxx group is present / NO SOLUTION YET
• Some problems that have been reported with plotting of warnings / NO SOLUTION YET

VERSION 2000 beta 2 (11/25/00):
• Sea data now nullified in METAR reports so garbage doesn't appear in station plots with sea elements
• Beta bug with Analysis > Wind > Wind Speed not working is fixed
• Celsius/English beta problems fixed (in plotting and climatology extract)
• Beta testers need to check their station plot elements and change TEMP/DWPT/VIS to match valid

choices
• Elevation can now be plotted in meters or feet according to English/metric preferences
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• Climatology > Extract Data now gives option of plotting the data or analyzing it
• Additional options in File > Preferences > Analysis to let users specify isopleth fonts as "small" and/or

"negative"
• Added remaining font files as well as font preferences
• Fixed problem with streamline thicknesses changing "randomly"
• Added option in File > Preferences > Meteorological > "Geopotential height in full meters only"
• Geostrophic height contouring algorithms improved to eliminate irregularities along margins
• Added upper highs/lows
• Added tutorial directory with tutorial files
• Re-instated and improved serial/key routines

VERSION 2000 beta 1 (11/11/00):
• Added photorealistic topography
• Fixed zoom bar on map settings panel not working
• Added file drag and drop capability from Windows Explorer
• Fixed outer space fill
• Fixed "Quit Searching" in Climatology graph
• Added NCEP legacy fonts to isoplething routines for labelling of lines
• Added "Thick Contours" option in File > Preferences > Analysis (makes isopleths twice as wide)
• Added easter egg (Shift-Ctrl-F7)
• Changed FTP timeout from 1000 to 15 seconds, so a quicker response occurs if a connection is hung
• Vastly improved isentropic analysis (in "Level" dropdown on toolbar)
• Added freeform horizontal analysis (in "Level" dropdown on toolbar)
• Corrected and improved 3-D atmosphere build (in Analysis menu)
• Reinstated and improved roaming sounding
• Satellite wind observation import provided
• Slight bug in contouring fixed (prevented random charts from drawing any contour lines)
• Changed "Wind Speed" analysis so that it uses a gridded x/y wind field for better accuracy
• Documentation provided in dual formats: context-sensitive Windows Help and PDF format.
• Numerous additions, edits, and improvements to help documentation.
• Added capability for user to modify Gradient Fills in analysis (in File > Preferences > Misc).
• Added capability to import and plot SATOB observations (NOAA/NESDIS format).
• Added scripting commands for ISOPLETH and GRADIENT
• Added extra surface station plot element which is available to user (in extreme lower left of plot)
• Added import of sea surface data from SYNOP reports
• Changes have been made to allow saving and loading of upper plot models
• Added capability to plot h and Nh code forms from SYNOP; corresponding additions in Preferences
• Changed temperature and precipitation units to a single "English or metric" choice
• Added streamlines
• Added capability to plot fronts, highs, and lows from ASUS1 KWBC bulletin

VERSION 2.3.3 (MAINTENANCE RELEASE) — BUILD #1015 (10/1/99):
Quality control was improved to change point/point clicking to mouse dragging.  A distance meter enhanced
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this capability.

VERSION 2.3.2 (MAINTENANCE RELEASE) — BUILD #989 (9/23/99):
The main purpose of this release was to get rid of a memory violation reported by six users (which consisted of
various forms of "Invalid pointer" and "Access violation" errors when Digital Atmosphere was started).  This
was finally traced to coding errors in the creation of new maps.  In addition to a fix for the problem, this release
has some additional enhancements.
* "Invalid pointer" and "access violation" errors eliminated.
* Status bar can be made visible or non-visible (View > Status Bar).
* The data directory is now *always* the "data" subdirectory under Digital Atmosphere.  Any data should
always be placed in here unless it is being received by EMWIN or is a single file to be chosen manually by the
user.
* In the synoptic decoder, dewpoints are now omitted if they exceed the temperature.
* File > Retrieve Data used to not process warning data, while File > Import EMWIN Directory, File > Import
File, and the schedulers did.  This has been fixed.
* The number of importable files during one pass has been increased from 100 to 150 files.
* METAR reports without times but times in FOS headers are now parsed properly.
* Font face/sizes in EMWIN Bulletins and View Raw Data can now be specified in Preferences > Fonts.
* A new feature, Map > Information, provides detailed information about the map projection currently shown.
* Another new feature, "Show distance", allows users to determine the distance between two points on the map.
Identify each of the two points by right-clicking and choosing "Set point", then choose "Show distance".  The
distance will be shown in nm, sm, and km.
* Under the View menu, the selections for Speed Buttons, Time Toolbar, Wind Toolbar, and Status Bar are
saved when the user exits the program, then restored when the program is started again.

VERSION 2.3.1 (MAINTENANCE RELEASE)  —  BUILD #930 (8/29/99):
* Fixed problem where 24-hr precipitation data in METAR reports wasn't recognized.
* Readme file updated with new information.
* Error message during Emwin Scheduler when no warning files are found has been eliminated.
* Map tiles have been consolidated from 365 down to 25 files, saving 10 MB of disk space when installed
(fewer wasted blocks in the file allocation tables).  Some users may see a slight slowdown when generating new
maps.  The new tiles are binary and cannot be edited.  Users who need to add map information should use the
more convenient Custom Overlay files (see the Data chapter under Overlay Custom Overlay).

VERSION 2.3 FINAL  —  BUILD #918 (8/20/99):
* Added two binary files required for program operation (DIGATMOS.GCI and OUTPUT.WRQ).
* Adjusted effects of "smart visibility plot" to only take effect when left-center slot contains visibility data,
weather symbols, or a blank entry.  This way other data (dewpoints, etc) residing in this slot does not get
blanked out when no weather is present.  The user may still have to adjust the contents of the far left slot for
optimum appearance.
* File > Quality Control now allows editing of pressure tendency, pressure trend, precipitation amount and
period, cloud codes, and mb and ft levels.
* Inability of File > Preferences > Contours settings to save has been rectified; settings will always be saved
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whenever "Ok" is clicked.
* Fixed a problem with inability to do station plots of FD data; and inability to plot 24 hour FD contours/grids.
* Added code that prevents "stack overflow error" and execution of warning import when OUTPUT.WRQ is
missing.
* Precipitation contours are now indicated in the legend, along with the units of measure (inches or mm).
* In Internet > Retrieve Data, an "Uncheck All" button has been added.

BUILD #907 (8/18/99):
* AIREP reports have been enabled.  These are usually found in upper air files and can help fill in wind
patterns across oceanic regions.
* "Round AIREP reports within xxx mb of a standard level" has been added.  When checked, and the user
produces a constant pressure map, Digital Atmosphere will include all AIREP reports that are within the
specified number of millibars of the constant pressure level being used (i.e. an AIREP at 278 mb will be
included in a 300 mb plot/contour if the box is checked and the value is 22 mb or greater).  If unchecked, then
all reports have to be exactly equal to the constant pressure level being used (i.e. an AIREP at 492 mb would
not be included in a 500 mb chart).  This will help users control the quality and variety of data being included
in upper air charts.
*  "Data > View Sounding" and map popup menu item "Show Sounding" have been re-enabled.
*  About 25 new EMWIN text products added to the DIGATMOS.EMP EMWIN product lookup list.  This
will add many new product descriptions to "EMWIN > Get EMWIN Bulletin".
* Digital Atmosphere now recognizes "SN" intermediate synoptic header in addition to "SA" and "SM" when
determining times for synoptic reports.  (Thanks to Hans-Stefan Lichius)
* Preferences > Meteorological option for "Round synoptic reports to nearest 6 hours when importing" has been
corrected to "round to nearest 3 hours".  Rounding operations have always been to nearest 3 hours.
* Data > Warnings has been adjusted to import warning datasets correctly.  EMWIN users who keep seeing
outdated warnings on their maps should change the purge intervals in their EMWIN reception software.
* The option "Default data time selection" in File > Preferences > General is now functional again.

BUILD #885 (8/16/99):
* If main window is maximized, the window is no longer resized when a new chart is loaded.
* Emwin Scheduler -- on receipt of new EMWIN data, the map did not erase; this has been fixed.
* MVFR/IFR contour analysis has been fixed.
* An "Access Violation" that popped up during import of some RCM (NEXRAD) datasets was fixed by adding
code to quality-check incoming data.  (Thanks in part to Wayne Cotterly
* Some problems with precipitation contouring in synoptic reports was fixed; additional code was written so
that Digital Atmosphere could differentiate missing reports from zero and zero from nonzero amounts.  (Thanks
to Hans-Stefan Lichius)
* In an effort to consolidate internal data processing, upper air split files (OUTPUT.H00, H85, F18, etc) are no
longer used.  This will solve QC problems where RAOB reports can't be deleted.  Users with slow computers
will notice delays when plotting rawinsonde reports (due to the large size of the upper air output file).  Since the
code has been rewritten slightly there is a slight chance this fix could introduce errors, so testers should note
any plots or contours that "don't seem to do anything".  (Thanks to Phil Rider)
* Rawinsonde data elements with solidii encoded anywhere in the element (rather than just the first position) are
thrown out.  For example, Katmandu was encoding heights like "5085/", corrupting upper air contours.
* Scalars (temperature, wind speed, etc) could not be contoured with FD data due to an unwanted line of test
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code.  This has been removed.  (Thanks to Phil Rider)
* Various buoys, such as those in the Arctic ocean, omit the wind (0ddff) group, confusing Digital Atmosphere
and making it plot erroneous winds and sky condition.  This has been fixed.
* EMWIN imagewrites were saving to the DA directory, not the directory specified in Preferences.  Fixed.
(Thanks to Jesse Ferrell)
* Scheduled internet retrieval was not making its panel appear during retrieval; this has been fixed.  (Thanks to
Wayne Cotterly)
* Derived fields (vorticity and convergence) are now functional.
* Radar status annotations now work with RCM data.  (Thanks to Jesse Ferrell)
* TVS signature will always be plotted in red.  (Thanks to Jesse Ferrell)
* A "Preferences" speed button has been added.  (Thanks to George Sobala)
* On the wind toolbar, wind vectors (as opposed to just barbs) now work again.  (Thanks to George Sobala)
* When any map is loaded, all settings (not just lat/long/zoom) are transferred to the Generate Map panel in
case the user wants to tweak the map.  Also fixed the inverted transferred latitude.  (Thanks to George Phillips)
* Menu item "View > Remove last product" has been added so that you can delete the last contour or plot.
* I could not duplicate the "Invalid filename" on "save station plot" in Preferences.  For users that continue to
have problems, please go to the Preferences > Misc tab and check "Diagnostic -- Show filename when
loading/saving station plots".  Then when you save or load the station plot, report the message that it shows.
* SPECIAL NOTES: Users may mistake station plot minus signs as decimal points, particularly with pressure
tendency.

BUILD # 864 (8/08/99):
* Added a "Generate Map" dropdown box on the Speed Button toolbar.  Clicking on any of these entries causes
a map for the area to be generated, using the default map width/height specified in File/Preferences/Map.  The
entries for the "Generate Map" dropdown box come from a new file called DIGATMOS.MSE.  Users may
freely modify this file.  Column 1-3 is for the latitude (south hemisphere negative).  Column 5-8 is for the
longitude (west hemisphere negative).  Column 10-14 is for the zoom width in miles.  Column 15-65 is for the
descriptive name.  Users may add saved maps to this list by simply leaving the first 3 columns blank, then for a
descriptive name use an asterisk followed by the filename (without any dot or extensions), for example,
*mymap .
* Added a Preferences entry under the Map tab for Default Width and Default Height.  This specifies default
image size settings for new maps that will be generated.
* Reworked the Preferences/Station Plot/"Save" segment, as some users have reported that the plot model is
incorrectly saved.  Could not duplicate this problem but made adjustments to code.
* Eliminated problems with importing FD and Model data (this was a consequence of improvements made to
the data import algorithms in Build #849.
* Build number now shown on splash screen.
* PROBLEMS REMAINING: Internet links except for Retrieve Data are dead; locks up using data retrieval
window with FSU SAO ticked.
* SUMMARY:  New files required to run this build:  DIGATMOS.MSE

BUILD # 849 (8/6/99):
* Synoptic and buoy recognition module reworked.  You should see a greater number of synoptic observations,
and especially buoy (ZZYY) observations that now work.  Please let me know if you see any problems.
* Eliminated "Access Violation" during View Raw Data/Find.  Corrected code to link in a missing component.
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(Thanks to John Glaveskas, Trevor Cousens, Geert Vandebrande)
* Legend was not cleared when generating a new chart; this has been fixed.  (Thanks to Geert Vandebrande)
* Eliminated problems with Digital Atmosphere resolving FD data times.  Corrected code to properly evaluate
FD forecast hours.  (Thanks to John Souza)
* Quality control has been fixed.  Some stations would not get QC'd, and this was due to a problem in the
mouse coordinate variables and has been fixed.  (Thanks to Michael Welch and Trevor Cousens)
* Relative humidity in station plots produced an invalid floating point operation; this was fixed. (Thanks to
Michael Welch)
* Television plot city font size was not set correctly; this has been fixed but not verified.  (Thanks to Jesse
Ferrell)
* The location to set Television font colors was not obvious.  A note has been placed in "Preferences" under
"Fonts" and in the User Manual to indicate where this is done.  (Thanks to Robert Dale)
* Television plots are now centered horizontally.  Also a bug where observation times were being ignored in
television plots, leading to blank maps, has been fixed.  (Thanks to Robert Dale)
* Removed "Status window on top" menu item, which is obsolete.  (Thanks to Robert Dale).
* An error was found in the synoptic cloud code import; this was fixed. (Thanks to Michael Welch)
* Stations without sky condition report plotted without a center symbol; a plus is now plotted at the observation
location.  The newest (8/05/99 or later) version of DIGATMOS.SYI is required.
* Topography now works.  (Thanks to Hendricus Lulofs and Trevor Cousens)
* At the end of a File/RecompileTables operation it seems that Windows locks up.  This is because Digital
Atmosphere is sorting the Warnings table.  A progress message has been added, and the status window no
longer truncates long progress messages.  The ICAO/WMO sorting algorithm has also been speeded up.
(Thanks to John Glaveskas)
* Large maps were not framed correctly when loading such as at startup.  This has been fixed by forcing the
image object width to equal the bitmap width.  (Thanks to Hendricus Lulofs and Geert Vandebrande)
* Internet retrieval list (DIGATMOS.SLZ) enhancements: Added UCAR upper air (thanks to Robert Schmidt),
added Albany buoy.
* Digital Atmosphere now parses the RCM file when the EMWIN Scheduler is running.  (Thanks to Robert
Dale)
* User must specify the EMWIN directory for warnings; this allows compatibility with software such as
RealEMWIN.  This option is in File/Preferences/General.  (Thanks to Robert Dale)
* Speed button toolbar can now be hidden or unhidden (see View menu item).  (Thanks to Robert Schmidt).
* All fonts used in contouring operations are now set in Preferences, Fonts under "Annotations".  Only the font
type is used; the size is ignored.  (Thanks to Robert Schmidt)
* Internet sites which don't report the filesize in some headers (such as IWIN and FSU) no longer produce
unusual progress results during download; program now reports "unknown".  (Thanks to Verna Young and
Mark Hayes)
* Digital Atmosphere no longer tries to resize itself after generating a new map when maximized.  (Thanks to
Robert Dale)
* VARIOUS ISSUES STILL TO BE RESOLVED: "Bitmap image not valid" will still appear when viewing
EMWIN products -- this is because the functionality has been temporarily disabled; geostrophic wind field
feathers not available; SKEW-T, CAPE and other extended analysis stuff has not been restored yet; will not
import a V2.2 map; Data/Warning causes "Illegal function" error; hidden toolbars reappear at startup (this is
not a bug but an item suggested and will be evaluated); unusually high heights (above 580 dam) such as with
what we are seeing this summer are inverted to 480+ dam.
* OTHER NOTES.  I am on the lookout for errors where a data directory, data product, or error message
shows a path with two solidii, for example, c:\program_files\digatm\data\\ or c:\digatm\data\\infile.txt.  This has
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cropped up a couple of times but I haven't found the source of it.  It will cause non-found datafile errors and so
forth.

CHANGES FOR V2.2 to V2.3 BETA INITIAL (JUNE 1999)

*  Multiple chart forms eliminated .  This was performed to simplify numerous algorithms within Digital
Atmosphere, reduce the complexity of our source code, and enable further development of other key areas of
the program.  The vast majority of users indicated that they preferred one map at a time.
*  Status panel deleted and toolbars added.  It was decided that the status panel, which has always been a
part of Digital Atmosphere, was too awkward, cluttered, and frequently got in the way.  It has been replaced by
two toolbars: a time toolbar and a wind toolbar.  They can be hidden or displayed in the "View" dropdown
menu.
*  Tab ordering improved.  The tabbing order of controls in the map customization screens were improved so
that navigation without the mouse would be much easier.
*  Automated version numbering.  This is mostly an internal change that isn't of interest to most users.
Version and build numbers listed on the Splash Screen and About Screen are now extracted directly from the
application file.  This is the same data seen when you choose "Properties" and "Version" from Windows
Explorer.
*  A new registration authentication scheme has been enabled.  To register your copy, you will need to go to
Help, Register to find out their individual serial number, then contact us for a key number.  Note that this
keying scheme is subject to change.
*  RCM NEXRAD radar parsing has been vastly improved.  The algorithms were edited, tested, and
tweaked to give a high level of competency in parsing NEXRAD RCM data.  Furthermore the algorithms
extract cell, mesocyclone, TVS, hail, and wind data from the datasets.  RCM data is not available at most
weather data servers, but it can be found in the SAORCMUS.TXT file regularly transmitted by EMWIN (this
is also available at http://emwin.cira.colostate.edu/rxfiles/SAORCMUS.TXT, which has been placed in the
new Internet data retrieval panel).
*  New NEXRAD site codes added to the station tables.  About 40 new RCM station codes have been added.
This fills in many radar gaps that existed in earlier Digital Atmosphere versions.
*  NEXRAD VAD/VWP wind parsing has been added.  Simply import an RCM file and plot using
"Analysis" for time and a valid FL for level.  These reports can then be plotted or analyzed.  Although this is an
incredible tool for filling in gaps between rawinsonde stations and rawinsonde times, NEXRAD winds are
usually missing where there are no droplets, dust, insects, or birds to yield a velocity measurement (such as
high aloft or in dry regions).
*  The level selector can contain FD winds, RCM winds, or both.  This is chosen with the "R", "F", and
"All" buttons next to the level selector.  Use it when, for example, you want to look at NEXRAD VAD/VWP
winds aloft and don't want to accidentally click on an FD wind level.  You would simply hit the "R" button to
pare down the list.
*  Major improvements in the Internet data retrieval panel.  The panel now uses true HTTP binary transfer
to connect with weather data sites, delivering much swifter, more reliable data downloads than in previous
Digital Atmosphere versions.  It also allows FTP sites to be accessed.  For those few users who need to specify
a port number and/or user ID & password, you must append the User ID, Password, and Port to the end, all
separated with "$$".  Example: ftp://ftp.mysite.com/pub/data.txt$$myusername$$mypassword$$port ).  If you
decide to specify a port number, you must specify a username and ID.
*  New formats added to "Export map" .  In earlier versions you could save your map as a BMP or a JPG.
In addition to those, you can now save PCX, PNG, and TIF (uncompressed and packbits) formats.  The
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packbits TIF format generally offers the best format for desktop publishing purposes.  The GIF and LZW TIF
formats were not included because they are proprietary technologies and require licensing from Unisys.
*  Map can be copied to the clipboard.  This can be found in the menu under "Map" and "Copy to
Clipboard".  When the map is in the clipboard it can be pasted into other Windows applications.
*  Fonts in Preferences improved.  The interface has been changed slightly, and we have added the ability to
let you set "annotations" fonts, which are seen when you plot custom map points and city overlays, and county
name fonts.
*  County name overlays added.  You can now add county names on your map.  The county name text will be
truncated automatically according to the map scale (to see more of each county name, make a more-zoomed in
map).  The font color is controlled by the "county overlay" setting in Preferences/Map and the font name/size is
controlled by the "county name" setting in Preferences/Fonts.
*  Custom geography added.  This is done in the WeatherGraphix style, with custom geography residing in
DIGATMOS.PLR.  Edit this file to make changes.  Note that longitude in the west hemisphere is negative; files
imported from WeatherGraphix will need to have the longitude signs inverted.  The color of the line is
controlled by the "roads and custom lines" setting in Preferences/Map.
*  Contour labelling algorithm improved .  Previous versions of Digital Atmosphere plotted isopleth labels
only at the chart edges, making closed contours difficult to interpret.  Digital Atmosphere will now plot labels
in many closed contour patterns.
*  Data tables now produced.  These are stored in OUTPUT.SFC (surface) and OUTPUT.UPR (upper) every
time you import data.  These tables can be parsed using your own applications or can be brought into
spreadsheets and databases.
*  Precipitation data now available.  Data from the synoptic 6xxxx group is now imported into Digital
Atmosphere and can be plotted or contoured.  Note that most U.S. and Canada stations report 6-hour
precipitation.
*  Precipitation inches/millimeters choice added in Preferences/Meteorological.  This applies to
precipitation plots and contours.
*  Pressure tendency, and low, middle, and high cloud symbols have been added.  These can be plotted if
they are part of the surface plot in Preferences/Station Plots.  The pressure tendency can be analyzed and
contoured.
*  Maps can be automatically exported when the program is in automatic mode.  You simply specify the
target file in Preferences/General under Autosave (a complete directory and filename is required), and check the
Autosave box.  The graphics type is determined by the extension of your filename (BMP, JPG, PNG, PCX, or
TIF).  Every time the map is refreshed automatically, the completed map will be exported to your target file.
*  Previous versions of Digital Atmosphere had trouble identifying some warnings.  This occurred when
warning bulletins did not end with the "NNNN" termination sequence (this recently began appearing on
EMWIN); therefore warnings piled up in the first warning text slot.  This has been fixed; a new header now can
substitute for an "NNNN" termination sequence.

CHANGES FOR V2.1C BETA to V2.2 (FEBRUARY 1999)

*  Preferences buttons for the FOUS level have been added.  This is located in Preferences, Meteorological.
This allows a level aloft (such as the T3 and T5, and R2 and R3 levels) to be plotted or analyzed.  Note that
since the T3/R2 and T5/R3 levels aren't exactly the same, you should avoid calculations which cause the
temperature and relative humidity to be combined (for example, dewpoint analyses).
*  Preferences buttons for the default time select have been added.  It is located in Preferences, General.
Using these buttons you can pick something else besides "Automatic" time select to appear on the status panel
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when Digital Atmosphere is started.
*  Cursor lat/long can be determined by right-clicking the map.  Using the pop-up menu simply choose
"Cursor location" and an information box will appear.
*  Nondiscrimination between ETA and NGM data during contour operations has been fixed.  Earlier
versions did not discriminate between ETA and NGM data (according to the status panel) during contour
operations.
*  Appropriate labelling is now applied to charts when a contour of model data is done.
*  The registration information box contained within the program for new users has been updated to
reflect a new E-mail address and minor changes in sales policies.
*  Default color preferences have been fine-tuned to get rid of contour line colors that match the background.

CHANGES FOR V2.1A BETA to V2.1B BETA (FEBRUARY 1999)

*  The lat/long grid interval can now be controlled.  This is done in "Preferences", "Maps".
*  A range check error that occurs during analysis of rawinsonde data has been fixed.
*  The File, Print option has been fixed.  The diagnostics window in the beta version has been disabled.  The
"inverse print" option had to be deleted due to an inability to make it work successfully without considerable
programming.  Many PostScript drivers allow you to force the printer to make negative printouts.
*  Wind feathers are reversed in the South Hemisphere to meet standard convention.  One note, however --
in the Analyze, Wind Grid section, the routines have to make the feathers a uniform style, so the center position
of the background map is what determines the style rather than each gridpoint location.
*  The status panel now uses "Automatic" for default time selection.  It's assumed that most people will
only want to use "Show Contents First" in special cases.
*  A Data Check interval has been added in Preferences in the General tab.  In earlier versions, Digital
Atmosphere checked for new data every 20 seconds.  This is now user-specifiable.
*  During find operations in "View Raw Data", the cursor is now an hourglass.
*  New station tables are now packaged with the upgrade.  This consists of DIGATMOS.RIX,
DIGATMOS.STI, DIGATMOS.STW, DIGATMOS.SXI, and DIGATMOS.SXW.  This fixes some persistent
"range check" errors with surface data that were present in the beta version.
*  The Internet alphanumeric product retrival list (DIGATMOS.SLZ) has been updated slightly.
*  Soundings have been reinstated.  The sounding window contains a box where you can enter the desired
station and easily view consecutive stations.
*  Background maps now plot after a gradient analysis.
*  You can now overlay the base map without erasing the graphics, thanks to the new Map command "Add
basemap".
*  The status bar at the bottom of the screen has been restructured.  It now holds a progress bar detailing
all ongoing operations, the task progress, and the ingest mode currently in use.  Additional status notifications
have been added throughout the analysis module and other processes.

CHANGES FOR V2.1B BETA to V2.1C BETA (FEBRUARY 1999)

*  Isentropic analysis has been reinstated.  The isentropic level can be selected from the Status Panel under
"active level".  You will be prompted for a level in whole Kelvin degrees.  While this level is active, all analysis
operations will pertain to parameters on that particular isentropic surface.  The two most useful parameters
under Analysis are "isentropic height" and "wind grid".
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*  Isentropic height has been added as an Analysis option.  This analyzes the height of datapoints in mb at the
Active Level.  Therefore its only suggested use is when an isentropic level has been entered into the Status
Panel.  Its color scheme currently follows the 500 mb contour scheme.
*  A Composed CAPE option has been added in Analysis.  This "builds" a 3-dimensional representation of
the atmosphere based on existing observations and calculates CAPE at each gridpoint, rather than calculating
CAPE at each station.
*  CAPE, LCL, and 0-6 km mean wind are now functional and can be accessed under the Analysis menu.
*  A bug has been fixed where the toolbar Print button had no effect.
*  A bug has been fixed where analysis gradient fills with no isopleths produced no background map.

CHANGES FOR V2.1 to V2.1A BETA (JANUARY 1999)

*  Documentation is now contained entirely in an Adobe Acrobat document.  The manual was extensively
rewritten and updated.
*  Lat/long grid usage is now controlled by the Preferences, Color checkbox.  The "none" radio button
under lat/long grid has been removed.
*  New time tokens for Internet data products have been introduced.  They allow you to specify the latest
synoptic or intermediate synoptic time.  You can also specify the previous hour as a base token.
*  You can easily override the time settings used in Internet time tokens to gain access to data files for
different hours.  The variables that will be used are now shown in the Internet Data Retrieval window.
*  Contour color and attribute settings are now in Preferences — "Contour", for easy access.  Advanced
users only — if you delete DIGATMOS.CGZ, Digital Atmosphere will automatically make a new one when
you open the Preferences window by importing your older DIGATMOS.CCL settings file.  This is how you can
preserve your color schemes when you upgrade.
*  You can pick a range of hours to analyze or plot, rather than just a specific one, when manually selecting
an observation time.  This is great for data-sparse areas.
*  View EMWIN bulletins using a nested tree structure similar to File Explorer, rather than the older series
of dropdown menus.  These bulletins also show the plain-English description of each region, as well as a more
complete description of each product, so you can easily see what product you'll be getting.
*  Extensive changes have been made in the station tables, DIGATMOS.STN.  Three-letter ISO-3166
country code identifiers are now being used, and the time zone entries have been reformatted and filled to
support upcoming capabilities.  Absolutely no attempt should be made to import station tables using the old
format without converting them to the new format.  Various stations have also been added worldwide.
*  There are no longer overflow problems with the View Raw Data window.  Imported data greater than
64K in size used to generate a "text exceeds memo capacity" error when the user viewed it through File, View
Raw Data.  The viewer has been replaced with a new 32-bit component which does away with the error.
*  Sporadic range check errors during data imports have been eliminated.  The error was caused when
erratic WMO numbers in synoptic data were looked up in a station table.
*  An import is automatically done after retrieving Internet data.  This eliminates an extra step that the user
had to do in the past.
*  It is now impossible for a station plot to appear at the intersection of the equator and the prime
meridian.  Occasionally when a report can't be processed correctly, Digital Atmosphere is forced to assume it
has a latitude and longitude of zero.
*  You can now adjust the lowest possible METAR pressure, under the Preferences, Meteorological tab, to
change how the hundreds place of a coded METAR sea level pressure is determined.  This is useful when
contouring very low or very high pressure.
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*  Model output thicknesses between 4800 m and 4999 m are now handled correctly.  Since they are coded
as hundreds and tens, earlier Digital Atmosphere versions simply assumed the thousands place was "5".
*  You can now specify to create a map centered on a particular station.  This is similar to how maps are
created in WeatherGraphix.  Maps can still be generated using lat and long.
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