The Weather Forecasting Forum
http://www.weathergraphics.com/forum/

V2.04 Font problems continue.
http://www.weathergraphics.com/forum/viewtopic.php?f=5&t=1515
Page 1 of 3

Author:  Dave Exton [ Wed May 20, 2009 8:44 pm ]
Post subject:  V2.04 Font problems continue.

Hi all,

Just installed V2.04 only to find that the previous ongoing font problems, viz no cloud symbol plots or pressure characteristic still exists. In addidition every time I install a new version of DA my true type meteorological fonts are removed from my fonts folder and replaced by a new met fonts folder with many symbols missing.

One more minor point, I have always had a craving for polar stereographic map projection but this still does not work properly. The map starts to plot and then, after disappearing, reappears without any latitude or longitude lines. Bit of a disapointment really.

Once bitten, twice shy! I kept a spare font table stashed away. I'll copy it back to my system fonts folder and continue to use the old version of DA.

Regards,
Dave Exton.

Author:  phaedrus [ Thu May 21, 2009 12:35 am ]
Post subject: 

Hi.. did you report the issue directly via the contact page? It might get addressed more quickly that way. I know they're trying to get caught up on a list of issues.

p

Author:  Peter [ Thu May 21, 2009 8:59 am ]
Post subject:  DA 2.05 is available

DA 2.05 is available and it addesses many issues

I had issues with 2.04 not running a download script and other problems but Tim has addressed those in ver 2.05 available last night.
But I have an issue with 2.05 which Tim is now aware.

Tim is aware of many of our issues and trying to sort them out so we have to be patient.
Download 2.05 and or look at the history page to see the changes between versions.

Regards

Author:  Peter [ Sat May 23, 2009 1:30 am ]
Post subject:  Fonts problem

This might sound like a stupid question but you say you 'copy the fonts back into the fonts folder'.
Fonts need to be installed and not copied.

Can you verify the TrueType meteo font was installed into your Windows\Fonts and not simply copied?

I have never had an issue with this on 3 computers where from DAWS through to DA 2.06 have been installed, the TTmeteo font has always remained after uninstalling and reinstalling, cloud cover and other symbols have always shown.

Regards

Author:  Dave Exton [ Sat May 23, 2009 5:23 am ]
Post subject: 

Hi folks,

Peter,

Thanks for the reply,
I'm comforted by your comment that you have had no problems with fonts etc. That suggests that the problem is fixable at my end.

In answer to your question, I have copied the fonts from previous editions of DA.

I hadn't had any problems with Equinox until one of the last version changes. After that, my station plots seemed to become corrupted - in as much as they were missing the symbols already mentioned.

After discussions with Tim / Shannon, and some fiddling on my part, I discoverd that my font table had changed with all the missing station plot symbols gone.

I downloaded a previous version of DA and all was put to rights. From that point forward, every time I downloaded a newer version of DA the fonts would again dissppear.

Getting wise to this, I copied (and saved) a fonts folder from a previous 'good' version of DA and replaced this into my system fonts (having deleted the old one first). This has always worked until installing the next version of DA. At no point in the procedings have I actually 'installed' any fonts (to my knowledge).

Am I missing something?

Kindest regards,
Dave.

Author:  Peter [ Sat May 23, 2009 6:57 am ]
Post subject:  Fonts problem

Dave,

I might be talking nonsense here as I am not a computer whiz kid but I 'installed' the meteo.ttf and didn't copy it into the Windows\Fonts.

I think what might be happening is when you uninstall DA the font is associated with DA therefore during uninstall, it removes the font from the \fonts folder. But that's guessing on my part.

In Windows XP:
Put the meteo.ttf in a Temp directory.

Go to Start - Control Panel - Fonts and open it.
Select File - Install New Font
Find the meteo.ttf file and select to put it in the 'List of fonts' to be installed and press 'OK'

The TrueType font will be 'installed' in the Windows\Fonts folder and will be recognised and 'registered' with Windows.

I did this at the beginning of DAWS years ago and after going from DAWS through until DA 2.06 uninstalling, reinstalling etc I have never lost the font and my charts have always had their correct symbols, provided the information is in the station data of course. This has applied to 2 computers and this laptop I am using.

I suspect what could be happeneing is when you uninstall DA it has associated meteo.ttf with DA and therefore deletes during the uninstall process. But if the font is installed and registered in the Windows\Fonts then Windows hangs onto it as a Windows product.

My description might be over simplistic but that's the way I think is and it would be logical in my mind anyway.

Hope this helps.

Regards Peter

Author:  geophi [ Sat May 23, 2009 6:20 pm ]
Post subject: 

Of course I'm having the same issues. Check this out...

http://www.weathergraphics.com/dl/meteo.ttf

and view it in Windows font viewer. I see no pressure tendency symbols on any PC. If this is the file that those symbols are supposed to be contained in, I don't see them. When I looked at this font installed in a default installation of DigitalAtmosphere, it looked the same. It's very strange that it works on some PCs, and not others.

Author:  Peter [ Sun May 24, 2009 2:18 am ]
Post subject:  Fonts issue

You will only see the weather symbols contained with the TrueType font.
There are no pressure tendency symbols as far as I am aware within meteo.ttf.

Many people who have the problem do not see any symbols, by that I mean they do not see cloud or weather condition symbols.

Some stations do not include current weather conditions within their report therefore no symbol will be shown at that station.

Regards

Author:  geophi [ Sun May 24, 2009 3:08 am ]
Post subject: 

Peter wrote:
You will only see the weather symbols contained with the TrueType font.
There are no pressure tendency symbols as far as I am aware within meteo.ttf.

Then why did I go through this troubleshooting exercise?
http://www.weathergraphics.com/forum/showthread.php?t=1461

Quote:
Some stations do not include current weather conditions within their report therefore no symbol will be shown at that station.

?? The originator of this thread, to whom you replied, was asking about cloud symbols and pressure change symbols. You suggested he make sure meteo.ttf was installed correctly. Neither of these type of symbols are in the meteo.ttf I'm not looking at the cloud symbols, and have no problem with the weather symbols, it is the pressure change symbols that I would like to be able to view. Three hourly metar observations from ASOS observing sites around the U.S. report pressure change/tendency. When I plot things, the numerical value of the pressure change is plotted. The pressure tendency symbol is not.

Author:  Peter [ Sun May 24, 2009 3:33 am ]
Post subject:  Font Problems

As far as I am aware, Pressure Tendency symbols are not in meteo.ttf, well I can't see them in my copy. Therefore DA cannot display any symbol from the font, if that symbol isn't there.

The originator of this thread was continuing a long time discussion where no symbols at all are shown.

I have symbols (the symbols contained within meteo.ttf) but no pressure tendency as they are not in the font.

DA can only display a symbol if:

1. the symbol exists with the meteo.ttf
and
2. the reporting station has reported that particular data.

Using the Quality Control function and stepping through the data, it is clear some stations do not always report a 'full complement' of statistics and DA can only analyse and display the data contained within that stations report.

Regards

Page 1 of 3 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/