The Weather Forecasting Forum
http://www.weathergraphics.com/forum/

What am I doing wrong?
http://www.weathergraphics.com/forum/viewtopic.php?f=9&t=1562
Page 1 of 1

Author:  Joe Stepansky [ Thu Dec 03, 2009 2:43 pm ]
Post subject:  What am I doing wrong?

I've developed the following script, which I've abbreviated for clarity (and included line breaks here that don't exist on the real script):

DOWNLOAD,[url]http://www.atmos.albany.edu/weather/data1/surface/sao/@Y@M@D@H_sao.wmo,C:\Documents[/url] and Settings\admjms\Local Settings\Application Data\DigitalAtmosphere\metar.dat

IMPORT,C:\Documents and Settings\admjms\Local Settings\Application Data\DigitalAtmosphere\metar.dat

ERASE

The problem is the IMPORT statement. When I run this script, the new data downloads just fine (I've looked at the resulting metar.dat file), but the map shows the data that was last downloaded by clicking the satellite dish image. For example, if I manually downloaded data by click on the dish for 13Z observations, then run my script in the 14Z hour (and metar.dat has the 14Z observations) the map still shows 13Z data.

And all of the OUTPUT.* files show the old file retrieval time. It seem that I need to tell DA to create the new OUTPUT files, but I don't know how.

What am I not doing?

Author:  Joe Stepansky [ Thu Dec 03, 2009 3:03 pm ]
Post subject:  This always happens

Shoot, this always happens. I ask a question, then keep looking for the solution and find it 5 minutes later. It's the INGEST command, not the IMPORT command.

But that brings up another question. I use three different maps, one for Pennsylvania, one for the Northeastern US, and a third for the entire US. I'd like to run my script every hour using the same three maps. Do I have to LOAD those maps each time I run the script, or is there a way I can have the script say "hey, DA, select one of the already open maps with this name"?

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/