What am I doing wrong?

Strictly for sharing scripts used in Digital Atmosphere and getting assistance from other users.
Post Reply
Joe Stepansky
Member
Posts: 16
Joined: Sat Dec 06, 2003 11:31 am
Location: Harrisburg, PA USA

What am I doing wrong?

Post by Joe Stepansky »

I've developed the following script, which I've abbreviated for clarity (and included line breaks here that don't exist on the real script):

DOWNLOAD,http://www.atmos.albany.edu/weather/dat ... \Documents and Settings\admjms\Local Settings\Application Data\DigitalAtmosphere\metar.dat

IMPORT,C:\Documents and Settings\admjms\Local Settings\Application Data\DigitalAtmosphere\metar.dat

ERASE

The problem is the IMPORT statement. When I run this script, the new data downloads just fine (I've looked at the resulting metar.dat file), but the map shows the data that was last downloaded by clicking the satellite dish image. For example, if I manually downloaded data by click on the dish for 13Z observations, then run my script in the 14Z hour (and metar.dat has the 14Z observations) the map still shows 13Z data.

And all of the OUTPUT.* files show the old file retrieval time. It seem that I need to tell DA to create the new OUTPUT files, but I don't know how.

What am I not doing?

Joe Stepansky
Member
Posts: 16
Joined: Sat Dec 06, 2003 11:31 am
Location: Harrisburg, PA USA

This always happens

Post by Joe Stepansky »

Shoot, this always happens. I ask a question, then keep looking for the solution and find it 5 minutes later. It's the INGEST command, not the IMPORT command.

But that brings up another question. I use three different maps, one for Pennsylvania, one for the Northeastern US, and a third for the entire US. I'd like to run my script every hour using the same three maps. Do I have to LOAD those maps each time I run the script, or is there a way I can have the script say "hey, DA, select one of the already open maps with this name"?

Post Reply