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CAUTION
If you are too close to the production time of 
the model, realtime files will be unavailable 
for download.  For example, the 12-hour 
forecast from the GFS is not available until 
about 1500 UTC, but Digital Atmosphere 
will offer it for download anytime after 1200 
UTC.  You may occasionally need to change 
the time tokens to force the download to use 
an earlier model run, or wait for new model 
data files to be posted.

3.5.2. Output grid.  It is not practical to have all 
model data at full resolution, as this would take 
potentially hundreds of gigabytes.  Most model 
output is provided as a subset based on a limited 
range of products, a limited set of vertical levels, 
and/or a coarser grid.  In this dropdown box, 

select the output grid that you think is best for 
your purposes.  We think it is good practice to 
specify typical grid sizes in megabytes in order 
to help forecasters manage their time, so we title 
each option accordingly.

3.5.3. Forecast hour.  Select the desired forecast 
hour here.  Typical values are 00 to 120 hours, or 
longer for global models.  If you’re not familiar 
with a model you should try rounding to the 
nearest 6 or 12 hours unless you’re sure that data 
exists.

3.5.4. Time tokens.  Each model dataset is iden-
tified by its “cycle”, which identifies the date and 
time corresponding to the first (00-hour) field.  
Likewise, most model data online is organized 
by cycle, and the Internet URL must be struc-
tured accordingly for many websites.  In Digi-

FIGURE 3-1. GRIB dis-
play interface as of sum-
mer 2021.  Users should 
work sequentially from 
top to bottom, first check-
ing that the time tokens 
are correct (for selecting 
the right model cycle) and 
then choose the model.  
The field is then chosen 
and after that is avail-
able to be plotted after 
the analysis command is 
reviewed.

Remember you must 
click on a field in Step 2, 
“Select field”, in order to 
populate the Display Field 
with a suggested analysis 
command.
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tal Atmosphere, we use a series of “template 
addresses” that use time tokens, placeholders 
in which values for year, month, day, and hour 
can be inserted.  When the GRIB Import panel 
is displayed, the time token values are filled in 
for you based on the system clock date, time, 
and time zone.  You should check the entries 
to make sure they are correct.  It may also be 
necessary to change the entries to the previous 
model cycle if data is not yet available and the 
model forecast run is not complete.  You can 
do all of this in the time token fields.

3.5.5. Download now.  When all the infor-
mation above is correct, you can press the 
Download Now button to begin the download 
process.  This may take awhile for large datas-
ets.  When it is done, continue to “Select Field” 
below.

3.5.6. Select data file.  If you intend on load-
ing GRIB data from a file, you may start with 

the Select Data File option.  You will be asked 
to choose a GRIB file from disk or the local 
network.  When it’s loaded, you can continue 
below to “Select GRIB Field”.

3.5.7. Save this GRIB file to a local file.  You 
can use this open to save a copy of the data in 
memory to a disk or local network file.  This 
is useful for keeping an archive copy on hand.  
Note that the entire GRIB file is saved, not 
individual fields.  The program will encourage 
the use of the “grib2” file extension, but you 
can choose “grib” or some other extension; the 
resulting file will be exactly the same.

3.5.7. Select field.  Once the GRIB data has 
been downloaded or loaded from disk, Digital 
Atmosphere will review it and build a list of 
displayable parameters, consisting of various 
combinations of forecast hours, levels, and 
weather values.  Select the desired one for 
display.  For vector fields like wind (UGRD/

FIGURE 3-2. A 
combined plot using 
METAR and SYNOP 
surface data, to-
gether with Canadian 
GEM RDPS sea-level 
pressure and thick-
ness from GRIB data.  
This is plotted on a 
basemap that uses 
a planetary terrain 
map (located under 
the Map menu).  The 
example shown is for 
1800 UTC, July 10, 
2021.  The combina-
tion of METAR and 
SYNOP data for plots 
and GRIB for synop-
tic contours provides 
superior results over 
data-sparse areas 
such as oceans.



DIGITAL ATMOSPHERE MANUAL / January 2023  |  19

VGRD) you can select either component and 
the vector form will be built and calculated by 
Digital Atmosphere unless the digatmos.grf 
reference file is configured to call for a scalar 
expression.

3.5.8. Display field.  An analysis command 
will be displayed in the text entry box.  This is 
obtained from the digatmos.grf file.  It can be 
further modified by editing the text.  For infor-
mation on analysis commands, see Appendix G, 
“Analysis Scripting”.
	 Please note that the base field (product) must 
always be set to GRIB.  Do not select fields like 
SLPR, DWPT, TEMP, etc, as this will cause the 
analysis routine to look in the observational data 
files.
	 Scripting of GRIB data is not yet supported 
but will be part of the Digital Atmosphere Pro-
fessional options.
	 Currently there is no capability to reference 
other fields in the GRIB file, but we are aware 
this is necessary and are working on a solution.  
We expect this will involve a value in parenthe-
ses that calls specific values of time, level, and 
field, such as GRIB(12,500,HGT).  Again this is 
not implemented yet, thus there is no solution 
for combining fields to produce values such as 
divergence unless these are already provided as a 
pre-existing field.

3.5.9. Customizing analysis commands.  De-
fault analysis options and titles for various GRIB 
fields are configured in the digatmos.grf file in 
the Digital Atmosphere working directory.  This 
may be edited by users with a text editor like 
Windows Notepad.  We recommend avoiding 
the use of word processors like Microsoft Word 
to edit this file as they may insert extraneous 
characters and corrupt the file.
	 In the analysis scripting in digatmos.grf, it’s 
important NOT to specify product types such as 
WIND, TEMP, etc, as this will override the GRIB 
data and cause Digital Atmosphere to attempt 
to refer to observational data files.  Always use 

GRIB as the product type.  Review the  examples 
shown throughout the file for clarification.

3.5.9. Customizing GRIB sources.  You may 
edit, add, or delete GRIB sources in the digat-
mos.grb file in the Digital Atmosphere working 
directory.  This may be necessary when a prod-
uct suddenly disappears, as the forecast center 
may have reorganized their directories.  Weather 
Graphics will occasionally check and update 
these GRIB sources.
	 Note that many of the URLs use variables 
starting with a dollar sign, which are explained 
at the top of the page.  Digital Atmosphere 
replaces these variables with time data based on 
the settings chosen by the user in the Import 
GRIB Data panel.
	 The titles for each product normally contain 
a short description of the gridded data,  This title 
is displayed to the user in the Import GRIB Data 
panel under the Output Grid option.  A descrip-
tion, a typical size in megabytes, and a grid size 
are included.  These are purely optional but are 
strongly recommended to enhance the forecast-
er’s ability to select an appropriate grid.
	 Note that servers which require a login will 
not be supported.  You may want to browser to 
obtain such files manually, or use a command-
line utility such as wget or curl.  The file can then 
be imported for display with the Select Data File 
option.

3.5.10. Notes about objective analysis.  Note 
that the objective analysis routine (in File > Pref-
erences > Analysis) does not need to use com-
plex options with GRIB data since there are no 
data voids.  However a small amount of smooth-
ing is necessary since the GRIB grid must be 
transformed to the Cartesian analysis grid in 
Digital Atmosphere, and this results in some loss 
of fidelity.
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3.6. Import historical data
	 This function is designed to directly access 
the free Historical Data dataset available on 
the Weather Graphics download page at www.
weathergraphics.com/dl .  The historical data 
may be installed to any location, and it will 
automatically make an entry in the Windows 
registry that will allow Digital Atmosphere to 
find the files.  For technical users, this entry is 
HKCU\Software\HistoricalData\InstallPath.
	 The data consists of converted METAR and 
SYNOP data for North America, twice daily at 
0000 and 1200 UTC, encoded in a highly com-
pressed binary format only viewable with this 
import function in order to keep the dataset 
size a reasonable size that can be transferred 
easily via the Internet, below 1 GB.  Due to this 
large size, only a basic set of meteorological 
fields are available.  For worldwide coverage or 
data on an hourly basis, the Surface Archives 
and Upper Archives products at weathergraph-
ics.com are recommended.

SPECIAL NOTE
If you are using a version of Digital Atmo-
sphere dated before January 2019 (V3.10a) 
or are using a Historical Data release before 
January 2019, the following applies.  The 
historical data installer must install to the 
Digital Atmosphere Program Files direc-
tory (where digatmos.exe is located).  It will 
automatically create the subdirectories it 
needs.  If it is not correctly installed, no his-
torical data will be viewable.  The Program 
Files directory is displayed in Help > About.

3.7. Clear data directory
	 This is a utility command that deletes all 
files in the data folder.  It should not be used 
unless you are seeing corrupted plots after 
multiple raw data imports.
	 Clearing the data directory ensures that 
File > Import Directory does not inadvertantly 

retrieve stray files that were placed there by the 
user.  It can also prepare the data directory in 
case the user wishes to place numerous files 
into the directory to be imported.

3.8. Font mode	
	 Text plots (especially station plots) can 
be plotted in one of two modes: as Windows 
Fonts or as NMC/NCEP Raster Fonts.
	 For most routine program use, users 
should use the Windows Font choice.  In that 
case, the exact font name and size will be con-
trolled from File > Preferences settings for the 
workchart style.
	 The NMC/NCEP Raster Fonts option is 
highly unique in that it uses character sets 
implemented in the late 1960s by the National 
Meteorological Center on their supercomput-
ers.  These fonts have been extracted from the 
FORTRAN code listings and can be used as 
fonts in Digital Atmosphere.  This not only 
provides “official” looking charts but also 
provides high-visibility plots that are especially 
suitable for faxes and photocopies.

3.9. Quality control
	 If you’re a newcomer to meteorology, you’ll 
quickly discover that not all weather data is 
100% accurate.  Every single batch of hourly 
observations contains errors.  The errors get 
there because of either transmission problems, 
communications interference, human error, 
equipment misconfiguration, equipment fail-
ure, or simply the observer hitting the wrong 
key when typing up the report.  In many 
developing countries, it is still very common 
for observations to be transmitted over radio 
or telephone to a central facility where it is 
entered into a terminal computer, and numer-
ous errors can be inadvertantly introduced this 
way.  The errors can either be unnoticable or 
may corrupt an analysis.  Fortunately, Digital 
Atmosphere provides a tool to help fix the 
problem.
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	 When you are looking at a chart and see 
a station reporting bad data, you will need to 
right-click once just to the top left of the sta-
tion, then choose “Set QC corner” on the popup 
menu.  Move the mouse to the bottom right of 
the station and repeat the procedure.  Next, click 
on File, then on Quality Control.  You’ll see a 
panel showing all of the meteorological data at 
that station.  Change the values to whatever is 
appropriate.  Always use a value of -9999 to indi-
cate missing or unusable data.
* Accept Entry — Saves the report as shown, in-
cluding any modifications you might have made.  
Once you hit Accept Entry, all changes become 
permanent.
* Ignore Changes — Ignores any changes that 
you’ve made to the report and moves to the next 
one.
* Delete Report — If the individual report is so 
corrupted that you know you won’t want to use 
it, you’ll probably want to delete it.  This is the 
button to use.
* Stop Search — Stops sifting through the file, 
saving any values that you’ve already entered.
	 Note that QC displays all data within the 
bounding box (even if it.s filtered out on the 
map), so you may need to press .Accept entry. 
numerous times until you find the station you 
want.  One way of avoiding this problem is to 
make the initial QC box as small as possible so 
that you get only the station you want.
	 Since QC changes the internal cached data in 
Digital Atmosphere, you will lose your changes 
if you reimport the original source data.

The rule file: A permanent fix
	 To permanently fix data from a given sta-
tion, at the main menu select Data > Edit Sta-
tion Rules.  See the Data menu chapter for more 
information.

3.10. Print
	 This option will print your currently active 
map.  It’s that easy!  If you want to make changes 

in the way that the map is printed, you’ll need to 
use Print Setup, listed below.

CAUTION
Do not print charts with black backgrounds, 
as this may consume excessive toner or ink.

	 Print sends an exact copy of the screen im-
age to the printer, so if the printouts are too dark 
or will consume a lot of toner, you will need to 
change your map settings in Preferences and 
regenerate new maps, preferably with white 
backgrounds, then print those.  Many PostScript 
printer drivers will also allow you to set the 
printer to produce a negative printout.
	 If the maps are too dark, you should avoid 
using solid colors.  Regenerate your maps with-
out topography or ocean fills.  Topography is 
designed mainly for screen viewing.  If you abso-
lutely must have dark maps on-screen and can’t 
force your printer to produce acceptable output 
(either through File, Print Setup or through the 
printer’s own setup menus), you will need to ex-
port the map and then use a photo-editing type 
graphics program (such as Photo Shop or Paint 
Shop Pro) to make a negative image or enhance-
ments that allow for better printouts.
	 If the printer shows memory errors, this 
means that the graphic you are sending to 
the printer is too large to fit into the printer’s 
memory.  The easiest way to remedy this is to go 
to File, Print Setup and choose a portrait print-
out rather than a landscape printout.  Another 
solution is to regenerate your charts without 
using any color fills or topography (i.e. totally 
composed of line graphics).  The third method 
of solving a memory problem is to use a lower 
resolution (i.e. choose 600 dpi rather than 1200 
dpi, or 300 dpi rather than 600 dpi in your 
printer setup).  With older printers such as the 
HP 4 it is essential  to increase the amount of 
RAM by installing a SIMM memory module.  
This requires a minimum of 2 MB of RAM, but 
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due to the cheap price of memory 16 MB is 
recommended.
	 Around 2003-2005 some users reported 
problems printing to HP LaserJet and a couple 
of other printers (such as getting blank pages).  
This is usually a problem with the Windows 
PCL 5 print driver and is beyond the control of 
Digital Atmosphere.  Solutions that have been 
documented are changing the resolution from 
600 to 300 dpi or change the print mode from 
“vector” to “raster”.  If your printer is equipped 
with a PostScript option, always use the Post-
Script mode for 600-dpi printing.  Overall, 
this printing problem is not specific to Digital 
Atmosphere and may occur with other ap-
plications that make extensive use of the PCL 
driver.  Also note that for some HP printers, 
PCL 6 fixes the problems.

3.11. Print setup
	 This function is used for specifying how 
you want your printer to print maps.  These 
panels will vary based on what type of printer 
you are using.  One option that is useful for 
some printers is the “Graphics Resolution”.  
When you lower this value, it will help you 
send extremely detailed charts to printers that 
keep producing “out of memory” errors or 
blank pages.

3.12. Calculator
	 Do you need to find a wind chill value?  
Mixing ratio?  Theta-e?  No problem.  Digital 
Atmosphere’s meteorological calculator lets 
you plug in values and find a result.
	 A very important note about pressure — 
when you are asked for “Actual Pressure”, this 
indicates the actual pressure of the parcel.  This 
is station pressure as a mercury barometer 
would observe it, not sea-level pressure or 
altimeter setting (which are corrected to sea 
level).  If you’re computing a surface-based 
parameter at a high elevation, you can find 

“actual pressure” by simply calculating “Station 
Pressure (mb)”.
	 An example: In Denver, Colorado, your 
elevation is 5300 ft and the pressure is 29.96 
inches.  This yields a station pressure or actual 
pressure of 834.8 mb.  You can then use this 
value in calculations which ask for this infor-
mation.

3.13. Warning status
	 (Under development)

3.14. Live chart retriever
	 (Professional version only)
	 This module retrieves weather from over 
the Internet and sends them automatically 
to your printer.  Please note that supported 
filetypes are limited to GIF, JPEG, PNG, and 
TIF.  There is no support for animated files or 
dynamically generated URLs.
	 To use this module, open the Chart Selec-
tion Menu and set a checkmark next to each 
chart you are interested in.  Then close the 
menu and click Activate Retriever.  The red 
square around the dog icon will turn green, 
indicating the retriever is active.
	 Charts will be sent to the printer shown 
in the Printer section.  You can also control 
the startup behavior here to indicate whether 
you want the initial set of charts printed.  The 
status of the retrieval jobs will be shown in 
the next three windows, “products queued for 
polling”, “retriever engine status”, and “preview 
of last downloaded product”.
	 To add or edit products in the Chart Selec-
tion Menu, use the INSERT and DEL key to 
add and delete rows, respectively.  Expert users 
may directly edit the digatmos.dfz file in the 
Digital Atmosphere working directory to make 
any complex changes.
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3.15. Station tables
	 When you import weather observations, 
Digital Atmosphere refers to a special, internal 
listing of all of the weather stations.  Starting in 
2010 the storage format for this table was exten-
sively revised and updated, and organized into 
a structured format called the Master Location 
Identifier Database (MLID).  It uses the latest 
identifier updates from the FAA, ICAO, and 
WMO.
	 After several years of development, the 
MLID was added to Digital Atmosphere in De-
cember 2014 with Version 2.12.  The old format 
(where ICAO appears in Columns 1-4) is no 
longer supported.
	 Some users may prefer to delete stations or 
add unofficial observing stations from their own 
network which report in METAR or SYNOP.  
Users may directly edit the Master Location 
Identifier Database, but this is not recom-
mended because it is designed to be overwritten 
when Digital Atmosphere or the MLID version 
is updated.  To keep your changes from being 
lost, we are implementing an “overlay file” solu-
tion.   This is a file that Digital Atmosphere uses 
to modify the MLID listings after it has been 
loaded.  Your overlay files can be kept perma-
nently without fear of loss, allowing you to use 
any version of the MLID with a permanent set of 
changes.

Editing the overlay file
	 (Under development -- this has not yet been 
added but is a high priority item)
	 Load the overlay file into any text editor.  If 
you don’t have one, follow the format in the di-
gatmos.lid file as a guide.  Column 15 is used for 
signaling whether a row in the overlay deletes 
something in the master station list or adds/re-
places a station.
* Delete a station: in column 15, enter DEL or 
DELETE and signify the identifier that is to be 
removed.  It will be searched for in MLID col-
umn 16 (ICAO), 19 (FAA), or 22 (WMO).  No 
other data needs to be entered.

* Add a station: in column 15, enter ADD.  
Make the appropriate entries throughout the 
row.  Note that column 16, 19, or 22 will be used 
by Digital Atmosphere to obtain the identifer, 
not columns 10-14.

3.16. Check for updates
	 Checks the Weather Graphics site to deter-
mine if a newer version of Digital Atmosphere 
is available.  If so, the user will be asked if they 
would like to go to the download page.

3.17. Preferences
	 Here’s where you set your preferences for 
how the program will operate.
	 For more information on each Preferences 
item, please consult the chapter at the end of 
this manual, titled “Preferences Settings”.

3.18. Exit
	 Exits Digital Atmosphere.  The background 
map will be saved and it will automatically ap-
pear the next time you run the program.  For 
many dialog boxes that were open, the directory 
they used will be memorized.  The last data set 
you imported will continue to be available.
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The map manu is used to control functions relat-
ing to the geographic and graphical display of 
information in the workchart.

4.1. Erase map
	 Before you make annotations, plots, or con-
tours on your map, Digital Atmosphere retains a 
copy of the original map image in case you want 
to start with a blank slate.  Use this command 
whenever you want to erase weather data from 
the map.

4.2. Load map
	 Loads a workchart from your disk drive.  
You will need a previously-saved workchart 
(which can be saved using the Save Map com-
mand).  Load Map loads images that are Win-
dows bitmaps (filename *.BMP), and it also 
expects to load a map attribute file with the same 
name (*.ATR), which contains data about the 
image’s latitude, longitude, and zoom setting.
	 If this map attribute file is not present, you 
will get an error.  This is why you cannot sub-
stitute a BMP satellite photo as a map, unless 
you’ve already created an corresponding bi-
nary ATR file that contains the proper attribute 
settings valid for that photo (not a job for the 
fainthearted).

4.3. Save map
	 Saves the workchart for future access within 
Digital Atmosphere.  This also saves any mark-
ings, annotations, weather data, and contours 
that are on the map already as a permanent part 
of the map, so if you intend to load this map 
later without any weather data, you’ll need to use 

the Erase Map command to get rid of the data  
before you save it.  Save Map produces one im-
age file (a Windows bitmap, *.BMP) and a very 
small map attribute file (*.ATR).  The ATR file 
is necessary to load the map into Digital Atmo-
sphere and should stay in the same directory as 
the BMP file.
	 An important consideration is that only 
Windows bitmap (BMP) files can be saved, and 
they are rather large.  File sizes can range any-
where from 300 to 700K in 8-bit color mode to 
2.5 megs in 24-bit color mode.  So avoid saving 
too many unless you have plenty of disk space.  
If you’re using on-the-fly disk compression (such 
as Stacker, DoubleSpace, DriveSpace, etc), these 
images will take up about 80% less disk space 
than they do when uncompressed.
	 Once the *.BMP file is saved, you are free to 
use any graphics editor to tweak or annotate the 
image.  Note that you must re-save it as the same 
type of graphics format it was in (a BMP with a 
color depth of 24 bits), or Digital Atmosphere 

4 / Map menu
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may produce an error when it attempts to load 
the image.

4.4. Generate map
	 There are three ways to generate a map.  The 
easiest method is to use the “Generate map” 
dropdown box on the speed button toolbar and 
pick a country or continent.  For those that want 
more accuracy, these two selections will provide 
greater control of map generation.

Enter station
	 If you know the station that you want to 
center you map on, you can simply enter it here.
* Station.  Enter an ICAO code, WMO code, 
IATA code, or partial station name.
* Map width.  Sets the width of the map in miles.
* Map size.  Allows you to specify how many 
screen pixels wide and tall you want the map 
image to be.  You may also wish to choose one 
of the map size quick-pick buttons.  If you want 
an exceptionally detailed image, you may want 
to choose one of the higher settings.  The 1550 
x 1150 size yields excellent printed maps that 
are suitable for publishing.  If this image size is 
larger than the screen, you will be provided with 
scroll bars to roam around the image.  However, 
note that large maps place a burden on your 
computer’s resources, and too many large maps 
open at the same time may cause warnings or er-
rors.  Avoid setting sizes larger than 2000 pixels.

Enter lat/long
	 This is a powerful tool that replaces the map 
contained within the selected workchart with 
another map.  Once you choose this command, 
you’ll see a settings panel appear.  This is where 
you choose how your map should look.  All 
maps are generated using an orthographic (“sat-
ellite view”) projection.
* Latitude.  Sets the latitude for the center of the 
screen in degrees.
* Longitude.  Sets the longitude for the center of 
the screen in degrees.

* Scale.  Sets the width of the map in either miles 
or kilometers.
* Image width / image height.  Allows you to 
specify how many screen pixels wide and tall 
you want the map image to be.  You may also 
wish to choose one of the map size quick-pick 
buttons.  If you want an exceptionally detailed 
image, you may want to choose one of the higher 
settings.  The 1550 x 1150 size yields excellent 
printed maps that are suitable for publishing.  If 
this image size is larger than the screen, you will 
be provided with scroll bars to roam around the 
image.  However, note that large maps place a 
burden on your computer’s resources, and too 
many large maps open at the same time may 
cause warnings or errors.  Avoid setting sizes 
larger than 4000 pixels unless testing shows 
there are no problems.
* Set auto height.  This forces the image height 
to conform to the aspect ratio of a printed page; 
either letter or ledger, so that you can be assured 
it fills the printed page.  The use of the margin 
(normally 0.25 inches) will change the aspect 
ratio slightly.
* Color style.  The newly created chart will use 
the color scheme selected here (see Preferences 
> Styles) and the Preferences chapter.
* Location quick-pick.  Click on any of these but-
tons to automatically set an appropriate lati-
tude, longitude, and scale for a commonly-used 
region.
* Zoom quick-pick.  Click on any of these buttons 
to automatically set a map scale based on a me-
teorological scale type.  Global scale sets a width 
of 8300 nm, synoptic scale 4000 nm, subsynoptic 
scale 3000 nm, meso alpha scale 1500 nm, meso 
beta scale 700 nm, and meso gamma scale 200 
nm.

4.5. Blank map
	 Creates a workchart with no background 
map.  Projection data from the last workchart is 
used.
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4.6. Import map from file
	 This option imports a graphic from an image 
file, replacing the existing map graphic.
	 IMPORTANT: Map positioning will remain 
unchanged, because there is no practical way to 
read the map and estimate lat/long and projec-
tion information.  This option is designed to be 
used for very special cases, such as when you 
have carefully matched up a Digital Atmosphere 
base map with a pre-existing satellite image and 
wish to load the satellite data in.

4.7. Import map from URL
	 This imports a map from an Internet URL, 
similar to “Import map from file” above.  The 
same caveats apply.

4.8. Import shapefile
	 Imports map data from a shapefile, which 
is  a geospatial vector data format.  Using In-
ternet searches you can find all kinds of useful 
geographic shapefiles for your area that may 
be applicable to your forecasting work (power 
grids, FAA center boundaries, and so forth).  It 
is important to remember that shapefiles (.shp) 
are always paired with a database file (.dbf) and 

index file (.shx) of the same name, and they need 
to reside in the same directory as the shapefile.
	 Also the shapefile must use latitude/longi-
tude coordinates.  UTM or E00 coordinates are 
not accepted.
	 When you import the shapefile, you will be 
shown an attribute selection dialog, which is 
necessary to tell Digital Atmosphere which fields 
contain the latitude and longitude information.  
Here you can also set the color of the line to be 
drawn.  In most cases you can leave all the drop-
down boxes to their default positions “(none)”, 
but with some files you may need to override 
this to indicate which fields contain the data.
	 You may also fine-tune your display by 
choosing to display only shapes that have spe-
cific attributes, such as in the case of a shapefile 
of NWS warning areas, you may only want to 
display a shape where WFO equals OUN, so that 
only the Oklahoma City warning area shows 
on the map.  Or you may want to use this in a 
shapefile of road data to make different kinds of 
roads appear differently.  This is done in the At-
tribute Selection Dialog under the “Plot Specific 
Features Only” panel.  Choose the attribute, the 
operator (equals or does not equal), and the de-
sired value.  If you’re unsure what to pick, open 

FIGURE 4-1. Road over-
lays (dark lines) from 
2010 US Census Bureau 
TIGER/Line shapefiles, 
combined with radar 
imagery.  These shapefile 
datasets can downloaded 
from the following link 
(be sure to unzip all files 
before trying to import 
them): http://catalog.
data.gov/dataset?res_
format=shapefile
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the shapefile DBF file in an editor that handles 
.dbf format (Microsoft Excel is good for this) 
and examine the rows.
	 Since the shapefile drawing process is 
somewhat slow with larger files, we encourage 
you to use “Map > Copy Markings Onto Base-
map” after you’re done, so that they remain 
part of your workchart even after you erase the 
data.
	 Shapefiles can be obtained from many 
sources, including the US Census Bureau, state 
geological and natural resource agencies, and 
other government agencies.  If they are zipped, 
always be sure to unzip them into a directory 
first before attempting to import them; the ZIP 
packages will not be recognized.

4.9. Copy markings onto basemap
	 If you choose this option, absolutely all 
markings, plots, and data becomes part of 
your basemap permanently, even if you choose 
Erase Map.  The markings will persist until you 
replace it with a different map through a Load 
Map or Generate Map operation.

4.10. Copy chart to clipboard
	 This is the easiest way of transferring 
a workchart to another software program.  
When you choose this, the workchart is placed 
in the Windows clipboard.  From there, you 
can paste it into any of your favorite graphics 
programs.

4.11. Export chart
	 This command is exactly identical to Save 
Map, except that no map attribute file (ATR) 
is saved.  Therefore it is designed for your own 
projects, presentations, or reports.  The output 
format can be selected under “Save as type”.  
Default JPEG compression settings can be 
altered in preferences, under File > Preferences 
> Map.

	 Here are the different supported filetypes.  
Since Digital Atmosphere produces graphics 
that are similar to monochromatic line art,  
non-lossy formats will always give the best 
results.
* GIF (Graphics Interchange Format).  Non-
lossy format that produces the smallest file.  
This is often the best choice for saving charts.
* PNG (Portable Network Graphics).  Non-lossy 
format similar to GIF; good compression.
* JPG (JPEG/Joint Photographic Experts 
Group).  Lossy format that yields excellent 
compression, but is not as crisp.  The most 
widely used format.
* BMP (Windows bitmap).  Non-lossy format 
native to Windows.  It does not work well in 
browsers and produces bloated filesizes; cre-
ates 24-bit files (may not be suitable with very 
old programs which expect 8-bit BMP files).

4.12. Cursor city distance
	 If this is enabled, the nearest city, direction, 
and distance will be shown corresponding 
to the geographical coordinates at the cursor 
location.  This only works in the United States.  
CPU load may increase slightly while this is 
enabled.
	 To disable Cursor City Distance, click this 
option again so the menu checkmark disap-
pears.

4.13. Map information
	 Displays detailed information about the 
map currently shown.  Included is the map 
width and height (in both pixels and nauti-
cal miles), the center latitude/longitude of the 
map, and the corner latitude/longitude points.  
All negative latitudes indicate the southern 
hemisphere, and all negative longitudes indi-
cate the western hemisphere.
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4.14. Set comment
	 Users may enter a plaintext comment here 
to be prepended to chart titles.  These titles are 
normally placed in the lower right side of each 
workchart when a product is generated.  The 
comment is only valid for the Digital Atmo-
sphere session and will be set to null when the 
program is restarted.

4.15. Make topography
	 Renders a topographic representation (ter-
rain features) of the Earth on your map projec-
tion.  After the topography is drawn, Digital 
Atmosphere then re-overlays the basic geogra-
phy data.  The topography draw operation may 
take a few minutes on slower computers.
	 Note: as of 2018 we recommend the use of a 
high-resolution planetary map (next section) in-
stead of “Make topography” as this will achieve 
much better results.

4.16. Import planetary map
	 Imports a special image (JPG, GIF, or BMP; 
JPG is preferred) which provides a topographical 
or thematic depiction of the entire earth (Figure 
4-2).  The source file must provide an equirect-
angular projection, also known as plate-carrée 
(Figure 4-3).  The top edge must represent 90°N, 
the bottom edge 90°S, the left edge 180°W, and 

FIGURE 4-3. The 
equirectangular, or 
plate-carée projec-
tion, must be used in 
Digital Atmosphere’s 
planetary maps fea-
ture.  Note the 1:1 
proportion between 
meridians and paral-
lels throughout the 
entire map, with no 
distortion or stretch-
ing of the graticule at 
polar latitudes.

FIGURE 4-2. Sample of a planetary map with 
built-in vector basemap (brown borders and 
coastlines) overlaid.
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the right edge 180°E, with no margins.  There-
fore, for an image with a width and height of x 
and y pixels, respectively, 45°N must appear at 
0.25y, the Equator at 0.5y, and 90°W at 0.25x.  
When properly imported, this graphic will be 
mapped correctly onto the active workchart.  
Since it is processor-intensive, the procedure 
will normally take a few minutes to complete.
	 The advantage of planetary maps is they 
can use information from a wide variety of 
sources, such as vegetation, land color, geolo-
gy, and so forth.  Numerous sources for plan-
etary maps may be found on the Internet via 
image search using terms like “equirectangular 
earth” or “earth texture”.  A resolution close to 
16000 x 8000 will give optimal results.  When 
using search engines, use image search and the 
search tools to specify the resolution.  Images 
of less than 4000 x 2000 pixels are not suffi-
ciently detailed and should be disregarded.
	 It is essential to visually inspect a new 
planetary map to make sure the creator did not 
use Mercator or some other format.  A non-
equirectangular projection is often indicated 
by “stretching” of the map content near the top 
of the map in a northward direction.  In a cor-
rect equirectangular projection, Greenland will 
have a squashed look, appearing almost twice 
as wide as it is tall, whereas with the inappro-
priate Mercator projection it will appear taller 
than it does wide.  Also, test any new planetary 
maps with the built-in vector map data using 
Add Overlay > Basemap.  If the vector data 
does not match the graphic image, it indicates 
a problem with the source planetary image or 
an improper projection.
	 IMPORTANT: Remember that to make this 
overlay permanent you must use Map > Copy 
Markings To Basemap.  You should then save 
the basemap for later use.

4.17. Add overlay
	 The overlay options allow you to add ad-
ditional geographic datasets as follows:

City overlay format
For city overlays, you will need to 
define the cities you want drawn by 
editing the file DIGATMOS.CIT with any 
text editor.  The columns used are as 
follows:

1-2	 Latitude of city in degrees
3-4	 Latitude of city in minutes
5	 N or S latitude sign
7-9	 Longitude of city in degrees.
10-11 	 Longitude of city in minutes.
12	 E or W longitude sign
14-33	 Name of city as you want
	  it to appear

	 The DIGATMOS.CIT file contains 
some default cities that are formatted 
per the above specifications, which you 
may find useful to refer to as a tem-
plate when adding new cities.

* Basemap: Redraws the workchart basemap 
without erasing the contents of the workchart.
* Point: Overlays a specified point on your 
map.  You can also load or save a point plot 
list. 
* City: Overlays predefined city marks and 
labels onto your map as a reference (see table 
in margin for formatting and location).
* County outlines:  Overlays United States 
counties, parishes, and certain city border 
information. 
* County names: Overlays the names of the 
counties.  The names are truncated according 
to the zoom factor so that they fit within the 
county.
* Highways: Overlays United States interstate 
highways onto the map.
* Secondary highways: Overlays United States 
U.S. and state highways onto your map.  This is 
a detailed process and may take a few minutes 
depending upon your computer. 
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4.18. Annotations
* Change credits: (Under development)
* Change title: (Under development)
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	 Before you use any of these commands, you 
will need to make sure there is an active Internet 
connection.  Note that Digital Atmosphere has 
only very limited support of proxy servers, so 
if you encounter problems, you’ll have to use a 
regular browser to obtain the data, then save it 
and import it manually into Digital Atmosphere, 
or script it with a specialized web download util-
ity such as wget.
	 If you are new to using the Internet and need 
some basic information, see the section on get-
ting data at the end of this manual.

5.1. Retrieve data
	 This module retrieves alphanumeric data 
through the Internet and saves it to your hard 
drive.  When the data download is completely 
finished, Digital Atmosphere will import the 
data for you.  This means you can immediately 
begin plotting and analyzing.
	 To use Retrieve Data, you must have a con-
nection to the Internet.  If you can’t get any of 
the download links to work, firewalls and antivi-
rus programs might be blocking Digital Atmo-
sphere.  Make sure Digital Atmosphere is run-
ning and check Windows under Control Panel > 
Windows Firewall > Allow A Program > Allow 
Another Program and find Digital Atmosphere 
in the list and Add it.  If you have a proxy server, 
enter any necessary proxy host information in 
Preferences > Misc.  Also check your system 
time and time zone, since some of the product 
URLs are date-time dependent.
	 When you select Retrieve data, you will be 
presented with a dialog box containing a list of 
weather data products where you can check off 
the items you want to download (see illustra-

tion) from a product list.  Normally you will 
only choose one or two products.  A common 
favorite is METAR data from Albany.
	 Once you press Retrieve, the chosen prod-
ucts will be downloaded and stored in your data 
directory.  Then you can use File, Import Direc-
tory to see the results.
	 Since Internet sites often change, you can 
fully edit the list of products and data directly 
from this dialog box by highlighting the item 
you wish to change and clicking the Edit Site 
button or the Delete Site button.  You can also 
add a new site by clicking the Add Site button.  
You will then be prompted to enter the site name 
and URL for the data.
	 Many sites, especially for surface and upper 
air data, have a filename that is dependent on 
the Greenwich Mean time of the observation.  
Digital Atmosphere lets you insert five-character 

5 / Data menu
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groups known as “time tokens” into a filename.  
Digital Atmosphere will substitute these 
groups with time data.  For example, if data for 
0400 UTC exists at the following URL: 
  http://www.data.com/04data.txt
Then use the following expression to obtain 
that data:
  http://www.data.com/@HHHHdata.txt

	 Digital Atmosphere supports rounding of 
time down to intermediate, synoptic, and ra-
diosonde hours.  Also time may be subtracted 
up to 24 hours.  Note that rounding is done 
first, followed by subtraction.
	 Note that any rounding and time subtrac-
tion operations must be applied to all of the 
time tokens (year, month, day, hour, etc) for 
that URL as they are processed individually.
	 Here is a complete list of time token com-
binations (revised in January 2023):

Character 1 - marker
@	 Character 1 is always an “at” symbol.  Four
     more characters follow as shown below: 

Character 2 - mode
Y	 Year (UTC, two digits) 
M	 Month (UTC, two digits)
D	 Day (UTC, two digits)
H	 Hour (UTC, two digits)
N	 Minute (UTC, two digits)
 
Character 3-4 - time (after any rounding down)
-	 If each character equals Character 2 then 
	  do not modify the time
01	 Subtract 1 hour from the specified time
02	 Subtract 2 hours from the specified time
03	 Subtract 3 hours from the specified time
06	 Subtract 6 hours from the specified time
12	 Subtract 12 hours from the specified time
24	 Subtract 24 hours from the specified time
 
Character 5 - rounding down
-	 If character equals Character 2 then
	  do not round down (use system clock)
X	 12-hour rounding (Radiosonde hour)
	  (rounds down to 00 or 12 UTC)
S	 6-hour rounding down (Synoptic hour)
	  (rounds down to 00, 06, 12, or 18 UTC)
I	 3-hour rounding (Intermediate hour)
	  (round down to 00/03/06/09/12/15/18/21)

Examples
@HHHH		 Use the latest hour
@HHHS		 Round time down to 00/06/12/18 UTC
@H12S		 Round time down to 00/06/12/18 UTC

			     then subtract 12 hours 
 

	 Although Digital Atmosphere automati-
cally figures the time tokens for you based on 
the system clock, you may need to override 
them.  This is useful if you want to see data for 
earlier hours.  All you have to do is change the 
numbers that are displayed in the time token 
panel.
* Solving incorrect time problems.  If the time 
tokens always show a slightly incorrect hour, 
check your Preferences menu under the Gen-
eral tab and make sure the “Daylight Saving” 
checkbox is marked in accordance with wheth-
er daylight savings time is in effect.  If the 
hours are significantly off, go to your Windows 
control panel, look under Date/Time, and 
make sure your computer is set to the correct 
time zone.  Then make sure your system clock 
is set to a current time which is valid for that 
time zone.  For example, if you live in New 
York and typically have your computer clock 
set to Greenwich Mean Time, you will have to 
set the Windows time zone to “GMT” rather 
than Eastern Time.
* Solving access problems.  Digital Atmo-
sphere must have access to a regular Inter-
net network (Winsock)  in order to retrieve 
data.  If for some reason you can’t retrieve 
data through Digital Atmosphere, all is not 
lost.  You can still use your Internet browser to 
get products, then save them to your Digital 
Atmosphere data directory.  More adept us-
ers can use retrieval utilities like wget (http://
gnuwin32.sourceforge.net/ under Packages 
and WGet) to script the download of data and 
call Digital Atmosphere to import it on startup 
using a script.
* Technical tip.  Do you want to swap data 
product lists with other users?  No problem; 
we’ve made it easy.  Simply give them a copy of 
your DIGATMOS.URX file (it’s in your Digital 
Atmosphere Application Data directory; see 
Help > About).  If they replace their DIGAT-
MOS.URX file with yours, they’ll get your list 
of data products.  We sometimes revise the DI-
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GATMOS.URX file to give users the latest set of 
data products, so be sure to save a backup copy.
	 Be aware that if you edit the file directly, 
columns 5-9 are not generally used, except if it is 
set to MADIS it will be expecting binary MA-
DIS data.  Do not set it to this value for plaintext 
MADIS data; we use MADXX for this purpose.  
An ANTAR code was used before 2019 V3.10b 
to signal SSEC Antarctic data, but this has been 
dropped as the data source is no longer active.

5.2. Data plots
	 This option is provided near the top of the 
menu, since it’s one of the functions you’ll be 
using most.  What it does is draw station plots, 
which are symbolic representations of the 
weather data at each station.  You can check on 
how they are currently laid out and modify their 
appearance in the File > Preferences section.
	 If the station center represents sky condi-
tion (the default preference), a red station plot 
indicates instrument flight rules (IFR), which 
means the ceilings are below 1000 feet and/or 
the visibility is below 3 miles.  A blue station plot 
indicates marginal visual flight rules (MVFR), 
meaning the ceiling is below 3000 feet and/or 
the visibility is below 5 miles.  These colors are 
good for helping you visualize areas of low ceil-
ings and visibility at a glance.
	 To “fix” bad data, use the Quality Control 
function (described in the File chapter).  To per-
manently fix data from a station, edit the Station 
Rules (see Data > Edit Station Rules).
	 You may also prioritize any station for 
display on the map in the Station Rules above.  
The data crowding function (explained in Main 
Menu > Control Toolbar) will omit certain sta-
tions to prevent them from cluttering up other 
stations, but by setting a station rule you may 
require that the desired station is always plotted.

5.3. Custom data plots
	 You can use this to plot custom datasets on 
your screen.  These can originate from Digital 

Atmosphere’s Climatology module or from your 
own sets of data.  The density of these graphical 
plots is determined by the settings in Prefer-
ences, Station Plots.
	 The source file for custom data plots is 
always CUSTOM.DAT, located in your Digital 
Atmosphere directory (even if the source of data 
is climatology).  Here is an example of what the 
format looks like:

APR LOWEST PRESSURE 
US AL:Bir 722280    33.567    -86.750   2951 
US AL:Hun 723230    34.650    -86.767   2946 
US AL:Mob 722230    30.683    -88.250   2956 
US AL:Mon 722260    32.300    -86.400   2957

	 The first line is used as a map legend title, 
and the lines following that are actual data 
groups.  The columns must be organized as 
follows, and data must be left-justified into its 
respective column or it will not plot (i.e. putting 
a latitude in columns 23-25 will not work, but it 
will if it is shifted to column 21-23).
* Column 1-10: City name (not used at this time; 
you may omit it)
* Column 11-20: WMO block (not used at this 
time; you may omit it)
* Column 21-30: Latitude in decimal degrees 
(not minutes or seconds; negative is south hemi-
sphere)
* Column 31-40: Longitude in decimal degrees 
(not minutes or seconds; negative is west hemi-
sphere)
* Column 41-50: Data value at this location

5.4. Table plots
	 You can use this to plot data from table-based 
plaintext sources.  It is first necessary to write a 
template in digatmos.tpl.
	 See Appendix K, Tabular Data, for more 
information.  This functionality was developed to 
allow importing of Australian data.
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5.5. Television plots
	 “Television plots” are large, simple displays 
- similar to what you might see on television - 
of the temperature at predefined cities.  Each 
plot is made up of a temperature value and a 
city name.  The use of Celsius or Fahrenheit 
is controlled in File, Preferences under the 
Meteorological tab.  The font is controlled in 
File/Preferences under “Fonts”, and the color 
is specified by the setting on the “Maps” tab 
under “Plots, text, and contours”.
	 The television plots are controlled by the 
file DIGATMOS.PLL.  It contains an ICAO 
and WMO that correspond to the city (either 
may be left blank).  There can be up to 500 
entries.  The format is as follows:
Column 1-4		  ICAO of the station
Column 6-10		  WMO of the station
Column 12-61		 City name 

5.6. Warnings
	 (Under development)
	 Overlays National Weather Service flash 
flood warnings, winter storm warnings, severe 
thunderstorm warnings, tornado warnings, 
severe thunderstorm watches, and tornado 
watches.  You must have original National 
Weather Service warning bulletins on your 
system and stored in your data directory.  The 
directory and import mode specified in Prefer-
ences, Ingest method is critical to finding the 
warning files.
— If Normal Import Mode is on, Digital 
Atmosphere will look in all files in the Manual 
Import Mode Data Directory to locate warn-
ings (make sure it is set correctly).
— If Automatic Import Mode is on, Digital 
Atmosphere will look only in files meeting 
the filename convention used by EMWIN 
(e.g. WSW*.*, FLW*.*, FFW*.*, SVR*.*, and 
TOR*.*).  If you are not using EMWIN but are 
in automatic mode, simply name your data file 
TORN.TXT.
	 Once you see the warnings on the screen, 
you can view the text for any of the warnings 

by right-clicking on or near the county and 
choosing “Identify Warning”.  Do not display 
multiple screens with warning data if you in-
tend to use Identify Warning.
	 There may be some warnings that Digital 
Atmosphere is unable to process, most likely 
due to unusual text formats.  It’s always best to 
use the overlay as a first-guess, and if you have 
a critical need to study the current warnings, 
refer back to the original data files that you 
captured.  If you find a warning that doesn’t 
plot correctly, please pass it on to me (prefer-
ably via E-mail) and I’ll adjust the program to 
plot it (and others like it) correctly.

5.7. AMDAR plot
(Under development)

5.8. Fronts
	 This option allows plotting of georefer-
enced fronts, highs, and lows. The features 
are georeferenced, therefore you can always 
plot them later even if you zoom in or quit the 
program. You will lose your frontal depictions 
if you again create a depiction or if you import 
original ASUS1 data.
	 Using original sources of data. Raw sources 
of data consist only of the ASUS1 KWBC nu-
merical text bulletin produced by the National 
Weather Service (covers the North American 
region only). This bulletin must have been im-
ported and found with its headers intact before 
it can be plotted. The bulletin is usually found 
on Unidata servers under data/surface/front 
or a similar directory, or by the bulletin header 
name itself. A couple of links are provided in 
Digital Atmosphere’s Internet > Retrieve Data 
window, which should be used if possible. 
	 If you prefer to create your own frontal 
analysis, use the “Fronts” tab on the control 
toolbar on the left side of the screen (see Chap-
ter 2, Control Toolbar).
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5.9. Fleetcode
	 Imports FLEETCODE format data. It pro-
duces graphics like those shown below. All fronts 
and isobars are plotted as spline curves, and due 
to the limited resolution of the data they may 
not display optimally. There is no way to alter 
how a spline plots except to change the scale of 
the workchart.
	 To the author’s knowledge, FLEETCODE 
data is produced only for Europe. It comes in 
under the ASXX21 Family of Services header. 
One source ready for use is provided in the de-
fault Internet tables.

5.10. Sferics
	 Downloading of SFUK/SFLOC lightning strike 
data is no longer supported in Digital Atmosphere 
due to the UK Met Office withdrawing the SFUK 
bulletin from public access, citing Resolution 40 
restrictions.  The data will only be viewable if a 
disk files with sferic data is being used.
	 Europe’s primary lightning network consists 
of five stations in the UK, one in Cyprus, and 
one in Gibraltar. The stations listen for static 
and use triangulation of the time delay to pin-
point the location. This is encoded to the nearest 
half-degree, yielding a resolution of about 40 
km. The commonly-available British bulletin 
(SFUK) has a domain of 40W to 40E and 30N 
to 70N. The time period for each bulletin is 30 
minutes, and a new bulletin is generated every 
30 minutes. The SFUK is based on the WMO 
FM 32-I SFLOC code form but is adapted under 
a national variation. The British Met Office does 

have a new system online that can pinpoint 
lightning within 100 meters, however this data is 
not publically distributed. Contact the Met Of-
fice if you need access to this data.

5.11. Convective outlooks
	 This option plots convective outlooks (thun-
derstorm forecasts) issued by the National 
Weather Service’s Storm Prediction Center 
(SPC) in Norman, Oklahoma. These are central-
ized human-produced forecasts issued sev-
eral times a day, and are used to help provide 
guidance to National Weather Service forecast 
offices. They are also used frequently by storm 
chasers, pilots, and hobbyists.
	 To use this option, you must have imported 
a convective outlook as part of your raw data set 
or from one of the choices in Internet > .
	 Advanced users can modify the color scheme 
by changing the contents of the file DIGATMOS.
CCC in the Digital Atmosphere directory using 
a standard text editor such as Notepad (never 
use a word processor such as Microsoft Word 
or you will corrupt the file). This file contains 
self-explanatory instructions for modifying the 
hexadecimal numbers used to determine colors 
of the various threat boundaries.
	 If there are any problems ingesting a bulletin, 
the problem is most likely an error in the com-
position of the bulletin. It is not necessary for 
the header to be intact, but the “STORM PRE-
DICTION CENTER” title must appear in the 
bulletin along with the convective outlook type, 

FIGURE 5-1. SPC Reports, added 
in 2020.
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valid times, and standard bounding locations 
of each threat area.

5.12. SPC reports
	 This plots reports of tornadoes, hail, or sig-
nificant wind (50 kt or greater) received by the 
NOAA Storm Prediction Center in Norman, 
Oklahoma.  Tornado data appears on the map 
as red squares, hail data appears as green dia-
monds, and wind data appears as blue circles.  
Valid dates are anytime from June 1, 1999 to 
the current calendar date.
	 For most cases, the user should choose 
“Direct SPC Download” to receive the data 
direct from SPC.  Simply enter the date in 
YYYYMMDD format in the “Requested Date” 
box.  This is in local time and spans 1200 UTC 
of the morning of interest to 1200 UTC the 
following morning.  Data for the current date 
is usually updated to within the past 10 min-
utes.  There are some gaps with older histori-
cal data, so you get a 404 “not found” error 
with some dates.  You can visit the SPC Storm 
Reports website to verify the date is missing.
	 For saved files on the local hard drive, us-
ers may select “Load from file”.  It is important 
to also select which type of bulletin is being 
imported, since this information is not pro-
vided in the rows or columns.  Failure to do 
this will result in the wrong type of plot on the 
screen.
	 Before the data is selected, you may also 
filter the SPC reports by time in the lower 
panel, “Options”.  If you choose “before”, only 
data before the HHMM time will be plot-
ted, and if you choose “after”, all data after the 
time will be plotted.  All other data, including 
reports for the exact time value itself, will not 
be plotted.

5.13. Hurricane tracks
	 Plots hurricane tracks from the National 
Hurricane Center (NHC) or Joint Typhoon 
Warning Center (JTWC) forecast/advisory 

bulletin (WTNT, WTPZ, WTPN, WTIO, and 
WTXS). This shows the current and forecast 
location of hurricanes, typhoons, and tropical 
storms. A track connecting each forecast point 
is created using a mathematical spline.
	 The source bulletin needs to be the NHC 
forecast/advisory or JTWC warning with 
coordinates and forecast positions. They can 
be automatically downloaded via the Internet 
> Retrieve panel. If there is any problem with a 
bulletin not plotting, it may be due to an error 
in the way the bulletin is written. Decoding 
these bulletins into machine-readable format 
is not always error-free.
	 Currently there is no support for bulletins 
from other global hurricane centers.
	 Technical information: The import mod-
ule locates hurricane bulletins based on the 
National Hurricane Center header (KNHC) 
or the Joint Typhoon Warning Center header, 
and saves them to the queue.hur holding file. 
When Data > Hurricane Tracks is requested, 
the hurricane module reads queue.hur and 
displays any available bulletins.

5.14. Sounding
	 This function allows you to display a 
sounding (a SKEW-T diagram, or graph of the 
vertical structure of the atmosphere above a 
point) for a chosen station.  You must have al-
ready imported upper air (rawinsonde or FD) 
data.  You will be prompted to enter the WMO 
or ICAO for the station that you want to view.  
The “Rescale” button resizes the SKEW-T win-
dow to its normal size (unstretches it).
	 If you do not know the WMO or ICAO 
you want to use, you can simply right-click on 
any horizontal map window and choose “Dis-
play SKEW-T”.  Digital Atmosphere will locate 
the closest rawinsonde observation and plot 
the sounding for you.

5.15. Cross section
(Under development)	
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5.16. Extract model data
	 This command extracts various elements 
from NGM and ETA output bulletins which 
have been imported.
	 Prior to using this command, you must 
use the status panel to (1) choose the desired 
Forecast Hour, and (2) to select the model you 
want (under Active Level). The extracted data is 
saved into a custom data file. Then you may use 
Overlay, Custom Data or Analyze, Custom Data 
to plot or contour that data element. For more 
details on custom data files, see Overlay, Custom 
Data in the “Overlay Commands” chapter.

5.17. Troubleshoot data
	 This interface shows at a glance which data-
sets are available from the most recent import 
operation. If a dataset is shown as empty, it 
cannot be plotted. Note that some data may be 
shown which does not really exist, due to wide 
variations in coding formats. You should consult 

this to check on any problems before reporting 
a problem about data not plotting. If no data is 
shown, check your source, the URL it came from 
(if any), and make sure the system clock settings 
are correct on your computer since some prod-
ucts are time-dependent.
	 Protip (US users): if you are still not get-
ting data and have tried everything, check the 
National Weather Service Telecommunications 
Gateway outages page at: http://tgftp.nws.noaa.
gov/tgstatus/ for messages.  On rare occasion 
there may be data outages.

5.18. View raw data
	 Sometimes you will want to go back and 
look at the original data.  Program users may 
wish to review observations for vital clues (such 
as observer remarks), as well as look through 
any other data embedded in the data files.
	 The file that is viewed is the internally-saved 
clean data file produced by the most recent File 
Import or Data Retrieve command.  The original 
raw source file is not referenced and does not 

FIGURE 5-2. The station 
rules table window.

Technical notes
The station rules table, 
when saved as default, is 
written to digatmos.rul, 
providing a feature that 
was first implemented 
in January 2001.  The 
file required direct edit-
ing with tools like Note-
pad until the addition of 
this “Edit Station Rules” 
dialog in March 2019.  If 
you still want to directly 
view or modify the rule 
file, go to your Appli-
cation Data directory 
(given in Help > About) 
and edit digatmos.rul 
with Notepad or a similar 
text editor.
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have to be present.  If you don’t like this inter-
face, you can view the same data file (DATA.
USR in the Digital Atmosphere directory) us-
ing any text editor.
	 The View Raw Data panel also has a .Find. 
function that lets you search for stations and 
keywords in the file.

5.19. Edit station rules
	 This function displays the station rule 
set.  It allows users to permanently modify or 
delete variables at a given station before they 
are plotted and analyzed.  This is useful for sta-
tions that are sending out bad data and must 
be repeatedly quality-controlled.  Rows with 
DELETE must be reloaded  from the Internet 
or from the local disk file for the changes take 
effect.  Rows with PRI will take effect with the 
next data plot.
	 You may move and reorganize rows by 
dragging the gray button on the left side of 
each row.  Rows are inserted by using the 
“Insert Row After” button, in which case a 
row will be inserted after the currently active 
row.  The currently active row may be deleted 
with the “Delete Row” button.  Use “Cancel” 
to avoid saving changes.  Currently there is no 
sort feature, so clicking the top header of the 
column will not sort rows.
	 When the window is first opened, the 
default station rules are displayed.  Pressing 
“Save Rules As Default” will replace the default 
rules with this table, including any changes 
that were made.  Pressing “Cancel” will cancel 
making any changes.
	 You may also choose to save your rule set 
to a disk file as a backup or for other types of 
analysis work.  You may do so using “Save To 
File”.  Likewise, “Load From File” will view any 
previously saved rule sets.  Be careful not to 
press “Save Rules As Default” unless you want 
these rules to be active.
	 Again, remember the changes to the sta-
tion tables do not take effect until “Save Rules 

As Default” is pressed and data is reloaded via 
Data Retrieve or a Load File selection.

Column 1 - Station
	 The station identifier (ICAO, WMO, or 
buoy number) that the rule will apply to is 
listed here.
	 WMO, buoy, and ship stations must be 
prefixed with W-, B-, and S- respectively be-
fore their station identifier.  This is to prevent 
conflicts since sometimes they may use the 
same number.  If a number is not prefixed it 
will be assumed to be a WMO station.

Column 2 - Data type
	 Indicate the type of data from the given 
station that will be modified.  Valid selec-
tions are ALL for all elements.  For specific 
elements, use TEMP, DWPT, WDIR, WSPD, 
SLP, or ALST, for temperature, dewpoint, wind 
direction, wind speed, sea-level pressure, and 
altimeter setting, respectively.  Only one data 
type may be specified; to handle multiple data 
types you will need to create additional table 
rows.

Column 3 - Action
	 This indicates the action that will be ap-
plied to data matching the given station and 
data type.  Valid selections are DELETE or 
DEL to remove the data, and PRI to prioritize 
the station for display.
	 Prioritizing a station for display will plot 
the station first before any other data is plot-
ted, ensuring it appears on the map.  This may 
be useful at very low settings of the data plot 
crowding slider (see Main Menu chapter under 
Control Toolbar).
	 The PRI functionality  replaces the older 
system before March 2019 (V3.20) in which 
prioritized stations were maintained in the file 
digatmos.pri.

Column 4 - Quantity
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	 Not used.  This will be used in the future for 
modifying data values.

Column 5 - Notes
	 Users may enter notes here.  This data is not 
used by the software.
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	 Digital Atmosphere hosts a powerful suite of 
tools for analyzing various atmospheric proper-
ties.  It is quite simple to use.  You simply click 
on a primary field that you want to view (such 
as temperature, wind speed, pressure, etc) in the 
Analysis menu.  However, if you first click on a 
derivative field (i.e. vorticity, divergence, or ad-
vection) in the status panel, Digital Atmosphere 
places a checkmark next to that field.  Derivative 
fields are not analyzed until you click on a pri-
mary field from the Analysis menu.  Only then 
are the derivative choices looked at.  All analysis 
methods are computed based on whatever level 
is selected under the “Active Level” pop up menu 
on the status panel, so if the analysis does not 
appear, it means no data is available for the ac-
tive level.
	 To “fix” bad data, try to determine the loca-
tion of the problem and use the Quality Control 
function (described in the File chapter) to find 
the bad data.  Then erase the map and analyze 
the chart again.  To permanently fix data from a 
station, use the Rule File (described in the Qual-
ity Control section above.
	 Font types used during analysis (contouring 
and labelling) operations are controlled in “File/
Preferences/Fonts” under “Annotations”.  Only 
the font name is used; the size is ignored.

6.1. Analysis basics
	 To fully understand how the analysis rou-
tines work, you have to know a little bit about 
the theory behind them.  All meteorological 
fields can be described as a series of waves.  For 
example, assume that at a certain time the cold-
est spot in the country is International Falls, 
MN at 12°F and the hottest spot is Death Val-
ley, CA at 96°F.  Then draw a long line on your 

map that passes through both of those points.  If 
you graph the temperatures along this line and 
gather data from cities along the line, your tem-
perature graph will show unique undulations, 
rises, and falls.  These are mathematical waves in 
the temperature field.
	 Assume that you find that the temperature 
200 miles on each side of Death Valley (along 
the line) is 94 deg F.  You could then assume 
most of the southwest United States is hot.  The 
temperature graph would show a gradual rise 
towards Death Valley and a gradual fall as you 
move away.  But what if the temperature 200 
miles on each side is instead 52 deg F?  With 
Death Valley being at 96, this would appear 
on your graph as a short upward “spike” at the 
location corresponding to Death Valley.  These 
are two unique mathematical waves — the first 
one (with gradual rises and falls) means that the 
temperature field is composed of large or long 
wavelength features.  The latter situation (with 
sharp spikes and dips) means that the tempera-
ture field is composed of short or small wave-
length features.  As you can see, gradual changes 
mean that the meteorological field has long 

6 / Analysis
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wavelength characteristics, and sharp localized 
changes imply small wavelength features.
	 Digital Atmosphere uses a 30 x 30 mesh 
(adjustable in Preferences > Analysis) to 
sample these conditions.  The mesh is like lines 
that are drawn across the map, 30 across and 
30 down, to sample the wave structure that is 
present in the type of analysis you pick.  Using 
equally-spaced grid points is the easiest way to 
perform computerized analysis calculations.  
Digital Atmosphere must find where reporting 
stations are within the grid, and try to map the 
values to that grid, taking into consideration 
how far the reporting station is from a grid-
point and figuring out what to do with grid-
points that aren’t assigned any data.  This is 
what takes up the majority of processing time.
	 So why not just map values to the grids 
and interpolate between all the points?  Digital 
Atmosphere’s nearest neighbor technique does 
something like this.  It maps data to gridpoints 
and fills in unassigned gridpoints using the 
nearest data value, a process known as expan-
sion.  However, if the temperature in San Fran-
cisco is 52 and in Los Angeles is 85 (and as-
suming we have NO other data), the analyzed 
field anywhere in California will show either 
52 or 85 degrees!  This is clearly not correct, 
so after expansion, Digital Atmosphere runs a 
smoothing algorithm.  Smoothers “even out” 
the mesh by changing the value at each grid-
point to an average of itself and its neighbors.  
Unfortunately, this can dampen out features in 
the field.  Too much smoothing will remove all 
of the short wavelength features.
	 A better way to do this is to use the 
Weighted, Barnes, or Cressman techniques.  
See the Preferences > Analysis section for 
more information.  Proper selection of analysis 
type gives much better control over smooth-
ing, which is not available from Internet web 
charts, and allows the software to accurately 
resolve a mix of large waves as well as small, 
localized waves.
	 Let’s now take a closer look at each type of 
analysis.

6.2. Analysis fields

Temperature
	 Analyzes the free air temperature in either 
degrees Fahrenheit or degrees Celsius.

Potential temperature
	 Potential temperature is what the tempera-
ture of the air would be if it was forced to the 
1000 mb level.  In other words, it eliminates 
the effects of elevation, allowing you to effec-
tively compare temperatures in mountainous 
areas using a common temperature measure-
ment.

Equivalent potential temperature (theta-e)
	 Equivalent temperature indicates the 
potential temperature of a parcel of air whose 
latent heat had been completely released.  
Physically, it’s what the parcel’s temperature 
would be if it were forced upwards to about 
200 mb then forced downwards to 1000 mb.  
In any given atmosphere, higher values of 
surface or low-level theta-e will always yield 
higher instability values (it’s a better indicator 
than dewpoint or temperature), so theta-e is 
useful for seeing where an inversion or cap is 
about to break.

Dewpoint temperature
	 The dewpoint is the temperature that the 
air must be cooled to before saturation begins.  
It is proportional to the actual quantity of 
moisture present in the air, so it is often used 
as a universal indicator of the “moisture” in the 
air.

Mixing ratio
	 This measure tells you exactly how much 
moisture is in the air.  It is calibrated in grams 
of water vapor per kilogram of air.  Mixing 
ratio is basically the same type of measure-
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Figure 6-1. Com-
parison of nearest 
neighbor (top) and 
Cressman (bottom) 
analysis.  In the Cress-
man analysis the sur-
face radius has been 
increased to 1000 nm 
and reduction inter-
val increased to 5 to 
handle the large voids 
between stations.  The 
result is a much better 
depiction of oceanic 
systems, in particular 
the high pressure area 
from the Gulf of Alaska 
to the lower right 
corner.  Also note the 
more evenly-spaced 
isobars across the 
Aleutian Islands.  In 
spite of that, contours 
near very isolated 
stations like the one 
just below the image 
center can take on a 
dipole appearance due 
to the lack of gradi-
ent information.  This 
can be improved with 
the use of smooth-
ing.  Note the good 
detail on smaller scale 
systems like the Alas-
kan occlusion, and the 
more refined isobar 
field in the Aleutians, 
thanks to the versatil-
ity of the Cressman 
technique at different 
scales.
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ment as dewpoint, however, mixing ratio is 
an absolute, measurable quantity, and with 
increasing amounts of moisture, changes in 
mixing ratio become more significant than 
changes in dewpoint.  This makes it ideal for 
finding features in moist air masses, especially 
in severe weather situations.
	 At the surface, by checking the divergence 
derivative and clicking mixing ratio, you can 
produce a “moisture convergence” chart use-
ful for forecasting severe thunderstorms.  By 
clicking that and the advection derivative, 
you can produce “moisture flux convergence” 
(SMC).  In an unstable atmosphere, it takes a 
few hours for SMC to produce convection, so 
persistant SMC areas must be watched.  SMC 
patterns are more important than the actual 
values.

Relative humidity
	 This is a measure of how close the air is to 
being saturated.  An analogy is having a shot 
glass half full of water, and a large jar half full 
of water.  Relative humidity is like saying that 
each of the containers is 50% saturated with 
water, regardless of the true amount in the 
container.

Wind chill
	 The wind chill is an empirical equation 
describing what the temperature feels like to a 
person based on the free air temperature and 
the wind speed.  The wind chill always equals 
the free air temperature when the winds are 4 
knots or less.

Heat index
	 The heat index is an empirical equation 
describing what the temperature feels like to a 
person based on both the free air temperature 
and the relative humidity.

Humidex
	 This is similar to the heat index but is often 
used in Canada.  It equals H = T + (0.5555 * 
(e - 10)), where T is the temperature in Celsius 
and e is the vapor pressure in mb.  Further in-
formation is available in Humidex, A method of 
quantifying human discomfort due to excessive 
heat and humidity, by J.M. Masterton and F.A. 
Richardson, CLI 1-79, Environment Canada, 
Atmospheric Environment Service, Downs-
view, Ontario, 1979.

Sea level pressure   
	 (Surface data only)  The sea level pressure 
is the atmospheric pressure at the surface in 
millibars reduced to sea level, taking into ac-
count temperature patterns over the previous 
12 hours.  It is similar to altimeter setting, but 
not the same.  It’s biggest use is for compar-
ing patterns over a broad area, as in synoptic 
analysis.

Altimeter setting   
	 (Surface data only) The altimeter setting, 
measured in inches, is what the surface pres-
sure would be if it were reduced to sea level, 
however it takes into account no temperature 
corrections.  Unlike the sea-level pressure, if 
the temperature outside varies drastically, the 
altimeter setting will fluctuate.  Altimeter set-
ting is typically what is used by the National 
Weather Service to report pressure readings 
to the public.  It is somewhat more commonly 
available than sea level pressure, so it finds use 
in day-to-day mesoscale analysis.

Geopotential height   
	 (Radiosonde data only) Geopotential height 
(usually called simply “height”) is the height 
of a given pressure surface (such as 300 mb) in 
meters.  It is widely used in upper-air analysis
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About analysis

 	 To fully understand how the analysis rou-
tines work, you have to know a little bit about 
the theory behind them. All meteorological 
fields can be described as a series of waves. 
For example, assume that at a certain time 
the coldest spot in the country is Interna-
tional Falls, MN at 12°F and the hottest spot is 
Death Valley, CA at 96°F.  Draw a long line on 
your map that passes through both of those 
points. If you graph the temperatures along 
this line and gather data from cities along the 
line, your temperature graph will show unique 
undulations, rises, and falls. These are math-
ematical waves in the temperature field.
	 Assume that you find that the temperature 
200 miles on each side of Death Valley (along 
the line) is 94 deg F. You could then assume 
most of the southwest United States is hot. 
The temperature graph would show a gradual 
rise towards Death Valley and a gradual fall as 
you move away. But what if the temperature 
200 miles on each side is instead 52 deg F? 
With Death Valley being at 96, this would ap-
pear on your graph as a short upward “spike” 
at the location corresponding to Death Valley. 
These are two unique mathematical waves 
— the first one (with gradual rises and falls) 
means that the temperature field is composed 
of large or long wavelength features. The latter 
situation (with sharp spikes and dips) means 
that the temperature field is composed of 
short or small wavelength features. As you can 
see, gradual changes mean that the meteoro-
logical field has long wavelength characteris-
tics, and sharp localized changes imply small 
wavelength features.
	 Digital Atmosphere uses a 30 x 30 mesh 
(grid) to sample these conditions. The mesh 
is like lines that are drawn across the map, 
30 across and 30 down, to sample the wave 
structure that is present in the type of analysis 

you pick. Using equally-spaced grid points is 
the easiest way to perform computerized analy-
sis calculations. Digital Atmosphere must find 
where reporting stations are within the grid, 
and try to map the values to that grid, taking 
into consideration how far the reporting station 
is from a gridpoint and figuring out what to do 
with gridpoints that aren’t assigned any data. 
This is what takes up the majority of processing 
time.
	 So why not just map values to the grids and 
interpolate between all the points? Digital Atmo-
sphere’s nearest neighbor technique does some-
thing like this. It maps data to gridpoints and 
fills in unassigned gridpoints using the nearest 
data value, a process known as expansion. How-
ever, if the temperature in San Francisco is 52 
and in Los Angeles is 85 (and assuming we have 
NO other data), the analyzed field anywhere in 
California will show either 52 or 85 degrees! This 
is clearly not correct, so after expansion, Digi-
tal Atmosphere runs a smoothing algorithm. 
Smoothers “smooth” out the mesh by changing 
the value at each gridpoint to an average of itself 
and its neighbors. Unfortunately, this can damp-
en out features in the field. Too much smoothing 
will remove all of the short wavelength features.
	 A better way to do this is to use the Weight-
ed, Barnes, or Cressman techniques. These 
techniques look at each gridpoint, find where it 
corresponds to on the earth, and from that loca-
tion it looks at the values of the stations around 
it and figures out a carefully averaged value best 
representing what the value at that gridpoint 
probably is. The Barnes algorithm goes a step 
further by going back and seeing how incorrect 
its mesh turned out to be, then adjusting that 
to produce a final analysis. The Cressman algo-
rithm does the same thing, but it also begins its 
analysis using values at stations over a wide area, 
then gradually tightens up its analysis, running 
corrections and using values at stations over 
a progressively more narrow area. This allows 
Cressman to accurately resolve large waves as 
well as small, localized waves.
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Wind speed
	 This is the speed of the air movement, 
usually measured in knots (nautical miles per 
second, or 1.15 mph).

Observed wind  
	 (Vector field) Computes an observed wind 
grid, as reported in the weather data.  The “ar-
row” of the feather or vector points towards 
where the wind is going.

Custom data file
	 Analyzes a custom data set from your 
CUSTOM.DAT file (see the appendix on Cus-
tom Data for full details).  The contour base 
and interval are automatically determined.

Geostrophic wind  
	 (Vector field) Computes a wind grid based 
on the pressure or geopotential height field.  
Geostrophic wind is based on the pressure 
gradient and the Coriolis effect, and due to the 
effects of friction, it is always higher than the 
observed wind speed.  Geostrophic winds are 
useful for getting an idea of how strong the 
winds will be later in the morning when air 
flow is being suppressed by radiational inver-
sions.

Ageostrophic wind  
	 (Vector field) This is the vector difference 
between the actual wind vector and the geo-
strophic wind vector.  Ageostrophic wind is 
stronger when the pressure and wind fields are 
out of balance.  Much of the vertical motion 
in the atmosphere can be attributed to ageo-
strophic flow.

Q-vectors   
	 (Vector field) The omega equation is a diag-
nostic for the total time derivative of pressure.  
It allows synoptic-scale vertical motion to be 
accurately estimated by analyzing tempera-
ture and wind fields above the boundary layer.  

The omega equation is defined as shown here, 
where the term on the left side of the equation 
indicates vertical motion.  On the right side, 
the left term is proportional to differential vor-
ticity advection, while the right term solves for 
thickness advection.  So positive differential 
vorticity advection plus warm thickness advec-
tion equals upward vertical motion.  A Q-vec-
tor roughly depicts the ageostrophic horizontal 
wind that develops in order to maintain the 
thermal wind balance in a developing synoptic 
system.
	 Q-vector convergence implies synoptic-
scale upward vertical motion, and Q-vector 
divergence implies downward vertical motion.  
This can be interpreted either by looking at the 
Q-vectors or running a derivative convergence 
field together with Q-vectors.  Also, where 850 
mb Q-vectors cross the 850 mb isotherms, 
moving towards warmer air, frontogenesis 
is indicated.  Q-vectors crossing into colder 
temperatures indicate frontolysis.  This qual-
ity is known as the “geostrophic frontogenesis 
function” (use 700 mb levels in mountainous 
areas).  Avoid using the advection derivative to 
forecast Q-vector movement, since the field is 
constantly changing and may not be represen-
tative after a few hours.

Divergence
	 Divergence is a measure of the amount of 
stretching of a parcel of air, or the relative rate 
of increase of a material surface.  Divergence is 
defined by the following, where u and v are the 
x and y components of wind, respectively.

Relative vorticity
	 Relative vorticity is a measure of curl of the 
air.  Geometrically, vorticity is twice the an-
gular speed of rotation of a parcel that moves 
with the flow.  It is a relatively simple expres-
sion of the flow of air, and is most often used 
to examine the wind field within the boundary 
layer.  Relative vorticity is defined by the fol-
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lowing, where u and v are the x and y compo-
nents of wind, respectively.

Absolute vorticity
	 Absolute vorticity is the same as relative 
vorticity, however, the Coriolis effect is added 
into the equation (absolute vorticity equals rela-
tive vorticity at the Equator).  Absolute vorticity 
of the wind is used most frequently in upper-air 
analysis.
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	 The radar menu is for native support of the 
United States WSR-88D radar systems.  Cur-
rently, the United States is the only country in 
the world that openly shares its raw radar data in 
real time.  Although Europe and other countries 
have similar radar networks, the data is propri-
etary and consequently Digital Atmosphere is 
unable to support this data except through low-
resolution imports of publicly available images 
(the user can configure these if they are avail-
able; see the Import Radar Images section).
	 Digital Atmosphere’s radar module processes  
Level III high-resolution data directly from sites 
that carry the data feed. Because there are over 
100 radar sites and 31 products at each site that 
can be used operationally, Digital Atmosphere 
has implemented a completely separate, unique 
system for retrieving data. The Data > Retrieve 
interface used for “normal” weather data is not 
used. Rather, all choices for obtaining data are 
built into the radar menu and controlled by op-
tions in Preferences.
	 To use the radar menu, you simply (1) 
make sure the station you want is set (with Set 
NEXRAD Station or Quick Pick); and (2) click 
on the product you want. The image will be 
downloaded (taking anywhere from 1 to 30 sec-
onds) and will be displayed immediately on the 
current workchart.
	 Special note about choosing multiple sta-
tions: Digital Atmosphere can only access a 
handful of stations at a time. It cannot access all 
stations in the U.S., because currently no server 
provides current data combined in one file, and 
accessing each file individually would take sev-
eral minutes of time and potentially “hammer” 
the server with requests. Digital Atmosphere is 
also intended to be a tool to view local storms 
and phenomena rather than to build national 

7 / Radar

mosaics, which are readily available on the Inter-
net from countless sources. If you select two or 
more stations, Digital Atmosphere will mosaic 
the radar based on highest reflectivity at a given 
bin.

7.1. View last radar product
	 This function will display any radar data that 
has been recently imported. You can use it to re-
display existing data without causing the system 
to download new radar data.

7.2. View radar free text messages
	 This will view freeform text messages (if 
present) contained in the downloaded data files.  
This generally has information on things like 
outages.

7.3. Load radar data from file
	 Rather than accessing new radar data 
through the Internet, you may load the data 
from an existing file. Any NEXRAD data in 
this file will be imported and automatically 
displayed. You may save data to be loaded and 
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viewed again at any time in the future by using 
the “Save radar data to file” command.

7.4. Save radar data to file
	 Saves any imported radar data to a file of 
your choice. You may then view it again later 
by using the “Load radar data from file” op-
tion.
	 Advanced users: This basically copies the 
queue.nid holding pen to your desired loca-
tion.

7.5. Import radar images
	 This is a sophisticated interface that allows 
any graphical radar image to be georeferenced 
and mapped into Digital Atmosphere.  This 
provides a “poor man’s” solution that can be 
used with international radar sites that just 
have a static graphical image.
	 Please see the appendix for complete 
information on how these are constructed and 
built.

7.6. Set NEXRAD station
	 Before Digital Atmosphere can access 
NEXRAD data from the Internet, it must 
know which stations you want to look at. A 
map will be displayed and you will be able to 
select the sites for which data should be ac-
cessed.

7.7. Quick pick
 Allows you to quickly set a new station by 
typing its identifier into an entry box. This is 
designed for advanced users. Always enter the 
three-letter identifier, such as FWS, MHX, or 
CCX.  If there are multiple stations, separate 
them with a space.
	 If you do not know what to enter or how 
to use this box, use the Set NEXRAD Station 
interface instead.

	 Special note: Please see “Special Note 
About Choosing Multiple Stations” in the 
radar introduction.

7.8. Tilt 1 reflectivity
	 Shows the most common radar product: 
radar reflectivity at the lowest (0.5 deg) scan. 
Radar echoes are shown as color-coded poly-
gons that may be one of 15 colors. If you need 
to see a scan over a wider area or at different 
elevations, use the expanded Reflectivity menu 
instead to select a more specialized reflectivity 
product.

7.9. Reflectivity
	 Shows radar echoes in any of several for-
mats. Reflectivity is simply a measure of power 
returned to the radar in decibels (dBZ).
* 0.5 deg. Shows reflectivity from scan eleva-
tion 1, tilted 0.5 deg from the ground. This is 
exactly the same as “Tilt 1 Reflectivity” selec-
tion shown in the radar main menu, so you 
should not normally have to select this item.
* 1.5 deg. Shows reflectivity from scan eleva-
tion 2, tilted 1.5 deg from the ground.
* 2.4 deg. Shows reflectivity from scan eleva-
tion 3, tilted 2.4 deg from the ground.
* 3.4 deg. Shows reflectivity from scan eleva-
tion 4, tilted 3.4 deg from the ground.
* Extended (248 nm) 0.5 deg.  This is similar to 
the 0.5 deg reflectivity scan, but shows it over 
a wider area (248 nm). This comes at the cost 
of degraded resolution (1.1 nm instead of 0.54 
nm).
* Composite. Composite reflectivity blends 
all available elevations, showing the highest 
reflectivity in all elevations above a given point 
on Earth. This is useful for showing all echoes 
returned by the radar, regardless of scan eleva-
tion. However this masks important features 
useful for severe weather forecasting, such as 
hook echoes and reflectivity gradients which 
are seen only on base slices. Composite reflec-
tivity can give false impressions of precipita-
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 	 Remote data is selected with the digatmos.
rad file. Data is imported into queue.nid, then 
is plotted. The digatmos.nxc file is used to 
define how fields are plotted, and digatmos.
nex defines the colors. Since the station iden-
tifier is not contained within the data blocks, 
the NEXRAD station table (digatmos.nxa) is 
consulted (this table is built from digatmos.
stn whenever doing a Recompile Tables com-
mand).
	 For advanced users who are custom-
izing access URLs, a list of valid product 
codes for Internet retrieval can be found 
at: http://www.nws.noaa.gov/tg/radfiles.
php . To get historical NEXRAD data, visit 
http://has.ncdc.noaa.gov/plclimprod/plsql/
HAS.FileAppSelect?datasetname=7000 
. Level II data is at http://has.ncdc.
noaa.gov/plclimprod/plsql/HAS.
FileAppSelect?datasetname=6500 but is not 
compatible with Digital Atmosphere at this 
time.

* Setting and overriding radar access URLs . 
Users are able to change URLs correspond-
ing to the desired products. This is done by 
editing the digatmos.rad file. Within this file 
you construct a template for retrieving the 
NIDS Level III radar file. Only the URLs in 
the “Default” section are used under normal 
circumstances. However you can override 
them by creating new sections (which con-
tain a title that starts with an equal sign). To 
implement any radar access source, set the 
“Preferred source” in Set NEXRAD Station to 
something besides Default. If the product you 
request cannot be found in the override, the 
one in the default section will be used.

* Setting and overriding color schemes . Like-
wise, users are able to set and override color 

schemes. To do this, simply edit the digatmos.
nex file. To implement any color scheme, go to 
Set NEXRAD Station and choose something 
besides the default color scheme. Color schemes 
for annotations, storm tracks, hail, mesocy-
clones, and so forth, are handled in the map’s 
color table (you may either edit this in File > 
Preferences > Colors or by directly editing any 
file in the /styles directory).

* Translucency: Radar echoes are drawn using 
translucent polygons. Due to the limited capabil-
ity of the graphics library currently being used, 
there is only limited support for translucency at 
this time.  For best results, make sure your base-
map is as bright or as dark as possible. Before 
plotting radar echoes, Digital Atmosphere will 
examine your style file for the background color 
(bas, in Preferences > Styles) and use the appro-
priate translucency algorithm based on whether 
it is closer to white or black. If you get unusual 
results, change your background color or regen-
erate the map, preferably towards the white or 
dark end of the spectrum.

* Mosaicing.  When plotting radar imagery for 
multiple sites, an important problem arises when 
Digital Atmosphere has to decide which radar’s 
data to use for a particular location.  The rule is 
that Digital Atmosphere plots the pixel for the 
nearest radar site.  The exception is when raster 
images (such as echo tops, composite reflectiv-
ity, etc) are displayed; in this case the pixel with 
the highest detected level is used (this raster rule 
took effect with Equinox v1.05, 1/16/07, and 
later versions).

RADAR: Technical information & overriding the defaults
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tion at the surface from suspended precipita-
tion, as in storm anvils.
* Extended (248 nm) composite.  This is similar 
to the composite product but reaches over a 
wider area: 248 nm instead of 124 nm.

7.10. Velocity
	 Shows radial velocity (to and from the 
radar site) in any of several formats. It is 
expressed in knots. Positive velocity is always 
motion away from the radar, while negative 
velocity is always motion toward the radar. As 
a mnemonic it is useful to link positive (“typi-
cal”) values to that of energy being transmitted 
from the radar (“typical” radar energy), and 
negative values as being associated with energy 
coming back the other way.
* 0.5 deg. Shows velocity from scan elevation 1, 
tilted 0.5 deg from the ground.
* 1.5 deg. Shows velocity from scan elevation 2, 
tilted 1.5 deg from the ground.
* 2.4 deg. Shows velocity from scan elevation 3, 
tilted 2.4 deg from the ground.
* 3.4 deg. Shows velocity from scan elevation 4, 
tilted 3.4 deg from the ground.
* Short 32 nm (0.5 deg). Surprisingly, the radar 
generates a close-range velocity product with a 
gate resolution of only 790 feet! You can view 
this product here for looking at storms up 
close.
* SRM 0.5 deg. Shows storm-relative mean 
radial velocity from scan elevation 1, tilted 0.5 
deg from the ground. The storm-relative mean 
radial velocity (SRM) product is essentially the 
same as base velocity, but removes the compo-
nent of the storm’s motion, allowing velocity 
signatures to be more accurately analyzed. This 
product is preferable to the standard velocity 
products for storm forecasting. The source for 
the storm motion component is usually the 
average motion of all storms detected by the 
radar’s SCIT storm tracking algorithm.

* SRM 1.5 deg. Shows storm-relative mean 
radial velocity from scan elevation 2, tilted 1.5 
deg from the ground.
* SRM 2.4 deg. Shows storm-relative mean 
radial velocity from scan elevation 3, tilted 2.4 
deg from the ground.
* SRM 3.4 deg. Shows storm-relative mean 
radial velocity from scan elevation 4, tilted 3.4 
deg from the ground.

7.11. Spectrum width
	 Spectrum width is a measure of the vari-
ance in velocity within each bin. It is actually 
generated from a pulse pair algorithm, rather 
than being computed directly from velocity 
data. The product is generated using 7 levels, 
with a maximum possible width of 20 kt. Any-
thing beyond 20 kt is truncated by the radar 
unit.
	 The spectrum width product it is the basis 
for the WSR-88D turbulence products. The 
application of the product to severe thunder-
storm forecasting is not known, but it may 
be a secondary indicator of small tornadoes, 
landspouts, and gustnadoes.
* 32 nm. Uses the close-range radius of 32 nm 
at 0.13 nm resolution.
* 124 nm. Uses the standard radius of 124 nm 
at 0.54 nm resolution.

7.12. Differential reflectivity
	 Dual-polarization radars have the ability to 
measure the signal as received in the horizon-
tal plane as well as the vertical plane.  The ratio 
between these two for a given bin is known 
as differential reflectivity (DR).  This tends to 
measure the oblateness of scatterers: particles 
that are stretched horizontally (pancaked) 
tend to be large raindrops.  On the other hand, 
particles stretched vertically usually include ice 
particles and especially hail.
	 Values of high differential reflectivity (+2 
to +5 and up) indicate stretching in the hori-
zontal, and suggest pancaked particles.  Values 
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that are near zero suggest a spherical ratio of 
width to height.  Values that are negative (e.g. -1 
to -2) indicate the particles are stretched in the 
vertical, and are likely to be ice.

7.13. Correlation coefficient
	 Correlation coefficient (DCC) provides a 
measure of the similarity of scatterers in the 
horizontal plane to scatterers in the vertical 
plane.
	 Very low correlation coefficients are in the 
range of 0 to 0.8 (0-80%) and normally indicate 
non-meteorological targets such as birds, insects, 
bats (especially in Texas), chaff, tornado debris, 
and ground clutter. Giant hail may dip into the 
upper range of these values (about 70-80%), as 
can large, clumped snow.
	 Moderate correlation coefficients are in the 
range of 0.8 to 0.97 (80-97%) and normally con-
sist of transitional forms of precipitation like hail 
and wet melting snow.
	 High correlation coefficients are in the range 
of 0.97 to 1 (97-100%) and are made up of un-
form snow, rain, and drizzle.  The highest values 
are made up of very small droplets.

7.14. Specific differential phase
	 Specific differential phase (DKD) measures 
the change in phase of the radar signal caused 
by precipitation and other scatterers.  It is highly 
similar to base reflectivity (DR), except that by 
nature it tends to be impervious to attenuation.  
This makes it of excellent use for finding the 
“true” reflectivity of cells when the beam is hav-
ing to cross lengthwise through a squall line or 
through numerous cells to a distant storm.

7.15. Other
	 A number of derived products are generated 
from the base products of reflectivity, velocity, 
and spectrum width.
* Echo tops (ET). This displays the highest alti-
tude at which a radar echo exceeds 18.5 dBZ. It 

is computed to the nearest 5,000 ft up to a maxi-
mum height of 70,000 ft. The standard coverage 
radius is 124 nm with a resolution of 2.2 nm.
* Vertically integrated liquid (VIL). Sums the 
reflectivities above a bin location to provide a 
measure of the total water load above a given 
location in kilograms per square meter. It has 
a direct correlation to severe weather, hail, and 
flood potential, and is most useful in assessing in 
an extremely short time which storm cells have 
the greatest significance. Generally values above 
40 kg/m^2 are associated with severe weather. 
The maximum possible displayable value is 80 
kg/m^2. The product has a coverage radius of 
124 nm with a resolution of 2.2 nm.
* Severe weather probability (SWP). Displays the 
probability of severe weather, based solely on 
the VIL algorithm. This product is of extremely 
limited use for severe weather forecasting and 
must be used with caution. Values are expressed 
as a percentage from 0 to 100. The product has 
a coverage radius of 124 nm with a resolution of 
2.2 nm.
* Mesocyclone. Shear couplets are resolved verti-
cally and with time to determine the existence 
of a storm mesocyclone. If one is present, it is 
displayed as a red circle. The radius of the circle 
equals the reported radius of the mesocyclone. 
Mesocyclones are resolved only within 124 nm 
of the radar.
* Hail index. The radar system contains a se-
vere hail index (SHI) algorithm that relates 
the 45 dBZ level to the -20C height. When the 
computed probability for hail for each storm 
cell exceeds a predetermined criteria, it will be 
displayed as a green isosceles triangle. If the 
triangle is small, there is a 30% probability of 
hail (50% if it is filled). If it is large, there is a 
30% probability of severe hail (50% if it is filled). 
The maximum expected hail size (MESH) is 
displayed in the middle of the symbol, rounded 
to the nearest whole inch; if less than one inch 
an asterisk shows. The hail index has a radius of 
coverage of 124 nm from the radar.
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* Tornado (TVS). This product uses the Tor-
nado Detection Algorithm (TDA) to resolve 
velocity signatures that suggest a tornado. The 
tornado signature is shown as a red filled in-
verted isosceles triangle. An ETVS may also be 
displayed, but the NIDS code does not provide 
for differenting TVS from ETVS signatures, 
therefore they will appear the same. The radius 
of coverage is 124 nm, but is rarely detected 
outside of 60 nm since the algorithm is unable 
to sample the lower portions of the storm at 
long ranges.
* 1-hour precipitation (OHP). Radar reflectivity 
is summed with time to estimate the rainfall 
accumulation in the coverage area. This prod-
uct provides an estimate of how much rain fell 
during the past hour. The highest reportable 
total is 8 inches. The radius of coverage is 124 
nm with a resolution of 1.1 nm.
* 3-hour precipitation (THP). Radar reflectivity 
is summed with time to estimate the rainfall 
accumulation in the coverage area. This prod-
uct provides an estimate of how much rain 
fell during the past three hours. The highest 
reportable total is 8 inches. The radius of cov-
erage is 124 nm with a resolution of 1.1 nm.
* Storm total precipitation (STP). Radar re-
flectivity is summed with time to estimate the 
rainfall accumulation in the coverage area. 
This product provides an estimate of how 
much rain fell during the past hour. The high-
est reportable total is 15 inches. The radius of 
coverage is 124 nm with a resolution of 1.1 
nm.
* Storm tracking information (STI). This prod-
uct shows information provided by the radar’s 
Storm Cell Interpretation and Tracking (SCIT) 
algorithm. It shows past, current, and future 
location of identified storm cells. Past locations 
are shown for each volume scan (this is an in-
terval of 5 minutes in VCP11 and 6 minutes in 
VCP21). Future locations are identified at 15, 
30, 45, and 60 minutes in the future; though 
these intervals are customizable by the radar 
site operator. Each storm has a unique ID of 
two characters ranging from A0 to Z9 and is 

recycled when past A0; when no storms have 
occurred in a certain number of volume scans 
the ID is reset to A0. The storm data has a 
radius of coverage of 248 nm.
* Clutter control filter (CFC). Shows the clutter 
filter notch and bypass maps as a radial im-
age. The levels are coded as follows: 0=disable 
filter; 1=no clutter filter; 2,5=low clutter filter; 
3,6=medium clutter filter; 4,7=high clutter 
filter. Codes 1 to 4 specify the map is bypassed 
by CTRL, while 5-7 force the filter to oper-
ate. The product has a radius of coverage of 
124 nm with a resolution of 1 km and 1.4 deg 
azimuth.
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8.1. Extract data
	 This option will let you extract climatology 
data for any of 2,000 stations around the world.  
Simply enter a partial word or country digraph 
to search for a station, or choose from the drop-
down list.
	 Extract Data will allow you to select a cat-
egory and timeframe of climatological data.  
Digital Atmosphere will then create a custom 
data field, saving it into CUSTOM.DAT in your 
Digital Atmosphere directory.  This can then be 
immediately plotted (with Graphics, Plot, Cus-
tom Data) or analyzed (with Analyze, Custom 
Data Field).  You can even import the data into a 
spreadsheet or database program.

8.2. Graph
	 This option will let you graph climatology 
data for any of 2,000 stations around the world.  
Simply enter a partial word or country digraph 
to search for a station, or choose from the drop-
down list.
	 What you’ll see is a graph of average high 
and low temperatures for each month, as well 
as extreme high and low temperatures for each 
month.  They will be indicated in either degrees 
Fahrenheit or Celsius, depending on your choice 
of units in File, Preferences.  At the bottom, 
you’ll see average monthly precipitation totals 
(United States) or precipitation days (elsewhere).  
The total height of a precipitation day bar is the 
total precipitation days during a given month.  
The part in gray is how many of those days are 
composed of snow days, and the part in red is 
how many are composed of thunderstorm days.

8.3. Hurricane tracks
	 Digital Atmosphere offers a database of his-
torical hurricane tracks, taken every six hours, 
for storms that occurred in the East Pacific and 
Atlantic basins from 1850 to 2002. The tracks 
will be displayed on the active workchart.
* Year. Use the range boxes to display data for a 
certain time period. To display data for only one 
year, enter the same year in both boxes.
* Line width. Enter a number here to control the 
width of the lines that will be plotted. The rec-
ommended value of 4 should be used.
* Plot storm name at origin. Plots a label con-
taining the storm’s name at the beginning of the 
track.
* Plot date labels along track. Plots dates and 
times along the length of each storm track.
* Color code for wind speed. Changes the line 
color of the previous segment based on the sus-
tained wind speed at that time. The values are: 
Gray 0-34 kt (tropical depression); Black 35-63 
kt (tropical storm); Green 64-83 kt (hurricane, 
Saffir Simpson 1); Yellow 84-95 kt (Saffir Simp-
son 2); Red 96-113 kt (Saffir Simpson 3); Purple 
114-134 kt (Saffir Simpson 4); Blue 135+ kt (Saf-
fir Simpson 5).

8 / Climatology
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* The source of the data is the NHC HURDAT 
tables at http://www.nhc.noaa.gov/pastall.
shtml . The tables are provided in Digital At-
mosphere verbatim, so users are free to swap 
out the existing tables with fresh ones. The files 
are located in the /hurr directory.

8.4. Tornado tracks
	 Digital Atmosphere is equipped with a 
database of United States tornadoes that oc-
curred between 1950 and 2002. These may 
be plotted on any weather chart for reference 
purposes. It is important to note that due to 
limitations in available data, the database car-
ries only the start and end location of a tor-
nado track, and not the intermediate points. 
This means that tracks will tend to be more 
accurate for short, slow-moving tornadoes, 
and much less accurate for long-tracked, 
fast-moving tornadoes. This is a limitation in 
the way that tornado climatology is compiled 
by the National Weather Service, and neither 
Digital Atmosphere nor its authors have any 
control over this.
* Year. Choose a range of years to display only 
data during these periods. To display data 
for only one year, set both blanks to the same 
value. Choose “all” if you want all years in the 
database to be displayed.
* Month. Choose a range of months to display 
only data during these periods. To display 
data for only one month, set both blanks to 
the same value. Choose “all” if you want all 
months in the database to be displayed.
* Day. Choose a range of days to display only 
data during these periods. To display data 
for only one day, set both blanks to the same 
value. Choose “all” if you want all days in the 
database to be displayed.
* Plot date labels at each track. Digital Atmo-
sphere will plot a MM/DD/YY label to the 
lower right of the beginning of each tornado 
track to show which date the track occurred.
* Color code. If checked, Digital Atmosphere 
will code a track black if there were no re-

ported injuries or fatalities, green if there were 
fatalities but no recorded deaths, and red if 
deaths occurred.
	 The source of data is the Storm Prediction 
Center historical tornado archive, located at 
http://www.spc.noaa.gov/archive/tornadoes/ . 
To save disk space, the data has been converted 
into a series of binary records stored in digat-
mos.tor that have this structure: Year (signed 
32-bit integer); month (unsigned 8-bit inte-
ger); day (unsigned 8-bit integer); hour (un-
signed 8-bit integer); minute (unsigned 8-bit 
integer); fujita rating, of which very little data 
is available (unsigned 8-bit integer); fatalities 
(signed 32-bit integer); injuries (signed 32-bit 
integer); latitude of beginning (4-byte float); 
longitude of beginning (4-byte float); latitude 
of end (4-byte float); and longitude of end (4-
byte float). Weather Graphics does not object 
to users providing their own updated tornado 
statistics to replace this one and sharing them 
with other users.
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9.1. Cascade
	 Arranges all open workcharts in a stacked 
fashion in which they overlap one another. The 
title bar remains visible so that you can always 
see which windows are open.

9.2. Tile
	 Arranges all open workcharts so that they do 
not overlap one another, appearing in a gridlike 
fashion.

9.3. Arrange icons
	 Minimized workcharts are arranged so that 
they are evenly spaced and do not overlap

9.4. Remove last product
	 The last product that was drawn on the ac-
tive workchart is erased. (Has not been tested 
with latest programming efforts as of 2015).

9.5. Replot last product
	 The last product that was drawn to the active 
workchart is drawn again. (Has not been tested 
with latest programming efforts as of 2015).

9.6. Allow Digital Atmosphere to 
run in background
	 Currently this option is not used.

9.7. Toolbox
	 This controls whether the left side panel 
containing the control toolbox is visible.  This 
may be unchecked temporarily to help make 

9 / Window

more of the workchart visible.  It will be reset to 
“checked”when Digital Atmosphere is started.

9.8. Speed buttons
	 If unchecked, the speed button bar at the top 
will be temporarily removed.  It will be restored 
when this open is checked again or the program 
is restarted.
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10.1. Open PDF User Manual
	 This option opens the User Manual in the 
user’s default PDF reader.
	 Alternately, instead of using this option, the 
user may look in the Digital Atmosphere pro-
gram group or search for “Digital Atmosphere 
Manual” in File Explorer.  The file is installed 
in the Program Files directory listed in Help > 
About.
	 The context-sensitive help (normally 
launched with the F1 key) was removed because 
of Microsoft’s decision to phase out WinHelp 
format in 2007 and remove support for it in 
Windows 7, 8, and 10.  This significantly im-
paired our own efforts to provide a simple help 
system embedded in the program.  As a result, 
we migrated to a PDF help manual.  This allows 
for easier printing, the use of more graphics, and 
it may allow us to provide a printed manual in 
the near future.

10 / Help

10.2. Help / Register
	 (Only appears if program is the Standard Ver-
sion and is unregistered)
	 If the program is still in 30-day evaluation 
mode, the Register menu option will be visible.  
Clicking it will present a dialog that “unlocks” 
the program and converts it to a fully registered 
version.
	 To use it, you must first obtain the key num-
ber shown in this panel.  This is uniquely gener-
ated for your computer.  E-mail this to us at ser-
vicedesk@weathergraphics.com.  If the license 
is valid, we will then provide a key number to 
enter in this panel that will complete the unlock 
process.
	 Programs that are still in evaluation mode 
after 30 days will lose some functionality such 
as loading and generating of maps.  However, 
completing the registration process at any time 
wil unlock it.
	 Please note that if you reinstall Windows 
or use a new computer and install the Standard 
version, you will see a different serial number in 
this panel and will need to contact us for a new 
key.  The Professional version does not check for 
serial or key numbers.
	 Be aware that attempting to bypass the 
evaluation period by setting the date to a much 
earlier value will end the evaluation mode.

FIGURE 10-1. The About panel.
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10.3. Help / About
	 Displays the version of Digital Atmosphere 
being executed, and also provides diagnostic 
information.  Within this section is helpful 
information on the location of your Program 
Path (where this executable resides) and the 
Application Data Path (where all of the Digital 
Atmosphere data files are located).
	 The Copy To Clipboard function will 
copy all of the diagnostic information to the 
clipboard.  This should be included in e-mails 
whenever requesting support from Weather 
Graphics.

CAUTION
We strongly discourage saving maps, user 
data, or any file requiring write access in the 
Program Files directory or any of its subdi-
rectories.  This portion of the file system is  
write-protected by Windows.  This change 
was introduced by Microsoft with the release 
of Windows Vista in 2007, as part of the new 
User Account Control (UAC) system.  This 
UAC change is part of the reason very old 
versions of Digital Atmosphere do not work 
reliably under Windows Vista/7/8/10 (the 
other reason being the oldest versions were 
16-bit applications).  You may place user 
data under the Application Data path, or 
create your own user data folder elsewhere, 
such as under the Desktop or Documents 
directory or in a custom directory created 
under C: .
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	 The preferences dialog is used to change 
any of numerous options for the software.  Any 
changes you make are used only for the dura-
tion of the program’s execution, unless you mark 
“Save as default preferences” at the bottom of the 
dialog window.  If you check this box, the en-
tire set of preferences is saved to your registry 
(HKCU\Software\DigAtm2015) and will be used 
each time you run the program.  Advanced users 
can manually delete the HKCU\Software\Di-
gAtm2015 with Windows REGEDIT if there is a 
need to “factory reset” all preferences.
	 The preferences menus are divided up into 
several sections, each of which may be accessed 
by clicking once on the tabs at the top of the 
dialog box.  Just click on the tab correspond-
ing to the settings you want to change to switch 
between preference pages.

11.1. General tab

Send errors to status window
	 If this option is checked, certain errors will 
be sent to the status panel at the bottom left.  In 
particular this pertains to Internet retrieval er-
rors.

Automatically check for updates
	 If checked, Digital Atmosphere will notify 
you when a new version is on the weathergraph-
ics.com website.  If an update is available, it will 
offer to download the update.  If you accept, the 
Digital Atmosphere download page will appear 
in your default browser. Otherwise it will offer to 
remind you, and you can accept or decline.
	 If this is unchecked, Digital Atmosphere will 
not check for updates.

NEXRAD settings
* Preferred radar source override: This directs 
Digital Atmosphere to which set of URLs it 
should be using to retrieve its NEXRAD (WSR-
88D) data.  Expert users can load the file digat-
mos.rad, found in your Application Data folder 
(see Help > About) to view and edit the sets.
* Preferred radar color override: This sets the 
radar color table scheme.  Expert users can load 
the file digatmos.nxc, found in your Application 
Data folder (see Help > About) to view and edit 
the sets.  Note that we are changing the color set 
formats as of 2015 to support newer NEXRAD 
data formats, so this item may temporarily not 
work.

Print settings
* Color assignment: This can be used to experi-
ment with how Digital Atmosphere maps colors 
to the printer, in case printouts do not look as 
expected.  Simply try changing the value here 
and make a printout, and if it still does not look 
satisfactory then change it back.
	 Expert users: Setting this to Palette causes 
the Windows API function StretchDIBits to use 
DIB_PAL_COLORS in the iUsage field (which 
indicates the color structure of the source im-
age).  If the setting is RGB, then DIB_RGB_
COLORS is used.

11 / Preferences
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11.2. Meteorological tab

CAPE mixed layer depth
	 This sets the depth of the layer that will be 
used for mixed layer parcel calculations (in-
cluding CAPE and parcel trace) in the Data > 
Soundings panel.

FOUS data level
	 Whenever you plot model (ETA/NGM) 
data, the temperature and moisture variables 
are determined according to this setting.  
Normally the first button (T1/R1) is selected to 
give you surface data, but by choosing another 
button you can plot or analyze temperature 
or moisture aloft (calculating derived values 
such as dewpoint should be done with caution, 
though, since T3 is not the same level as R2).  
Here are the meanings of the different levels.

	 Level    Equivalent
	 T1	 Surface 
	 T3	 About 100 mb above surface (1 km) 
	 T5	 About 215 mb above surface (2 km) 
	 R1	 Surface to about 35 mb above the 
			   surface (lowest 1000 ft) 
	 R2	 About 35 mb above surface to 500 mb 
	 R3	 500 mb to the tropopause

Geopotential heights in full meters only
	 The geopotential height on upper-level 
charts are commonly plotted in decameters 
(dam). When this box is checked, contour 
labels and upper plot models will appear in full 
meters.  When it is unchecked, the labels and 
plot models will switch to conventional short-
ening typically used by meteorologists (see 
table below).  The default setting is unchecked.
	 Normal shortening values are as follows:
* 100-500 mb: Hundreds, tens, and units, dam.
* 501-1000 mb  Hundreds, tens, and units, m.

Round synoptic reports to nearest 3 hours 
when importing
	 You have two options when importing 
synoptic (SYNOP) data — you can either 
round the reports to the nearest 3 hours (mak-
ing maximum use of off-hour data) or use no 
rounding (ensuring sampling of the atmo-
sphere at an exact moment).  It is generally 
best to use no rounding when possible.

View NEXRAD RCM rather than RAREP 
radar data
	 This prevents two different radar formats 
from being mixed when you use Data > Radar 
> Echoes.  Check this box whenever you use 
NEXRAD RCM data (such as that transmitted 
over EMWIN).  If you use the old SD RAREP 
code, uncheck this box.

Round AIREP reports within __ mb of a 
standard level
	 Forecasters like to see AIREP reports on 
upper-air charts, but AIREPs are rarely at an 
exact standard constant-pressure level.  When 
this box is checked, it allows AIREPs within a 
certain range of the active pressure level to be 
included on the map.  Usually 25 mb is a good 
value.  When it is unchecked, no AIREPs will 
be used unless they are at the exact pressure 
level that’s active.

Display highs and lows when plotting frontal 
bulletins
	 This should usually be left checked.  When 
you display a frontal bulletin using Data > 
Fronts, Digital Atmosphere will automati-
cally plot highs and lows contained in that 
bulletin.  However if you intend to plot an 
analyzed pressure analysis, you may want to 
have Digital Atmosphere determine the high 
and low locations.  Thus you can switch off the 
frontal bulletin highs and lows with this option 
so they don.t clash.
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	 If you wish to suppress drawing of highs and 
lows in Digital Atmosphere analysis, you will 
need to remove the HILO command from the 
appropriate analysis script entry in digatmos.
mnu (see Analysis Scripting in the appendix).

Display pressure values when plotting frontal 
bulletins
	 This should usually be left checked.  When 
you display a frontal bulletin using Data > 
Fronts, Digital Atmosphere will automatically 
plot any pressure values found in that bulletin 
for highs and lows.  You may suppress these la-
bels by unchecking this selection.  This does not 
have any effect on highs and lows created with 
an Analysis command; it is solely for imported 
frontal bulletin message data.

Winter depiction: extend contours over non-
precipitating areas
	 (Not implemented yet)

Convert ALSTG to SLP for analysis (advanced 
users only)
	 If you are plotting maps with sea-level 
pressure, then source data that does not offer a 
sea-level pressure value but does have altimeter 
setting data will be converted through a simple 
standard-atmosphere pressure reduction.  This 
should not be used in mountainous areas or with 
unusually hot or cold temperatures.

Lowest possible METAR pressure
	 The METAR surface observation code 
format only allows the tens, units, and tenths 
place to be encoded, which means that Digital 
Atmosphere has to determine whether the final 
millibar value is 9xx.x or 10xx.x.  The default 
value for lowest METAR pressure is 960 mb, 
which means that if a value such as 584 is found, 
Digital Atmosphere will assume it is 1058.4 mb, 
not 958.4 mb.
	 Normally there is no need to change this, but 
if you’re looking at exceptionally low pressure 

areas and the sea level pressure contours aren’t 
plotting correctly, you’ll want to decrease this 
value.  Likewise, if you’re looking at very high 
pressure and the sea level pressure contours 
aren’t plotting correctly, you’ll want to increase 
this value.  Some adjustment may be needed 
during the cold season in temperate and polar 
latitudes.

Earth’s rotation constant
	 Specifies the earth’s rotation in radians per 
second, which is normally set at 0.000007292.  
Naturally, there is no need to change this un-
less you want to tinker and see the results.  The 
earth’s rotation constant is used in the Coriolis 
parameter equations, which are used for geo-
strophic wind calculations and calculation of 
absolute vorticity.  Hitting reset replaces any 
entered value with the Earth’s rotation constant.

Gravity constant
	 Specifies the gravity on the Earth’s surface, 
which is normally set at 9.806 m/s-2.  There’s no 
need to change this unless you want to tinker 
and see the results.  Gravity is only used in the 
calculation of geostrophic wind based solely on 
height contours.  Hitting the reset button re-
places any entered value with the Earth’s gravity 
constant.

11.3. Maps tab

Topography: use avg elev rather than max
	 This controls what source of data is used 
when you select Map > Make Topography.  
When it is checked, average elevation data is 
used.  When it is unchecked, the maximum 
elevation data is used.

Fill outer space
	 When the map is zoomed out to where you 
can see the disc of the Earth, the area outside the 
disc (the outer space area) will be filled with the 
general plot color if this option is selected.
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Label graticule
	 When checked, and the  are checked and 
active, latitude/longitude labels will be placed 
at the left and bottom of the map consistent 
with the  setting.

Draw graticule behind landmasses
	 If checked, the latitude/longitude graticule 
will not appear on top of landmasses and will 
only be shown over oceanic areas.

Plot legend on right hand side of the map
	 The product legend will appear on the 
right side of the map if this is checked, other-
wise it will appear on the left side.

Copy viewed point files from PLS to PLT 
format
	 Data point files that were used before 2008 
used the older PLS format.  If checked, Digital 
Atmosphere will offer to convert them for you 
to the new PLT format if they are encountered.

Graticule type
	 Digital Atmosphere can overlay a latitude/
longitude grid, and here you can control how 
it will be displayed.  You will see the lat/long 
grids only if the .lat/long grids. setting in the 
.map element table. is checked and only when 
you re-generate a new map.  Note that the 
grid interval is controlled by the .grid interval. 
setting and the color is controlled by the grid 
color listed in the .map element settings. color 
table.
* Line.  Plots latitude/longitude as a series of 
lines.
* Mixed.  Same as “line” above, but also adds 
dots for every integer degree of latitude and 
longitude.  The size and interval of the dots is 
fixed and cannot be controlled.
* Cross.  Plots a cross at each latitude/longitude 
intersection.

* Dash.  Plots latitude/longitude as a series of 
dashed lines.
* Dotted.  Plots latitude/longitude as a series of 
dotted lines

Graticule interval
	 If a latitude/longitude map is plotted, this 
value controls what interval will be used (in 
degrees) to plot the grid.  A value of 10 or 15 
should normally be used.  So that the grid 
wraps uniformly around the globe, the value 
you select should divide evenly into 360.

Default map size
	 When you use quick mapmaking com-
mands such as Generate Map on the speed 
button toolbar, this determines what the map 
size will be in pixels.

Map features to be drawn
	 Use this table to set which geographical 
features you want displayed.  Remember that 
these will not take effect until the next time 
you generate a map.  Colors are set in Styles.
	 NOTE: To set translucency on states, set 
the Styles / Misc field for states to 1.  This will 
prevent international borders from being re-
drawn with state/province line settings.

Professional map file tile root location
	 You can use this to adjust where the Pro-
fessional maps can be located, such as if you 
copy them to a hard drive.

JPEG image compression
	 If you choose Map, Export and choose 
JPEG as an image type, the image will be com-
pressed according to the settings you specify 
here.  JPEG is a lossy compression scheme, 
which means that higher compression values 
result in degradation of the image.  As the user, 
you select the tradeoff that you think is most 
acceptable.  For a typical 640 x 480 image, 
a setting of 0% (loose) will result in a high-
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quality image with a filesize of 225K.  A setting 
of 100% (tight) will result in a very coarse image 
with a filesize of 11K.

11.4. Station Plots tab

Plot radar status labels
	 Whenever Overlay > Radar is chosen, this 
determines whether symbols are plotted at each 
radar location together with the radar echoes.  
By unchecking this box, only radar echoes will 
be plotted.

Station plot units
	 This controls the units (English or metric) 
used for plots of temperature, dewpoint, vis-
ibility, sea temperature, wave height, wind wave 
height, swell height, minimum and maximum 
temperature, elevation, precipitation, and .televi-
sion. plots.  This also controls the units used for 
Data > Television temperature plots.

Surface plot model settings
	 These settings only apply when the active 
level is the surface level and Overlay, Data is 
selected.
* Plot wind barb.  If checked, Digital Atmosphere 
will plot a wind barb at each station plot when 
it is reporting valid wind data.  If unchecked, no 
wind barb is plotted on any report.
* Smart visibility plot.  If checked, Digital At-
mosphere will omit plotting surface visibility 
when no significant weather is occurring.  If 
unchecked, surface visibility is always plotted.
* Plot missing as “M”. If checked, missing values 
for key elements will be plotted as “M” instead of 
left blank.
* Color code IFR/MVFR plots.  If checked, when 
stations are reporting IFR conditions (visibility 
less than 3 miles and/or ceiling less than 1000 
ft), the OKTAS (sky cover) plot symbol is col-
ored red; when MVFR conditions (visibility less 
than 5 miles and/or ceiling less than 3000 ft), the 
OKTAS (sky cover) plot symbol is colored blue.  

If unchecked, the standard draw color is used to 
paint the sky cover plot symbol.
* Use km when above 5000 m. If a visibility is 
reported as greater than 5000 m (5 km) it will be 
reported in whole kilometers.
* Plot model configuration.  A “grid” of combo 
boxes are set up in a way that represents the 
various data positions around a given station 
plot.  You can use these combo boxes to adjust 
the kinds of data that are plotted in the differ-
ent positions.  A “Save Plot Model” and a “Load 
Plot Model” option are provided so that you can 
make quick, on-the-fly changes to the desired 
plot model.  For a listing of the different types of 
data and the meaning of encoded values, please 
see the Appendix.
* Load plot model.  Loads a predefined plot 
model configuration from disk.
* Save plot model.  Saves the current plot model 
configuration to disk.
 
Upper plot model settings
	 These settings only apply when the active 
level is an upper level and Overlay, Data is se-
lected.
* Plot wind barb.  If checked, Digital Atmosphere 
will plot a wind barb at each station plot when 
it is reporting valid wind data.  If unchecked, no 
wind barb is plotted on any report.
* Fill dewpoint depression circle.  If checked, 
Digital Atmosphere will “shade in” the station 
plot of each upper level station whenever the 
dewpoint depression is 5 deg C or less.  If un-
checked, all station plots are left unfilled.
* Plot model configuration.  A “grid” of combo 
boxes are set up in a way that represents the 
various data positions around a given station 
plot.  You can use these combo boxes to adjust 
the kinds of data that are plotted in the different 
positions.  A “Save Plot Model” and a “Load Plot 
Model” option are not provided for upper air 
plot models since most users will stick to a single 
configuration.
* Load plot model.  Loads a predefined plot 
model configuration from disk.
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* Save plot model.  Saves the current plot 
model configuration to disk.

11.5. Analysis tab

Analysis type
	 Specifies which algorithm is to be used to 
construct the analysis.

* Nearest neighbor (proximal interpolation) — 
This is by far the quickest, and most users will 
use this setting.  It is a simple multivariate in-
terpolation scheme. Values are mapped to the 
closest gridpoint.  This leaves some gridpoints 
unfilled which are not near a station.  These 
unfilled points are filled by “expanding” grid-
points outward in all four directions to their 
unfilled neighbors until all unfilled points are 
completed.  Afterwards, a smoothing operator 
removes noise, with the smoothing propor-
tional to how soon in the iteration cycle the 
gridpoint was filled with data.  
STRENGTHS: It’s fast and always works since 
a gridpoint will always be matched with a data 
point.
WEAKNESSES: Very simplistic technique. In 
data void areas, the transition between grid-
points using different sources takes on a  linear 
or pie-shaped appearance.

* Weighted — Digital Atmosphere looks at 
the neighboring stations around a gridpoint, 
giving it an average of those values around it 
with more weight allotted to values from closer 
stations and less weight from distant stations. 
STRENGTHS: This method is more sophisti-
cated than Nearest Neighbor as it uses multiple 
sources of data, considering distance.  Since 
the crude expansion technique is not used, this 
eliminates noise in the analysis.
WEAKNESSES: Not as sophisticated as the 
Barnes and Cressman techniques.

* Barnes — The Barnes method, the corner-
stone of the MCIDAS and GEMPAK weather 
workstations, has a number of advantages: 
versatility, simplicity, and speed.  The 1964 
Barnes version used a radius of influence, Rm 
from each gridpoint, where stations exceeding 
Rm are discarded and stations within Rm are as-
signed a distance-dependent Gaussian weight-
ing function.  A difference field is calculated, 
which determines how far off from reality the 
analysis field appears to be, then a difference 
correction is applied to the analysis field.  This 
takes a relatively long time to compute, but is 
one of the more accurate analysis algorithms.  
STRENGTHS:  Only two passes are necessary.  
WEAKNESSES: It can fail with extreme data 
distribution.
REFERENCES: Koch, SE, des Jardins, M, 
Kocin, PJ 1983, “An interactive Barnes objective 
map analysis scheme for use with satellite and 
conventional data”. J Climate Appl. Meteor., 22, 
1487-1503.

* Cressman — The Cressman analysis method 
is similar to the Barnes technique, however 
it is a successive corrections method (SCM) 
technique.  In this technique, it uses multiple 
iterations with a smaller and smaller radius of 
influence to eliminate all errors.  It takes more 
time, but the results can be superb if config-
ured correctly.  In data-sparse areas like over 
oceans, it is common for there to be erroneous 
contours with Nearest Neighbor and Weighted 
methods.  The Cressman method is one of the 
best methods for use in these data sparse areas 
without smoothing fine-scale data near dense 
data areas.
STRENGTHS: It is sophisticated and flexible, 
and retains more mesoscale structure while 
smoothing data-sparse areas properly.  
WEAKNESSES: It can’t resolve short-wave-
length components very well, it can require 
a large amount of time, and it can fail with 
extreme data distribution.  It does not account 
for the distribution of observations relative to 
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one another.  Also the optimum distance values 
might only be obvious after trial and error.
REFERENCES: Cressman, G.P. (1959): “An 
Operational Objective Analysis System”. Mon. 
Weather Rev, 87, 367-374.

For the following items, the letter after the title 
indicates the parameter applies to: N=Nearest 
Neighbor, W=Weighted, B=Barnes, or 
C=Cressman.

Automatic smoothing
	 If checked, Digital Atmosphere will auto-
matically determine the surface and upper air 
surface radius based on existing data for the 
Weighted, Cressman, and Barnes analyses.

Smoothing coefficient
	 (ALL) Sets the mathematical value of “s” for 
the smoothing equation.  This affects what kind 
of wavelengths will be filtered in the analysis 
grid.

Smoothing passes
	 (ALL) Determines how many times a 
smoothing operator will operate whenever it is 
called.  With this, you can set how “smoothed” 
the maps will look when the analysis is com-
plete.  This should be set to “1” or to a low non-
zero value.

Surface radius / Upper radius
	 (W, B, C, in nm) Determines a radius of 
influence used in the Weighted, Cressman, and 
Barnes analysis method for surface data.  All 
data outside the radius of influence is ignored.  
This value should approximate the average spac-
ing between surface stations.  For good results 
in data-sparse oceanic areas use Cressman and 
increase this radius to 500-1000 nm or more, 
with at least 4 or 5 reduction steps (below).

Auto Surface/Upper radius
	 (W, B, C) When the “Auto” box is checked, 
Digital Atmosphere will ignore the Surface/Up-
per Radius slider values and calculate an appro-
priate amount based on the areal width of the 
workchart.  This allows flexibility between me-
soscale maps and oceanic maps with large data 
voids.  The user can exert control over the final 
value with the Auto Radius Bias slider (below).

Gamma
	 (B) This is known as the “convergence pa-
rameter”.  It determines the gamma used in the 
Barnes analysis method.  It may range between 
0..1, but a value of 0.2 to 0.3 is recommended.

Reduction
	 (C) Determines the number of interval steps 
used in the Cressman algorithm between the 
surface/upper radius and zero.  For example if 
radius=300 and reduction=4, then each analysis 
pass will analyze stations within 300, 225, 150, 
then 75 nm of a gridpoint, with the earlier passes 
capturing large-scale waves and the later passes 
capturing small-scale waves.
	 Increasing this number will increase the 
sensitivity to a variety of wavelength scales.  De-
creasing it will make the analysis proceed faster 
at the cost of degraded sensitivity to various 
wavelength scales.  The analysis time is propor-
tional not only to the analysis type and the num-
ber of reduction steps, but also to the number of 
stations that exist in the window.

Analysis domain size
	 This controls the number of gridpoints in the 
analysis domain.  The default is 30 x 30, but you 
can set it to 60 x 60 for fine-scale analysis.  The 
maximum this should be set to is 100 x 100, and 
larger sizes may cause memory errors.  A good 
rule of thumb is that the gridpoint count should 
exceed the number of stations in the domain by 
more than twice (i.e. the grid should be no more 
than 40 x 40 when 800 stations are available, 
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though higher gridpoint counts may be need-
ed with increased station clustering.  Station 
domain counts may be found under the status 
window when Data > Data Plots is performed.  
Excessive gridpoint resolution may cause noise 
and unusual isopleth artifacts, especially if the 
analysis does not have enough smoothing or 
reduction passes.

Isopleth - small fonts
	 This option simply controls what size and 
type of fonts are used to label contour lines on 
analysis charts.

Isopleth - negative fonts
	 Plots an inverted color font.

Auto radius bias
	 When Auto Surface Radius or Upper Ra-
dius is used, this biases the values by the given 
percentage.  Normally this should be set to 
100%.

11.6. Styles tab
	 With Digital Atmosphere you are not stuck 
having to use one set of map colors, line styles, 
and fonts for everything.  Obviously when you 
want to use a different color set, this might 
mean spending a lot of time making tedious 
changes.  Digital Atmosphere allows you to 
manage sets of colors, fonts, and line settings.  
These sets are known as styles.  A style is iden-
tified by a plaintext name and a filename (all 
styles are stored in the \styles directory under 
Digital Atmosphere, without exception).  To 
change the color settings, use the Preferences > 
Styles panel.  Advanced users may edit the files 
directly.

Editing the parameters
	 Listed here are the various codes that ap-
pear in the edit window.  Above all, be sure 
you pick Save when you are done, or your 
changes will be discarded!

Code
	 This is a predefined code that marks the 
parameter type for internal use.  It cannot be 
modified.

Parameter
	 This is a predefined code that is used to 
provide a plain language explanation of the 
parameter for that row.  It cannot be modified.

R, G, B
	 These are color codes, which must be a 
whole number between 0 and 255.  The R col-
umn is for red, G is for green, and B is for blue.  
To pick orange, for example, you would set R 
to 255, G to 128, and B to 0.  You do not need 
to use these columns.  A vastly simpler input 
is available simply by clicking on the color 
swatch to the right of the R, G, and B columns.  
If you do wish to enter R, G, and B values, the 
following resource may help:
    http://www.colorpicker.com/
Do not enter hex (hexadecimal) values; they 
will not be recognized.

Color swatch
	 Click on the color swatch to select a dif-
ferent color.  In the popup window, a cross-
hair will show the current color value.  Move 
it around or change the values to pick a new 
color.  The value of R, G, and B will be filled in 
automatically for.

Contour type
	 Indicates the purpose of this contour.  It 
cannot be modified.

Unit
	 Proper entries are as follows.  Do not 
mixmatch units or the program will ignore the 
setting and use a default unit.  Units marked 
with * cannot be changed.



DIGITAL ATMOSPHERE MANUAL / January 2023  |  75

   Temperature . . . . . .	 deg f, deg c, deg k
   Moisture . . . . . . . .  	 g/kg
   Relative Humidity .	 percent
   Horizontal Velocity 	knots, mph, m/s
   Vertical Velocity . . 	 microbars/s
   Height . . . . . . . . . . 	 meters
   Pressure . . . . . . . . 	 mb, hpa, kpa, inches
   Precipitation Totals	 inches, mm

Base
	 Determines the base value that the inter-
vals are based off of.  For example, if you use an 
interval of 5 degrees, a base of zero will give 0, 5, 
10, 15, 20, 25.. degrees.  If you use a base of 2 de-
grees, you.ll get 2, 7, 12, 27, etc.  Always reduce 
the base to the lowest common denominator (as 
close to zero as possible).

Interval
	 Represents the contour step interval (the 
numerical difference between each contour).

AI
	 Automated interval.  If y is entered, Digital 
Atmosphere will override the base and interval 
settings and choose the ones that will give the 
clearest view of the data field.

Style
	 Indicates the linestyle that will be used to 
draw the contour.  Acceptable values are solid, 
dash, or dot.  Radar echoes must be either solid, 
clear, bdiag, fdiag, cross, crdiag, horiz, or vert.

Making a new style
	 At some point you may not be happy with 
just editing the default styles.  When you want to 
create a new style, click the New... button.
	 Enter a plaintext name.  Choose any phrase 
that will readily identify the map to you.  A brief 
phrase without any brackets should be used.
	 Filename for this map style.  The file shown 
here is what the filename will be on your hard 

drive.  This will be filled in automatically when 
you choose a plaintext name.  However the edit 
box gives you the opportunity to override the 
filename.  Only alphanumeric characters and 
dashes are allowed.
	 Style template filename (optional).  Nor-
mally the new color settings will be extracted 
from the \styles\master.stx file.  If you’d like to 
clone a different file, choose it here.

Creating style files manually
	 Advanced users can can create their own 
style files manually in a text editor, as long as the 
filename ends with *.sty, resides in the \styles 
directory, and conforms to the style formats 
shipped with Digital Atmosphere in this direc-
tory.  Incorrect configurations may produce an 
error in Digital Atmosphere and prevent fields 
from being generated.

NOTE: To set translucency on states, set the 
Styles > Misc. field for states to 1.  This will pre-
vent international borders from being redrawn 
with state/province line settings.

11.7. Misc1 tab

Advanced internet settings
	 If you use a proxy host, enter the name and 
port here.  If you do not know the proxy settings, 
you will need to contact your ISP.  We cannot 
guess thes settings or look them up for you.  
For example, users of Alphalink in Melbourne, 
Australia will notice on their Alphalink sup-
port pages that they would need to enter proxy.
alphalink.com.au in “Proxy host” and 8080 in 
“Proxy port”.
	 SPECIAL NOTE: Due to the use of more 
sophisticated connections to proxy servers, this 
may no longer work with many ISPs.

Color gradient fills
	 This section lets you define how gradient fills 
will look.  It is designed mostly for experienced 
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users and will require some basic mathemati-
cal knowledge.  The colors are defined accord-
ing to the plotted Value for the particular point 
on the map, which will always be in the range 
0..1, where 0 is the lowest possible reading and 
1 is the highest possible reading.  This Value is 
fitted to a sine wave according to user defined 
parameters to determine the Red, Green, and 
Blue component of its color.
	 See the appendix for full information.

Planetary maps
	 This preference setting is used for Map > 
Planetary Map generation.
* Smooth final image.  Applies a smoothing 
function to the finished planetary map.
* Reoverlay geography.  Plots the basemap on 
top of the planetary map.

Cities
	 Digital Atmosphere has certain functions 
related to cities (namely, Map > Cities and 
Map > Cursor City Distance).  It is impractical 
for all 40,000 towns and cities in the United 
States to be displayed and used all the time.  
Therefore this panel gives the user control over 
how many towns and cities are considered. 
	 Set the number high (in the thousands 
or tens of thousands) to use as few cities as 
possible.  Set the number low (in the tens or 
hundreds) to use as many cities as possible.  To 
determine whether a city will display at a given 
threshold, open digatmos.cty, look up the city, 
and look at its PROGDI value (cols 40-44).
	 You will have to enter a number lower than 
this value for it to be used.  There is some vari-
ation in the sensitivity between different states 
and you may need to increase or decrease the 
factor for your region.
* Cursor sensitivity threshold. This controls 
which cities and towns will be referred to 
when Map > Cursor City Distance is active.

* Plotting threshold.  Controls how many cities 
and towns will be plotted when Map > Cities is 
chosen.

Special diagnostics
	 This obtains diagnostic information for 
specialized user debugging purposes.  As of 
2015 its only function was to obtain system 
time data.

11.8. Misc2 tab

Copy imported data to local file
	 If enabled, data will be saved to a local 
file with a fixed filename.  If you know how to 
write command line batch files, you can have a 
script which monitors this file for changes, and 
then when a change is detected it performs 
other operations on this file.

Debug GRIB data
	 (For internal use only)

Icons have black backgrounds
	 Icons plotted on the map will have black 
backgrounds.

11.9. Annotations tab

Text annotations / Highs and lows
	 Highs and lows will be plotted with the 
characters shown here.  This is useful for inter-
national users who may have other abbrevia-
tions for high and low pressure areas.

Text annotations / Title
	 If this is enabled, a large title will be dis-
played at the top or bottom of the chart in-
dicating the product name, such as “Station 
Plots”.  You can use the other options here to 
further fine-tune the appearance of the title 
and disable the small, detailed legend that nor-
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mally appears in the bottom left or bottom right 
corner.

Text annotations / Credits
	 This will display a permanent credit at one 
corner of the screen, such as a copyright, website 
name, or source.  Using the options here you can 
fine-tune it the way you want it to look.

Logo
	 Here you can specify a logo, such as a com-
pany image, to be displayed on the chart.  Ac-
ceptable image types are GIF and JPEG.
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If you are having trouble with Digital Atmo-
sphere, first check and see if the problem you are 
having and its solution are listed here.  If not, 
you can obtain technical support via the Inter-
net.  We always appreciate feedback and notifica-
tion when users find bugs, since we are commit-
ted to producing the best possible product.

A station plot I want to look at isn’t on the 
map
Digital Atmosphere operates with a default 
selection of using a clutter suppression algo-
rithm, which avoids plotting a station if there 
is a chance it will overwrite an neighboring one 
that’s already plotted.  You can turn this off by 
going to File > Preferences > Station Plots and 
checking “Plot All Stations”.  This may make 
your map VERY cluttered.  To have a legible, un-
cluttered map and see a particular station, your 
only options are zooming in further so that more 
stations in the region of interest are displayed, 
or eliminating a neighboring station you don’t 
want to see by deleting it from the DIGATMOS.
STN listing and selecting File, Recompile Tables.  
Plans are in the works for a station priority func-
tion that forces Digital Atmosphere to always 
plot a desired station before it uses the clutter 
supression algorithms.
Also check your “digatmos.rul” file to see if you 
have set exceptions or deletions for certain sta-
tion.  A couple of problematic stations are added 
by default.

The analysis isopleths don’t seem to match well 
with the data.
All objective analysis routines are smoothed so 
that the isopleths don’t look extremely coarse.  
You can reduce the smoothing operators in the 

File, Preferences, Analysis menus.  Also, take 
into account that if a station sends out a bad 
meteorological value, the analysis may yield a 
more representative value than the station plot 
itself.  You can clean up bad data using the Qual-
ity Control command as discussed in previous 
chapters.  If you need extremely accurate iso-
plething, hand analysis (on top of a printed map) 
is always the best solution.

Why are some station plots red or blue?
A red station plot indicates instrument flight 
rules (IFR), which means bad weather with the 
ceilings below 1000 feet and/or the visibility 
below 3 miles.  A blue station plot indicates mar-
ginal visual flight rules (MVFR), meaning mar-
ginally bad weather, with the ceiling below 3000 
feet and/or the visibility below 5 miles.  These 
colors are useful for helping you visualize areas 
of poor weather at a glance.  Areas poleward of a 
warm front are often characterized by extensive 
IFR (red) areas.

How can I make a map with the colorful to-
pography?
Whenever you use the Map, Generate Map 
command, the map is always in monochrome 
outline format.  We recommend using the Plan-
etary Maps option (see the Maps section in this 
manual) for generating maps with topography, 
terrain, and vegetation.

Every now and then when generating a map, I 
see an area that’s been flooded by an ocean fill.
There is probably a defect in the geography file 
that allows a gap in the coastline to be plotted.  
Let me know all the settings on the “Generate 
Map” panel so I can reproduce it.  You may be 
able to fix this yourself by zooming in on the 

12 / FAQs
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suspect area and making changes to the data 
in the geography files to isolate and close off 
the coastline gap (see the File Commands, 
Generate Map section).  If you succeed, let me 
know what you did so I can fix the distribution 
copies. 

Digital Atmosphere never fills ocean colors. 
This may happen if the map background 
color is set to a custom (non-basic) color. It 
is a limitation of the graphics components we 
are using. To remedy the problem, go to File 
> Preferences > Maps > “Background Color” 
and choose a color under Basic Colors (not a 
custom one) and make sure that Water Body 
Fill is checked. Then re-generate your map. 

The printer responds with “overflow error” 
or erratic “out of paper” errors
The maps that Digital Atmosphere sends to 
your printer are huge and for best results will 
require 4MB or more of RAM on your printer.  
This usually isn’t a problem with inkjet printers 
(where the printfile can be spooled off the hard 
drive), but laser jet printers require a complete 
image in their memory before they print to the 
drum.  If this is the case, go to File > Printer 
Setup and change the resolution settings so the 
map is printed at a lower resolution.  Another 
remedy is to avoid solid color fills, such as to-
pography, blue oceans, etc, since they take up 
considerable printer memory.

The Digital Atmosphere status bar shows 
a countdown message down to zero, then I 
get the error message “Automatic/EMWIN 
surface file not found.” 
How it happens: When Digital Atmosphere is 
in EMWIN Scheduler mode, every 60 seconds 
it checks the “EMWIN Data Directory” for 
the presence of the “EMWIN Surface Data-
file”. If there is no such file, an error message is 
returned and Digital Atmosphere turns off the 
EMWIN Scheduler.

How to fix it: First, find out what file the 
surface observations are being stored in. For 
example, the satellite EMWIN feed usually 
puts them in:
    Directory:
	 C:\WEATHER\WXDATA\RXFILES\
    File:
	 SAHOURLY.TXT
Check this in Digital Atmosphere by going to 
File > Preferences > General.  Compare “EM-
WIN Data Directory” to the correct directory 
and “EMWIN Surface Datafile” to the correct 
data file. 

FD observations will not plot. 
This is usually due to one of several things: 
* The file containing weather observations ei-
ther does not contain FD observations or was 
not imported by Digital Atmosphere. 
* Before plotting the data, the current level is 
not set to a level in feet.
* The FD observations have been reformat-
ted or are in a nonstandard format, and they 
have failed the pattern recognition algorithms 
in Digital Atmosphere. If this happens, please 
send a sample of the file (no larger than 50K) 
to support@weathergraphics.com and we will 
try to provide added support for the format 
in future releases of the program. Be sure to 
clearly mark what is wrong with the sample or 
we will not be able to do anything with it. 

Upper level height contours don’t work. The 
computer freezes up. 
Go to File > Preferences > Analysis > “Figure 
geostrophic heights”.  If it is checked, height 
contours can take a long time on old comput-
ers.  Newer computers should not have this 
issue.
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Do you need the Internet to use Digital Atmo-
sphere? 
No, you don’t. Digital Atmosphere will work 
with saved (canned) data, as long as it is given a 
file containing raw weather data. 

How can I change isopleth colors, linestyles, 
and intervals? 
Edit the Analysis script (under Analysis > Edit 
Analysis Script) to change the COLOR= entry 
for the isopleth type and set new red:green:blue 
values.  In old (pre-2003) versions of Digital 
Atmosphere, go to File > Preferences > Contours 
and make the changes.

I get a “Range Check” or “Floating Point Over-
flow” error when importing data.  However 
everything else seems to work fine. 
This is caused by a corrupt data element in your 
file that is causing Digital Atmosphere to abort 
one of the import modules. It will continue im-
porting data, but one of the data types (such as 
synoptic, SD, or rawinsonde) will be unavailable. 
Range check errors are for the most part harm-
less though annoying. If this happens, please 
send a sample of the file (no larger than 50K) 
to support@weathergraphics.com and we will 
try to fix it in the next version of the program. 
Be sure to clearly indicate the problem with the 
sample or we will not be able to do anything 
with it. 

How can I download data to a file and then 
load it into Digital Atmoshere so that it can 
process the data? 
You must save the incoming weather data into a 
disk file. Under your favorite browser, bring up 
the raw data on your screen, then choose “File, 
Save As...” and save it as a text file (not HTML).  
Remember the location you saved it to.  Then go 
into Digital Atmosphere, choose “File, Import a 
file...” and choose that file. After it imports, you 
can then plot and analyze it.  Note that if you’re 
on the Internet, you can skip this whole process 

by choosing Internet > Retrieve Data and let 
Digital Atmosphere do all the work.

I’m having problems printing to my HP Laser-
Jet printer.
This issue may have been solved in Windows 
7/8/10.  Around 2005, some users reported 
problems printing to HP LaserJet printers (such 
as getting blank pages).  To fix this, go to print 
setup (below), and either change the resolution 
from 600 to 300 dpi or change “vector” to “ras-
ter”.  If your printer is equipped with a PostScript 
option, use the PostScript mode for 600-dpi 
printing. This 600-dpi PCL5 printing problem is 
not specific to Digital Atmosphere.  Documents 
with various graphic images may not print 
correctly to the LaserJet 4 in PCL mode at 600 
dpi unless the Graphics option in the Windows 
printer driver setup is set to Raster mode.

Digital Atmosphere is missing the mouse 
tracker and roaming SKEW-T. 
The mouse tracker has been replaced by right-
clicking on the map and choosing “Get lat/long”.  
The roaming SKEW-T will be enabled soon. 

When using the Internet Data Retrieval func-
tion, Digital Atmosphere always retrieves the 
wrong file, a missing file, or the file for an 
incorrect time. 
This will happen if your computer clock is set to 
the wrong time or Windows is set to the wrong 
timezone.  Also if you’ve recently gone off or 
came onto daylight saving time, check File > 
Preferences > General > “Adjust for daylight 
time”.  To set the timezone, head to your Win-
dows status bar and right-click on the time 
clock.  Choose Adjust Time/Date. Then look at 
the Time Zone tab. Make sure these settings are 
all correct.  Digital Atmosphere tries to deter-
mine UTC (Greenwich Mean Time) based on 
the system time and the time zone setting, and 
using this data tries to retrieve the appropriate 
file. 
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How can I customize the Television Plot cit-
ies? 
All you need to do is look in your Digital At-
mosphere program directory (using any ASCII 
editor such as Windows Notepad) and edit the 
file named DIGATMOS.PLL . Columns 1-4 
should contain the ICAO (for METAR obser-
vations) and columns 6-10 should contain the 
synoptic station number (for synoptic observa-
tions). Either the ICAO or synoptic identifier, 
or both, can be used. Columns 12-50 should 
contain the text for the station that you want 
plotted on the map (leave it blank if you want 
nothing). We hope to do away with this crude 
interface in an upcoming version of Digital 
Atmosphere and add a city list interface. 

I performed a contour analysis but no lines 
appear. 
In most cases, the contour lines have been set 
to the background color.  Go to File > Prefer-
ences and check the colors under the Map tab 
and the Contours tab.
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from online services, the Internet, etc, that is fed 
into Digital Atmosphere when the user selects 
File, Import.  First, the file is copied and filtered to 
produce a clean data file (C:\DIGATM\DATA.USR), 
and then data is imported, producing a formatted 
data file.
STATION PLOT — A small grouping of numbers 
and symbols that depicts the observed weather at 
a given location.  Plots are not “drawn”; they are 
“plotted”.
STATUS PANEL — The window that shows the 
clock, the active level, data display options, and 
import filters.
STERILIZED DATA FILE — A temporary file 
containing original raw data that is produced when-
ever the user imports data.  It contains no control 
codes or extraneous characters.  The sole purpose 
of a clean data file is for the File, View Raw Data 
command and for Digital Atmosphere functions 
where English-language bulletins are drawn on 
the screen (such as tornado watches, convective 
outlooks, etc).  Weather data plots and analyses 
do not come from this file, but from the formatted 
data file.
TOPOGRAPHY — The multicolor shades that can 
be manually drawn on landmasses to represent 
terrain.
UPPER AIR — Involving any level besides the 
surface.

Please refer to these key terms when asking for 
technical support or talking with other users.  It 
will help streamline some of the confusing “lingo” 
used for the functions in this program.

ACTIVE LEVEL — At any given moment, Digital 
Atmosphere will only perform analysis or plotting 
operations for a certain type of data or height/level 
(such as surface, 300 mb, NGM model output, etc).  
Active level describes which one is the current one.  
You change it by going to the Level menu.  The ac-
tive level is indicated by a checkmark in the Level 
menu, as well as in the title of the status panel.
ANALYSIS — See objective analysis.
DERIVATIVE FIELD — The vorticity, divergence, 
or advection of a selected primary field.
DIALOG BOX — Any box (window) that pops up 
on the screen temporarily asking you to enter or 
click something.
FORMATTED BINARY DATA FILE — The end re-
sults of File, Import, where tables of raw data are 
stored on disk and made available to the plotting 
or analysis routines.  These files consist of com-
pressed data and can only be modified using the 
File, Quality Control function.
IMPORTING — The process of “crunching” raw 
data.  This is how you feed new data into Digital 
Atmosphere.  The data is stored in formatted data 
files.
ISOPLETHING — The process of Digital Atmo-
sphere drawing contours, or lines, on the screen, 
as the result of an objective analysis.  Isopleths 
are not “plotted”; they are “drawn”.
MAP ATTRIBUTE FILE — A small file (36 bytes) 
that is paired with a geographical bitmap file to 
provide mathematical mapping information about 
that image.  A map attribute file has the file exten-
sion “ATR”.
MAP GENERATION — Forcing Digital Atmosphere 
to draw a customized map based on latitude, longi-
tude, and zoom settings that the user selects.
OBJECTIVE ANALYSIS — The process that Digital 
Atmosphere undergoes before it can show a con-
tour or isopleth.  It consists of looking at data at 
randomly-spaced points, mapping it to a grid, and 
running smoothers on the grid.  In the context of 
this user’s guide, I will refer to objective analysis 
as simply “analysis”, and refer to human analysis 
as “hand analysis”, etc.
OCEAN FILL — The blue color that Digital Atmo-
sphere usually draws in oceans and lakes.
PLOT — See station plot.
PRIMARY FIELD — An atmospheric property that 
the user chooses to analyze.  The user may also 
force Digital Atmosphere to calculate a derivative 
field of the primary field.
RAW DATA FILE — The original weather data 

APPENDIX A — Terminology
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A custom data field comprises a package of data that can be readily imported into Digital Atmosphere.  
You can create this data by any means (using third-party programs).
The custom data field must always be placed in the file CUSTOM.DAT in your Digital Atmosphere directory.  
It should be structured according to the following example:

   THUNDERSTORM DAYS (ALL MONTHS) 
   US AL:Bir 722280    33.567    -86.750   57        *                  
   US AL:Oza 722269    31.283    -85.717   73        *         
   US AL:Hun 723230    34.650    -86.767   54        *         
   US AL:Mon 722265    32.383    -86.367   56        *        

Here is a breakdown of each row and column:
Row 1   A header that will be used by Digital Atmosphere to title the field
Row 2+  Custom data

Column 1-19    	Not used.  The user may wish to put location names here.     
Column 21-29 	Latitude (degrees and thousandths; negative is southern hemisphere)
Column 31-39 	Longitude (degrees and thousandths; negative is western hemisphere)
Column 41-49	 Primary data value
Column 51-59	 Secondary data value

Ingesting a scalar field.  When a simple scalar field (such as temperature, pressure, wind speed, etc) is 
imported, the value must be placed in the primary data value field, and the secondary data value field 
must contain an asterisk character: *.

Ingesting a vector field.  If a numerical value is detected in the secondary data value field, Digital Atmo-
sphere will assume a vector field (such as wind u/v component) is being ingested.  The primary data value 
must assume a direction relative to true north (such as wind direction), and the secondary data value 
must assume a magnitude (such as wind speed).  When vector data mode is being used, analysis calcula-
tions will use wind barb symbology to represent data elements.

APPENDIX B — Custom data fields
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For technically inclined users only!

This file, ending with the file extension *.ATR, is associated with each map which is saved to disk.  The at-
tribute file consists of 6 48-bit floating point numbers.  They can be modified as follows:

Number	 Purpose
1		  Central latitude (degrees)
2		  Central longitude (degrees)
3		  Zoom setting
4		  Horizontal offset (in pixels)
5		  Vertical offset (pixels)
6		  Projection, where
		    0 or 2 = orthographic
		    1 = polar stereographic (not implemented)
		    3 = space oblique (not implemented)

APPENDIX C — Map attribute file format
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Product codes
Represents a set of data (a product).

pla ACARS plots
plf Standard data plots
plc Custom data plot
tdy Television-style data plots
rad Radar plots
sf0 Europe sferics (0 hr)
sf6 Europe sferics (6 hr)
wgr Wind grid

Field codes
Representing a single quantity; usually a scalar 
value.

tmf Temperature (deg F)
tmc Temperature (deg C)
pot Potential temperature (deg K)
wcx Wind chill factor
hix Heat index
dwf Dewpoint (deg F)
dwc Dewpoint (deg C)
rhu Relative humidity
mxr Mixing ratio
eqp Equivalent potential temperature (the-
ta-e)
slp Sea level pressure
alt Altimeter setting (QNH)
wsp Wind speed
cig Ceiling
hgt Geopotential height
thk Thickness (1000-500 mb)
wrx Warning overlays
p01 1-hour precipitation
p06 6-hour precipitation
p12 12-hour precipitation
p18 18-hour precipitation
p24 24-hour precipitation
rst RCM radar storm centroids
rhl RCM radar hail signatures
rms RCM centroid movement and speed
rtv RCM tornado TVS signature
reh RCM echo height signatures
rem RCM echo movement
wxp ASUS1 KWBC frontal depiction bulletin
ste Sea surface temperature
pdw Wave period
htw Wave height
hti Wave instrument-measured height
pdd Wind wave period
htd Wind wave height
di1 Primary swell direction
di2 Secondary swell direction
pd1 Primary swell period

ht1 Primary swell height
pd2 Secondary swell period
ht2 Secondary swell height
cig MVFR/IFR weather
dy1 SPC Convective Outlook Day 1
dy2 SPC Convective Outlook Day 2
06k Surface-6000 ft shear [not completed]
lcl Lifted condensation level [not com-
pleted]
be+ CAPE [not completed]
be- CIN [not completed]
cxx [not used]
hux [not used]
iht [not used]
zb+ [not used]
prt [not used]

Radar product codes
All ranges 128 nm unless otherwise noted

Base reflectivity
BREF1  Base reflectivity 0.5 deg
BREF2  Base reflectivity 1.5 deg
BREF3  Base reflectivity 2.4 deg
BREF4  Base reflectivity 3.4 deg
BR248  Base reflectivity 0.5 deg (248 nm)

Base velocity
BV32   Base velocity 0.5 deg (32 nm)
BVEL1  Base velocity 0.5 deg
BVEL2  Base velocity 1.5 deg
BVEL3  Base velocity 2.4 deg
BVEL4  Base velocity 3.4 deg

Base spectrum width
SW     Spectrum width
SW32   Spectrum width (32 nm)

Derived products
CR     Composite reflectivity
CR248  Composite reflectivity (248 nm)
ET     Echo tops
SWP    Severe weather probability
VIL    Vertically integrated liquid
STI    Storm tracking
H      Hail detection
TVS    Tornado vortex signature
M      Mesocyclone
OHP    One-hour precipitation
THP    Three-hour precipitation
STP    Storm total precipitation
SRMV1  Storm relative velocity 0.5 deg
SRMV2  Storm relative velocity 1.5 deg
SRMV3  Storm relative velocity 2.4 deg
SRMV4  Storm relative velocity 3.4 deg
CFC    Clutter filter

APPENDIX D — Field and product codes
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Because of the complexity of GRIB data and the fact that it is not fully supported by Digital Atmosphere 
yet, Weather Graphics Technologies will not provide assistance in locating, retrieving, or using GRIB data.  
It is provided as-is.  Comments are welcomed but we may not be able to respond to questions. If you 
need help, please access our public discussion group on our website at www.weathergraphics.com

Sources
The majority of GRIB output data is available from supercomputer models, such as the ETA model output 
provided by the National Center for Environmental Prediction near Washington DC. Sources of data include 
(updated as of 2018):

http://tgftp.nws.noaa.gov/SL.us008001/ST.opnl/- Choose the .grl directories. Within these, try to choose 
the smallest datasets, as even the smallest ones will contain a vast amount of data. The larger ones may 
crash Digital Atmosphere. A good dataset usually ends in awp211. These are GRIB sets but will not have 
a *.grb extension. To get them to show up you will need to change the filetype to “AWIPS” or “all” when 
choosing a GRIB file to import.

https://www.ecmwf.int/en/forecasts/datasets/wmo-essential (follow Public FTP link)

New NWS GRIB filename convention

Since 2002, the NWS has used a hierarchichal naming convention that forms a URL. An example is:
  http://weather.noaa.gov/pub/SL.us008001/ST.opnl/MT.eta_CY.00/RD.20031009/PT.grid_DF.gr1/fh.0000_
tl.press_gr.awp211

This shows that at the central server location (SL.us008001), one can find operational status data (ST.
opnl) consisting of the Eta 00Z cycle model (MT.eta_CY.00) produced on 09 Oct 2003 (RD.20031009). 
Within this one can find GRIB data (PT.grid_DF.gr1) consisting of data for the 00h forecast hour mapped 
onto the AWIPS 211 grid (fh.0000_tl.press_gr.awp211).

For more information on this naming convention see
   http://www.nws.noaa.gov/datamgmt/filstnd.html (Directory and File Naming Standards)
   http://www.nws.noaa.gov/datamgmt/tgftp_file_reference.html (TGFTP File Reference).

Old NWS GRIB filename convention

The legacy filename format for NWS GRIB data is as follows. Some datasets can still be found in the top-
level directory at http://weather.noaa.gov/pub/ which use this filename convention.

Sample: us008_gf000_02020300_HxXAx

Portions: us008_gfMMM_YYMMDDHH_ADGT

Here is what each field means:

MMM - Model code. Underlined codes are in current use as of February 2002; others are obsolete and 
are listed only for historical purposes. 000=Experimental, 010=GlobalWindWave, 039=NGM, 044=SeaS-
fcTemp, 076=MRFbiascorrected, 077=AVNfcst, 078=MRF, 080=MRF, 081=AVNinit, 082=MRFinit, 
083=ETA80km, 084=ETA22km, 085=ETA29km, 086=RUC60km, 089=ETA48km, 094=MRF-T170/L42, 
096=AVNfcst-T170/L42, 121=WesternNorthAtlanticwavemodel, 122=AlaskaWatersRegWaveModel, 
130=MergeOfRucEtaSpectral.

YYMMDDHH - Year, month, date, and hour - of model start time.

A - GRIB designator - H=WAFS (Family Of Services), Y=AWIPS, Z=AWIPS.

D - Data type. X=mixture.

APPENDIX E — GRIB data
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G - Grid. A=201 (Nhem/PS), H=213 (US/PS), I=202 (US/PS), J=203 (Alaska/PS), K=204 (Hawaii/
MER), L=205 (PuertoRico/PS), M=206 (CentralUS/LAM), N=207 (Alaska/PS), O=208 (Hawaii/MER), 
P=210 (PuertoRico/MER), Q=211 (US/LAM), R=212 (US/LAM), T=214 (Alaska/PS), U=215 (US/LAM), 
V=216 (Alaska/PS), X=experimental. Code following the geographical area means PS=Polar Stereo-
graphic, LAM=Lambert Conformal, MER=Mercator.

T - Timestamp. A=00, B=06 C=12, D=18, E=24, F=30, G=36, H=42, I=48, J=60, K=72, L=84, 
M=96, N=108, O=120, P=132, Q=144, R=156, S=168, T=180, U=192, V=204, W=216, X=228, 
Y=240. However if “A” (GRIB designator) is Z (AWIPS), this will instead be A=02, B=03, C=04, D=08, 
etc.

Note that Digital Atmosphere will only process grids mapped in lat/long, polar stereographic, and lam-
bert conformal projections

 



DIGITAL ATMOSPHERE MANUAL / January 2023  |  95



96  |  DIGITAL ATMOSPHERE MANUAL / January 2023



DIGITAL ATMOSPHERE MANUAL / January 2023  |  97

Scripting is a powerful function that allows Digital 
Atmosphere to do various tasks while unattended. 
You can have it download data every half hour 
and always have the latest map displayed, or send 
charts to the printer automatically. The possibilities 
are up to you.

Scripting basics

To run a single script command
Simply type in the script command in the “com-
mand” line on the scripts toolbar. Hit return or click 
“Enter” and it will be processed. Note that this 
does not run a script; it just runs a script com-
mand. A list of commands is below.

To write a script
Use any text editor or click on Create Script on 
the scripts toolbar and you can begin typing your 
script. Note that scripts should use the file exten-
sion .dsf in order to be properly recognized in 
Digital Atmosphere. To “comment out” a line of 
code simply place a # (octothorpe), : (colon), or 
; (semicolon) at the beginning of the line. Com-
mands are generally not case-sensitive.

To run a script in run-time
Go to the scripts toolbar and select the Run Script 
button.

To run a script at startup
Advanced users can run scripts on Digital Atmo-
sphere startup by using standard command-line 
parameters. A space and the full name of the script 
file is simply appended after the filename at the 
command prompt or in the shortcut property for 
Digital Atmosphere.

To use the scheduler
Go to the scripts toolbar and select the Scheduler 
button (it will say “Scheduler on...” or “Scheduler 
off...”). This will bring up a configuration window 
(see below) where the scheduler will coordinate 
which script files run at which time.

* You must set “Enable scheduler” for the sched-
uler to take effect.
* When the scheduler is no longer wanted, bring 
up this window again and unset “Enable sched-
uler”.
* To specify the execution time for each script, 
write the execution time in 4-digit UTC time in 
hhmm format (i.e. 7:45 am is 0745 and 2:15 pm 
is 1415), followed by a space, and the name of the 
file (including its .dsf extension).
* Be sure to specify the full pathname of the file, 

otherwise Digital Atmosphere will assume it is lo-
cated in your Digital Atmosphere directory.
* There can be an unlimited number of scripts and 
execution times in this list.
* Advanced users: You can edit or swap out this 
schedule list if you wish; it’s located in the Digital 
Atmosphere directory under digatmos.sft . 
 
Data display commands

PRODUCT,type,level,title
Overlays a meteorological product on the map. The 
appropriate data must have already been import-
ed. Valid type parameters are documented at the 
end of this section. Levels are specified as follows: 
for surface data, the level is 0 (zero); for milli-
bar levels the level equals the millibar level (500, 
etc); and for FT height levels the level equals the 
ten-thousands and thousands digits multiplied by 
-1 (so 34,000 ft equals -34). The title parameter is 
optional and contains a text title that will be placed 
in the legend. Derived fields are not supported at 
this time.

ANALYZE,scriptstring
Performs an analysis using an analysis script com-
mand. For information on building an analysis 
script command please see the Analysis section.

FONTTRUETYPE
Forces workchart fonts to TrueType mode.  Takes 
effect when new products or contours are dis-
played.

FONTNCEP
Forces workchart fonts to NCEP raster font mode.  
Takes effect when new products or contours are 
displayed.

SFCPLOTMODEL,filename
Loads a particular surface plot model. Filename 
must be the fully qualified filename with path and 
extension (*.sps).

Data management commands

DOWNLOAD,url,filename
Downloads a product from an Internet source. The 
url is the fully qualified, RFC 1738 standard URL 
(including filename), and filename is the full local 
name where the file will be stored.
Example: download,ftp://userid:password@ftp.
mydomain.com/anonftp/pub/out.jpg,c:\da20\bin\
map\in.jpg

APPENDIX F — Scheduler scripting
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UPLOAD,url,filename
Uploads a product to an Internet source. The 
url is the fully qualified, RFC 1738 standard URL 
(including filename), and filename is the full local 
name of the file to be uploaded.
Example: upload,ftp://userid:password@ftp.
mydomain.com/anonftp/pub/out.jpg,c:\da20\
bin\map\out.jpg

Note that you can set a password privately by 
using the DIGATMOS.PWD file (if there isn’t one, 
you may create it).  This will make your scripts 
secure and prevent passwords from showing up 
in the status windows. This file must be located 
in the Digital Atmosphere directory.  Make en-
tries as follows:
token=value
So if you have a login for your blog site, you 
might have something like this in your DIGAT-
MOS.PWD file:
myusername=joeblow
mypassword=12341234
When Digital Atmosphere encounters %%some-
thing%% in your URL, it will replace it with the 
values you defined in DIGATMOS.PWD.  Thus, in 
the example above %%myusername%% would 
get replaced with joeblow, and %%mypass-
word%% would get replaced with 12341234.

INGEST,filename
Imports the specified data file (filename is a fully 
qualified file name).

Radar commands

RADAR,product,station
Retrieves the desired radar product from the 
given station.  Station is a 3-letter station identi-
fier (e.g. FWS, EWX, etc).  Multiple stations are 
separated by one space character.  Product is the 
Radar Product Code from the table below.

RADARPLOT
Plots the latest retrieved radar data.

RADARSAVE,filename
Saves the latest retrieved radar data to a given 
filename.

IMPORTRADAR
Imports an imagemap radar, using parameters 
selected in Radar > Import Radar Images.

Derived product commands

HURRICANE
Imports hurricane bulletins.

HURRMODEL,type

Plots hurricane models.  The type is as follows: 
0, splines only; 1, splines and datapoints; 2, 
splines, datapoints, and labels.

FLEET
Plots all fleetcode information.

FLEETHL
Plots fleetcode bulletins with only highs and lows.

FLEETF
Plots fleetcode bulletins with only fronts.

FLEETI
Plots fleetcode bulletins with only isobars.

 
Graphics commands

LOAD,filename
Loads a map. IMPORTANT: You must specify 
the .dmf file in your filename, e.g. c:\da20\bin\
mymap.dmf . The associated map will also be 
loaded.

SAVE,filename
Saves a map. The filename parameter is the fully 
qualified filename without the extension (i.e. 
without .bmp).

EXPORT,filename
Exports a map (i.e. saves it to a variety of for-
mats and without the accompanying .atr file). 
The filename parameter is the fully qualified 
filename with a valid extension (may be bmp, gif, 
jpg, png, pcx, or tif). Compressed TIFF saving is 
not available.

IMPORT,filename
Imports a map.

SOUNDING,station
Plots a sounding for the given station.

ERASE
Erases all of the overlays on the map.

BLANK
Erases the overlays as well as the basemap.

STAMP
Imprints a timestamp at the top of the map that 
says “GENERATED (date) (time)”.

CLIP
Copies the map to the clipboard.

GRADIENTCOLOR,red|blue|green,ph1|ph2|
scale|offset,value
Sets one of the File > Preferences > Misc > set-
tings to a particular value. This allows the script 
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to change a contour gradient scheme on the fly.

Programming commands

SET,keywordnumber,keyword
Sets a specified keyword (1 through 9) to a certain 
value. You can then use this keyword later on in 
the same script simply by placing the token $$x 
anywhere in the code, where x is the keywordnum-
ber. This is useful for managing large scripts.

Examples:

SET 1 500
Sets keyword 1 to “500”

PRODUCT $$1 HGT
$$1 indicates “500”, so here 500 mb heights are 
plotted

PRODUCT $$1 TMP
$$1 indicates “500”, so here 500 mb temperatures 
are plotted

TIMERON
Enables the script timer. It will adhere to the cur-
rent timer script schedule.

TIMEROFF
Turns off the script timer.

PRINT
Prints the map to the default printer using default 
settings.

SLEEP,seconds
Causes Digital Atmosphere to pause for the speci-
fied number of seconds. An hourglass cursor will 
be displayed during this time.

SPAWN,filename
Executes an executable file or MS-DOS batch file 
specified by filename (must be a fully qualified 
filename with correct path; e.g. “c:\utilities\mypro-
gram.exe”).

MINIMIZE
The Digital Atmosphere application window is mini-
mized.

MAXIMIZE
The Digital Atmosphere application window is 
maximized.

NORMAL
The Digital Atmosphere application window is nei-
ther minimized nor maximized.

QUIT
Quits the program

Mapping commands

MAKE,projection,lat,long,zoom,width,height
Makes a map using the given coordinates. Projec-
tion is an integer (1 for standard orthographic, 2 
for polar sterographic, 5 for satellite, 3 for merca-
tor, and 10-29 for special NEXRAD projections).  
Lat is negative in the southern hemisphere. Long 
is negative in the western hemisphere. Zoom is a 
value equal to 3964/x, where x is the width of the 
map in statute miles. Width and height are the 
map sizes in pixels.

TOPO
Makes a topographic underlay on the map (takes 
some time).

POINT
Plots points.

BASEMAP
Plots the basemap.

CITY
Plots cities.

COOUT
Plots county outlines.

CONAME
Plots county names

HIGHWAY
Plots Interstate highways (U.S. only).

ROAD
Plots major roads (U.S. only).

CUSTOM
Plots custom overlays.

REMOVE
Removes the last product from the display.

 
Deprecated commands

THESE COMMANDS ARE NOT SUPPORTED AS OF 
THIS BUILD. THIS IS A REFERENCE FOR DEBUG-
GING OLDER SCRIPTS.

CENTER,station,zoom,width,height
Makes a map with the chosen station in the center 
of the screen. Zoom is a value equal to 3964/x, 
where x is the width of the map in statute miles. 
Width and height are the map sizes in pixels.

ARCHIVE,cddriveletter,yymm,yymmddhh
Accesses data from the Weather Graphics Tech-
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nologies Surface Archives or Upper Archives CD-
ROM. The cddriveletter parameter is the drive 
letter, while yymm is the year and month (full 
four digits) and yymmddhh is the year, month, 
date, and hour (full eight digits). Caution: This 
command has not been fully tested and may not 
work.

GRADIENT,on|off
Turns on or turns off the File > Preferences > 
Contours > option.

ISOPLETH,on|off
Turns on or turns off the File > Preferences > 
Contours > option.
 

List of valid product types 
For a list of valid codes, see the appendix show-
ing Valid Product Types.
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Sample scripts

This script downloads synoptic data from Albany (offline as of 2017), imports it, displays plots, and iso-
pleths sea level pressure, then outputs it to a file. Note that this will probably not work on your computer 
without changes, and is only intended to demonstrate the appearance of script commands.

Note the first line below is split onto two lines due to lack of room on this PDF document.

    download,http://www.atmos.albany.edu/weather/data1/surface/syn/@Y@M@D@S_syn.wmo,c:\digatm\
data\test.dat
    import,c:\digatm\data\*.*
    product,plf,0,Test plot
    product,slp,0,Test plot
    export,d:\da20\bin\map\out.jpg

This script plots a series of upper air charts for 1200 UTC August 27, 1990 from our Upper Archives 
CD-ROM and saves the completed charts for 250 mb, 500 mb, 700 mb, and 850 mb to individual files 
(1990082712250.gif, etc). Again this may not work on your computer without some changes.

    set,1,9008
    set,2,90082712
    archive,f,$$1,$$2
    product,plf,250,PLOT
    export,d:\da20\bin\shannon\19$$2250.gif
    erase
    product,plf,500,PLOT
    export,d:\da20\bin\shannon\19$$2500.gif
    erase
    product,plf,700,PLOT
    export,d:\da20\bin\shannon\19$$2700.gif
    erase
    product,plf,850,PLOT
    export,d:\da20\bin\shannon\19$$2850.gif
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(3) The active level is always taken from the Active 
Level setting on the toolbar. It can be overridden 
using a Setup Command. The same is true for data 
Time settings.

(4) Multiple fields are handled by using the output 
form to write a field to a slot, such as STOR=5 to 
store the result in slot 5. A slot contains a single 
scalar analysis grid. Various transformations which 
depend on a field number, such as SDIF (scalar 
difference), are supplied with two field slots with 
which to read.

(5) Commands can be strung together to produce 
multiple fields. Currently there is a limit of 255 
characters to a script command.

(6) Suggestions for transformation commands, 
output commands, operators, and so forth are 
greatly welcomed at this time. Much more is 
planned; this is only a start! For an idea of what 
is possible see the PCGRIDDS documentation 
at http://www.lib.noaa.gov/pcgridds/appendix.
html#C as some of the commands are based on 
these techniques.

(7) Scripts are not case-sensitive.

 
Examples

CONT CINT=4 SLPR
Explanation: Take the sea level pressure field. Set 
the contour interval to 4. Now contour it. Note that 
the color is not set, so the result color is unpre-
dictable. Also the level is not set, so if the current 
height setting is 500 mb, an invalid fieldwill result.

DATA VKNT WSPD
Explanation: Take the wind speed field (which will 
be in m/s). Convert it to knots. Now view it as a 
numerical grid.

CONT CINT=60 DASH COLOR=200,0,0 
SDIF=1,2 STOR=2 HGHT H000 STOR=1 HGHT 
H500
Explanation: Take the 500 mb height field. Store it 
in slot 1. Take the 1000 mb height field. Store it in 
slot 2. Compute a difference between field 1 and2.
Now set the pen color to 200,0,0 (lightred, i.e. 
red=200, green=0, blue=0. Set lines to dashed, 
and set a contour interval of 60. Nowcontour 
theresult. This produces the 1000-500 mb thick-
ness.

Analysis scripting is slightly different from sched-
uler scripting. While scheduler scripts are designed 
to accomplish tasks in Digital Atmosphere such as 
accessing data, displaying fronts, and so forth, the 
analysis script language is based solidly on logic 
and mathematics, and is meant to build display 
products in a very flexible manner.  However, 
analysis script sentences may be embedded in a 
scheduler script by using the scheduler command 
ANALYZE.

An analysis sentence is made up of a group of 
commands on one line. There are two ways of 
executing a script containing these analysis sen-
tences:

(1) On the command line (in the Toolbox under the 
Scripting tab).

(2) In the DIGATMOS.MNU file, which is used to 
build the Analysis dropdown menu. This may be 
edited by hand. The pipe, |, symbol is used to 
separate the title from the script form and may be 
placed anywhere between the two providing it is 
padded with spaces only. The Standard version is 
limited to 50 defined script commands; the Pro-
fessional version is unlimited.  Note that you will 
need to restart Digital Atmosphere to invoke the 
changes.

Command sentence structure

A sentence of analysis script follows the strict 
order:

[output] [transform] [base] [setup]

(1) Digital Atmosphere processes the script from 
RIGHT TO LEFT, so that any optional setup is done 
(such as setting the level), then defining the base 
field to be worked on (such as temperature), then 
transforming (such as converting m/s to kts), then 
producing output (such as setting a contour inter-
val and then displaying contours. Deviation from 
this form may cause unpredictable results.

(2) Users must be vigilant as to whether a scalar 
or vector field is being processed. For example, 
CONT WIND will result in a nonsensical output, 
because wind is a vector field and cannot be 
isoplethed.   To view wind speed, you will need to 
extract a magnitude by using CONT WSPD (contour 
windspeed) or use a display function provided for a 
vector field.

APPENDIX G — Analysis scripting
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For other examples please open the DIGATMOS.
MNU file and study the examples provided. They 
drive the Analysis dropdown menu.

Setup commands

HSFC
Set level to surface

H000
Set level to 1000 mb

H925
Set level to 925 mb

H850
Set level to 850 mb

H700
Set level to 700 mb

H500
Set level to 500 mb

H400
Set level to 400 mb

H300
Set level to 300 mb

H250
Set level to 250 mb

H200
Set level to 200 mb

H150
Set level to 150 mb

H100
Set level to 100 mb

Analysis method commands
If not specified, the setting in Preferences > 
Analysis will be used.

ANLN
Sets analysis method to Nearest Neighbor

ANLW
Sets analysis method to Weighted

ANLC
Sets analysis method to Cressman

ANLB
Sets analysis method to Barnes

Base field commands

TEMP
Temperature (deg C)

THTA
Theta, or potential temperature (deg K)

DWPT
Dewpoint (deg C)

RELH
Relative humidity (%)

BULB
Wet bulb temperature (deg C)

MIXR
Mixing ratio (g/kg)

HIDX
Heat index (deg F)

HGHT
Geopotential height (m)

GHGT
Geostrophically balanced height field (m)

THTE
Theta-e, or equivalent potential temperature 
(deg K)

PTEN
Reported pressure tendency

WCHL
Wind chill (deg F).  This is the November 2001 
JAG/TI formulation.

WCHO
Old wind chill formula (deg F).  This is the origi-
nal model.

WCHC
Environment Canada wind chill formula (deg C)

HIDX
Heat index (deg F)

HAAT
Australian apparent temperature (deg C)

HUMX
Humidex (deg C)

WSPD
Wind, speed (m/s)

WIND
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Wind, vector (m/s) (referenced to true north)

WDRC
Wind, direction (deg)

UGRD
Wind, west-to-east component (m/s) (referenced 
to true north)

VGRD
Wind, south-to-north component (m/s) (referenced 
to true north)

HGHT
Geopotential height (m)

SLPR
Sea level pressure (QFF) (mb)

ALST
Altimeter setting (QNH) (in Hg)

PRES
Pressure (mb) (used for upper-level heights)

LATT
Latitude (deg)

LONG
Longitude (deg)

ELEV
Elevation (m)

TSEA
Temperature, sea-surface (deg C)

PC01 / PC02 / PC03 / PC06 / PC09
PC12 / PC15 / PC18 / PC24
Precipitation during the period given by the last 
two numbers, which represent hours.

PCXX
Precipitation (unknown time period; used in Aus-
tralian AXF data)

WSWP
Wave period (sec)

WSWH
Wave height (m)

WWWP
Wind wave period (sec)

WWWH
Wind wave height (m)

WLP1
Sea swell period 1 (sec)

WLP2

Sea swell period 2 (sec)

WLH1
Sea swell height 1 (m)

WLH2
Sea swell height 2 (m)

WLD1
Sea swell direction 1 (screen relative)

WLD2
Sea swell direction 2 (screen relative)

Transformation commands

VKNT
m/s to kt

VMPH
m/s to mph

VKMH
m/s to km/h

FTOK / FTOC / CTOF / CTOK / KTOF / KTOC
convert deg F, deg C, or K to deg F, deg C, or K 
(first letter indicates which scale is being converted 
from, and fourth letter indicates which scale is be-
ing converted to)

CCFF
convert Celsius degree increments to Fahrenheit 
degree increments (this is a straight mutiplication 
by 9/5 and does not use the Celsius or Fahrenheit 
scale)

DEGF / DEGC
deg C to deg F, and from F to C respectively (do 
not use, will be superseded by CTOF and FTOC)

MAGN
Magnitude of a vector field (produces speed for a 
wind field)

DVRG
Divergence of a vector field

RVRT
Relative vorticity of a vector field (pure; used 
mainly at surface)

AVRT
Absolute vorticity of a vector field (adds Earth’s 
rotation; used for upper air)

SMTH
Apply Haltiner smoother

SMTP=[number]
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Allow this number of smoothing passes (default 
1)

SMTC=[number]
Set smoothing coefficient (0 to 1 only) (default 
0.5)

SSUM=[f1,f2]
Calculates sum of fields f1 and f2

SDIF=[f1,f2]
Calculates difference of fields f1 and f2

SAVG=[f1,f2]
Calculates average of fields f1 and f2

SMLT=[f1,f2]
Calculates product of fields f1 and f2

SDVD=[f1,f2]
Calculates quotient of fields f1 and f2

SADC=[f1,#]
Calculates sum of field f1 and any number #

SSBC=[f1,#]
Calculates difference of field f1 and any number 
#

SMLC=[f1,#]
Calculates product of field f1 and any number #
SDVC=[f1,#]
Calculates quotient of field f1 and any number #

Universal output commands

COLOR=r,g,b
Set draw color to color: r=red, g=green, b=blue 
(each is 0-255, with 0 being dark and 255 light)

STOR=n
Store field in slot n (1-9)

Scalar output commands

DATA
Data grid values

CONT
Contour (defaults to contour interval of 1)

VAON
Allow plotting of numeric values below minimum/
maximum (default)

VAOF
Prohibit plotting of numeric values below mini-
mum/maximum

NMCY
Plot highs and lows in special NMC font (default 
is according to Preferences > Analysis)

NMCN
Plot highs and lows in standard font (default is 
according to Preferences > Analysis)

HILO
Plots H or L above data at gridpoint maximum/
minimum

HIID
Plots H above data at gridpoint maximum

LOWD
Plots L above data at gridpoint minimum

MXMN
Plots H or L above data at gridpoint maximum/
minimum

MAXD
Plots H above data at gridpoint maximum

MIND
Plots L above data at gridpoint minimum

DVCV
Plots H or L above data at gridpoint maximum/
minimum

DVVD
Plots H above data at gridpoint maximum

CVVD
Plots L above data at gridpoint minimum

PLMN
Plots H or L above data at gridpoint maximum/
minimum

PLLD
Plots H above data at gridpoint maximum

MNND
Plots L above data at gridpoint minimum

OVER
Overlay basemap translucently (good for fills)

CINT=[number]
Contour interval (must be an nonzero positive 
number)

GRTN=[number]
Contours or fills greater than this number

LSTN=[number]
Contours or fills less than this number

EQUA=[number]
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Plot a contour equal to this number

LINE=[number]
Set line width (must be nonzero positive integer)

FILL
Fill using fill color

SOLD
Plot contours as solid line

DASH
Plot contours as dashes

DOTS
Plot contours as dots

DADO
Plot contours as dash-dot

DADD
Plot contours as dash-dot-dot

FILL
Perform a floodfill

FILS=[number]
Set fillstyle to one of the following (must appear 
to right of FILL command):  0, Solid (default); 1, 
Cross; 2, Diagonal cross; 3, Diagonal 1; 4, Diago-
nal 2; 5, Horizontal stripes; 6, Vertical stripes

Vector output commands

BARB
Wind barbs (m/s)

BKNT
Wind barbs (m/s shown as kt)

BMPH
Wind barbs (m/s shown as mph)

BKMH
Wind barbs (m/s shown as km/h)

VECT
Vector grid

STRM
Streamline
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The list of radar resources is kept in the file digat-
mos.rdy.

Here is a quick tutorial on how to add a radar site.  
We Googled “south africa radar” and found a radar 
image page at http://metsys.weathersa.co.za .  
We go to the page for Durban and see that there is 
an image.  Right-clicking on the image we see that 
the radar image is stored in http://metsys.weath-
ersa.co.za/radar_image/DN.gif (which is good, as 
loopers and non-fixed filenames can be consider-
ably more complicated to deal with).  Now we need 
to get the latitude and longitude of this site.  It’s 
not anywhere on the page, however the website 
has a handy radar information page at http://
metsys.weathersa.co.za/nwrn.htm.  This shows 
Durban at 30.01S 30.93E.  Make a note of that.

Now we need to import the radar image into a 
graphics program; we use PaintShop Pro.  In your 
browser, right-click on the image and choose Copy 
Image.  Then paste it in your software.

In another window, open Notepad and then open 
your digatmos.rdy file in the Digital Atmosphere 
directory.  Start a new line at the top of the data 
block (anywhere in the list is fine, but entering new 
items at the top we can see the column headers 
more conveniently).

In your graphics program, position the cursor 
on the very center of the radar site and read the 
X/Y coordinates, wherever your graphics pro-
gram displays it.  This shows a center position 
of304,367(X=304,Y=367).  Enter this into digat-
mos.rdy under XXX YYY.  So far it should look like 
this:

Now we need to find the top left and bottom right 
of the part of the image containing valid radar 
information.  This image has a border box enclos-
ing the radar product; the legends are outside of it 
and the radar image is inside of it. We can use the 
border box.  The top left is (0,54) and bottom right 
is (612,665).  Enter this under LEFX,TOPY and 
RGTX,BOTY.

Now we determine the maximum range of the 
radar scan.  This can be seen easily with the 200 
km ring.  So the range will be 200 km.  Enter that 
under RNG.  Now we need to determine a scale in 
pixels per km.  This is an easy task since the range 
rings and site center are obvious.  Since the left-
most extent of the 200 km ring is at X=0 and the 
radar center is X=304, this means that we have 

304 pixels per 200 km of distance.  Do the division 
and we get 304/200 = 1.52.  Fit this figure under 
SCALE.

Now put the latitude and longitude under LATITU 
LONGITU.  Note that if your figures came in de-
grees-minutes-seconds you need to convert them 
to decimal values before entering them here.  For-
tunately the South Africa radar information page 
gave us decimal degrees.  Always use negative for 
westerly longitudes and southerly latitudes.  So we 
will be entering -30.01 30.93.

Now let’s get the URL of the image.  Simply right-
click on the radar image in your browser and 
choose Copy Image Location.  Paste this under 
URL in digatmos.rdy.  In this case the image is at 
http://metsys.weathersa.co.za/radar_image/DN.gif 
.

Under FMT we need to enter the image format 
type.  Typically you just use the extension on the 
URL, which in this case is gif.  Other types seen 
may be jpg and png.  Some sources use the wrong 
image type on the filename, in which case the im-
age will not display in Digital Atmosphere and you 
will have to see if the site is posting, say, a JPG us-
ing a PNG filename (this kind of thing is happening 
with Canadian radar images).

Now we need to develop a color table to tell Digital 
Atmosphere which radar colors contain informa-
tion.  Scroll to the bottom of the digatmos.rdy file 
and start a new TABLE= line using a value that 
is not in use.  If you’re using the default Digital 
Atmosphere digatmos.rdy file, you’ll probably be 
starting a TABLE=05 line.  So enter TABLE=05 
followed by two forward-slashes and a note telling 
you what this table is for.  We recommend:

TABLE=05 // South African radars

Now we need to enter the color information for 
each intensity level.  The South African radar 
source has a handy scale on the right side.  View 
this in your graphics program.  Now you need to 
use whatever tool will let you hover over pixels and 
show you the color value using RGB numbers (i.e. 
three numbers, each ranging from 0, dark, to 255, 
bright, indicating the numerical level of red, green, 
and blue).  In PaintShop Pro it is the eyedropper 
icon (pick up color).  If you hover over the “0 dBz” 
level, which is gray, you should see it has R=90 
G=89 B=90.  We enter a line using this format:

APPENDIX H — Radar import tutorial
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LEVEL=dbz,red,green,blue,threshold

The red, green, and blue are self-explanatory.  
The dbz is the dBz level from the scale; it’s only 
used for color mapping.  If no scale is provided 
you can use 0 for weak echoes ranging up to 
60 for heavy levels.  Finally threshold is a value 
used to “accept” pixels that are close to the re-
quired R,G,B values... we will use 10.  However it 
may be important to set this for JPG files where 
color drift may occur.  Threshold should usually 
be 10, but you can increase it to 50 or 100 if 
lossy JPGs are used and “holes” are appearing 
in the generated radar images.  Basically Digital 
Atmosphere looks at the numerical difference in 
red, blue, and green and adds up these differ-
ences (using the absolute value) to gauge the 
pixel against the threshold.  So if you define 
RGB=10,10,10 and the program sees a pixel with 
RGB=30,30,30, this adds up to a difference of 
60.  The pixel will be treated as part of your level 
definition as long as the threshold value doesn’t 
exceed 60.

When we are done defining all levels it will look 
like this:

TABLE=05 // South African radar
  LEVEL=00,090,089,090,10
  LEVEL=05,074,060,140,10
  LEVEL=10,000,089,000,10
  LEVEL=20,000,113,000,10
  LEVEL=30,008,125,222,10
  LEVEL=35,024,069,231,10
  LEVEL=36,107,012,198,10
  LEVEL=39,198,016,132,10
  LEVEL=42,189,101,132,10
  LEVEL=45,206,134,057,10
  LEVEL=48,247,195,049,10
  LEVEL=51,255,251,000,10
  LEVEL=54,255,154,090,10
  LEVEL=57,255,093,008,10
  LEVEL=60,255,052,024,10
  LEVEL=65,189,190,189,10
  LEVEL=70,214,211,214,10

Note that extraneous zeroes have been prefixed 
to make numbers two or three digits.  This is op-
tional, and has been done here to make the file 
look neater.  We will also skip South Africa’s 80 
dBz since it matches the basemap color (white) 
and may give undesirable results.

Finally we need to hook up this table number 
(05) with the Durban radar entry above.  Put this 
number under CO to point it at the table.

We’re done!  Now generate a map in Digital 
Atmosphere for Durban (the ICAO is FADN) and 
use a tight zoom level of about 300 or 400 nm.  
Now use Radar > Import Images and Clear All 

and then check Durban.

Note that there are traces of radar range rings.  
This cannot be avoided since it is an artifact on 
the original image.  The outer red radar range 
ring is provided by Digital Atmosphere to mark 
the maximum extent of radar information and 
can be shut off by putting RANGERING=0 instead 
of RANGERING=1 before the TABLE= entries in 
digatmos.rdy.  The palette can also be changed 
in this section to something more desirable.
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Digital Atmosphere is not able to automatically 
read satellite images and georeference them. This 
is an extremely complex function, so the user must 
develop techniques to accomplish this.

We cannot provide support for this, but we will 
present some suggestions on how to get started.  
Also see our user forums at www.weathergraph-
ics.com/forum as many users have worked with 
this sort of task.  The Map > Import command is 
central to working with satellite images as it allows 
the basemap to be replaced with any graphical im-
age.  However the image must correspond with the 
basemap that was replaced.

Help from Ton Lindemann
Users who wish to use satellite imagery as base-
maps in DAWS from David Taylor’ GeoSatSignal 
output may ask for a free set of .dmf setup files. 
The set comes with a sample map for each con-
tinent and ocean, except the polar regions. Just 
replace the sample map by GSS output and open 
the .dmf-file to have the image on the desktop in 
Digital Atmosphere.  The winzipped file is around 
720 kB and comes with a setuplist for GSS. It can 
be ordered free by sending an e-mail to: postbus@
meteo-maarssen.nl (e-mail updated August 2019).

Help from Fred van den Bosch
In the RIG-journal 73 (June 2003) is an article 
by Thomas Scheelen ( www.rig.org.uk ). He uses 
some modules of David Taylor like HRPT-reader 
and Groundmap. My experiences are based on that 
article:

Setup.  Download from http://www.satsignal.net/ 
the programs HRPT-reader and GroundMap and 
install them.

Download.  Download files from http://www.saa.
noaa.gov/. How to do this is described on http://
www.satsignal.net/. On the page about HRPT-read-
er is a link to basic notes on using the SAA. The 
final results are one or more downloaded files.

HRPT-reader.  Open a downloaded file. The main 
result is a false colour image. Save this image. On 
the background a location file is saved too.
GroundMap.  Open the location file from the previ-
ous step. Choose .Ortographic. as projection and 
use a suitable output size. The image is showed. 
Save the image.  If Groundmap is not registered 
you have a few possibilities in output size. This 
means that you get a rather small image in DAWS. 
But you can see what is possible.

Initial Digital Atmosphere.  Generate a map. Use 
for latitude and longitude the same values as in 
the download. Use for scale a size that generates 
more or less the same map as GroundMap. It is 
not so important at this moment. Give width en 
height the values from the download. Generate the 
map and if it.s ok, save it with <Map/Save map> 
as BMP.

Fine-tuning.  Repeat the next steps until both 
maps fits exactly.

1.Choose icon .load map. and read the GroundMap 
image.

2.Choose <map/add base map>. This option will 
project the DA-map over the image and will surely 
not fit. Now we must try to make the DA-map fit. 
This is done by making changes in <Map/Generate 
map/Enter lat/lon.> :

3.Latitude. This will move the map in vertical direc-
tion

4.Longitude. This will move the map in horizontal 
direction.

5.Scale for resizing the map.

6.Make small changes in the steps 3, 4 and 5. Af-
ter <OK> DA will generate a new map.

7.Continue with step 1.

Finishing.  Save the DA-map for the last time. This 
must be done because every lay-out has its own 
base map and parameter-files. Always open this 
corresponding map before loading a picture with a 
different layout from GroundMap.

APPENDIX I — Importing satellite images
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This is a breakdown of the color fill method used in File > Preferences under the Misc 1 tab.

The colors are defined according to the plotted Value for the particular point on the map, which will always 
be in the range 0..1, where 0 is the lowest possible reading and 1 is the highest possible reading.  This 
Value is fitted to a sine wave according to user defined parameters to determine the Red, Green, and Blue 
component of its color.

First the value (0 for minimum possible and 1 for maximum possible) is fitted to the sine wave to deter-
mine what the amplitude will be.  Amplitude will always be in the range -1 to 1.  Amplitude is determined 
by ph1 and ph2, which are in degrees.  A greater difference between ph1 and ph2 will result in a more 
curved function, while a smaller difference will produce a flatter function.  For basic users, the sine re-
sponses are as follows: 

	 Amplitude = sin( [(ph2-ph1) * Value] + ph1 )

	 where
	    ph1 = a user defined value in degrees,
	    ph2 = a user defined value in degrees,
	    sin(0)=0, sin(90)=1, sin(180)=0, sin(270)=-1 .

Finally the amplitude is modified according to the user-defined scale and offset values to determine Color-
Value, which must always be in the range 0..1 (0 is dark, 1 is bright).  This means if an Amplitude value 
is negative, it must be offset so that it falls into the range 0..1.  An out of bounds ColorValue is always 
rounded up or down so that it equals 0 or 1.

	 ColorValue = (Amplitude * Scale) + Offset

Example: For a basic scale where cold temperatures are black and hot temperatures are bright red, set 
Red Ph1=0, Ph2=90, Scale=1, and Offset=0.  Set the Green and Blue Scale to 0 and Offset to 0, which 
will always provide a value of 0 for these components.

APPENDIX J — Color fills
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Digital Atmosphere is capable of importing obser-
vations from a comma-delimited database listing. 
This is excellent for weather observations exported 
out of a database or a spreadsheet.  It is also suit-
able for Australian AXF weather data.  This type of 
data is not ingested through standard data import 
but is instead plotted on demand from data located 
in custom.dat in the Application Data directory 
(this location is listed in Help > About).

If recognized as shown below, the data will be 
imported and available for viewing as long as it is 
imported as usual from the data directory or from 
a specified file.

The rules for this data are:

* Comma-delimited data only.
* Each line must correspond to one observation
* No extraneous commas are permitted (even 
within quote marks)
* The observation must contain the station’s lati-
tude and longitude.

To take advantage of this capability, you need to 
open the DIGATMOS.FMT file with a text editor and 
define the start sequence and the parameters that 
apply to that type of data.

Start sequence

You define the start sequence by placing a “start 
sequence” between brackets in the DIGATMOS.FMT 
file; for example if your database starts out with 
a piece of text containing “Joe’s Data” you should 
start out with this:

[Joe’s Data]

No database entries are read in until the start se-
quence is found.

 
Parameter list

To actually read the data, you will need to create a 
parameter list, such as this:

TMP=4
DWP=6

Each entry must be on its own line, and the list 
ends when the end of the file is reached or another 
start sequence is found. The example above indi-
cates that the temperature can be found in column 

4 and the dewpoint can be found in column 6.

Sample listing

Here is a sample of an entry in DIGATMOS.FMT 
which is used for Australian Bureau of Meteorology 
AXF data.

[synopData]
ICA=3
WMO=1
LAT=6
LON=7
ELE=9
TIM=5
DAT=4
TMP=22
DWP=23
WND=11
WNM=12
SKY=10
CIG=26
WXX=14
VIS=13

Valid parameters

ICA=xxx
ICAO of the station (for display purposes only)

WMO=xxx
WMO number of the station (for display purposes 
only)

LAT=xxx
Latitude, in hundreds of degrees (negative is 
southern hemisphere)

LON=xxx
Longitude, in hundreds of degrees (negative is 
western hemisphere)

LAX=xxx
Latitude, in regular format (negative is southern 
hemisphere)

LOX=xxx
Longitude, in regular format (negative is western 
hemisphere)

ELE=xxx
Elevation in meters (used only for potential tem-
perature calculations)

TIM=xxx

APPENDIX K — Tabular weather data (comma delimited)
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Time in UTC (expressed as 450 for 4h50m and 
1629 for 16h29m)

DAT=xxx
Day of month (expressed as “16” for September 
16)

TMP=xxx
Temperature in degrees Celsius

DWP=xxx
Dewpoint in degrees Celsius

WND=xxx
Wind direction in degrees true

WNS=xxx
Wind speed in knots

WNM=xxx
Wind speed in meters/second

SKY=xxx
Total sky cover in oktas (9=obscured, 10=not 
available)

SLP=xxx
Sea-level pressure in millibars< FONT face= 
Courier>

CIG=xxx
Ceiling in hundreds of feet

WXX=xxx
Weather code; first and second digit equals ww 
weather code (e.g. 61 is light rain)

VIS=xxx
Visibility in meters

P01=xxx
Precipitation total in millimeters (past 1 hr)

P06=xxx
Precipitation total in millimeters (past 6 hr)

P12=xxx
Precipitation total in millimeters (past 12 hr)

P24=xxx
Precipitation total in millimeters (past 24 hr)

PXX=xxx
Precipitation total in millimeters (source-defined 
period; unknown to Digital Atmosphere)

PCP=xxx
Precipitation total in millimeters

PCT=xxx
Precipitation time period in hours

PTR=x
Pressure trend (equals a in app group)

PTN=xxx
Pressure tendency (in tens of millibars)

SNO=xxx
Snow depth in centimeters

CLL=x
Low cloud code

CLM=x
Middle cloud code

CLH=x
High cloud code

MAX=xxx
Maximum temperature, in degrees Celsius

MIN=xxx
Minimum temperature, in degrees Celsius
 

More on Australian AXF data

Information on Australian AXF data can be found 
here:
http://www.bom.gov.au/nmoc/Obs/IDY03000.
doc
http://www.bom.gov.au/nmoc/Obs/IDY03090.
doc
http://www.bom.gov.au/nmoc/Obs/IDY03100.
doc

Note that there may be restrictions on the use of 
Australian data, so look into this before creating 
commercial products.



DIGITAL ATMOSPHERE MANUAL / January 2023  |  119



120  |  DIGITAL ATMOSPHERE MANUAL / January 2023



DIGITAL ATMOSPHERE MANUAL / January 2023  |  121

The master template file for space-delimited tabu-
lar weather data is found in the Digital Atmosphere 
Application Data directory under digatmos.tpl.  It is 
applied to all data imported through File > Import 
and Data >Retrieve to locate embedded tables of 
space-delimited meteorological data.

The template file contains four columns: SPEC for 
the element type, V1 for column start (if appli-
cable), V2 for length (if applicable), and T1 for text 
data (if applicable).

Element types

#DEF
Starts the definition of a table.  On this #DEF row, 
give the table a name in T1; this name is used for 
display purposes.

#LEG
Defines a line that can be used as a legend for 
the table (such as a line that contains a date or 
valid time).  Specify a keyword in T1 that is to be 
located on the line.  When encountered, it will be 
used in legends.

#FLG
A scrap of text which, when encountered during 
importing, tells Digital Atmosphere that it is about 
to encounter a table.  This flag must be encoun-
tered before any data can be imported.  Specify 
the scrap of text in T1.

#BEG
Is a scrap of text which, when encountered dur-
ing importing, tells Digital Atmosphere that a data 
table is starting immediately.  Put the scrap in T1, 
and define the column where it must be seen in 
V1 and the length of the scrap in V2.  Data import 
always ends on an empty line.

#DAT
Specified for each data element that will appear in 
a row of data.  Give the field a name in T1 (this is 
used only for display purposes). Define the begin-
ning column of the data in V1 and the length of the 
data in V2.

#MIS
Specifies characters that are used to denote miss-
ing data.

#LAT
Specifies where the latitude (decimal only) is 
found.  Put the column start position in V1 and the 

field length in V2.

#LON
Similar to #LAT but for longitude.

Example

SPEC V1  V2  T1

#DEF -   -   Australian temperature data
#LEG -   -   Observations
#FLG -   -   IDCLCD0002
#BEG 66  2   :-
#MIS -   -   #*+
#LAT 67  6
#LON 60  6
#DAT 1   10  Date
#DAT 12  6   Stn_num
#DAT 23  40  Name
#DAT 81  5   max
#DAT 87  1   dc
#DAT 89  5   min
#DAT 95  1   dc
#DAT 97  5   terrmin
#DAT 103 1   dc
#DAT 105 1   of
#DAT 107 6   SLP_9_am
#DAT 114 5   T_9_am
#DAT 120 5   Td_9_am
#DAT 126 1   cld
#DAT 128 1   of
#DAT 130 6   SLP_3_pm
#DAT 137 5   T_3_pm
#DAT 143 5   Td_3_pm
#DAT 149 1   cld
#DAT 151 1   of

#DEF -   -   Australian rainfall data
#LEG -   -   Observations
#FLG -   -   IDCLRD00001
#BEG 66  2   :-
#MIS -   -   +
#LAT 67  6
#LON 60  6
#DAT 1   10  Date
#DAT 12  6   Stn_num
#DAT 23  40  Name
#DAT 81  5   Precipitation_mm
#DAT 87  1   PP
#DAT 89  1   DC
#DAT 91  1   OF

 

APPENDIX L — Tabular weather data (space delimited)
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Whenever an Analysis is performed on any data 
(scalar, isoplethed fields only), Digital Atmosphere 
always exports its output to GRID.TXT. The output 
can then be imported into spreadsheets or ana-
lyzed further by other methods.

The output consists of 900 points (30 by 30) rep-
resenting the value at each point of X and Y in the 
geographic area shown in the workchart window. 
The X-axis is left-right in the window, pointing 
right, while the Y-axis is up-down in the window, 
pointing down. This means that the highest values 
of X and Y are found east and south, respectively. 
The latitude/longitude of each X and Y point in 
decimal format is shown, followed by the analyzed 
value at that point.

Here is a sample of output from GRID.TXT.

    X  Y  LATITUDE LONGITUDE VALUE
    0  0  42.435   -107.721  1012.79998779
    0  1  42.471   -107.141  1012.84558105
    0  2  42.505   -106.560  1012.92547607
    0  3  42.537   -105.979  1013.08880615 

APPENDIX M — Exported analysis grids
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(blank)
Nothing will be plotted in this space

TEMP
Air temperature in whole degrees (C or F)

TEMP(10)
Air temperature in tenths (C or F)

DWPT
Dewpoint in whole degrees (C or F)

DWPT(10)
Dewpoint in tenths (C or F)

GUST
Wind gust (kt)

RH
Relative humidity (%)

MXR
Mixing ratio (g/kg)

THETA
Potential temperature (deg K)

THETAE
Equivalent potential temperature (theta-e) (deg K)

WINDCHILL
Wind chill

HEATINDEX
Heat index

SLP
Sea level pressure (mb) (plots tens, units, and 
tenths)

ALSTG
Altimeter setting (in Hg) (plots units, tenths, and 
hundredths)

WX
Pictogram of current weather type

VIS
Prevailing visibility (sm or m)

ELEV
Elevation (ft or m)

CIG
Ceiling (lowest layer more than half of sky) (hun-
dreds of feet)

OKTAS
Cloud cover in oktas (eighths)

ID (added March 2019)
The software automatically chooses either an 
ICAO or WMO identifier based on the type of data 
(METAR, SYNOP, etc) being used to draw the plot.

ID(ICAO)
Station identifier (4-letter ICAO)

ID(WMO)
Station identifier (5-digit WMO)

PCP01/PCP06/PCP12/PCP18/PCP24
Precipitation during past 1/6/12/18/24 hours.

PTEND
Pictogram of pressure tendency during past 3 
hours

CLD/L
Pictogram of low cloud type

CLD/M
Pictogram of middle cloud type

CLD/H
Pictogram of high cloud type

CLDHGT
Cloud height code (synoptic only) (see chart be-
low)

CLDAMT
Cloud amount code (synoptic only) (see chart 
below)

SHIPDIR
Pictogram of direction of ship movement

SHIPSPD
Speed of ship movement (kt)

SEATEMP
Sea-surface temperature (C or F)

TEMPTYPE
Type of temperature measurement device

WAVEPD
Period of ocean waves (sec)

WAVEHGT
Height of ocean waves (ft or m)

APPENDIX N — Station plot fields
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SEAINSTHGT
Instrument-measured height of ocean waves (ft 
or m)

WINDPD
Ocean wind wave period (sec)

WINDHGT
Ocean wind wave height (ft or m)

SWELL1DIR
Direction of primary ocean swells (deg)

SWELL2DIR
Direction of secondary ocean swells (deg)

SWELL1PD
Primary ocean swell period (sec)

SWELL1HGT
Primary ocean swell height (ft or m)

SWELL2PD
Secondary ocean swell period (sec)

SWELL2HGT
Secondary ocean swell height (ft or m)

MINTEMP
Minimum temperature (C or F)

MAXTEMP
Maximum temperature (C or F)

GRNDSTATE
Ground state code (see below)

Ground state codes
0 Surface of ground dry (without cracks and no 
appreciable amount of dust or loose sand)
1 Surface of ground moist
2 Surface of ground wet
3 Flooded
4 Surface of ground frozen
5 Glaze on ground
6 Loose dry dust or sand not covering ground 
completely
7 Thin cover of loose dry dust or sand covering 
ground completely
8 Moderate or thick cover of loose dry dust or 
sand covering ground completely
9 Extremely dry with cracks
10 Ground predominantly covered by ice
11 Compact or wet snow (with or without ice) 
covering less than half of ground
12 Compact or wet snow (with or without ice) 
covering half to less than entire ground
13 Even layer of compact or wet snow covering 
ground completely
14 Uneven layer of compact or wet snow cover-

ing ground completely
15 Loose dry snow covering less than half of 
ground
16 Loose dry snow covering at least half of 
ground but ground not completely covered
17 Even layer of loose dry snow covering ground 
completely
18 Uneven layer of loose dry snow covering 
ground completely
19 Snow covering ground completely; deep drifts

Synoptic cloud amount codes 
(CLDAMT) (Nh)
This category is defined as Nh; the amount of all 
the low cloud present, or, if no low cloud is pres-
ent, the amount of all the middle clouds pres-
ent.  The figure is always in oktas (eighths).  9 
is reserved for sky obscured by fog and/or other 
meteorological phenomena, and / is reserved for 
cloud cover being indiscernable for reasons other 
than fog or other meteorological phenomena, or 
observation is not made

Synoptic cloud height codes 
(CLDHGT) (h)
“h” is reserved for the height of the surface of 
the base of the lowest cloud seen.  If the total 
sky cover is greater than 4/8ths, this figure is 
also transposed into the CIG slot, where they are 
plotted as “L” (.low cloud.) followed by a loose 
translation of the table below in hundreds of feet.  
This “L” differentiates it from true ceilings where 
“C”, “E”, or “M” is prefixed.

Code  Meaning
0    0 to 50 m
1    50 to 100 m
2    100 to 200 m
3    200 to 300 m
4    300 to 600 m
5    600 to 1000 m
6    1000 to 1500 m
7    1500 to 2000 m
8    2000 to 2500 m
9    2500 m or more, or no clouds
/    Height of base of cloud not known, or base of 
clouds at a level lower and tops at a level higher 
than that of the station
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APPENDIX O — Multilanguage support

Support for output of the chart legends in another 
language can be obtained by editing the language.
txt file in the Digital Atmosphere directory.  Simply 
create a new section header at the end of the file 
like:

[DANSK]

Then set the language by editing the Language= 
line at the top:

Language=DANSK

This tells Digital Atmosphere to only read sections 
following a [DANSK] block and ignore the rest of 
the file.  You can have as many different sections 
and section headers as you like in the file.

To add the foreign language entries, copy all of the 
information in the English section and paste it be-
low the new language header, then in the “Display 
as” column write the items as you wish them to be 
displayed.  It is not necessary to edit items under 
“Name (not used in Dig Atm)” but you may edit the 
entries to make the file more readable for you.

If you do not intend to use Digital Atmosphere in 
English you may simply overwrite the English sec-
tion with your own entries.

Note that there is no support for Unicode at this 
time (thus Cyrillic and other fonts cannot be plot-
ted due to Unicode deficiencies in the compiler).

To change the language of the analysis options un-
der “Analysis” you may edit the digatmos.mnu file 
directly.  There is currently no support for display-
ing the main menu in other languages.
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Listed here are some examples of what kinds of data will be imported by Digital Atmosphere, depending 
on your checkmarks on the status panel. You can refer to these examples if you have any trouble getting 
Digital Atmosphere to read something or are unsure of what a particular product or bulletin should look 
like.

METAR data
This is the backbone of weather observation code worldwide. It is issued hourly from thousands of weath-
er stations. A sample report will look like this:

KDFW 012353Z 17006KT 10SM FEW045 SCT070 SCT250 28/19 A3006 RMK AO2 SLP170 T02780194 
10300 20272 55005=

 
Airways (SAO) data
This code was used prior to 1996 and formed the backbone of weather observation code in the United 
States and Canada.  Support is still provided in Digital Atmosphere for backward compatibility. The data 
looks like this:

JFK SA 1150 250 SCT 7 113/44/21/2513/989=

SYNOP data
This format is used worldwide for surface and oceanic observations.  Data appears as follows:

AAXX 02184
72376 32966 62806 10222 20117 38330 40163 58003 91753 333 10222 20144 555 90218=

 
SD RAREP radar reports
Also called hourly radar reports, RAREPS, and SD reports. Early versions of Digital Atmosphere do not im-
port this type of data. Radar reports come from about 100 stations around the country. A few years ago, 
they were typed up by humans, but most of them are now centrally generated by computer based on data 
from NEXRAD radar sites around the country. This is what a radar report looks like:

MCI 0225 CELLS TRW/NEW 250/195 D10 C2330 MT 300
^OI22

 
FD winds aloft data
This is not an analysis of real conditions; rather it is numerical output from the National Centers for 
Environmental Prediction (formerly NMC) in Washington, DC. It is used primarily for aviation forecasting 
purposes, consisting of a coded wind and temperature forecast at 12 and 24 hours into the future. Never-
theless, it makes excellent forecasting charts in Digital Atmosphere.

For Hours
ID Use Z From Now 3000 6000 9000 12000 18000 24000
2XG 09-18 00-09 3613 2911+06 2520+02 2430-03 2342-15 2462-26

Rawinsonde data
Also called TEMP or TTAA data. This is the backbone of upper-air observation reports, sent twice daily from 
hundreds of stations worldwide (several dozen in the United States alone). It is a highly numerical, coded 
set of data that is used extensively in meteorological operations and is used as input into the numerical 
forecast models. Here’s an example of what it looks like:

APPENDIX P — Raw data samples
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72558 TTAA 69121 72558 99973 00821 30002 00130 ///// /////

92762 01611 03014 85444 01850 00521 70993 04159 30025 50559 etc..
 

Weather watches
Also called SPC watches, SELS watches, watch boxes, or even WWUS9 KMKC. This is an English bul-
letin produced by forecasters at the Storm Prediction Center (formerly NSSFC, the National Severe 
Storms Forecast Center).

WWUS9 KMKC 141239
SEL7
MKC WW 141239
KSZ000-142000-

BULLETIN - IMMEDIATE BROADCAST REQUESTED
SEVERE THUNDERSTORM WATCH NUMBER 77
NATIONAL WEATHER SERVICE KANSAS CITY MO
639 AM CST THU MAR 14 1996

.A..THE STORM PREDICTION CENTER HAS ISSUED A SEVERE THUNDERSTORM WATCH FOR
PARTS OF EAST-CENTRAL AND SOUTHEASTERN KANSAS
EFFECTIVE THIS THURSDAY MORNING AND AFTERNOON UNTIL 200 PM CST.
LARGE HAIL...DANGEROUS LIGHTNING AND DAMAGING THUNDERSTORM WINDS
ARE POSSIBLE IN THESE AREAS.
THE SEVERE THUNDERSTORM WATCH AREA IS ALONG AND 45 STATUTE MILES
NORTH AND SOUTH OF A LINE FROM 45 MILES WEST OF EMPORIA KANSAS TO
45 MILES EAST OF CHANUTE KANSAS.

Convective outlook
The convective outlook is a bulletin produced by forecasters at the Storm Prediction Center (formerly 
NSSFC, the National Severe Storms Forecast Center), and intended for use by other National Weather 
Service meteorologists. Two are produced; one for the “today” time frame (Day 1), and another for 
the “tomorrow” time frame (Day 2). It is one of the best sources of forecast information on the poten-
tial for severe thunderstorms.

ACUS1 KMKC 141441
SWODY1
MKC AC 141441

CONVECTIVE OUTLOOK...REF AFOS NMCGPH94O.
VALID 141500Z - 151200Z

REF WW NUMBER 0077...VALID TIL 2000Z

THERE IS A SLGT RISK OF SVR TSTMS TO THE RIGHT OF A LINE FROM PGO
OKC 30 NNE P28 35 ESE SLN OJC JEF MVN EVV BWG BNA MEM PBF PGO.
GEN TSTMS ARE FCST TO THE RIGHT OF A LINE FROM OXR FAT TPH ELY
15 NW PUC CAG LIC HLC FNB PIA FWA YNG DUJ DCA 25 W RIC RDU AND CBM
TXK FSI 60 NNE AMA RTN 10 SE ABQ 30 SSW DMN.
 

Model output data
These are numerical output bulletins from the National Center for Environmental Prediction (NCEP, for-
merly known as NMC), which describe forecast parameters at different locations around the country. 
These bulletins are available on most weather databases. For those who want the “real thing” from the 
supercomputers, full-fledged model output is in a binary format known as GRIB; these files are huge, 
hard to obtain, and are not importable into Digital Atmosphere at this time.
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652
FOUS72 KWBC 201200
OUTPUT FROM ETA 12Z JAN 20 96
TTPTTR1R2R3 VVVLI PSDDFF HHT1T3T5 TTPTTR1R2R3 VVVLI PSDDFF HHT1T3T5
SEA//928157 03005 131714 30989795 GEG//894554 03407 152312 25969490
06021947750 05304 021921 34009996 06000877354 02207 101416 29979693
12010957438 -1802 992315 30019995 12014928044 03104 021809 32999795
18006957340 01501 992612 30019995 18000957342 02502 012208 30999895
24005977941 02601 012517 28019995 24011957646 02502 022516 29999794
30010967941 01201 042819 27019894 30000957544 01001 042513 27009894
36005856037 -0202 102814 26019894 36004938141 01501 072607 27009794
42000794430 -0906 152811 25019793 42003837138 00703 123009 26009693
48000783339 -0510 182710 27009792 48000614637 00007 173109 24999491

ASUS frontal bulletin
Produced by the National Centers for Environmental Prediction.

515
ASUS1 KWBC 111919
CODSUS
VALID 111118Z
HIGHS 1030 41165 1030 38154 1027 45135 1025 31138 1035 6143 1022 3730
1033
5589 1030 6286
LOWS 979 46169 1017 38139 997 4257 997 3865 980 63172 987 66144 998
75113
1005 36102 1013 35112 998 7168
OCFNT WK 46169 46170 45171
COLD WK 45171 44170 42169 40169 40169 39168
WARM WK 45171 46172 47174 46178
COLD WK 38139 36140 33144 31149 31153
STNRY WK 4418 4525 4531 4741 4748 4653 4457 4160
TROF 4257 4151 3647 3145 2845
COLD WK 3865 3763 3463 3164 2869 2673 2478 2384
COLD WK 66144 64142 62142 59142 53145 48149 45153 42156 40162
STNRY WK 55116 59117 62121 65129 67138 69144 69155 68167 68176
STNRY WK 6291 6395 64101 64110 63117
OCFNT WK 76114 77111 78104 7895 7786 7680
COLD WK 36102 34103 32104 31106
TROF 36101 35101 32100 30101 28102 26102
COLD WK 7680 7574 7168 6866 6565 6365 5969 5672
STNRY WK 37103 38104 40106 40109 41111 43114 44117
WARM WK 38101 3999 3897 3795 3791
TROF 48112 51112 55112
TROF 5294 5095 4896 4498 4199
TROF 5571 5270 4968 4767
NNNN

Hurricane bulletin
Produced by the National Hurricane Center.

WTNT22 KNHC 060837
TCMAT2
TROPICAL DEPRESSION LARRY FORECAST/ADVISORY NUMBER  19
NWS TPC/NATIONAL HURRICANE CENTER MIAMI FL   AL172003
0900Z MON OCT 06 2003
TROPICAL DEPRESSION CENTER LOCATED NEAR 17.3N  94.0W AT 06/0900Z
POSITION ACCURATE WITHIN  50 NM
PRESENT MOVEMENT TOWARD THE SOUTH-SOUTHWEST OR 200 DEGREES AT   3 KT
ESTIMATED MINIMUM CENTRAL PRESSURE 1005 MB
MAX SUSTAINED WINDS  20 KT WITH GUSTS TO  25 KT...DISSIPATING
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12 FT SEAS..  0NE   0SE   0SW 100NW.
WINDS AND SEAS VARY GREATLY IN EACH QUADRANT.  RADII IN NAUTICAL
MILES ARE THE LARGEST RADII EXPECTED ANYWHERE IN THAT QUADRANT.
REPEAT...CENTER LOCATED NEAR 17.3N  94.0W AT 06/0900Z
AT 06/0600Z CENTER WAS LOCATED NEAR 17.5N  93.9W
FORECAST VALID 06/1800Z 16.9N  94.1W...INLAND...DISSIPATING
MAX WIND  20 KT...GUSTS  25 KT.
FORECAST VALID 07/0600Z...DISSIPATED
REQUEST FOR 3 HOURLY SHIP REPORTS WITHIN 300 MILES OF 17.3N  94.0W
THIS IS THE LAST FORECAST/ADVISORY ISSUED BY THE
NATIONAL HURRICANE CENTER ON LARRY UNLESS REGENERATION OCCURS.
FORECASTER PASCH
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* IMPORT: Added support for retrieving basic WT-Meso 
data from NWSTG Lubbock bulletins, since the WT-Meso 
data has been pulled from public access and made pro-
prietary. (5/20/21)
* MAPPING:: Fixed planetary map problem along 180 
meridian (checking for -9999 null values, not just 9999).
20201030: Fixed station plots to make sure plots adhere 
to the specified time range; some plots had been slipping 
through due to changes in station plot display prioritiza-
tion. (12/11/20)

DA5 2021 V3.34
Unreleased pending more work - April 2022
* Updated version from 2021 V3.33 to 2022 V3.34 in 
combination with fix for sounding File Not Found er-
ror.  The sounding module was still accessing location-
identifier-list.csv.  This V3.34 was released to the user 
requesting a fix but I was not able to complete posting 
the update publicly. (4/4/22)

DA5 2021 V3.33
GRIB and Fleetcode improvements
Released 2021-07?
* GRIB: Added more GRIB products, and updated the 
links to reflect changes to the GFS data that caused data 
to not be found.
* GRIB: Changed behavior of GRIB form to not reset the 
form.  This allows user to more easily modify successive 
GRIB downloads.
* GRIB: Added GRIBGRID display command so users can 
see the extent of the available data.
* GRIB: Sea level pressure command corrected to 
SDVC=0:100 instead of SDVC=1:100, which caused it to 
pass the wrong field to the mathematical calculations and 
not plot.
* GRIB: Added thickness product from CMC GEM and a 
thickness display command in the DIGATMOS.GRF file.
* FLEETCODE: Added antialiased lines to Fleetcode iso-
pleth plotting.  These do not draw entirely correctly as 
the spline segments have to be generated in small steps, 
but it does improve the look slightly.
* PLOTTING OF TEMPERATURE EXTREMES ADDED: Lo-
cated under Data > WPC Temperature Records.

DA5 2021 V3.32 - “Fleetcode Update”
Released 2021-04-19
* IAC/FLEET PLOTTING: Barb/pip fronts have been re-
stored based on testing.
* IAC/FLEET PLOTTING: User is now provided the choice 
of either barb/pip or non-barb/pip in the Data > Fleet-
code menu option.  The latter should be selected if the 
fronts are believed to not be pointing the right direc-
tion.  The WMO code format does not explicitly provide 
for frontal direction, so this uses the left/right hand rules 
(relative to the line) that ASXX21 EGRR seems to be fol-
lowing.
* IAC/FLEET PLOTTING: Problems with spurious and bro-
ken fronts and isopleths have been resolved.  It occurred 
when nonstandard line spacings existed in the source 
Fleetcode bulletin, causing the cleaned-up bulletin to get 
rebuilt incorrectly.  The ingest now ignores null lines.
* IAC/FLEET PLOTTING: Non-barbed stationary front 
type used in IAC/FLEET plots changed to a more frequent 
spacing so as to reduce visual confusion with cold and 

Provided here is the best available listing of versions, in 
reverse chronological order.

In all changes, DIGATMOS.VER will be modified to bring 
the version up to date where the user’s version can be 
compared with the latest release of DIGATMOS.VER 
online.

DA5 2023 V3.50a
Released 2023-06-06
* IMPORTED DATA: Double instances of existing observa-
tional data are eliminated during data import.
* Encapsulates all unreleased changes below.

DA5 2023 V3.50
Completed 2023-01-23 (special addition request)
* PLOTTING/ANALYSIS: Tendency for 1, 3, 6, and 12 
hours is available if a surface dataset for two different 
times is imported.  See below for specifics.
* PLOTTING/ANALYSIS: Surface pressure change added 
(increase blue, decrease red; time intervals of 1hr, 3hr, 
6hr & 12hr)
* PLOTTING/ANALYSIS: Surface dewpoint change added 
(increase green, decrease brown; time intervals of 1hr, 
3hr, 6hr & 12hr)
* PLOTTING/ANALYSIS: Surface temperature change 
added (increase red, decrease blue; intervals of 1hr, 3hr, 
6hr & 12hr)
* PLOTTING/ANALYSIS: Dewpoint depression analysis for 
surface, 850, 700 and 500mb (5 to 0 only, green in color)
* PLOTTING/ANALYSIS: Height change  850, 700 and 
500mb (decrease red, increase blue; intervals 12 and 
24hr)
* Other files changed are DIGATMOS.MNU (to add in 
delta analysis options) and LANGUAGE.TXT (new chart 
names)
* The default OUTPUT.S00 etc files have been restructed 
and older versions are not compatible.

DA5 2022 V3.41
Unreleased pending more work - 2023-01-07
Work was frozen at this point as V3.41, there are no 
changes from V3.40 to V3.41.

DA5 2022 V3.40
Unreleased pending more work - Summer 2022
* RADAR: Adjusted radar sources. (7/20/22)
* ANALYSIS: Added in an experimental module to plot 
maximum temperatures (Data > Max/Min temperatures 
in set).  This does not use the coded max/min tempera-
ture data but is determined by parsing all observations, 
and requires all available data to be ingested for all 
times. (7/20/22)
* SCRIPTING: Projection parameter must be specified 
at the beginning of MAKE command.  Previous scripts 
which use the MAKE command can be changed simply by 
changing instances of “MAKE,” to “MAKE,1,”. (4/20/22)
* MAPPING: Added new options for plotting County 
Names, added overlay radar polygons, fixed digatmos.cxt 
to correct misplaced county labels and eliminate low level 
Virginia county names. (4/19/22)
* ANALYSIS: Fixed problem SDVC in digatmos.grf which 
was pulling in data from field 0 instead of 1 in SDVC. 
(7/9/21)

APPENDIX Q — Version change summaries
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warm fronts.
* IAC/FLEET PLOTTING: Troughs and waves in IAC/
FLEET now use a more fine-grained dash line so as to 
stand out from isobars.
* IAC/FLEET PLOTTING: Isobar labels have been 
shifted upward 7 pixels so as to not be obscured by the 
line.

DA5 2021 V3.31
Released 2021-04-13
* Baseline release for spring 2021 for new round of 
maintenance.  Foremost issue is fixing reports of FLEET 
code diagnostic plot issues.  If there are bugs at this 
point with FLEET we will issue V3.31a, V3.31b, etc.
* Distributables now released as ZIPs due to reports of 
Microsoft Edge generating false security notifications 
when EXE is run from the browser (likely this is Micro-
soft trying to strongarm developers into buying code 
signing certifications).

DA5 2020 V3.30
Released 2020-08-14 (unreleased dev version 
started as V3.21/V3.22a beginning 2019-11)
* Sporadic download problems are known to exist since 
V3.20.  This manifests itself as downloads “skipping” 
about 1 to 5% of the time (surface data, SPC data, 
etc) producing an empty download file. V3.30 uses 
the same download code base as V3.20 and I actually 
reverted some unreleased inhouse changes back to a 
2/27/19 code set.  I will be subcontracting this out for 
the next version so it’s finally fixed. Feedback from our 
users about this issue, negative or positive, is request-
ed; email tim.vasquez@weathergraphics.com.  It would 
be helpful to know how often you see this program, 
along with your Windows version, Dig Atm version (to 
confirm which one), and any other details. (2020-08-
14)
* Included a starter planetary map in the AppData \
planetary subdirectory. (2020-08)
* Identifiers have been brought current through July 
2020 (August 2020 for FAA identifiers). (2020-08)
* File >Station Tables > Import MLID has been adjust-
ed to support the adjusted MLID table format beginning 
August 2019, while providing backward compatability 
with the old MLID structure.  The code now uses the 
header rows to identify the correct columns. (2020-08)
* Exported station listings are now provided with the 
installer, located in the Application Data directory (see 
Help > About) under station-list-icao.txt and station-
list-wmo.txt.  These will confirm whether a station is 
included.  They are automatically regenerated if a new 
MLID file is imported. (2020-08)
* Installer is packaged with a default US topographic 
map produced by the planetary map set. (2020-08-14)
* Default first-run app width has been widened. (2020-
08-14)
* Pro vs. Pro Patch builds have been eliminated.  De-
fense Mapping Agency map tiles have been pushed out 
to a separate optional map add-on, and this will shrink 
the Professional builds to the same size as Standard 
builds and the installer script. (2020-08)
* Plotting of SPC Storm Reports (live from SPC) is 
available.  This is accomplished in Data > SPC Storm 
Reports.  The archive goes back to June 1, 1999 and 
covers everything up to today’s date, often with live 
data. (2020-08)
* GRIB2 support has been added.  This is a preliminary 
capability that will be improved once I evaluate it and 
decide further how to implement it.  This was done 

by removing the old GRIB1 code base and interface, 
and added a File > Import GRIB Data panel which 
encapsulates all GRIB display.  Automated scripting of 
GRIB data is not yet available, and it will be some time 
before it can be developed. (2020-06-24)
* Removed code that sets window state on startup 
(maximized, normal) as this was causing errors on 
startup. (2020-06-24)
* Startup forces the number of charts on startup to at 
least 1 (cc=0 in temp.idx), as problems are sometimes 
introduced by a corrupted window state and saved to 
temp.idx as cc=-1. (2020-06-24)
* Analysis menu paints with correct styling now. 
(2020-05)
* Fixed the DIGATMOS.RUL file so that the DELETE 
action does not have to be spelled specifically as DEL, 
now DELETE will also work. This amibiguity caused 
some problems where users previously added a station 
to be flagged and nothing happened. (2020-05)
* Added extended frontal analysis support (2020-03-
31)
* New frontal support requires STY files must now 
contain an ‘ams’ ‘bnd’ and ‘dry’ entry for air mass, 
boundaries, and drylines, respectively, to work prop-
erly.  These have been updated in all internal and 
distribution versions, with distribution versions set to 
use standard Verdana fonts.  By accepting the new 
style files with the installer, users will receive the new 
changes.  Users who continue to use older style files 
without adding these lines may receive minor errors or 
unusually formatted text when attempting to plot air 
mass markings, drylines, or boundaries.  Users who 
wish to manually edit their existing files can copy/paste 
the default lines below. (2020-05)
ams  Air mass markings          064-064-064                36 Verdana 

dry  Drylines                   136-045-023  3 

bnd  Boundaries                 000-000-000  3

* Working to fix graticule for hurricane chart and adapt 
anti-aliasing for graticule.
* Updating Climatology > Hurricane plots and adding 
frequency.  Will need to switch out old hurricane files 
for new ones.
* User may specify the data directory in Preferences > 
General.  This is now stored in the registry and is no 
longer hardcoded as WorkingDirectory+’data\’.  Any 
bugs related to missing data during data import may 
be associated with this change.
* Removed new bug caused by changes in previous 
version in which ship synoptic winds were always as-
sumed to be in m/s.
* Wind barb plotting adjusted to vary line width ac-
cording to station model scale.

DA5 2019 V3.20
Released 2019-03-07
* Emergency support to add handling for https URLs 
(TLS/SSL) downloading, which allows radar and certain 
surface data to be downloaded once again.
* Prioritized station display has been moved from 
digatmos.pri into the Station Rules (see below).  The 
digatmos.pri file is now obsolete.
* Added the station plot element “ID”, which is differ-
ent from ID(ICAO) and ID(WMO) in that either an ICAO 
or WMO is automatically selected based on the type of 
data used for the station plot.
* Adds analysis commands CTOF, FTOC, KTOF, KTOC, 
CTOK, and FTOK for conversions between Celsius, 
Fahrenheit, and Kelvin.  The DEGF and DEGC com-
mands are retained but are superseded by CTOF and 
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FTOC respectively.
* Added analysis menu option for potential temperature 
analysis in Fahrenheit.
* Fix Import Directory / update manual <---- appears to 
work as designed
* Help button removed from View Raw Data dialog since 
documentation is now in PDF form.
* Added user interface for Station Rules under Data > 
Edit Station Rules.  Added information in user manual.
* Added analysis support for new wind chill formula, old 
formula, and Canadian formula, and also the Australian 
apparent temperature.  The new analysis menu scripting 
commands are WCHL, WCHO, WCHC, and HAAT, respec-
tively.
* Handling of buoy handling improved, better integration 
with SYNOP data.  In order to do this, the QUEUE.SYN 
and OUTPUT.SYN data structures had to be changed.  All 
WMO numbers as viewed in QC are now prefixed with 
“W-”, all ship synoptic with “S-”, and buoy data with “B-”.  
Unnamed buoys are assigned a temporary numerical sta-
tion name based on their coordinates.
* The DIGATMOS.RUL file has been adjusted to allow the 
new prefixed SYNOP/SHIP/BUOY station names, which 
are longer.  Numerical stations are always assumed to 
be WMO stations; ship and buoy stations must use the 
prefixes above.  Columns are no longer locked to fixed 
positions and are purely space-delimited now.
* Removed two bad buoy stations in the Barrow, Alaska 
area by editing the DIGATMOS.RUL file.
* Updated identifier database to 2/10/2019 (WMO, ICAO, 
and FAA)
* Fixed missing hint text for speed buttons (appears 
when user hovers over them with mouse).
* SFUK30 and SFUK31 lightning data source was re-
moved from Data > Retrieve Data.  This Met Office sys-
tem was terminated in 2008.
* Fixed station tables to correct Canadian stations 71641 
and 71098 (changed within Environment Canada but not 
published with WMO).
* Added MADIS mirror source to Data > Retrieve Data 
panel.
* Adds line breaks in Software Update message to make 
dialog more readable; allows line breaks to be added to 
update message.
* Added DENSITY scripting command.  This controls the 
Data Plot Crowding slider bar. Usage is DENSITY,position 
where position equals 0, all the way left (sparse) to 100, 
all the way right (plot all data).
* Plaintext MADIS processing has been optimized to work 
faster. [Using arrays based on station ID’s first letter].
* Antarctic data: Legacy support for SSEC Antarctic 
data in DIGATMOS.URX has been deleted since the URL 
(http://amrc.ssec.wisc.edu/~amrc/9018.txt) is gone and 
the file-by-file loop is no longer required.  The data ap-
pears to be mirrored at ftp://amrc.ssec.wisc.edu/archive/
YYYY/MMDD/AWS.Wallops.YYYY.MM.DD.HZ.txt however 
this is a new non-standard table, and an ingest algorithm 
needs to be written.
* Antarctica data import support is removed since the file 
structure (from the late 1990s) and data is gone.

DA5 2019 V3.10a
Released 2019-02-01
* Contour > Wind > Streamline: Removed temporary 
block on code that was accidentally left in place.
* General debugging: Added code to prevent infinite loop 
(program hang) while drawing antialiased lines.
* Registry: Adjusted code to cease using registry key Di-
gAtmEquinox for miscellaneous data; uses main registry 

path now.
* Station Identifiers: Edited code to provide proper pro-
cessing of ICAO identifiers with a number in the second 
position (K1A5, etc).
* Historical Data: Modified File > Historical Data to use 
install location supplied by the new Historical Archives in-
staller, and gives user a method of manually selecting the 
dataset location (which can now be installed anywhere).
* Historical Data: Added code to plot Historical Data date 
on bottom right of workchart.
* Station plots: Sky condition of -9999 (missing) is now 
plotted with crosshair symbol.

DA5 2019 V3.10
Released 2019-01-30 or later
* Updated data sources (digatmos.urx) to remove old 
sources and add WeatherGraphics data server.
* Updated station plot wind barbs to use antialiased lines. 
The station circle has not been changed yet.
* Added code to prevent infinite loop (program hang) 
while drawing antialiased lines.
* More debugging work and bug fixes forthcoming in 
February.

DA5 2018 V3.09
Released 2018-10-08 or later
* Anti-aliased isoplething added throughout the analysis 
module.
* Set variable (non-integer) analysis contour widths; 
changed SLP contours to 1.5px wide.
* Added 8100px planetary map to /planetary directory; 
set default topographic directory to planetary directory.
* Enabled Data > Set Comment; documented in manual.
* Enabled launching of User Manual in Help > About.  
Deprecated the CHM help and removed it from the in-
staller.
* Rearranged some menu items.
* Extensive changes to the User Manual.  Developed a 
couple of new sections including the planetary map sec-
tion.
* On 1/27/2019 generated a STD build and put it in /
www/wg/dl.  PRO existed already.

2018 v3.08a
Released 2018-09-20
* Isolated and fixed a longtime bug in which a few 
stations were omitted during data import due to array 
bounding problems. Also fixed station indexes to separate 
out numbers (A..Z,#) to (0..9,A..Z). Added diagnostic 
dump function to check station table contents. Changed 
relevant parts of import1 and stntable units.
* Fixed bug in buoy import code to ingest all of the data 
portions
* Added bad buoy stations to DIGATMOS.RUL so SLPs 
don’t get plotted
* Increased Surface Radius in Preferences > Analysis 
from 100 to 2000 nm so that Barnes and Cressman work 
better in oceanic analyses (should be increased signifi-
cantly when data sparse areas are in the analysis; in-
crease Reduction to provide fine-scale data at same time 
if there are also stations close to each other)
* Added Auto Station Radius setting to Preferences > 
Analysis to support automatic handling of Weighted, 
Barnes, and Cressman at different zoom scales. If 
checked, the station radius will be treated as 20% of 
the mean window size, but actual station spacing may 
vary depending on the number of observations that were 
imported.
* Added a Station Radius Bias slider in the right lower 
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side of the Analysis Preferences panel which lets the 
user adjust the Auto Station Radius by this percentage 
for all future calculations.  Station radius is the radius 
around a gridpoint in which observations are accepted 
for that location; it may be subject to weighting and 
reduction (in which successive passes are made at pro-
gressively smaller radii down to zero).  Setting it too 
high will produce sensitivity to high wavelengths with 
overly smoothed fields; setting it too low will produce 
sensitivity to low wavelengths with noisy fields.
* Added Copy To Clipboard to Troubleshoot Data; al-
lowed Ctrl+A selection.

2018 v3.08
Released 2018-08-15
* Full update of station tables, including many changes 
in Canada
* Eliminated a few random analysis

RELATED CHANGES: Master Location Index had bad 
station locations (updated MLID 3.1.1c to 3.2.0)

    METAR stations:
    CYBC CYCC CYCG CYDC CYEL CYHD CYKJ
    CYNE CYPQ CYPW CYPY CYQL CYXH CYYH
    CYZR DAFI DATG EFPN EFRV EKVB LEMU
    LOKN LTAE LZKC MHSC MMTC MMTX MUBS
    MUSL OIBH PAFS RJNO SCNY SCPF SCQE
    SCRL SHCY VDKH VEJT VTUP VYNT YCDR
    YPLC YSTW ZPLJ

    Check SYNOP stations:
    71081 71908 72469 72501 72558 72649
    74389 74560 (thanks to rschmidt)

    Fixed SYNOP locations at:
    02949 06654 11184 17120 29771 33946
    47739 48357 48969 59431 61697 62018
    68541 71001 71023 71033 71036 71038
    71056 71072 71085 71136 71141 71142
    71151 71167 71174 71187 71196 71208
    71220 71247 71250 71267 71268 71272
    71290 71292 71293 71304 71366 71369
    71398 71410 71436 71488 71499 71513
    71527 71559 71582 71584 71587 71608
    71610 71613 71618 71629 71632 71634
    71649 71675 71681 71684 71685 71686
    71689 71691 71693 71718 71736 71802
    71843 71874 71884 71886 71888 71903
    71905 71920 71921 71933 71941 71947
    71956 72506 72607 74484 74646 74735
    76640 78312 85766 85864 94674 94762
    94864 97072 97120 97796

    WMO Pub 9 listings are erroneous for
    these stations and are not acceptable:
    34434 42423 60535 60621 62002 62007
    72257 74724

    WMO Pub 9 listing is doubtful:
    58660

    WMO Pub 9 has inverted longitude sign and
    is not acceptable:
    04017 65536

VERSION 2018 v3.07 (INTERNAL)
6/26/2018

* Added Auto Aspect settings to Map > Generate Map 
> Height to size the aspect ratio for various paper 
sizes.

VERSION 2018 v3.06a
6/25/2018
* Three text lines were set to visible = false; fixed this

VERSION 2018 v3.06
6/24/2018
* Developed import routine for Digital Atmosphere 
Historical Data
* Added thorough debugging information to About form
* Removed time debugging from Preferences > Misc 1 
and moved to About form
* Quality Control window has been resized to handle 
Aero controls without producing scrollbars.
TO DO -- Add checks to the time legend stamp, remove 
c:\sfc-packed directory and store data

VERSION 2018 v3.05 (INTERNAL)
5-19-2018
* Increased line length limit of graphics commands 
(digatmos.mnu) from 255 to 9999 characters
  - This will eliminate unpredictable results with com-
plex commands that are cut off.
* Added anti-aliasing for Analysis isopleth lines equal-
ling a width of 1.
* Added starter scripts to provide shading for moisture 
(need to buffer analysis grids to help them run faster).

VERSION 2018 v3.04 (INTERNAL)
3-16-2018
* Removed diagnostic grid from cross section analysis

VERSION 2018 v3.03 (INTERNAL)
3-01-2018
* Fixed default map not plotting elements in correct 
location.
* Toolbox color scheme adjusted from purples to blues.

VERSION 2018 v3.02 (INTERNAL)
2-14-2018
* A few minor corrections before Denver conference 
release

VERSION 2018 v3.01
Early February 2018
* Reworked cross-section analysis.  Added RH, lapse 
rate, in-plane winds, etc.

VERSION 2018 v3.00
January 2018
* Establishes update of Digital Atmosphere
* Fixes WSR-88D NEXRAD code changes

VERSION 2017 3.0
Main release of versions below.
- Testing in Windows 10.
- Preferences form is slightly larger to accommodate 
Windows 10 controls.

VERSION 2017 2.30a/b/c/d/e
Build tests

VERSION 2017 2.30
(Coding start date 6/1/2015 - Release date 9/20/2017)
Continued update/revision work of revisions that 
started with V2.11.  It was decided with this update to 



DIGITAL ATMOSPHERE MANUAL / January 2023  |  139

get rid of the TMS menu framework, but after seeing it 
did not detract from menu appearance in Windows 8 it 
was decided to leave it alone.
  - The Level III radar module with dual-polarization 
products has been completed and updated through Build 
17 (added 8-Sep-17)
- Extensive work on documentation
 - Added colon to next NMC character position (font.012)
- Extensive GUI control panel work to slim it and improve 
appearance.
- Added hovering hints to speed bar.
- BELOW are changes before December 2016.
- Updated data sources, removed old ones (Albany, FSU), 
changed URLs (NWS, Texas Tech).  These changes are 
also reflected in the DIGATMOS.URX file so older versions 
can use this.
- Data > Data Retrieval dialog delete function fixed (was 
inoperative)
- Data > Data Retrieval window optimized so that cursor 
returns to active row upon a deletion or edit.
- Extensive development of the PDF manual.
- Geography rendering (Map > Generate) is much faster.
- Radar module has been revised to provide fixes for new 
coding changes.
- Format of DIGATMOS.NXC has been changed.  DIGAT-
MOS.RAD has been updated.
- Color theme has been adjusted to a gray/silver contem-
porary look.
- Changed color scheme from blue to a more subdued 
dark gray / gray.
- Made a change to allow Analysis menu options to inherit 
the menu style.
- Paired this release with a drastic update in the program 
documentation to bring it up to date.  Focus will be on a 
PDF manual, and it will be created as a shortcut in tan-
dem with the program.
- Added support for Shapefile attribute matching; also 
removed an Application.ProcessMessages block in the 
Shapefile module that was slowing down the process 
somewhat.
- Removed support for GPS as it is based on old 9-pin 
COM port technology and most users have upgraded 
to USB devices, which are not yet supported by Digital 
Atmosphere.
- Changed Climatology menu to Tools.  Restructured 
menus to move certain data functions from the File menu 
to the Data menu, and tools from the File menu to the 
Tools menu.
- Internet data source table has been updated to change 
frontal bulletin source from hpc.ncep.noaa.gov to wpc.
ncep.noaa.gov.
- Added status message for Map > Copy Markings To 
Basemap.
- Changed default font set to Calibri.
- Set legend font style to bold.

VERSION 2.14
compiled 05-Jul-17 (Not released)
- MAIN CHANGES: Contains brand new updated station 
tables, a new
      radar data package,
- Interim release to fix the accidental registered version 
on the website and a lack of a Pro version for 2.12/2.13
- GPS component and menu have been removed as those 
use obsolete COM ports
- Color tables in DIGATMOS.NEX have been changed to 
the GRLevelX format to allow more standardization.  All 
types of radar products are contained in this single file.
- Printer configuration is temporarily not working

VERSION 3.00
This is the parallel Delphi 7 version (see Delphi 7 Fork below, 2013) which has not been 
released since there are dependencies in the radar module that have not been addressed.

VERSION 2.13
began 23-Feb-15
 - Fixed problem with elevation data not being extracted 
from location identifier tables (so no wet bulb / mixing 
ratio / theta E)
 - Added wet bulb to station plots.

VERSION 2.12
began 23-Dec-14 released 23-Dec-14 as public release of 
2.11
- Includes the 2.11 snow depth plot option.
- Added support for new Master Location Identifer Data-
base format
- Implemented 12/30/2014 release of MLID location 
database
MANIFEST CHANGES:
master-location-identifier-database.csv (add)

VERSION 2.11
began 23-Dec-14 released 23-Dec-14
- Begun as a continuattion of V2.09.  The Delphi 7 fork 
was dropped and the Delphi 5 code base was retained 
to avoid having to rewrite dependencies for Delphi 7 and 
prolonging the release date.
- Adds snow depth plot display option in Preferences sta-
tion plot model).

DELPHI 7 FORK - 2012-2013
Between August 2012 and June 2013 a parallel version 
(V3.00-V3.01) was developed under Delphi 7.  In 2014 
it was decided to set this aside due to problems with de-
pendencies (zlib, etc) and so the more important issues 
could be addressed.

VERSION 2.10
began 04-Dec-09
- Enhanced scripting; added DELETE script command 
for file delete; allowed use of absolute filename in script 
execution commands

VERSION 2.09
Began 12-Oct-09
Began work on DIFAX graphic engine (Weatherpipe type 
utility) for Pro version and completed most of it.
MANIFEST CHANGES
DIGATMOS.DFY (add)
DIGATMOS.DFZ (add)

VERSION 2.08 
25-Jul-09
This updates affects the Professional Edition only.
- Cross Section > Copy To Clipboard function now works.
- Added Cross Section > Save To File (allows GIF, PNG, 
JPG, and BMP).

VERSION 2.07
18-Jul-09
- Adds cross-section capability under Data > Cross 
Section (requires radiosonde data and a line segment 
dragged on the map).
- Fixes problem with Workchart levels & times not being 
remembered fully when program is started; active levels 
and time selections were displayed but were not set 
internally, thus 500 mb plots would not appear, even with 
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500 mb showing in Active Level window, unless it was 
reselected
- Preferences > Analysis > Auto smoothing setting is 
now saved across sessions
- NEW FILES: Adds the file DIGATMOS.ELX to support 
the cross section module.

VERSION 2.06
22-May-09
- Fixed issue with soundings for WMO stations 00000-
09999 (Northern Europe) not plotting in V2.04-2.05.  
This was caused by different handling of WMO identifier 
leading zeroes, which are often stripped out by spread-
sheets such as Excel when preparing station identifier 
lists.  Any further issues with Northern Europe SYNOP 
or upper air may be attributable to this issue; this is-
sue will be monitored.
- Hardened filtering of miscellaneous text in METAR 
import; this will produce fewer spurious results in the 
Station Data > Audit module.
- Further updates to station identifier list; provided up-
dated list and station package.  The identifier list now 
contains almost all ICAOs currently being transmitted.  
Work will now be done to finalize and document the 
location identifier format and fix other Dig Atm bugs 
reported. 

VERSION 2.05
20-May-09
- Adjusted Sounding window so that it is in the screen 
center.
- Fixed a problem with soundings not plotting in V2.04; 
this was due to the station table format changing and 
the sounding module being unable to validate the cho-
sen WMO code.  This has been fixed.
- Removed faulty line of code that interfered with 
scripting (Unable to Create File error) whenever a URL 
was in the script line
- Fixed handling of custom data in Analysis module; 
Barnes/Cressman/etc were using value stacks for grid 
0 instead of 1/2/3
- Adds a new menu option (DIGATMOS.MNU) for cus-
tom data, data type CUSX, which is imported from the 
existing CUSTOM.DAT file rather than from the OUT-
PUT.*** imported/formatted data.  This can be used in 
addition to CUST in script files.
- Added more stations to location-identifier-list.csv and 
recompiled tables.
- Added a datafile edit capability (File > Station tables 
> Audit) to assist users with identifying stations that 
did not import due to missing data in the location 
identifier list.  This only evaluates the data against the 
current station table ingested into Digital Atmosphere.
- Added FAA identifier tables, added DIGATMOS.SXF 
and DIGATMOS.STF to build.  This allows more ac-
curate handling of airways and 3-letter identifiers and 
separates them internally to prevent mixups.
  - Some new stations in location identifer list; will con-
tinue to add more in the days/weeks ahead.  Station 
indexes rebuilt.

VERSION 2.04
17-May-09
- Added the new LIL.CSV Location Identifier List and 
will begin phasing out the old DIGATMOS.STN file.  
Made appropriate changes in File > Station Tables 
menu to give user the option of importing the new LIL.
CSV or an older .STN table.  The LIL.CSV list is still in a 
draft form and is still in development.

VERSION 2.03
10-Apr-09  (Unreleased)
This version contains enhancements to scripting com-
mands.
  - If you use scripts that use the LOOP command, you 
*MUST* be aware of the following scripting changes 
before using script files.
 - In scripting, support has been added for a LOOP...
END block.  Previously “LOOP” would run the entire file 
as a loop.  Now all content between the LOOP com-
mand and an END command are run.  Multiple loops 
are supported, but nested loops are not supported.
- The LOOP command now requires 4-digit years.  It is 
as follows:
       LOOP,yyyy,mm,dd,hh,span,iterations
        where
          yyyy = loop start 4-digit year
          mm = loop start numerical month
          dd = loop start numerical day of month
          hh = loop start hour
          hours = span of loop from start to finish in 
hours (may exceed 24)
          interval = interval of timestep in hours (e.g. 
1=hourly, 24=daily)
- Added EXIT scripting command to exit the program.
- Scripting: User may now choose @YYX or @YYYYX 
token to choose between a 2-digit year or 4-digit year 
expression.
- Scripting lines which begin with //, #, :, or ; are 
treated as comments
- Scripting now allows comments to exist at the end of 
lines; these comments must begin with //
- Checked SOUNDING scripting command.  This is NOT 
an interactive display and only exports silently to a 
graphics file.  Users may use the SOUNDING command 
as follows:
     SOUNDING,station,filename,omitdate,omittrace
        where
          station = ICAO
          filename = fully qualified output filename, GIF, 
JPG, or PNG
          omitdate = use false to display date, true to 
omit date
          omittrace = use false to display lifted trace, true 
to omit it
  - Add DIGATMOS.TSL temporary station table to 
manifest (used by sounding routine)
  - DIGATMOS.MNU is altered to remove numerous %2 
and %3 entries that caused the “deg F” and “deg C” 
toolbar speed buttons to produce jumbled isotherm 
plots.
  - (Need to add checks to delete OUTPUT.FSL file)
  - Script file execution is adjusted so that if an excep-
tion (error) is thrown the script file will get closed prop-
erly, mitigating Error 32 (sharing violation) afterward.
  - MADIS data throws “Read Beyond End Of File” error.  
This was found to be due to a change in NOAA MADIS 
coding where an extra integer (purpose unknown) has 
been inserted after Precipitation and before Weather. 
Code has been fixed to handle this.

VERSION 2.02
2.02  16-Mar-09 -
  - Added code to prevent infinite loop during QC, Pref-
erences Form, or Calculator form display
  - Removed bug in setting height of QC form
  - Added a test to see whether a DIGATMOS.STN file 
exists in both the Program Directory and Applications 
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Data directory, which is checked on a File > Recompile 
Tables operation, and ask the user which one to import.

VERSION 2.01 
04-Mar-09
  - Added new setting in File > Preferences > Maps tab 
called “Professional map tile root location” to allow DA to 
find GNC/ONC/JNC/TPC/JOG tiles.
  - Shifted default tile map root to the Program Files 
directory hierarchy instead of the Local Application Data 
directory to allow maps to be available when overwriting 
old Digital Atmosphere Professional installations.

VERSION 2.00
 27-Feb-09
  - NAMING: Dropped the Equinox name.  The file folder 
architecture of this Digital Atmosphere series is different 
than the Equinox line. Thus we are reverting to the basic 
Digital Atmosphere nomenclature for simplicity’s sake.
  - NEW FEATURE: Program detects if the Scheduler is 
on at shutdown.  When the program is started again, the 
Scheduler resumes operation about five seconds after 
startup.
  - NEW FEATURE: Digital Atmosphere “remembers” 
across sessions the settings for the Workchart Panel for 
Active, Isentropic, Surface, Upper, and Forecast time and 
level dropdown boxes.
  - FIX: Data date/time detection changes have been 
made.  Date/time is established ONLY during file import, 
internet retrieve, or script download, as follows. If none 
of the special conditions are met then the date/time is 
presumed to be the current clock UTC time.
      -- INTERNET RETRIEVE: Obtained from the time 
tokens.
      -- FILE IMPORT: Obtained from any file imported that 
contains an
           8-digit number at the start of the filename, which 
is presumed
           to signify a yymmddhh group.
      -- SCRIPT DOWNLOAD: Obtained from any 8-digit 
number in the URL, which      is presumed to signify a 
yymmddhh group.
  - FIX: Changed digatmos.mse so that Haiti is set to 
longitude -73, not +73
  - FIX: Fixed the QC and Calculator form so that scroll 
bars (which may occur in certain Windows skins) will not 
appear.  Could not test this inhouse.
  - Only a full release is provided; no patch from previ-
ous versions is available due to the change in file folder 
architecture.

EQUINOX V1.52 BETA
26-Feb-09
  - NEW FEATURE: User-defined analysis domain size.  All 
Digital Atmosphere versions prior to this one used a fixed 
30 x 30 domain.  The user can choose a finer analysis 
resolution in File > Preferences > Analysis > Analysis Do-
main Size.  About 50 x 50 is sufficient for most purposes; 
resolutions exceeding 100 x 100 will appear “noisy” and 
may require excessive filtering.  It is not advisable to set 
the resolution finer than the resolution of the observation 
network, as this will cause mathematical noise.
  - FIX: Fixed problem with blank okta station symbol 
being plotted if sky condition was unknown (oktas=10) 
in TrueType mode... this problem goes back through all 
Equinox versions.
  - FIX: Fixed the Preferences form so that scroll bars 
(which may occur in certain Windows skins) will not ap-
pear.  Could not test this inhouse.

  - FIX: Established proper display of version number 
(V1.51 showed as V1.50)

EQUINOX V1.51 BETA 
21-Feb-09
  - Preferences will be reset.  Preferences are now being 
established in the registry HKCU\DigAtmEquinox key 
instead of HKCU\DAFusion.  This will allow Digital Atmo-
sphere to co-exist independently of older versions.  Older 
preferences will NOT be imported.
  - Changed setup program to require admin privileges, 
since correct font installation under XP/2000/Vista re-
quires power user or admin privileges.
  - Fixed extra solidus in ImportData module that may 
cause a \\data.usr not found error.
  - Fixed Mercator isoplething issues caused by unnec-
essary checks against drawing isopleths in part of the 
canvas that’s in outer space.
  - Changed the set of default data (OUTPUT. files) to 
conform to the new internal surface data class definition 
(older OUTPUT files cause a read beyond end of file error 
if not refreshed by downloading new data).

EQUINOX V1.50 BETA 
01-Feb-09
  - The scheme for folders for Digital Atmosphere has 
been changed, making it fully compatible with the 
User Account Control restrictions of Windows Vista. No 
longer is all working content placed in a single Digital 
Atmosphere directory. Instead it is placed in CSIDL_LO-
CAL_APPDATA, which under Vista is C:\[User]\UserName\
AppData\Local and in XP is C:\Documents and Settings\
[User]\Local Settings\Application Data. Users wishing to 
tinker with Digital Atmosphere files will need to look in 
this directory to make modifications. (12/18/08,2/1/09)
  - When a required file is not found (testfile unit), Digital 
Atmosphere suggests an e-mail address to report the 
problem to.  This has been updated. (2/1/09)
  - Infiletype variable in import module changed from 100 
to 255 length to handle much larger filenames. (2/1/09)
  - The setting for File > Font Mode is now remembered 
across sessions (default is TrueType fonts). (2/1/09)
  - Repaired Mercator projection to allow correct display 
across the 180 degree meridian.  This has not been fully 
tested. (2/1/09)
  - Cosmetic: changed Digital Atmosphere window title 
to use a pipe (|) instead of two dashes (--) between the 
version number and software type. (2/1/09)

VERSION Equinox 1.10a
(May 24, 2007)
    Micropatch to fix corrupted handling of downloaded ra-
dar data (data was downloaded into obs.001, obs.002 etc 
and program needed to find these in nids.001, nids.002, 
etc.
    Added description element into version change mes-
sage, so users can decide whether a download is needed 
when a notification is received.

VERSION Equinox 1.10 
(May 18, 2007)
    Numerous fixes and repairs, including fixes for han-
dling of climatological daily data from SYNOP reports.

VERSION Equinox 1.05
(January 17, 2007)
    A few new Mexican radars in the northwest provinces 
have been added to DIGATMOS.RDY.  Not all radars are 
active, as Mexico’s radar network is not reliable.
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    Internet > Retrieve shows how many items are 
selected.
    Map > Overlay > Points now uses a more capable 
file format.  See the help under Map > Add Point.  It 
allows the use of lines, attributes that can be changed, 
and shortcuts.
    Map > Overlay > Points now prompts for a filename.  
Editing is no longer done in the program as editing flow 
was unclear.
    Contour labels are now plotted at the top of closed 
contours.
    Removed digatmos.ptt from project; it is superflu-
ous.
    Adjusted digatmos.nex to put clear air mode on the 
same palette as precipitation mode to allow for a stan-
dardized mosaic.
    Entering “------” for a color in digatmos.nex keeps 
that color level from plotting.  This can be used to al-
low for a unified mosaic color scheme.
    Added code to prevent Digital Atmosphere from gen-
erating zero-value serial numbers.
    Added handling for METAR unknown precipitation 
(UP).  This will plot as two solidii (//) and will carry 
weather code 100.  I saw lots of UP reports from Texas 
during the January 15 2007 sleet event; UP is most 
likely sleet.
    Changes made to WSR-88D plotting module to allow 
various raster data (most notably Composite Reflec-
tivity) to plot correctly.  The module now determines 
polygon positioning based on the number of rows in the 
raster table as well as the resolution for the product 
as defined in digatmos.nxc. Also added progress bar 
updating on raster data.
    In Radar > (product) logic is added to detect and 
discard old radar scans so as not to mess up mosaics.  
An RPG product that is more than 15 minutes older 
than the preceding RPG products being plotted will be 
discarded and a message will appear in the status win-
dow showing it was discarded.  The weakness is if the 
plotted site is the very first to be plotted, it will be used 
since no other comparisions are available.
    A tutorial has been added for the Radar > Import 
Image menu option on how to add radars , using the 
example of Durban, South Africa.  This will be of con-
siderable interest to international users.
    Started preliminary work on importing GRIB2 data .  
This module does not work and will not plot, however 
the file will be handled with probably no errors.
    Muted menu colors slightly to reduce blue and red 
saturation.

VERSION Equinox 1.04
(January 7, 2007)
    Preferences > Annotations > “H” and “L” characters 
now plot correctly.  The software was defaulting to “H” 
and “L” rather than using the characters shown here.
    Removed possible error in installer related to “tuto-
rial” directory.  This was returning a harmless error.
    Incorrectly plotted coordinates when using older 
Digital Atmosphere charts (from early Fusion and 
before) has been fixed by adding sanity checks to the 
load function for *.dmf map data.  If the rotation value 
is out of bounds (<-360 or >360 deg), which may be 
the case in earlier versions where the rotation value 
was not specified, it will set it to zero and correct the 
source file, permanently fixing the problem for that 
map.
    Diagnosed slight positioning errors in contour labels 
and highs/lows and fixed them.

VERSION Equinox 1.03
((January 6, 2007)
    METAR visibility values are now correctly ingested.
    Fixed script LOAD command which was only loading 
in the image and not loading the background map and 
resizing the window.
    Eliminated redundant labels in the chart title stack 
to prevent multiple display of the exact same chart 
title.
    Fixed problem with GRN or TEMPO in METAR being 
interpreted as GR and PO weather types.
    Improper time token entries in Internet Retrieve 
(using one instead of two digits) will be automatically 
detected and corrected.
    View Last Radar Product fixed, so as to plot the last 
-radar- product.  A Window > Replot Last Product com-
mand has been added to replot any last product.
    Added “Window > Allow Digital Atmosphere to 
run in background” command which prevents Digital 
Atmosphere from popping up (such as during scripting 
operations) and regaining focus.  Right now this only 
suppresses the “plotting radar” message... if you see 
Digital Atmosphere pop up at other times, please send 
detailed information.
    Tutorial directory and sample.txt file added to build.

VERSION Equinox 1.02
(January 2, 2007)
    Emergency patch as Internet > Retrieve was non-
functional due to problem in URL preprocessor.

VERSION Equinox 1.01
(January 2, 2007)
    When all workcharts are closed and then new ones 
are created, there is now proper handling of the work-
chart and its background map.  The user no longer gets 
an empty frame.
    Added ability to auto-retrieve historical (past 1-2 
weeks) radar images based on date-time selection 
from Radar > Set Date-Time and presence of an archi-
val source in the digatmos.rad resource file.  If these 
are selected then choosing a radar product will cause 
historical data to be accessed via the Internet.   This is 
slightly slow because the data directory will have to be 
analyzed to find the closest matching file time.
    Password security has been introduced on script-
ing and internet resource URLs.  This allows you to 
devise your scripts so that they can be traded with-
out compromising login information, and so that they 
execute onscreen without being insecure.  They can 
be used for not only passwords, but account names, 
server names, and so forth.  Your list of sensitive data 
must be maintained in DIGATMOS.PWD.  On each line, 
write token=value where token is a name created by 
you and value is the actual value to be substituted.  
When %%token %% (your token word surrounded by 
double-percent signs) is found in a URL, it is replaced 
with the equivalent value that you defined.  Digital 
Atmosphere will display the %%token %% marker, so 
don’t name tokens with sensitive information.

VERSION Equinox 1.00
(January 1, 2007)
    Help files converted from WinHelp to CHM to ensure 
compatibility with Vista.  This removes dependencies 
on Winhlp32.exe.  (12/22/06)
    Fixed analysis labels to provide correct centering of 
individual labels and correct coloring.  (12/27/06)
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    Fixed problem with Canadian radar data import.  
Canada made some changes sometime in November 
2006.  This required some structural changes and a small 
change to the digatmos.rdy file.  Part of this was to allow 
users to explicitly define the image type, since Canada’s 
radar imagery was a GIF file but was actually a PNG ob-
ject. (12/28/06)
    Support is added for NCEP high-res front bulletins.  
These are provided at http://www.hpc.ncep.noaa.gov/
discussions/codsus_hr and described at http://www.hpc.
ncep.noaa.gov/html/read_coded_bull_hr.shtml .  With 
these new bulletins, frontal positions are located to the 
nearest tenth of a degree (6 nm resolution) rather than 
nearest whole degree (60 nm).  There is no need to use 
the older format. (12/29/06)
    Fixed Error 103 problem with GRIB import caused 
when certain data is not found in a file.  This was caused 
by incorrect file handling. (12/29/06)
    Added support for public ECMWF data by making ap-
propriate entries in digatmos.grd.  Also introduced sup-
port for scaling of units based on digatmos.grd entries.
    Enabled support for Preferences > Maps > Label Grati-
cule. (12/29/06)
    Fixed incorrect symbol type used for thunderstorms in 
METAR reports.  Digital Atmosphere was mapping TSRA, 
TSSN, TSGR, etc to the ww code 91-94 sections rather 
than 95-99.  This has been fixed.  (12/29/06)
    Added thread processing command to code just before 
FTP uploads to allow system to catch up.  This was re-
sulting in null FTP uploads. (12/29/06)
    Enabled “check for updates” module to compare pro-
gram version number with production version number on 
website and ask user once whether they want to update.  
(12/29/06)
    Added import of MADIS data direct from FSL (NOAA).  
This is included in a new Internet Retrieval resource list.
    Improved Internet Retrieval system to stream down-
loads into individual files, so binary files (like MADIS 
and future GRIB/BUFR) can be properly handled.  Files 
are captured under different names in /data and are 
processed out to the Digital Atmosphere home directory 
under obs.asc, obs.bin, and nids.bin.  The obs.*, nids.*, 
and madis.000 files are deleted before each new down-
load.  This also allows better management of content 
inside /data directory.  (12/30/06-12/31/06)
    Added pointer URL search function in Internet > 
Retrieve.  This was necessitated by the way SPC carries 
convective outlooks, and the fact that no static pages 
for this product exists.  In Internet > Retrieve, URLs 
with a space in the middle are handled as pointer URLs.  
See the Internet > Retrieve help for more information.  
(12/30/06)
    Fixed convective outlook plotting.  Changes in entire 
bulletin format prevented the plotting routine from work-
ing. (12/30/06)  

FUSION 0.6h
11-Nov-06
    Resets expiration date (60 days from first run). 

FUSION 0.6e3
05-Jul-06
    Added queue.iac and temp.iac to the build so that if no 
FLEET data has been imported, system will not cause an 
error when user displays FLEET data. 

FUSION 0.6e2
04-Jul-06
    Added PNG support (import/export)

    A METAR VRB wind (basically any wind direction that is 
assigned an internal wind direction value of -9999) is now 
omitted from plots and objective analyses.
    Additional code has been added to catch METAR lines 
which omit the wind block; up until now these have been 
discarded.

FUSION 0.6e1
03-Jul-06
*  This does the first and foremost important thing of 
resetting all 30-day expirations for the evaluation. Obvi-
ously I cannot make the release unlimited, as software 
pirates would have a field day with any unlimited version 
posted on our website. You can contact me if you’re a 
registered user and need a key.
* Also I have set up the compiler system under a new 
computer and a fresh Win 2000 OS. This release is rebuilt 
under that machine. If anything looks squirrely, let me 
know and I’ll see what happened. 
 
WORKSTATION V1.0b
(March 24 2004)
* Adds support for RVRT, AVRT, DVRG script commands. 
Fixed internal handling of fields to provide more uniform 
use of u,v,z format and prevent any surprise problems.
* Fixed gust problem in METAR import routine.
* Fixed Recompile Tables to remove something that was 
commented out, preventing digatmos.stn from being 
imported.
* Updated this help file accordingly.

WORKSTATION
(Dec 2003 - March 2004)
***** Hundreds of changes were made which are too 
numerous to list. *****

WORKSTATION 0.32alpha
(15 Nov 2003)
* Algorithm added to read the server directory when 
a front bulletin is being imported. If a server direc-
tory structure is accessed on the same path as the file 
desired, the time tokens are discarded and the last file in 
the directory list is queued for download. [This is a sig-
nificant development in the Digital Atmosphere line that 
allows DA to consistently obtain the latest frontal bulletin 
from a standard server that allows directory listings. It 
has been a much-needed capability. Digital Atmosphere 
depends on a consistent appearance of a directory listing, 
and this algorithm may not work if a server begins listing 
four-digit years in the directory listing, goes to a strange 
directory format, or the last file on the page is not the 
latest frontal bulletin. If this occurs please contact me 
with details.]
* The weather symbol fonts have been thoroughly re-
worked. Fonts have been scaled down in relative size and 
left/right bounds have been repaired on a few symbols. 
Fonts now include pressure tendency and cloud code 
symbols. This allows integration of full station plot data. 
In summary, ASCII slots 040-049 contain augmented sky 
cover symbols; 050-059 contain automated sky cover 
symbols; 060-068 contain pressure tendency; 069 the 
symbol for automated observation with no sky cover 
report; 071-079 contain low clouds; 081-089 contain 
middle clouds; and 091-099 contain high clouds; and 
100-199 contain standard WMO weather symbols. IF YOU 
INSTALL THE PATCH AND ARE STILL MISSING CLOUD 
AND PRESSURE TENDENCY SYMBOLS, PLEASE DELETE 
THE “WeatherSymbols” FONT FROM YOUR CONTROL 
PANEL > FONTS AND REINSTALL THE PATCH -- AND 
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NOTIFY ME OF THE PROBLEM. [The new fonts allows 
further improvements to plotting functionality in the 
Alpha version.]
* Digital Atmosphere plotting module has been revised 
to handle the new fonts and to add pressure tendency, 
pressure trend, and cloud symbols back into the plots. 
[This further enhances functionality in the Alpha ver-
sion.]
* A checkbox for Suspend Highs/Lows has been added 
to the “Fronts” Toolbar Control Panel as well as to 
Preferences > Analysis (which cannot be saved as 
a preference since it is for temporary use only. [Al-
lows user to defeat plotting of High/Low labels on the 
map on demand, for example, when plotting the NCEP 
Fronts bulletin together with a METAR isobar analysis -- 
this prevents a duplicate field of H and L symbols from 
appearing on the map]
* A bug has been removed where a sky cover = 10 
(automated with no sky cover result) created no sta-
tion marking (in the classic DA a crosshair was plot-
ted). This uses the new font symbol of a small circle 
with crosshair (ASCII 69). [Fixes station plots in the 
Alpha version where a station is not marked by any 
station circle or square.]
* Created a separate, independent download algo-
rithm (not tied to the main download system) to allow 
internal downloads to a site (such as of a directory 
listing) without creating a programming mess. [May 
fix problems with erratic download behavior (including 
missing datasets) when trying to download NEXRAD 
radar data.]
* Hourglass has been added during Map > Generate 
operations. [Helps give user feedback as to when the 
system is busy.]
* Spacing of elements in a station plot has been 
expanded by 10%. [Allows station plot to be slightly 
less cluttered and maximizes ability to display weather 
symbols.]
* Bug was removed where a weather condition of 1 
to 4 resulted in no weather symbol but left a blank 
area in the WX symbol area (pressing out the visibility 
value when set to “smart” and causing a value to be 
shown). 1 to 4 are now treated as no weather value. 
[Invisible “hijacking” of the weather symbol slot is now 
prevented.]
* Adds the missing USMAP.BMP file required for the 
Radar > Internet Radar Settings to show its informa-
tion. [Fixes a bug in the Alpha release where going to 
Radar > Internet Radar Settings shows sites but no 
background map.]
* A correction was made to the front import module 
to fix an infinite loop during processing of frontal data. 
Also adds code to prevent writing of spurious frontal 
data. [Fixes lockups during data import. Fixes range 
check errors during data import. Fixes stray segments 
on frontal depictions.]

WORKSTATION 0.31alpha
(15 Oct 2003)
* This version entails a vast retooling of the GRIB mod-
ule. It allows much faster, convenient access to GRIB 
datasets. As usual, GRIB data is imported through the 
File > Import GRIB module. From there, the changes 
are significant. First, a GRIB field must be chosen on 
the Grib Control panel (on the toolbox) -- see below 
for more info. All of the packaged fields are stripped 
out into individual field files (GRID.001...GRID.999 in 
the /grids subdirectory), with an index provided in /
grids/grid.idx and /grids/grid.dat. From there they may 

be accessed and viewed at any time. Since they are 
plaintext, users may adapt these field files for other 
purposes. To summarize, here are the latest changes in 
this update:
* The GRIB module has been thoroughly reworked to 
spool gridded data directly out to files in \grids subdi-
rectory. This allows the data to be instantly selected 
and plotted, without the need for re-import. Importing 
more GRIB data replaces the gridded data selections 
with new data.
* Wind direction fields are now automatically separated 
into their own special fields, providing that the correct 
U/V components can be located.
* Scheme of DIGATMOS.GRD modified so that >PARAM 
parameters can be resolved to Digital Atmosphere 
contour Styles.
* Added control panel for GRIB on Toolbox > Control. 
Allows selection of gridded data that has been previ-
ously converted through File > Import GRIB. By check-
ing either “Plot” or “Contour”, the field will be displayed 
immediately when selected. Otherwise it can be viewed 
after being selected using Plot > Custom data or Con-
tour > Custom Data.
* SPECIAL NOTE -- CONTOUR INTERVALS FOR ANALY-
SIS FIELDS, especially with GRIB data, need to be 
checked and are not complete!!! I have to resolve all 
of the measurement units between the GRIB data, the 
internal formats, and the Styles.
* SPECIAL NOTE -- Custom Data Plots and Contours no 
longer work except when GRIB data is selected. This 
will be fixed.

VERSION WORKSTATION 0.3alpha
(12 Oct 2003)
* Numerous improvements were made to the GRIB 
module (File > Import GRIB). It appears to be work-
ing now with the NCEP AWIPS Eta grid and globalmar-
inenet GRIB files. A bug was fixed in which bitmap data 
(particularly for marine grids) was ignored, resulting in 
bad plots. Fixed a corruption of wind output in which 
components rather than polar vectors were written to 
the custom data file, resulting in bad GRIB wind plots. 
Help documentation has been updated. The author 
would like inputs on how the GRIB module is working.
* Fixed Contour > Custom Data so that it works with 
GRIB and other data. This will be worked on so that it 
uses parameter intervals defined in user settings.
* Removed crowding algorithm from Data > Custom 
Data. GRIB wind plots now contain the entire grid (and 
may be illegible if the grid is dense enough). This will 
be replaced with a more flexible user-defined method.
* Got some rudimentary isopleth labels working in the 
Contour module. This will need more work to tie in bet-
ter with the Style settings.
* A Styles panel was developed and implemented to 
manage the Styles settings. Changes are reflected in 
the help documentation.
* The parameter lat/long was added to the default 
styles. A master default style (styles\master.stx) was 
added.

VERSION WORKSTATION
0.2alpha (07 Oct 2003)
* Adds Shapefile import capability. Documentation for 
this added to manual.
* Corrected Help > About window.
* Fixes front page tab so that Data/Control is on front 
rather than diagnostics.
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VERSION WORKSTATION 0.1alpha
(Sep 2003)
* ERRONEOUS SYNOPTIC WEATHER VALUES, PARTICU-
LARLY IN BUOYS, WAS ELIMATED. The T/Td extraction 
routines, as well as pressure, pressure tendency, rainfall, 
and so forth were looking at the whole report rather than 
just Section 1 and as a result if a 10xxx, 11xxx, 20xxx, 
or 21xxx group was omitted in Section 1, it would be 
pulled out of other sections if a similar group existed, 
and thus a false T or Td was encoded. The routine was 
changed to only look at Section 1 and ignore other sec-
tions.
* NEXRAD RADAR SUPPORT has been added. Stations 
are selected in a selection panel, and are retained within 
the program permanently whenever a radar source is 
selected in Internet > Retrieve. Users can also manually 
select a radar file for import.
* OCEAN FILL PROBLEMS are now largely eliminated. 
This is because the mapping routines use polygons in-
stead of vectors now.
* A MULTIPLE DOCUMENT INTERFACE HAS BEEN RE-
INSTATED to allow multiple maps to be worked with 
simultaneously.
* NEW WEATHER TYPE FACES HAVE BEEN ADDED. This is 
reflected in your Windows Fonts folder.
* THE LAST DATA DIRECTORY USED DURING A 
FILE>IMPORT FILE ROUTINE IS REMEMBERED. This is 
handy for users who constantly access the same data 
directory all the time.
* SOME CHANGES TO MASTER STATION LIST (created 
Edition 51 and afterward).
* DOCUMENTATION CORRECTED to delete obsolete infor-
mation such as time zone settings, etc.
* METAR IMPORT ADDS ABILITY TO HANDLE “RECENT” 
PRECIPITATION/OBSCURATION TYPES. Now the module 
looks for REDZ, RERA, RESN, RERASN, REFZ, RESH, RE-
SHRA, RESHSN, REGR, REFG, and RETS.
* METAR IMPORT HANDLED Q9 BUT NOT Q0 QNH PRES-
SURES, E.G. Q0984, Q0993, ETC. This support has been 
added.
* METAR IMPORT GUSTS ABOVE 100 ARE NOW HAN-
DLED.
* METAR IMPORT OF P0000 PRECIPITATION WAS PLOT-
TED AS TRACE. Fixed to represent a zero amount.
* STILL ON THE DRAWING BOARD....
* · TRY TO ADD A WAY OF HANDLING WINDS WITH NO 
DIRECTION... A REMARK NEAR THE STATION PLOT?

VERSION 2K2 0.5beta
(Feb 2002)
* Uses significantly enhanced topography/terrain engine.
* Parses Australian AXF surface data, indicated by [syn-
opData] or [metar2Data] and ended by [$] and defined 
by formats in DIGATMOS.FMT.
* Changed program icon.
* Moved many user controls from toolbar to side panel.
* Parses Australian weather collective bulletin produced 
by Australian Bureau of Meteorology.
* Parses FM45-IV (analysis) and FM46-IV (forecast) fleet 
code (see http://www.fleetcode.com/fleetcodedefinition.
html for more info).
* Import routines drastically improved and streamlined, 
allowing full content of all METAR reports to be ingested 
(which in turn improves reliability of high/low/rainfall 
data from METARs).
* Plots earth shadows, depicting sunset/sunrise termina-
tor line and twilight terminator.
* Adds GRIB import routines

* User can right-click on the map and choose “Recenter 
Map” to move the view.
* Deletes Daytime Saving item in General Preferences; 
all time conversions are now totally transparent to the 
user; the user only needs to make sure their computer 
is set to the right time and time zone in the Windows 
Control Panel.
* Added wet bulb temperature
* Numerous other changes and tweaks (not yet docu-
mented)

VERSION 2000 - V1.0a maintenance
(4/16/01)
* Added “mixed” grid option in Preferences > Maps.
* Adds revised station tables.

VERSION 2000 - V1.0a
(1/20/01)
* Eliminates problem reported in V1.0 with left third of 
screen occasionally being blotted out at random.
* Analysis > Export Last Analysis has been removed and 
in its place the text output is always written to GRID.TXT.
* Added SLEEP command to Scripting (see Appendix / 
Scripting section).
* Corrected program so that a timer script will only 
execute ONCE per scheduled time interval. The previous 
version would keep re-executing the script as long as the 
current time was the scheduled execution time.
* Added rule file (DIGATMOS.RUL) with rules for import-
ing observations.
* Minor enhancements to tracking of metric vs. English 
units for purposes of product labelling
* Added COM4 to COM8 in EMWIN Ingest
* Allows up to 1000 stations in DIGATMOS.PRI priority 
table
* Adds Map > Import command to allow satellite photos, 
etc, to be “underlaid”
* Map > Generate By Lat/Lon now allows latitude, longi-
tude, and zoom to be numerically tweaked and advanced 
settings to be “reset” with one button click.
* Enhanced fills for Australia
* Script timer has been renamed to “Scheduler”.
* Scheduler now allows multiple script names along with 
the usual multiple execution times; documentation has 
been added in this manual under Appendix / Scripting.
* Digital Atmosphere now caches a map as soon as it is 
created so that it will be available on reloading Digital 
Atmosphere (this applies both in Generate by Lat/Long 
and Generate dropdown menu).
* Vorticity and divergence now color appropriately as in 
earlier versions (with inverted shades for negative diver-
gence). A solid zero-line has also been added.
* Divergence and vorticity have now been added to the 
Analysis > Wind menu for more convenient access.
* Divergence has been recalibrated and plots in 10**-6 
m-2
* A bug in the scripting which prevented wind analysis 
(grids and streamlines) from plotting is now fixed.

BETA 1/21/01 FIXES
* Problem with Map > Save in 1/20/01 release fixed
* Conflict with Alt- shortcut keys for main menu fixed
* Added script command SFCPLOTMODEL for loading 
surface plot models (see Appendix / Scripting)
* Script commands for convective outlooks and MVFR/IFR 
depiction (dy1, dy2, cig) added to documentation.
* Printing capabilities have been fully restored and diag-
nostic gridboxes on printouts are eliminated. Print button 
has been fixed.
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VERSION 2000 - V1.0
(12/3/00):
* Option added to File > Preferences > Analysis to al-
low transparent fonts
* Slight changes made to remove plotting of extra pixel 
line at bottom of NMC fonts
* Errors under Win 98 with File > Get Archived Data 
and EMWIN ZIS extraction fixed
* EMWIN ingest capabilities improved with regards to 
extraction of ZIS files (previous versions were error-
prone)
* Map > Generate by Station fixed
* Option for 1000-500 mb thickness added in File > 
Preferences > Contours
* MVFR/IFR contour labels were invisible with certain 
contour font combinations; this is fixed

VERSION 2000 beta 3
(12/2/00):

NEW FEATURES . . . . .
* Added EMWIN ingest engine (in EMWIN > Ingest)
* EMWIN upper air (upr*.*) added to File > Import 
EMWIN data
* Added command to clear out data directory (File > 
Clear data directory)
* Frontal workchart toolbox added (in Data > Frontal 
bulletins and right-click menu)
* 1000-500 mb thickness added (in Analysis > Temper-
ature > Thickness); upper air data is required
* Calculator now allows station pressure, wind chill, 
and heat index calculations entirely in metric
* Replaced .CXN, .CXP county name label file with edit-
able .CXT file
* Moved county name label for Ventura County (Cali-
fornia) westward slightly
* Added aspect ratio to Map > Generate Map
* Color palettes in Preferences > Colors are now saved 
and loaded with maps (with .ATP file)
* Added more information in help file
* Added Dutch weather station corrections in DIGAT-
MOS.STN
* Drop a file from Windows explorer onto a running 
copy of Digital Atmosphere to import that file
* When a convective outlook indicates “NO TSTMS” this 
is plotted on the map
* Print capability re-enabled (was disabled during beta 
tests)

ERROR FIXES
* Error: File not found error in File > Get Archive Data 
/ FIXED
* Error: Old links for UNCA in DIGATMOS.SLZ Internet 
retrieval table / FIXED
* Error: Altimeter setting H/L values round to nearest 
inch / FIXED
* Error: Map > Generate Map “offset settings may pro-
duce bad results / FIXED
* Error: If edge of Earth is seen in a generated map, 
ocean fills do not work correctly / FIXED
* Error: DRSN (drifting snow) in METAR not properly 
recognized by Dig Atm / FIXED
* Error: Help does not work for Map > Information but-
ton / FIXED
* Error: Map > Information produces some bad results 
/ FIXED
* Error: QC rubberband keeps appearing erratically / 
FIXED; NOW DISAPPEARS ON RELEASE OF MOUSE-

CLICK
* Error: When cancelling in Map > Generate map, cor-
rupt results occur / FIXED

VERSION 2000 beta 2
(11/25/00):
* Sea data now nullified in METAR reports so garbage 
doesn’t appear in station plots with sea elements
* Beta bug with Analysis > Wind > Wind Speed not 
working is fixed
* Celsius/English beta problems fixed (in plotting and 
climatology extract)
* Beta testers need to check their station plot elements 
and change TEMP/DWPT/VIS to match valid choices
* Elevation can now be plotted in meters or feet ac-
cording to English/metric preferences
* Climatology > Extract Data now gives option of plot-
ting the data or analyzing it
* Additional options in File > Preferences > Analysis to 
let users specify isopleth fonts as “small” and/or “nega-
tive”
* Added remaining font files as well as font preferences
* Fixed problem with streamline thicknesses changing 
“randomly”
* Added option in File > Preferences > Meteorological 
> “Geopotential height in full meters only”
* Geostrophic height contouring algorithms improved 
to eliminate irregularities along margins
* Added upper highs/lows
* Added tutorial directory with tutorial files
* Re-instated and improved serial/key routines

VERSION 2000 beta 1
(11/11/00):
* Added photorealistic topography
* Fixed zoom bar on map settings panel not working
* Added file drag and drop capability from Windows 
Explorer
* Fixed outer space fill
* Fixed “Quit Searching” in Climatology graph
* Added NCEP legacy fonts to isoplething routines for 
labelling of lines
* Added “Thick Contours” option in File > Preferences 
> Analysis (makes isopleths twice as wide)
* Added easter egg (Shift-Ctrl-F7)
* Changed FTP timeout from 1000 to 15 seconds, so a 
quicker response occurs if a connection is hung
* Vastly improved isentropic analysis (in “Level” drop-
down on toolbar)
* Added freeform horizontal analysis (in “Level” drop-
down on toolbar)
* Corrected and improved 3-D atmosphere build (in 
Analysis menu)
* Reinstated and improved roaming sounding
* Satellite wind observation import provided
* Slight bug in contouring fixed (prevented random 
charts from drawing any contour lines)
* Changed “Wind Speed” analysis so that it uses a 
gridded x/y wind field for better accuracy
* Documentation provided in dual formats: context-
sensitive Windows Help and PDF format.
* Numerous additions, edits, and improvements to help 
documentation.
* Added capability for user to modify Gradient Fills in 
analysis (in File > Preferences > Misc).
* Added capability to import and plot SATOB observa-
tions (NOAA/NESDIS format).
* Added scripting commands for ISOPLETH and GRADI-
ENT
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* Added extra surface station plot element which is avail-
able to user (in extreme lower left of plot)
* Added import of sea surface data from SYNOP reports
* Changes have been made to allow saving and loading 
of upper plot models
* Added capability to plot h and Nh code forms from 
SYNOP; corresponding additions in Preferences
* Changed temperature and precipitation units to a single 
“English or metric” choice
* Added streamlines
* Added capability to plot fronts, highs, and lows from 
ASUS1 KWBC bulletin

VERSION 2.3.3 (MAINTENANCE RELEASE) — BUILD 
#1015 
(10/1/99):
* Quality control was improved to change point/point 
clicking to mouse dragging. A distance meter enhanced 
this capability.

VERSION 2.3.2 (MAINTENANCE RELEASE) — BUILD 
#989
(9/23/99):
     The main purpose of this release was to get rid of a 
memory violation reported by six users (which consisted 
of various forms of “Invalid pointer” and “Access viola-
tion” errors when Digital Atmosphere was started). This 
was finally traced to coding errors in the creation of new 
maps. In addition to a fix for the problem, this release 
has some additional enhancements.
* “Invalid pointer” and “access violation” errors elimi-
nated.
* Status bar can be made visible or non-visible (View > 
Status Bar).
* The data directory is now *always* the “data” subdirec-
tory under Digital Atmosphere. Any data should always 
be placed in here unless it is being received by EMWIN or 
is a single file to be chosen manually by the user.
* In the synoptic decoder, dewpoints are now omitted if 
they exceed the temperature.
* File > Retrieve Data used to not process warning data, 
while File > Import EMWIN Directory, File > Import File, 
and the schedulers did. This has been fixed.
* The number of importable files during one pass has 
been increased from 100 to 150 files.
* METAR reports without times but times in FOS headers 
are now parsed properly.
* Font face/sizes in EMWIN Bulletins and View Raw Data 
can now be specified in Preferences > Fonts.
* A new feature, Map > Information, provides detailed 
information about the map projection currently shown.
* Another new feature, “Show distance”, allows users 
to determine the distance between two points on the 
map. Identify each of the two points by right-clicking and 
choosing “Set point”, then choose “Show distance”. The 
distance will be shown in nm, sm, and km.
* Under the View menu, the selections for Speed But-
tons, Time Toolbar, Wind Toolbar, and Status Bar are 
saved when the user exits the program, then restored 
when the program is started again.

VERSION 2.3.1 (MAINTENANCE RELEASE) — BUILD 
#930
(8/29/99):
* Fixed problem where 24-hr precipitation data in METAR 
reports wasn’t recognized.
* Readme file updated with new information.
* Error message during Emwin Scheduler when no warn-
ing files are found has been eliminated.

* Map tiles have been consolidated from 365 down to 25 
files, saving 10 MB of disk space when installed (fewer 
wasted blocks in the file allocation tables). Some users 
may see a slight slowdown when generating new maps. 
The new tiles are binary and cannot be edited. Users who 
need to add map information should use the more con-
venient Custom Overlay files (see the Data chapter under 
Overlay Custom Overlay).

VERSION 2.3 FINAL — BUILD #918
(8/20/99):
* Added two binary files required for program operation 
(DIGATMOS.GCI and OUTPUT.WRQ).
* Adjusted effects of “smart visibility plot” to only take 
effect when left-center slot contains visibility data, 
weather symbols, or a blank entry. This way other data 
(dewpoints, etc) residing in this slot does not get blanked 
out when no weather is present. The user may still have 
to adjust the contents of the far left slot for optimum ap-
pearance.
* File > Quality Control now allows editing of pressure 
tendency, pressure trend, precipitation amount and pe-
riod, cloud codes, and mb and ft levels.
* Inability of File > Preferences > Contours settings to 
save has been rectified; settings will always be saved 
whenever “Ok” is clicked.
* Fixed a problem with inability to do station plots of FD 
data; and inability to plot 24 hour FD contours/grids.
* Added code that prevents “stack overflow error” and 
execution of warning import when OUTPUT.WRQ is miss-
ing.
* Precipitation contours are now indicated in the legend, 
along with the units of measure (inches or mm).
* In Internet > Retrieve Data, an “Uncheck All” button 
has been added.

BUILD #907
(8/18/99):
* AIREP reports have been enabled. These are usually 
found in upper air files and can help fill in wind patterns 
across oceanic regions.
* “Round AIREP reports within xxx mb of a standard 
level” has been added. When checked, and the user 
produces a constant pressure map, Digital Atmosphere 
will include all AIREP reports that are within the specified 
number of millibars of the constant pressure level being 
used (i.e. an AIREP at 278 mb will be included in a 300 
mb plot/contour if the box is checked and the value is 22 
mb or greater). If unchecked, then all reports have to be 
exactly equal to the constant pressure level being used 
(i.e. an AIREP at 492 mb would not be included in a 500 
mb chart). This will help users control the quality and 
variety of data being included in upper air charts.
* “Data > View Sounding” and map popup menu item 
“Show Sounding” have been re-enabled.
* About 25 new EMWIN text products added to the 
DIGATMOS.EMP EMWIN product lookup list. This will add 
many new product descriptions to “EMWIN > Get EMWIN 
Bulletin”.
* Digital Atmosphere now recognizes “SN” intermedi-
ate synoptic header in addition to “SA” and “SM” when 
determining times for synoptic reports. (Thanks to Hans-
Stefan Lichius)
* Preferences > Meteorological option for “Round synop-
tic reports to nearest 6 hours when importing” has been 
corrected to “round to nearest 3 hours”. Rounding opera-
tions have always been to nearest 3 hours.
* Data > Warnings has been adjusted to import warning 
datasets correctly. EMWIN users who keep seeing out-
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dated warnings on their maps should change the purge 
intervals in their EMWIN reception software.
* The option “Default data time selection” in File > 
Preferences > General is now functional again.

BUILD #885
(8/16/99):
* If main window is maximized, the window is no lon-
ger resized when a new chart is loaded.
* Emwin Scheduler -- on receipt of new EMWIN data, 
the map did not erase; this has been fixed.
* MVFR/IFR contour analysis has been fixed.
* An “Access Violation” that popped up during import 
of some RCM (NEXRAD) datasets was fixed by adding 
code to quality-check incoming data. (Thanks in part to 
Wayne Cotterly
* Some problems with precipitation contouring in 
synoptic reports was fixed; additional code was written 
so that Digital Atmosphere could differentiate miss-
ing reports from zero and zero from nonzero amounts. 
(Thanks to Hans-Stefan Lichius)
* In an effort to consolidate internal data processing, 
upper air split files (OUTPUT.H00, H85, F18, etc) are no 
longer used. This will solve QC problems where RAOB 
reports can’t be deleted. Users with slow computers 
will notice delays when plotting rawinsonde reports 
(due to the large size of the upper air output file). 
Since the code has been rewritten slightly there is a 
slight chance this fix could introduce errors, so testers 
should note any plots or contours that “don’t seem to 
do anything”. (Thanks to Phil Rider)
* Rawinsonde data elements with solidii encoded 
anywhere in the element (rather than just the first 
position) are thrown out. For example, Katmandu was 
encoding heights like “5085/”, corrupting upper air con-
tours.
* Scalars (temperature, wind speed, etc) could not be 
contoured with FD data due to an unwanted line of test 
code. This has been removed. (Thanks to Phil Rider)
* Various buoys, such as those in the Arctic ocean, 
omit the wind (0ddff) group, confusing Digital Atmo-
sphere and making it plot erroneous winds and sky 
condition. This has been fixed.
* EMWIN imagewrites were saving to the DA direc-
tory, not the directory specified in Preferences. Fixed. 
(Thanks to Jesse Ferrell)
* Scheduled internet retrieval was not making its panel 
appear during retrieval; this has been fixed. (Thanks to 
Wayne Cotterly)
* Derived fields (vorticity and convergence) are now 
functional.
* Radar status annotations now work with RCM data. 
(Thanks to Jesse Ferrell)
* TVS signature will always be plotted in red. (Thanks 
to Jesse Ferrell)
* A “Preferences” speed button has been added. 
(Thanks to George Sobala)
* On the wind toolbar, wind vectors (as opposed to just 
barbs) now work again. (Thanks to George Sobala)
* When any map is loaded, all settings (not just lat/
long/zoom) are transferred to the Generate Map panel 
in case the user wants to tweak the map. Also fixed 
the inverted transferred latitude. (Thanks to George 
Phillips)
* Menu item “View > Remove last product” has been 
added so that you can delete the last contour or plot.
* I could not duplicate the “Invalid filename” on “save 
station plot” in Preferences. For users that continue to 
have problems, please go to the Preferences > Misc tab 

and check “Diagnostic -- Show filename when loading/
saving station plots”. Then when you save or load the 
station plot, report the message that it shows.
* SPECIAL NOTES: Users may mistake station plot mi-
nus signs as decimal points, particularly with pressure 
tendency.

 
BUILD # 864
(8/08/99):
* Added a “Generate Map” dropdown box on the Speed 
Button toolbar. Clicking on any of these entries causes 
a map for the area to be generated, using the de-
fault map width/height specified in File/Preferences/
Map. The entries for the “Generate Map” dropdown 
box come from a new file called DIGATMOS.MSE. Us-
ers may freely modify this file. Column 1-3 is for the 
latitude (south hemisphere negative). Column 5-8 is 
for the longitude (west hemisphere negative). Column 
10-14 is for the zoom width in miles. Column 15-65 is 
for the descriptive name. Users may add saved maps 
to this list by simply leaving the first 3 columns blank, 
then for a descriptive name use an asterisk followed 
by the filename (without any dot or extensions), for 
example, *mymap .
* Added a Preferences entry under the Map tab for 
Default Width and Default Height. This specifies default 
image size settings for new maps that will be gener-
ated.
* Reworked the Preferences/Station Plot/”Save” seg-
ment, as some users have reported that the plot model 
is incorrectly saved. Could not duplicate this problem 
but made adjustments to code.
* Eliminated problems with importing FD and Model 
data (this was a consequence of improvements made 
to the data import algorithms in Build #849.
* Build number now shown on splash screen.
* PROBLEMS REMAINING: Internet links except for 
Retrieve Data are dead; locks up using data retrieval 
window with FSU SAO ticked.
* SUMMARY: New files required to run this build: DI-
GATMOS.MSE

BUILD # 849
(8/6/99):
* Synoptic and buoy recognition module reworked. You 
should see a greater number of synoptic observations, 
and especially buoy (ZZYY) observations that now 
work. Please let me know if you see any problems.
* Eliminated “Access Violation” during View Raw Data/
Find. Corrected code to link in a missing component. 
(Thanks to John Glaveskas, Trevor Cousens, Geert 
Vandebrande)
* Legend was not cleared when generating a new 
chart; this has been fixed. (Thanks to Geert Vandeb-
rande)
* Eliminated problems with Digital Atmosphere resolv-
ing FD data times. Corrected code to properly evaluate 
FD forecast hours. (Thanks to John Souza)
* Quality control has been fixed. Some stations 
would not get QC’d, and this was due to a problem in 
the mouse coordinate variables and has been fixed. 
(Thanks to Michael Welch and Trevor Cousens)
* Relative humidity in station plots produced an invalid 
floating point operation; this was fixed. (Thanks to 
Michael Welch)
* Television plot city font size was not set correctly; 
this has been fixed but not verified. (Thanks to Jesse 
Ferrell)
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* The location to set Television font colors was not 
obvious. A note has been placed in “Preferences” under 
“Fonts” and in the User Manual to indicate where this is 
done. (Thanks to Robert Dale)
* Television plots are now centered horizontally. Also 
a bug where observation times were being ignored in 
television plots, leading to blank maps, has been fixed. 
(Thanks to Robert Dale)
* Removed “Status window on top” menu item, which is 
obsolete. (Thanks to Robert Dale).
* An error was found in the synoptic cloud code import; 
this was fixed. (Thanks to Michael Welch)
* Stations without sky condition report plotted without a 
center symbol; a plus is now plotted at the observation 
location. The newest (8/05/99 or later) version of DIGAT-
MOS.SYI is required.
* Topography now works. (Thanks to Hendricus Lulofs 
and Trevor Cousens)
* At the end of a File/RecompileTables operation it seems 
that Windows locks up. This is because Digital Atmo-
sphere is sorting the Warnings table. A progress message 
has been added, and the status window no longer trun-
cates long progress messages. The ICAO/WMO sorting 
algorithm has also been speeded up. (Thanks to John 
Glaveskas)
* Large maps were not framed correctly when loading 
such as at startup. This has been fixed by forcing the 
image object width to equal the bitmap width. (Thanks to 
Hendricus Lulofs and Geert Vandebrande)
* Internet retrieval list (DIGATMOS.SLZ) enhancements: 
Added UCAR upper air (thanks to Robert Schmidt), added 
Albany buoy.
* Digital Atmosphere now parses the RCM file when the 
EMWIN Scheduler is running. (Thanks to Robert Dale)
* User must specify the EMWIN directory for warnings; 
this allows compatibility with software such as RealEM-
WIN. This option is in File/Preferences/General. (Thanks 
to Robert Dale)
* Speed button toolbar can now be hidden or unhidden 
(see View menu item). (Thanks to Robert Schmidt).
* All fonts used in contouring operations are now set in 
Preferences, Fonts under “Annotations”. Only the font 
type is used; the size is ignored. (Thanks to Robert 
Schmidt)
* Internet sites which don’t report the filesize in some 
headers (such as IWIN and FSU) no longer produce 
unusual progress results during download; program now 
reports “unknown”. (Thanks to Verna Young and Mark 
Hayes)
* Digital Atmosphere no longer tries to resize itself after 
generating a new map when maximized. (Thanks to 
Robert Dale)

* VARIOUS ISSUES STILL TO BE RESOLVED: “Bitmap 
image not valid” will still appear when viewing EMWIN 
products -- this is because the functionality has been 
temporarily disabled; geostrophic wind field feathers not 
available; SKEW-T, CAPE and other extended analysis 
stuff has not been restored yet; will not import a V2.2 
map; Data/Warning causes “Illegal function” error; hid-
den toolbars reappear at startup (this is not a bug but 
an item suggested and will be evaluated); unusually high 
heights (above 580 dam) such as with what we are see-
ing this summer are inverted to 480+ dam.

* OTHER NOTES. I am on the lookout for errors where 
a data directory, data product, or error message shows 
a path with two solidii, for example, c:\program_files\
digatm\data\\ or c:\digatm\data\\infile.txt. This has 

cropped up a couple of times but I haven’t found the 
source of it. It will cause non-found datafile errors and so 
forth.

CHANGES FOR V2.2 to V2.3 BETA INITIAL
(JUNE 1999)
* Multiple chart forms eliminated. This was performed to 
simplify numerous algorithms within Digital Atmosphere, 
reduce the complexity of our source code, and enable 
further development of other key areas of the program. 
The vast majority of users indicated that they preferred 
one map at a time.
* Status panel deleted and toolbars added. It was de-
cided that the status panel, which has always been a part 
of Digital Atmosphere, was too awkward, cluttered, and 
frequently got in the way. It has been replaced by two 
toolbars: a time toolbar and a wind toolbar. They can be 
hidden or displayed in the “View” dropdown menu.
* Tab ordering improved. The tabbing order of controls 
in the map customization screens were improved so that 
navigation without the mouse would be much easier.
* Automated version numbering. This is mostly an inter-
nal change that isn’t of interest to most users. Version 
and build numbers listed on the Splash Screen and About 
Screen are now extracted directly from the application 
file. This is the same data seen when you choose “Prop-
erties” and “Version” from Windows Explorer.
* A new registration authentication scheme has been 
enabled. To register your copy, you will need to go to 
Help, Register to find out their individual serial number, 
then contact us for a key number. Note that this keying 
scheme is subject to change.
* RCM NEXRAD radar parsing has been vastly improved. 
The algorithms were edited, tested, and tweaked to give 
a high level of competency in parsing NEXRAD RCM data. 
Furthermore the algorithms extract cell, mesocyclone, 
TVS, hail, and wind data from the datasets. RCM data is 
not available at most weather data servers, but it can be 
found in the SAORCMUS.TXT file regularly transmitted by 
EMWIN (this is also available at http://emwin.cira.colo-
state.edu/rxfiles/SAORCMUS.TXT, which has been placed 
in the new Internet data retrieval panel).
* New NEXRAD site codes added to the station tables. 
About 40 new RCM station codes have been added. This 
fills in many radar gaps that existed in earlier Digital 
Atmosphere versions.
* NEXRAD VAD/VWP wind parsing has been added. Sim-
ply import an RCM file and plot using “Analysis” for time 
and a valid FL for level. These reports can then be plotted 
or analyzed. Although this is an incredible tool for filling 
in gaps between rawinsonde stations and rawinsonde 
times, NEXRAD winds are usually missing where there 
are no droplets, dust, insects, or birds to yield a velocity 
measurement (such as high aloft or in dry regions).
* The level selector can contain FD winds, RCM winds, or 
both. This is chosen with the “R”, “F”, and “All” buttons 
next to the level selector. Use it when, for example, you 
want to look at NEXRAD VAD/VWP winds aloft and don’t 
want to accidentally click on an FD wind level. You would 
simply hit the “R” button to pare down the list.
* Major improvements in the Internet data retrieval 
panel. The panel now uses true HTTP binary transfer to 
connect with weather data sites, delivering much swifter, 
more reliable data downloads than in previous Digital 
Atmosphere versions. It also allows FTP sites to be ac-
cessed. For those few users who need to specify a port 
number and/or user ID & password, you must append 
the User ID, Password, and Port to the end, all separated 
with “$$”. Example: ftp://ftp.mysite.com/pub/data.txt$
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$myusername$$mypassword$$port ). If you decide to 
specify a port number, you must specify a username 
and ID.
* New formats added to “Export map”. In earlier ver-
sions you could save your map as a BMP or a JPG. In 
addition to those, you can now save PCX, PNG, and TIF 
(uncompressed and packbits) formats. The packbits 
TIF format generally offers the best format for desktop 
publishing purposes. The GIF and LZW TIF formats 
were not included because they are proprietary tech-
nologies and require licensing from Unisys.
* Map can be copied to the clipboard. This can be 
found in the menu under “Map” and “Copy to Clip-
board”. When the map is in the clipboard it can be 
pasted into other Windows applications.
* Fonts in Preferences improved. The interface has 
been changed slightly, and we have added the ability 
to let you set “annotations” fonts, which are seen when 
you plot custom map points and city overlays, and 
county name fonts.
* County name overlays added. You can now add coun-
ty names on your map. The county name text will be 
truncated automatically according to the map scale (to 
see more of each county name, make a more-zoomed 
in map). The font color is controlled by the “county 
overlay” setting in Preferences/Map and the font name/
size is controlled by the “county name” setting in Pref-
erences/Fonts.
* Custom geography added. This is done in the Weath-
erGraphix style, with custom geography residing in 
DIGATMOS.PLR. Edit this file to make changes. Note 
that longitude in the west hemisphere is negative; 
files imported from WeatherGraphix will need to have 
the longitude signs inverted. The color of the line is 
controlled by the “roads and custom lines” setting in 
Preferences/Map.
* Contour labelling algorithm improved. Previous ver-
sions of Digital Atmosphere plotted isopleth labels only 
at the chart edges, making closed contours difficult 
to interpret. Digital Atmosphere will now plot labels in 
many closed contour patterns.
* Data tables now produced. These are stored in OUT-
PUT.SFC (surface) and OUTPUT.UPR (upper) every time 
you import data. These tables can be parsed using your 
own applications or can be brought into spreadsheets 
and databases.
* Precipitation data now available. Data from the 
synoptic 6xxxx group is now imported into Digital 
Atmosphere and can be plotted or contoured. Note that 
most U.S. and Canada stations report 6-hour precipita-
tion.
* Precipitation inches/millimeters choice added in 
Preferences/Meteorological. This applies to precipitation 
plots and contours.
* Pressure tendency, and low, middle, and high cloud 
symbols have been added. These can be plotted if 
they are part of the surface plot in Preferences/Sta-
tion Plots. The pressure tendency can be analyzed and 
contoured.
* Maps can be automatically exported when the pro-
gram is in automatic mode. You simply specify the tar-
get file in Preferences/General under Autosave (a com-
plete directory and filename is required), and check 
the Autosave box. The graphics type is determined by 
the extension of your filename (BMP, JPG, PNG, PCX, 
or TIF). Every time the map is refreshed automatically, 
the completed map will be exported to your target file.
* Previous versions of Digital Atmosphere had trouble 
identifying some warnings. This occurred when warn-

ing bulletins did not end with the “NNNN” termination 
sequence (this recently began appearing on EMWIN); 
therefore warnings piled up in the first warning text 
slot. This has been fixed; a new header now can sub-
stitute for an “NNNN” termination sequence.

CHANGES FOR V2.1C BETA to V2.2
(FEBRUARY 1999)
* Preferences buttons for the FOUS level have been 
added. This is located in Preferences, Meteorological. 
This allows a level aloft (such as the T3 and T5, and 
R2 and R3 levels) to be plotted or analyzed. Note that 
since the T3/R2 and T5/R3 levels aren’t exactly the 
same, you should avoid calculations which cause the 
temperature and relative humidity to be combined (for 
example, dewpoint analyses).
* Preferences buttons for the default time select have 
been added. It is located in Preferences, General. Us-
ing these buttons you can pick something else besides 
“Automatic” time select to appear on the status panel 
when Digital Atmosphere is started.
* Cursor lat/long can be determined by right-clicking 
the map. Using the pop-up menu simply choose “Cur-
sor location” and an information box will appear.
* Nondiscrimination between ETA and NGM data during 
contour operations has been fixed. Earlier versions did 
not discriminate between ETA and NGM data (according 
to the status panel) during contour operations.
* Appropriate labelling is now applied to charts when a 
contour of model data is done.
* The registration information box contained within the 
program for new users has been updated to reflect a 
new E-mail address and minor changes in sales poli-
cies.
* Default color preferences have been fine-tuned to get 
rid of contour line colors that match the background.

CHANGES FOR V2.1A BETA to V2.1B BETA
(FEBRUARY 1999)
* The lat/long grid interval can now be controlled. This 
is done in “Preferences”, “Maps”.
* A range check error that occurs during analysis of 
rawinsonde data has been fixed.
* The File, Print option has been fixed. The diagnostics 
window in the beta version has been disabled. The “in-
verse print” option had to be deleted due to an inability 
to make it work successfully without considerable pro-
gramming. Many PostScript drivers allow you to force 
the printer to make negative printouts.
* Wind feathers are reversed in the South Hemisphere 
to meet standard convention. One note, however -- in 
the Analyze, Wind Grid section, the routines have to 
make the feathers a uniform style, so the center posi-
tion of the background map is what determines the 
style rather than each gridpoint location.
* The status panel now uses “Automatic” for default 
time selection. It’s assumed that most people will only 
want to use “Show Contents First” in special cases.
* A Data Check interval has been added in Preferences 
in the General tab. In earlier versions, Digital Atmo-
sphere checked for new data every 20 seconds. This is 
now user-specifiable.
* During find operations in “View Raw Data”, the cursor 
is now an hourglass.
* New station tables are now packaged with the up-
grade. This consists of DIGATMOS.RIX, DIGATMOS.STI, 
DIGATMOS.STW, DIGATMOS.SXI, and DIGATMOS.SXW. 
This fixes some persistent “range check” errors with 
surface data that were present in the beta version.
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* The Internet alphanumeric product retrival list (DIGAT-
MOS.SLZ) has been updated slightly.
* Soundings have been reinstated. The sounding window 
contains a box where you can enter the desired station 
and easily view consecutive stations.
* Background maps now plot after a gradient analysis.
* You can now overlay the base map without erasing the 
graphics, thanks to the new Map command “Add base-
map”.
* The status bar at the bottom of the screen has been 
restructured. It now holds a progress bar detailing all on-
going operations, the task progress, and the ingest mode 
currently in use. Additional status notifications have been 
added throughout the analysis module and other pro-
cesses.

CHANGES FOR V2.1B BETA to V2.1C BETA
(FEBRUARY 1999)
* Isentropic analysis has been reinstated. The isentropic 
level can be selected from the Status Panel under “active 
level”. You will be prompted for a level in whole Kelvin 
degrees. While this level is active, all analysis operations 
will pertain to parameters on that particular isentropic 
surface. The two most useful parameters under Analysis 
are “isentropic height” and “wind grid”.
* Isentropic height has been added as an Analysis op-
tion. This analyzes the height of datapoints in mb at the 
Active Level. Therefore its only suggested use is when an 
isentropic level has been entered into the Status Panel. 
Its color scheme currently follows the 500 mb contour 
scheme.
* A Composed CAPE option has been added in Analysis. 
This “builds” a 3-dimensional representation of the at-
mosphere based on existing observations and calculates 
CAPE at each gridpoint, rather than calculating CAPE at 
each station.
* CAPE, LCL, and 0-6 km mean wind are now functional 
and can be accessed under the Analysis menu.
* A bug has been fixed where the toolbar Print button 
had no effect.
* A bug has been fixed where analysis gradient fills with 
no isopleths produced no background map.

CHANGES FOR V2.1 to V2.1A BETA
(JANUARY 1999)
* Documentation is now contained entirely in an Adobe 
Acrobat document. The manual was extensively rewritten 
and updated.
* Lat/long grid usage is now controlled by the Prefer-
ences, Color checkbox. The “none” radio button under 
lat/long grid has been removed.
* New time tokens for Internet data products have been 
introduced. They allow you to specify the latest synoptic 
or intermediate synoptic time. You can also specify the 
previous hour as a base token.
* You can easily override the time settings used in Inter-
net time tokens to gain access to data files for different 
hours. The variables that will be used are now shown in 
the Internet Data Retrieval window.
* Contour color and attribute settings are now in Pref-
erences — “Contour”, for easy access. Advanced users 
only — if you delete DIGATMOS.CGZ, Digital Atmosphere 
will automatically make a new one when you open the 
Preferences window by importing your older DIGATMOS.
CCL settings file. This is how you can preserve your color 
schemes when you upgrade.
* You can pick a range of hours to analyze or plot, rather 
than just a specific one, when manually selecting an ob-
servation time. This is great for data-sparse areas.

* View EMWIN bulletins using a nested tree structure 
similar to File Explorer, rather than the older series of 
dropdown menus. These bulletins also show the plain-
English description of each region, as well as a more 
complete description of each product, so you can easily 
see what product you’ll be getting.
* Extensive changes have been made in the station 
tables, DIGATMOS.STN. Three-letter ISO-3166 coun-
try code identifiers are now being used, and the time 
zone entries have been reformatted and filled to support 
upcoming capabilities. Absolutely no attempt should be 
made to import station tables using the old format with-
out converting them to the new format. Various stations 
have also been added worldwide.
* There are no longer overflow problems with the View 
Raw Data window. Imported data greater than 64K in 
size used to generate a “text exceeds memo capacity” er-
ror when the user viewed it through File, View Raw Data. 
The viewer has been replaced with a new 32-bit compo-
nent which does away with the error.
* Sporadic range check errors during data imports have 
been eliminated. The error was caused when erratic WMO 
numbers in synoptic data were looked up in a station 
table.
* An import is automatically done after retrieving Inter-
net data. This eliminates an extra step that the user had 
to do in the past.
* It is now impossible for a station plot to appear at the 
intersection of the equator and the prime meridian. Oc-
casionally when a report can’t be processed correctly, 
Digital Atmosphere is forced to assume it has a latitude 
and longitude of zero.
* You can now adjust the lowest possible METAR pres-
sure, under the Preferences, Meteorological tab, to 
change how the hundreds place of a coded METAR sea 
level pressure is determined. This is useful when contour-
ing very low or very high pressure.
* Model output thicknesses between 4800 m and 4999 
m are now handled correctly. Since they are coded as 
hundreds and tens, earlier Digital Atmosphere versions 
simply assumed the thousands place was “5”.
* You can now specify to create a map centered on a 
particular station. This is similar to how maps are created 
in WeatherGraphix. Maps can still be generated using lat 
and long.
 
Documentation on older versions not available in this ver-
sion history.
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